Site Modeler Class –InRoads V8i
Platform Generation
1) Call out the product by selecting Start> All Programs > Bentley> InRoads Group V8i (SELECT Series1) – Remember you can also generate a shortcut in your computer by right clicking over this icon and placing it on the desktop. At any point, if the software prompts to register the product, deny the request to bypass registration. 
2) At the MicroStation manager, select the file Base.dgn (under C:\Training Site Modeler\)
3) From InRoads, select File > Open and under files of type, select Surfaces (*.dtm). Select Original Ground.dtm, and click on Open. Do not close the dialog box. 
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4) Change the file, under Files of Type, at the bottom of the dialog box, to Preferences (*.xin). Select the civil.xin file located at the same directory. Once it has been opened, select Cancel. 
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5) From the InRoads Explorer, do a right click over the active partition (Bottom tab from the InRoads menú) and select Site Modeler:
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6) Do a right click over the main title, Site Modeler, and select New:
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7) At the Site Modeler Tab, under Type, Site Project, type in: Total Project. Select Apply without closing the dialog box:
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8) Change the Type to Site and under Name, type in Platforms, select Apply and do not close the dialog box:
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9) Change the Type to Surface, and under Name, type in Original Ground and under Surface Type, select Existing Ground .  As far as the remaining options, turn off the option Add to Active Site, turn on the option From Surface: Original Ground and turn on the option: Use as Base Surface for Active Site:
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Select the Apply button and close the dialog box by selecting Close at the bottom of the dialog box.
MicroStation will now temporarily show  the Original Ground contours and its display, according to standards will show as follows:
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10) In order to change both the contour symbology and its interval, from InRoads, select Site Modeler > Tools > Options, select the Surfaces directory from the left side and under the General Option, you will see a list of all available surfaces: 
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Select the Existing Ground Surface and the Details option at the bottom of the dialog box:
Make the following changes: Change the Boundary Color to White, Major Contours to Cyan , and Major Contours to yellow. At the bottom of the dialog box, change the Major Countour Elevation interval to 1.00 and for Minor Contours, change the Elevation Interval to 0.5.
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Select Apply at the bottom of the dialog box, and select Yes when the prompt message appears:
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The design will be modified after the changes have been accepted. Select OK at the bottom of the dialog box to close it. 
11) At the top left corner of the Site Project Options dialog box, select  File> Save As and save the new configuration as civil.spf:
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Select Save and cancel to close the dialog box
12) On the Site Project Options dialog box, under type, Select Platforms. Then type P for the Prefix Name and select Breaklines for Style. Select Add and Apply at the bottom part of the dialog box.
Select the new added family of surfaces, Platforms and select the Details button. In the Visualization root, change the Boundary color to White, Major Contours for cyan and Minor Contours to yellow.  Type 1 for the elevation interval and 0.5 for the Minor Interval: 
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For the Slopes tree, select Cut – Fill Slope under Side Slopes, and select Rounded for the Corners, Type Radial and for the slopes, type in 30% for both Cut and Fill:
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Select Apply and OK. Save the configuration by selecting File > Save As at the top left corner. Select Close to dismiss the dialog box: 
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The new Surface family, Platforms, is added to the list of available surfaces.
13) Zoom in the contours and try to delete them using the MicroStation Delete command. Contours, for now, are not part of the design file. They are only temporary for which they can not be deleted from the design file. 
14) At the bottom left corner of the surface, you can see a previously created rectangle. The rectangle is a MicroStation element which elevations were NOT relevant at the time it was created:
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Zoom in to the rectangle:
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15) At the Power Civil Explorer, under the Site Modeler partition, and in order to expand the Project, select the plus sign next to the Site Modeler Project (Under the Total Project, select the plus sign to open up the Project as follows):
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16) Under Platforms, right click and select New:
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17) At the Site Modeler Tab, under Type, verify that the Type is set to Surface, Select Platforms. Notice that P1 is automatically typed under Name. Turn OFF the From Surface and Use as Base Surface for Active Site Options. Turn on the option Add to Active Site. Select Apply and close to dismiss the dialog box:
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18) The platform, on explorer, will now be active (red box on P1):
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The drawing, however, has changed to the following:
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In order for the site to remain as the same configuration as the Existing ground, the configuration for the Site should match.
19) From the InRoads menu, select Site Modeler > Site> Edit:
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20) On the Edit Site dialog box, change the Boundary Colors to White, Major contours to Cyan and Minor Contours to yellow. Modify the Major Contour interval to 1.00 and type 0.5 for the Minor Contour elevation Interval. Select Apply and close the dialog box.
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The new model will now have the new configuration:
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21) Zoom in again to the platform: 
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22) From the InRoads menu, select Site Modeler> Element> New. Verify that the Add Option is turned ON and that P1 is the current selected Surface. Select the crosshair button on Element ID and then click the rectangle. InRoads will automatically assign a unique identification number. The Style should  be Breakline, the Feature Type should be brakline and under Method, select Constant Elevation. For the elevation, type in 300.00. 
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23) Click Apply and closet he Dialog box. The platform is now at an elevation of 300.00 and is automatically added to the project: 
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24) To visualize the vertices of the element, the surface must be edited. From the InRoads menu, select Site Modeler > Surface > Edit.  Select the Display folder and turn on Vertices. Double click on Vertices and select Tahoma for the font. Click OK.
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Select Apply and Close. 
The platform will have the vertices displayed.
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Modifying the Platform Geometry
1) From MicroStation, select the Insert Vertex command:
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Insert a vertex to the outside as shown:
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The model is automatically updated.

Using the MicroStation Delete Vertex command, delete de vertice. The model is automatically updated:
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2) From the InRoads Explorer, right click on P1 and select Center Window:
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The platform is automatically centered in the window.
3) Now, insert a vertex to the inside, as shown:
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Apparently, contours do not follow the platform limits:
To correct the contours, element properties must be changed.
4) From the InRoads menu, select Site Modeler > Element > New/ Edit, TURN OFF the Add option (now the command is under the Edit mode). Select the MicroStation element that defines the platform using the crosshair button and change the Feature Type to Boundary. Select Apply and close the dialog box. 
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The model is now updated as expected:
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5) Delete the added vertex to return to the original configuration. REPEAT THE LAST STEP, making sure that the Feature Type is set back to Breakline. THIS IS EXTREMELY IMPORTANT for the benching (in future steps), are correctly modeled.
6) With the MicroStation move command, select the platform element and move it to the right: 
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7) To return to the original configuration, select the MicroStation Undo command. The model is not synchronized:
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8) To resolve this and syncronize all graphics, InRoads must recognize MicroStation’s undo command by selecting Site Modeler > Tools> Syncronize with Graphics:
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Upon receiving the following message:
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Select Yes and select OK again on the last message (The model is now syncronized):
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9) To raise and lower the platform by a specific delta, from InRoads, select Site Modeler> Element> Raise/Lower.  With the crosshair button, select the element and type in 5.00 (additional positive delta in elevation). Click Apply and Close.
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The element is now 5.00 higher than its original elevation:
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A negative number will make the platform lower in delta elevation.
10) In order to balance the platform with respect to original ground based on a percentage of cut and fill, from InRoads, select Site Modeler> Surface> Raise/Lower by Volume.
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From the dialog box, select P1 for the Surface Name, and under Realtive From, seleccionar Original Ground. Type in 0.5 for Cut and then select Apply:
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The new balanced elevation for this percentage of Cut/Fill are calculated and the model is automatically syncronized: 
[image: image48.png]



Verify the cut and fill volumes. Since 0.5 was typed for Cut, the other 50% is considered fill. Volumes will almost be identical to balance the element with respect to Original Ground. Select Close. 
11) In order to manualy modify the vertex elevations, select from the InRoads menu, Site Modeler> Element > Information
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Here, select the platform element using the crosshair button:
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Select the Vertices Option as well as the first line on the right side:
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Type in 300.00 for Z on the lower part of the dialog box and then, select the Modify Z button on the top right part of the dialog box. When receiving the following message: 
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Accept with the OK button. The first and last vertice are modified to a 300.00 elevation. 
Select the following line on the vertices list and type in 305.00
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Continue modifying the vertices as follows. DO NOT FORGET that before selecting the following line, the Modify Z button has to be selected:
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Click Apply and accept the message.
The model is now modified as follows: 
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Close the dialog box. 
The model, after rotating the view in MicroStation is automatically updated and merged in the Project:
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The platform, up to this point has constant sideslopes of 30% for both cut and fill. 
12) In order to modify the slopes, select from the InRoads menu, Site Modeler> Surface> Edit
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Verify that the Surface name is P1. Select the Slopes folder from the left side and then select the General Option. Change the sideslopes for both cut and fill to 45%. Click Apply and both the Project and the drawing automatically update. Do not close the dialog box.
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13) In order to make the slopes vary depending on the cut and fill height, under General, change the Side Slope Method to Cut- Fill Table: 
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Type in 1.00 for Cut on the H:1V box for a height of 1000.00. Select the Add button. For fill, type in 5.00 in the H:1V box for a height of 1000.00. Select the Add button. Finally, select Apply and the design is automatically updated: 
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Close the dialog box.
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14) In order to do benching for the platform sideslopes, select, from the InRoads menu, Site Modeler>Element> Side Slope
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On the Side Slope dialog box, select the Element branch, veriy that Add to Active Surface Option is turne don and type in 45% for the Slope. Under feature, select Boundary. Turn on theClose Elements and Use Association options:
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Select the Target Options branch and select the Method To Surface. Select the Original Ground Surface.
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Select the Limit/ Benching branch on the left side and turn on the Option Use Limit on the right side. Type 4.00 for the Horizontal Value and turn on the Use Bench option. Type 5.00 for the Width and 0.00% for the Slope: 
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Go back to the Element branch, select the Single Select button at the bottom left corner of the dialog box:
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InRoads will now ask to Identify the Element, select the MicroStation Platform element and accept, now place a data point outside of the platform (you will see a dynamic message “Direction of Slope Element”). Accept the data point outside of the platform.
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Select Apply at the bottom left corner of the dialog box and Close it.
The element has now all the benching: 
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As the platform has now more elements in the surface and its properties have the visualize vertices option turned on, these properties must now be turned off to visualize the elements with no elevation text in them. 
15) From the InRoads menu, select Site Modeler> Surface > Edit
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Select the Diplay folder on the left side, and its General branch. Turn off the Vertices box. Select Apply and close the box:
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The model is now text free at its vertices: 
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Alternative Methods to define elevations
Drape –Minimum Elevation
1) In the drawing file, you will see another platform drawn to the right of the current modeled platform:
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2) From the InRoads Explorer menu, right click on top of Platform, P1 and select New:
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3) Verify that the Type is set to Surface and type P2. Only the Add to Active Surface option must be turned on:
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Select Apply and closet he dialog box.
Platform P2 will now be active:
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4) From the InRoads menu, select  Site Modeler> Element > New
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5) Using MicroStation, zoom in to the new block representing the platform:
[image: image79.png]



6) In the New/Edit dialog box, verify that the Add Option is turne don and that the active Surface is set to P2. Use the crosshair to the right side of the Element ID field and select the platform MicroStation block. The identifying number is automatically filled in the box. For the Method, select Drape and under Drape Options, select Minimum Elevation. At the bottom part of the dialog box, under Drape, select Original Ground and turn on both options to the right of the dialob box (Redefine Element and Use Reference Association). Apply and Close the dialog  box:  
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The model is automatically updated:
[image: image81.png]



In order to visualize the vertices, edit P2 and turn on Vertices: 

[image: image82.png]



The software computes the mínimum elevation of the platform and assigns it to the rest of the vertices.
Drape – Maximum Elevation
1) Instead of generating an additional platform, the just created platform will be edited to change its elevation to the Maximum Elevation method.
Frm the InRoads menu, select Site Modeler> Element > New/Edit
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TURN OFF the Add Option, use the crosshair next to the Element ID field to select the MicroStation element, select the P2 Platform and for Drape Options, change the method to Maximum Elevation. Do not modify the rest of the values.
Click Apply and close the dialog box: [image: image84.png]o= New/Edit Element
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The design and elevations are modified so that the maximum elevation is found along the geometry of the platform and then assigned to all of its vertices:
[image: image85.png]




Drape - Centroid
1) From the InRoads menu, select Site Modeler> Element > Edit
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TURN OFF the Add Option, use the crosshair next to the Element ID field to select the MicroStation element, select the P2 Platform and for Drape Options, change the method to Centroid. Do not modify the rest of the values.

Click Apply and close the dialog box: [image: image87.png]IE:
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The design and elevations are modified so that the centroid elevation is found along the geometry of the platform and then assigned to all of its vertices:

[image: image88.png]




Drape – Complete Element
1) From the InRoads menu, select Site Modeler> Element > Edit
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TURN OFF the Add Option, use the crosshair next to the Element ID field to select the MicroStation element, select the P2 Platform and for Drape Options, change the method to Entire Element. Do not modify the rest of the values.

Click Apply and close the dialog box:
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In the design, the element is modified so that its elevations are read exactly at its geometry following the Original Ground.
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Modify the element once again so that its vertices are computed using the Maximum Elevation method:
[image: image92.png]



 Slope/Offset Method 
1) Another MicroStation Element representing a new platform has been drawn to the right of P2 in the design file:
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2) From the InRoads explorer, right click on top of the Platforms and select New: 
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3) Verify that the Type is set to Surface and key in P3.  Only the Add to Active Surface must be turned on. 
[image: image95.png]Suface | Geomety | Site Modsler

Tope: Suface v

Name:

Suface Type:

|

I From Surface: | 7ccr Hatial

Addta Active Site

Use as Base Suface for Active Site

Help

i





Click Apply and close the dialog box.
P3 is now added and active to the Explorer Window.
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4) Using the MicroStation Drop Element command, turn on Line Strings/Shapes and select the MicroStation element representing P3: 
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El elemento ahora quedara roto en todas sus partes individuales.
5) From the InRoads menu, select Site Modeler> Element > New/Edit
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Verify that the Add option is turned on and that the surface is set to P3. For Element ID, use the crosshair nest to Element ID and select the left vertical line of the element (see figure). For the Method, select Constant Elevation and type 300.00. Click Apply and DO NOT closet he dialog box:
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6) To visualize the elevations, edit the P3 Surface properties and turn on Vertices:
[image: image100.png]



7) To define the rest of the platform, they must be referenced to the first element with a specific slope. In the New/Edit Element dialog box, turn on the Add option, verify that the Surface is P3. Select the crosshair next to Element ID and select the top horizontal line of the platform. The ID field is automatically filled. Select the Slope/Offset from Element Method. For the Drape Option, select Vertices and for the Slope value, type in -1.00%. Turn off Offset. Turn on the Redefine Element and Use Reference Association options. At the bottom part of the dialog box, under Reference, select the crosshair button and select the first element (left vertical line). The proper information is autotatically filled in the boxes. Click Apply and do not close the dialog box: 
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The design is automatically updated:
[image: image102.png]



8) To continue adding elements to the Platform referenced to the first element and with a specific slope, in the Newe/Edit dialog box, verify that the Add option is turned on and verify that the selected surface is P3. Use the crosshair button next to the Element ID field and select the right vertical line (see figure). The ID Element is automatically populated. Fort he Method, select  Slope/Offset from Element. Fort he Drape Option, Select vertices and for the slope, type -1.00%.  Turn on the Redefine and Use Reference Association options. In the lower left corner of the dialog box, under References, select the crosshair and select the first element in P3 (left vertical line). Click apply and do not close the dialog box:
[image: image103.png]



The model is automatically updated.
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9) In order to finish the platform, repeat the process for the last line (see figure). Use a -1.00% Slope from the refence element (left vertical line).Click Apply and Close the dialog box.
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The model is automatically updated.
[image: image106.png]



Points
1) In order to add points to the current Platform, P3, select form the InRoads menu, Site Modeler > Element > Define Point
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2) In the Define Point dialog box, select the Add option and verify that the surface is P3. For the Method, slect Drape and on the left bottom part of the dialog box, under Drape, slect Platforms for the Site and on the right side, use the crosshair in the Point to Define Section. Select a point approximately at the middle of the platform (location is not important as long as the point is inside the platform). Click Apply and Close the dialog box” 
[image: image108.png]



Site Modeling Tentatives
f you try to come close to the model and try to do a tentative over it, the model will not recognize it. Contours are temporary graphics and many times, tentatives in MicroStation are needed.
To setup tentatives in the model:
1) From the InRoads menu, select Site Modeler > Tools> Options
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Select the Visualization directory and under the General tree, under Snaps, turn on the Options for Surface and Site for Display Snaps. 

Select Apply and Close.
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2) Try doing a tentative snap on the model. It will now clearly snap to all elements. 
Volumetrics
1) To compute the volumen between Surfaces, Surfaces and Site, Site to Site, Level to Site or Level to Surface, from the InRoads menú, select Site Modeler> Tools> Site Volume
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2) On the General option, select Prismoidal for the Calculation Method:
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3) Under the Calculation Options tree, select Surface to Surface and select the Original Ground on the From field and P2 on the To field. Turn off the Use Range option at the bottom part of the dialog box:
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4) Go back to the General leaf and select Apply. Volumes are now calculated:
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5) Select the Output leaf on the left side of the dialog box and turn on the Output to ASCII file option, click inside the bos and then select the Save As button on the right. Name the file as vol.txt (under the training directory). Click Apply. The ASCII file has now been created.
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6) Once that the ASCII file has been generated, select the Output option and turn off the Output to ASCII file option. Go back to the Calculations Options leaf and turn on the Use Range option at the bottom of the dialog box: 
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7) Select the Range leaf on the left side and turn on the Auto Range Increment Option. Set the Range Increment to 1.00, then select the Set Range button. The range in elevations are now calculated:
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Select Apply and the ASCII file with volumetrics in elevation ranges is now generated:
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Moving and merging platforms
Now that all the platforms maintain intelligence and are part of the Project, simply move Platform 2 close to Platform 3 to visualize how both of them merge automatically. 
1) Select the MicroStation move command
[image: image119.png]



When prompted to identify the element, select P2 and for its final destination, place it close to P3. The model is automatically merged: 
[image: image120.png]



Profiles
1) From the InRoads main menu, select File > New, select the Geometry tab and for Type, select Geometry Project. Type Platforms on the Name field. Click Apply and close the dialog box. 
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2) From the InRoads menú, select Evaluation > Profile> Create Profile. Turn on all surfaces (except for Default) on the General folder: 
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3) Select from the Source leaf, the option Multipoint Alignment, type in axis for the name: [image: image123.png]= Create Profil
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4) Select Apply and at the bottom part of the dialog box and when prompted to identify a beginning point, click to the left of P2 somewhere close to the middle of its geometry, continue this imaginary line all the way to the right and finish it past P3. Reject with a right click to finish the multipoint alignment. 
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5) When prompted to identify location, place the profile anywhere on the design file: 
[image: image125.png]



Visualizatiion
1) In order for all elements to be permanent in the design file, simply select from the InRoads menu, Site Modeler > Tools >Export Visualization. Select the Platforms Site and turn on the option Set Graphic Group. Click Apply and close the window. Graphical elements, defining the platforms will now be permanent in the design file. 
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Generating the final Surface
1) In order to create a total final surface (not just the individual ones), from the InRoads menu, select Site Modeler > Tools > Create Surface
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2) On the dialog box, select under Create From in Site, Plataforms. At the bottom, on Surface, type Platforms as the name for the total Surface. Click Apply and close the dialog box. The surface is now added to the InRoads session. 
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Tracking

It is useful knowing how to obtain immediate feedback based on Project Project data. From the InRoads menu, select Site Modeler > Tools> Site Tracking
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Once the Activated button is selected, the cursor carries all type of information dynamically displayed in the dialog box:
[image: image130.png]



System Configuration
If the project is to always be part of specific standards, it has to be part of a project configuration.
1) From the InRoads menu, select File > Project Defaults.  Select the New button and type in Training Site Modeler. Click OK and Cancel. 
[image: image131.png]= New Configuration

Nome: Trenament Steodde




2) In addition to all files and directories already known to InRoads, a new file must be added as the sistem is initialized. On the Default Preferences area, click inside the Site Modeler Options box (*.spf) and then select the Browse button on the right side. Select the civil.spf file located on the training directory.  
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Click Apply and Close the dialog box.
From this point going forward, the configuration is set and fixed as a new session of the product is started.

