Cannot open DWG file - FileFormats - Forum - FileFormats - Be Communities by Bentley

Cannot open DWG file

FileFormats

FileFormats
This is the community for things related to Bentley product interoperability with file formats other than DGN.
FileFormats - Forum

Cannot open DWG file

  • When opening a DWG file I encounter the error message which says "Cannot locate a default SHX font. Please install msdefault.shx Program must now exit!" Is there anything I can do to correct this?

    Thanks

     

  • Where do you have MS_FONTPATH pointing to? And is msdefault.shx in that folder?

  • Yes. It is pointing to the right directory and the msdefault.shx file is located there. It doesn't do this with all DWG files I try to open just a few.

    BTW Thanks for the help on the ablility to post. I talked with JDEG and he got my page to show the "Start a New Thread".

  • Hmmm... that is interesting. Can't say that an intermittent issue like you describe seems logical, but obviously it is happening to you. On the files that this IS happening, is it consistent? IOW, each time you try to open the file, you are seeing this? Do you have any first- or third-party or custom applications or macros involved? Would it be possible to get one of those files (a small one would be preferred).

    Regarding the inability to post anything, yes, we discussed that here... truly an odd situation that we are going to keep a lookout for.

  • I believe I found out the problem. I was trying to opening the DWG file in a new session of Microstation while having a DGN file already open in Microstation. If I close everything out and just open the DWG file it works.

  • Hmmm... that should have no relevance at all. In fact, I just tried that in a couple of different scenarios (one where MicroStation is open with a DGN file and then I opened a DWG file and then another where I had one session of MicroStation open to a DGN file and then I started a second session of MicroStation open to a DWG file) and had no issues whatsoever. Is it possible that you were doing something else? Could you also identify some of the things (if any) that were asked in the previous reply? TIA

  • Can I email you the file I'm trying to open? It's only 544 KB.

    The previous reply your talking about, is that the problem I had with posting on here?

  • I do not recommend e-mailing files... there are just too many things that could go wrong with that. If the file is less than 4MB (recommended... as providing a small example that demonstrates an issues is almost ALWAYS easier to diagnose), then you can attach it to a Forum posting by clicking on the Options tab in the editor. If larger than 4MB, then the FTP section of this wiki article should help.

    AFA the previous reply is concerned... "On the files that this IS happening, is it consistent? IOW, each time you try to open the file, you are seeing this? Do you have any first- or third-party or custom applications or macros involved?"

  • I've tried opening several DWG files and every single one of them states the same error message about the msdefault.shx file in V8i. I've also tried it in V8 2004 edition and XM and have no problems with either of these two applacations, it pulls up the DWG files with no error messages. I went into the Workspace>Configuration>MS_FONTPATH and under Directory List is set to C:\Documents and Settings/All Users/Application Data/Bentley/Microstation/System/Fonts. This is where the file msdefault.shx is located.

    So, it's not really just one certain DWG file, it's all that I try to open. Also to note, I can reference the DWG files into a DGN file with no problem.

    Why are those files listed under C:\Documents and Settings directory intead of under C:\Programs Files\Bentley like it was in V8?

    Thanks

  • A fallback font (e.g. msdefault.shx) is only used when MicroStation encounters an element using an SHX font it con't otherwise find, which could explain intermittent behavior (i.e. if it can resolve the element's font, no fallback is required).

    Out of curiosity, have you modified your font configuration file at all (MstnFontConfig.xml)? For example, under the appropriate language, what is the default SHX font? Does your expansion of MS_FONTPATH end with a backslash?

      

  • Pat-seed.dgn

    Phil,

    I found out what the problem is with all this msdefault.shx error messages, but I don't why it's doing it. I uninstalled V8i and reinstalled with a fresh start. I weeded through what I had customized and different settings I had set. If I start V8i where the Microstation manager dialog box is and select under options where the .dws file is created. I always had a customized DGN Seed File selected. If I selected the seed file Seed2d.dgn which comes with Microstation, I have no problem bringing any DWG file up, but if I chose my custom DGN Seed File (Pat-Seed.dgn, which I have attached for you to give it a try) and try to open a DWG file, it crashes with the error that I explain previously. I don't understand why the custom seed file would be making it crash.

    Maybe this helps identify where the problem is coming from, but I still don't understand why?

    Thanks

  • This is due to a bug in MicroStation that is file-specific. We can think of two workarounds off-hand:

    1. Edit your seed file so that it uses an SHX or TrueType font once (e.g. create a text element with a TrueType font, then delete the element).
    2. Open another file first before attempting to open a DWG with your seed

    We will of course address this bug in future builds; sorry for the inconvenience.

      

  • Thanks a bunch Jeff, that solved the problem.
  • Same for us - tricky indeed...

    nr.2  doesn't work if you save to a dwg an microstation attempts to switch to it afterwards

  • any updates on this been finally resolved yet?

    we are just beginning the transition from XM to V8i and this has cropped up as a problem.

    when we open DWG with a standard installation from the file manager it works just fine. but as soon as we try to load it with our company specific workspaces MS and PD just crash with the cannot find font error. we have tried adjusting our custom seed files as suggested with no success. MS_FONTPATH + MS_DWGFONTPATH both point to folders on our server which contain msdefault.shx + standard.shx

    the only work around we have found to work is to open a DGN file first with file manager to load user/project specific variables and THEN open the dwg with a control-O as opposed to control-W not exactly ideal when we probably use DWG maybe 60% of the time for projects.....

    anyone had any success is solving this problem in a slightly more elegant manner i would love to hear about it as it is currently one of the last bugs to resolve before we deploy V8i across our entire company