Applies To 
   
  Product(s): ProjectWise BatchPlot
  Version(s): All
  Environment:  N/A
  Area:  N/A
  Subarea:  N/A
  Original Author: Bentley Technical Support Group
   

 

 

 

 

 

 

 

 

Overview

Follow these steps to set up batch plotting in ProjectWise:

  1. [Admin] Create the BatchPlot application in the ProjectWise Administrator. The application must be called "Batchplot".
  2. [Admin] Create an Extension mapping for the batchplot job file. Extension should be *.job and associated to the BatchPlot application.
  3. [Client] Run the iDesktop Integration installer for MicroStation and make sure the option for Batch Plotting is enabled.
  4. [Client] From the ProjectWise Explorer, create a Batchplot Program Association to the MicroStation executable, Tools > Program Association > Batchplot > C:\Bentley\Program\MicroStation\Ustation.exe. Set the Partner application to Yes.
  5. Import the *.plt plot driver file(s) for your printer into a ProjectWise vault. If you use pen tables for your plots import these as well. The plot file and pen tables don't need to be associated to any application but they need to be imported in a ProjectWise vault for document control.
  6. From the ProjectWise Explorer, open a design file in MicroStation.
  7. In MicroStation open the BatchPlot Utility, File > Batch Print/Plot.
  8. From the BatchPlot dialog box open the BatchPlot Specification Manager, Specifications > Manage. Select the BatchPlot specification parameters. (Very Important)The Printer, Plot Area, Layout and Display must be created and/or selected from the BatchPlot Specification Manager or BatchPlot will not work through ProjectWise.

    Printer - Select the printer driver from the ProjectWise Vault (step 5). The driver should have the <default_outfile/auto_overwrite> set to the plotting device you are using.

    Example:
    Mapped LPT Port:default_outfile/auto_overwrite = "lpt1"
    Default System Printer:default_outfile/auto_overwrite = "Printer Name"
    If using the system printer <printer.plt> the "Printer Name" needs to match the name of the default printer under the printer Control Panel, for example, "HP DesignJet".

    Plot Area - Lets you set the Plot Boundary to View, Shape, or Cell. You can also tell BatchPlot to search the master file or reference file for the plot boundary specified.

    • Select Shape or Cell for the plot boundary. The shape or cell must be present in the Reference View specified in the top section of this dialog box. If the shape or cell is not present in the Reference View, ProjectWise will not find the boundary object.
    • If the Search Files option is set to Reference Files, the attached reference file with the cell or shape must exist in the current vault or ProjectWise will not find the boundary object.

    Layout - Used to describe how BatchPlot determines the size and position of each plot. For more information see the MicroStation documentation.

    Display - Contains options for controlling how the elements plot. Display also lets you assign a pen table to control and/or enhance the plotter output. For detailed information on creating pen tables see the MicroStation documentation. The pen table must be selected from a ProjectWise Vault (step 5).

  9. Add the design files you wish to plot.
  10. Choose File > Save As and save the job file to the vault. The job file must have a *.job extension and be associated to the "Batchplot" application created in step 1.
  11. Exit MicroStation.
  12. Go to the vault and right-click on the job file you created. From the menu choose BatchPlot > Open Set Content. This will create a set containing the design files from the job file. If desired, you can drag-and-drop files to and from this set.
  13. To plot the set, right-click on the job file and choose BatchPlot > Plot. You will see a Print dialog appear and animate copying the files to the printer.

Notes:
If the plots are not generated at the plotter check the batchplt.log file for any errors. By default the log file is saved in C:\Bentley\Workspace\projects\examples\generic\out\.

See Also

Product TechNotes and FAQs

ProjectWise TechNotes And FAQs

External Links

Bentley Technical Support KnowledgeBase

Bentley LEARN Server

Comments or Corrections?

Bentley's Technical Support Group requests that you please confine any comments you have on this Wiki entry to this "Comments or Corrections?" section. THANK YOU!