OpenRoads Designer CONNECT Edition

OpenRoads Designer 是一款综合全面且功能完备的详细设计应用程序，可用于测量、排水、地下公共设施和道路设计，取代以前通过 InRoads、GEOPAK、MX 和 PowerCivil 交付的所有功能。

土木设置
父主题: OpenRoads Designer CONNECT Edition帮助


OpenRoads Designer CONNECT Edition OpenRoads Designer CONNECT Edition OpenRoads Designer CONNECT Edition

土木设置

土木变量
父主题: OpenRoads Designer CONNECT Edition


土木变量

配置变量

描述

OPENQV_WHITE_BACKGROUND

Windows 设置，用于将“模板库”对话框设置为白色背景而不是黑色。设置为 1 表示白色。

CIVIL_SHOW_MS_PROPERTIES

显示通常隐藏在土木元素中的额外 MS 属性。

CIVIL_STOP_COMMAND_DEFAULTS

停止将其默认值存储为 xml 的土木命令。主要用于自动化测试。现有文件必须删除，因为该变量不会阻止系统读取这些文件。

CIVIL_TM_USERTIW_FOLDER

定义可以定位“从 ASCII 创建地形”工具的向导设置文件的目录。

CIVIL_CONTENTMANAGEMENTDGNLIBLIST

此变量定义特征定义 DGN 库的目录和特定文件名。有关详细信息，请参阅 CIVIL_CIVILCELLDGNLIBLIST。

CIVIL_CIVILCELLDGNLIBLIST
  1. 定义土木单元 DGN 库的目录和特定文件名。示例：CIVIL_CIVILDGNLIBLIST = c:\workspace\dgnlibs\civilcells.dgnlib
  2. 允许使用通配符。示例：CIVIL_CIVILDGNLIBLIST = c:\workspace\dgnlibs\*.dgnlib
  3. 如果未设置此变量或未找到 dgnlib 文件，则该过程的工作原理应该如此所示（查看每个 dgnlib 的内部并列出任何包含土木单元的 dgnlib）。
  4. 如果已设置此变量并找到 dgnlib 文件，则此文件应用于列出土木单元，不得再作它用。换而言之，如果此文件包含其他土木项（例如，特征定义、项目设置或过滤器），则应忽略这些项。

CIVIL_CIVILTMDGNLIBLIST

此变量定义地形模型过滤器 DGN 库的目录和特定文件名。有关详细信息，请参阅 CIVIL_CIVILCELLDGNLIBLIST。

CIVIL_DESIGNSTANDARDSDGNLIBLIST

此变量定义设计标准 DGN 库的目录和特定文件名。有关详细信息，请参阅 CIVIL_CIVILCELLDGNLIBLIST。

CIVIL_PROJECTSETTINGSDGNLIBLIST

此变量定义项目设置 DGN 库的目录和特定文件名。有关详细信息，请参阅 CIVIL_CIVILCELLDGNLIBLIST。

CIVIL_DISALLOW_LOCKCHANGES

如果设置为值 1，则不允许对现有规则进行任何锁更改。换而言之，它可以防止锁定的规则被解锁或解锁的规则被锁定。

CIVIL_DISALLOW_REFERENCEDELETIONS

如果设置为值 1，则不允许在某个元素被另一个元素引用时删除该元素。不能跨参考文件工作。

CIVIL_CIVILSETTINGS_READONLY

如果设置为值 1，则来自 DGN 库的所有标准、首选项或特征将在激活文件中保留为只读。

CIVIL_SHOW_SHARED_FEATUREDEF_PROPS

显示特征定义的属性，可用于将所有本地或模板样式的默认值设置为相同。可用于为元素模板设置特征定义

CIVIL_UNIT_LENGTH_STATIONING_LENGTH（仅限巴西）

此外，用户还可以选择将 CIVIL_UNIT_LENGTH_STATIONING_LENGTH 配置变量定义为桩号长度（通常为 20 米）。如果未定义此变量，则桩号长度将默认为 20 米。如果定义了此变量，则必须定义为大于零且小于 100，否则将默认为 20 米。此变量应为整数。不支持非整数。请注意，软件不会检查该值是否为整数，也不会检查 InRoads 首选项和这些配置变量是否同步。这些是实施/培训问题。

CIVIL_OVERRIDE_UNIT_LENGTH_STATIONING（仅限巴西）

用户必须将 CIVIL_OVERRIDE_UNIT_LENGTH_STATIONING 配置变量定义为 true。如果此变量未定义或未定义为 true，则单位长度桩号将为 100 工作单位。软件将该值视为不区分大小写。

CIVIL_EXAGGERATION_VALUES

纵断面放大系数值。在产品中设置为值 = {"1", "2","3", "4","5","10", "20", "50", "100"}。

CIVIL_DEFAULTSETTINGS

用于定位保存包含土木精确绘图默认值的 XML 文件的文件夹。

CIVIL_RELAX_NUMBER_OF_LINEARS

允许用户放宽相邻线性元素的数量。如果此变量设置为 false 或未定义，则相邻线的最大数量为 20。

CIVIL_RELAX_NUMBER_OF_ELEMENTS_FOR_RULES

允许用户放宽元素的总数（线 + 弧）。如果此变量设置为 false 或未定义，则最大元素总数为 250。

CIVIL_RELAX_NUMBER_OF_ELEMENTS_ON_IMPORT

允许用户在导入几何时放宽元素的总数（线 + 弧）。如果此变量设置为 false 或未定义，则最大元素总数为 1000。这仅适用于纵面路线。

CIVIL_DEFAULT_LINEAR_STROKING

定义在切线段上计算点或三维路面间距位置的频率。“廊道模型”不使用此变量。如果未设置，则值默认为 10。此变量在生成三维元素和应用模板命令时使用。

CIVIL_DEFAULT_PROFILE_STROKING

定义沿纵断面计算点或三维路面间距位置的频率，并根据相对纵断面的弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置，则值默认为 0.1。应用竖曲线密封时，在“廊道模型”中使用此变量。

CIVIL_DEFAULT_CURVE_STROKING

定义沿曲线段计算点或三维路面间距位置的频率，并根据相对平曲线的弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置，则值默认为 0.01。应用平曲线密封时，在“廊道模型”中使用此变量。

CIVIL_DTM_LINESTRING_FILTER_TOLERANCE

默认情况下未启用。仅在需要时针对每个项目（地形数据采用 DWG 格式）启用。过滤查看 3 个点。过滤器最大间隙是点 1 和点 3 之间的距离。如果该距离在最大间隙内，则检查点 2 以查看过滤器公差是否在该范围内。如果在，则将其移除。

CIVIL_DTM_LINESTRING_FILTER_MAXGAP

与 CIVIL_DTM_LINESTRING_FILTER_TOLERANCE 结合使用。

CIVIL_DEFAULT_STATION_LOCK

如果设置为 true，则计算各种命令的桩号并保持为偶数。例如，三维路面的桩号将始终保持为偶数（如果公式得出不同的结果）。

如果未设置或设置为 false，则按指定的增量保持桩号值。

CIVIL_REPORTS_DIRECTORY
如果该变量设置为有效的目录位置，则软件会查看此特定位置来定位 XML 报告。如果此变量未设置或设置为无效位置，则软件会查看 Civil 默认安装报告的位置。
注释: 如果定义了 InRoads 项目的默认 XSL 位置，则在 CIVIL_REPORTS_DIRECTORY 之前使用该位置。这可以为 InRoads 用户保持连续性。

CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_1_SAG

凹抛物线长度在选项 1 的超高过渡段内。在内部默认设置为 45。如果需要其他值，用户可以添加配置并分配其他值。如果“过渡段 ID”设置为“抛物线”，则用户在计算超高时选择该选项。

CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_1_CREST

凸抛物线长度在选项 1 的超高过渡段内。在内部默认设置为 55。如果需要其他值，用户可以添加配置并分配其他值。如果“过渡段 ID”设置为“抛物线”，则用户在计算超高时选择该选项。

CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_2_SAG

凹抛物线长度在选项 2 的超高过渡段内。在内部默认设置为 30。如果需要其他值，用户可以添加配置并分配其他值。如果“过渡段 ID”设置为“抛物线”，则用户在计算超高时选择该选项。

CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_2_CREST

凸抛物线长度在选项 2 的超高过渡段内。在内部默认设置为 40。如果需要其他值，用户可以添加配置并分配其他值。如果“过渡段 ID”设置为“抛物线”，则用户在计算超高时选择该选项。

CIVIL_DEFAULT_BEST_FIT_UPPER_ENVELOPE

这些将仅用于“自动创建三维元素”功能。“最佳拟合纵断面”仍将使用典型命令/xml 首选项。

CIVIL_DEFAULT_BEST_FIT_LOWER_ENVELOPE

请参阅 CIVIL_DEFAULT_BEST_FIT_UPPER_ENVELOPE

CIVIL_DEFAULT_BEST_FIT_CREST_LENGTH

请参阅 CIVIL_DEFAULT_BEST_FIT_UPPER_ENVELOPE

CIVIL_DEFAULT_BEST_FIT_SAG_LENGTH

请参阅 CIVIL_DEFAULT_BEST_FIT_UPPER_ENVELOPE

CIVIL_DEFAULT_BEST_FIT_MINIMUM_LENGTH

请参阅 CIVIL_DEFAULT_BEST_FIT_UPPER_ENVELOPE

CIVIL_SURVEY_STROKE_TOLERANCE_LINEAR

为测量生成的切断线设置描边距离。将在该距离向切断线中插入其他点，导致沿着测量线性特征生成其他顶点。如果未设置此变量，则测量将使用 CIVIL_DEFAULT_LINEAR_STROKING 值。

CIVIL_SURVEY_STROKE_TOLERANCE_CURVE

将测量的描边距离设置为测量弯曲线特征的中线纵坐标（设置为“切断线”）。如果未设置此变量，则测量将使用 CIVIL_DEFAULT_CURVE_STROKING 值。

CIVIL_SURVEY_RETAIN_SURVEY_ON_COPY

如果已设置，在复制点或链时，此变量会将副本保留为测量项。

CIVIL_SURVEY_OBSERVATION_NON_EDITABLE

如果已设置，则阻止编辑、删除、操作观测。

CIVIL_SURVEY_FILES_FOLDER

如果已设置，则此文件夹定义 Survey 搜索 TIW 和 EXE 文件的位置。

CIVIL_SURVEY_IGNORE_TDS_FC_RECORD

使用“Tripod 数据系统”数据导入项加载测量数据文件时，此变量会导致解析忽略 TDS 原始文件中的 FC（特征代码）记录。

CIVIL_SURVEY_USERTIW_FOLDER

定义可以定位用户 .TIW 文件的备选目录。

CIVIL_SURVEY_EXPAND_ALL_DATA_IMPORT_ITEMS

在加载测量数据文件时展开所有数据导入项。用户能够移除原始导入项来清理列表，以便仅将所需的文件类型显示为要加载的候选项。在加载测量数据文件时，此变量会自动将列表重置为原始状态 + 用户定义的项，这样用户就不必手动按“数据导入项”对话框中的“重置”图标。

CIVIL_SURVEY_GEOID_BINFILE_FOLDER

定义可以定位 GEOID BIN 文件的备选目录。如果未设置，则使用标准 GEOID BIN 位置。

CIVIL_UPGRADE_PROMPT_OFF=1

如果包括，将自动升级 SELECTseries 3 文件，而无需用户干预/对话框。

CIVIL_OPEN_OLD_READONLY=1

如果自行包括在内不会执行任何操作，则还需要定义“提示关闭 cfg”，然后将以只读方式打开而不进行任何升级，例如，对于批次出图。

CIVIL_iMODEL_INCLUDE_ICM

设置为 1 - 仅限设计模型

设置为 2 - 仅限地形模型

设置为 3 - 适用于设计模型和地形模型

发布 i.dgn（将用作 OpenRoads 移动应用程序的 .imodel）时，需要将此 CFG 变量设置为 1、2 或 3 以获得嵌入式土木数据（如线性参考）。

TARGET_ALIAS_ALLOW_ALL_LINEARS

将此变量设置为 1 时，激活 DGN 或任何附加的参考文件中的所有线性元素将自动添加到“目标别名”可用目标列表。

_CIF_ALLOW_EXTENDED_UPGRADES =1

如果已在 OpenRoads.cfg 文件中设置，则允许 SELECTseries 4 中的土木单元 DGNLIB 升级到 OpenRoads Designer CONNECT Edition 格式。有关其他详细信息，请参阅 OpenRoads Designer 自述“新增功能”。

CIVIL_CIRCLE_MESH_STROKE_NUMBER

设置用于勾画整圆的点数。弧将使用基于弧扫掠总圆率的数字（1/4 圆弧将生成 1/4 的笔划点数）。

地下公共设施配置变量

以下变量可用于根据工作流的需要配置地下公共设施。

配置变量 | 描述
SU_3D_Bends_Detail = | 有效值： 低 -（默认值）- 三维导管模型中的弯曲分辨率较低，在较大的数据集中具有更好的性能。 高 - 三维导管模型中的弯曲建模为类似于配件。
SU_3D_Structure_ExtrudeMethod = | 有效值： 向上 -（默认值）- 这意味着使用拱顶的切片向上拉伸。 向下 - 这意味着从顶单元的底部向下拉伸切片。
SUDA_SEED_FILE = | 指向包含水力种子数据（例如，暴雨事件和入口水力属性）的 dgnlib 文件。
SUDA_SEED_MODEL = | 前一种子文件中包含水力种子数据的模型。
SUE_SEED_FILE = | 指向包含 SUE（例如，非水力）元素的用户数据扩展种子数据的 dgnlib 文件。
SUE_SEED_MODEL = | 前一种子文件中包含种子数据的模型。
CIVIL_SUBSURFACE_FILTERS_DGNLIBLIST = | 指向存储公共设施过滤器的 dgnlib 文件。这些过滤器将加载到浏览器“OpenRoads 标准”选项卡和“过滤器管理器”中的“公共设施过滤器”。请注意，还必须设置 MS_DGNLIBLIST 配置变量才能加载此 dgnlib 文件。
SUDA_USE_HAESTAD_CONDUITS | 有效值： 1 = 启用 如果启用，则从为导管特征定义选择的“水力原型”中的数据读取水力（例如，暴雨和污水）导管的导管尺寸，这可以指向导管目录，也可以指向用户自定义管线。非水力导管（例如，电力通信电缆和管道）的尺寸仍在特征定义的“导管表”中设置。 0 = 禁用 如果禁用，则在放置导管时从特征定义的“导管表”中读取水力（例如，暴雨和污水）导管的导管尺寸，Haestad 尺寸用于水力学计算。这意味着两个导管尺寸列表必须同步。 无论此变量的设置如何，非水力导管（例如，电力通信电缆和管道）的尺寸仍在特征定义的“导管表”中设置。
父主题: 土木设置


新增功能

下面汇总了本版本中的新增功能和增强功能。

Bentley OpenRoads Designer CONNECT Edition 新增功能

下面汇总了 2018 版本 4 中的新增功能和增强功能。

普遍增强

  • 将 Power Platform 更新为 Update 11 CONNECT Edition(V10.11.00.38)。相应的 MicroStation 版本为 (V10.011.00.36)。
  • 采用 CONNECT 许可。有关详细信息：CONNECT 许可。
  • 包括 Bentley LumenRT Designer CONNECT Edition Update 11。
  • 包括 Bentley Descartes CONNECT Edition Update 2 (V10.09.00.38)。
  • 更新了 gINT Civil Tools CONNECT Edition Update 1 (V10.02.01.13)。
  • 支持以下 ProjectWise Connect Edition (V10.00.03.140)。
  • 移至在线帮助。
  • 包含土木模型的 DGN 使用创建产品的品牌，这称为“产品一致”。DGN 为 OpenRoads 或 OpenRail。有关详细信息，请参阅：产品一致。
  • 从 DGN 发布 iModel（包括 Subsurface Utility 模型）现在支持 ProjectWise 中的 iModel Composition Service。

测量增强功能

  • 坡度很平时，可以不显示坡度箭头。
  • 对于英制数据，测量使用公制笔划距离。
  • 如果取消 PW 选择文件对话框，将弹出错误的 Windows 对话框。
  • 包含 B 样条曲线的特征不会按预期显示。

几何图形增强功能

  • “转置几何图形 (Transpose Geometry)”工具。
  • “几何点”工具得到了增强，可以从地形、网格和纵面纵断面获取高程。
  • 几何点现在可以相对于线形旋转放置。
  • 从桩号/偏移/高程 ASCII 文件导入几何点。
  • 添加了几何点 XML 报告，用于报告几何图形和测量点。
  • 添加了“复制纵面 (Copy Vertical)”工具，用于复制相同平面中的几何图形，或者复制到另一个纵面几何图形。

地形增强功能

  • 现在，可以在“常规访问 (General Access)”中创建 HEC-RAS 格式。
  • “高程分析”报告有所改进，可以在点超出公差范围时显示。

建模增强功能

  • 叠加组件现在允许使用空心组件。
  • 现在，组件可以是空心组件，并且可以使用单个实例进行创建。
  • 将竖向偏移临时尺寸标注线添加到了廊道的动态横截面。
  • 在调整缩放比率时，不会调整动态剖面临时尺寸标注文本的大小。
  • 现在，使用曲线加宽不仅可以增加缓和曲线长度，还可以增加设置的距离。

绘图制作和标注的增强功能

  • 可以在纵断面中添加等效半径的标注。
  • 可以在纵断面中添加 VPC 到 VPI 的水平距离。

地下公共设施增强功能

  • 此版本使用 OpenFlows SewerGEMS 版本 10.02.00.52。
  • “从图形中提取公共设施”工具的性能得到了提高。以前，沿导管路径分布的每一对点均表示为一条两点线，其中每条线均有关联规则。现在，沿该路径分布的点均表示为沿一条直线分布的弯头。
  • 现在，可以由站点管理员使用 CONNECT 许可来配置可在“地下公共设施”（例如，CivilStorm、SewerCAD）中激活的各种许可证的可用性。以前，“地下公共设施”不知道是否有其中某个产品的许可证，因此，通常给出的消息是告知您将记录使用量，可能会额外收费。现在，可用性由 CONNECT 许可控制，这意味着，您可以确切地了解有哪些产品许可证和功能级别（入口或链接数）可供使用。
  • 现在，可以为低影响开发设置父汇水区，也就是说，可以在“地下公共设施”中正确设置这些元素类型。
  • “组件”功能区中的“复合出水口结构”和“低影响开发”图标变得更大，更容易找到。
  • 包含“地下公共设施”数据的参考的 DGN 在加载时就像它们已激活一样，出现异常后，会有同步数据的提示。
  • 更改场景可能会导致图形数据和数据库中的相应数据不同步。
  • 如果在 DGN 中创建公共设施项目时未使用正确的种子文件，则在发布 iModel 时会出现问题。现已对这种情况进行了测试，如果 SUDA_SEED_FILE 和 SUDA_SEED_MODEL 变量未提供适合的种子，将会显示一条错误消息。
  • 如果节点单元的构造类元素使用“按层”而非具体线符，它们可能会在二维模型中错误旋转。
  • 查询结果不会在二维模型中高亮显示。
  • 将“设置特征定义”工具用于较大量的节点时，该工具会挂起。
  • 大型地形模型在设置为活动状态时会对性能造成负面影响。
  • 如果其中一个存在冲突的元素位于参考文件中，冲突检测找不到冲突。
  • 如果两个节点中只有一个具有特征定义，则使用“重新连接链接”在节点之间移动链接时，会出现异常。

技术预览增强功能

  • 添加了几何图形构建器和编辑器，用于创建地块和小块地。
  • 几何图形构建器支持不同测量单位的输入，并且可将输入转换为 DGN 主单位。例如：连杆、杆和链。
  • 基于三维似棱形挖方和填方网格创建土方运距图。
  • 将三维廊道网格模型导出为通用 IFC 格式。
  • 添加了单个内业断链。
  • 可以对准实景模型以及创建实景模型（即地面提取的 3sm 文件）轮廓。
  • 资产管理器。
  • 可以使用桩号批量设置标记。
  • 可以导出到形状文件。
  • 文本收藏夹管理器。
  • 导出到 MaXML。

下面汇总了 2018 版本 3 中的新增功能和增强功能。

普遍增强

  • 将 Power Platform 更新为 Update 10 CONNECT Edition(V10.10.00.28)。相应的 MicroStation 版本为 (V10.010.00.23)。
  • 包括 Bentley LumenRT Designer CONNECT Edition Update 10。
  • 包括 Bentley Descartes CONNECT Edition Update 2 (V10.08.00.27)。
  • 更新了 gINT Civil Tools CONNECT Edition Update 1 (V10.01.01.21)。
  • 支持以下 ProjectWise Connect Edition (V10.00.03.49) & (V10.00.03.140)。
  • 优化了网格图元的“属性”对话框加载。
  • 在“转换”工具中添加了最小二乘法。

测量增强功能

  • 解决了有关测量替代的自定义属性问题。
  • 修复了在打开和关闭测量的特征定义时的浏览器问题。

几何图形增强功能

  • 增加了“通过曲线上的点查找几何点 (Locate Geometry Points via Points on Curve)”、“角度后方交会”，以及“交点”方法。
  • 增加了对使用“LandXML 导入”的几何点的描述。
  • XML 报告会显示几何点的描述。
  • 表编辑器显示 K 值、后斜坡、后切线长度，并且支持纵面几何的抛物线和/或弧定义几何。
  • 现在，表编辑器中的平面几何图形会显示桩号列、后象限角列、后切线长度列。
  • 在表编辑器中添加了“报告”按钮和设计标准警告。
  • 速度表显示纵面线形的最大坡度。
  • 可以导入、复制和投影速度表信息。
  • 现在，“纵断面投影至其它剖面”和“局部纵断面投影至其它剖面”工具可以从参考文件中选择元素。

建模增强功能

  • “创建挖方和填方土方量”工具已得到增强，可以在分析中使用特征网格。不再需要为建议的粗略坡度创建地形模型。

  • “创建挖方和填方 (Create Cut Fill)”工具的性能得到了提升。

  • 挖方和填方 <土方量选项> 现在包含用于将挖方和填方系数定义为相应值的设置。

  • 现在可以在创建挖方和填方网格时分割弃方材料。这样，便可对“仅已移除 (Removed Only)”和“已移除并更换 (Removed and Replaced)”的弃方材料使用不同的值。

  • 解决了会生成错误结果的组件显示规则这一问题。

  • 使用特定数据集更正了廊道性能。

绘图制作和标注的增强功能

  • 现在，可以在平面图模型中放置单元（指北针）。
  • 纵面线形立面会显示在平面线形标注上。

地下公共设施增强功能

  • 本版本使用 Haestad 版本 10.01.01.04，并包含截至 2018 年 9 月 19 日的累积修补程序集。
  • “地下公共设施”纵断面图纸现在可以使用表格标注功能。此功能使用文本收藏夹（已经可用于平面图标注）来为标注提供值和格式。
  • 用于在平面图中绘制节点的二维单元现在使用单元中的所有元素（包括文本、剖面线等）进行绘制。以前，只会绘制单元中包含的一部分元素。
  • 如果在图形中选择雨水或污水元素或者在“公共设施属性”的“水力分析”选项卡中显示信息的任何其他位置（例如，场景的属性）选择雨水或污水元素，此选项卡现在会自动显示在“地下公共设施”选项卡上方。

技术预览增强功能

  • 添加了几何图形构建器和编辑器，用于创建地块和小块地。
  • 基于三维似棱形挖方和填方网格创建土方运距图。
  • 创建 HEC-RAS 格式以导出数据供今后进行溪流和河流分析。
  • 将三维模型导出为 IFC 格式。（基于 IFC4 架构 2，查看器必须支持该版本。）
  • 添加了单个内业断链。
  • 资产管理器。
  • 文本收藏夹管理器。
  • 导出到 MaXML。

先前的 OpenRoads Designer 版本

2018 版本 2（以前称为 Update 4）

普遍增强

  • 将 Power Platform 更新为 Update 10 CONNECT Edition (V10.10.00.23)。相应的 MicroStation 版本为 (V10.010.00.23)。
  • 包括 Bentley LumenRT Designer CONNECT Edition Update 10。
  • 包括 Bentley Descartes CONNECT Edition Update 2 (V10.08.00.22)。
  • 更新 gINT Civil Tools CONNECT Edition Update 1 (V10.01.01.06)。
  • 支持以下 ProjectWise Connect Edition (V10.00.03.49) & (V10.00.03.14X)。

测量增强功能

  • 添加了用于合并外业簿的实用工具。
  • 可通过键入点列表以创建测量链（例如，AC100-AC109，AC100-AC101，AC104-AC106）来创建线性链。
  • 可以将测量修饰符显示为单个象限，从而模拟 (SELECTseries 4) 中的行为。
  • 使用“缺省”级别的元素定义单元时，可以在“特征定义”调用的元素模板级别上将测量点作为单元放置。这模拟了 MicroStation 的行为，并且支持在测量点需要位于不同级别上时使用一个单元定义。
  • 添加了“关闭 RECT (Close RECT)”命令。

地形增强功能

  • “视距分析”工具得到了增强，可以使用线形的速度表计算给定桩号的瞬时速度。
  • “视距分析”工具现在支持通过公式进行分析。
  • “水膜效应”工具现在可预览流线并且支持接受结果。
  • “水膜效应”现在可以选择手动轨迹边坡图。

几何图形增强功能

  • 所有几何点均分配有名称，现在包含一个描述字段。
  • 捕捉到几何点的几何元素现在会在元素信息下方显示点名称。
  • 水平和竖向表编辑器已从“技术预览”转至“商业发布”。

建模增强功能

  • 模板组件现在支持弧形和圆形组件。
  • 现在，针对线性 XY、Z、XYZ 目标类型的“目标别名”支持在 DGN 中加载所有目标，而无需将它们添加为廊道参考。该工具最初会缺省加载廊道参考。
  • 初始化廊道以及线性模板处理的性能得到了提升。
  • 其他土方量选项：添加了“弃方”、“挖方”、“填方”和“土基”。
  • 现在，“创建挖方和填方土方量”工具会在“特征定义”中考虑土方量选项。此外，这也支持“挖方和填方”工具考虑“弃方材料”并自动填充“挖方和填方”的特征定义。
  • “创建挖方和填方土方量”已得到增强，可以脱离特征网格运行。因此，可以从三维模型创建挖方和填方。不再需要为建议的粗略坡度创建地形模型。
  • 现在，可以根据三维模型和横截面名称边界组生成“端部区域土方量”报告。
  • 可以使用 MasshaulTOTIW.xml 和“端部区域土方量”报告工具生成土方运距报告。
  • 现在，可以在“创建/编辑超高规则文件”工具中查看和编辑导入的超高比率表。
  • 添加了“显示模板”工具。
  • 可以从包含圆弧的图形中导入模板。

绘图制作和标注的增强功能

  • 可以在平面图纸模型和图表上放置坐标系网格。
  • 现在，以轮廓为框架的曲率标注可以基于行高和曲线的合理量使用曲线的幅度。
  • “框架标注”支持使用记号，而不是框架行中的垂直线。
  • 可以通过标注的线形和标签关闭断链名称。
  • 添加了用于放置视图无关标签的功能。

技术预览

  • 资产管理器（技术预览）。
  • 文本收藏夹管理器（技术预览）。
  • 导出到 MAXML（技术预览）。

Update 3

普遍增强

  • 将 Power Platform 更新到 Update 8 (V10.08.00.34)。相应的 MicroStation 版本为 V10.08.00.37。
  • 包括 Bentley LumenRT Designer CONNECT Edition Update 4。
  • 包括 Bentley Descartes CONNECT Edition Update 2 (V10.06.00.32)。
  • 更新了 gINT Civil Tools CONNECT Edition Update 1 (V10.01.01.03)。
  • “转换”工具支持重新定位地形模型、几何点、平面和纵面几何，以及图形。
  • 添加了用于修改几何点和曲线集缩写的配置功能，以便快速满足当地和/或客户要求。此配置将在标注和报告期间修改这些缩写。有关详细信息，请参阅：
    • C:\ProgramData\Bentley\OpenRoads Designer CE\Configuration\Organization-Civil\_Civil Default Standards - Imperial.cfg
    • C:\ProgramData\Bentley\OpenRoads Designer CE\Configuration\Organization-Civil\_Civil Default Standards - Metric.cfg
  • 将 Civil (SELECTseries 4) 数据以项目方式升级到 OpenRoads Designer Update 3（技术预览）。
  • 更正了不连续线串在 DGN 设置为“另存为 DWG (Saves as DWG)”时显示为连续线串的问题。
  • 在“设置”>“文件”>“设计文件设置”>“土木格式设置”下加入了其他桩号格式。
  • 提供了 OpenRoads SDK。

测量增强功能

  • 现在支持导入 MX INP 文件。
  • 对测量减少的报告现在可以在进行调整前发出报告。
  • 附加的测量 Dgnlib 属性现在显示在“资源管理器”和“属性”中。
  • 支持导入超过 16 个字符的 SDR 文件。
  • 支持导入 Leica GSI 文件。
  • 解决了用于创建曲线而不是直线的 PC JPT 代码。
  • 更正了从观测移动的修饰符标签。

地形增强功能

  • 包括“视距分析”工具和报告功能。
  • 添加了“点检查 (Point Checking)”工具，用于查询地形模型与三维线串，并报告二者之间的偏差。

几何图形增强功能

  • 添加了表格编辑器，用于平面和纵面几何（技术预览）。
  • “水平偏移”工具包含一个用于在放置时移除偏移规则的开关。
  • 可以修剪和延伸至复合体的基本元素。这有助于使用“重新定义复合体 (Redefine Complex)”定义新路径。
  • 可以将速度表添加到平面几何。
  • 更正了“竖向”>“任意线连接”工具，以便正确跟踪元素的竖向偏移。
  • “导入 LandXML”现在支持区域小数设置。
  • “导出 LandXML”现在包含激活纵断面，前提是该纵断面未命名。
  • 已经解决了在导入 GPK 时会错误添加额外断链的问题。
  • 解决了在使用“土木精确绘图”>“纵断面偏移”工具时发生崩溃的问题。
  • 使用“设置特征定义”工具时，现在支持切换“自动注释”。

建模增强功能

  • “点控制”的选择列表现在包含所有空点，即使廊道特征定义关闭了空点也是如此。
  • “目标别名”对话框现在包含用于为 XY、XYZ 和 Z 目标类型加载所有目标的开关。这样便可选择不是廊道参考的别名。
  • 现在，可以使用“常规访问 (General Access)”工具在纵断面视图中创建模型的三维剖切。
  • 新增一个工具，用于通过两个点创建三维剖切，从而限制纵断面视图中“模型三维剖切”的桩号和立面范围。
  • 在打开“点属性”对话框时，编辑 ITL 中的模板点已经过优化，消除了在大工作空间中打开时出现的延迟。
  • 更正了在地形模型源自英制数据集中的公制时表面模板组件的放置。
  • 修复了线性模板，可以接受廊道参考以驱动特征定义约束。
  • “调整竖向覆盖关系”工具将识别参考 DGN 文件中的廊道。
  • 现在，叠加组件可在属性中报告量。
  • 已解决以下问题：以特定方式删除含有特定数据的模板点时会崩溃。
  • 修复了“廊道对象”>“三维路面”，以便在本地副本与 ITL 文件不同时，能以红色文本显示。
  • 解决了不支持使用“当前偏移”的“动态”部分。

绘图制作和标注的增强功能

  • 在纵断面表的表格数据中添加了超高图。
  • 在标注中添加了视图无关属性，用于控制文本在设计、绘图和图纸模型中的旋转。
  • 纵断面框架标注现在包括平面曲率。
  • 为命名边界添加了从图纸种子继承线符的功能。
  • 对于相应的纵面几何（坡谷/坡顶），纵面曲线类型的标注已反向。
  • 添加了为横截面轴网的桩号和基准标签选择文本收藏夹的功能，可以为桩号和立面自定义格式和精度。
  • 添加了为纵断面中的桩号和基准标签选择文本收藏夹的功能，可以为桩号和立面自定义格式和精度。
  • 更正了在 DGN 的 UOR 与图纸种子 DGNLIB 文件的 UOR 不同时命名边界的放置。
  • 更正了使用不同 UOR 时标注的间距。
  • 更正了通过标注对有效横截面的段进行过滤的功能。

地下公共设施增强功能

本版本的地下公共设施基于 Haestad CONNECT Edition Update 1 版本 (10.01.00.70)。

水力和水文增强功能

  • Update 2 中引入的“新建暴雨事件场景 (New Storm Event Scenarios)”工具已得到增强。现在，可以使用该工具从 IDF 暴雨数据中选择要使用的重现期和持续时间，并将其转换为雨量，然后再创建模拟所需的暴雨事件、场景、备选项和计算选项。
  • 添加了对英国《洪水估算手册》雨量数据的支持，通过为六个汇水区描述符指定相应的值可以计算该数据。这会计算 IDF 数据，然后可以将其与相应的暴雨示意图配合用来创建要在模拟中使用的雨量数据。
  • 添加了对澳大利亚气象局雨量数据的支持，可以将该数据作为 CSV 文件下载。这可提供 IDF 数据（DDF 数据会自动进行转换），然后可将该数据与相应的暴雨示意图配合用来创建要在模拟中使用的雨量数据。
  • 现在，可以将其他重现期添加到英国《洪水研究报告》和《洪水估算手册》IDF 暴雨数据格式中。现在，自动添加了 75 年重现期。
  • 暴雨事件数据现在可存储用来创建这些数据的库和暴雨示意图的名称，因而，可以更轻松地了解其创建方式。
  • 添加了按树状顺序对相关水力数据表进行排序的功能。

建模增强功能

水力（暴雨和污水）元素的特征定义现在支持选择一部分包含可用的用户数据扩展 (UDX)。例如，可以为管道垫层设置两个 UDX 字段：一个用于输水排水管，一个用于过滤排水管，并为每个导管特征定义选择相应的 UDX。这样可以确保只有有效的垫层类型才可用于各种类型的导管。

缺陷

  1. 解决了几个有关接在地形模型后面的导管（例如，通信管线）的功能问题。
  2. 更改导管的起始或停止节点时出现的问题已得到解决，可确保纵断面模型正确反映新的节点数据。
  3. 解决了一些问题，可防止节点顶部上升到参考地形模型或网格上方，并且可确保在导管大小更改时节点底部会正确更新。
  4. 以下问题已得到解决：相对网格放置汇水井时，会为其设置错误的纵向斜坡。在此版本中，相对网格或地形模型放置的汇水井将从该表面获取其纵向斜坡。如果希望从线性元素（排水槽或路缘线）中读取纵向斜坡，则选择该元素作为高程的参考。
  5. Update 2 中引入了一项功能，它支持仅使用单个单元（例如端墙）来支撑两个高程点的节点特征定义，因此，可以为其分配单独的地面和?底标高。这适用于相对地形模型放置的节点，但不适用于按输入的高程放置的节点，这一问题现在也得到了解决。
  6. 导致单元的隐藏部分显示出来的问题已得到解决。此问题出现在以下情况下：单元是使用 MicroStation V8i 中的布尔运算创建而成，并且设置了用于保留原始元素的选项。对于在 MicroStation CONNECT Edition 中创建的单元，原始元素始终会得到保留。无论如何，在 MicroStation 中看起来正常的单元在作为节点的一部分放置时，将会看起来不正常。
  7. 节点的拉伸部分现在可以正确使用底部单元的元素模板中定义的材料。
  8. 以下异常情况已得到解决：找不到连接到单元的材料。

Update 2

普遍增强

  • 将 Power Platform 更新到 Update 7。有关详细信息，请参考 MicroStation 帮助的新增功能。
  • 更新了 Bentley Descartes Connect Edition Update 2。
  • 更新了 gINT Civil Tools CE Update 1。
  • 安装程序现在使用“按需”技术。

测量增强功能

  • 添加了地形测量功能。

地形增强功能

  • 水膜效应功能（技术预览）。

几何图形增强功能

  • “简化几何图形”工具可用于为平面和纵面几何移除内部和外部参考规则。
  • 增强了“重新定义复合体 (Redefine Complex)”，该功能现在也适用于纵面几何。
  • 可以在放置时不规定捕捉，并在放置后移除捕捉。
  • 可以导入/导出 GENIO 格式。
  • 添加了通过三维模型创建动态纵断面剖切并在纵断面视图中显示的功能（技术预览）。
  • 现在可以调整“特征定义”下拉列表的大小。

建模增强功能

  • 扩展了翻转约束，可以接受参考斜率超出范围的有条件结果。
  • 增强了“编辑超高规则文件”工具。
  • 为超高中的曲线调整添加了其他全局变量。
  • 自动参考三维模型现在会缺省打开“启用捕捉 (Enable Snap)”。
  • 添加了对地面提取实景网格进行对准和轮廓构建的功能（技术预览）。

绘图制作和标注的增强功能

  • 将表格数据添加到了横截面和纵断面图纸。
  • 添加了斜坡指示符和 tad 极点。
  • 添加了用于为平面图创建矩形命名边界的方法。
  • 添加了可以在横截面图纸上自定义横截面间距的功能。

地下公共设施增强功能

  • 现在，可以计算溢流所形成的一维流动路径和水塘。
  • “土木纵断面模型”现在显示水力导管的水力和能量坡度线。
  • Haestad 横截面和渠道元素类型已得到实施。
  • 支持使用单一三维单元（例如端墙）建模的节点具有不同的地面高程和?底高程。
  • “设置特征定义”命令现在可用于节点、导管和汇水区元素类型。
  • 新增用于在多种场景中查找临界暴雨事件的命令。
  • 可以导入和导出 WinDes MDX 文件格式。
  • 支持“英国输入时间”计算方法。
  • 现在，支持与 SewerCAD 和 SewerGEMS 相同的废水节点类型，以便协助对污水系统进行水力设计。
  • 添加了新功能，可以仅对水力导管使用 Haestad 尺寸。以前，在放置导管时，使用的是特征定义的导管表中的尺寸集，进行水力计算时，使用 Haestad 尺寸。有关详细信息，请参考“地下公共设施”帮助的新增功能。
父主题: OpenRoads Designer CONNECT Edition帮助
父主题: 自述


入门

屏幕提示
操控器和图柄
土木消息中心
自定义对话框
父主题: OpenRoads Designer CONNECT Edition帮助


屏幕提示

所有土木工具都会显示屏幕提示，用于接受在创建各个元素时所需的输入。

示例：两点间直线

1.第一个提示针对线的起点，显示在光标旁。

2.第二个提示针对终点，也显示在光标旁。

动态反馈

动态反馈 在创建元素时显示。它是另一种让您专注工作的同时提供有用信息的方法。在创建元素时提供此信息有助于您在短时间内做出更好的设计决定。

示例：按点创建弧

在创建弧时，请注意显示弧半径、弧长和中心点的动态反馈。

父主题: 入门


操控器和图柄

当选择由“土木几何图形”工具创建的任何元素后，将动态显示某些操控器。这些操控器因元素类型而异。

示例：两点间直线

操控器的呈现方式如下：

  1. 文本操控器 - 单击即进入可编辑状态，供您键入新值。上图中的距离和方向文本操控器便是此类示例。
  2. 拖曳图柄 - 单击并拖曳这些图柄可重新定义元素。
    • 箭头形拖曳图柄 - 重新定义一个或多个方向受约束的点。在之前的示例中，平行箭头（与直线平行）约束为仅更改距离；垂直于直线的箭头约束为仅更改方向。
    • 圆形拖曳图柄 - 不受约束移动点。
    • 间隔拖曳图柄（未显示）- 每次对土木元素使用 MicroStation 修改命令之一时，均会显示此类拖曳图柄。此拖曳图柄用于更改间隔终点的位置。
  3. 捕捉图标 - 如果捕捉创建了一个点，操控器会显示为一个圆，旁边有相应的捕捉图标。
    • 将鼠标悬停在终点上会显示拖曳图柄，随后可按上面所述正常使用这些图柄。利用显示的图柄会移除捕捉，并对点应用一个新约束。
  4. 土木精确绘图约束 - 使用土木精确绘图约束创建的点将以文本操控器的形式显示相应的土木精确绘图信息。将鼠标悬停在点上会显示拖曳图柄，随后可按上面所述正常使用这些图柄。利用显示的图柄会移除精确绘图约束，并对点应用一个新约束。

属性

属性的工作方式与操控器类似，也会显示设计意图和规则数据。元素信息中的属性窗格显示用于创建元素的数据。您可以编辑属性窗格中的大部分数据来更改元素定义。

具有正常输入的直线

第一个点由关键点捕捉创建的直线

第一个点由土木精确绘图（桩号-偏移）创建的直线

元素信息还显示元素是否与任何其他元素相关。例如，元素之间的圆弧将与用于定位圆弧的两个参考元素相关。您可以在窗格顶部的树视图中选择这些元素，必要时还可以查看和更改其属性。

“取决于”部分用于检查或编辑相关元素。

操控器 - 垂直

在无任何捕捉也无任何土木精确绘图约束的情况下放置直线时，您将看到屏幕上的操控器。这些操控器可用于编辑直线，如下所述：

  • 单击长度和斜率文本操控器后可以编辑值。
  • 将鼠标悬停在夹点上时，将平行于直线显示一个箭头操控器；使用此箭头操控器可将直线修剪或延长到所需长度。
  • 使用垂直于直线的终点箭头可旋转直线（保持长度不变并更改斜率）。
  • 中点处的垂直箭头可用于平行移动直线。
  • 端点处的夹点可用于移动点但不约束长度或斜率。
  • 中点处的夹点可用于整体移动直线。

捕捉直线终点后，正常的操控器会变为捕捉操控器。在插图中，左侧的端点由关键点捕捉，因此有一个指示捕捉类型的图标。

  • 您可以通过单击并拖曳的方式在空间中移动捕捉的端点。这会移除捕捉，并创建新的终点位置，此位置可能是数据点、其他捕捉或土木精确绘图输入。
  • 如果将鼠标悬停在捕捉的终点夹点上，将显示正常的操控器供您修剪、编辑或旋转直线。此操作还会移除捕捉。
  • 同样，当直线终点由土木精确绘图创建时，正常的操控器会变为单个夹点和精确绘图操控器。
  • 精确绘图操控器为文本标签，您可以单击它们并对其进行编辑。
  • 将鼠标悬停在夹点上可显示用于旋转、修剪和延伸功能的正常操控器。精确绘图输入会随之变为新的输入值。
父主题: 入门


土木消息中心

对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

Bentley 土木消息中心对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。

消息中心可以浮动，也可以停靠和固定。

土木消息中心包含四种类型的消息：

  • MicroStation - 复制 MicroStation 在其自己的消息中心显示的所有消息

  • 错误 - 显示在土木工具中找到的需要注意的严重问题

  • 警告 - 显示应该调查的不太严重的错误

  • 消息 - 显示有关土木工具的信息性消息

可以通过单击标题来隐藏消息类型。在上图中，错误和警告显示（用橙色背景表示），MicroStation 和信息性消息隐藏。左侧有一个“全部隐藏”按钮可以隐藏所有类型的消息。

MicroStation 消息

MicroStation 消息是也会出现在 MicroStation 消息中心的消息的镜像。为了方便起见，这些消息已复制到土木消息中心。

错误

错误是需要注意的严重问题。以下列表显示了错误示例。

  • 曲线半径低于分配的设计标准的最小值

  • 将数据保存到本地坐标几何数据库时出现问题

警告

警告是不太严重、但仍需注意的问题。以下列表显示了警告示例：

  • 在不包括曲线的情况下，超出路线中的最大偏差。

  • 超出最大或最小曲线或切线长度。

消息

消息仅是信息性消息。

相应的屏幕标志符号

除 MicroStation 消息之外，消息中心显示的消息都附有屏幕标志符号 以指示出现问题的位置。

将鼠标悬停在标志符号上方可获得问题的弹出式摘要。

右键单击消息中心以缩放至出现问题的位置。当多条消息分布在一个大项目中时，这会很有帮助。

右键单击并选择“缩放至”。

父主题: 入门


自定义对话框

土木几何 界面的屏幕性质可明显减少对话框的需求。对话框的一个用途是确定在光标处提供的提示。例如，如果使用“插入直-缓-圆-缓-直曲线”并关闭过渡和变截面选项，则不会在光标提示中询问它们的值，也不会创建过渡和变截面。

对话框自定义

通过自定义各种常用条目的对话框，可以进一步采取操作。自定义对话框条目可以保存在 DGN 库中。例如，使用“两点间弧”工具，可能定期需要创建两种不同类型的尽端路，一种半径为 40，另一种半径为 50。

右键单击该对话框并选择“自定义”。

这将打开自定义实用工具。

使用自定义实用工具将“放置”方法设置为“居中”、“半径”并将其隐藏在对话框中，将半径值锁定为 50，并隐藏所有其他参数。

在图像中，单击“弧长”的状态列以选择“隐藏”选项。

对于半径，输入值 50，并将单击状态设置为“在光标处提示锁定值”。

单击“保存”按钮以保存自定义设置。

此自定义工具的对话框仅显示半径，唯一需要的输入是拾取中心点、起点和终点。

另存为

单击对话框自定义设置上的“另存为”按钮时，可以将自定义对话框保存到 DGN 库。

还可以在自定义工具上使用自定义名称创建另一个半径为 40 的自定义工具，然后在 DGNLIB 中，在任务导航器中有一个自定义 CulDeSac 组，可以从中选择 40 半径或 50 半径。

父主题: 入门


功能区

土木工作流
功能区界面
功能区选项卡
父主题: OpenRoads Designer CONNECT Edition帮助


土木工作流

OpenRoads Designer 工作流选项卡在以下情况下显示：从快速访问工具栏中选择 OpenRoads Designer 建模或 OpenRoads Designer 制图。选项卡、工具组和工具按工作流从左到右排列。

父主题: 功能区


功能区界面

功能区界面包含以下部分：

  1. “文件”选项卡 - 用于打开后台视图，可在其中执行不同的操作，例如管理文件及其设置、导入和导出文件、访问帮助等。
  2. 快速访问工具栏 - 包含用于选择工作流的选项和其他常用命令。
  3. 其他选项卡 - 包含一个或多个组。
  4. 组 - 一组密切关联且带标签的命令或工具。
  5. 搜索功能区 - 输入要在功能区中搜索的单词或短语。
  6. “登录”标志符号 - 以 CONNECTED 用户身份登录时显示。
  7. 最小化 - 通过单击 [image] 最小化功能区。
  8. 帮助 - 通过单击 [image] 从功能区访问 MicroStation 帮助。

提示: 要从后台视图快速返回视图窗口，请单击“主页”选项卡或按 <Esc>。

注释: 虽然功能区界面中未显示工具箱，但可从工具箱对话框（通过文件 > 设置 > 用户 > 工具箱访问）打开它们。

还可以参考 LEARNServer 课程“功能区：MicroStation CONNECT Edition 的新界面”。

功能区控制选项
快速访问工具栏
父主题: 功能区


功能区控制选项

该功能区提供了许多控制选项，旨在帮助您找到完成任务所需的工具。

选项卡

功能区的顶部是一系列包含组中相关工具的选项卡。从快速访问工具栏中可用的工作流进行选择时，系统将会加载选项卡。

“文件”选项卡和后台视图

最左侧的功能区选项卡包含一系列工具和设置对话框。通常，这些工具和对话框与以前“文件”、“工作空间”和“帮助”菜单中的项相关。

组

每个选项卡内均有许多组，其中包含与该选项卡中隐含的任务相关的工具。

面板

面板是用于对按钮进行分组的容器。例如，随附的绘图 > 视图 > 工具功能区组中的 Mstn.View.Rotation2D.Panel 和 Mstn.View.Rotation3D.Panel。面板可以水平堆叠在垂直面板内，这样面板内所含的按钮将分行显示。<空间> 功能区组弹出菜单中采用的便是这种方式。

分割按钮

分割按钮包含一系列下拉列表形式的工具。下拉箭头的左侧还会出现激活工具的图标。单击该图标将激活特定的工具。如果从下拉列表中选择任何其他工具，选定工具将替换激活工具。

下拉式按钮

下拉式按钮仅包含一系列下拉列表形式的工具。

工具或按钮

每个组内均有工具或按钮图标。选择一个图标将打开相关的工具设置窗口或对话框。

功能区图库

功能区图库以图形方式显示功能区中的一系列相关项。例如，“材质”图库（可视化 > 材质 > 应用）将显示各种不同的材质。您可以在该图库中单击所需材质将其选定。如果该图库中有许多项，您还可以滚动浏览该图库或将其展开，以便在展开的窗格中显示其余项。

对话框启动器

某些组的右下侧有一些小按钮，用来打开与该组中的工具相关的对话框。通常，这些对话框是设置对话框。例如，“尺寸标注样式”对话框可以使用“尺寸标注”组中的对话框启动器打开。

增强的工具提示

将指针置于工具和对话框启动器等功能区项的上方时，将显示增强的工具提示，其中会显示项名称以及概要描述。

调整组大小

调整应用程序窗口的大小时，功能区会自动调整组大小。

组弹出菜单

右键单击某个组时，将列出该组中可用的工具。该组中显示的工具将带有复选标记。通过在弹出菜单中切换选择工具，您可以显示/隐藏这些工具。如果该组包含分割按钮，则分割按钮中的工具将在弹出菜单中列为子菜单。此外，您也可以显示/隐藏这些子菜单中的工具。

搜索功能区

要在多个选项卡和功能区工作流中查找工具或对话框，搜索功能区是一种更为简单的方法。有关进一步详细信息，请参阅“使用搜索功能区”。

最小化功能区

单击 [image] 将最小化功能区。再次单击同一图标可展开功能区。

访问帮助

单击 [image] 将打开 MicroStation 帮助。

父主题: 功能区界面


快速访问工具栏

“快速访问工具栏”包含工作流下拉列表和其他常用命令。

工作流

根据显示的功能区选项卡设置工作流。缺省情况下，以下工作流可用：

工作流 | 描述
OpenRoads Designer 建模 | 访问 OpenRoads Designer 工具。
OpenRoads Designer 绘图制作 | 访问 OpenRoads Designer 绘图制作工具以及绘图和注释工具，用于主要被视为制图操作的基本非土木功能。
地理技术 | 访问 gINT 土木工具，这是 gINT 的附加组件，可将数据从 gINT 数据库导入 CAD 环境中，从而进行高级审查和分析。
实景建模 | 访问可对点云和实景网格执行各种操作的工具。Bentley Descartes 工具位于应用程序功能区的“实景建模”工作流中。
绘图 | 显示绘图和注释工具，并用于所有常见功能，如放置线、连接参考以及放置注释等功能，这些往往被视为制图操作。
建模 | 显示曲面和实体建模工具，并用于放置和构造曲面、实体、网格和参数化特征。
可视化 | 显示可视化工具，并用于生成渲染、应用材质以及设置相机视图和照明。
任务导航 | 显示可选择的任务选项。通过此工作流，可以在此版本中使用于先前版本中创建的任务和工作流。
地下公共设施 | 访问 Subsurface Utilities Design and Analysis (SUDA) 工具，从而支持土木设计师和公共设施协调员对地下特征进行建模，以便进行规划、制定设计决策、进行水力设计。

常用命令

有关这些命令的详细信息，请参考 MicroStation 帮助。

父主题: 功能区界面


功能区选项卡

功能区的顶部是一系列选项卡。“文件”选项卡始终会显示。它包含“后台”视图。从快速访问工具栏中选择工作流时，将打开工作流选项卡。每个工作流选项卡均包含多个工具组，其中包含用于完成工作流相关任务的工具。

“文件”选项卡和后台视图
主页
地形
几何图形
廊道
模型细部设计
绘图制作
测量
父主题: 功能区


“文件”选项卡和后台视图

“文件”选项卡会打开后台视图，您可以在该视图中执行管理文档和设置、导入和导出文件、访问帮助等不同的操作。

针对其中大部分操作的帮助位于 MicroStation 帮助文件中，但有一些相关的土木操作。

工具

选项 | 描述
许可证管理 | 用于将受 SELECTserver 许可证管理器并发许可证控制的应用程序和程序许可证检出到无法持续连网访问 SELECTserver 的系统（例如，工作站、便携式 PC 和便携式设备）。
设置 > 用户
选项 | 描述
精确绘图设置 | 包含与精确绘图点输入工具相关的控制选项。有关详细信息，请参阅 MicroStation 帮助。
自定义功能区 | 用于自定义功能区。有关更多详细信息，请参阅 MicroStation 帮助。
资源管理器设置 | 用于为“资源管理器”对话框设置不同的选项。
首选项 | 用于设置用户首选项 - 可控制产品运行方式的设置。
工具框 | 用于打开工具箱，其中包含各种土木工具。有关更多详细信息，请参阅 MicroStation 帮助。

设置 > 文件

选项 | 描述
设计文件设置 | 用于更改设计文件特定的设置。

发布 i-model

选项 | 描述
发布 i-model | 用于将设计文件转换为 .i.dgn 文件。在 MicroStation 中能够打开的所有设计文件均可转换为 i-model。有关更多详细信息，请参阅 MicroStation 帮助。

帮助

选项 | 描述
帮助内容 | 在缺省 Web 浏览器中打开 MicroStation Web 帮助。
RSS 阅读器 | 打开 RSS 阅读器。
自述 | 打开产品自述。
关于 OpenRoads Designer | 用于显示产品相关信息，包括版本和许可信息。
父主题: 功能区选项卡


主页

属性
基本
选择
模型分析与报表
模型导入/导出
OpenRoads Designer 帮助
父主题: 功能区选项卡


属性

功能区：主页

请参阅属性。

父主题: 主页


基本

“基本”组是一个启动常用工具的地方。

功能区：主页

资源管理器
连接工具
层显示
层管理器
属性
详细
父主题: 主页


选择

选择组用于选择和取消选择要修改或操作的元素。

功能区：主页

设置

描述

选择元素

通过定义区域或通过绘制与元素相交的线，以每个元素为基础选择和取消选择元素。

全选

选择设计中的所有元素。

全部不选

取消选择设计中的所有元素。

围栅工具

  • 放置围栅
  • 修改围栅
  • 操作围栅内容
  • 删除围栅内容
  • 打散围栅内容
  • 将围栅保存到文件
  • 命名边界

放置围栅 - 用于放置围栅。

修改围栅 - 用于移动围栅或修改它的一个顶点。

操作围栅内容 - 用于移动、复制、旋转、镜像、缩放或拉伸围栅内容，这些内容由围栅和（拉伸除外）围栅（选择）模式定义。

删除围栅内容 - 用于删除围栅内容。

打散围栅内容 - 用于将围栅中的内容打散为其组件。

将围栅保存到文件 - 用于将激活围栅的内容复制或移动到新的 DGN 或 DWG 文件。

命名边界 - 使用“命名边界”对话框管理命名边界和边界组。

父主题: 主页


模型分析与报表

功能区：主页

报告
土木分析
廊道报表
父主题: 主页


模型导入/导出

功能区：主页

地形导入
导入几何
导入 IRD
父主题: 主页


OpenRoads Designer 帮助

功能区：主页

设置 | 描述
OpenRoads Designer 帮助 | 访问 OpenRoads Designer 帮助
打开 RSS 阅读器 | 用于从 Bentley 网站获取所有更新和新闻
“RSS 阅读器”对话框
父主题: 主页
父主题: 主页


地形

创建
编辑
分析
杂项
加标签
父主题: 功能区选项卡


创建

功能区：地形

设置

描述

从文件

通过从外部文件导入来创建地形模型。支持多种文件格式，如 LandXML、Lidar (* .las) 和原有产品 （InRoads、GEOPAK 和 MX）。

从图形过滤器

一种自动存储图形元素搜索设置的方法，用于自动“按元素创建地形模型”。使用“图形过滤器管理器”存储的设置来创建地形。

从元素

从三维图形元素创建地形模型。

其他方法

  • 按文本内插创建
  • 从 ASCII 文件创建地形模型
  • 从点云创建
  • 创建剪切的地形模型
  • 创建复合地形模型
  • 创建增量地形模型
  • 创建廊道备选表面

按文本内插创建 - 从还包含高程标签的二维图形中创建地形模型。

从 ASCII 文件创建地形模型 - 从还包含高程标签的二维图形中创建地形模型。

从点云创建 - 从 MicroStation Point Cloud 数据中创建地形模型。

创建剪切的地形模型 - 通过剪切现有地形模型和给定可选横向或竖向偏移来创建地形模型。

创建复杂地形模型 - 通过合并/附加多个地形模型来创建新的复合地形模型。

创建增量地形模型 - 通过两个地形模型之间的差异或地形模型与平面之间的差异（高程）来创建新的地形模型。

创建廊道备选表 - 根据廊道模型中的用户指定点沿任何给定路径创建地形模型。

父主题: 地形


编辑

功能区：地形

设置

描述

设置激活

设置激活地形模型文件。激活地形模型是默认情况下在轮廓模型中显示的模型，是廊道建模器的默认目标。

编辑模型

使用几个简单的编辑工具打开工具设置；删除、插入和移动顶点，删除三角形和交换线。

编辑复合地形模型

通过更改合并顺序编辑复杂的地形，更改合并或附加方法以及添加或移除组件地形模型

特征管理

  • 添加特征
  • 删除特征

添加特征 - 在使用创建命令创建的地形中添加更多特征。例如，从切断线创建地形，然后添加点。

删除特征 - 从“添加特征”或“从元素创建”添加的地形中移除元素。

边界选项

  • 添加边界
  • 删除边界

添加边界 - 用于从地形中提取隐含或存储的边界，并能够编辑/规则化边界。

移除边界 - 从无规则的地形模型中移除边界元素。

转换

用于重定位地形模型、几何点、平面和纵面几何图形以及图形。
父主题: 地形


分析

“分析”组用于……

功能区：地形

设置

描述

点

  • 测点间分析
  • 测点分析
  • 反转点

测点间分析 - 报告地形模型上的 2 个点位置之间的信息（高程差、长度和斜率）。

测点分析 - 报告有关地形模型中用户指定的点位置的信息（高程、斜率、等高线、斜坡方向）。

反转点 - 报告有关地形模型中用户指定的点位置的信息（高程、斜率、等高线、斜坡方向）。支持几种类型：线性、弧、径向、垂直和按元素。二维和三维视图/模型中均支持该工具。结果显示在光标提示符和（可选）Civil 报告浏览器中。

土方量

  • 创建挖方和填方土方量
  • 分析土方量

创建挖方和填方土方量 - 计算两个曲面（通常是现有地形和一个曲面（地形或网格））间的挖方和填方土方量，并使用土方量特性创建三维网格实体。

分析土方量 - 计算 2 个地形模型或一个地形模型和平面之间的土方量（高程）。能够在一个区域（围栅）或多个区域中进行处理并计算一系列高程内的土方量。也可以选择挖方和填方系数。

水力

  • 分析水塘
  • 分析轨迹边坡

分析水塘 - 通过地形模型上的数据点位置分析水塘（低点）的地形模型（土方量、区域最大深度）。

分析轨迹边坡 - 沿曲面的轨迹遵循用户指定的斜率值或最大斜率。可以追踪上游或下游。

报告

  • 特征集交叉报表
  • 冲突点报表

特征集交叉报表 - 定位相交线特征，例如切断线或等高线。

冲突点报表 - 报告用于创建具有重复点的地形模型的源数据（由具有相同或不同高程的 X, Y 位置定义）。

水膜效应

分析地形模型可能的水膜效应条件。

视距分析

根据指定的设计地形或廊道的顶网格和可选的现有曲面或网格分析沿路线或廊道控制路线的视线距离。
父主题: 地形


杂项

杂项组具有地形导出工具和图像过滤器过滤器。

功能区：地形

设置

描述

图形过滤器管理器

为各个地形特征创建单独的过滤器，并合并这些过滤器以形成过滤器组。

导出到文件

标识将土木地形模型导出到外部文件的要求。

地形模型可以导出为：

  • GEOPAK (TIN)
  • Inroads (DTM)
  • MX (FIL)
  • LandXML 版本 1.2
父主题: 地形


加标签

加标签组用于……

功能区：地形

设置 | 描述
标注地形等高线 | 在选择的等高线上为标高放置附加标签。
标注地形位置 | 在地形模型上的特定位置注明标高。
父主题: 地形


几何图形

通用工具
平面
纵断面
父主题: 功能区选项卡


通用工具

功能区：几何图形

设置

描述

导入/导出

  • 导入几何
  • 从 ASCII 导入平面几何
  • 从 ASCII 导入纵面几何
  • 导出几何图形

如果坐标几何数据库中存储的图形元素为 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素，则可导入这些元素。

通过文本向导从 ASCII 文件中导入平面几何元素。

通过文本向导从 ASCII 文件中导入纵面几何元素。

用于将选定土木几何元素导出到以下某一坐标几何数据库中：MX FIL 文件、InRoads ALG 文件或 GEOPAK GPK 文件。

设计元素

  • 设置激活纵断面
  • 设置激活地形模型
  • 通过图形过滤器选择
  • 创建土木规则特征

指定多个潜在纵断面元素中的哪个元素将驱动三维模型。

指定多个潜在地形模型中的哪个模型位于激活文件或参考文件中。

激活地形模型是默认情况下在轮廓模型中显示的模型，是廊道建模器的默认目标。

将与“图形过滤器”匹配的所有元素放入 MicroStation 选择集中。

标准

  • 设置设计标准
  • 设计标准工具栏
  • 设置特征定义
  • 特征定义工具栏
  • 匹配特征定义
  • 土木消息中心
  • 设置元素信息

用于为先前没有设计标准的元素分配设计标准。“设计标准”工具栏中的激活设计标准是要分配给选定元素的标准。

为土木几何元素分配设计标准或更改元素的设计标准。

为土木几何元素分配特征定义，或更改元素的特征定义。

使用“特征切换栏”上的命令来激活或取消激活影响各种几何图形命令的设置。

将某个元素的特征提供给另一元素。

对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。

在绘图的特定元素上添加您自己的批注。

土木切换

  • 土木精确绘图
  • 激活规则
  • 取消激活规则
  • 删除规则
  • 取消激活参考规则

激活或取消激活精确绘图。

移除选定元素的规则。当规则移除后，操控器不可用于编辑且元素不会更新。

取消激活选定元素的规则。

报告

  • 平面曲线数据表
  • 纵断面报表
  • 合规报表
  • 地图检查报表
  • 桩号偏移报表
  • 点特征桩号偏移高程报表
  • 桩号基准报表
  • 超高报表

从所选土木平面几何元素生成报告。

创建包括有关所选纵面路线的信息的 XML 报告数据文件。

根据一组闭合土木平面元素和参考元素生成报告。

根据绘制的数据（而不是软件存储的内部精度）生成包含精度信息的报告。

创建包含所选平面几何元素的桩号偏移数据的报告。

创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。

创建包含所选平面几何元素的桩号偏移数据的报告。

可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。
父主题: 几何图形


平面

功能区：几何图形

设置

描述

直线

  • 直线
  • 任意线连接
    • 切线连接
    • 缓和曲线连接
    • 曲线连接
    • 定角度连接
    • 任意线连接
  • 两弧切线连接
  • 任意线延长
    • 切线延长
    • 缓和曲线延长
    • 曲线延长
    • 按角度起点元素
    • 任意线延长
  • 两点间倒角

直线 - 在用户定义的两个点之间创建线。

与参考元素成一定倾斜构造线

切线连接 - 以零度倾斜角度创建缓和曲线过渡到另一元素的线，仅当“连接 (To elemen)”为曲线、“偏移”锁定为零时适用。

曲线连接 - 以零度倾斜角度创建弧过渡到另一元素的线，仅当“连接 (To elemen)”为曲线、“偏移”锁定为零时适用。

定角度连接 - 以用户定义的倾斜角度创建没有任何过渡的线，“偏移”锁定为零。

任意线连接 - 与参考元素成一定倾斜构造线。

两弧切线连接 - 在先前放置的弧之间构造线。

切线延长 - 从另一元素以零度倾斜角度创建没有任何过渡的线，仅当“延长 (From element)”为曲线、“偏移”锁定为零时适用。

以零度倾斜角度创建从另一元素缓和曲线过渡的线，仅当“延长 (From element)”为曲线、“偏移”锁定为零时适用。

曲线延长 - 以零度倾斜角度创建从另一元素弧过渡的线，仅当“延长 (From element)”为曲线、“偏移”锁定为零时适用。

定角度延长 - 以您定义的倾斜角度创建从另一元素没有任何过渡的线，“偏移”锁定为零。

任意线延长 - 以一定倾斜从基准元素构造线。

两点间倒角 - 切平一个角，例如，它可通过在元素之间插入一条线来改变现有的交点。

弧

  • 圆
  • 两点间弧
  • 圆弧连接
    • 简单圆弧切向连接
    • 双圆弧曲线连接
    • 圆+缓和曲线连接
    • 圆+双缓和曲线连接
    • 圆弧连接
  • 两弧间弧
  • 圆弧延长
    • 简单圆弧切向延长
    • 双圆弧组合延长
    • 圆+缓和曲线延长
    • 圆+双缓和曲线延长
    • 圆弧延长
  • 插入直-缓-圆-缓-直曲线
    • 插入简单切向圆弧
    • 插入缓-圆-缓曲线
    • 插入直-圆-直曲线
    • 插入三心圆曲线
    • 插入两心圆曲线
    • 插入直-缓-圆-缓-直曲线
  • 任意元素与弧之间的复杂过渡

圆形 - 绘制一个圆形。

两点间弧 - 创建两点之间的弧。

简单圆弧切向连接 - 创建与另一元素没有任何过渡的简单半径弧，“偏移”锁定为零。

双心圆弧切向连接 - 创建与另一元素弧过渡的弧，“偏移”锁定为零。

圆+缓和曲线连接 - 创建与另一元素缓和曲线过渡的弧，“偏移”锁定为零。

圆+双缓和曲线连接 - 创建反向缓和曲线过渡到另一元素的弧，仅当“连接 (To element)”为反向曲线、“偏移”锁定为零时可应用。

圆弧连接 - 基于控制一端切线的选定基准元素构造弧。

两弧间弧 - 在先前放置的弧之间构造弧。此工具能够选择在基本弧和构造弧之间应用后过渡段和/或前过渡段。

简单圆弧切向延长 - 基于控制一端切线的选定基准元素构造弧。

双心圆弧组合延长 - 创建从另一元素弧过渡的弧，“偏移”锁定为零。

圆+缓和曲线延长 - 创建从另一元素缓和曲线过渡的弧，“偏移”锁定为零。

圆+双缓和曲线延长 - 创建从另一元素反向缓和曲线过渡的弧，仅当连接为反向曲线、“偏移”锁定为零时可应用。

圆弧延长 - 基于控制一端切线的选定基准元素构造弧。

简单圆弧 - 创建两端均没有缓和曲线或渐变的半径弧，“偏移”锁定为零。

插入缓-圆-缓曲线 - 创建两端均有缓和曲线过渡、但没有渐变的半径弧，“偏移”锁定为零。

插入直-圆-直曲线 - 创建两端均有渐变过渡、但没有过渡的半径弧，“偏移”锁定为零。

三心圆弧 - 创建两端有半径过渡的半径弧，结果将生成三心圆曲线，“偏移”锁定为零。

双心圆弧 - 创建一端有半径过度的半径弧，结果将生成双心圆曲线，“偏移”锁定为零。

插入直-缓-圆-缓-直曲线 - 在先前放置的元素之间构造弧。

点

  • 点
  • 插入点

点 - 构造土木点元素。

等间隔点 - 在视图中插入指定数量的点，和/或遵循指定的间隔。

偏移和渐变

  • 整路段等距偏移
  • 局部路段等距偏移
  • 局部路段渐变偏移
  • 局部路段按定比率渐变偏移

整路段等距偏移 - 按常量值沿整个长度偏移所选元素

局部路段等距偏移 - 按常量值沿用户选定的桩号范围偏移所选元素

局部路段渐变偏移 - 按可变数量沿用户选定的桩号范围偏移所选元素

局部路段按定比率渐变偏移 - 按比率沿用户选定的桩号范围偏移所选元素

反向曲线

  • 按定角度反向曲线连接
  • 按定半径比率反向曲线连接
  • 按带切线的反向曲线连接
  • 按定角度线连接
  • 自由反向曲线连接

按定角度反向曲线连接 - 在先前绘制的元素之间构造反向曲线。

按定半径比率反向曲线连接 - 创建反向曲线，其中第二曲线半径与第一曲线半径成比例。“偏移”锁定为零。

按带切线的反向曲线连接 - 创建反向曲线，其中两个半径相等，您可以指定曲线间的切线长度，“偏移”锁定为零。

按定角度线连接 - 以第一次拾取元素时测量的偏转角创建简单线性元素。

自由反向曲线连接 - 在先前绘制的元素之间构造反向曲线，两条曲线之间的切线长度可选。

缓和曲线

  • 缓和曲线延长
  • 插入缓和曲线

缓和曲线延长 - 使用此基准元素确定一端切线，从先前放置的元素构造缓和曲线。

插入缓和曲线 - 在两个确定切线的基准元素之间构造一条（或多条）缓和曲线。

修改

  • 起点桩号
  • 添加断链
  • 复制元素
  • 插入圆角
  • 附加元素

起点桩号 - 将桩号设置分配给元素。

添加桩号 - 在元素上的指定位置定义桩号。

复制元素 - “复制元素”工具仅创建可见几何图形的新实例。

插入圆角 - 将曲线插入先前创建的元素中。

附加元素 - 通过在先前建立的复合元素中附加其他元素来构造复合元素。

复杂几何图形

  • 按元素复合
  • 交点法创建路线
  • 复合重新定义
  • 按最佳拟合定义
  • 按模板创建三维几何模型

按元素复合 - 通过将先前放置元素按顺序连接来构造其复合元素。

交点法创建路线 - 基于用户的 PI（交点）位置输入，使用曲线创建线性元素。对于 PI 处没有曲线的情况，曲线可以包括过渡段或将半径设置为零。

按重新定义复合 - 在与原始元素相距指定距离处复制元素。

按最佳拟合定义 - 构造与选定线性对象定义的过程最佳拟合的元素。

按模板创建三维几何模型 - 用于访问“拾取模板”对话框，然后在相对于参考元素的绘图中插入所选模板。在模板中特征定义设置为创建几何的任意点，都将以模板定义的偏移生成偏移元素构造。

父主题: 几何图形


纵断面

功能区：几何图形

设置

描述

打开纵断面模型

生成一个视图，该视图在纵断面中显示所需特征，从而使“纵面几何”工具能够与所选特征进行交互。

设置激活纵断面

指定可能会驱动三维模型的几个纵断面元素。结果是在三维模型中创建三维样条，表示平面路线与设计纵断面的组合。

元素纵断面

  • 插入过渡纵断面
  • 按固定高程绘制纵断面
  • 基于固定点按坡率绘制纵断面
  • 基于参照纵坡按固定坡度绘制纵断面
  • 基于参照纵坡按可变坡度绘制纵断面
  • 基于元素按竖向偏移绘制纵断面
  • 按三维元素绘制纵断面
  • 创建土木规则特征

通过匹配相邻元素的坡度和高程来定义元素的纵断面。根据相邻元素的配置，创建单个凸曲线/凹曲线或自由反向曲线连接。

按给定高程为整个元素定义平面纵断面。

通过计算相对于三维点的坡度来定义元素的纵断面。

通过使用设计纵断面投影一个元素的固定坡度来定义另一个元素的纵断面。

通过使用设计纵断面投影一个元素的可变坡度来定义另一个元素的纵断面。此命令与“按坡度绘制纵断面 (Profile by Slope)”命令的区别仅在于您可以选择其他选项。具体来说，您可以定义一个范围而不是整个元素，并且有多种坡度方法可供使用，而不是只有固定坡度。

根据竖向偏移定义元素的纵断面。结果与“按可变坡度绘制纵断面 (Profile by Variable Slope)”命令类似，不同的是它使用两个竖向偏移，而不是在两个坡度之间过渡。

根据绘图中的三维元素（在纵断面空间中）生成纵断面。

将土木几何图形规则分配给由土木几何图形命令以外的工具创建的元素。

直线

  • 直线坡
  • 任意坡连接
  • 任意坡延长
  • 插入切线坡

直线坡 - 在用户定义的两个点之间构造纵断面线。

任意坡连接 - 按照相对坡度从指定位置到参考元素构造纵断面线。

任意坡延长 - 按照相对坡度从参考元素到指定位置构造纵断面线。

插入切线坡 - 在先前放置的两个纵断面曲线之间构造纵断面线。

曲线

  • 按点创建竖曲线
  • 任意竖曲线连接
  • 任意竖曲线延长
  • 插入任意竖曲线

按点创建竖曲线 - 在指定点之间构造纵断面曲线。

任意竖曲线连接 - 从指定点到元素构造纵断面曲线。

纵断面曲线延长 - 在现有元素与要指定的点之间构造纵断面曲线。

插入任意竖曲线 - 在两个指定元素之间构造纵断面曲线。

复杂几何图形

  • 按竖曲线单元创建纵断面
  • 按竖交点创建纵断面
  • 按最佳拟合定义纵断面
  • 插入变坡点及竖曲线
  • 添加竖曲线单元至纵断面
  • 插入反向曲线坡
  • 纵断面偏移

按竖曲线单元创建纵断面 - 从先前放置的元素构造复杂纵断面元素。

按竖交点创建纵断面 - 构造由垂直交点 (VPI) 定义的纵断面复合体。

按最佳拟合定义纵断面 - 通过选定的纵断面构造由最佳拟合定义的纵断面复合体。

插入变坡点及竖曲线 - 将纵断面曲线插入到纵断面元素中。

添加竖曲线单元至纵断面 - 将其他元素附加到先前建立的复杂元素。

插入反向曲线坡 - 使用两条曲线之间的可选切线长度在先前绘制的元素之间构造反向曲线。

纵断面偏移 - 按照与基本元素的偏移构造纵断面元素。基本元素可以是线、弧、缓和曲线或复合体。

元素纵断面

  • 插入过渡纵断面
  • 按固定高程绘制纵断面
  • 从固定点按坡率绘制纵坡
  • 基于参照纵坡按固定坡度绘制纵断面
  • 基于参照纵坡按可变坡度绘制纵断面
  • 基于元素按竖向偏移绘制纵断面
  • 按三维元素绘制纵断面

插入过渡纵断面 - 通过匹配相邻元素的坡度和高程来定义元素的纵断面。根据相邻元素的配置，创建单个凸曲线/凹曲线或自由反向曲线连接。

按固定高程绘制纵断面 - 按给定高程为整个元素定义平面纵断面。

从固定点按坡率绘制纵坡 - 通过计算相对于三维点的坡度来定义元素的纵断面。

基于参照纵坡按固定坡度绘制纵断面 - 通过使用设计纵断面从一个元素投影固定坡度来定义另一个元素的纵断面。

基于参照纵坡按可变坡度绘制纵断面 - 通过使用设计纵断面从一个元素投影可变坡度来定义另一个元素的纵断面。此命令与“按坡度绘制纵断面 (Profile by Slope)”命令的区别仅在于您可以选择其他选项。具体来说，您可以定义一个范围而不是整个元素，并且有多种坡度方法可供使用，而不是只有固定坡度。

基于元素按竖向偏移绘制纵断面 - 根据竖向偏移定义元素的纵断面。结果与“按可变坡度绘制纵断面 (Profile by Variable Slope)”命令类似，不同的是它使用两个竖向偏移，而不是在两个坡度之间过渡。

按三维元素绘制纵断面 - 根据绘图中的三维元素（在纵断面空间中）生成纵断面。
父主题: 几何图形


廊道

创建
编辑
杂项
超高
检查
父主题: 功能区选项卡


创建

功能区：廊道

设置

描述

新建廊道

通过定义廊道名称、标识基线参考和纵断面并指定设计阶段，可以创建廊道。创建廊道后，该软件会自动前进到“创建三维路面”工具。

新建三维路面

根据桩号限制以及从当前模板库中选择的模板，为道路设计创建三维路面。

复制三维路面

作为创建和修改三维路面的替代方法，此工具将现有的三维路面复制到根据相同基线参考新定义的桩号范围中。

导入 IRD

导入（SELECTseries 2）以及 Roadway Designer (IRD) 文件中包含的以前版本的廊道。
过渡段
  • 创建过渡段
  • 编辑过渡段

根据选择先前创建的两个三维路面，在两个三维路面之间创建过渡。

修改先前在两个三维路面之间创建的过渡。
模板
  • 创建模板
  • 显示模板

打开当前模板库以添加新模板、删除或修改现有模板。

通过使用激活 MicroStation 线符，可在绘图文件中用户定义的数据点处绘制当前模板库中的选定模板。所有末端条件均会绘制，且没有标注。该绘图作为模板库文档的起点非常有用。
父主题: 廊道


编辑

设置

描述

编辑三维路面

打开当前模板库并显示包含选定三维路面的模板。

编辑
  • 创建末端条件异常
  • 创建关键桩号
  • 创建次要路线
  • 参数化约束
  • 曲线加宽
  • 点控制

定义末端条件异常，它们用于修改末端条件解的行为，而无需使用其他三维路面。

在提示廊道选择和桩号（动态输入或通过键入命令）之后，桩号将添加到廊道进行处理。这用于当项目发生特殊情况且需要将不与模板间隔重合的桩号包括在处理中时添加相应桩号。

设置次要路线的参数，用于修改横截面处理的方向。要求包括廊道选择，次要路线定义、起点和终点桩号（在仅使用部分路线元素的情况下）以及起点和终点偏移。

为替代指定的桩号范围设置约束值。

将水平控件应用于点，使其在控制路线的每条曲线处朝远离中心线的方向移动。

通过指定先前创建的廊道中的桩号范围、点的选择（来自模板中的可用点）和控件选项类型，定义廊道中水平和/或垂直控件。

廊道对象

一站式查看与廊道对象相关的数据。非常适合管理廊道数据，因为它包含三维路面、关键桩号、参数化约束、点控件、各种参考和末端条件异常，所有这些内容都在一个对话框内。

更新廊道

处理廊道以确保它为最新版本。

父主题: 廊道


杂项

功能区：廊道

设置

描述

定义目标别名

为廊道定义目标别名。处理多个曲面时可以使用目标别名创建所需结果，而不必编辑模板库中的模板。

廊道参考
  • 添加廊道参考
  • 删除廊道参考

用于向廊道中添加选定的图形元素并重新进行处理。廊道建模中通过特征成为目标的图形元素在添加为廊道参考后才能使用。示例包括路肩、路缘、人行道等。这样，用户便可以一个路面上的特定路肩为目标，同时通过将元素引用至特定廊道来忽略相邻路面上的路肩。元素可被引用至多个廊道。

用于从廊道中移除选定的图形元素（之前通过“添加廊道参考”加入的元素）并重新进行处理。

廊道剪切
  • 添加剪切参考
  • 删除剪切参考

“剪切”功能可用于在使用 MicroStation 元素或多个廊道时移除重叠区域。在下面的插图中，矩形（MicroStation 元素）被定义为廊道的剪切参考。因此，系统会“剪切”或删除矩形内廊道的所有元素，只剩下平面几何图形元素。如果处理多个廊道且某个廊道与交叉路面（由另一个廊道定义）相交，则可使用剪切来移除交叉部分内的所有重叠特征。

移除剪切参考并在无任何参考的情况下重新处理廊道模型。此操作并不删除实际的剪切参考元素。

同步模板

使用当前模板库中的同名模板更新三维路面内的模板。系统会覆盖之前对三维路面中的模板所做的全部更改且无警告。

调整竖向覆盖关系

在每个已处理的桩点处，此命令根据输入条件和模板顶部到现有地面的距离来确定理想的 PGL 点。

父主题: 廊道


超高

设置

描述
创建
  • 创建超高区间
  • 创建超高车道
  • 使用道路模板创建超高车道

为基线参考上的特定桩号范围添加超高区间（通常是每个曲线集一个）。

基于宽度和相对于基线参考的偏移创建彩色填充的车道，作为超高计算的前体。

这是一种创建超高车道的备选方法，它将使用指定模板的宽度和横坡以及超高规则文件中指定的参数。
计算
  • 计算超高
  • 编辑超高规则文件
  • 导入超高
  • 将超高指定给廊道

计算超高 - 基于规则文件计算桩号和超高过渡比率。基于横坡，将这些值扩充到超高车道、创建编辑操控器、重新着色颜色填充。

编辑超高规则文件 - 编辑 XML 格式的超高规则文件。

导入超高 - 通过 CSV 文件导入超高值。

将超高指定给廊道 - 将超高与廊道关联，这样，路面将反映超高桩号/横坡，而不是模板中的路面横坡缺省值。

插入超高桩号/横坡

将各个桩号/超高过渡（横坡）插入到之前创建和计算的超高车道。

超高编辑器

打开超高编辑器。

超高报表

创建超高 XML 报表并打开 Bentley Civil 报表浏览器。

打开超高视图

在 MicroStation 视图中打开可编辑的超高图。
父主题: 廊道


检查

功能区：廊道

设置

描述
动态截面
  • 打开横断面视图
  • 通过桩号定位横断面
  • 编辑桩号
  • 显示横断面标注
  • 移除临时尺寸标注

在选定的 MicroStation 视图中创建动态横截面视图。

使用此工具放置数据点（在平面视图中），以查看列表中未包括的桩号的动态横截面。

编辑桩号的横截面实例。

根据两个数据点将显示文本（宽度、斜率）放入动态横截面视图中。

移除使用“显示横断面标注”工具放置的动态横截面视图中的尺寸标注。

三维漫游

使用户能够以更逼真的可视化方式查看三维模型。

廊道报表
  • 组件数量
  • 设计输入报表
  • 结果报表
  • 清表报表
  • 超高报表

报告包括组件（混凝土、表层土、路肩、挖方和填方土方量）表面积、体积、计量单位、单位成本以及组件和总成本。

打开带有默认路面设置报告的 Civil 报告浏览器，其中包括廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡段、末端条件异常和超高区间信息。

打开带有默认路面设置报告的 Civil 报告浏览器，其中包括详细的廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡段、末端条件异常和超高区间信息。

打开带有压碾/剥离组件报告的 Civil 报告浏览器。

可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。

父主题: 廊道


模型细部设计

土木单元
三维工具
父主题: 功能区选项卡


土木单元

功能区：模型细部设计
设置 | 描述
放置土木单元 | 激活浏览器以选择要放置的土木单元。可以从激活 DGN 的图形或浏览器（提供来自当前 DGN 中所有设计模型的可用土木单元的示意图预览）中选择土木单元，或者通过当前定义的配置选择土木单元。
创建土木单元 | 激活命令。提示您为新的土木单元命名并选择参考元素。将标识并高亮显示相依元素以供验证。
处理土木单元 | 重新处理所有线性模板和所选土木单元的模板。如果激活地形已更改或需要刷新参考文件交互，可能需要执行此操作。
移除土木单元 | 激活打散命令并锁定土木单元。 标准 MicroStation“打散”命令适用于土木单元，但选择取决于模型中的元素优先级，可能需要循环元素才能选择土木单元。
父主题: 模型细部设计


三维工具

设置

描述

应用线性模板

访问“拾取模板”对话框，然后在相对于线性元素的绘图中插入所选模板。

应用表面模板

访问“拾取模板”对话框，然后在相对于地形模型的绘图中插入所选模板。

三维元素
  • 通过放坡将三维元素应用到目标
  • 通过土方量创建三维元素
  • 按平面图纵断面的附加三维体
  • 按三维元素的平面图

创建从线性元素计算到表面的三维元素。

从另一个参考表面创建按土方量计算的地形模型。

“按平面图纵断面的附加三维体”工具从纵断面线的一部分创建三维元素。

从三维 MicroStation 元素创建二维元素并利用激活纵断面的原始三维元素。

父主题: 模型细部设计


绘图制作

注释
命名边界
父主题: 功能区选项卡


注释

标注元素 | 用于向元素添加注释。
移除元素标注 | 用于移除元素注释。
标注模型 | 用于向模型添加注释。
移除模型标注 | 用于移除模型注释。
父主题: 绘图制作


命名边界

命名边界

调整纵断面命名边界

父主题: 绘图制作


测量

外业簿
分析
编辑
父主题: 功能区选项卡


外业簿

功能区：“测量”>“外业簿”

创建

导入

导出

父主题: 测量


分析

功能区：“测量”>“分析”

测量视图

注释

修饰

父主题: 测量


编辑

功能区：测量 > 编辑

编辑线性

编辑线性点

父主题: 测量


文件

另请参阅文件。

首选项
设计文件设置
父主题: OpenRoads Designer CONNECT Edition帮助


首选项

用于设置用户首选项 - 可控制产品运行方式的设置。

首选项与设计文件无关，无法保存在设计文件中。但是，当您单击确定按钮后，它们会保存在由 MS_USERPREF 配置变量所指向的用户首选项文件中。

您可以通过以下方式访问此对话框：

  • 功能区：文件 > 设置 > 用户 > 首选项

视图选项 -“土木”是 OpenRoads Designer 使用的首选项的一个分类。（有关其余分类的帮助，请参阅 MicroStation 帮助。）

视图选项 -“土木”分类为光标提示、操纵器和各种操作切换提供了许多设置。

操纵器设置

这些设置允许用户控制土木几何操纵器和任何相关文本的设置和线符。

超高设置

将超高组件绘制到设计文件中时，这两个选项允许用户指定是将它们绘制为“彩色阴影填充”还是“仅限边界”。

选项 | 描述
彩色阴影填充 | “彩色阴影填充”将在计算完成后填充超高通道。着色是基于横坡的硬编码： 坡度 < -10％ = 蓝色 -10％ <= 坡度 <= -0.5％ = 计算得出的绿色和蓝色之间的颜色 -0.5% < 坡度 < 0.5% = 白色 0.5% <= 坡度 <= 10% = 计算得出的红色和黄色之间的颜色 坡度 > 10％ = 深红色 基于道路的一边，颜色翻转。除了设置此选项以外，还必须打开“填充视图属性”。
仅边界 | 在此选项中，仅显示每条车道的外部边界，并可选择。
无 | 超高车道/编辑图柄不会显示，但它们仍在文件中。要显示它们，请设置为其他两个选项之一。
父主题: 文件


设计文件设置

用于更改设计文件特定的设置。

您可以通过以下方式访问此对话框：

  • 功能区：文件 > 设置 > 文件 > 设计文件设置

“土木格式设置”分类为控制设计文件中的土木注释的土木设置提供选项。有关所有其他分类的详细信息，请参阅 MicroStation 帮助。

坐标设置

在任何土木对话框中控制其坐标的显示和精度。此外，该设置还控制如何解释输入的任何坐标。例如，如果设置为“X, Y”，则解释所有坐标并将其显示为“X, Y”格式。如果设置为“向北, 向东”，则同样适用。

比率设置 - (距离:偏移)

在任何土木对话框中控制比率的显示和精度。此外，该设置还控制如何解释输入的任何比率。例如，如果设置为“1:D”，则解释所有比率并将其显示为此格式（1:100、1:50 等等）。如果设置为“D:1”，则以类似的方式显示和解释比率（5:1、10:1 等等）。

桩号设置

控制要在土木对话框中使用和显示的桩号值的格式、分隔符和精度。此外，还有两个选项可以控制如何在桩号值中表示公式。

  • 按名称 - 桩号公式由桩号前面的用户定义字符表示。（A100+00、B105+00，依此类推。）
  • 按索引 - 桩号公式由附加到桩号设置的硬编码数值表示。数字从 1 开始，按升序排列。（100+00 R 1、105+00 R 2，依此类推。）

半径设置

  • 曲线方法 - 有“弧”和“弦”这两个选项可用。
  • 曲线长度 - 此项设置 1^ 曲线的标准定义。
  • 半径切换字符 - 此项允许用户指定将在土木对话框中使用哪个字符在半径定义和曲率定义之间进行“切换”。

如“首选项”主题中所述，加载 Bentley Civil 时，可以使用“土木格式设置”面板进行设置。其中一个设置是曲率切换。

“半径切换”按键用于定义曲率而不是半径。“半径切换”可用于定义弧的任何命令。默认情况下，这些命令会提示输入半径，如下所示。

可以使用该开关将半径更改为曲率，如下所示。键入 d，后跟曲率值。

曲率显示在提示符下。

曲率保留在规则中，如操纵器中所示。

仅当锁定时，曲率才会保留。

如果需要在同一命令实例中切换回半径，请再次键入 d。

下次启动弧命令时，将默认返回半径模式。

如果使用通过点动态操作弧，则将切换回半径持久性。

缓和曲线设置

纵断面设置

控制纵断面上下文中的坡度和比率的精度和显示或输入格式。此外，设置默认“竖曲线参数格式”（半径、K 值或 M 值）。

使用“纵断面设置”控制纵断面上下文中的坡度和比率的精度和显示/输入格式。单击“竖曲线参数”字段以设置半径或 K 值：

  • K 值 - 曲线长度/坡度变化。（例如，K = L/A）

  • 半径 R 值等于 100*K。（例如，R = 100*L/A）；生成一条抛物线（之所以叫半径，是因为生成的抛物线近似于半径 = 100*K 的圆形曲线）

父主题: 文件


主页

属性
基本
选择
模型分析与报表
模型导入/导出
OpenRoads Designer 帮助
父主题: OpenRoads Designer CONNECT Edition帮助


属性

“属性”工具箱包含用于设置激活元素属性的控制选项。

功能区：主页

设置 | 描述
元素模板关联 | 用于在放置元素时锁定激活元素模板。打开时，将高亮显示图标。
元素模板 | 打开“元素模板”下拉菜单可设置激活元素模板，并可使用“元素模板”对话框管理元素模板。
层 | 打开“层”下拉菜单可设置激活层和激活层过滤器、管理层和过滤器、设置层显示并应用过滤器以及调出现有层过滤器。
颜色 | 打开“激活颜色”下拉菜单可设置激活颜色以及更改所选元素的颜色。
线型 | 打开线型下拉菜单可将激活线型设置为所选线型。
线宽 | 打开线宽下拉菜单可设置激活线宽以及更改所选元素的线宽。
透明度 | 打开透明度下拉菜单可设置激活元素透明度。
优先级 | 打开优先级下拉菜单可设置激活元素优先级（仅限二维模型），该优先级确定了元素相对于其他元素的显示方式。
元素类别 | 打开元素类下拉菜单可设置放置元素时的激活元素类。
将元素与模板相关联
设置激活元素模板
设置激活层
通过“特性”工具箱设置激活线型
从“属性”工具箱中设置激活线宽
设置激活元素透明度
设置激活元素优先级
设置激活类
父主题: 主页


将元素与模板相关联

  1. 使用元素选择工具选择元素。
  2. 在“特性”部分，如果元素模板关联图标未在凹陷的背景中高亮显示，则单击该图标将其状态改为已选中。
  3. 单击元素模板图标旁的下拉列表框。

    将显示可用模板组和模板的下拉列表。

  4. 在下拉列表中单击模板的名称。

    元素即关联（或“锁定”）到模板。

父主题: 属性


设置激活元素模板

  1. 单击“特性”功能区组中的元素模板下拉列表图标。

    将显示一个包含可用模板的下拉列表。

  2. 在下拉列表中单击要激活的模板名称。 选定的模板将设置为“激活”，且“特性”组中的特性设置将会更改以匹配此激活模板。
注释: 也可以在“元素模板”对话框中激活元素模板，展开 DGN 文件和所需的模板组，右键单击该模板并选择设置激活。元素模板将会激活。
父主题: 属性


设置激活层

“LV”表示激活层

设为激活层的层的名称会显示在状态栏中。

保存 DGN 文件设置
父主题: 属性


保存 DGN 文件设置

要保留不同会话期间对 DGN 文件设置（如工作单位）所做的更改，您必须明确保存这些设置。

选择文件 > 保存设置选项会将设置保存在激活的设计文件中。只有当“首选项”对话框（文件 > 设置 > 用户 > 首选项）的“操作”类别中的“退出时保存设置”首选项设置为关闭时，才会启用此选项。这使您可以随时保存设置，因为退出文件时不会自动保存设置。

保存的设置包括通过设置框控制的设置和视图配置（视图在屏幕上的排列方式以及视图中显示的设计平面区域）。但是，用户首选项、出图和渲染设置不会保存。

FILEDESIGN
父主题: 设置激活层


设置激活颜色

上次更新时间： 2019 年 1 月 30 日
  1. 打开“激活颜色”对话框（绘图 > 主页 > 特性 > 颜色）。

  2. 在“激活颜色”选项卡中，从调色板选择需要的颜色。

    新的激活颜色将显示在预览区域中。单击“确定”后，新的激活颜色将显示在功能区的“特性”组中。


通过“特性”工具箱设置激活线型

从“特性”组的“线型”选项菜单中，选择需要的线型。“线型”选项菜单的菜单项对应于最近使用的激活自定义线型（最多四个）和八个编号的标准线型。

父主题: 属性


从“属性”工具箱中设置激活线宽

从属性组的“线宽”选项中，选择所需的线宽值。

父主题: 属性


设置激活元素透明度

  1. 在“特性”组中，选择激活元素透明度图标。
  2. 在对话框中，键入新的透明度值，或使用滑块调整透明度值。
父主题: 属性


设置激活元素优先级

  1. 从“特性”组中选择激活元素优先级图标。
  2. 在对话框中，键入新的优先级值，或使用滑块调整优先级值。
父主题: 属性


设置激活类

  1. 打开“设计文件设置”对话框（文件 > 设置 > 文件 > 设计文件设置）。
  2. 在“类别”列表框中，选择元素特性。
  3. 从“类”选项菜单中，选择基本或构造。
  4. 单击确定。
父主题: 属性


基本

设置

描述

资源管理器

使用资源管理器对话框管理项目数据。

连接工具

  • 参考
  • 光栅管理器
  • 点云
  • 实景网格

使用“参考”对话框管理参考连接。

使用“光栅管理器”对话框管理光栅参考连接。

使用“点云”对话框导入、控制、呈现和操作点云图像。

使用“实景网格连接”对话框连接和操作实景网格。

模型

显示“模型”对话框，该对话框可用于创建新模型、复制模型、编辑模型属性、删除和导入模型、创建图纸边界以及列出任何过滤器。

层显示

使用“层显示”对话框打开和关闭层。

层管理器

使用“层显示”对话框打开和关闭层。

属性

检查或修改有关元素的信息，如元素的类型、特性和几何图形。

详细

  • 键入命令
  • 开关精确绘图
  • 辅助坐标
  • 保存的视图
  • 单元
  • 标记
  • 细节
  • 窗口列表

打开“键入命令”窗口。

使用“保存的视图”对话框管理保存的视图。

在单元库中创建和管理单元。

通过“标注”对话框检查设计中所做的标注和备注。

显示与在资源管理器对话框的任何一个选项卡中选择的内容有关的信息
使用资源管理器管理工作集数据
连接工具
层显示
层管理器
属性
详细
父主题: 主页


使用资源管理器管理工作集数据

设置 | 描述
文件 | “文件”选项卡显示模型、保存的视图、参考、层等分类中的文件内容。您还可以查看激活模型的内容。
项 | “项”分类按层次顺序显示激活文件中的非图形业务数据。支持六个分类；不支持用户创建或修改分类。
资源 | “资源”选项卡显示 DGNLib 文件中可用于激活 DGN 文件的共享资源。
OpenRoads 模型 | OpenRoads Designer 的“模型”选项卡按类别（如线形、地形模型、廊道等）显示内容。
图纸索引 | “图纸索引”包含用于管理图纸索引的控件。 图纸索引是来自一个或多个设计文件的图纸模型的有序命名集合。
链接 | 注释: 有关更多详细信息，请参考 MicroStationCONNECT Edition 帮助主题“‘资源管理器’对话框：‘链接’选项卡”。
OpenRoads 标准 | OpenRoads Designer 的“标准”部分用于创建、编辑或查看平面和纵面几何图形设计标准、特征信息、土木单元、标注以及图形过滤器。
资源管理器简介
常用工具
文件
项
资源
OpenRoads 模型
图纸索引
链接
OpenRoads Designer 标准
父主题: 基本


资源管理器简介

通过以下方式访问此对话框：

  • 主页 > 主功能区

“资源管理器”对话框用于管理和控制项目内容。这是您浏览文件、链接、项、资源和图纸索引的集中界面。

  • 文件 - 用于浏览和管理模型、参考、保存的视图、层、样式、模板等文件内容。
  • 项 - 按照层次顺序显示 DGN 文件中的非图形业务数据。
  • 资源 - 按照层次顺序显示 DGN 文件中使用的资源。
  • OpenRoads 模型 -
  • 图纸索引 - 用于管理查看图纸索引。图纸索引是来自一个或多个设计文件的图纸模型的有序命名集合。
  • “链接”选项卡 - 用于查看链接的数据。
  • OpenRoads 标准 - 用于创建、编辑或查看平面几何和纵面几何设计标准、特征信息、土木单元、标注和图形过滤器。

在“资源管理器”对话框中的对象选择会同步到无模式对话框中的相应对象选择。

在“资源管理器”对话框的若干选项卡中，您可以在树中搜索对象。您可以根据具体要求执行“简单”搜索、“标准”搜索或“高级”搜索。“简单”搜索可以根据搜索文本执行搜索。“标准”搜索可以创建简单查询。“高级”搜索可以构造复杂的搜索条件，您可以保存这些条件以供日后使用。搜索结果会存储在一个以搜索条件命名的文件夹中。通过搜索结果文件夹的右键菜单，您可以将结果保存为报告定义（仅适用于“标准”和“高级”搜索），编辑搜索标准，删除搜索标准，或查看属性。

可以从“资源管理器设置”对话框（“文件”>“设置”>“用户”>“资源管理器设置”）中设置“资源管理器”对话框的属性。

父主题: 使用资源管理器管理工作集数据


常用工具

下表中详细介绍资源管理器中多个分类均共有的四个工具。

工具 | 描述
刷新 | 刷新激活的树以反映对 DGN 文件所做的更改。
透明 | 为选定图形项打开透明度。
缩放 | 缩放选定图形项。
隔离 | 隔离选定图形项。
缩放到项
在资源管理器中查询数据
父主题: 使用资源管理器管理工作集数据


文件

可以使用“资源管理器”对话框的“文件”选项卡浏览和管理文件内容。“文件”选项卡显示模型、保存的视图、参考、层等分类中的文件内容。您还可以查看激活模型的内容。模型内容包括保存的视图、层、命名组、光栅、点云、参考、元素、辅助坐标系和项。要显示模型内容，在“模型”分类下方展开激活模型即可。您只能查看激活模型的内容。

您可以对文件内容执行搜索。通过搜索可轻松找到所需的信息，但若在层次中执行查找，这将是一项非常繁琐的操作。

“资源管理器”对话框的“文件”选项卡显示模型、保存的视图、参考、层等分类中的文件内容。展开每个类别均会列出相应类别或其他子类别中的项。您可以通过下列方式管理“资源管理器”的“文件”选项卡中所显示的文件内容：

  • 右键单击分类 - 您可以从弹出式菜单中选择菜单项以对文件执行操作。例如，如果您右键单击“模型”分类，则会看到“管理”、“新建”、“属性”和“导入”。选择“管理”会打开“模型”对话框。
  • 右键单击分类内的项 - 您可以从弹出式菜单中选择菜单项以对所选项执行操作。例如，如果您右键单击“保存的视图”分类内某个保存的视图，则会看到“应用”、“重命名”、“更新”和“删除”。单击“属性”会打开“属性”对话框，其中显示元素的属性。
  • 右键单击“元素”分类 - 您可以选择“组织方式”，以便按“名称”、“类型”、“层”、“颜色”、“样式”、“线宽”、“类”、“模板”、“透明度”和“优先级”组织列表中的元素。
  • 右键单击元素 - 右键单击“元素”分类中的元素时，您会看到与元素类型相关的菜单项。
  • 双击分类 - 展开或折叠分类。
  • 双击分类内的项 - 激活或打开项（如果可能）。例如，双击现有模型将会打开该模型。
  • 拖放操作 - 您可以将保存的视图和模型（分别从“保存的视图”和“模型”分类中）拖曳到视图窗口中。

有关更多详细信息，请参阅 MicroStation 帮助。

父主题: 使用资源管理器管理工作集数据


项

“项”分类按层次顺序显示激活文件中的非图形业务数据。支持六个分类；不支持用户创建或修改分类。

支持以下操作：

  • 右键单击分类 - 您可以从弹出式菜单中选择菜单项，包括“缩放”、“隔离”和“清除隔离”。
  • 双击分类 - 展开或折叠分类。
  • 右键单击分类内的项 - 右键单击“元素”分类中的元素时，您会看到与元素类型相关的菜单项。例如，如果右键单击“元素”分类内的廊道，则会看到各种“廊道”工具。单击“属性”会打开“属性”对话框，其中显示元素的属性。

单击“地形模型”元素内的“地形”。

有关更多详细信息，请参阅 MicroStation 帮助。

父主题: 使用资源管理器管理工作集数据


资源

“资源”选项卡显示 DGNLib 文件中可用于激活 DGN 文件的共享资源。

您可以在“资源管理器设置”对话框中设置“资源”选项卡的可见性。

有关更多详细信息，请参阅 MicroStation 帮助。

父主题: 使用资源管理器管理工作集数据


OpenRoads 模型

“OpenRoads 模型”选项卡显示活动模型和参考文件中的所有土木对象。

“OpenRoads 模型”选项卡按类别显示内容，例如，线形、地形模型、廊道等。展开每个类别均会列出相应类别或其他子类别中的项。可通过以下方式管理该内容：

  • 右键单击分类 - 您可以从弹出式菜单中选择菜单项以对文件执行操作。例如，如果右键单击“路线”类别，将显示“锁定 - 停用规则”、“解锁 - 激活规则”、“缩放”、“隔离”、“清除隔离”。右键单击分类内的项 - 您可以从弹出式菜单中选择菜单项以对所选项执行操作。例如，如果您右键单击“保存的视图”分类内某个保存的视图，则会看到“应用”、“重命名”、“更新”和“删除”。单击“属性”会打开“属性”对话框，其中显示元素的属性。
  • 右键单击元素 - 右键单击“元素”分类中的元素时，您会看到与元素类型相关的菜单项。例如，如果右键单击线形元素，弹出菜单将包含平面几何图形工具。
  • 双击分类 - 展开或折叠分类。

  • 双击分类内的项 - 激活或打开项（如果可能）。

    图纸索引

父主题: 使用资源管理器管理工作集数据


图纸索引

“图纸索引”包含用于管理图纸索引的控件。

图纸索引是来自一个或多个设计文件的图纸模型的有序命名集合。您可以将任何设计文件中的任何图纸模型链接到图纸索引中。然后，可以在图纸索引内统一管理所有图纸模型的属性。图纸索引也可添加到打印管理器打印集中，以便进行打印。

设置 | 描述
刷新 | 刷新图纸索引的内容。尽管做出任何更改后，图纸索引将自动刷新，但在某些情况下，您可能需要通过单击此图标进行手动刷新。
打开要编辑的图纸索引 | 您可以对图纸索引做出更改。单击此图标后，其他用户无法更改图纸索引。
将图纸索引设为只读 | 关闭图纸索引上的编辑选项。单击此图标后，将保存对图纸索引做出的更改，且其他用户可以更改图纸索引。
管理图纸索引 | 打开“管理图纸索引”对话框，在该对话框中可以查看图纸索引及其属性。
创建文件夹 | 在图纸索引中创建新的文件夹。
添加图纸 | 打开“添加图纸”对话框，您可以在该对话框中选择要从中添加图纸链接的文件。
删除 | 从图纸索引中删除所选文件夹或图纸链接。如果该文件夹包含链接或其他文件夹，这些内容也会被删除。
作为表放置 | 启动“放置表”工具以放置索引图纸。索引图纸包含作为表放置的图纸索引中所有图纸的属性。
打开打印管理器 | 打开“选择打印样式”对话框。在“选择打印样式”对话框中选择所需打印样式并单击“确定”，将会打开打印管理器。打印管理器中将显示“图纸索引”。您可以使用图纸索引合成新的打印集文件。
重置图纸链接的弹出菜单 | 右键单击图纸时，将打开一个包含以下选项的弹出菜单： 打开 - 打开所选图纸。 向元素添加链接 - 在打开 DGN 文件中向所选元素添加图纸链接。
父主题: 使用资源管理器管理工作集数据


链接

如果打开的 DGN 文件或已配置的 DGN 库中存在链接集，链接集会显示在“资源管理器”对话框的“链接”选项卡中。该链接集的名称会显示在“链接集”图标旁的下拉列表框中。

链接显示在“资源管理器”对话框的“链接”选项卡中。您可以在文件夹中组织链接。还可以为文件夹创建链接，此时会链接文件夹中的所有内容。要打开某个链接，请双击该链接，或者右键单击该链接，然后从弹出菜单中选择“打开”。

创建链接集后，您可以打开该链接集、浏览其链接、打开链接、向元素添加链接、添加详图符号链接，还可以查看链接和文件夹的属性。

链接集可以包含指向以下内容的链接：DGN 和 DWG 文件；设计、绘图和图纸模型；文件夹、参考、保存的视图、绘图边界以及以其他文件格式创建的支持文档。每个链接集都是独立的对象，它们作为非图形数据存储在 DGN 文件或 DGN 库 (DGNLib) 中。如果移动其中存储了链接集的 DGN 文件，这些链接集会随 DGN 文件一起移动，并保留指向目标文件的链接。

链接集不能存储在 DWG 文件中。

在“资源管理器”对话框的“链接”选项卡中，您可以查看链接集中的信息，包括浏览链接集、打开链接、向元素添加链接、添加详图符号链接以及查看链接的属性。“资源管理器”对话框的“链接”选项卡用于组织链接。您可以创建文件夹并在其中放入链接来组织链接。

创建的链接可以指向 DGN 和 DWG 文件；设计、绘图和图纸模型；参考和保存视图。此外，还可以链接到以下各项：

  • Microsoft Word 文档，包括文档中的标题和书签
  • Microsoft Excel 工作簿，包括工作簿中的特定工作表
  • Adobe PDF，包括文件中的书签
  • 网站、键入命令和电子邮件地址
  • 文件夹、链接集和配置变量
  • 任何其他文件类型

在向元素添加链接时，您可以选择不创建链接集而快速创建链接，也可以使用资源管理器来创建链接集。

有关更多详细信息，请参阅 MicroStation 帮助。

父主题: 使用资源管理器管理工作集数据


OpenRoads Designer 标准

OpenRoads Designer 的“标准”部分用于创建、编辑或查看平面和纵面几何图形设计标准、特征信息、土木单元、标注以及图形过滤器。

dgnlib 中存储的标准以灰色显示（仅供查看），而当前文件中使用的标准以蓝色显示（可编辑）。在当前文件中使用 dgnlib 中的标准时，系统会将该标准复制到当前文件部分。

可通过以下方式管理该内容：
  • 右键单击类别 - 可以从弹出菜单中选择菜单项以对标准执行操作。例如，如果右键单击“特征定义”类别，则会显示“属性”、“缩放”、“隔离”和“清除隔离”。这些选项对于所有类别均相同。
  • 右键单击类别内的类别 - 可以从弹出菜单中选择（子）类别以对选定类别执行操作。例如，如果右键单击“特征定义”类别中的“线形 (Alignment)”，则会显示“新建类别”、“新建特征定义”、“属性”、“缩放”、“隔离”和“清除隔离”。这些选项对于所有类别中的所有（子）类别均相同。
  • 右键单击项 - 右键单击任一类别中的项时，将显示与项相关的实用工具。例如，如果右键单击“沿批注对齐点”，弹出菜单将包含“剪切”、“复制”、“重命名”、“删除”、“属性”、“缩放”、“隔离”和“清除隔离”。这些选项对于所有类别中的所有项均相同。
  • 双击类别或（子）类别 - 展开或折叠类别或子类别。

以下类别为内置类别，无法更改。此层次级别的其他类别不受支持。子类别受支持并且可以嵌套。项也可以添加到任一类别下方。

类别 | 描述
特征定义 | 包含以下特征：
特征符号 | 与特征定义结合使用，存储
标注组 | 包含多个组，每个组都是多个标注定义的集合。
标注定义 | 包含单个标注定义
土木单元 | 包含来自 DGNlib 和当前文件的土木单元。
设计标准 | 包含平面和纵面几何图形设计标准。
地形过滤器 | 包含在图形地形过滤器管理器中创建的图形地形过滤器。
项目设置 | （将来）包含测量设置。
特征定义
特征符号
标注组
标注定义
土木单元
设计标准
地形过滤器
项目设置
父主题: 使用资源管理器管理工作集数据


连接工具

另请参阅连接工具。

可缩放的地形模型
父主题: 基本


可缩放的地形模型

概述
管理可扩展地形模型
“可扩展地形模型管理器”对话框
创建新的可扩展地形模型
“新建 STM 设置”对话框
向 STM 文件添加高程数据
“STM 高程源编辑器”对话框
导入文件
“STM 导入选项”对话框
“转换通用文本”对话框
导出到 TM
提取 TM 元素
提取光栅网格
视域分析
提取等高线
覆盖元素
显示可扩展地形模型
父主题: 连接工具


层显示

另请参阅层显示。

父主题: 基本


层管理器

另请参阅层管理器。

父主题: 基本


属性

另请参阅属性。

父主题: 基本


详细

请参阅详细信息。

父主题: 基本


选择

设置

描述

选择元素

通过定义区域或通过绘制与元素相交的线，以每个元素为基础选择和取消选择元素。

全选

选择设计中的所有元素。

全部不选

取消选择设计中的所有元素。

围栅工具

  • 放置围栅
  • 修改围栅
  • 操作围栅内容
  • 删除围栅内容
  • 打散围栅内容
  • 将围栅保存到文件
  • 命名边界

放置围栅 - 用于放置围栅。

修改围栅 - 用于移动围栅或修改它的一个顶点。

操作围栅内容 - 用于移动、复制、旋转、镜像、缩放或拉伸围栅内容，这些内容由围栅和（拉伸除外）围栅（选择）模式定义。

删除围栅内容 - 用于删除围栅内容。

打散围栅内容 - 用于将围栅中的内容打散为其组件。

将围栅保存到文件 - 用于将激活围栅的内容复制或移动到新的 DGN 或 DWG 文件。

命名边界 - 使用“命名边界”对话框管理命名边界和边界组。

注释: 有关围栅工具的更多深入信息，请参阅“MicroStation 帮助”。
放置围栅
修改围栅
操作围栅内容
删除围栅内容
打散围栅内容
指定围栅内容中包含哪些元素
来自围栅的命名边界
父主题: 主页


放置围栅

用于放置围栅。

您可以通过以下方式访问此工具：

设置 | 描述
围栅类型 “围栅类型”选项及其对应的功能如下：
  • 块、形状或圆 — 设置图形放置围栅的几何特征。
  • 元素 — 可通过选择元素创建围栅。可用于围栅的元素包括闭合共面元素（形状、圆、椭圆、复杂形状、成组开孔）、任何实体（球体或特征实体除外）或闭合拉伸或圆柱。如果在三维文件中使用共面元素，则通过在整个模型中延展平面区域来应用该体积块。
  • 从视图 — 将围栅设置为包括选定视图的内容。
  • 从文件 — 将围栅设置为包括 DGN 文件的内容。可从选项菜单中选取以下选项：
    • 激活 — 选定视图中激活模型内的元素。
    • 全部 — 选定视图中激活模型及其参考内的元素。
    • 选择 — 选定参考（或激活模型）中的元素，通过从所需模型/参考中选择元素来对其加以标识。
  • 泛填 — 将围栅设置为包括由一组元素封闭的（最小）区域。
围栅模式 | 设置围栅（选择）模式与围栅放置，。
展开

展开工具设置以显示已命名的围栅工具。
提示: 在放置围栅后、选择另一工具前，如果您对围栅放置不满意，只需重置即可开始重新放置。
父主题: 选择


修改围栅

用于移动围栅或修改它的一个顶点。

您可以通过以下方式访问此工具：

围栅和围栅（选择）模式定义要进行操作的围栅内容，即是否。

设置 | 描述
修改模式 您可以选择模式：
  • 顶点 - 您可以修改围栅的顶点。
  • 位置 - 您可以修改围栅的位置。
围栅模式 | 设置围栅（选择）模式，该模式定义要进行操作的围栅内容。
键入: < MOVE | MODIFY > FENCE
父主题: 选择


操作围栅内容

用于移动、复制、旋转、镜像、缩放或拉伸围栅内容，这些内容由围栅和（拉伸除外）围栅（选择）模式定义。要了解围栅内容的构成，请参阅指定围栅内容中包含哪些元素。

您可以通过以下方式访问此工具：

操作方法由“操作”工具设置决定。除拉伸外，在“使用围栅”工具设置打开时，每种方法均等效于操作工具。

操作 | “使用围栅”打开时的等效工具
复制 | 复制元素
移动 | 移动元素
缩放 | 缩放
旋转 | 旋转
镜像 | 镜像
阵列 | 构造阵列
拉伸 | 拉伸元素

“操作”设置为“拉伸”时，“操作围栅内容”将忽略围栅（选择）模式，并按如下方式对元素进行操作：

  • 功能区：管理 > 主页 > 选择 > 围栅工具拆分按钮
  • 移动位于围栅内部的直线、线串、多线或形状的顶点。位于围栅外部的顶点并不移动。
  • 移动位于围栅内部的弧的端点。位于围栅外部的弧的端点并不移动。
  • 移动完全位于围栅内部的椭圆、圆或单元。

可使用“围栅拉伸”来操作断点（当多线本身为墙面时，多线中的断点通常用于表示窗口或门口）。例如，可以放置一个围栅以包括窗口，并沿着墙面移动窗口。也可以通过仅在围栅中包括断点的起点和终点来更改窗口的大小。这意味着，在大多数情况下，不必将多线拖放到其组件元素中即可执行此类操作。

有关多线的常规信息，请参阅使用多线。

无法将某个断点从包含它的多线线段中移出。如果您因移动围栅而使断点的起点或终点从线段中移出，断点位置只不过会投影到线段上的最近点处。如果将某个断点从线段末端移出，它仅仅会被删除。

如果只有弧的一个端点位于围栅中，则会有效地旋转和缩放弧，以便该点移动到新位置。这意味着，弧不会改变其长宽比（例如，圆弧不会变成椭圆形）或扫角。弧的新端点位置与围栅的移动方式保持一致，而不像“围栅拉伸”那样只是在 x 或 y 方向缩放弧。

键入: FENCE ICON
注释: 拉伸和移动操作期间会保持多线中的切口、断点和部分删除项的相对位置。
提示: 要将顶点的移动范围约束为角的倍数，请将精确绘图与“拉伸”选项结合用于“操作围栅内容”。

设置 | 描述
拉伸单元 | 如果打开，将拉伸与围栅重叠的内容。 LOCK CELLSTRETCH [OFF | ON | TOGGLE] 键入命令还可用于关闭或打开“拉伸单元”。
复制元素
使用图柄
使用重置弹出菜单
使用精确绘图
特殊围栅操作
移动元素
比例
旋转
镜像
构造阵列
使用多线
GUID-63144798-1C12-E587-E286-3DA2D155A306
GUID-F3867CF1-3616-6944-6E3D-7331FD2E6A9B
GUID-391F7C6F-4036-4C12-0BEF-5FC6FB9311DC
GUID-7270B2C4-705A-F4F8-B8A3-227FFD09CD7C
父主题: 选择


复制元素

用于复制元素

设置 | 描述
副本 | 设置要创建的副本数。
使用围栅 | 如果打开，将复制围栅内容。此选项菜单将设置围栅（选择）模式。
键入: COPY ICON
键入: [FENCE] COPY [ELEMENT]
提示: 从“重置”弹出菜单中选择复制即可选择“复制元素”工具。以此方式选择该工具时，复制操作将影响选择的所有元素。
注释: 如果从连接的参考复制元素，则仅当元素的层在激活模型中不存在时，才复制它们。要更改层的处理方式，可从中选择“首选项”，然后选择“参考”类别。
注释: 如果复制参考中带标记的元素，则标记自动连接到激活模型中的关联元素。
父主题: 操作围栅内容


使用图柄

图柄用于修改或操作元素，以与特定用户操作相关的屏幕上交互图形表示。图柄有多种类型，可执行不同的功能。

可使用图柄操作或修改以下内容：

  • 单个元素，包括三维实体。
  • 一组元素。
  • 参考（“将连接参考视为元素进行操作”已启用时）。
  • 参考剪切边界。
  • 命名边界（显示命名边界时）。

修改或操作上述元素的方法为，首先使用“元素选择”工具选中元素，此时即会显示元素、命名边界或参考边界显示的相应图柄。

最常见的图柄类型为用于元素选择的图柄。这些图柄会在单击或拖曳元素时显示。

图柄显示后即可执行以下操作：

  • 拖曳图柄修改元素，同时保持顶点处角度及半径比等几何约束不变。
  • 在按住 <Alt> 键的同时拖曳单个图柄，可修改元素而不保持几何约束。
  • 拖曳选中元素的任何其他部分可移动或复制该元素。要进行复制，需要在开始拖曳时即按住 <Ctrl> 键。
  • 在按住 <Ctrl> 键的同时输入数据点可选择多个图柄并同时进行修改。
  • 在按住 <Ctrl> 键的同时拖曳选择集可框起一组图柄并将这些图柄选中。
  • 选择多个元素后，选择任何高亮显示元素上的图柄。

通过单个图柄修改元素时，缺省操作模式为保留几何关系，例如顶点处角度、半径比等。对于大多数几何图形，拖曳图柄时，可以按 <Alt> 键来关闭此模式，以便仅操作选中的图柄。

例如：

  • 修改圆时，在缺省模式下（左），拖动图柄将修改半径，而在另一种拖曳模式下（右），将绕圆心沿选定轴缩放圆。

  • 修改椭圆时，在缺省模式下（左），拖曳图柄将修改椭圆并保持半径比，而在另一种拖曳模式下（右），将绕圆心沿选定轴缩放椭圆。

  • 修改形状和线串时，在缺省模式下（左），拖曳图柄将修改元素，同时保持剖面之间的角度。在另一种拖曳模式下（右），将仅修改选中的图柄，其他顶点保持不变。

其他类型的图柄包括：

  • 用于更改方向的箭头图柄。
  • 用于将三维元素移动到新位置的旋转球图柄。
  • 用于移动剪切面各边的平边图柄。

指向图柄时会出现指示其功能的工具提示。

父主题: 操作围栅内容


使用重置弹出菜单

重置弹出菜单提供方便的途径让您访问常用工具和实用程序。

此菜单在您单击或按住“重置”按钮时弹出，具体取决于“首选项”对话框（文件 > 设置 > 用户 > 首选项）的“输入”类别中的“重置弹出菜单”首选项。

如果“重置弹出菜单”首选项设置为缺省值“按住”，访问菜单前必须按住重置按钮的时间间隔由同样位于“输入”类别中的“按住延迟”首选项决定。

重置

输入重置命令。

只有当“首选项”对话框（文件 > 设置 > 用户 > 首选项）的“输入”类别中的重置弹出菜单首选项设置为单击时，重置弹出菜单中才会显示此菜单项。

RESET

弹出菜单选项

打开“首选项”对话框的“输入”类别，从中可选择用于设置“重置弹出菜单”和“按住延迟”首选项的控制选项。

只有当重置弹出菜单首选项设置为单击时，重置弹出菜单中才会显示此菜单项。

元素选择

激活“元素选择”工具，使用它可以选择和取消选择要修改或操纵的元素。

只有当未选中“元素选择”工具时，重置弹出菜单中才会显示此菜单项。

全选

选择设计中的所有元素。

“全选”主要用于各种勾画和测试工具，对于大型设计应谨慎使用，因为：

  • 可能需要花费很长时间才能将许多元素添加到选择集。
  • 无论元素是否可见都会被选择。
CHOOSE ALL
提示: 通常，大量元素的效率要高得多。

取消选择

取消选择设计中的所有元素。

CHOOSE NONE

选择上一个

恢复之前的选择集。

CHOOSE PREVIOUS
注释: 如果有任何当前选中的元素不在之前的选择集中，选择“选择上一个”选项将会取消选中这些元素。

属性

效果与在功能区中选择属性工具相同。

父主题: 操作围栅内容


使用精确绘图

精确绘图是一种制图辅助工具，用于计算诸如当前指针位置、先前输入的数据点、上一个坐标指令、当前工具需求以及您通过快捷键入或精确绘图选项输入的任何指令等参数。精确绘图随后会生成相应的精确坐标并将其应用于激活工具。

父主题: 操作围栅内容


特殊围栅操作

“操作围栅内容”工具可用于“拉伸”（延长或缩短）与围栅重叠的元素段。通过移动落在围栅内的元素顶点，即可完成上述操作。您还可以使用“复制”工具、“移动”工具、“缩放”工具和“旋转”工具来拉伸与围栅重叠的元素。

还可以使用将围栅内容复制到新文件工具，将围栅内容移动或复制到新文件。

FENCE FILE 键入命令可用于将围栅内容复制到一个新的 DGN 文件。

FENCE SEPARATE 键入命令可用于将围栅内容移动到一个新的 DGN 文件。

父主题: 操作围栅内容


移动元素

用于移动元素

设置 | 描述
使用围栅 | 如果打开，将移动围栅内容。此选项菜单将设置围栅（选择）模式。
键入: MOVE ICON
键入: [ FENCE ] MOVE [ ELEMENT ]
提示: 从“重置”弹出菜单中选择移动即可选择“移动元素”工具。以此方式选择该工具时，移动操作将影响选择的所有元素。
父主题: 操作围栅内容


比例

用于调整元素的大小可以单独缩放各元素、缩放选定组内的元素或者缩放围栅内的元素。“围绕元素中心”打开时，选择的元素将围绕其（各自的）中心点缩放。

设置 | 描述
方法 设置用于缩放元素的方法。
  • 激活比例 — 按激活比例因子（X 轴比例、Y 轴比例和 Z 轴比例）进行缩放。如果比例因子介于 0 到 1 之间（例如 0.25），则该方向上的大小将缩小；如果比例因子大于 1，则该方向上的大小将增大。
  • 三点 — 通过输入三个数据点以图形方式进行缩放。比例因子由第一点和第三点之间的距离除以第一点和第二点之间的距离得到。
X 轴比例 | “方法”设置为“激活比例”时，沿视图 x 轴（水平）的比例因子。
Y 轴比例 | “方法”设置为“激活比例”时，沿视图 y 轴（垂直）的比例因子。
Z 轴比例 | （仅限三维）方法为“激活比例”时沿视图 z 轴（深度）的比例因子。
成比例 | （仅“方法”设置为“三点”时）如果打开，将保持元素比例。
副本 如果打开，则将复制元素并缩放元素；不会操作原始元素。相邻的字段用于设置要创建的缩放副本数。
注释: 复制和缩放带标记的元素时，将仅缩放元素。如果想同时缩放标记，首先必须连同基准元素一起选择标记，然后选取“比例”工具。
使用围栅 | 如果打开，将缩放围栅内容。此选项菜单将设置围栅（选择）模式。
围绕元素中心 如果打开（在工具设置的“扩展信息”部分中），所选择的元素将围绕其中心点而不是选择的点缩放。单元和文本元素将围绕其原点缩放。

可以单独选择各元素，也可使用选择集或围栅选择多个要缩放的元素。选择了多个元素时，它们都将围绕其自己的中心点缩放。

多线偏移 | 如果打开，将缩放多线偏移（例如，调整房间大小时缩放墙壁厚度）。
尺寸标注值 如果打开，将修改尺寸标注值以反映缩放的尺寸标注的大小。

如果关闭，则仅缩放尺寸标注元素，而尺寸标注值保持不变。

注释 如果打开，则会缩放注释。注释是在注释比例锁打开时放置的可注释元素。可注释元素类型为尺寸标注、文本元素、文本节点、批注、详图符号、注释单元和标记。

如果关闭，注释的大小将保持不变。

键入: SCALE ICON
键入: [ FENCE ] SCALE [ POINTS ] [ COPY | ORIGINAL ]
提示: 从“重置”弹出菜单中选取比例即可选择“比例”工具。以此方式选择该工具时，缩放操作将影响选择的所有元素。
父主题: 操作围栅内容


旋转

用于旋转元素。可以单独旋转各元素、旋转选定组内的元素或者旋转围栅内的元素。“围绕元素中心”打开时，选择的元素将围绕其（各自的）中心点旋转。

设置 | 描述
方法 设置用于旋转元素的方法。
  • 激活角度 — 按“激活角度”（可在文本字段中输入）旋转元素。
  • 两点 — 通过输入两个数据点定义旋转角度。
  • 三点 — 通过三个数据点定义旋转角度。
围绕元素中心 如果打开，则选定元素将围绕其中心点而非选定点旋转。单元和文本元素将围绕其原点旋转。

可以单独选择各元素，也可使用选择集或围栅选择多个要旋转的元素。选择了多个元素时，它们都将围绕其自己的中心点旋转。

副本 如果打开，则将复制元素并旋转副本；不会操作原始元素。相邻的字段用于设置要创建的旋转副本数。
注释: 复制和旋转带标记的元素时，将仅旋转元素。如果想同时旋转标记，首先必须连同基准元素一起选择标记，然后选取“旋转”工具。
使用围栅 | 如果打开，将旋转围栅内容。此选项菜单将设置围栅（选择）模式。
键入: ROTATE ICON
键入: [ FENCE ] [ ROTATE | SPIN ] [ COPY | ORIGINAL | POINTS ] [ COPY | ORIGINAL ]
提示: 从“重置”弹出菜单中选取旋转即可选择“旋转”工具。以此方式选择该工具时，旋转操作将影响选择的所有元素。
提示: 如果“使用围栅”选项打开时重复旋转操作，将复制已移动围栅内的所有元素以及原始围栅内容。要创建多个旋转副本，通常更简便的方法是使用“构造阵列”工具并将“阵列类型”设置为“环形”。
父主题: 操作围栅内容


镜像

用于镜像元素。

设置 | 描述
镜像方向 设置镜像元素时采用的方向：
  • 水平 — 围绕水平轴。
  • 垂直 — 围绕垂直轴。
  • 直线 — 围绕由两个数据点定义的直线。
围绕元素中心 如果打开，则选定元素将围绕其中心点而非选定点旋转。单元和文本元素将围绕其原点旋转。

可以单独选择各元素，也可使用选择集或围栅选择多个要旋转的元素。选择了多个元素时，它们都将围绕其自己的中心点旋转。

复制 | 如果打开，则将复制元素并镜像副本；不会操作原始元素。
使用围栅 | 如果打开，将镜像围栅内容。此选项菜单将设置围栅（选择）模式。
多线偏移 | 如果打开，将镜像多线轮廓偏移。
文本 | 如果打开，将镜像文本。
键入: MIRROR ICON
键入: [FENCE] MIRROR [ COPY | ORIGINAL ] [ HORIZONTAL | LINE | VERTICAL ]
提示: 从“重置”弹出菜单中选择镜像即可选择“镜像”工具。如果通过此方式选择工具，则镜像操作将影响所选择的所有元素。
父主题: 操作围栅内容


构造阵列

用于将一个或多个元素复制多次以创建阵列。

设置 | 描述
方法 设置所构造的阵列类型；根据设置方法的不同，可以使用不同的工具设置。
  • 矩形 — 构造矩形阵列
  • 环形 — 构造环形（圆形）阵列
  • 沿路径 — 沿路径元素构造阵列
激活角度 | （矩形阵列类型）对齐在其上放置副本的假想正交轴网。
行 | （矩形阵列类型）行数。
列 | （矩形阵列类型）列数。
行间距 （矩形阵列类型）行间距。

从线性元素的左下角或者圆或椭圆的中心测量行间距。

列间距 | （矩形阵列类型）列间距。
副本 （“环形”阵列类型）设置阵列中元素的副本数。

（“沿路径”阵列类型）设置阵列中元素的副本数。

增量角 （“环形”阵列类型）设置元素副本之间的角度。
  • 如果为正值，则逆时针放置副本。
  • 如果为负值，则顺时针放置副本。
总角度 （“环形”阵列类型）设置排列副本时所用的总角度。
  • 如果为正值，则逆时针放置副本。
  • 如果为负值，则顺时针放置副本。
旋转项 （环形阵列类型）如果打开此项，则围绕阵列的中心旋转元素。

（沿路径阵列类型）如果打开此项，则旋转元素以保持其相对于路径元素的方向。

模式 （沿路径阵列类型）设置创建阵列的方式。
  • 数量 — 通过“副本数”设置定义阵列中的项数。
  • 距离 — 通过“距离”设置定义阵列中各项间的距离。
  • 两者 — 分别通过“副本数”和“距离”设置定义阵列中的项数以及每项间的距离。
距离 | （“沿路径”阵列类型）设置阵列中项之间的距离。
使用围栅 | 如果打开此项，则将围栅内容复制到阵列中。此选项菜单将设置围栅（选择）模式。
键入: ARRAY RECTANGULAR
键入: FENCE ARRAY RECTANGULAR
键入: ARRAY POLAR
键入: FENCE ARRAY POLAR
键入: ARRAY PATH
键入: FENCE ARRAY PATH
键入: ARRAY ICON
父主题: 操作围栅内容


使用多线

多线元素由最多 16 个单独定义的线以及可选的终端端帽和节点组成。更改某个多线线型时，文件中使用选定多线线型的所有元素都会更新。

多线

父主题: 操作围栅内容


删除围栅内容

用于删除围栅内容。

您可以通过以下方式访问此工具：

键入: FENCE DELETE
父主题: 选择


打散围栅内容

用于将围栅中的内容打散为其组件。然后便可单独操作各个元素。

您可以通过以下方式访问此工具：

设置 | 描述
复杂元素 | 如果打开此项，复杂元素（单元、复杂链、复杂形状、文本节点、曲面或实体）将打散为其组件。
尺寸标注 如果打开此项，元素尺寸标注将打散成线、线串、椭圆、弧和文本。
  • 转为几何图形 — 打散为线、线串、椭圆、弧和文本。
  • 转为段 — 打散为单个尺寸标注段。
线串/形状 | 如果打开此项，线串和形状将转换为一系列单独的线元素。
多线 | 如果打开此项，多线元素将转换为线串、线和/或弧的集合。
共享单元 如果打开此项，则可以使用关联的选项菜单来打散共享单元：
  • 转为几何图形 — 打散为其组件。
  • 转为普通单元 — 转换为非共享单元。
文本 | 如果打开此项，文本元素中的文本字符将转换为用于绘制字符的单个元素 — 线、线串、弧、椭圆和形状。
应用程序元素 | 如果打开此项，则可用于打散线宽较细的几何图形。
围栅模式 设置确定围栅内容的方法。
  • 内部
  • 重叠
  • 剪切
  • 排空
  • 排空重叠
  • 排空剪切
键入: DROP FENCE
注释: “打散围栅内容”无法用来一次在多个层上打散元素。例如，如果打开“复杂”和“线串/形状”并在包含两个线串的复杂形状上运行，则将打散复杂形状，但不打散组件线串。即此操作会生成两个线串。
打散复杂状态
父主题: 选择


打散复杂状态

用于将复杂元素（单元、复杂链、复杂形状、文本节点、曲面或实体）打散成若干组件，随后可以单独操作这些组件。

您可以通过以下方式访问此工具：

键入: DROP COMPLEX
提示: 要快速打散多个复杂元素，请放置围栅并使用“打散围栅内容的复杂状态”工具。
父主题: 打散围栅内容


指定围栅内容中包含哪些元素

围栅（选择）模式确定哪些内容构成围栅内容 — 即围栅内部、围栅外部或与围栅重叠的元素（或部分元素）是否“包含”在要处理的围栅中。

  • 内部 — 仅处理完全位于围栅内部的元素。
  • 重叠 — 仅处理位于围栅内部或与围栅重叠的元素。
  • 剪切 — 仅处理完全位于围栅内部的元素以及位于围栅内部和与围栅重叠的部分元素。
  • 排空 — 仅处理完全位于围栅外部的元素。
  • 排空重叠 — 仅处理位于围栅外部或与围栅重叠的元素。
  • 排空剪切 — 仅处理完全位于围栅外的元素以及位于围栅外并与围栅存在重叠的部分元素。

    围栅选择模式。左图：围栅块和元素。右图：每种围栅选择模式下的围栅内容。

围栅选择模式是一种工具设置（标记为“围栅模式”），用于绘图 > 主页 > 选择 > 围栅工具中的围栅工具以及可以对围栅内容执行操作的操作工具。对于后一种情况，可以通过“使用围栅”控制选项旁的选项菜单进行设置。“锁定”对话框中也有一个控制选项。

注释: 设置围栅选择模式时，无需放置或调出围栅。相反，放置围栅后，可以调整围栅选择模式以更改围栅内容，而无需移动或替换围栅。
“首选项”对话框：“操作”类别
操作多个元素
创建打开的 DGN 文件的备份副本
GUID-D957F451-7FB6-720E-E09D-5A95B82D1BAB
父主题: 选择


“首选项”对话框：“操作”类别

由用于设置与元素选择和标识、绘图指针以及层标识相关的首选项的控制选项组成。

设置 | 描述
打开多个应用程序窗口 | 如果打开，则可在具有多个显示屏幕的系统上打开多个 OpenRoads Designer 应用程序窗口。从该设置旁边的下拉列表中，可以选择显示屏幕的数量。最多可以选择四个显示屏幕。缺省值为关闭。您需要重新启动 OpenRoads Designer 会话，才能使此设置更改生效。 如果打开，则可通过从视图窗口的控制菜单中选择更改屏幕，在不同的屏幕之间移动视图窗口。
按层同步线符 | 如果打开，则打开其他模型或视图组时，激活颜色、线型和线宽将设置为“按层”。 注释: 如果已设置配置变量 ，则此设置将暗显。
高亮显示断开的关联 | 如果打开，将通过更改相应线宽和线型自动标识失去关联的元素。缺省值为打开。
显示所有视图中的激活层 | 如果打开（缺省值），将显示所有视图中的激活层。
查看工具应用于激活视图 | 如果打开（缺省值），查看工具将使用激活视图。如果关闭，从视图边框工具箱以外的位置打开且不需要额外输入的查看工具将提示选择视图，而不是使用激活视图。
使用首选项中的捕捉模式 | 如果打开，捕捉模式数据将保存到用户首选项文件。如果关闭，捕捉模式数据将存储到 DGN 文件。
资源高速缓存 | 设置为从产品资源文件和应用程序资源文件中读取的资源保留的内存量 (KB)。缺省值为 1024。
父主题: 指定围栅内容中包含哪些元素


操作多个元素

对很多元素（例如大型数组）执行的部分围栅操作可能需要很长时间才能完成。

为了减少可能存在的问题，请在尝试执行此类操作之前备份 DGN 文件。

父主题: 指定围栅内容中包含哪些元素


创建打开的 DGN 文件的备份副本

  1. 打开“键入命令”窗口（）。
  2. 在窗口的键入命令栏中，键入 BACKUP [file_specification]。

    File_specification 是要保存备份副本的目录。如果省略 file_specification，会将一份打开的 DGN 文件的副本（带有“.bak”扩展名）保存至 MS_BACKUP 指定的目录。

    已打开的 DGN 文件不会关闭。

父主题: 指定围栅内容中包含哪些元素


来自围栅的命名边界

通过“放置围栅”工具放置围栅时，可选择将其另存为命名边界，以供将来使用。例如，这种做法在创建模型多个部分的检查点时非常有用。您可以快速调出命名边界，用以重新创建打印。

展开“放置围栅”工具设置时，您会看到用于创建、删除和激活命名边界的选项。

父主题: 选择


模型分析与报表

报告
土木分析
廊道报表
父主题: 主页


报告

在工具箱中选择 | 描述
平面曲线数据表 | 该过滤器用于指定要包括在报告数据文件中的平面路线组。
纵断面报表 | 该过滤器用于指定要包括在报告数据文件中的纵面路线组。
合规报表 | 该过滤器用于指定有关闭合路线和参考路线的信息。
地图检查报表 | 该过滤器用于根据绘制的数据（而不是软件存储的内部精度）指定信息。
桩号偏移报表 | 该过滤器用于指定有关选定路线或特征的桩号偏移数据的信息。
点特征桩号偏移高程 | 创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。
桩号基准报表 | 该过滤器用于指定有关选定路线或特征的桩号基础数据的信息。
超高报表 | 该过滤器用于指定有关超高的信息，并可显示选定区间的数据。
平面曲线数据表
纵断面报表
合规报表
地图检查报表
桩号偏移报表
点特征桩号偏移高程报表
桩号基准报表
超高报表
父主题: 模型分析与报表


平面曲线数据表

用于从所选土木平面几何元素生成报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

使用“平面曲线数据表”从所选土木平面几何元素生成报告。该报告包含坐标、桩号设置以及有关所选元素的其他几何数据。

工作流

1.选择“平面曲线数据表”工具。

2.按照危险警告提示操作：

提示 | 用户操作
定位第一个元素 | 选择一个土木平面几何元素。
定位下一个元素 - 重置可完成 | 继续选择元素。选择所有元素后，单击“重置”移至下一提示。
起点桩号 | 输入一个数据点以图形方式进行定义。或者，键入桩号，按 ENTER，然后输入一个数据点以继续。
终点桩号 | 输入一个数据点以图形方式进行定义。或者，键入桩号，按 ENTER，然后输入一个数据点以继续。
间隔 | 向 XML 报告数据文件添加其他点（称为计算事件点）。如果键入命令字段中的值大于 0.0，软件将沿每个所选路线计算点。在每个路线上，计算点之间的距离等于指定间隔。计算点将添加到 XML 报告数据文件中。
纵断面 | 对不包含纵断面数据的 XML 文件选择“无”，对仅包含 XML 路线的激活纵断面的 XML 文件选择“激活纵断面”，对包含属于路线子项的所有纵断面的 XML 文件选择“全部”，对仅包含选择集中现有纵断面的数据的 XML 文件选择“选择”。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。

父主题: 报告


纵断面报表

用于创建包括有关所选纵面路线的信息的 XML 报告数据文件。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包括有关所选纵面路线的信息的 XML 报告数据文件。要运行此工具，系统将提示用户从长断面视图中选择一个或多个纵面元素。

  1. 从“分析与报表”工具组中选择“纵断面报表”工具。

  2. 按照危险警告提示操作：

提示 | 用户操作
定位第一个纵断面元素 | 在纵断面窗口中选择土木纵面几何元素。
定位下一个纵断面元素 - 重置可完成 | 选择其他元素或单击“重置”移至下一提示。
父主题: 报告


合规报表

用于根据一组闭合土木平面元素和参考元素生成报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“合规报表”工具根据一组闭合土木平面元素和参考元素生成报告。

1.选择“合规报表”工具。

2.按照危险警告提示操作：

提示 | 用户操作
定位第一个元素 | 选择属性的第一个元素。请注意，可以使用复杂的闭合土木平面几何元素。
定位下一个元素 | 重置以完成，继续选择元素以定义闭合形状。选择所有元素后，单击“重置”移至下一提示。
定位父项 - 重置可跳过 | 指定或忽略父路线。
定位主要参考 - 重置可跳过 | 指定主要和次要参考元素。
主要参考路线带宽 | 如果选择了主要参考元素，但未选择次要参考元素，软件将检查每个点是否在指定的带宽内。如果是，则显示主要参考的合规参考信息。如果超出带宽，则不显示任何合规参考信息。
定位第一个次要参考元素 - 重置可完成 | 如果同时选择了主要和次要参考元素，软件将检查每个点是否在指定的带宽内。如果是，则显示主要参考元素的合规参考信息，而非任何次要参考元素的信息。如果点超出带宽，则使用最近的次要参考元素。
定位下一个次要参考元素 - 重置可完成 | 如果主要参考元素也被选为次要参考元素，则将主要参考元素视为普通的次要参考元素以及主要参考元素。这意味着，如果某个点超出带宽，但主要参考元素仍是最近的元素，则显示主要参考元素的合规参考信息。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

另请参阅

土木分析与报告命令

父主题: 报告


地图检查报表

用于根据绘制的数据（而不是软件存储的内部精度）生成包含精度信息的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“地图检查”根据绘制的数据（而不是软件存储的内部精度）生成包含精度信息的报告。设计出图时，长度和方向的精度仅限于绘制的值，而不是软件维护的完整值。这些绘制的值在构建期间使用，这可能会引入原始设计中不存在的闭合误差。此工具可用于根据绘制的精度确定闭合误差。

1.从“分析与报表”工具组中选择“地图检查报表”工具。

2.按照危险警告提示操作：

选择第一个元素

请注意，可以使用复杂的闭合土木平面几何元素。

定位下一个元素

重置以完成，继续选择元素以定义闭合形状。选择所有元素后，单击“重置”移至下一提示。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。

另请参阅

土木工程报告浏览器

父主题: 报告


桩号偏移报表

用于创建包含所选平面几何元素的桩号偏移数据的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包含所选平面几何元素的桩号偏移数据的报告。偏移始终沿与基准元素垂直的方向相对偏移元素测量。报告的桩号设置沿偏移元素测量。偏移用于基准（非偏移）元素上的方位基点。

“间隔”（可选）定义每个偏移测量值之间沿偏移元素的距离。值为零不会产生任何影响。

“偏移”（可选）使偏移距离测量到不是直接位于偏移元素上、而是按指定距离进行偏移的点。值为零不会产生任何影响。

工作流

  1. 从“分析与报表”工具组中选择“桩号偏移报表”工具。

  2. 在“工具设置”中定义可选“间隔”或“偏移”。

  3. 按照危险警告提示操作：

提示 | 用户操作
定位元素 | 选择一个土木平面几何元素。
定位第一个偏移元素 | 选择要计算偏移的土木平面几何元素。
定位下一个偏移元素 - 重置可完成 | 继续选择元素。选择所有元素后，单击“重置”生成报告。

4.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。

父主题: 报告


点特征桩号偏移高程报表

用于创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“点特征桩号偏移高程报表”工具可创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。基线元素可以是线性、弧、曲线或任何非点元素。点可以是土木单元或 MicroStation 单元、零长度线或点。偏移始终沿与基线元素垂直的方向相对点测量。报告的桩号设置沿基线元素测量。如果所选点没有点名称或特征，则字段留空。如果使用二维模型或视图中的数据，则高度字段为空。该工具可用于二维或三维视图或模型。

创建点特征桩号偏移高程报告
父主题: 报告


桩号基准报表

用于创建包含所选平面几何元素的桩号偏移数据的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包含所选平面几何元素的桩号偏移数据的报告。偏移始终沿与基准元素垂直的方向相对偏移元素测量。报告的桩号设置沿基准元素测量。偏移用于基准（非偏移）元素上的方位基点。

“间隔”（可选）定义每个偏移测量值之间沿基准元素的距离。值为零不会产生任何影响。

“偏移”（可选）使偏移距离测量到不是直接位于基准元素上、而是按指定距离进行偏移的点。值为零不会产生任何影响。

1.选择“桩号基准报表”工具。

2.在“工具设置”中定义可选“间隔”或“偏移”。

3.按照危险警告提示操作：

提示 | 用户操作
定位元素 | 选择一个土木平面几何元素（上面称为基准元素）。
定位第一个偏移元素 | 选择要计算偏移的土木平面几何元素。
定位下一个偏移元素 | 重置以完成，继续选择元素。选择所有元素后，单击“重置”生成报告。

4.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

另请参阅

土木工程报告浏览器

父主题: 报告


超高报表

创建桩号、过渡段、横坡以及其他超高数据的超高 XML 报告并打开 Bentley 土木工程报告浏览器。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。

1.选择“超高报表”工具。

2.按照危险警告提示操作：

提示 | 用户操作
定位第一个超高断面 | 选择先前创建的超高断面。请注意，可以在选择工具之前创建超高断面的选择集。在这种情况下，系统会提示您输入一个数据点以接受选择集中的元素。
定位下一个超高断面 - 重置可完成 | 继续选择超高断面。完成后，单击“重置”显示报告。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

另请参阅

土木工程报告浏览器

父主题: 报告
父主题: 报告


土木分析

在工具箱中选择 | 描述
测点分析 | 报告 TM 中的用户指定点位置的相关信息（高程、坡度、等高线、坡度方向）。
反转点 | 计算并显示每对指定点之间的距离和方向。
分析土方量 | 计算 2 个 TM 或 TM 与平面（立面）之间的土方量。能够在一个区域（围栅）或多个区域中进行处理并计算一系列高程内的土方量。也可以选择挖方和填方系数。
测点间分析 | 报告 TM 上 2 个点位置之间的信息（高程差、长度和坡度）。
分析轨迹边坡 | 沿用户指定的坡度值或最陡坡度跟踪曲面。可以追踪上游或下游。
分析水塘 | 分析通过 TM 上的数据点位置定位的水塘（低点）的地形模型（土方量、区域最大深度）。
元素组件工程量 | 用于报告单个或多个土木单元或廊道以创建组件工程量摘要的报表工具。
三维漫游 | 沿线形生成快速漫游可视化。
测点分析
反转点
分析土方量
测点间分析
分析轨迹边坡
分析水塘
元素组件工程量
三维漫游
特征定义
OpenRoads Designer 标准
父主题: 模型分析与报表


测点分析

用于动态查看有关所选二维或三维设计元素、地形模型或网格的信息。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“测点分析”工具动态查看有关所选二维或三维设计元素、地形模型或网格的信息。

结果基于所选元素的类型。例如，如果选择了二维 MicroStation 元素，则结果包括“桩号”、“偏移”、X、Y 和“方向”。

在这种情况下，桩号设置基于元素原点的 0+00，而“偏移”基于光标到元素的垂直距离。如果选择了三维元素，此时将显示高程和斜率。

利用地形模型或网格时，还显示有关点所在三角形的信息。这可能包括斜率和长宽比。也可以绘制等高线。

先决条件

需要二维或三维 MicroStation 元素、土木几何元素、地形模型或 MicroStation 网格

非曲面元素工作流

  1. 启动工具。

  2. 选择二维或三维元素。

  3. 当光标移动时，在对话框和工具提示中报告点信息。

地形模型或网格工作流

  1. 启动工具。

  2. 选择地形模型或网格。

  3. 当光标移动时，在对话框和工具提示中报告点信息。如果光标点在地形模型外部或在空区内部，则仅显示一条消息，即没有点数据。

  4. 使用 ALT 键盘按钮更改对话框选项以显示等高线、三角形、高程、坡度箭头。

  5. 数据点在默认层绘制显示的等高线。

选项

设置 | 描述
显示等高线 | 显示与用户选择点的高程相同的所有等高线。例如，如果点的高程为 153.64，则显示地形模型中高程为 153.64 的所有等高线。
仅显示在视图中的等高线 | 仅显示视图中的等高线，而非显示用户选择点的所有等高线。这对于非常大的地形模型十分有用
显示边坡 | 以百分比显示三角形的斜率（与水平面相比）
显示三角网 | 高亮显示用户选择点所在的三角形。
设置 | 描述
桩号 | 根据用户选择的平面几何元素报告光标位置的桩号位置。
偏移 | 根据用户选择的平面几何元素报告光标位置的偏移。
X | 报告用户选择点的 X 坐标。
Y | 报告用户选择点的 Y 距离。
高程 | 报告用户选择点的高程（以主单位表示）。
坡度 | 报告用户选择点所在三角形的坡度（以百分比表示）。该斜率从水平面进行测量。
坡向 | 报告用户选择点所在三角形的坡向。该坡向描述三角平面的朝向。坡向范围以度表示。北向轴定义为零度，角度沿顺时针方向增加。因此，零度指北，90 度指东，180 度指南，270 度指西。为水平三角形分配默认坡向 360 度。
父主题: 土木分析


反转点

用于计算并显示每对指定点之间的距离和方向。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

“反转点”工具计算并显示每对指定点之间的距离和方向。支持几种类型：线性、弧、径向、垂直和按元素。二维和三维视图/模型中均支持该工具。结果显示在光标提示符和（可选）土木工程报告浏览器中。能够以图形方式或通过键入现有测量点名称选择点。

此工具使用激活 MicroStation 线符、文本设置和绘图比例。方向值利用“设计文件设置”>“角度显示格式”设置确定格式、精度和方向模式。用于距离的小数位数由“设计文件设置”>“工作单位”>“线性单位精度 (Linear Units Accuracy)”值确定。用户不能定义注释的布局和内容。

顺序非常重要，因为方向是从第一点计算到第二个点。所有输入类型通用的选项。

所有输入类型支持以下选项。请注意，这些选项必须在工具设置中设定，因为它们没有对应的危险警告提示。

选项 | 描述
报表 3D | 切换为打开状态后，显示和注释包括两点间的水平距离、方向、坡距和高差。切换为关闭状态后，仅显示水平距离和方向。
标注 | 切换为关闭状态后，不显示注释，仅显示元素（基于输入类型）。切换为打开状态后，将显示注释。
保存 | 切换为关闭状态后，仅当工具处于激活状态时才显示元素（基于输入类型）。重置后，不再显示所有元素/注释。切换为打开状态后，元素/注释会写入激活文件，并在命令完成后可见。要保存注释，“标注”开关也必须处于打开状态。
输出报告 | 切换为关闭状态后，输出将显示在提示字段和土木消息中心内。当“输出报告”切换为打开状态（定义了反转点）后，重置操作将打开土木工程报告浏览器以显示填入了反转点的反转报告。
使用点名称 | 可以使用测量数据点来代替以图形方式选择点。支持在单个工具中混用数据点和测量点。打开该选项，然后将鼠标悬停在某个测量点上方，随即显示其名称。（如果已知点名称，则无需悬停。）在危险警告提示或工具设置的相应字段中键入该名称，然后按 Enter 或 Tab 以接受并移至下一提示。“使用点名称”可与任何输入类型一起使用。
输入类型
在两点之间反向
反向弧上的点
径向反向点
在两点之间垂直反向点
按元素垂直反向点
按元素反向点
父主题: 土木分析


分析土方量

用于计算两个模型或一个模型和一个平面之间的土方量并（可选）将结果放在文件中用户定义的位置。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 土方量拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“分析土方量”工具计算两个模型或一个模型和一个平面之间的土方量并（可选）将结果放在文件中用户定义的位置。针对两个地形模型的并集（对于模型到模型选项）或整个地形模型和高程之间（对于高程选项）计算土方量。可以指定一个可选边界来计算部分地形模型的土方量。在这种情况下，通过从边界元素垂直绘制以与地形模型相交来计算土方量。

先决条件

此工具至少需要一个地形模型。

工作流

  1. 启动工具。

  2. 指定“土方量方法”（可调整后续提示）。

  3. 指定“地形模型来源”。

  4. 指定“到地形模型或高程”（对于“地形模型到高程 (Terrain Model to Elevation)”选项）。

  5. 选择边界（或重置为“无”）。

  6. 如果需要，设置挖方和填方系数。

  7. 接受。

  8. 如果“保存结果”切换到打开状态，则在激活视图中放置结果的位置上点击确认。

设置 | 描述
容积法 | 地形模型到地形模型土方量：确定两个地形模型之间的土方量。此选项通常用于确定从现有地面地形到所建议表面的项目土方量。 地形模型到平面：确定地形模型和指定高程之间的土方量。此选项通常用于确定水位（高程）和所建议水塘之间的土方量。
地形模型来源 | 地形模型或网格。
到地形模型 | “地形模型到地形模型土方量”中使用的地形模型。
到平面 | 为“地形模型到平面”计算指定的高程。
挖方系数 | 应用于挖方土方量。此参数也称为膨胀系数，用于定义材料从地面移除后体积会增加多少。例如，值 1.3 表示挖方材料将膨胀到原始体积的 1.3 倍。默认值为 1.0，即不做任何调整。
填方系数 | 应用于填方土方量。此参数也称为压缩系数，用于定义填方材料放入场地后体积会减少多少。例如，值 0.8 表示填方材料将缩小到原始体积的 0.8 倍。默认值为 1.0，即不做任何调整。
挖方量 | 调整后的挖方材料体积（以立方英尺或米为单位）。如果“挖方系数”设置为除 1 以外的其他值，则此值将该系数考虑在内。
填方量 | 调整后的挖方材料体积（以立方英尺或米为单位）。如果“填方系数”设置为除 1 以外的其他值，则此值将该系数考虑在内。
平衡方量 | 挖方和填方土方量之差（以立方英尺或米为单位）。
保存结果 | 切换为打开状态后，系统会提示用户在激活文件中点击确认以放置结果。
父主题: 土木分析


测点间分析

用于查看地形模型或网格的两个所选点之间的高程、斜率、距离和增量信息。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“测点间分析”工具查看地形模型或网格的两个所选点之间的高程、斜率、距离和增量信息。

工作流

1.启动工具。

2.选择地形模型。

3.输入一个数据点作为第一点。如果该点在地形模型外部或在空区内部，则不是有效的点，因此不被接受。必须选择其他点。

4.输入一个数据点作为第二点。（如果第二点在不同的地形模型上，请使用 ALT 键盘按钮。）

5.报告点之间的距离、坡度和高差。

设置 | 描述
高程 1 | 地形模型或网格在第一个所选点的 X、Y 坐标处的高程（以主单位表示）。
高程 2 | 地形模型或网格在第二个所选点的 X、Y 坐标处的高程（以主单位表示）。
高差 | 高程 1 和高程 2 之间的高差（以主单位表示）。
坡度 | 根据点 1 和点 2 的 X、Y 坐标报告两点之间的直线斜率及其相应的地形高程。它不考虑两点之间的地形斜率。
长度 | 报告两点之间的直线长度。
角度 | 根据点 1 和点 2 的 X、Y 坐标报告两点之间的直线方向。
父主题: 土木分析


分析轨迹边坡

用于动态追踪地形模型或网格曲面上的路径。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 水力拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“分析轨迹边坡”工具动态追踪地形模型或网格曲面上的路径。例如，以水滴顺着所选地形模型（或网格曲面）向下移动或从曲面向上移动到水源的路径为例。输入包括路径原点的数据点。

支持两种轨迹方法：最大坡度轨迹和常数边坡轨迹。

如果将“最大坡度轨迹”方法与“向下”选项结合使用，则所示路径遵循从经过地形模型或网格的点到地形模型或网格的低点或边缘的最陡下降。如果与“向上”选项结合使用，则所示路径遵循从经过地形模型或网格的点到地形模型或网格的低点或边缘的最陡下降。

使用“常数边坡轨迹”方法时，需要更多输入信息：斜率（以百分比表示）和距离（以主单位表示）。假设使用斜率 5% 和距离 500 主单位。初始数据点放置在屏幕上，当光标移动时，将显示各种解。每种可能的解由一个长度为 500 主单位的线串组成，且其斜率基于地形模型的实际斜率。因此，该线串沿着指定斜率的路径蜿蜒，直到长度为 500 主单位（或者如果无解，则小于 500 主单位）。将 DP2 置于屏幕上时，在数据点时间动态显示的第一个线串现已固定。使用 DP 2 作为初始端点，将动态显示新的解。请注意，根据样板房的地形，介于 DP 3 和 DP 4 之间的解有近 90 度的转弯。在 DP 4 附近的这个分段结尾处也有一个小转弯。请注意，您只需输入一个数据点来定义原点，而软件则确定路径的其余部分。

（向下）轨迹边坡中的一个选项是考虑“最小深度”。地形模型有大量低点，但这些区域中有很多只是模型中的小凹痕或凹陷，在这些地方水会流到附近的低点。要利用此选项，请将值设置为以主单位表示的深度（英尺或米）。Bentley Civil 确定每个低点，然后确定放置在指定深度的水是否溢出凹痕并流入相邻三角形。如果水没有流入相邻三角形，则在追踪过程中将其用作低点。如果水流入相邻三角形，则对相邻三角形上的点进行深度测试，直至找到深度测试不溢出的点。然后，将此点用作低点。设置为零时，不利用“最小深度”。

工作流

1.启动工具。

2.选择地形模型。

3.按照屏幕下角的提示操作：按 Alt 键切换上游/下游、按 Shift 键更改为常数边坡。或者，在对话框中设置选项。

4.点击确认以显示轨迹路径。

5.点击确认以将瞬态图形保存为带形线的元素。请注意，可以使用前面的对话框设置启动另一个轨迹边坡的其他数据点。

设置 | 描述
轨迹方法 | 最大坡度轨迹 - 在指定斜率沿模型或对象表面移动。 常数边坡轨迹 - 在高程 1 处找到一个区域。
坡度 | 选择以指定坡度。如果未选择，将使用模型或对象的高程。
长度 | 在最大距离处绘制每条轨迹（以主单位表示）。轨迹非线性，而是遵循模型或对象的指定斜率。
最小深度 | 最小低点。值 0.0 表示不会使用最小低点深度。
跟踪边坡方向 | 向上：显示一个箭头，指示从所选点逆流而上的方向。 向下：显示一个箭头，指示从给定点顺流而下的方向。

特征

有关详细信息，请参考特征定义。

父主题: 土木分析


分析水塘

用于沿着下游追踪一个点到低点，然后填充它，得出土方量、最大深度和最大高程。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 水力拆分按钮

“水塘分析”工具沿着下游追踪一个点到低点，然后填充它，得出土方量、最大深度和最大高程。此外，以图形方式显示水塘描述。

显示水塘 - 设置为“激活水塘”时，仅创建/分析一个水塘。设置为“所有水塘”时，测试所有低点，如果可以创建一个满足“最小深度”的水塘，则创建/绘制该水塘。将鼠标悬停在水塘上方时，将显示“土方量”、“深度”和“高程”。

当“下降轨迹”切换为打开状态后，将显示（从用户指定的原点）到水塘的下降轨迹以及水塘轮廓。“高程 1”是地形模型上的原点的高程，而“高程 2”是用于创建水塘的低点。

工作流

1.启动工具。

2.选择地形模型。

3.当光标移动时，将显示轨迹路径以及从光标点下游找到的任何水塘。

4.点击确认以将瞬态图形保存为带形线的元素。

以图形方式显示水塘描述。

常规

设置 | 描述
水塘容量 | 沿着下游追踪一个点到低点，然后填充它以显示土方量。
深度 | 沿着下游追踪一个点到低点，然后填充它以显示最大水塘深度。
高程 | 沿着下游追踪一个点到低点，然后填充它以显示最大曲面高程。

过滤器:

水塘过滤器 - 无过滤（不执行任何操作）

按面积过滤 - 选中时，其他字段包括“最小面积”（以主单位表示）。软件将仅考虑/显示大于用户指定面积的水塘解决方案。

按深度过滤 - 选中时，其他字段包括“最小深度”（以主单位表示）。软件将仅考虑/显示深度大于或等于用户定义“最小深度”的水塘解决方案。

显示所有水塘 - 切换为打开状态后，显示地形模型中的所有水塘。切换为关闭状态后，仅显示包含当前光标位置的水塘。点击确认，以将该水塘绘制到激活文件中。

特征

有关详细信息，请参考特征定义。

父主题: 土木分析


元素组件工程量

用于报告单个或多个土木单元和/或廊道以创建组件工程量摘要。

您可以通过以下方式访问此工具：

  • 功能区：主页 > 模型分析与报表 > 廊道报表拆分按钮
  • 功能区：廊道 > 查看 > 廊道报表拆分按钮

“元素组件工程量”是一种报告工具，用于报告单个或多个土木单元和/或廊道以创建组件工程量摘要。使用报告浏览器的详细报告极大地简化了各个组件的手动报告。

  1. 选择“分析与报表”>“元素组件工程量”。
    选择要报告的单个元素之后，在重置工具以生成用于选择集的摘要报告之前，选择要报告的后续元素。
  2. 从摘要表中选择“报表”，将报告浏览器打开到详细报告选项样式表。
父主题: 土木分析


三维漫游

另请参阅三维漫游。

父主题: 土木分析


特征定义

特征定义 用于控制线符、注释以及应用于几何元素的各种其他属性。

特征定义用于：

  • 定义几何元素的实质。所建模的对象，如路缘、中心线等。

  • 在各种视图中控制线符，包括能够在平面、纵断面和三维空间中定义不同的线符

  • 定义地形建模特性（点、切断线、空区等）

  • 定义曲面显示特性

特征切换栏

有关详细信息，请参考“工具”>“土木几何”>“特征切换栏”。

命令对话框上的特征字段

命令具有用于特征定义的输入字段。

特征定义 | 选择描述所创建元素的特征定义。例如，路缘或中心线。使用“特征切换栏”上的“覆盖”开关，强制此特征定义“使用激活”（建议的工作流）。
名称 | 该名称通过选定的特征定义进行填充。如果需要，用户可以使用新名称覆盖此名称。

另请参阅

土木标准选项卡

父主题: 土木分析


OpenRoads Designer 标准

土木单元

此分支列出了所有已创建的、在激活设计模型或 DGN 库文件中可用的标准土木单元。土木单元是先前存储的土木对象的集合，这些对象使用灵活但明确定义的规则创建，可在许多项目中重复使用。

土木单元通常存储在一个或多个 DGNLIB 文件中，访问方式类似于 MicroStation 单元或环形交叉口。对于列出的任何土木单元，可以通过右键单击来放置所选土木单元。该命令提示根据需要在所选土木单元的定义中选择外部组件。

设计标准

设计标准用于监视所需的曲率和其他路线检查（在平面土木几何元素上）以及坡度和 K 值（在纵面几何元素上）。

这些标准存储在设计库 (DGNLIB) 中，该库可以为只读并存储在一个中央位置供所有用户使用，并由配置变量 MS_DGNLIBLIST 引用。DGNLIB 是一个类似于种子文件的空文件，可在其中设置各种 MicroStation 和 Civil 资源。组织可以使用许多 DGNLIB，建议将水平和垂直标准存储在一个 DGNLIB 中，但与其他 DGNLIB 类型的数据分开。如果同时使用公制和英制单位，您可能需要为每种单位提供一个 DGNLIB。

这些标准在浏览器中设置。请注意，浏览器中的层次结构将镜像到“设计标准工具栏”选取列表中。可以根据组织的标准自定义该层次结构。

可通过“主页”>“基本”访问项目浏览器。首先完成垂直标准更有效，因为在构建水平标准时将参考垂直标准。

右键单击单个条目并从弹出菜单中选择“属性”以查看设置。

水平设计标准属性

竖向设计标准属性

创建新的水平和垂直标准

注释: 如果已有 SELECTseries 2 水平标准，则可以升级到 SELECTseries 3 并添加垂直标准。

常规程序为：

  1. 确定水平和垂直标准的层次结构。这也决定了从头开始创建多少内容以及复制和粘贴多少内容。请记住，用户可以看到您构建的层次结构，因此请保持名称直观。

  2. 使用 Civil 产品之一打开 DGNLIB 文件。仅加载 MicroStation 无法访问这些工具。从主菜单中选择“文件”>“项目浏览器”。

  3. 在项目浏览器中，单击“土木标准”选项卡。

    注释: 用户选项卡的配置可能与图解不同。可以在主菜单上的“设置”>“项目浏览器”下更改选项卡。
  4. 将层次结构导航到“水平”和“垂直”。这是从头开始构建的起点。

  5. 创建层次结构的第一个部分。在开始时，避免倾向于构建整个层次结构。构建第一个标准，然后复制并粘贴到下一个标准中要更容易，因为许多字段值都相同。例如，双车道与四车道的条目相同，值略有不同。设置双车道文件夹，然后将完成的文件夹复制和粘贴到四车道并根据需要更改值，而不是所有内容都键入两次。

  6. 选择要开始的位置，右键单击并从弹出菜单中选择“新建”。将在标题为“竖向设计标准”的表中生成一个新条目。要重命名，请右键单击并选择“重命名”，然后更改名称。层次结构可以嵌套。

  7. 要设置每个条目的值，请高亮显示相应条目，右键单击并从弹出菜单中选择“属性”。
  8. 单击每个字段并调整值。要设置 K 值，请将“竖向表类型”设置为“K 表”，然后单击“表”以显示图标（三点）。单击以打开弹出的表编辑器。

  9. 向表编辑器添加信息（每个设计速度对应一行）并关闭。

  10. 继续添加其他垂直标准，方法是复制第一个条目并根据需要调整“最小坡度”和“最大坡度”以及“坡度偏差”。通过复制已经获得 K 值表信息，因此不必重新输入该信息。使用标准时，选择水平输入项 50 kph 或 mph 将使用垂直列表中的默认值 50 kph 或 mph。

  11. 完成垂直标准后，转到水平标准。添加新条目和填充标准的过程完全相同。过渡表通过表编辑器完成。

  12. 过渡表 - 请注意，绿皮书具有默认过渡段，但没有最小过渡段。

  13. 为某个超高值（如 4%）完成一组条目后，将整个分组复制并粘贴到标准中最为容易。重命名（例如，将 4% 重命名为 6%），然后调整 6% 分组中的值。这将维护每个条目中的值，因此您只需调整过渡表即可。

“设计标准”分支列出激活设计模型或 DGN 库中可用的设计标准，并启动命令在激活设计模型中为平面和纵面几何创建新的设计标准。“设计标准”定义用于帮助设计师在执行几何布局时保持所需的曲率和其他检查，这些标准通常基于地理区域或权威机构的公认标准，因此建议在 DGN 库中创建和存储这些标准。

要创建新的设计标准，请选择“水平”或“垂直”，然后右键单击以选择“新建”命令。单击“新建”之后，输入设计标准的名称并填充“属性”面板，如下所示。

每个水平标准的属性如下：

  • 设计值

    • 速度 - 这是标准的设计速度。
    • 默认半径 - 这是在命令启动时用来填充命令的半径。
    • 最小半径 - 这是相应设计速度的最小半径。使用小于此半径的值将导致显示警告。
    • 过渡段类型 - 可以是“表”或“公式”。
    • 表 - 如果“过渡段类型”为“表”，则此属性用于填充表。
    • 包括过渡段
    • 检查相切

  • 弧

    • 最大弧长
    • 最小弧长

  • 切线

    • 最大切线长度
    • 最小切线长度
    • 最大偏差 - 两条切线在无曲线的情况下连接时线间的最大角度。

  • 竖向设计标准

每个垂直标准的属性如下：

  • 最小坡度

  • 最大坡度

  • 最大坡度偏差

  • 竖向表类型

  • 表

父主题: 土木分析


廊道报表

此工具箱包含多个廊道报表。所有报表都需要选择一个廊道才能在 Civil 报表浏览器中生成报表。缺省报表（如安装包中提供）如下所述，但您可以选择多种不同报表中的任意报表作为缺省报表。

在工具箱中选择 | 描述
组件数量 | 报表包括组件（即混凝土、表层土、紧急停车带、挖方和填方）表面积、体积、测量单位、单位成本以及要素成本和总成本。预览窗口将显示相关信息，单击报表按钮可将报表在 Civil 报表浏览器中打开。
设计输入报表 | 在 Civil 报表浏览器中打开缺省路面设置报表，其中包括廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡、末端条件异常以及超高区间信息。
结果报表 | 打开与设计输入报表相同的报表。
清表报表 | 打开带有压碾/剥离组件报告的 Civil 报告浏览器。
超高报表 | 可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。
报表概述
组件数量
设计输入报表
结果报表
清表报表
超高报表
父主题: 模型分析与报表
父主题: 检查


模型导入/导出

导入地形
导入几何
导入 IRD
父主题: 主页


导入地形

“导入地形”选项卡包含许多创建地形模型的工具，既可从图形元素、ASCII 文件、点云、LandXML 中创建，也可通过从各种 Bentley Civil 产品中导入来创建。这些工具还支持将两个或以上模型合并在一起，另外还支持剪切模型。

设置 | 描述
从文件 | 通过从外部文件导入来创建地形模型。支持大量文件格式，例如 USGS DEM、DTED、Lidar (*.las) 和本地产品（InRoads、GEOPAK 和 MX）。
从图形过滤器 | 一种自动存储图形元素搜索设置的方法，用于自动“按元素创建地形模型”。使用“图形过滤器管理器”存储的设置来创建地形。
从元素 | 从三维图形元素创建地形模型。
按文本内插创建 | 从还包含高程标签的二维图形中创建地形模型。
从 ASCII 文件创建地形模型 | 从还包含高程标签的二维图形中创建地形模型。
从点云创建 | 从 MicroStation Point Cloud 数据中创建地形模型。
创建剪切的地形模型 | 通过剪切现有地形模型和给定可选横向或竖向偏移来创建地形模型。
创建复合地形模型 | 通过合并/附加多个地形模型来创建新的复合地形模型。
创建增量地形模型 | 通过两个地形模型之间的差异或地形模型与平面之间的差异（高程）来创建新的地形模型。
创建廊道备选表面 | 根据廊道模型中的用户指定点沿任何给定路径创建地形模型。
父主题: 模型导入/导出


导入几何

该工具用于导入到本地产品（InRoads、GEOPAK 和 MX）或从其中导出，还具有可从通用 MicroStation 元素中创建“土木”元素的工具。

在工具箱中选择 | 描述
导入几何 | 如果坐标几何数据库中存储的图形元素为 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素，则可导入这些元素。
从 ASCII 文件导入平面几何图形 | 用于通过文本向导从 ASCII 文件导入平面几何元素。
从 ASCII 文件导入纵面几何 | 用于通过文本向导从 ASCII 文件导入纵面几何元素。
父主题: 模型导入/导出


导入 IRD

设置 | 描述
导入 IRD | 导入（SELECTseries 2）以及 Roadway Designer (IRD) 文件中包含的以前版本的廊道。
父主题: 模型导入/导出


“RSS 阅读器”对话框

用于从 Bentley 网站和社区中获取所有更新和新闻作为 RSS 源。

您可以通过以下方式访问此对话框：

  • 文件 > 帮助 > RSS 阅读器
  • 状态栏：单击 RSS 消息区域。
设置 | 描述
源列表 | 列出最新的源，并附有源网站或论坛的链接。还会显示各个源项的日期和作者。
搜索 | 您可以搜索特定的 RSS 源、关键字或主题。
过滤器 | 您可以根据排序首选项（日期、时间或作者）过滤可用的 RSS 源（单击向下箭头可设置排序首选项）。还会显示源的计数。
设置 | 打开“RSS 设置”对话框，您可以用它来管理产品源。
父主题: OpenRoads Designer 帮助


地形

地形模型 (TM) 在基础设施和映射工作流中起着重要作用。基于这些模型的数据收集方法在细节和覆盖范围方面与日俱增，因而，必须能够在各种基础设施和映射工作流中访问所生成的地形。

可以提供各种格式的数据（包括二维和三维原始图形元素）用于地形模型。现有地面地形模型还可以在使用廊道建模工具创建建议的设计地形模型中用作起点。

地形概述
地形
父主题: OpenRoads Designer CONNECT Edition帮助
相关概念
构成表面


地形概述

地形模型概述

地形模型是根据在正在建模的表面上收集的点数据，以数学方式计算的一组三维三角形。模型用于定义高度不规则的表面，尤其是地球表面，但可以为建议的表面、子表面地理技术层等生成模型。地形模型也称为数字地形模型 (DTM)、三角形化不规则网络 (TIN) 或三角形化曲面。

MicroStation 地形模型工具支持在地形模型中导入和标注地形等高线及点。您可以将地形模型导入到 DGN 以使用其数据。MicroStation 支持从 LandXML 文件格式导入的地形模型。但是，任何操作或从土木产品进行导入操作均必须在 Bentley Civil 中完成。

Bentley Civil 提供了一组强大的工具，用于创建、编辑、分析和使用地形模型。

地形模型作为 MicroStation 元素

地形模型识别为 MicroStation 元素类型。当您选择一个地形模型时，“选择元素”工具的“元素类型”选项卡会指示它为“地形”元素类型。

地形模型和元素模板
引用地形模型
模板属性
特征类型
三角网选项 - 边界方法
元素信息
属性
父主题: 地形


地形模型和元素模板

地形模型和元素模板

“地形模型”工具用于在地形模型中导入和标注地形等高线及点。将地形模型导入 DGN 中可使用其数据。支持从 LandXML 文件格式导入的地形模型。

地形模型识别为 MicroStation 元素类型。当您选择一个地形模型时，“选择元素”工具的“元素类型”选项卡会指示它为“地形”元素类型。

可以使用元素模板来控制地形模型属性的显示。创建完一个具有所需属性的元素模板后，可以将其应用于任何地形模型。

将元素模板应用于地形模型

  1. 使用“选择元素”工具选择地形模型。

  2. 在“基本工具”工具箱中，选择“元素信息”工具。

    将打开“元素信息”对话框。

  3. 在“常规”选项卡上，单击“模板”属性右侧的箭头，并选择元素模板。

    所选元素模板的属性将应用于地形模型。

父主题: 地形概述


引用地形模型

引用地形模型

处于不同工作角色的人们可能想要查看以不同方式显示的地形。例如，曲面设计师可能需要查看三角形，而排水功能设计师可能需要查看等高线。最佳工作流程是保留单个地形模型并将其引用到其他 DGN 文件中，而不是在各个位置复制地形模型。

当将含有地形模型的 DGN 文件引用到另一个 DGN 文件中时，您可以允许该地形模型以不同的方式显示在其他文件中。这样便可针对不同的用途采用不同的显示方式，而不会更改原始 DGN 文件中地形模型的显示。

替代地形模型的线符

  1. 将包含地形模型的 DGN 文件作为参考连接。

  2. 选择地形元素。

  3. 在“基本工具”工具箱中，选择“元素信息”工具。

    将打开“元素信息”对话框。

  4. 在“参考”选项卡中，将“替代线符”属性设置为“是”。

  5. 根据需要更改其他显示属性。

    或

    选择要应用于地形模型的元素模板。

    地形模型的显示在 DGN 文件中发生变化，但在原始 DGN 文件中没有变化。

父主题: 地形概述


模板属性

地形模型的模板属性

模板属性 |  |  |  |
常规设置 | 层 |  |  |
 | 颜色 |  |  |
 | 线型 |  |  |
 | 线宽 |  |  |
计算的特征显示 | 等高线 | 如果打开，则显示地形模型的等高线。 |  |
 | 三角形 | 如果打开，则显示地形模型的三角形。 |  |
 | 三角形顶点 | 如果打开，则允许在地形模型中的每个顶点处使用高程标签。 |  |
 | 流向箭头 | 如果打开，则允许配置指示地形模型上的流向的箭头。 |  |
 | 低点 | 如果打开，则允许在地形模型中的低点处标注符号和高程。 |  |
 | 高点 | 如果打开，则允许在地形模型中的高点处标注符号和高程。 |  |
计算的特征设置 | 等高线 | 最大斜率选项 | “忽略最大斜率”允许省略超过“最大斜率值”的等高线。 |
 |  | 最大斜率值 | 不绘制斜度大于该值的斜率。以小数斜率形式输入“最大斜率值”。小数斜率为主单位中每单位长度的标高变化率。 |
 |  | 光滑因子 | 控制平滑程度。范围为 1 至 10，其中 10 表示最平滑。 |
 |  | 平滑 | 选项包括“无”、“样条”、“无需进行重叠检测的样条”和“顶点”。“无”表示不对等高线进行平滑处理。等高线可能会显示为有角。 “样条”会产生非常平滑的等高线。但性能可能较慢。 “无需进行重叠检测的样条”会跳过对重叠的检测和修正。等高线曲率剧烈变化的区域中，等高线可能会重叠。为获得更佳性能，优先使用此方法，而不是“样条”方法。 “顶点”使用圆形曲线平滑处理算法来代替样条。 |
 |  | 主间距 | 绘制主等高线时所依据的标高范围。 |
 |  | 次间隔 | 绘制次等高线时所依据的标高范围。 |
 |  | 计曲线 | 显示 | 如果打开，则显示计曲线。
 |  |  | 颜色 |
 |  |  | 线型 |
 |  |  | 线宽 |
 |  |  | 透明度 |
 |  |  | 显示文本 |
 |  |  | 文本样式 |
 |  |  | 文本间隔 |
 |  |  | 衰退 用于为地形的凹陷区域定义不同的线符。 | 颜色
 |  |  |  | 线型
 |  |  |  | 线宽
 |  | 间曲线 | 显示 | 如果打开，则显示间曲线。
 |  |  | 颜色 |
 |  |  | 线型 |
 |  |  | 线宽 |
 |  |  | 透明度 |
 |  |  | 显示文本 |
 |  |  | 文本样式 |
 |  |  | 文本间隔 |
 |  |  | 衰退 | 颜色
 |  |  |  | 线型
 |  |  |  | 线宽
 | 三角形 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 主题显示样式 | 允许选择地形模型中三角形的显示方式。这些显示样式与视图特性可用的显示样式相同。 |
 |  | 材质 |  |
 | 三角形顶点 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 点类型 | 请参阅“模板属性”表中的“点单元”。 |
 |  | 单元比例 |  |
 |  | 显示文本 |  |
 |  | 文本样式 |  |
 |  | 文本前缀 |  |
 |  | 文本后缀 |  |
 | 流向箭头 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 箭头类型 |  |
 |  | 单元比例 |  |
 | 低点 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 点类型 |  |
 |  | 单元比例 |  |
 |  | 显示文本 |  |
 |  | 文本样式 |  |
 |  | 文本前缀 |  |
 |  | 文本后缀 |  |
 |  | 最小深度 |  |
 | 高点 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 点类型 |  |
 |  | 单元比例 |  |
 |  | 显示文本 |  |
 |  | 文本样式 |  |
 |  | 文本前缀 |  |
 |  | 文本后缀 |  |
源特征显示 | 断线 | 如果打开，则显示断线。 |  |
 | 边界 | 如果打开，则显示边界。 |  |
 | 导入的等高线 | 如果打开，则显示导入的等高线。 |  |
 | 岛 | 如果打开，则显示岛。 |  |
 | 孔 | 如果打开，则显示孔。 |  |
 | 排空 | 如果打开，则显示排空。 |  |
 | 点 | 如果打开，则显示点。 |  |
源特征设置 | 断线 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 边界 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 导入的等高线 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 岛 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 孔 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 排空 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 | 点 | 颜色 |  |
 |  | 线型 |  |
 |  | 线宽 |  |
 |  | 透明度 |  |
 |  | 点类型 |  |
 |  | 单元比例 |  |
 |  | 显示文本 |  |
 |  | 文本样式 |  |
 |  | 文本前缀 |  |
 |  | 文本后缀 |  |
父主题: 地形概述


特征类型

地形模型特征

地形模型工具中使用特征类型的概念。

特征类型 | 描述
点或高程标注 | 与其他任何点均没有函数关系的点（具有 X,Y,Z 数据）。开放地形中的随机测量点将成为随机点示例。单元、圆和文本字符串等点元素是用于以图形方式定义高程标注的典型 MicroStation 元素。线、线串和其他纵向元素同样有效。软件为每个纵向元素的每个顶点创建高程标注。
切断线 | 切断线用于指定坡度急剧变化的线性特征，如路面边缘、沟渠底、脊等。任何纵向元素均可定义为切断线。在地形模型中，三角形不会贯穿切断线。
软断裂线 | 软切断线是一种切断线，但如果它与切断线相交，不会影响三角网，会被忽略。
等高线 | 具有相同高程的元素或元素集。等高线可以作为源数据来生成地形模型，也可以进行计算（基于地形模型绘制）。等高线间隔是两个相邻等高线之间的高程差。
孔 | 由闭合形状定义的范围，用于标出当前地形被忽略而利用底层地形的区域。
边界 | 表面的外部边界。
覆盖边界 | 通过覆盖到底层表面来确定高程的表面边界。
排空 | 由闭合形状定义的范围，用于标出缺少数据或遮挡范围的区域。不使用空区范围中的点或打断数据，也不会在空区范围内创建三角形。空区坐标包含在三角网中，连续空区坐标之间的孔隙线作为投影线插入表面中。因此，它们不会更改表面的坡度或高程。
垂投空区 | 由闭合形状定义的范围，用于标出缺少数据或遮挡范围的区域。不使用空区范围中的点或打断数据，也不会在空区范围内创建三角形。在垂投空区中，空区坐标不包含在三角网中。空区插在三角网后面。空区坐标和孔隙线投影到地形模型表面上。尽管用户必须为垂投空区顶点提供高程，但用户高程将更改为地形模型表面在 XY 垂投空区坐标位置的高程。
断裂空区 | 由闭合形状定义的范围，用于标出缺少数据或遮挡范围的区域。不使用空区范围中的点或打断数据，也不会在空区范围内创建三角形。它与空区和垂投空区的区别在于，它利用图形元素的顶点高程，而连续空区坐标之间的孔隙线作为切断线插入。因此，断裂空区会更改表面的坡度和高程。
岛 | 由闭合形状定义的范围，用于标出数据完全位于空区中的区域。例如，河流、湖泊等中间的岛。
父主题: 地形概述


三角网选项 - 边界方法

三角网选项 - 边界方法

几个地形模型工具使用三角网选项部分指定边界方法。

许多外边界三角形薄而窄并且不代表表面。数据集的边界在本质上是凹形时，这一点尤为明显。消除这些三角形的一种方法是使用边界方法。

选项 | 描述
“无”或“不删除” | 不删除外部三角形。请注意，最大三角形长度将被忽略。不存在用户定义的参数。
删除裂片 | 基于软件内硬编码的公式，消除长而细的三角形。请注意，最大三角形长度将被忽略。不存在用户定义的参数。
最大三角形长度 | 删除外边界长度超过用户指定距离的外部三角形。请注意，该选项不适用于内部三角形，仅适用于模型边界上的三角形。以主单位指定最大三角形长度。
父主题: 地形概述


元素信息

元素信息中的地形模型

由于地形模型是 MicroStation 元素，因此可以在“元素信息”对话框中找到大量信息。一个重要的选项是打开/关闭地形模型特征的显示。例如，等高线、三角形和空区。

边方法

这将显示创建地形模型时使用的边方法。

源特征显示

关闭或打开用于创建地形模型的任何数据的显示。所做的更改立即显示在屏幕上，无需退出文件并重新进入。

特征

列出选定地形模型的特征名称和特征定义。

信息

列出选定地形模型的 X、Y、Z 范围。另外，它具有每种类型的源特征的数量，即点、空区或切断线的数量。

计算的特征

关闭或打开地形模型中非源数据的任何数据的显示。例如，三角形、高点、低点和流程箭头。所做的更改立即显示在屏幕上，无需退出文件并重新进入。

父主题: 地形概述


属性

地形模型的快速属性

选择地形模型并右键单击“属性”将会打开地形模型“属性”弹出窗口。

通过此方式，可以方便地关闭和打开特征显示。用户还可以更改“边界方法”（对模型重新创建三角网）以及添加或更改“特征名称”或“特征定义”。

父主题: 地形概述


地形

选择
地形创建
地形编辑
地形分析
地形杂项
地形标注
父主题: 地形


选择

另请参阅选择

父主题: 地形


地形创建

“地形模型创建”工具组包含用于从图形元素、ASCII 文件、点云和 LandXML 创建地形模型的工具以及从各种 Bentley Civil 产品导入地形模型的工具。这些工具还支持将两个或以上模型合并在一起，另外还支持剪切模型。

设置

描述

从文件

通过从外部文件导入来创建地形模型。支持多种文件格式，如 LandXML、Lidar (* .las) 和原有产品 （InRoads、GEOPAK 和 MX）。

从图形过滤器

一种自动存储图形元素搜索设置的方法，用于自动“按元素创建地形模型”。使用“图形过滤器管理器”存储的设置来创建地形。

从元素

从三维图形元素创建地形模型。

其他方法

  • 按文本内插创建
  • 从 ASCII 文件创建地形模型
  • 从点云创建
  • 创建剪切的地形模型
  • 创建复合地形模型
  • 创建增量地形模型
  • 创建廊道备选表面

按文本内插创建 - 从还包含高程标签的二维图形中创建地形模型。

从 ASCII 文件创建地形模型 - 从还包含高程标签的二维图形中创建地形模型。

从点云创建 - 从 MicroStation Point Cloud 数据中创建地形模型。

创建剪切的地形模型 - 通过剪切现有地形模型和给定可选横向或竖向偏移来创建地形模型。

创建复杂地形模型 - 通过合并/附加多个地形模型来创建新的复合地形模型。

创建增量地形模型 - 通过两个地形模型之间的差异或地形模型与平面之间的差异（高程）来创建新的地形模型。

创建廊道备选表 - 根据廊道模型中的用户指定点沿任何给定路径创建地形模型。

地形模型创建工具
从文件创建
从图形过滤器创建
从元素创建
其他方法
父主题: 地形


地形模型创建工具

“地形模型创建”工具组包含用于从图形元素、ASCII 文件、点云和 LandXML 创建地形模型的工具以及从各种 Bentley Civil 产品导入地形模型的工具。这些工具还支持将两个或以上模型合并在一起，另外还支持剪切模型。

可以从各种源数据创建地形模型。每种数据类型均有不同的输入要求，但创建工具之间有很多相同的选项。多种创建工具使用以下两个概念：

  • 地理坐标系

  • 过滤

地理坐标系

“地理坐标系”部分支持用户在处理其他任务的数据时将数据从一种坐标实时转换为另一种坐标。如果数据位于下游任务所需的坐标系中，则不使用此部分。但是，如果下游任务需要与源数据不同的坐标系，则用户可以选择源数据的坐标系，并指定创建地形模型的坐标系。可以在创建过程中转换其他坐标系的源数据，然后在“复合地形”或“合并”工具中对其进行合并。如果“源”和“目标”设置为“无”，则假设源数据采用设计文件工作单位。如果软件可以检测到坐标系，则会填充到“源”字段中。

设置 | 描述
来源 | 无 - 指定传入的地理坐标系，显示“图像投影”对话框以从可搜索库中进行选择。
目标 | 无 - 指定传出的地理坐标系，显示“图像投影”对话框以从可搜索库中进行选择。

图像投影

要从库中选择地理坐标系：

  1. 在“GCS”部分单击源或目标字段中的按钮。

    指定传入数据的输入坐标系，以及相对于 TM 中使用的实际坐标系的输出坐标系。

    在主对话框“从文件创建地形 (Create Terrain from File)”或“从 ACSII 创建地形模型 (Create Terrain Model from ACSII)”的“GCS”对话框部分选择“浏览”按钮时，将显示第二个“图像投影”对话框。

    将打开“选择几何坐标系统”对话框。

  2. 展开库并双击 GCS。

    或

    选择 GCS 并单击“确定”。

    指定传入数据的输入坐标系，以及相对于 TM 中使用的实际坐标系的输出坐标系。

在主对话框“从文件创建地形 (Create Terrain from File)”或“从 ACSII 创建地形模型 (Create Terrain Model from ACSII)”的“地理坐标系”对话框部分选择“浏览”按钮时，将显示此第二个“图像投影”对话框。

工作流

  1. 选择输入坐标系基准，并单击“确定”。

    “投影设置”对话框将使用选定的坐标系基准填充。

  2. 选择输出坐标系基准，并单击“确定”。
    “投影设置”对话框将使用选定的坐标系基准填充。

过滤

支持三个选项：“无”、“平铺”和“切线”。从经验研究来看，平铺算法更快，通常可以使文件大小减少 30% 到 50%。TIN 算法通常可以减少 70% 到 90%。

分块算法是用于将数据集划分为块的递归分治算法。为每个分块计算最佳拟合平面，如果 LIDAR 点落在用户设置的平面 Z 公差范围内，则将其移除。

TIN 算法可将位于用户设置的三角形平面的 Z 公差范围内的点过滤出来。TIN 算法先将点分块为最多具有 2 百万个点的分块，然后对每个分块重复进行三角形化以过滤出点。

完成过滤后，对话框中将显示“过滤前的点特征”、“过滤后的点特征”和“百分比减少”（只读）。如果加载了多个数据文件，则测试过滤器结果仅适用于活动选择。

选择该选项后，输入字段将更改为反映选择内容。下面列出了所有选项通用的字段。

测试过滤器 | 填充过滤器字段后，检查用于启动过滤器例程的“测试过滤器”是否填充了“报表”字段。在将数据作为表面导入之前，可以再次调整和处理这些字段（如果需要）。
源文件单位 | 如果软件可以确定数据文件中的单位，将填充此字段。如果无法确定单位，将显示“未知”。用户可以指定“未知”、“毫米”、“厘米”、“米”、“千米”、“英寸”、“英尺”、“美制测量英尺”、“英里”等。如果为“未知”，则使用设计文件单位。

无

如果选择“无”，则不应用任何过滤器。不需要进行其他输入。

平铺

分块算法是用于将数据集划分为块的递归分治算法。为每个分块计算最佳拟合平面，如果点位于用户设置的平面的 Z 公差范围内，将移除这些点。

Z 公差 | 过滤过程中，允许表面移动的 Z 坐标的变化。通常在第一次调用过滤函数时，对于英制数据集，Z 公差应设置为 0.5 到 1.0，对于公制数据集，应设置为 0.25 到 0.5。根据效果和所需结果，Z 公差可以上下变化。
最小平铺点 | 如果平铺的点数少于此数，则平铺不会细分。通常，此数量设置为 5。
最大平铺分界线 | 是指允许的递归级别，且是指初始平铺集可以细分的次数。通常，此数量设置为 5。
起点平铺长度 | 在递归到最少分块点之前，数据集最初划分为此大小的分块。此参数的设置需要适当了解点之间的距离，这需要检查 MicroStation 中的点才能确定。通常将此值设置为点之间距离的 10 倍。

切线

TIN 算法可将位于用户设置的三角形平面的 Z 公差范围内的点过滤出来。TIN 算法先将点分块为最多具有 2 百万个点的分块，然后对每个分块重复进行三角形化以过滤出点。

Z 公差 | 过滤过程中，允许表面移动的 Z 坐标的变化。通常在第一次调用过滤函数时，对于英制数据集，Z 公差应设置为 0.5 到 1.0，对于公制数据集，应设置为 0.25 到 0.5。根据效果和所需结果，Z 公差可以上下变化。
粒度 | 粗糙 (Course) - 过滤出较多点，其中脊和谷有一些模糊。 精细 - 过滤出较少点，其中脊和谷的模糊程度很低。
重新插入点 | 过滤点后，将基于公差进行进一步检查，公差范围外的点将重新插回表面中。
父主题: 地形创建


从文件创建

用于通过从外部文件类型导入来创建 TM。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建

导入支持以下格式：

导入过程支持同时导入多个同一类型的文件。定义的导入设置对要导入的所有选定文件通用。

“导入地形模型”对话框

“导入地形模型”对话框是模式窗体，一旦打开就不允许与图形环境交互。

该对话框的左上角支持四个工具：

设置 | 描述
选择要导入的文件 | 显示“选择要导入的文件”对话框。
重命名地形模型 | 重命名指定的地形模型。
删除地形模型 | 从列表中移除指定的地形模型。请注意，此工具不会删除地形模型。
全景视图 | 将整个指定的地形模型放置在激活视图中。

该对话框的右窗格中支持几个选项：

  • 地形模型 - 此类选项指示激活 *.dgn 文件中是否已存在地形模型以及如何与要导入的数据组合。

  • 投影 -

  • 过滤器 - 对于大型数据集，过滤可能是一个十分有用的选项。

  • 特征定义 - 用于导入地形的特征定义。如果未选择任何选项，则使用激活线符绘制地形模型。

  • 三角形化选项 - 指定如何处理创建的地形模型的外部三角形

  • 地理坐标系 (GCS) - 如果软件可以确定要导入的文件的地理坐标系，则填充字段。如果设置为“未知”，则该软件将使用 MicroStation 设计单位。如果生成的地形模型需要位于不同的 GCS 中，则使用本部分。

地形模型

工具设置 | 描述
附加到现有地形模型 | 切换为打开状态后，附加到 *.dgn 中的所选地形模型。 切换为关闭状态后，创建一个新的地形模型，忽略激活文件中或参考的任何其他地形模型。
要附加到的地形模型 | 键入地形模型名称或从可用地形模型的列表中选择。 选择“附加到现有地形模型”时可用。

投影

工具设置 | 描述
目标 |
目标描述 |
目标单位 |

过滤器

请注意，此部分中的设置因源数据的文件类型而异。

选择以减少导入到 TM 中的数据点数目，然后在提供的字段中输入“最大点数”值。

工具设置 | 描述
源文件单位 | 如果软件可以确定数据文件中的单位，将填充此字段。如果无法确定单位，将显示“未知”。用户可以指定“未知”、“毫米”、“厘米”、“米”、“千米”、“英寸”、“英尺”、“美制测量英尺”、“英里”等。如果为“未知”，则使用设计文件单位。

有关过滤的详细信息，请参阅“过滤”。

特征定义

工具设置 | 描述
特征定义 | “无特征定义”是默认值。从下拉菜单中选择特征定义。
导入选项 | 根据源文件中定义的样式创建设计文件元素。将扫描 DGN，找到的前 15,000 个元素将添加到已附加到所创建的地形模型的规则中。更改其中一个元素将会影响地形模型。在 DGN 中找到的其他元素将添加到地形模型中，但不会添加到规则中。更改其中一个元素不会影响地形模型。如果达到限制，土木消息中心将显示一条警告。 导入两者 - 使用特征创建地形。

三角网选项

设置 | 描述
边方法 | 不移除 - 不移除外部三角形。 裂片 - 根据软件中硬编码的公式分解细长的三角形。 侧边 - 移除外部边缘长度超过用户指定距离的外部三角形。“侧边”选项不适用于内部三角形，仅适用于模型边缘的三角形。

地理坐标系

工具设置 | 描述
来源 |
来源描述 |
源单位 |
“从文件创建”工作流
“地理坐标系”对话框
定义地标界碑
选择地理坐标系
“地理坐标系属性”对话框
“选择地理坐标系”对话框
“来自地标的地理坐标系”对话框
“来自参考的地理坐标系”对话框
“在参考中设置地理坐标系”对话框
“重投影设置”对话框
父主题: 地形创建


从图形过滤器创建

使用之前定义的图形过滤器创建地形，图形过滤器确定三角测量的候选元素。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建

可采用各种格式为地形模型提供数据，包括二维和三维原始图形元素。对于“按图形过滤器创建地形”，元素必须为三维。当源数据具有一致的（标准化）元素符号时，该工具非常有用。信息可存储在过滤器组中，而不是在每次创建地形模型时为每个地形特征定义元素符号。大量组可存储在 dgnlib 中，因此用户只需根据特征类型和关联符号选择相应的组。如果所有组均不适用，则可创建新的过滤器组，操作极其简单。

“按图形过滤器创建地形”工具的优势是可以同时导入大量地形特征；用户无需单独选择每个特征，就像使用“按元素创建地形”工具一样。但是，源数据必须保持一致才能使用此工具。

设置 | 描述
附加到地形 | 如果地形已经存在于模型文件中（或被参考）且要将数据添加到选定 TM，则开启此设置。
图形过滤器组 | 从列表中选择过滤器组。如果文件或 DGNlib 中未定义过滤器组，则会显示提示以指示没有过滤器组，并打开“图形过滤器管理器”对话框。请注意，创建过滤器组后，用户将返回到“创建 TM (Create TM)”对话框。
地形过滤器管理器 | 打开“地形过滤器管理器”。
预览 | 单击以高亮显示视图中与过滤器匹配的任何元素。
忽略特征链接 | “忽略特征链接”选项覆盖“地形过滤器管理器”对话框中的“链接到地形特征”。 关闭时，使用每个过滤器内“链接到地形特征”中的设置。开启时，忽略每个过滤器内的“链接到地形特征”设置，且不按规则创建地形模型。

三角网选项

特征定义

从来源更新地形

使用图形过滤器创建的地形保留“地形”上的创建规则。此设置可在项目浏览器中访问，路径为“土木模型”>“地形模型”。用鼠标选择“规则”可以更新“地形来源”。更新操作会重新处理规则并添加任何已添加的其他图形元素。

图形过滤器管理器

提示 | 用户操作
附加到地形 | 如果地形已经存在于模型文件中（或被参考）且要将数据添加到选定 TM，则开启此设置。
图形过滤器组 | 从列表中选择过滤器组。如果文件或 DGNlib 中未定义过滤器组，则会显示提示以指示没有过滤器组，并打开“图形过滤器管理器”对话框。请注意，创建过滤器组后，用户将返回到“创建 TM (Create TM)”对话框。
图形过滤器管理器 | 打开“图形过滤器管理器”。
预览 | 单击以高亮显示视图中与过滤器匹配的任何元素。
地形特征 | 不链接特征图形 从图形创建地形模型，但不保留与图形的任何关联。因此，如果稍后编辑图形，地形模型不会更新，而是需要重新生成。使用此选项可提高性能。 链接图形特征 创建地形模型并将其关联到图形元素。因此，对图形的编辑将立即更新地形模型。如果对大型数据集使用此选项，则构建地形模型需要很长时间。将扫描 DGN，找到的前 15,000 个元素将添加到已附加到所创建的地形模型的规则中。更改其中一个元素将会影响地形模型。在 DGN 中找到的其他元素将添加到地形模型中，但不会添加到规则中。更改其中一个元素不会影响地形模型。如果达到限制，土木消息中心将显示一条警告。

三角网选项

特征定义

按图形过滤器创建的相关工作流
地形过滤器管理器
父主题: 地形创建


从元素创建

用于从带形线的三维图形元素创建地形模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建

如果源元素发生更改，带形线的地形会自动更新。地形特征类型的每个元素或每组元素均可单独选择或通过选择集进行选择。如果这些元素没有一致性线符或特性，则此工具非常有用（在这种情况下，选择“创建图形过滤器组”工具可能更好）。从第一组元素创建地形模型之后，软件会提示附加另一个地形特征（通过定义元素的另一个选择集）或创建另一个地形模型。模型名为“地形模型(元素)”、“地形模型(元素) 1”，依此类推。

包含预定义选择集的工作流：

  1. 定义一个类型的所有元素（例如，所有切断线）的选择集，使之成为地形模型。

  2. 选择工具。系统将显示提示，指示选择集中有多少个元素。要接受的数据点。

  3. 在提示符下设置要提取的元素类型（例如，切断线、点、空区）。

  4. 输入边缘选项。

  5. 将创建地形并自动打开“添加特征”或“移除特征”工具，以便可以附加到新创建的 TM。

不含预定义选择集的工作流：

  1. 选择工具。

  2. 出现提示时，选择要包括的第一个元素。继续选择元素，然后重置以关闭提示并转至下一步。

  3. 设置要提取的元素类型（例如，切断线、点、空区）。

  4. 输入边缘选项。

  5. 要接受的数据点。

将创建地形模型。

另请参阅

特征类型

边方法

特征

父主题: 地形创建


其他方法

按文本内插创建
从 ASCII 文件创建地形模型
从点云创建
创建剪切的地形模型
创建复合地形模型
创建增量地形模型
创建廊道备选表面
父主题: 地形创建


地形编辑

土木地形模型编辑工具组包含用于编辑和操作地形模型的工具，包括按特征添加和移除、编辑无规则地形模型以及使用复杂地形模型等工具。

设置

描述

设置激活

设置激活地形模型文件。激活地形模型是默认情况下在轮廓模型中显示的模型，是廊道建模器的默认目标。

编辑模型

使用几个简单的编辑工具打开工具设置；删除、插入和移动顶点，删除三角形和交换线。

编辑复合地形模型

通过更改合并顺序编辑复杂的地形，更改合并或附加方法以及添加或移除组件地形模型

特征管理

  • 添加特征
  • 删除特征

添加特征 - 在使用创建命令创建的地形中添加更多特征。例如，从切断线创建地形，然后添加点。

删除特征 - 从“添加特征”或“从元素创建”添加的地形中移除元素。

边界选项

  • 添加边界
  • 删除边界

添加边界 - 用于从地形中提取隐含或存储的边界，并能够编辑/规则化边界。

移除边界 - 从无规则的地形模型中移除边界元素。

转换

能够转换、旋转和缩放元素。可以同时对常规或土木元素执行这三种修改。
设置激活
特征管理
编辑复合模型
编辑模型
边界选项
转换
父主题: 地形


设置激活

用于设置激活地形模型文件。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑
  • 功能区：几何图形 > 通用工具 > 设计元素拆分按钮

此工具设置激活地形模型文件。默认地形模型是默认情况下在纵断面模型中显示的模型，是廊道建模器的默认目标。

如果廊道中模板的末端条件与现有地面相互作用，则需要激活地形模型。在任何给定时间只能有一个地形模型为激活状态，但多个地形模型可以组合为一个复杂的地形模型。地形模型可以与廊道模型位于同一设计文件中，但大多情况其都在单独的文件中且被参考。在“地形”功能区中找到“设置激活地形模型”工具。

工作流

  1. 启动命令。
  2. 选择要指定为缺省地形的地形模型。
父主题: 地形编辑


特征管理

添加特征
删除特征
更改特征类型
父主题: 地形编辑


编辑复合模型

用于将多个复合地形模型合并或附加成一个模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑

“编辑复合地形模型”工具的功能类似于“创建复合地形模型”，但利用先前定义的复合模型。选择该工具后，对话框的列表框中将填充位于当前 *.dgn 文件中或参考该文件的复合地形模型。

工作流

  1. 启动命令。

  2. 选择现有复合地形。

  3. 将显示合并框，可以通过添加或移除组件地形对其进行编辑，或者更改合并顺序或合并方法。

  4. 单击“确定”更新地形。

另请参阅

创建复合地形模型

合并或附加地形模型

父主题: 地形编辑


编辑模型

用于编辑没有带规则的图形元素的地形模型，包括操作顶点、交换线和删除三角形。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑

这些编辑命令适用于没有带规则的图形元素的地形模型。例如，从其他格式导入地形模型而不创建特征。这些命令允许进行有限的编辑，而无需返回源和导入特征。如果需要其他编辑功能，则导入原始源并使用其他编辑方法。

设置 | 描述
删除顶点 | 删除指定的顶点，然后在没有它的情况下重新三角形化地形模型。注意，无法选择位于地形模型边（边界）的顶点。
删除边三角网 | 从用户定义的边确定三角形，然后从模型中删除三角形，并相应地更新边界。
交换线 | 更改两个三角形的公共边。
插入顶点 | 在地形模型的内部或外部插入顶点。如果该点位于模型内部，则支持使用面的高程（从三角形顶点内插）作为高程。
移动顶点 | 移动三角形的顶点。工具设置中的开关使用户可以使用原始顶点的高程。
按线删除三角形 | 删除与该线（由工具中的两个数据点定义）相交的所有三角形，并相应地更新边界。
父主题: 地形编辑


边界选项

添加边界
删除边界
父主题: 地形编辑


转换

此单个工具能够转换、旋转和缩放元素。土木元素对上述三个独立的动力平台工具无效，因此，该工具可以同时对常规元素或土木元素进行所有这三种修改（如果需要）。

可以通过以下方式访问此工具：

  • 功能区：“地形”>“编辑”
  • 功能区：“几何图形”>“常用工具”

此工具与任何其他工具的操作方式均相同，不同的是，用户可以保存转换以便以后在其他元素上使用，此工具包含一些预定义的单元类型转换。此工具还会向消息中心输出记录，说明已完成和已修改的内容。

在转换土木元素时，它们会变成简化的元素，这意味着，如果元素是某项规则的目标，则该规则将被移除。如果要转换土木元素，则会出现一个警告框。

转换对话框选项
父主题: 地形编辑


地形分析

土木地形模型分析工具集包含用于计算体积、显示坐标、高程以及模型上的点或点之间的其他相关数据的工具，以及分析池塘和流域的工具。

设置

描述

点

  • 测点间分析
  • 测点分析
  • 反转点

测点间分析 - 报告地形模型上的 2 个点位置之间的信息（高程差、长度和斜率）。

测点分析 - 报告有关地形模型中用户指定的点位置的信息（高程、斜率、等高线、斜坡方向）。

反转点 - 报告有关地形模型中用户指定的点位置的信息（高程、斜率、等高线、斜坡方向）。支持几种类型：线性、弧、径向、垂直和按元素。二维和三维视图/模型中均支持该工具。结果显示在光标提示符和（可选）Civil 报告浏览器中。

土方量

  • 创建挖方和填方土方量
  • 分析土方量

创建挖方和填方土方量 - 计算两个曲面（通常是现有地形和一个曲面（地形或网格））间的挖方和填方土方量，并使用土方量特性创建三维网格实体。

分析土方量 - 计算 2 个地形模型或一个地形模型和平面之间的土方量（高程）。能够在一个区域（围栅）或多个区域中进行处理并计算一系列高程内的土方量。也可以选择挖方和填方系数。

水力

  • 分析水塘
  • 分析轨迹边坡

分析水塘 - 通过地形模型上的数据点位置分析水塘（低点）的地形模型（土方量、区域最大深度）。

分析轨迹边坡 - 沿曲面的轨迹遵循用户指定的斜率值或最大斜率。可以追踪上游或下游。

报告

  • 特征集交叉报表
  • 冲突点报表

特征集交叉报表 - 定位相交线特征，例如切断线或等高线。

冲突点报表 - 报告用于创建具有重复点的地形模型的源数据（由具有相同或不同高程的 X, Y 位置定义）。

水膜效应

该工具用于评估车辆在湿滑路面上失去控制的可能性。

视距分析
测点间分析
测点分析
反转点
创建挖方和填方土方量
分析土方量
分析水塘
分析轨迹边坡
特征集交叉报表
冲突点报表
水膜效应
视距分析
父主题: 地形


测点间分析

用于查看地形模型或网格的两个所选点之间的高程、坡度、距离和增量信息。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“测点间分析”工具查看地形模型或网格的两个所选点之间的高程、坡度、距离和增量信息。

工作流

1.启动工具。

2.选择地形模型。

3.输入一个数据点作为第一点。如果该点在地形模型外部或在空区内部，则不是有效的点，因此不被接受。必须选择其他点。

4.输入一个数据点作为第二点。（如果第二点在不同的地形模型上，请使用 ALT 键盘按钮。）

5.报告点之间的距离、坡度和高差。

设置 | 描述
高程 1 | 地形模型或网格在第一个所选点的 X、Y 坐标处的高程（以主单位表示）。
高程 2 | 地形模型或网格在第二个所选点的 X、Y 坐标处的高程（以主单位表示）。
高差 | 高程 1 和高程 2 之间的高差（以主单位表示）。
坡度 | 根据点 1 和点 2 的 X、Y 坐标报告两点之间的直线斜率及其相应的地形高程。它不考虑两点之间的地形斜率。
长度 | 报告两点之间的直线长度。
角度 | 根据点 1 和点 2 的 X、Y 坐标报告两点之间的直线方向。
父主题: 地形分析


测点分析

用于动态查看有关所选二维或三维设计元素、地形模型或网格的信息。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“测点分析”工具动态查看有关所选二维或三维设计元素、地形模型或网格的信息。

结果基于所选元素的类型。例如，如果选择了二维 MicroStation 元素，则结果包括“桩号”、“偏移”、X、Y 和“方向”。

在这种情况下，桩号设置基于元素原点的 0+00，而“偏移”基于光标到元素的垂直距离。如果选择了三维元素，此时将显示高程和斜率。

利用地形模型或网格时，还显示有关点所在三角形的信息。这可能包括斜率和长宽比。也可以绘制等高线。

先决条件

需要二维或三维 MicroStation 元素、土木几何元素、地形模型或 MicroStation 网格

非曲面元素工作流

  1. 启动工具。

  2. 选择二维或三维元素。

  3. 当光标移动时，在对话框和工具提示中报告点信息。

地形模型或网格工作流

  1. 启动工具。

  2. 选择地形模型或网格。

  3. 当光标移动时，在对话框和工具提示中报告点信息。如果光标点在地形模型外部或在空区内部，则仅显示一条消息，即没有点数据。

  4. 使用 ALT 键盘按钮更改对话框选项以显示等高线、三角形、高程、坡度箭头。

  5. 数据点在默认层绘制显示的等高线。

选项

设置 | 描述
显示等高线 | 显示与用户选择点的高程相同的所有等高线。例如，如果点的高程为 153.64，则显示地形模型中高程为 153.64 的所有等高线。
仅显示在视图中的等高线 | 仅显示视图中的等高线，而非显示用户选择点的所有等高线。这对于非常大的地形模型十分有用
显示边坡 | 以百分比显示三角形的斜率（与水平面相比）
显示三角网 | 高亮显示用户选择点所在的三角形。
设置 | 描述
桩号 | 根据用户选择的平面几何元素报告光标位置的桩号位置。
偏移 | 根据用户选择的平面几何元素报告光标位置的偏移。
X | 报告用户选择点的 X 坐标。
Y | 报告用户选择点的 Y 距离。
高程 | 报告用户选择点的高程（以主单位表示）。
坡度 | 报告用户选择点所在三角形的坡度（以百分比表示）。该斜率从水平面进行测量。
坡向 | 报告用户选择点所在三角形的坡向。该坡向描述三角平面的朝向。坡向范围以度表示。北向轴定义为零度，角度沿顺时针方向增加。因此，零度指北，90 度指东，180 度指南，270 度指西。为水平三角形分配默认坡向 360 度。
父主题: 地形分析


反转点

用于计算并显示每对指定点之间的距离和方向。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 点拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

“反转点”工具计算并显示每对指定点之间的距离和方向。支持几种类型：线性、弧、径向、垂直和按元素。二维和三维视图/模型中均支持该工具。结果显示在光标提示符和（可选）土木工程报告浏览器中。能够以图形方式或通过键入现有测量点名称选择点。

此工具使用激活 MicroStation 线符、文本设置和绘图比例。方向值利用“设计文件设置”>“角度显示格式”设置确定格式、精度和方向模式。用于距离的小数位数由“设计文件设置”>“工作单位”>“线性单位精度 (Linear Units Accuracy)”值确定。用户不能定义注释的布局和内容。

顺序非常重要，因为方向是从第一点计算到第二个点。所有输入类型通用的选项。

所有输入类型支持以下选项。请注意，这些选项必须在工具设置中设定，因为它们没有对应的危险警告提示。

选项 | 描述
报表 3D | 切换为打开状态后，显示和注释包括两点间的水平距离、方向、坡距和高差。切换为关闭状态后，仅显示水平距离和方向。
标注 | 切换为关闭状态后，不显示注释，仅显示元素（基于输入类型）。切换为打开状态后，将显示注释。
保存 | 切换为关闭状态后，仅当工具处于激活状态时才显示元素（基于输入类型）。重置后，不再显示所有元素/注释。切换为打开状态后，元素/注释会写入激活文件，并在命令完成后可见。要保存注释，“标注”开关也必须处于打开状态。
输出报告 | 切换为关闭状态后，输出将显示在提示字段和土木消息中心内。当“输出报告”切换为打开状态（定义了反转点）后，重置操作将打开土木工程报告浏览器以显示填入了反转点的反转报告。
使用点名称 | 可以使用测量数据点来代替以图形方式选择点。支持在单个工具中混用数据点和测量点。打开该选项，然后将鼠标悬停在某个测量点上方，随即显示其名称。（如果已知点名称，则无需悬停。）在危险警告提示或工具设置的相应字段中键入该名称，然后按 Enter 或 Tab 以接受并移至下一提示。“使用点名称”可与任何输入类型一起使用。

另请参阅

报告浏览器

父主题: 地形分析


创建挖方和填方土方量

用于计算两个曲面（通常是现有地形和一个曲面（地形或网格））间的挖方和填方土方量，并使用土方量特性创建三维网格实体。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 土方量拆分按钮

“创建挖方和填方土方量”工具计算两个曲面（通常是现有地形和一个曲面（地形或网格））间的挖方和填方土方量，并使用土方量特性创建三维网格实体。从设计曲面到现有曲面绘制竖直边缘，并计算闭合实体的土方量（以主单位表示）。请注意，设计曲面可能不连续，在这种情况下，会为所有区域创建一个网格实体。高亮显示任何一块实体将高亮显示所有块。可以在“快速属性”（从上下文相关菜单访问）或“元素信息”中查看土方量。

此工具也可用于可视化土方、顶网格和底网格。

实用功能包括施工排序和分期。

快速属性

通过右键单击任何土方量对象从上下文相关菜单访问，将显示所有填方或挖方土方量的体积。同时会显示表面积和特征定义信息。可以输入可选描述。

元素信息

创建挖方和填方土方量
父主题: 地形分析


分析土方量

用于计算两个模型或一个模型和一个平面之间的土方量并（可选）将结果放在文件中用户定义的位置。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 土方量拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“分析土方量”工具计算两个模型或一个模型和一个平面之间的土方量并（可选）将结果放在文件中用户定义的位置。针对两个地形模型的并集（对于模型到模型选项）或整个地形模型和高程之间（对于高程选项）计算土方量。可以指定一个可选边界来计算部分地形模型的土方量。在这种情况下，通过从边界元素垂直绘制以与地形模型相交来计算土方量。

先决条件

此工具至少需要一个地形模型。

工作流

  1. 启动工具。

  2. 指定“土方量方法”（可调整后续提示）。

  3. 指定“地形模型来源”。

  4. 指定“到地形模型或高程”（对于“地形模型到高程 (Terrain Model to Elevation)”选项）。

  5. 选择边界（或重置为“无”）。

  6. 如果需要，设置挖方和填方系数。

  7. 接受。

  8. 如果“保存结果”切换到打开状态，则在激活视图中放置结果的位置上点击确认。

设置 | 描述
容积法 | 地形模型到地形模型土方量：确定两个地形模型之间的土方量。此选项通常用于确定从现有地面地形到所建议表面的项目土方量。 地形模型到平面：确定地形模型和指定高程之间的土方量。此选项通常用于确定水位（高程）和所建议水塘之间的土方量。
地形模型来源 | 地形模型或网格。
到地形模型 | “地形模型到地形模型土方量”中使用的地形模型。
到平面 | 为“地形模型到平面”计算指定的高程。
挖方系数 | 应用于挖方土方量。此参数也称为膨胀系数，用于定义材料从地面移除后体积会增加多少。例如，值 1.3 表示挖方材料将膨胀到原始体积的 1.3 倍。默认值为 1.0，即不做任何调整。
填方系数 | 应用于填方土方量。此参数也称为压缩系数，用于定义填方材料放入场地后体积会减少多少。例如，值 0.8 表示填方材料将缩小到原始体积的 0.8 倍。默认值为 1.0，即不做任何调整。
挖方量 | 调整后的挖方材料体积（以立方英尺或米为单位）。如果“挖方系数”设置为除 1 以外的其他值，则此值将该系数考虑在内。
填方量 | 调整后的挖方材料体积（以立方英尺或米为单位）。如果“填方系数”设置为除 1 以外的其他值，则此值将该系数考虑在内。
平衡方量 | 挖方和填方土方量之差（以立方英尺或米为单位）。
保存结果 | 切换为打开状态后，系统会提示用户在激活文件中点击确认以放置结果。

另请参阅

报告浏览器

父主题: 地形分析


分析水塘

用于沿着下游追踪一个点到低点，然后填充它，得出土方量、最大深度和最大高程。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 水力拆分按钮

“水塘分析”工具沿着下游追踪一个点到低点，然后填充它，得出土方量、最大深度和最大高程。此外，以图形方式显示水塘描述。

显示水塘 - 设置为“激活水塘”时，仅创建/分析一个水塘。设置为“所有水塘”时，测试所有低点，如果可以创建一个满足“最小深度”的水塘，则创建/绘制该水塘。将鼠标悬停在水塘上方时，将显示“土方量”、“深度”和“高程”。

当“下降轨迹”切换为打开状态后，将显示（从用户指定的原点）到水塘的下降轨迹以及水塘轮廓。“高程 1”是地形模型上的原点的高程，而“高程 2”是用于创建水塘的低点。

工作流

1.启动工具。

2.选择地形模型。

3.当光标移动时，将显示轨迹路径以及从光标点下游找到的任何水塘。

4.点击确认以将瞬态图形保存为带形线的元素。

以图形方式显示水塘描述。

常规

设置 | 描述
水塘容量 | 沿着下游追踪一个点到低点，然后填充它以显示土方量。
深度 | 沿着下游追踪一个点到低点，然后填充它以显示最大水塘深度。
高程 | 沿着下游追踪一个点到低点，然后填充它以显示最大曲面高程。

过滤器:

水塘过滤器 - 无过滤（不执行任何操作）

按面积过滤 - 选中时，其他字段包括“最小面积”（以主单位表示）。软件将仅考虑/显示大于用户指定面积的水塘解决方案。

按深度过滤 - 选中时，其他字段包括“最小深度”（以主单位表示）。软件将仅考虑/显示深度大于或等于用户定义“最小深度”的水塘解决方案。

显示所有水塘 - 切换为打开状态后，显示地形模型中的所有水塘。切换为关闭状态后，仅显示包含当前光标位置的水塘。点击确认，以将该水塘绘制到激活文件中。

特征

有关详细信息，请参考特征定义。

父主题: 地形分析


分析轨迹边坡

用于动态追踪地形模型或网格曲面上的路径。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 水力拆分按钮
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“分析轨迹边坡”工具动态追踪地形模型或网格曲面上的路径。例如，以水滴顺着所选地形模型（或网格曲面）向下移动或从曲面向上移动到水源的路径为例。输入包括路径原点的数据点。

支持两种轨迹方法：最大坡度轨迹和常数边坡轨迹。

如果将“最大坡度轨迹”方法与“向下”选项结合使用，则所示路径遵循从经过地形模型或网格的点到地形模型或网格的低点或边缘的最陡下降。如果与“向上”选项结合使用，则所示路径遵循从经过地形模型或网格的点到地形模型或网格的低点或边缘的最陡下降。

使用“常数边坡轨迹”方法时，需要更多输入信息：斜率（以百分比表示）和距离（以主单位表示）。假设使用斜率 5% 和距离 500 主单位。初始数据点放置在屏幕上，当光标移动时，将显示各种解。每种可能的解由一个长度为 500 主单位的线串组成，且其斜率基于地形模型的实际斜率。因此，该线串沿着指定斜率的路径蜿蜒，直到长度为 500 主单位（或者如果无解，则小于 500 主单位）。将 DP2 置于屏幕上时，在数据点时间动态显示的第一个线串现已固定。使用 DP 2 作为初始端点，将动态显示新的解。请注意，根据样板房的地形，介于 DP 3 和 DP 4 之间的解有近 90 度的转弯。在 DP 4 附近的这个分段结尾处也有一个小转弯。请注意，您只需输入一个数据点来定义原点，而软件则确定路径的其余部分。

（向下）轨迹边坡中的一个选项是考虑“最小深度”。地形模型有大量低点，但这些区域中有很多只是模型中的小凹痕或凹陷，在这些地方水会流到附近的低点。要利用此选项，请将值设置为以主单位表示的深度（英尺或米）。Bentley Civil 确定每个低点，然后确定放置在指定深度的水是否溢出凹痕并流入相邻三角形。如果水没有流入相邻三角形，则在追踪过程中将其用作低点。如果水流入相邻三角形，则对相邻三角形上的点进行深度测试，直至找到深度测试不溢出的点。然后，将此点用作低点。设置为零时，不利用“最小深度”。

工作流

1.启动工具。

2.选择地形模型。

3.按照屏幕下角的提示操作：按 Alt 键切换上游/下游、按 Shift 键更改为常数边坡。或者，在对话框中设置选项。

4.点击确认以显示轨迹路径。

5.点击确认以将瞬态图形保存为带形线的元素。请注意，可以使用前面的对话框设置启动另一个轨迹边坡的其他数据点。

设置 | 描述
轨迹方法 | 最大坡度轨迹 - 在指定斜率沿模型或对象表面移动。 常数边坡轨迹 - 在高程 1 处找到一个区域。
坡度 | 选择以指定坡度。如果未选择，将使用模型或对象的高程。
长度 | 在最大距离处绘制每条轨迹（以主单位表示）。轨迹非线性，而是遵循模型或对象的指定斜率。
最小深度 | 最小低点。值 0.0 表示不会使用最小低点深度。
跟踪边坡方向 | 向上：显示一个箭头，指示从所选点逆流而上的方向。 向下：显示一个箭头，指示从给定点顺流而下的方向。

特征

有关详细信息，请参考特征定义。

父主题: 地形分析


特征集交叉报表

用于定位相交线特征，例如切断线或等高线。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 报告拆分按钮

此工具将定位相交线特征，例如切断线或等高线。在交叉点处，计算并比较两个元素的高程。如果两个元素交叉处的高程差小于指定的公差，则不会在报告中列出。

设置 | 描述
应用层公差 | 如果选中，则使用指定的公差来过滤数据。如果未选中，则列出所有交叉特征，甚至包括那些在交叉点处具有相同高程的交叉特征。
层公差 | 指定“层公差 (Level Tolerance)”，它将充当报告的过滤器。如果两个交叉特征的相交点的高程差小于“层公差 (Level Tolerance)”，则不会包括在报告中。

通过高亮显示该行并单击报告对话框顶部的图标，用户可以缩放到相交位置。“视图中 (In View)”图标以选定相交为中心。“导出”图标将打开“土木工程报告浏览器”，其中包含可以打印的地形交叉特征报告。

工作流

  1. 启动命令。
  2. 选择地形模型。
  3. 将显示任何找到的交叉线性特征的报告。
父主题: 地形分析


冲突点报表

用于报告地形中具有相同 X, Y 坐标的点。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 分析 > 报告拆分按钮

地形模型中的任何位置（由 X, Y 坐标定义）有且只有一个高程。但是，用于创建地形模型的源数据可以具有重复点（由具有相同或不同高程的 X, Y 位置定义）。在三角形化期间，如果遇到具有相同 X,Y 坐标的两个或更多个点，则利用第一点（通过其高程），而忽略可能具有不同高程的第二点或后续点。“冲突点报表”工具利用此报告的基础源数据。

设置 | 描述
应用层公差 | 如果选中，则使用指定的公差来过滤数据。如果未选中，则列出所有冲突点，其中包括那些具有相同 X,Y,Z 坐标的冲突点。
层公差 | 指定“层公差 (Level Tolerance)”，它将充当报告的过滤器。如果两个冲突点的高程差小于“层公差 (Level Tolerance)”，则它们不会包括在报告中。

在以下示例中，未使用“应用层公差 (Apply Level Tolerance)”。

将列出所有冲突点、层差、点的高程和模型的高程。标记为“地形”的点用于地形模型创建。以下报告使用 2.0 主单位的层公差。因此，报告中仅列出高程差大于 2 的冲突点。

通过高亮显示该行并单击报告对话框顶部的图标，用户可以缩放到冲突点的位置。“视图中 (In View)”图标以选定点为中心。“导出”图标将打开“土木工程报告浏览器”，其中包含可以打印的“重复点”报告。

工作流

  2. 选择地形模型。

  3. （可选）打开“应用层公差 (Apply Level Tolerance)”并设置值。

  4. 将显示任何找到的重复点的报告。

父主题: 地形分析


水膜效应

什么是水膜效应？

要让道路使用者能够停止或驾驶车辆，车辆轮胎必须抓地。抓地通过在轮胎与路面最上层微粒接触的区域中产生摩擦来实现。如果可用的摩擦不足以抵抗加速度、刹车或转弯操作产生的力，轮胎可能会滑过路面。在干燥条件下，支持大多数正常操作的情况通常会产生表面摩擦，但路面潮湿或被淹没时可用摩擦的程度会降低。

轮胎胎面与压力、路面与几何图形、车速与水面深度等因素影响轮胎与路面的有效横向和纵向摩擦。当失去抓地力或牵引力时，移动车辆要么打滑，要么发生水膜效应，二者都是重大的驾驶危险。水膜效应最不为人知，但也是最危险的情况。

需要检查的潜在问题区域

超高发展区域可能会导致问题，尤其是纵向坡度相对平坦的地区。通往汇合点（如环形交叉口）的道路也可能是问题区域，尤其是因为车辆在高速行驶时刹车。

另一个可能造成问题的区域是上下坡道，其中穿过通行车道、分道角区和坡道的额外路面宽度可能导致流动路径极长。

工作流

开始之前

水膜效应分析的结果是增量地形模型和流线。增量地形模型中的高程是计算水深的高程，这些高程通常非常小，大约几毫米或一英寸的零头，它们均从 0 开始。因此，建议您在使用“水膜效应”之前创建一个新的 DGN，并在路面地形模型中参考。这样一来，DGN 中元素的高程范围将是增量地形模型的高程，别无其他。这意味着主题显示可用于有效地显示水深变化。

如果 DGN 包含其他元素（如路面），则高程范围将为零（最小水深）到路面的最大高程。

“水膜效应”命令会提示您选择路面地形模型。为了避免进行不必要的处理，必须限制此地形模型，使其仅覆盖路面，而不覆盖道路边缘特征，如路缘、人行道、边界等等。

这同样适用于双车道或分车道公路的中线或中央保护区。例如，如果中线对明渠建模，这可能会导致沿其反向产生长流线，使水膜深度高到无法接受。在这种情况下，最好创建两个单独的地形模型，分别用于道路两边。

  1. 水膜深度计算

    该命令提供了两个供选择的公式来计算水膜深度。

    Galloway

    其中

    D 为路面纹理顶部以上的水膜深度 (mm)。

    T 为平均路面纹理深度 (mm)（请参阅“纹理深度”部分）。

    L 为排水径长度 (m)（请参阅“排水径”部分）。

    I 为降雨强度 (mm/h)（请参阅“降雨强度”部分）。

    S 为排水径坡度 (%)（请参阅“排水径”部分）。

    道路研究实验室

    位置

    d 为流动路径终点的流动深度 (mm)

    lf 为流动路径的长度 (m)

    I 为降雨强度 (mm/hr)

    Sf 为流动路径的坡度

    请注意，完成分析之后，可以更改用于单条流线的公式。为此，您需要显示包含增量地形模型和流线的三维模型。在此模型中，您可以选择流线并在“属性”对话框中更改其使用的公式。这样做将自动更新增量地形模型。

    斜率

    用于计算水膜深度的坡度可以是流线上的每对点之间的瞬时坡度，也可以是“等面积坡度”，计算如下：

    • 用此面积除以流线长度，然后乘以 2。
      • 由此计算得出等面积三角形的纵坐标 = 等面积纵坐标。
    • 绘制这个新的纵坐标（在流动路径的最高点）并将其连接回分析点。
    • 计算这条线的斜率（等面积坡度）。

    （来自 Austroads 道路设计指南第 5A 部分）

    上图显示了包含几个分段的流动路径上的“等面积坡度”。

    报告

    为所选流线提供报告。要创建报告，请执行以下操作：

    • 选择流线。
    • 单击上下文相关菜单中的“创建流线报告 (Create Flow Line Report)”图标。将打开报表浏览器。
    • 展开“土木几何”。
    • 选择 Aquaplaning.xsl。

    此样式表显示相关信息，例如，薄膜深度、坡度、沿流线的距离和高程。

“水膜效应”对话框
创建水膜效应特征定义
父主题: 地形分析


视距分析

什么是视距分析？

根据指定的设计地形或廊道的顶网格和可选的现有曲面或网格分析沿路线或廊道控制路线的视线距离。各种其他设置指定视点和对象的路径、高度和偏移，以确定在不与设计或现有地形或网格相交的情况下是否可以实现所需的视线距离。

prolog

在工具执行完成时，将显示“结果”对话框，而且视线出现在三维模型中。

视距分析的特征定义包含 3 个特征符号，这些符号代表每个视线在每个视点位置的视线距离分析结果。

“已实现的特征符号”指定实现了所需视线距离的所有视线的颜色、线宽和样式。

“已放宽的特征符号”指定所实现的视线距离大于或等于“已放宽的视线距离”且小于所需视线距离的所有视线的颜色、线宽和样式。

“未实现的特征符号”指定未实现所需视线距离的所有视线的颜色、线宽和样式。

报告

为“结果”框中的视线显示更详细的报告。可通过创建新 xsl 样式表或修改随附的样式表之一来自定义报告。

已实现

选中“打开”时，实现了所需视线距离的所有视线都显示在三维模型中。

已放宽

选中“打开”时，所实现的视线距离大于或等于“已放宽的视线距离”且小于所需视线距离的所有视线都显示在三维模型中。

未实现

选中“打开”时，未实现所需视线距离的所有视线都显示在三维模型中。

显示已选定

如果为“打开”，将仅显示在“结果”对话框中选择的行。用户还可以使用向上/向下箭头显示在“结果”对话框中选择的行。如果为“关闭”，将恢复“已实现”、“已放宽”和“未实现”复选框的先前状态。

视距分析工作流
视距分析报告
视距分析对话框选项
父主题: 地形分析


地形杂项

地形模型杂项工具组包含一些报告工具、图形过滤器设置工具，以及标注和导出工具。

设置

描述

图形过滤器管理器

为各个地形特征创建单独的过滤器，并合并这些过滤器以形成过滤器组。

导出到文件

标识将土木地形模型导出到外部文件的要求。

地形模型可以导出为：

  • GEOPAK (TIN)
  • Inroads (DTM)
  • MX (FIL)
  • LandXML 版本 1.2
图形过滤器管理器
导出到文件
父主题: 地形


图形过滤器管理器

用于为各个地形特征创建单独的过滤器，然后将它们组合成过滤器组。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 杂项

使用图形过滤器创建过滤器组

可以从“按图形过滤器创建地形”工具内访问管理器，或直接从位于“地形模型杂项”工具组中的“图形过滤器组”工具访问。设置过滤器组的常规工作流是为单个地形特征创建单独过滤器，然后将它们组合成过滤器组。例如，常用数据集可能包含点和分别使用层、点和断点的切断线。为点创建特征，为切断线创建特征，然后组合成一个过滤器组，并指定一个有意义的名称，以便于指示其内容。另一组可具有所有特征。请注意，可以使用过滤器组，其中的过滤器比数据中的过滤器多。如果找不到特定过滤器的数据，则该过滤器将被忽略。

创建过滤器

  1. 通过对话框顶部的图标选择“创建过滤器”，或右键单击“图形过滤器”并选择“创建过滤器”。名为“新过滤器”的行将添加到层次结构中。可以随时将此过滤器重命名为合适的名称。
  2. 高亮显示刚才创建的过滤器，并请注意，对话框的右窗格有“属性”窗格，其中包含“常规”和“按剖面过滤 (Filter By Sections)”。

常规

在此，您将指定在 TM 创建过程中所用数据的大小或数据量。例如，此过程可能和指定层一样简单。或者您可能需要指定层、颜色或其他 MicroStation 特性。选择足够的信息，使该过滤器保持唯一，以区别于文件中的其他元素。

设置 | 描述
名称 | 用于标识过滤器的唯一短名称。
描述 | 用于进一步标识过滤器的可选描述（如果“名称”不足）。
特征类型 | 选择与数据类型对应的特征。另请参阅特征。
过滤器类型 |
编辑过滤器 | 打开“编辑过滤器”对话框，您可在其中设置过滤器参数，即级别、颜色、土木特征等。 单击左侧的类别，然后选择参数，可以设置这些参数。定义选择集，选择类别，然后单击“通过选择”。软件将基于选择集中的元素自动填充字段。支持多选（选择六种颜色或五个级别等）。要查看与过滤器匹配的元素数量，请单击“预览”。视图中适合过滤器的所有元素将高亮显示。设置完参数后，单击“完成”关闭编辑器，并返回“过滤器管理器”对话框。

过滤依据

“过滤依据”部分将快速显示当前过滤器中指定的类别。例如，如果使用级别和颜色来定义过滤器，则过滤完成后，级别和颜色项将会打开。

有关级别、颜色、线宽、线型和其他元素属性的详细信息，请参考 MicroStation 帮助主题。

有关“透明度”的详细信息，请参考“MicroStation 其他元素特性”帮助主题。

有关“元素模板”的详细信息，请参阅“MicroStation 其他元素特性”帮助主题。

对于“单元名”，高亮显示该单元并单击“添加 ->”以添加到列表。可以一次性选择多个单元。要移除，高亮显示左侧列表中的单元并单击“<- 移除”。添加或移除整个列表支持“全部”或“无”选项。

对于“土木特征”，高亮显示土木特征并单击“添加 ->”以添加到列表。可以一次性选择多个特征。要移除，高亮显示左侧列表中的特征并单击“<- 移除”。添加或移除整个列表支持“全部”或“无”选项。

“高程”选项有助于将数据移出感兴趣的范围。例如，数据可能具有 0 高程数据，此数据可能会使地形模型倾斜。可以排除特定的值（例如 0）或排除高程范围。注意，此处是排除，不是包含。

创建过滤器组

在创建至少一个过滤器之后，可以创建过滤器组。常规工作流为：

  1. 高亮显示“图形过滤器组”，右键单击并选择“新建图形过滤器组”。层次结构中将添加一行，可以随时对此行重命名。也可以添加可选描述。请注意，该名称是显示在“按过滤器创建地形”工具内的内容。

  2. 单击“过滤器”以打开“选择过滤器”对话框。此时左窗格会显示当前已定义的所有过滤器。

  3. 高亮显示要包括在组中的过滤器（在左窗格中），然后单击“添加”。这些过滤器会移动到右窗格。如果错误添加了某个过滤器，在右窗格中高亮显示该过滤器，然后单击“移除”。

  4. 选择所需过滤器之后，单击“确定”以关闭对话框并创建过滤器组。请注意，一个过滤器可能属于多个过滤器组。

图形管理器工具栏

为便于访问，对话框顶部放置了几个工具：

设置 | 描述
创建图形过滤器组 | 创建空的图形过滤器组。
创建图形过滤器 | 创建空的图形过滤器。
从选择集创建过滤器 | 从激活文件或参考文件选择设计文件元素，此命令使用符号来填充过滤器中的特性。
复制 | 将过滤器或组添加到剪贴板用于粘贴命令。
粘贴 | 将条目从剪贴板添加到列表，如果添加的名称存在大于等于 1 的数字，输入新名称或稍后重命名。
删除 | 删除条目。
预览 | 将所有通过过滤器的元素放入高亮显示区。
清除预览 | 从预览元素中移除所有高亮显示内容。

属性

属性模式会根据树视图中的激活选择进行更改，从而为“过滤器”或“过滤器组”提供顶层属性。

常用特性

名称 - 当前 DGN 中用户可定义的描述，必须具有唯一性。

描述 - 用户可定义的描述。

过滤器组属性

添加或移除过滤器 - 用于选择可用过滤器。

过滤器属性

特征类型 - 预定义的“地形特征类型 (Terrain Feature Type)”列表。

过滤器类型 - 不可编辑。

编辑过滤器 - 将打开“元素属性”的单独对话框。

过滤依据 - 允许在要使用的过滤器中定义主要选择的属性。

编辑过滤器 - 将打开“编辑过滤器”对话框。

编辑过滤器

该窗体在左侧视图中列出“元素选择”模式、可用属性信息以及所选类型。当通过“选择”添加时，所有属性均加载为激活状态，这使得过滤器对于该选择来说非常具有选择性和特定性。可以在任何过滤器中进行多个选择。

示例

层 - 道路可以包含多个特征，这些特征针对路面边缘和中心线使用不同的线型。如果每个特征均需要分别管理，则稍后需要根据独特的属性（本例中为“线型”）来定义特定的过滤器。但是，如果将其视为无特征的切断线，则只能根据“层”进行选择。

父主题: 地形杂项


导出到文件

用于识别将土木地形模型导出到外部文件的要求。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 杂项

由于基础地形模型 (TM) 数据收集方法将增加细节和大小，因此，需要采用高效的方式存储和导出 TM，这样才能跨各种基础设施和映射工作流进行数据传输。作为这些工作流的一部分，一个共同的要求是将数据存储在主存储外部，以便备份数据或将数据传输到其他应用程序（甚至传输到早期版本的 Bentley Civil 应用程序）。使用此命令可识别土木 TM 导出到外部文件的要求。

TM 可导出到：

  • GEOPAK (TIN)

  • MX (FIL)

  • LandXML 版本 1.2

注释: 导出到 MX 或 LandXML 格式时，需要额外提示。

工作流

  1. 启动命令。

  2. 选择地形。

  3. 选择输出类型。

  4. 完成 MX 或 LandXML 格式的额外提示。

  5. 在文件管理器中，输入要创建的导出文件的名称。

  6. 单击“保存”。

父主题: 地形杂项


地形标注

设置 | 描述
标注地形等高线 | 在选择的等高线上为标高放置附加标签。
标注地形位置 | 在地形模型上的特定位置注明标高。
标注地形等高线
标注地形位置
父主题: 地形


标注地形等高线

用于在选择的等高线上为标高放置附加标签。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 标签

用于在选择的等高线上为标高放置附加标签。等高线自动标记为地形模型元素的一个属性。您可以使用此工具放置附加标签。

工具设置

设置 | 描述
地形模型 | 所选地形模型的名称。
注释模式 | “所有等高线”选项将在选择的所有等高线上放置标签。 “主等高线”选项将仅在主等高线上放置标签。
尺寸标注样式 | 从包含所有可用尺寸标注样式的列表设置当前尺寸标注样式。 要创建或选择尺寸标注样式，请单击放大镜图标，打开“尺寸标注样式”对话框。 要将任何尺寸标注相关的工具设置恢复为缺省尺寸标注样式设置，请单击“重置样式”图标。
文本对齐方式 | 如果使用“向上倾斜”定向文本标签，读取标签时将好像站在山底往山上望。 如果使用“跟踪线”定向文本标签，文本方向将取决于选择等高线时使用的线的方向。
高度 | 使用工作单位设置文本高度。 缺省值由文本样式设置。
宽度 | 使用工作单位设置文本宽度。 缺省值由文本样式设置。
“注释比例锁”图标 | 如果打开，将使用激活模型的注释比例生成等高线注释。
“标注地形等高线”工作流
父主题: 地形标注


标注地形位置

用于在地形模型上的特定位置注明标高。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 标签

工具设置

设置 | 描述
地形模型 | 所选地形模型的名称。
注释模式 | “所有等高线”选项将在选择的所有等高线上放置标签。 “主等高线”选项将仅在主等高线上放置标签。
文本样式 | 从包含所有可用文本样式的列表设置当前文本样式。 要新建文本样式，请单击“文本样式”选项菜单旁的放大镜图标，打开“文本样式”对话框。 要将任何文本相关的工具设置恢复为缺省文本样式设置，请单击“重置样式”图标。
尺寸标注样式 | 从包含所有可用尺寸标注样式的列表设置当前尺寸标注样式。 要创建或选择尺寸标注样式，请单击放大镜图标，打开“尺寸标注样式”对话框。 要将任何尺寸标注相关的工具设置恢复为缺省尺寸标注样式设置，请单击“重置样式”图标。
文本旋转 | 设置文本相对于引线的旋转：“水平”、“垂直”或“线内”。
文本框 | 设置框架的类型（如果有）—“无”、“直线”“方框”、“旋转方框”、“圆形”、“长圆”、“六角”、“旋转六边形”、“三角形”、“五边形”或“八边形”。
高度 | 使用工作单位设置文本高度。 缺省值由文本样式设置。
宽度 | 使用工作单位设置文本宽度。 缺省值由文本样式设置。
“注释比例锁”图标 | 如果打开，将使用激活模型的注释比例生成标高注释。
位置 | 确定是否可以放置由多段组成的引线。如果设置为“手动”，则可以放置多段引线。如果设置为“自动”，则只能放置一段引线。 缺省设置由尺寸标注样式（“放置”分类）确定。
引线类型 | 设置引线的类型：“直线”或“曲线”。
水平连接 | 设置引线连接端：“自动”、“左”或“右”。
线中引线 | 如果打开，则使用线中引线。线中引线是与文本对齐的额外引线段。
“标注地形位置”工作流
父主题: 地形标注


几何图形

入门
选择
通用工具
平面
纵断面
常用工具
父主题: OpenRoads Designer CONNECT Edition帮助


入门

您将在“入门”中找到以下主题：

土木几何曲率
土木几何设计标准
土木几何操作和修改命令
父主题: 几何图形


土木几何曲率

如“首选项”主题中所述，加载 Bentley Civil 时，可以使用“土木格式设置”面板进行设置。其中一个设置是曲率切换。

“半径切换”按键用于定义曲率而不是半径。“半径切换”可用于定义弧的任何命令。默认情况下，这些命令会提示输入半径，如下所示。

可以使用该开关将半径更改为曲率，如下所示。键入 d，后跟曲率值。

曲率显示在提示符下。

曲率保留在规则中，如操纵器中所示。

仅当锁定时，曲率才会保留。

如果需要在同一命令实例中切换回半径，请再次键入 d。

下次启动弧命令时，将默认返回半径模式。

如果使用通过点动态操作弧，则将切换回半径持久性。

父主题: 入门


土木几何设计标准

设计标准可用于在执行几何布局时保持所需的曲率和其他路线检查。这些标准在两个级别上发挥作用：

  • 为元素创建工具提供值（例如，最小半径和过渡段长度）
  • 检查复合元素的适用性（例如，检查路线中的结）

设计标准非常注重路线。您可能会发现使用设计标准进行非路线计算的价值有限。

违反设计标准时，通过两种方式提供反馈：

  • 图形上的图标（在有问题的元素上）。将鼠标悬停在该图标上方可显示错误的工具提示报告。
  • 在土木消息中心

设计标准工具栏

在菜单上，选择“几何图形”>“通用工具”>“标准”>“设计标准工具栏”以打开设计标准切换栏。

此工具栏可用于设置所有命令使用的激活设计标准。

  1. 选择所需的标准。
  2. 单击左侧的按钮以切换标准的开关状态。启用此项后，所有标准将使用该标准中包含的值。禁用此项后，选定标准将被忽略。
注释: 可从项目浏览器访问设计标准。

创建设计标准

设计标准可用于根据设计速度和其他考虑因素设置组织所需的标准来控制路线配置。

  1. 为标准创建 DGNLIB。
  2. 打开“文件”菜单，选择“项目浏览器”，然后打开“土木标准”选项卡。通过右键单击，然后选择“新建”，或者通过复制/粘贴现有标准，可以创建一个新的标准。
  3. 创建后，选择该标准以设置或编辑其属性。
  4. 打开该项的“细节”面板以查看设置。

以下列表描述了每个标准的属性：

  • 速度 - 这是标准的设计速度；供用户参考，也用于公式
  • 默认半径 - 这是在命令启动时用来填充命令的半径；不支持在设计标准设置中输入曲率。
  • 最小半径 - 这是相应设计速度的最小半径；使用小于此半径的值将导致显示警告
  • 过渡段类型 - 可以是“表”或“公式”；过渡段长度公式是在 AASHTO 手册 2004 中找到的硬编码公式。

    公制公式：

    L = V3 / (46.7 * RC)，其中：

    L = 长度 (m)

    V = 速度 (km/h)

    C = 向心加速度（横向加速度的增加速率，m/s3）

    R = 曲线半径 (m)

    设计标准中的唯一输入是 C。

    可找到以下公式：

    AASHTO 2004 – 公式 3-27，第 185 页。

    AASHTO 2011 – 公式 3-25，第 3-70 页。

    英制公式：

    L = 3.15*V3 / R*C

  • 表 - 如果“过渡段类型”设置为“表”，则此属性用于填充表（参见下文）
  • 确保接触弧 (Insure Tangency Arc) - 如果设置为 True，则该标准检查所有弧以确保不纽结
  • 包括弧的过渡段 - 如果设置为 True，则对圆弧命令应用过渡段
  • 最大弧长
  • 最小弧长
  • 确保接触切线 (Insure Tangency Tangent) - 如果设置为 True，则检查切线是否纽结
  • 包括过渡段 - 如果设置为 True，则线命令将添加过渡段
  • 最大切线长度
  • 最小切线长度
  • 最大偏差 - 两条切线在无曲线的情况下连接时线间的最大角度

过渡表 - 这是一个半径表，其中列出每个半径对应的默认和最小过渡段长度。如果在列表中找不到使用的实际半径，则使用最接近但不超过特定半径的半径的过渡段长度。

父主题: 入门


土木几何操作和修改命令

本主题讨论如何对土木元素使用操作和修改命令。

操作命令

MicroStation 操作命令对土木元素禁用，因为允许对基于规则的土木元素使用这些命令会破坏用于定义元素的规则。

如果需要对土木元素执行其中一个命令，首先通过右键单击元素移除规则，然后将允许执行该操作。

修改命令

MicroStation 修改命令可用于土木元素，但“智能修剪”除外，不允许执行该命令。不应使用此工具箱中的“圆角”和“倒角”命令。应该使用等效的土木几何命令。

示例：部分删除

部分删除用于移除直线的一部分。“部分删除”（和其他土木几何修改命令）在土木元素上正常运行。

间隔和间隙

选择直线后，将保留直线的原始定义（规则）。此元素是通过在第一条线段上拾取而选择的。请注意，在该间隔上放置了一个新的操纵器。可以拖动此操纵器来更改间隔长度并缩短间隙。

在第二个间隔上拾取将显示该端的间隔操纵器。

有关间隔和间隙的一些注意事项：

  • 原始基本几何图形使用其规则创建元素；基本几何图形始终都会保留

  • 间隔是显示基本几何图形的位置（可见）。

  • 间隙是不显示基本几何图形的位置。

  • 土木几何修剪或延伸命令沿原始基本几何图形创建间隔。

  • MicroStation 修改命令沿原始基本几何图形创建间隔或间隙。

  • 间隔可用于任何命令，或者可以使用基本几何图形。

父主题: 入门


选择

另请参阅选择

父主题: 几何图形


通用工具

常规几何导入/导出
常规几何设计元素
常规几何标准
常规几何土木切换
报告
父主题: 几何图形


常规几何导入/导出

该工具用于导入到本地产品（InRoads、GEOPAK 和 MX）或从其中导出，还具有可从通用 MicroStation 元素中创建“土木”元素的工具。

在工具箱中选择 | 描述
导入几何 | 如果坐标几何数据库中存储的图形元素为 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素，则可导入这些元素。
从 ASCII 导入平面几何 | 通过文本向导从 ASCII 文件中导入平面几何元素。
从 ASCII 导入纵面几何 | 通过文本向导从 ASCII 文件中导入纵面几何元素。
导出几何图形 | 用于将选定土木几何元素导出到以下某一坐标几何数据库中：MX FIL 文件、InRoads ALG 文件或 GEOPAK GPK 文件。
导入几何
从 ASCII 文件导入平面几何
从 ASCII 文件导入纵面几何
导出几何图形
父主题: 通用工具


导入几何

如果坐标几何数据库中存储的图形元素为 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素，则可导入这些元素。

您可以通过以下方式访问此工具：

  • 功能区：几何 > 通用工具 > 导入/导出拆分按钮
  • 功能区：主页 > 模型导入/导出 > 地形导入拆分按钮

如果坐标几何数据库中存储的图形元素为 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素，则土木几何工具可导入这些元素。

工作流

  1. 单击“导入几何”。将显示“导入几何”对话框。有三种可用的文件类型。

  2. 选择几何图形数据库。选中后，将查询几何图形数据库并显示检查清单。

  3. 选中要导入的元素并单击“导入”按钮。

    • 如果导入命令再次运行，先前导入的元素将显示为已检出。

    • 选中“创建规则”框以在导入元素时对其应用规则，从而能够使用操控器编辑元素。取消选中此框后，元素作为平面图形导入。

注释: 有些导入的几何图形无法应用规则。请参阅导入平面几何和导入纵面几何。
父主题: 常规几何导入/导出


从 ASCII 文件导入平面几何

通过文本向导从 ASCII 文件中导入平面几何元素。

您可以通过以下方式访问此工具：

  • 功能区：几何 > 通用工具 > 导入/导出拆分按钮

导入各种数据类型

本主题提供有关可使用“文本导入向导”导入的各种数据类型的导入过程详细信息。

坐标几何点

每行均作为一个坐标几何点处理。如果过滤器未指定点名称，则会以与“添加坐标几何点 (Add Cogo Point)”命令相同的方式生成名称。如果提供了桩号偏移数据而不是纵坐标、横坐标、高程数据，则必须存在激活的平面路线。如果一个点的桩号偏移数据不在水平桩号范围内，则不会导入该点。然后将每个坐标几何点添加到激活的坐标几何缓冲区，并在添加所有点之后更新 InRoads Explorer。

数据示例 - 点名称、纵坐标、横坐标、高程

Cogo1 417289.44 194301.93 0.00

Cogo2 417233.32 194384.69 0.00

Cogo3 417179.75 194468.90 0.00

Cogo4 417186.60 194566.65 0.00

Cogo5 417211.60 194663.48 0.00

Cogo6 417236.60 194760.30 0.00

Cogo7 417255.53 194857.96 0.00

平面路线

除了最后一行（被处理为路线的最后一个点）之外，每行都被处理为水平 PI。每个 PI 在处理时，均会添加到数组中。加载完所有数据之后，每个 PI 及相关的圆弧和过渡螺线将插入到新创建的路线中，其对应的名称、描述和样式由用户通过“几何图形选项 (Geometry Options)”对话框指定。添加完所有 PI 之后，路线将插入到 InRoads Explorer 中的激活几何图形项目中并激活。

数据示例 - 纵坐标、横坐标、半径、第一缓和曲线长度、第二缓和曲线长度

注释: 平面路线数据以 PI 为基础。

1000 1000

2000 2000 500 100 100

3000 1000 500

4000 2000 500 75 125

5000 1000

上面的示例与在以下坐标处使用“几何图形”>“平面曲线集”>“添加 PI (Add PI)”添加 PI 相同：

1000, 1000

2000, 2000

3000, 1000

4000, 5000 和

5000, 1000。

然后使用“几何图形”>“平面曲线集”>“定义曲线 (Define Curve)”添加以下曲线集：

  • 半径为 500 的 SCS 类型的曲线集、长度为 100 的前缘回旋缓和曲线和长度为 100 的尾缘回旋缓和曲线
  • 半径为 500 的 SCS 类型的曲线集，无缓和曲线
  • 半径为 500 的 SCS 曲线集、长度为 75 的前缘回旋缓和曲线和长度为 100 的尾缘回旋缓和曲线

几何选项（文本导入向导）

当导入平面或纵面路线时，将显示“几何选项”对话框。文件名称显示在对话框标题中。

平面路线向导

当数据由以下项定义时读取文件：

  • 点类型（POB、POE、PC、PT、PCC、PRC、TS、SC、CS、ST、SS），视为路线上的点
  • 点类型（CC、SPI），视为路线外的点
  • 纵坐标
  • 横坐标
  • 桩号

软件根据点类型和坐标确定所有几何图形。过渡螺线的类型由“文件”>“项目选项”>“几何与螺线定义 (Geometry and Spiral Definition)”定义。过渡螺线的长度是 TS 和 SC 之间的桩号差。

使用平面路线向导的以下关键字：

  • 路线上的点
  • 路线外的点
  • 桩号

定义多个过滤器以读取这些类型的文件。

点顺序

做出以下假设：

  • 点从路线的起点开始到路线的终点
  • 圆弧的点必须是圆弧的起点（即 PC）、圆心（即 CC），然后是圆弧的终点（即 PT）
  • 过渡螺线的点必须是螺线的起点（即 TS）、螺线的交点（即 SPI），然后是螺线的终点（即 SC）

顺序十分重要，以便使软件可以据此确定一系列点是组成直线、圆弧还是过渡螺线。无论元素是圆弧还是螺线，均是基于路线外的点以及上一个点和下一个点的位置。如果从上一个点到路线外的点的距离与从路线外的点到下一个点的距离相等，则元素是圆弧。否则，元素是过渡螺线。在后一种情况下，软件必须能够计算螺线的起始半径和结束半径。这可以通过检查螺线前后的点来实现。

父主题: 常规几何导入/导出


从 ASCII 文件导入纵面几何

通过文本向导从 ASCII 文件中导入纵面几何元素。

您可以通过以下方式访问此工具：

  • 功能区：几何 > 通用工具 > 导入/导出拆分按钮

坐标几何点

每行均作为一个坐标几何点处理。如果过滤器未指定点名称，则会以与“添加坐标几何点 (Add Cogo Point)”命令相同的方式生成名称。如果提供了桩号偏移数据而不是纵坐标、横坐标、高程数据，则必须存在激活的平面路线。如果一个点的桩号偏移数据不在水平桩号范围内，则不会导入该点。然后将每个坐标几何点添加到激活的坐标几何缓冲区，并在添加所有点之后更新 InRoads Explorer。

数据示例 - 点名称、纵坐标、横坐标、高程

Cogo1 417289.44 194301.93 0.00

Cogo2 417233.32 194384.69 0.00

Cogo3 417179.75 194468.90 0.00

Cogo4 417186.60 194566.65 0.00

Cogo5 417211.60 194663.48 0.00

Cogo6 417236.60 194760.30 0.00

Cogo7 417255.53 194857.96 0.00

纵面路线

除了最后一行（表示路线的最后一个点）之外，每行都表示纵面 PVI。每个 PVI 在处理时都存储在一个数组中。加载完所有数据之后，每个 PVI 都将插入到新创建的路线中，其对应的名称、描述和样式通过“几何图形选项 (Geometry Options)”对话框指定。然后，路线将插入到 InRoads Explorer 中的激活平面路线并激活。

注释: 不支持纵面回旋曲线

数据示例 - 桩号、高程、半径

69 9.93

72 18.14 50.00

43 8.33 20.00

49 16.54 50.00

14 10.38

纵面路线向导

使用纵面路线文本导入向导读取完全定义的数据和部分定义的数据（软件应计算缺少的数据）。

完全定义的数据

创建文本导入向导以读取表示纵面路线的数据。可以轻松创建向导来读取“桩号”、“高程”和可选的“曲线长度”。

部分定义的数据

创建文本导入向导以读取表示纵面路线的数据。可用数据为“桩号”、“高程”、“曲线长度”和“前坡度 (Ahead Grade)”。用 ? 表示桩号和/或高程未知，以指示软件需要计算未知值。

创建第一个过滤器来定义明确“桩号”、“高程”和“曲线长度”选项的线。

设置“范围内的行 (Lines within Range)”、“自此行开始导入 (Start Import at Line)”(1) 和“至此行结束导入 (End Import at Line)”(EOF)。下一个。

设置“起始行 (Lines that Start With)”并指定信息，分隔字符分隔每个字段。下一个。

设置“制表符”、“空格”、“忽略连续分隔符”。下一个。

分隔

列数据格式曲线长度。

显示内容指示必须使用文本导入向导的“纵面路线”分析器处理问题。

? 前面的数据都没问题。这是一个未知数，不视为零。

“曲线长度”数据处理非数据（第一行和最后几行）和数值数据前面的字母字符。

创建第二个过滤器以定义坡度。

设置“包含的行 (Lines that Include)”并指定信息，分隔字符分隔每个字段。下一个。

选择相应列，右键单击并选择列标题。

注意：未知的功能仅适用于纵面路线。

注意：需要数字字符时处理字母数字字符的功能仅适用于纵面路线。

父主题: 常规几何导入/导出


导出几何图形

将选定的土木几何元素导出到 LandXML。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 导入/导出拆分按钮
父主题: 常规几何导入/导出


常规几何设计元素

该工具用于设置激活纵断面和地形。还可以选择图形元素。

在工具箱中选择 | 描述
设置激活纵断面 | 指定多个潜在纵断面元素中的哪个元素将驱动三维模型。
设置激活地形模型 | 指定多个潜在地形模型中的哪个模型位于激活文件或参考文件中。 激活地形模型是默认情况下在轮廓模型中显示的模型，是廊道建模器的默认目标。
通过图形过滤器选择 | 将与“图形过滤器”匹配的所有元素放入 MicroStation 选择集中。
创建土木规则特征 | 为非土木几何工具创建的元素分配土木几何规则。
设置激活纵断面
设置激活
通过图形过滤器选择
创建土木规则特征
父主题: 通用工具


设置激活纵断面

指定哪些潜在的多个纵断面元素将驱动三维模型。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 设置激活纵断面
  • 功能区：几何图形 > 通用工具 > 设计元素

使用“设置激活纵断面”工具指定哪些纵断面元素可能会驱动三维模型。结果是在三维模型中创建三维样条，表示平面路线与设计纵断面的组合。

  1. 单击“设置激活纵断面”图标。

  2. 在纵断面视图中，选择要指定为设计纵断面的纵断面元素。

父主题: 常规几何设计元素


设置激活

设置激活地形模型文件。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑
  • 功能区：几何图形 > 通用工具 > 设计元素拆分按钮

此工具设置激活地形模型文件。缺省地形模型是作为纵断面模型中显示的缺省地形和廊道模型缺省目标的模型。

如果廊道中模板的末端条件与现有地面相互作用，则需要激活地形模型。在任何给定时间只能有一个地形模型为激活状态，但多个地形模型可以组合为一个复杂的地形模型。地形模型可以与廊道模型位于同一设计文件中，但大多情况其都在单独的文件中且被参考。在“地形”功能区中找到“设置激活地形模型”工具。

工作流

  1. 启动命令。
  2. 选择要指定为缺省地形的地形模型。
父主题: 常规几何设计元素
父主题: 廊道建模工作流


通过图形过滤器选择

从选定的图形过滤器创建 MicroStation 选择集。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 设计元素拆分按钮

“通过图形过滤器选择”工具从选定的图形过滤器创建 MicroStation 选择集。

前提条件：

您至少需要一个图形过滤器或过滤器组才能使用此工具。有关如何创建过滤器和过滤器组的详细信息，请参阅图形过滤器管理器。

设置 | 描述
图形过滤器组 | 从列表中选择过滤器组。如果文件或 DGNlib 中未定义过滤器组，则会显示提示以指示没有过滤器组，并打开“图形过滤器管理器”对话框。请注意，在创建过滤器组之后，用户将返回“通过图形过滤器选择”对话框。
地形过滤器管理器 | 打开“地形过滤器管理器”。
预览 | 单击以高亮显示视图中与过滤器匹配的任何元素。

工作流

  1. 选择“通过图形过滤器选择”工具。
  2. 出现提示时，单击（在“工具设置”中）“图形过滤器”按钮以打开“图形过滤器”对话框。将显示工作空间 DGNlib 内定义的所有过滤器和过滤器组，以及存储在激活 DGN 文件中的过滤器和过滤器组。
  3. 选择过滤器或过滤器组，它将填充“工具设置”对话框并关闭“图形过滤器”对话框。
  4. （可选）如果要在选择集创建之前查看候选元素，请单击“预览”。
  5. 出现提示时，点击确认选择。扫描文件，并将与其中一个过滤器匹配的任何元素添加到 MicroStation 选择集。
父主题: 常规几何设计元素


创建土木规则特征

为非土木几何工具创建的元素分配土木几何规则。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 设计元素拆分按钮

使用“创建土木规则特征”工具为非土木几何工具创建的元素分配土木几何规则。例如，MicroStation 智能线可以成为土木几何带形线元素，并配有操控器以及从中衍生的所有编辑功能。

注释: 该元素必须位于二维设计模型中，才能将其转换为土木规则特征。

工作流

  1. 单击“创建土木规则特征”图标。

  2. 选择要向其分配规则的图形元素。
  3. 重置（在大多数情况下右键单击）以关闭选择集。
  4. 现在已为所选元素分配土木规则，您可以选择操控器进行编辑。

纵面几何

在纵断面中，具有激活纵断面的基准元素随即在水平方向上复合，将自动向前传递基准元素（需要激活纵断面）。如果这是真正的纵面几何，则在复合纵断面中不可编辑，因为它是在元素纵面级别进行控制。可以创建一个可编辑的纵面元素快照的副本。

父主题: 常规几何设计元素


常规几何标准

  • 功能区：几何 > 通用工具 > 标准拆分按钮

包含设计标准、特征“定义”和“消息中心”。

在工具箱中选择 | 描述
设置设计标准 | 用于为先前没有设计标准的元素分配设计标准。“设计标准”工具栏中的激活设计标准是要分配给选定元素的标准。
设计标准工具栏 | 为土木几何元素分配设计标准或更改元素的设计标准。
设置特征定义 | 为土木几何元素分配特征定义，或更改元素的特征定义。
特征定义工具栏 | 使用“特征切换栏”上的命令来激活或取消激活影响各种几何图形命令的设置。 另请参阅 特征切换栏
匹配特征定义 | 将某个元素的特征提供给另一元素。
土木消息中心 | 对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。
设置元素信息 | 在绘图的特定元素上添加您自己的批注。
设置设计标准
设计标准工具栏
设置特征定义
特征定义工具栏
匹配特征定义
土木消息中心
设置元素信息
父主题: 通用工具


设置设计标准

为之前没有的元素分配设计标准。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

此命令用于为先前没有设计标准的元素分配设计标准。“设计标准”工具栏中的激活设计标准是要分配给选定元素的标准。

父主题: 常规几何标准


设计标准工具栏

为土木几何元素分配设计标准或更改元素的设计标准。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

“设置元素设计标准 (Set Element Design Standard)”用于将设计标准分配给土木几何元素或更改元素的设计标准。

“设置元素设计标准”与设计标准工具栏结合使用。该工具栏中显示的激活设计标准是要分配给所选元素的标准。

工作流

  1. 单击“设置元素设计标准 (Set Element Design Standard)”。将显示“设计标准”工具栏。

  2. 选择要分配的设计标准。

  3. 选择要为其分配设计标准的元素。

  4. 选择该元素以查看是否已应用设计标准。

  • 如果该元素的参数不符合标准的要求，则屏幕上和土木消息中心将显示错误标志符号。元素不会更改，仅报告错误。

父主题: 常规几何标准


设置特征定义

为土木几何元素分配特征定义，或更改元素的特征定义。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

“设置特征定义”为土木几何元素分配特征定义，或更改元素的特征定义。

工作流

  1. 单击“设置特征定义”。将显示“设置特征 (Set Feature)”对话框。

  2. 选择要分配的特征定义。“设置特征定义”与“特征切换栏””配合使用。可以通过将命令设置为使用激活特征来使用切换栏中显示的激活特征，也可以从命令对话框中选择特征定义。

  3. 选择要分配特征定义的元素。还可以使用选择集。

线符已更改，元素信息反映已分配特征定义。

父主题: 常规几何标准


特征定义工具栏

激活和取消激活影响各种几何图形工具的设置。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

使用“特征工具栏”上的工具来激活和停用影响各种几何图形工具的设置。

打开“土木工具”任务窗格并切换到“常规几何 (General Geometry)”或“平面几何”部分，然后单击“特征切换栏”图标。

单击“替代特征定义 (Override Feature Definition)”图标，强制激活工具使用工具栏中选择的特征定义。

展开“特性定义”下拉菜单，从可用的既定特性定义中进行选择。

使用“匹配特征定义”工具，利用指定给所选元素的特征定义来填充该组合框。

单击“自动创建三维体”图标，为创建的元素生成三维模型元素。该三维体通过默认数据模型的最佳拟合计算得出。但是，如果创建的元素与其他具有既定设计剖面的几何元素相邻，则系统将计算“插入过渡纵断面”来定义此三维元素。

单击“使用特征定义模板”图标，可自动将道路模板应用于创建的元素中。特征定义必须在其属性中指定模板。

打开/关闭链工具。如果打开工具链，则许多工具可以自动确定计算过程中要使用的基本元素。例如，“插入直-缓-圆-缓-直曲线”将选择最近的两个元素，并将其设置用于基准元素以构造其圆角。

打开/关闭“保存捕捉”。如果打开，则将捕捉保存到几何图形中（默认为打开捕捉）。

打开/关闭“规则取消激活”。如果打开，则工具将在禁用规则的情况下创建元素。

父主题: 常规几何标准


匹配特征定义

将某个元素的特征提供给另一元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

  1. 配备“元素选择”工具，然后左键单击要为其提供特征定义的元素。

  2. 打开“土木工具”任务窗格的“常规几何 (General Geometry)”部分，然后单击“匹配特征定义”图标。

  3. 将光标移动到“视图”时，它带有一个工具提示，提示您“定位元素”，因此将光标移动到要与特定定义匹配的元素，然后左键单击。分配给所拾取元素的特征定义在特征定义切换栏中填充，供随后用于任何命令。

父主题: 常规几何标准


土木消息中心

对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

Bentley 土木消息中心对可能影响设计过程的各种问题提供反馈，例如，违反建筑和设计标准的错误。

消息中心可以浮动，也可以停靠和固定。

土木消息中心包含四种类型的消息：

  • MicroStation - 复制 MicroStation 在其自己的消息中心显示的所有消息

  • 错误 - 显示在土木工具中找到的需要注意的严重问题

  • 警告 - 显示应该调查的不太严重的错误

  • 消息 - 显示有关土木工具的信息性消息

可以通过单击标题来隐藏消息类型。在上图中，错误和警告显示（用橙色背景表示），MicroStation 和信息性消息隐藏。左侧有一个“全部隐藏”按钮可以隐藏所有类型的消息。

MicroStation 消息

MicroStation 消息是也会出现在 MicroStation 消息中心的消息的镜像。为了方便起见，这些消息已复制到土木消息中心。

错误

错误是需要注意的严重问题。以下列表显示了错误示例。

  • 曲线半径低于分配的设计标准的最小值

  • 将数据保存到本地坐标几何数据库时出现问题

警告

警告是不太严重、但仍需注意的问题。以下列表显示了警告示例：

  • 在不包括曲线的情况下，超出路线中的最大偏差。

  • 超出最大或最小曲线或切线长度。

消息

消息仅是信息性消息。

相应的屏幕标志符号

除 MicroStation 消息之外，消息中心显示的消息都附有屏幕标志符号 以指示出现问题的位置。

将鼠标悬停在标志符号上方可获得问题的弹出式摘要。

右键单击消息中心以缩放至出现问题的位置。当多条消息分布在一个大项目中时，这会很有帮助。

右键单击并选择“缩放至”。

父主题: 常规几何标准


设置元素信息

在绘图的特定元素上添加您自己的批注。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 标准拆分按钮

使用“设置元素信息”命令将您自己的批注添加到绘图中的特定元素。

  1. 打开“土木工具”任务窗格的“常规几何图形 (General Geometry)”部分，然后单击“设置元素信息”图标。

  2. 将光标移动到“视图”时，它带有一个工具提示，提示您“定位元素”，因此将光标移动到要提供描述的元素。

  3. 在“设置元素信息”对话框上，输入主题并在提供的空白处提供描述，然后单击“应用”。

  4. 配备“选择元素”工具，然后单击“视图”中所需的元素。

  5. 按键组合 Ctrl + I。

  6. 在“元素信息”对话框上，展开元素标题下的树，然后单击“信息”分支。

    • 您输入的主题显示在“类型”行中，您提供的描述将显示在同一名称的字段中。

注释: 每个元素只能存储一个无法编辑但会用新的信息覆盖的信息。
父主题: 常规几何标准


常规几何土木切换

访问“土木精确绘图”和工具，以便管理土木规则。

在工具箱中选择 | 描述
激活土木精确绘图工具栏 | 激活或取消激活精确绘图。
激活规则 |
取消激活规则 |
删除规则 | 移除选定元素的规则。当规则移除后，操控器不可用于编辑且元素不会更新。
取消激活参考规则 | 取消激活选定元素的规则。
激活土木精确绘图工具栏
删除规则
取消激活参考规则
父主题: 通用工具


激活土木精确绘图工具栏

访问精确绘图命令。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 土木切换拆分按钮

单击“激活土木精确绘图工具栏”图标可访问精确绘图命令。使用土木精确绘图可精确输入点，无论点是物理点还是线性几何的终点。通过锁定土木精确绘图输入中的两个值，可以将土木精确绘图值作为点的相关规则保留。

工具

单击“切换土木精确绘图”图标可激活或取消激活精确绘图。

单击“快捷方式”图标可访问“土木精确绘图设置”对话框。

单击“距离和方向”图标可将纵坐标输入顺序设置为先距离后方向，二者共用一个公共原点。

单击“距离-方向取消关联”图标可将输入顺序设置为先第一纵坐标距离后第二纵坐标方向，二者无公共原点。

单击“距离-距离”图标可将输入顺序设置为先第一纵坐标距离后第二纵坐标距离，二者无公共原点。

单击 XY 图标可将纵坐标输入顺序设置为先 X 轴后 Y 轴，二者共用一个公共原点。

单击 DX DY 图标可将纵坐标输入顺序设置为先 X 坐标差后 Y 坐标差，二者共用一个公共原点。

单击“桩号-偏移”图标可将纵坐标输入顺序设置为先桩号标识后偏移值，二者共用一个公共原点。

备注：这些方法均可配置。缺省情况下会配置上述方法。您可以编辑、移除这些缺省方法，也可以添加其他方法。

父主题: 常规几何土木切换


删除规则

移除选定元素的规则。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 土木切换拆分按钮

使用“删除规则”命令移除选定元素的规则。当规则移除后，操控器不可用于编辑且元素不会更新。

工作流

  1. 选择“删除规则”工具。

  2. 左键单击要从中移除操控器的元素。

  3. 在开放空间中单击鼠标右键以关闭选择集。

父主题: 常规几何土木切换


取消激活参考规则

取消激活选定元素的参考规则。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 土木切换拆分按钮

使用“取消激活参考规则”命令可取消激活选定元素的参考规则。参考规则是选定元素所依赖的元素，因此元素之间的曲线取决于定义它的另外两个元素。此命令可用于取消激活其他元素的规则。

工作流

  1. 选择“删除取消激活参考规则”图标。

  2. 选择要从中移除参考规则的元素。

  3. 在开放空间中单击鼠标右键以关闭选择集。

父主题: 常规几何土木切换


报告

在工具箱中选择 | 描述
平面曲线数据表 | 该过滤器用于指定要包括在报告数据文件中的平面路线组。
纵断面报表 | 该过滤器用于指定要包括在报告数据文件中的纵面路线组。
合规报表 | 该过滤器用于指定有关闭合路线和参考路线的信息。
地图检查报表 | 该过滤器用于根据绘制的数据（而不是软件存储的内部精度）指定信息。
桩号偏移报表 | 该过滤器用于指定有关选定路线或特征的桩号偏移数据的信息。
点特征桩号偏移高程 | 创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。
桩号基准报表 | 该过滤器用于指定有关选定路线或特征的桩号基础数据的信息。
超高报表 | 该过滤器用于指定有关超高的信息，并可显示选定区间的数据。
平面曲线数据表
纵断面报表
合规报表
地图检查报表
桩号偏移报表
点特征桩号偏移高程报表
桩号基准报表
超高报表
父主题: 通用工具


平面曲线数据表

用于从选定元素生成可打印的 PDF 信息文件。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

使用“平面曲线数据表”从选定元素生成可打印的 PDF 信息文件。

  1. 打开“土木工具”任务窗格的“平面几何”部分，然后单击“平面曲线数据表”图标。

  2. 将光标移动到“视图”时，它将显示命令提示，要求您“定位第一个元素”，因此将光标移动到要包含在报告中的元素，然后左键单击该元素。

  3. 系统提示“定位下一个元素”，因此将光标移动到要包含在报告中的另一个元素，然后点击确认（例如左键单击）。

  4. 选择要包含在报告中的所有元素后，右键单击空白区域。

    • 将打开“平面曲线数据表”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  5. 当系统提示“选择纵断面”时，按向下箭头键以导航可用选项，然后按 Enter 键。

    • 将打开“平面曲线数据表”。
父主题: 报告


纵断面报表

用于创建 XML 报告数据文件，其中包含有关所选垂直对齐的信息。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包括有关所选纵面路线的信息的 XML 报告数据文件。要运行此工具，系统将提示用户从长断面视图中选择一个或多个纵面元素。

  1. 从“分析与报表”工具组中选择“纵断面报表”工具。

  2. 按照危险警告提示操作：

提示 | 用户操作
定位第一个纵断面元素 | 在纵断面窗口中选择土木纵面几何元素。
定位下一个纵断面元素 - 重置可完成 | 选择其他元素或单击“重置”移至下一提示。
父主题: 报告


合规报表

用于根据一组闭合土木平面元素和参考元素生成报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“合规报表”工具根据一组闭合土木平面元素和参考元素生成报告。

1.选择“合规报表”工具。

2.按照危险警告提示操作：

提示 | 用户操作
定位第一个元素 | 选择属性的第一个元素。请注意，可以使用复杂的闭合土木平面几何元素。
定位下一个元素 | 重置以完成，继续选择元素以定义闭合形状。选择所有元素后，单击“重置”移至下一提示。
定位父项 - 重置可跳过 | 指定或忽略父路线。
定位主要参考 - 重置可跳过 | 指定主要和次要参考元素。
主要参考路线带宽 | 如果选择了主要参考元素，但未选择次要参考元素，软件将检查每个点是否在指定的带宽内。如果是，则显示主要参考的合规参考信息。如果超出带宽，则不显示任何合规参考信息。
定位第一个次要参考元素 - 重置可完成 | 如果同时选择了主要和次要参考元素，软件将检查每个点是否在指定的带宽内。如果是，则显示主要参考元素的合规参考信息，而非任何次要参考元素的信息。如果点超出带宽，则使用最近的次要参考元素。
定位下一个次要参考元素 - 重置可完成 | 如果主要参考元素也被选为次要参考元素，则将主要参考元素视为普通的次要参考元素以及主要参考元素。这意味着，如果某个点超出带宽，但主要参考元素仍是最近的元素，则显示主要参考元素的合规参考信息。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

父主题: 报告


地图检查报表

用于根据绘制的数据生成包含精度信息的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“地图检查”根据绘制的数据（而不是软件存储的内部精度）生成包含精度信息的报告。设计出图时，长度和方向的精度仅限于绘制的值，而不是软件维护的完整值。这些绘制的值在构建期间使用，这可能会引入原始设计中不存在的闭合误差。此工具可用于根据绘制的精度确定闭合误差。

1.从“分析与报表”工具组中选择“地图检查报表”工具。

2.按照危险警告提示操作：

选择第一个元素

请注意，可以使用复杂的闭合土木平面几何元素。

定位下一个元素

重置以完成，继续选择元素以定义闭合形状。选择所有元素后，单击“重置”移至下一提示。

3.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。

父主题: 报告


桩号偏移报表

用于创建包含所选平面几何元素的桩号偏移数据的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包含所选平面几何元素的桩号偏移数据的报告。偏移始终沿与基准元素垂直的方向相对偏移元素测量。报告的桩号设置沿偏移元素测量。偏移用于基准（非偏移）元素上的方位基点。

“间隔”（可选）定义每个偏移测量值之间沿偏移元素的距离。值为零不会产生任何影响。

“偏移”（可选）使偏移距离测量到不是直接位于偏移元素上、而是按指定距离进行偏移的点。值为零不会产生任何影响。

工作流

  1. 从“分析与报表”工具组中选择“桩号偏移报表”工具。

  2. 在“工具设置”中定义可选“间隔”或“偏移”。

  3. 按照危险警告提示操作：

提示 | 用户操作
定位元素 | 选择一个土木平面几何元素。
定位第一个偏移元素 | 选择要计算偏移的土木平面几何元素。
定位下一个偏移元素 - 重置可完成 | 继续选择元素。选择所有元素后，单击“重置”生成报告。

4.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

父主题: 报告


点特征桩号偏移高程报表

用于创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

“点特征桩号偏移高程报表”工具可创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。基线元素可以是线性、弧、曲线或任何非点元素。点可以是土木单元或 MicroStation 单元、零长度线或点。偏移始终沿与基线元素垂直的方向相对点测量。报告的桩号设置沿基线元素测量。如果所选点没有点名称或特征，则字段留空。如果使用二维模型或视图中的数据，则高度字段为空。该工具可用于二维或三维视图或模型。

父主题: 报告


桩号基准报表

用于创建包含所选平面几何元素的桩号偏移数据的报告。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 通用工具 > 报表拆分按钮

此工具可创建包含所选平面几何元素的桩号偏移数据的报告。偏移始终沿与基准元素垂直的方向相对偏移元素测量。报告的桩号设置沿基准元素测量。偏移用于基准（非偏移）元素上的方位基点。

“间隔”（可选）定义每个偏移测量值之间沿基准元素的距离。值为零不会产生任何影响。

“偏移”（可选）使偏移距离测量到不是直接位于基准元素上、而是按指定距离进行偏移的点。值为零不会产生任何影响。

1.选择“桩号基准报表”工具。

2.在“工具设置”中定义可选“间隔”或“偏移”。

3.按照危险警告提示操作：

提示 | 用户操作
定位元素 | 选择一个土木平面几何元素（上面称为基准元素）。
定位第一个偏移元素 | 选择要计算偏移的土木平面几何元素。
定位下一个偏移元素 | 重置以完成，继续选择元素。选择所有元素后，单击“重置”生成报告。

4.完成最后一个提示后，土木工程报告浏览器将打开生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。请参阅土木工程报告浏览器进行打印，等等。

父主题: 报告


平面

平面几何线
平面几何弧
平面几何点
偏移和渐变
反向曲线
平面几何缓和曲线
平面几何修改
平面几何复合
父主题: 几何图形


平面几何线

各种线放置工具（“按点”、“连接 (To elements)”、“延长 (From elements)”、“弧间 (Between Arcs)”和“倒角”）。

在工具箱中选择 | 描述
直线 | 在用户定义的两个点之间创建线。
切线延长 | 与参考元素成一定倾斜构造线。
切线延长 | 以一定倾斜从基准元素构造线。
两弧切线连接 | 在先前放置的弧之间构造线。
两点间倒角 | 切平一个角，例如，它可通过在元素之间插入一条线来改变现有的交点。
直线
任意线连接工具
任意线延长工具
两弧切线连接
倒角
父主题: 平面


直线

用于在用户定义的两个点之间创建直线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 直线拆分按钮

可以通过多种方式定义点：

  • 单击图形。

  • 使用土木精确绘图。

  • 相对于其他元素捕捉。

  • 先前创建的几何点元素

当工具启动时或处于激活状态时，可以在对话框中锁定任何值。对话框中的所有值均会随着光标的移动而动态更新。

工作流

  1. 标识直线的起点。

    提示输入起点。

    提示使用土木精确绘图 XY 坐标输入起点。

  2. 标识直线的终点。

    距离显示在光标处，可以通过键入数值并按 Enter 键来锁定。

    请注意提示最右侧的箭头。这可以显示在许多工具中，允许您切换到其他可用参数。在这种情况下，按键盘上的向左或向右箭头会将参数切换到“方向”。

    方向可以锁定。

    当距离或方向被锁定时，这些锁将反映在对话框中。

    距离和方向值在对话框和屏幕提示中动态更新。

  3. 点击确认（例如左键单击）以接受值并创建直线。

操控器

使用“元素选择”选择直线并查看其编辑操控器。

普通操控器

如果放置直线时不存在任何捕捉或任何土木精确绘图约束，则会看到如上所示的屏幕操控器。这些操控器可用于编辑直线，如下所示：

  • 可以单击距离和方向文本操控器来编辑值。

  • 与直线平行的箭头可用于延长或修剪直线，例如，更改距离。

  • 与直线垂直的端点箭头可用于旋转直线，例如，保持距离并更改方向。

  • 中点处的垂直箭头可用于平行移动直线。

  • 端点处的圆点可用于移动点而不约束距离或方向。

  • 中点处的圆点可用于移动整条直线。

捕捉操控器

捕捉直线终点后，正常的操控器会变为捕捉操控器。左端由关键点捕捉，因此会显示一个圆点和指示捕捉类型的图标。

可以通过单击该圆点并拖动来在空间中移动捕捉到的一端。这将打断捕捉并创建一个新的端点位置，该位置可能是一个数据点、不同的捕捉或土木精确绘图输入。

如果将鼠标悬停在捕捉到的端点上方，将显示普通操控器以用于延长/修剪或旋转直线。这也会打断捕捉。

同样，通过土木精确绘图创建直线端点时，普通操控器将替换为一个圆点和精确绘图操控器。

精确绘图操控器为文本标签，您可以单击它们并对其进行编辑。

将鼠标悬停在圆点上方可显示普通操控器进行旋转和修剪/延长。精确绘图输入会随之变为新的输入值。

属性

规则数据也可在直线属性中访问。选择直线并单击“元素信息”。属性窗格中的大部分数据都可以进行编辑，以更改直线定义。

注释: 检查几何图形时，“元素信息”对话框会显示几何图形所属的地形模型（如果有）。
父主题: 平面几何线


任意线连接工具

切线连接 | 以零度斜交角创建到另一元素无任何过渡的直线（仅当“到”元素为曲线时适用），偏移锁定至零。
缓和曲线连接 | 以零度斜交角创建到另一元素为缓和曲线过渡的直线（仅当“到”元素为曲线时适用），偏移锁定至零。
曲线连接 | 以零度斜交角创建到另一元素为圆弧过渡的直线（仅当“到”元素为曲线时适用），偏移锁定至零。
定角度连接 | 以用户定义的斜交角创建无任何过渡的直线，偏移锁定至零。
任意线连接 | 与参考元素成一定倾斜构造线。
任意线连接
父主题: 平面几何线


任意线延长工具

切线延长 | 以零度斜交角创建从另一元素开始无任何过渡的直线（仅当“从”元素为曲线时适用），偏移锁定至零。
缓和曲线延长 | 以零度倾斜角度创建从另一元素缓和曲线过渡的线，仅当“延长 (From element)”为曲线、“偏移”锁定为零时适用。
曲线延长 | 以零度斜交角创建从另一元素开始为圆弧过渡的直线（仅当“从”元素为曲线时适用），偏移锁定至零。
定角度延长 | 以定义的斜交角创建从另一元素开始无任何过渡的直线，偏移锁定至零。
任意线延长 | 以一定倾斜从基准元素构造线。
任意线延长
父主题: 平面几何线


两弧切线连接

用于在先前放置的两段弧之间构造直线。此工具可以选择在弧和构造的直线之间应用后过渡段和/或前过渡段。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 直线拆分按钮

工作流

  1. 单击“两弧切线连接”。将显示“两弧切线连接”对话框。对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  2. 选择要从中构造直线的弧。点击确认（例如左键单击）。

  3. 选择到第一条弧的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  4. 选择要将直线构造到的第二条弧。要接受的数据点。

  5. 选择到第二条弧的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  6. 通过在第二条弧中的不同解决方案编号之间移动鼠标来选择解决方案。找到所需的解决方案修补程序，通过点击确认接受解决方案。

  7. （可选）如果在设置对话框中选择了后过渡段和/或前过渡段，则会出现一条提示，允许修改过渡段属性。使用向左和向右箭头键在后过渡段和前过渡段之间切换。完成过渡段属性之后，点击确认。

  8. 选择调整选项“无”、“后”、“前”或“两者”。这将有效地修剪所绘制的源和/或目标元素。

使用 ALT 键

在命令操作期间，可以使用 ALT 键在备选解决方案之间切换。当屏幕动态显示（最多）4 个解决方案时，按键盘上的 ALT 键在备选解决方案之间切换。

操控器

操控器可用于：

  • 相对源绘制弧的偏移

  • 相对目标绘制弧的偏移

  • 后过渡段

  • 前过渡段

  • 拖动图柄可以动态调整与两段弧的可选偏移距离

属性

还可以在属性中访问“两弧切线连接”规则数据。

父主题: 平面几何线


倒角

用于创建拐角，例如，通过在元素之间插入直线来改变现有交点。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 直线拆分按钮
注释: 通过定义非零的前后半径，还可以构造曲线-直线-曲线。

  1. 打开“土木工具”任务窗格，找到“平面几何图形 (Horizontal Geometry)”部分，然后单击“倒角”图标。

    • 将打开“倒角”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移至视图中后，将出现一个命令提示，要求您“定位第一个元素”，请将光标移至要进行倒角操作的起始元素，然后在其上点击确认（单击鼠标左键）。

  3. 使用以下方法之一设置“起点偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  4. 此时出现提示“定位第二个元素”，请将光标移至倒角必须延伸到的元素，然后点击确认。

  5. 使用以下方法之一“输入终点偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  6. 将光标移至两个元素之间的空白处。此时出现提示“定义前路径长度”，请将以下方法结合使用来定义倒角的前路径直线段（按向左或向右箭头键来导航选项）：

    • 输入“前路径长度”值，然后按 Enter 键。

    • 输入“倒角角度”值，然后按 Enter 键。

    输入用于定义过渡的值后，点击确认以执行命令。

  7. 此时出现提示“定义半径”，请将以下方法结合使用来定义倒角的后路径直线段（按向左或向右箭头键来导航选项）：

    • 输入“后半径”值，然后按 Enter 键。

    • 输入“前半径”参数值，然后按 Enter 键。

    注释: 添加后半径和/或前半径可以构造曲线-直线-曲线结构，而不是简单直线。

    输入用于定义倒角的值后，点击确认以执行命令。

  8. 要修剪倒角交点处的元素或者将倒角延长至与现有元素相交，“偏移”值必须设为零。按向下箭头键以选择可用的选项，然后按 Enter 键。

操控器

操控器可用于：

  • 移动

  • 长度

  • 倒角角度

  • 曲线半径，前提是构造中包含前曲线和/或后曲线

属性

要查看新元素的属性，请使用“选择元素”工具。

在视图中输入倒角上的数据点，然后将光标悬停在选定元素上。单击“属性”图标可访问选定元素的规则数据。

父主题: 平面几何线


平面几何弧

各种弧放置工具（“按点”、“连接 (To elements)”、“延长 (From elements)”、“弧间 (Between Arcs)”、“双心圆 (2 Center)”、“三心圆 (3 Center)”和“复合过渡 (Complex Transitions)”）。

在工具箱中选择 | 描述
圆 | 绘制圆形。
两点间弧 | 创建两点之间的弧。
圆弧连接 | 基于控制一端切线的选定基准元素构造弧。
圆弧延长 | 基于控制一端切线的选定基准元素构造弧。构造可能还包括可选缓和曲线过渡或弧过渡（双心圆曲线）。
插入直-缓-圆-缓-直曲线 | 在先前放置的元素之间构造弧。此工具能够选择在元素和构造的弧之间应用后过渡段和/或前过渡段。
两弧间弧 | 在先前放置的弧之间构造弧。此工具能够选择在基本弧和构造弧之间应用后过渡段和/或前过渡段。
任意元素与弧之间的复杂过渡 | 在先前放置的元素之间构造弧。此工具能够选择在元素和构造的弧之间应用“后缓和曲线”和/或“前过渡段”。
圆
两点间弧
圆弧连接工具
圆弧延长工具
插入直-缓-圆-缓-直曲线工具
两弧间弧
任意元素与弧间的复杂过渡
父主题: 平面


圆

用于绘制圆。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

使用“圆”工具绘制圆。

  1. 打开“土木工具”任务窗格，找到“平面几何图形 (Horizontal Geometry)”部分，然后单击“圆”图标。

    • 将打开“圆”对话框。

    • 选中“半径值”字段旁的框可锁定关联值。

  2. 将光标移至视图中后，将出现命令提示“输入中心点”，因此，点击确认，例如，在要充当圆心的位置上单击鼠标左键。

  3. 光标旁现在显示提示“输入通过点”，因此，执行以下操作之一：

    • 在“圆”对话框上，输入“半径值”，选中相应框，然后在视图中输点击确认；这将使用半径规则创建圆。

    • 在视图中，将指针移至距中心点的所需距离处，然后点击确认；这将使用通过点规则创建圆。

操控器

  • 中心移动点操控器

  • 半径文本操控器

  • 通过点拖曳图柄

属性

要查看新元素的属性，请使用“选择元素”工具。

在视图中的圆上单击鼠标左键，然后将光标悬停在选定元素上。单击“属性”图标可访问选定元素的规则数据。

父主题: 平面几何弧


两点间弧

用于在点之间创建弧。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“两点间弧”用于在点之间创建弧。最常见的用途是在 3 个点之间创建弧，但也有其他功能。

可以通过以下多种方式定义点：

  • 在图形上单击

  • 使用土木精确绘图定义

  • 相对于其他元素捕捉

  • 现有的几何点元素

“两点间弧”对话框

在以下情况下，对话框中的任何输入均可锁定：该工具启动时；如果该工具处于活动状态，则随时可以锁定。对话框中的所有值均会随着光标的移动而动态更新。

用于创建弧的六种工作流

  • 起点、半径和扫角（或长度）

  • 中心点、半径和扫角（或长度）

  • 起点、终点和通过点

  • 起点、通过点和终点

  • 起点方向、终点

  • 起点、终点方向

工作流 1（起点、半径方法）

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 起点、半径
2 | 起点 | 弧起点
3 | 中心点 | 半径
4 | 扫角/长度 | 扫角或长度

  1. 选择放置方法。

  2. 选择弧的起点。

  3. 选择半径可以锁定到的中心点。

  4. 选择扫角或长度可以锁定到的终点。

使用向左/向右箭头可以在扫角与长度之间切换。

扫角或长度可以锁定。

工作流 2（中心点、半径方法）

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 中心点、半径
2 | 中心点 | 半径
3 | 起点 | 半径或起点方向
4 | 扫角/长度 | 扫角或长度

  1. 选择放置方法。

  2. 选择弧的中心点。

  3. 选择半径可以锁定到的中心点。

    • 半径显示在光标处，可以键入值将其锁定。

    • 提示可以切换到起点方向，可将其锁定。

    • 点击确认以设置起点。

  4. 选择扫角或长度可以锁定到的终点。

    • 使用向左/向右箭头可以在扫角与长度之间切换。

    • 扫角或长度可以锁定。

工作流 3（起点、终点、通过点方法）

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 起点、终点、通过点
2 | 起点 | 弧起点
3 | 终点 | 半径、长度或扫角
4 | 通过点 | 半径、长度或扫角

  1. 选择放置方法。

  2. 选择弧的起点。

  3. 选择半径可以锁定到的终点。

    • 半径显示在光标处，可以键入值将其锁定。

    • 使用向左/向右箭头可以在长度与扫角之间切换，可以将其锁定。

    • 选择一个数据点以设为终点。

  4. 选择半径、扫角或长度可以锁定到的通过点。

    • 使用向左/向右箭头可以在半径、扫角与长度之间切换。

工作流 4（起点、通过点、终点方法）

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 起点、终点、通过点
2 | 起点 | 弧起点
3 | 通过点 | 半径、长度或扫角
4 | 终点 | 半径、长度或扫角

  1. 选择放置方法。

  2. 选择弧的起点。

  3. 选择半径、扫角或长度可以锁定到的通过点。

    • 半径显示在光标处，可以键入值将其锁定。

    • 使用向左/向右箭头可以在扫角与长度之间切换，可以将其锁定。

    • 选择一个数据点以设置通过点。

  4. 选择用于锁定半径的终点。

工作流 5 和 6（起点方向、终点和起点、终点方向方法）

起点方向、终点

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 起点方向、终点
2 | 起点 | 起点切线方向
3 | 终点 | 起点切线方向
4 | 起点切线 | 起点切线方向

起点、终点方向

提示编号 | 提示内容 | 选项
1 | 绘制方法 | 起点、终点方向
2 | 起点 | 终点切线方向
3 | 终点 | 终点切线方向
4 | 终点切线 | 终点切线方向

  1. 选择放置方法。

  2. 选择可以锁定起点切线方向的弧起点。

  3. 选择在提示时会保留起点切线方向并且可以锁定该方向的终点。

  4. 选择起点切线方向或终点切线方向。

操控器

使用“选择元素”可以选择弧并查看其编辑操控器。

如果在放置弧时没有捕捉和土木精确绘图约束，操控器将如上所示。这些操控器可用于编辑直线，如下所述：

  • 单击半径和长度文本操控器可以编辑值

  • 单击与弧平行的箭头可以延长或修剪弧

  • 单击与直线垂直的终点箭头可以垂直于弧移动终点

  • 单击终点处的点形操控器可以移动终点

  • 单击弧中点处的点可以动态移动半径

  • 单击通过点处的点可以移动通过点

  • 单击 PI 处的点可以移动 PI 点

  • 单击 PI 处的箭头可以沿后切线或前切线滑动 PI 点

属性

此外，也可以在弧的属性中访问规则数据。选择弧并单击“元素”>“信息”。您可以编辑属性窗格中的大部分数据来更改弧定义。

备注：检查几何图形时，“元素信息”对话框会显示几何图形所属的地形模型（如果有）。

父主题: 平面几何弧


圆弧连接工具

简单圆弧切向连接 | 创建与另一元素无任何过渡的简单半径圆弧，偏移锁定至零。
双圆弧曲线连接 | 创建到另一元素为圆弧过渡的圆弧，偏移锁定至零。
圆+缓和曲线连接 | 创建到另一元素为缓和曲线过渡的圆弧，偏移锁定至零。
圆+双缓和曲线连接 | 创建到另一元素为相反缓和曲线过渡的圆弧（仅当“到”元素为反旋曲线时适用），偏移锁定至零。
圆弧连接 | 基于控制一端切线的选定基准元素构造弧。
圆弧连接
父主题: 平面几何弧


圆弧延长工具

简单圆弧切向延长 | 创建与另一元素无任何过渡的简单半径圆弧，偏移锁定至零。
双圆弧组合延长 | 创建从另一元素开始为圆弧过渡的圆弧，偏移锁定至零。
圆+缓和曲线延长 | 创建从另一元素开始为缓和曲线过渡的圆弧，偏移锁定至零。
圆+双缓和曲线延长 | 创建与另一元素为相反缓和曲线过渡的圆弧（仅当“从”元素为反旋曲线时适用），偏移锁定至零。
圆弧延长 | 基于控制一端切线的选定基准元素构造弧。
圆弧延长
父主题: 平面几何弧


插入直-缓-圆-缓-直曲线工具

插入简单切向圆弧 | 创建两端没有缓和曲线或渐变的半径弧，偏移锁定至零。
插入缓-圆-缓曲线 | 创建两端为缓和曲线过渡但无渐变的半径弧，偏移锁定至零。
插入直-圆-直曲线 | 创建两端渐变但无过渡的半径弧，偏移锁定至零。
插入三心圆曲线 | 创建两端具有半径过渡的半径圆弧，结果为三心曲线，偏移锁定至零。
插入两心圆曲线 | 创建一端具有半径过渡的半径圆弧，结果为双心曲线，偏移锁定至零。
插入直-缓-圆-缓-直曲线 | 在先前放置的元素之间构造弧。
插入直-缓-圆-缓-直曲线
父主题: 平面几何弧


两弧间弧

用于在先前放置的两段弧之间构造弧。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“两弧间弧”用于在先前放置的两段弧之间构造弧。此工具能够选择在基本弧和构造弧之间应用后过渡段和/或前过渡段。

工作流

对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  1. 选择“复合”或“反向”作为“曲线类型”。

  2. 选择用作构造线的起点的后元素弧。单击鼠标左键接受。

  3. 选择与第一个元素或后元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  4. 选择用作构造线的终点的前元素。单击鼠标左键接受。

  5. 选择与第二个元素或前元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  6. 您也可以填写“后过渡段”信息。此信息可以采用五种可能的格式组合：

    • 缓和曲线长度（如下所示）

    • 缓和曲线 A 值

    • 缓和曲线 RL 值

    • 缓和曲线偏差

    • 缓和曲线增量 R

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    • 如果对话框中的“后过渡段”选项设置为“无”，系统将不会提示您输入此信息。

    缓和曲线的定义：

    • 长度 = 缓和曲线长度

    • A 值 = RL 的平方根

    • RL 值 = 半径乘以长度

    • 偏转 = 缓和曲线 PI 的偏转，在美国，有时称为缓和曲线角度

    • 增量 R = 从简单曲线没有缓和曲线的位置到具有缓和曲线的曲线的偏移；在美国，称之为投射或偏移

  7. 您也可以填写“后过渡段”信息。此信息可以采用五种可能的格式组合：

    • 缓和曲线 - 长度（如下所示）

    • 缓和曲线 - A 值

    • 缓和曲线 - RL 值

    • 缓和曲线 - 偏转

    • 缓和曲线 - 增量 R

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    • 如果对话框中的“前过渡段”设置为“无”，系统将不会提示您输入此信息。

  8. 选择弧的半径。可以用图形方式选择该值，也可直接键入数值。

选择截断方法。从以下选项中进行选择：

  • 无

  • 上一步

  • 前

  • 两者

这将截断或修剪用于构造弧的元素。

使用 ALT 键

在操作该命令期间，可以使用键盘上的 ALT 键在备选解决方案之间切换。如果屏幕动态画面显示（最多）四个解决方案，按 ALT 键可以在备选项之间切换。

缓和曲线

在本次构造操作中，缓和曲线可以是：

  • 缓和曲线。一条缓和曲线（创建曲线构造）

此处列出了可用于创建缓和曲线的值。

  • 双缓和曲线。使用此工具可以创建两条缓和曲线；第一条缓和曲线的过渡与参考元素在同一侧，从参考元素半径开始，过渡到无穷远。第二条缓和曲线从无穷远过渡到新曲线的半径，在相对一侧。尽管此弯曲参考元素为最常见的用例，但可以在任何所需的位置使用双缓和曲线。

注释: 最常使用的情况是参考元素本身是曲线，并在相对一侧。

操控器

操控器可用于：

  • 偏移

  • 后过渡段

  • 前过渡段

  • 半径

  • 拖动图柄可以动态调整与两段弧的可选偏移距离

父主题: 平面几何弧


任意元素与弧间的复杂过渡

用于在先前放置的两个元素之间构造一段弧。此工具能够选择在元素和构造的弧之间应用“后缓和曲线”和/或“前过渡段”。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“任意元素与弧间的复杂过渡”用于在先前放置的两个元素之间构造一段弧。此工具能够选择在元素和构造的弧之间应用“后缓和曲线”和/或“前过渡段”。

工作流

注释: 在“任意元素与弧间的复杂过渡”对话框中，可随时锁定任何输入。锁定某些值可能会限制或影响其他值。

  1. 打开“土木工具”任务窗格，找到“平面几何图形”部分，然后单击“任意元素与弧间的复杂过渡”图标。

    • 将打开“任意元素与弧间的复杂过渡”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 选择要用于构造直线的元素。点击确认，单击鼠标左键接受。

  3. 设置与第一个元素的偏移距离。可以使用鼠标以图形方式定义此距离，也可以键入数值。

  4. 选择要用于构造直线的第二个元素。要接受的数据点。

  5. 设置与第二个元素的偏移距离。可以使用鼠标以图形方式定义此距离，也可以键入数值。

    • 您也可以在“任意元素与弧间的复杂过渡”对话框中填写“后缓和曲线”信息。此信息可以采用下列格式：

      • 长度（缓和曲线的长度）

      • A 值（RL 的平方根）

      • RL 值（半径乘以长度）

      • 偏转（缓和曲线 PI 的偏转，在美国，有时称为缓和曲线角度）

      • 偏移

      注释: 如果对话框中的“后缓和曲线”选项设置为“无”，系统不会提示您输入此信息。

    • 您也可以在“任意元素与弧间的复杂过渡”对话框中填写“前过渡段”信息。“类型”选项包括：

      • 缓和曲线

      • 双缓和曲线

    • 可选：从以下方法中进行选择：

      • 长度（缓和曲线的长度）

      • A 值（RL 的平方根）

      • RL 值（半径乘以长度）

      • 偏转（缓和曲线 PI 的偏转，在美国，有时称为缓和曲线角度）

      • 偏移

  6. 设置弧的半径。可以用图形方式定义该值，也可直接键入数值。

  7. 选择截断方法。从以下选项中进行选择：

    • 无

    • 上一步

    • 前

    • 两者

这将截断或修剪用于构造弧的元素。

使用 ALT 键

在操作该命令期间，按住 ALT 键可以在备选解决方案之间切换。对于此命令，该键有两种功能：

  • 拾取基准元素时，按 ALT 键可以拾取复合元素的组件，而不是复合元素本身。

  • 放置弧时，按 ALT 键可以在最短弧与最长弧之间切换（循环显示）。

曲线过渡

基于此工具进行的曲线构造可以包括选定参考元素与曲线之间的过渡。可用的过渡选项有：

  • 无 - 无过渡（仅构造中间简单曲线）

  • 缓和曲线 - 一条缓和曲线（创建曲线构造）

此处列出了可用于创建缓和曲线的值。

  • 双缓和曲线 - 使用此工具可以创建两条缓和曲线；第一条缓和曲线的过渡与参考元素在同一侧，从参考元素半径开始，过渡到无穷远。第二条缓和曲线从无穷远过渡到新曲线的半径，在相对一侧。尽管此弯曲参考元素为最常见的用例，但可以在任何所需的位置使用双缓和曲线。

注释: 最常使用的情况是参考元素本身是曲线，并在相对一侧。

  • 曲线 - 构造双中心曲线（过渡曲线由半径和长度定义）

  • 弧比率 - 构造双中心曲线（过渡长度由中心曲线的比率定义）

操控器

  • 偏移

  • 后缓和曲线

  • 前过渡段

  • 半径

  • 拖动图柄可以动态调整与两段弧的可选偏移距离

父主题: 平面几何弧


平面几何点

该工具用于绘制单个点、沿元素的点或等间距点。

在工具箱中选择 | 描述
点 | 构造土木点元素。
插入点 | 在视图中插入指定数量的点，和/或遵循指定的间隔。
放置点
插入点
父主题: 平面


放置点

用于构造土木点元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 点 拆分按钮

“放置点”可构造土木点元素。如果未使用特征定义，则该点工具将根据特征定义或 MicroStation 点（零长度线）放置单元格或文本。该点可放置在二维和三维模型视图的 (X,Y) 或 (X,Y, 高程) 中。

操控器

使用“功率选择器 (Power Selector)”选择创建的点以查看编辑操控器。对于点元素，有一个移动点拖曳图柄。

如果使用土木精确绘图放置点，则输入也将显示为操控器。

项目浏览器和属性

点规则数据也可在元素属性中访问。

注释: 对于 InRoads 用户，注释样式来自 InRoads 样式管理器和缺省点样式。
父主题: 平面几何点


插入点

用于插入指定数量的点，和/或遵循指定的间隔。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 点 拆分按钮

“插入点”工具可用于插入指定数量的点，和/或遵循指定的间隔。这些点可放置于两个点之间，也可以沿元素和可选偏移量放置。

如果未使用特征点定义，则该工具将根据特征定义或 MicroStation 点（零长度线）在激活 MicroStation 符号中放置单元格或文本。

该点可放置在二维和三维模型视图的 (X,Y) 或 (X,Y, 高程) 中。

放置方法

两种放置方法将确定输入提示。这些方法如下：

  1. 两点间

  2. 沿元素

两点间

间距

沿元素

点沿元素（或可选偏移量）放置，因此需要 MicroStation 或土木平面元素。

危险警告提示 | 选项
间距 | 点数 - 指定等距放置的点数量。 间隔 - 以指定的值放置点。 偶数 - 在偶数桩号处放置点。 最大间隔 -
偏移 | 可以选择按某一偏移量放置点，即：按一定距离（正数表示复制到右侧，负数表示复制到左侧）平行复制该元素，这就是点的位置。

操控器

等距间隔点没有图形操控器。

项目浏览器和属性

点规则数据也可在元素属性中访问。

注释: 对于 InRoads 用户，标注样式来自 InRoads 样式管理器和默认点样式。
工作流: 放置点
父主题: 平面几何点


偏移和渐变

在工具箱中选择 | 描述
整路段等距偏移 | 将选定路段沿整个长度偏移一个常量值
局部路段等距偏移 | 将选定路段沿用户选择的桩号范围偏移一个常量值
局部路段渐变偏移 | 将选定路段沿用户选择的桩号范围偏移一个可变量
比率定义的渐变 | 将选定路段沿用户选择的桩号范围偏移一个比率
整路段等距偏移
父主题: 平面


整路段等距偏移

用于复制距原始元素指定距离的元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 偏移和渐变拆分按钮

使用“整路段等距偏移”工具复制距原始元素指定距离的元素。

  1. 打开“平面几何”部分，然后单击“整路段等距偏移”图标。

    • 将打开“整路段等距偏移”对话框。

    • 选中“偏移”字段旁边的框将锁定关联值。

  2. 将光标移动到“视图”中时，命令提示会请求您“定位元素”，因此点击确认（例如左键单击）要复制的元素。

  3. 可以用以下方法设置偏移：

    • 移动光标时，将显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

父主题: 偏移和渐变


反向曲线

在工具箱中选择 | 描述
按定角度反向曲线连接 | 在先前绘制的元素之间构造反向曲线。
按定半径比率反向曲线连接 | 创建反向曲线，其中第二个曲线半径与第一个曲线半径成一定比例。“偏移”锁定为零。
按带切线的反向曲线连接 | 创建半径相等的反向曲线，您可能还会指定曲线之间的切线长度，偏移锁定至零。
按定角度线连接 | 以从第一个拾取元素测得的偏转角创建简单线性元素，偏移锁定至零。
自由反向曲线连接 | 在先前绘制的元素之间构造反向曲线，两条曲线之间的切线长度可选。
按定角度反向曲线连接
自由反向曲线连接
父主题: 平面


按定角度反向曲线连接

用于在先前绘制的元素之间构造反向曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 反向曲线拆分按钮

工作流

  1. 打开“土木工具”任务窗格的“平面几何”部分，然后单击“按定角度反向曲线连接”图标。
    • 将打开“按定角度反向曲线连接”对话框。
  2. 将光标移动到“纵断面视图”时，它将显示命令提示，指出“定位第一个元素”，因此将光标移动到要过渡的元素，然后选择它。
  3. 通过将光标沿第一个元素移动到过渡将开始的位置来输入起始点，然后点击确认（左键单击）。
  4. 命令提示请求您“定位第二个元素”，因此将光标移动到过渡必须延伸到的元素，然后点击确认。
  5. 通过将光标沿第二个元素移动到过渡将结束的位置来输入终点，然后点击确认。
  6. 要修剪曲线交叉处的元素或将新曲线扩展为与现有元素相交，请按向下箭头键从可用选项中进行选择，然后点击确认。使用“按定角度反向曲线连接”工具可在先前绘制的元素之间构造反向曲线。
父主题: 反向曲线


自由反向曲线连接

用于创建包括有关所选纵面路线的信息的 XML 报告数据文件。此工具还可以循环后曲线或前曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 自由反向曲线连接拆分按钮

工作流

  1. 单击“自由反向曲线连接”。将显示“自由反向曲线连接”对话框。对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。
  2. 选择要构造第一个或后曲线的元素，然后点击确认（左键单击）以接受。
  3. 选择距第一个元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

    • 按 END 键将解锁锁定值。

  4. 选择要构造自由反向曲线连接的第二个元素。要接受的数据点。
  5. 选择距第二个元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。
  6. 选择过渡段信息。此信息位于三个可能的输入中：

    • 线性过渡段长度

    • 线性过渡段角度

    • 长度

  7. 使用向左或向右箭头键在字段之间切换，键入所需的值，然后按 Enter 键以接受。
  8. 使用向左或向右箭头键切换到“后半径”提示。定义后半径。可以使用鼠标以图形方式选择此距离，也可以键入数值。
  9. 选择“前半径”或“半径比”信息。使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    • 半径比是后半径和前半径的直接比较。例如，如果后半径设置为 100 且半径比设置为 1:2，则前半径将产生值 200?。

  10. 点击确认以选择自由反向曲线连接的起始点。
  11. 根据所选的偏移量，选择截断方法。从以下选项中进行选择：

    • 无

    • 上一步

    • 前

    • 两者

    这将截断或修剪用于构造弧的元素。仅当偏移值设置为零时，此选项才可用。

  12. （可选）对于复杂的循环几何，如果锁定一个或两个半径，则可以使用循环选项。

    循环可以设置为以下选项：

    • 无

    • 后（如上所述）

    • 前

    • 两者

对话框自定义

右键单击对话框可针对特定任务或用户首选项来自定义对话框。

操控器

操控器可用于：

  • 后偏移和前偏移

  • 后半径

  • 前半径

  • 长度

  • 过渡段长度

  • 拖动图柄可以动态调整与两段弧的可选偏移距离

属性

“自由反向曲线连接”规则数据也可在属性中访问。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“自由反向曲线连接”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问以下选项：

  • 按定角度反向曲线连接 - 创建两条半径相等的反向曲线，用户指定从第一个选择元素测量的偏转角，“偏移”锁定为零

  • 按定半径比率反向曲线连接 - 创建反向曲线，其中第二曲线半径与第一曲线半径成比例。“偏移”锁定为零

  • 按带切线的反向曲线连接 - 创建反向曲线，其中两个半径相等，您可以指定曲线间的切线长度，“偏移”锁定为零

  • 按定角度线连接 - 以第一次拾取元素时测量的偏转角创建简单线性元素

父主题: 反向曲线


平面几何缓和曲线

各种缓和曲线放置工具。（“延长 (From elements)”、“元素间 (Between Elements)”）

在工具箱中选择 | 描述
缓和曲线延长 | 使用此基准元素确定一端切线，从先前放置的元素构造缓和曲线。
插入缓和曲线 | 在两个确定切线的基本元素之间构造一条（或多条）缓和曲线。
缓和曲线延长
插入缓和曲线
父主题: 平面


缓和曲线延长

用于从先前放置元素的位置构造缓和曲线，使用此基准元素确定一端的相切。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 缓和曲线拆分按钮

“缓和曲线延长”使用此基准元素确定一端切线，从先前放置的元素构造缓和曲线。

该工具仅提供回旋缓和曲线。不支持其他类似缓和曲线的过渡段，例如布劳斯缓和曲线等。

工作流

  1. 单击“缓和曲线延长”。将显示“缓和曲线延长”对话框。对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  2. 选择构造缓和曲线的元素。点击确认（例如左键单击）。基准元素可以是任何元素；线、弧、缓和曲线或复杂。

  3. 选择距元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  4. 指定起点。这是缓和曲线将开始的基准元素的距离。

  5. 键入缓和曲线的半径和长度。这是一个双重提示。在缓和曲线端点处输入半径，然后按向右箭头键输入缓和曲线长度。

选项
父主题: 平面几何缓和曲线


插入缓和曲线

用于在两个确定相切的基准元素之间构造缓和曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 缓和曲线拆分按钮

“插入缓和曲线”在两个确定切线的基准元素之间构造一条（或多条）缓和曲线。取决于基准元素的配置，可能有：

  • 连接的单条缓和曲线：

线和弧

两个弧，其中一个弧完全包含在另一个弧的圆内

  • 两个弧之间的复合缓和曲线

  • 两个弧之间的反缓和曲线

该工具仅提供回旋缓和曲线。不支持其他类似缓和曲线的过渡段，例如布劳斯缓和曲线等。

线与弧之间的单条缓和曲线

复合缓和曲线

反螺旋

对话框

操作

对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

您可以锁定其中一条缓和曲线长度，但不能同时锁定两者。当一条缓和曲线锁定时，第二条缓和曲线的长度将调整以产生复合缓和曲线或反缓和曲线。如果两条缓和曲线均锁定，则效果就像二者均已解锁。也就是说，使两条缓和曲线的长度相等，以适应解。

公共半径仅用于复合缓和曲线。如果指定公共半径，则反缓和曲线将不可用。定义公共半径时，第一条缓和曲线将从弧半径 1 过渡到公共半径，第二条缓和曲线将从公共半径过渡到弧半径 2。

  1. 选择构造缓和曲线的第一个基准元素。使用左键单击以接受。

  2. 选择距第一个元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  3. 选择第二个元素并从第二个元素偏移。请注意，在设置偏移时，会有一些灰色数字，表示备选解。将光标移动到其中一个数字附近将为缓和曲线构造选择不同的解。根据基准元素的配置，最多可能有四种解。

  4. 如果基准元素配置指示双缓和曲线或反缓和曲线，则您将获得过渡段长度的额外提示。如果接受默认值，则两条缓和曲线将等长。请注意，您可以在此提示中再次选择四种解中的一种。

    • 请注意此提示右侧的开关箭头。使用向右箭头键，您可以在此提示下切换对话框中的其他选项以进行输入。此处提供的其他输入包括：

    1. 缓和曲线比率

    2. 公共半径

    3. 后过渡段长度

    4. 前过渡段长度

  5. 选项: 将缓和曲线定义为长度在上。作为备选方案，您可以按半径来定义缓和曲线旋，并通过更改对话框中的方法来定义以下项之一。

    1. 长度（如上所示） 缓和曲线的长度

    2. 缓和曲线的 RL 值由等于半径乘以长度的参数定义

    3. A-Value RL 值可能非常大，因此在某些司法管辖区使用 A 值；A 值等于 RL 的平方根

    4. 偏转有时称为缓和曲线角或 θ 角；这是缓和曲线交点处的偏转

    5. Delta R 也称为抛掷或缓和曲线偏移；这是在引入缓和曲线之后从简单曲线偏移到同一曲线上没有缓和曲线的情况

使用 ALT 键

在命令操作期间，可以使用 ALT 键在备选解决方案之间切换。当屏幕动态显示（最多）四个解时，按键盘上的 ALT 键将在备选方案之间切换。

对话框自定义

右键单击对话框可针对特定任务或用户首选项自定义对话框。

能够自定义对话框

操控器

操控器可用于：

  • 偏移

  • 缓和曲线长度

属性

“插入直-缓-圆-缓-直曲线”规则数据也可在属性中访问。下面显示的属性是可编辑属性。

可编辑属性

每条缓和曲线（如果是双缓和曲线构造）将具有以下只读属性，对土木设计师进行查看十分有用。

只读属性

父主题: 平面几何缓和曲线


平面几何修改

“桩号设置”、“桩号”、处理土木规则以及复制土木元素。

在工具箱中选择 | 描述
起点桩号 | 将桩号设置分配给元素。
添加断链 | 定义元素上指定位置处的桩号。
复制元素 | “复制元素”工具仅创建可见几何图形的新实例。
插入交点及复合曲线 | 通过在先前建立的复合元素中附加其他元素来构造复合元素。
附加元素 | 构造与选定线性对象定义的过程最佳拟合的元素。
起点桩号
添加断链
复制元素
插入交点及复合曲线
附加元素
父主题: 平面


起点桩号

用于向元素分配桩号设置。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 修改拆分按钮

起点桩号向元素分配桩号设置。您可以分配桩号值和沿该桩号值的元素的位置。此工具可用于土木元素或普通 MicroStation 图形。如果从未运行此工具，则假定开始桩号设置为零。如果沿元素的位置不在元素的开头，则分配的桩号将重新投影到元素的起点，因此将对整个元素进行桩号设置。例如，如果选定位置是沿元素的 500 个主单位并且指定的桩号是 25+00，则元素开头的桩号是 20+00。

用于桩号设置的许多首选项（如小数位数、加号位置等）都在“设计文件设置”中进行控制。（链接到“设计文件设置”）。

元素处理程序

使用“功率选择器”选择元素可看到编辑操控器。

单击文本可更改桩号的值。

单击箭头可移动此桩号值的位置。

项目浏览器和属性

已分配桩号设置的任何元素都会在“元素信息”中报告这些元素。可以编辑桩号值作为使用操控器的备选方法。右键单击“桩号设置”，然后选择“删除桩号设置”，即可删除桩号设置。

“指定的位置”是元素到选定点的距离（起点距离）。指定的桩号是分配给“起点距离”点的桩号。起点桩号和终点桩号在元素的开头和结尾进行桩号设置。

为元素设置桩号
父主题: 平面几何修改


添加断链

用于在元素上的指定位置定义桩号公式。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 修改拆分按钮

“添加桩号公式”工具用于在元素上的指定位置定义桩号公式。如果先前未定义任何桩号设置，则还会指定一个以零为起点的桩号。此工具可用于土木元素或普通 MicroStation 图形。可以将多个桩号公式添加到元素中，但应按照从元素开头到结尾的顺序添加。要移除桩号公式，请使用项目浏览器。

首选项

用于桩号设置的许多首选项（如小数位数、加号位置等）都在“设计文件设置”中进行控制。（链接到“设计文件设置”）。

元素处理程序

使用“功率选择器”选择元素可看到编辑操控器。

单击文本可更改桩号的值。

单击箭头可移动此桩号值的位置。

单击箭头可移动后桩号的位置和值。

单击后桩号文本可更改后桩号的位置和值。

单击前桩号文本可更改前桩号的值。

项目浏览器和属性

指定了桩号公式的任何元素都会在其属性中报告这些元素。作为使用操控器的替代方法，可以在属性中编辑桩号值。

添加断链
父主题: 平面几何修改


复制元素

仅用于创建可视几何图形的新实例。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 修改拆分按钮

“复制元素”工具仅创建可见几何图形的新实例。移除所有间隔/规则。要为元素设置规则，请使用“创建土木规则特征”工具。请注意，它还会复制竖直几何元素。

工作流

  1. 选择该工具并按照警告提示操作。

  2. 选择要复制的第一个元素。

  3. 继续选择，然后重置以结束选择过程。

  4. 点击确认接受选定元素，以进行复制。

父主题: 平面几何修改


插入交点及复合曲线

用于在先前创建的元素中插入曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 修改拆分按钮

使用“插入交点及复合曲线”工具在先前创建的元素中插入曲线。

  1. 打开“土木工具”任务窗格的“平面几何”部分，然后单击“插入交点及复合曲线”图标。

  2. 将光标移动到“视图”时，它将显示命令提示，要求您“定位插入曲线的切线”，因此将光标移动到要转换为曲线的元素，然后点击确认，例如左键单击该元素。

  3. 系统提示“定位顶点”，因此将光标移动到曲线的波峰或波谷，然后左键单击。

  4. 系统提示“输入通过点”，因此使用以下方法之一指定曲线必须经过的点（通过按向左或向右箭头键导航选项）：

  • 移动光标时，会在提示框中显示值。左键单击所需的值。

    • 输入“半径”值，然后按 Enter 键并点击确认。

    • 输入后过渡段长度值并按 Enter 键，然后点击确认。

    • 输入前过渡段长度值并按 Enter 键，然后点击确认。

操控器

操控器可用于：

  • 移动

  • 长度

  • 斜率

  • 弧半径

属性

要查看新元素的属性，请使用“选择元素”工具。

左键单击“视图”中的“插入交点及复合曲线”，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 平面几何修改


附加元素

用于在先前建立的复合元素中附加其他元素，形成复合元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 修改拆分按钮

使用“附加元素”工具可以在先前建立的复合元素中附加其他元素，形成复合元素。

  1. 打开“土木工具”任务窗格，找到“平面几何图形”部分，然后单击“插入/添加竖曲线单元至纵断面”图标。
  2. 将光标移至视图中后，系统会给出命令提示，要求您“定位复合元素”，请将光标移至现有复合元素和数据点，然后点击确认，例如在其上单击鼠标左键。
  3. 系统提示“定位要添加/插入的元素”时，将光标移至要加入到复合元素的其中一个元素，然后单击该元素。

操控器

操控器可用于：

  • 移动

  • 长度

  • 斜率

属性

要查看新元素的属性，请使用“选择元素”工具。

在视图中的复合元素上单击鼠标左键，然后让光标悬停在选定元素上。单击“属性”图标可访问选定元素的规则数据。

父主题: 平面几何修改


平面几何复合

创建并重定义“复合”路线、“最佳拟合”、“偏移”工具（平行复制）反向曲线，以及“按模板创建三维几何模型”。

在工具箱中选择 | 描述
按元素复合 | 通过将先前放置的元素按顺序连接来构造其复合元素。
交点法创建路线 | 基于用户的 PI（交点）位置输入，使用曲线创建线性元素。对于 PI 处没有曲线的情况，曲线可以包括过渡段或将半径设置为零。
按最佳拟合定义 | 构造与选定线性对象定义的过程最佳拟合的元素。
按元素复合
交点法创建路线
按最佳拟合定义
按模板创建三维几何模型
父主题: 平面


按元素复合

用于从先前放置的元素构造复杂元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 复杂几何图形拆分按钮

“按元素复合”通过按顺序连接之前所放置元素来构造这些元素的复杂元素。

工作流

  1. 单击“按元素复合”。随即显示“复杂元素”对话框。

    有两种操作方法：“手动”和“自动”。

  2. 使用“自动”方法时，将鼠标悬停在起始元素上方，直到方向箭头指向所需的方向。单击鼠标左键以接受所选元素。

  3. 此时，复杂路径将高亮显示。再次单击鼠标左键以接受复杂创建，或者右键单击以取消。

  4. 或者，使用“手动”方法时，单击鼠标左键以单独选择每个元素。

选择所有项之后，点击确认，例如在元素的绘图区域中单击鼠标左键，以接受复杂元素创建。

操控器

将元素迁移到复杂元素时，各个元素操控器保持不变。

属性

也可在组成复杂元素的单个元素属性中访问规则数据。选择单个元素以编辑属性。可对属性窗格中的大部分数据进行编辑以更改任何元素的定义。

父主题: 平面几何复合


交点法创建路线

用于根据用户输入的 PI（交点）位置创建具有曲线的线性元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 复杂几何图形拆分按钮

“交点法创建路线”根据用户输入的 PI（交点）位置创建具有曲线的线性元素。对于 PI 处没有曲线的情况，曲线可以包括过渡段或将半径设置为零。

曲线上的过渡可以是弧过渡或回旋缓和曲线（使用以下方法）。有关各种缓和曲线参数的描述，请参阅缓和曲线延长。

  • 缓和曲线 - 长度

  • 缓和曲线 - A 值

  • 缓和曲线 - 偏转

  • 缓和曲线 - 增量 R

  • 缓和曲线 - RL

  • 曲线 - 长度

  • 曲线 - 偏转

  • 曲线 - 增量 R

  • 曲线 - 比率

工作流

  1. 单击“交点法创建路线”。随即显示“复合元素(按 PI)”对话框。

  2. 点击确认以设置元素的起点。

  3. 点击确认以设置第二个 PI。

  4. 点击确认以设置第三个 PI。半径始终应用于当前正设置数据点的前一个 PI。可通过在提示中键入新值来编辑半径。此为三重切换输入。使用向左向右箭头键进行切换以设置后过渡段和前过渡段参数。

  5. 继续点击确认以添加更多 PI 点。单击“重置”按钮以停止添加 PI 点。

操控器

操控器可用于：

  • 每个线段上的距离和方向

  • 每条曲线上的半径和过渡参数

  • PI 点处的拖曳图柄

属性

线段和曲线段的排序列表显示在“元素信息”的顶部树形结构中。选择每条直线或曲线将显示有关此复合部分的属性。

父主题: 平面几何复合


按最佳拟合定义

用于构造最适合由所选线性对象定义的课程的元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 复杂几何图形拆分按钮

使用“按最佳拟合定义平面”构造最适合由所选线性对象定义的课程的元素。

  1. 打开“土木工具”任务窗格的“平面几何”部分，然后单击“按最佳拟合定义平面”图标。

    将打开“创建最佳拟合平面”对话框。

    选择“创建复合元素”、“创建单一元素”或“按边缘复合”。

    选中任一字段旁边的框将会锁定关联的值。

创建复合元素

  1. 使用向下箭头键导航“最佳拟合”选项，然后点击确认（左键单击）以执行您的选择。

  2. 在将用于创建新元素的线性对象上点击确认。

  3. “包络”将定义最佳拟合工具的工作空间，因此输入一个值，然后点击确认。

  4. 为“半径取整”输入一个值，然后左键单击。

  5. 如果要“包括缓和曲线”，请选中“创建最佳拟合平面”对话框上的框。包括缓和曲线将打开以下选项。

    • 强制对称缓和曲线

    • 缓和曲线长度取整

  6. 输入“默认半径”，然后点击确认。

创建单一元素

  1. 使用向下箭头键导航“最佳拟合”选项，然后点击确认（左键单击）以执行您的选择。

  2. 在将用于创建新元素的线性对象上点击确认。接受。

  3. 在第二个线性对象上点击确认以创建新元素。

按边缘复合

  1. 使用向下箭头键导航“最佳拟合”选项，然后点击确认（左键单击）以执行您的选择。

  2. 在将用于创建新元素的线性边缘对象上点击确认。接受。

  3. 在次要边缘对象上点击确认。接受。

  4. “包络”将定义最佳拟合工具的工作空间，因此输入一个值，然后点击确认。

  5. 为“半径取整”输入一个值，然后左键单击。

  6. 如果要“包括缓和曲线”，请选中“创建最佳拟合平面”对话框上的框。包括缓和曲线将打开以下选项。

    • 强制对称缓和曲线

    • 缓和曲线长度取整

  7. 输入“默认半径”，然后点击确认。

父主题: 平面几何复合


按模板创建三维几何模型

用于访问“拾取模板”对话框，然后在相对于参考元素的绘图中插入所选模板。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 复杂几何图形拆分按钮
使用“按模板创建几何图形”工具访问“拾取模板”对话框，然后在相对于参考元素的绘图中插入所选模板。在模板中特征定义设置为创建几何的任意点，都将以模板定义的偏移生成偏移元素构造。

  1. 打开“土木工具”任务窗格的“平面几何”部分，然后单击“在元素间按模板创建几何图形 (Create Geometry by Template between Elements)”图标。

  2. 将光标移动到“视图”时，将显示一个命令提示符，要求您“定位参考元素”，因此将光标移动到要应用模板的元素，然后左键单击数据点。

    • 将打开“创建三维路面几何图形 (Create Template Drop Geometry)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  3. 系统提示“选择模板”时，必须按住 Alt 键并单击向下箭头键，打开“拾取模板”对话框。

  4. 对话框打开后，导航树以选择可用模板，然后单击“确定”，并在视图中点击确认。

注释: “选择模板”命令提示会保留您上次的选择，如果要应用相同模板的多个实例，只需在显示填充的提示时点击确认即可。
父主题: 平面几何复合


纵断面

以下主题位于“纵面几何”中：

纵断面
纵面几何线
纵面几何曲线
纵面几何复合
纵面几何定义元素纵断面
父主题: 几何图形


纵断面

打开纵断面模型
设置激活纵断面
剖切地面线
纵断面投影至其它剖面
局部纵断面投影至其它剖面
纵断面单元投影至其它剖面
放置 - 平面交叉点投影至其它剖面 (Place Profile Intersection Point)
父主题: 纵断面


打开纵断面模型

用于生成在纵断面中呈现所需特征的视图，从而使纵面几何工具能够与所选特征进行交互。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 打开纵断面模型

使用“打开纵断面模型”工具生成在纵断面中呈现所需特征的视图，从而使纵面几何工具能够与所选特征进行交互。

  1. 选择“打开纵断面模型”图标。

  2. 将光标移动到工作空间，并注意附有一个命令提示，要求您“定位平面图元素”。

  3. 选择要在纵断面中使用的元素。

  4. 光标现在带有提示，显示“选择或打开视图”。

    • 如果打开了另一个视图，则点击确认（例如，左键单击该视图以在纵断面中呈现选定元素。

    • 如果未打开其他视图，则单击“视图组”工具栏上的 2 号图标，然后再次单击新视图。

  5. 使用纵面几何工具编辑绘图。

父主题: 纵断面


设置激活纵断面

用于...

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 设置激活纵断面
  • 功能区：几何图形 > 通用工具 > 设计元素

使用“设置激活纵断面”工具指定哪些纵断面元素可能会驱动三维模型。结果是在三维模型中创建三维样条，表示平面路线与设计纵断面的组合。

  1. 单击“设置激活纵断面”图标。

  2. 在纵断面视图中，选择要指定为设计纵断面的纵断面元素。

父主题: 纵断面


剖切地面线

生成其高程通过覆盖在曲面上来确定的纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 纵断面创建拆分按钮

使用“剖切地面线”工具生成其高程通过覆盖在曲面上来确定的纵断面。曲面可以是地形模型、网格或网格实体。

“快速剖切地面线”是一个配套工具，它提供相同的结果，但通过假设整个元素被覆盖且偏移量为零来简化输入。

  1. 选择“按曲面绘制纵断面 (Profiles by Surface)”图标。

    • 将打开“剖切地面线”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”时，它将显示命令提示，要求您“定位纵断面的第一个元素”，并将光标移动到穿过地形模型的水平线。

  3. 选择要剖切的所有元素后，右键单击空白区域。

  4. 当系统提示“定位参考表面”时，点击确认地形模型。

  5. 可以用以下方法设置起点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值，然后按 Enter 键。

  6. 可以用以下方法设置终点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值，然后按 Enter 键。

  7. 当系统提示选择“点选择”时，按向下箭头键以导航选项，然后按 Enter 键执行您的选择。

    • 整个元素均用于确定高程

    • 顶点 - 仅计算元素顶点处的高程

    • 终点 - 仅计算元素终点处的高程

    • 质心 - 仅计算质心处的高程

  8. 当系统提示选择“点调整”时，按向下箭头键以导航选项，然后按 Enter 键执行您的选择。

    • 无 - 不执行调整

    • 最小值 - 在上一步中使用的点的最小值，选择最小高程并将此值用于整个纵断面

    • 最大值 - 在上一步中使用的点的最大值，选择最大高程并将此值用于整个纵断面

  9. 当系统提示选择“覆盖选项”时，按向下箭头键以导航选项，然后按 Enter 键执行您的选择。这仅适用于等于“全选”的点选择。可用选项包括：

    • 三角形 - 确定元素穿过三角形边的每个点的高程

    • 切断线 - 仅当元素穿过切断线时，点选择才会确定高程

  10. 使用以下方法之一建立“水平偏移”：

    • 键入所需的值，按 Enter 键以锁定，然后点击确认。

    • 值解锁后，移动光标时，提示中将显示一个值。点击确认所需的值。

    注释: 按“结束”键以解锁值。

  11. 使用以下方法之一建立“竖向偏移”：

    • 键入所需的值，按 Enter 键以锁定，然后点击确认。

    • 值解锁后，移动光标时，提示中将显示一个值。点击确认所需的值。

    注释: 按“结束”键以解锁值。

  12. 要查看元素的纵断面，请单击“打开纵断面模型”图标。

  13. 将光标移动到工作空间中，并注意附有提示，要求您“定位平面图元素”。点击确认新的纵断面元素。

  14. 光标现在带有提示，显示“选择或打开视图”。

    • 如果打开了另一个视图，则点击确认，以在纵断面中呈现选定元素。

    • 如果未打开其他视图，则单击“视图组”工具栏上的 2 号图标，然后再次单击新视图。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“纵断面视图”中选择提升的元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵断面


纵断面投影至其它剖面

用于...

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 纵断面创建拆分按钮

使用“纵断面投影至其它剖面”工具可在一个元素的“纵断面视图”中显示另一个元素纵断面。

注释: 工作空间必须包含平面视图和打开纵断面模型才能使用此工具。
  1. 当纵断面在“纵断面视图”中可见时，选择“纵断面投影至其它元素”图标。
  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“选择元素投影”，因此请将光标移动到现有的纵断面。
  3. 当系统提示“选择平面元素到投影”时，请将光标移动到“平面视图”，并点击确认将用作投影目标的平面几何元素。
    注释: 现在，源纵断面显示在目标元素的纵断面空间中。
  4. 要查看元素的纵断面，请单击“打开纵断面模型”图标。
  5. 将光标移动到“平面视图”，并注意附有提示，要求您“定位平面图元素”。点击确认新创建纵断面的元素。
  6. 该光标现在附有提示，指示“选择或打开视图”，因此将光标移动到“纵断面视图”中并点击确认。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“纵断面视图”中选择提升的元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵断面


局部纵断面投影至其它剖面

用于在一个元素的纵断面空间中显示另一个元素纵断面的一部分。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 纵断面创建拆分按钮

“局部纵断面投影至其它剖面”与“纵断面投影”工具具有相同的功能，但它可以使用桩号范围，而不是整个元素。使用“局部纵断面投影至其它剖面”工具可在一个元素的纵断面空间中显示另一个元素纵断面的一部分。

注释: 工作空间必须包含平面视图和打开纵断面模型才能使用此工具。

  1. 当纵断面在“纵断面视图”中可见时，选择“局部纵断面投影至其它剖面”图标。

    • 将打开“放置纵断面投影”对话框。
    • 选中任一字段旁边的框将会锁定关联的值。
  2. 将光标移动到“纵断面视图”时，它将显示“选择剖面投影”命令提示，因此请将光标移动到现有的纵断面。
  3. 当系统提示“选择平面剖面到投影”时，请将光标移动到“平面视图”中并选择要向其提供高程的元素。
  4. 可以用以下方法设置起点距离：
    • 移动光标时，会在提示框中显示值。在所需值处点击确认（即左键单击）。
    • 输入值并按 Enter 键，然后点击确认该值。
  5. 可以用以下方法设置终点距离：
    • 移动光标时，会在提示框中显示值。在所需值处点击确认。
    • 输入值并按 Enter 键，然后点击确认该值。
    注释: 现在，源纵断面显示在目标元素的纵断面视图中。
  6. 要查看元素的纵断面，请单击“打开纵断面模型”图标。
  7. 将光标移动到“平面视图”，并注意附有提示，要求您“定位平面图元素”。点击确认新创建纵断面的元素。
  8. 该光标现在附有提示，指示“选择或打开视图”，因此将光标移动到“纵断面视图”中并点击确认。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“纵断面视图”中的高层元素中点击 X，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵断面


纵断面单元投影至其它剖面

用于在元素的纵断面视图中显示相邻元素的纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 纵断面创建拆分按钮

使用“纵断面单元投影至其它剖面”工具，可在元素的纵断面视图中显示相邻元素的纵断面。例如，在半径纵断面设计中，交叉口转弯半径附近的路面边缘非常重要。

注释: 工作空间必须包含平面视图和打开纵断面模型才能使用此工具。

  1. 选择“纵断面单元投影至其它剖面”图标。

  2. 将光标移动到“平面视图”时，它将显示命令提示，要求您“选择要投影到的元素”，因此将光标移动到连接两条腿的元素，然后点击确认（例如左键单击）。

    • 将打开“纵断面单元投影至其它剖面”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。当值被锁定后，如果出现字段提示，则该字段旁边会出现一个挂锁图标，且在该点输入值没有任何效果。
  3. 使用以下方法之一“定位后延伸距离”：
    • 移动光标时，会在提示框中显示值。在所需值处点击确认。
    • 输入值并按 Enter 键，然后点击确认。
  4. 使用以下其中一种方法定位前延伸距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

    • 在“纵断面视图”中，添加内容与过渡元素一起出现。

对话框自定义

右键单击“纵断面单元投影至其它剖面”对话框，针对特定任务或个人首选项自定义该对话框。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“纵断面视图”中选择所需的元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵断面


放置 - 平面交叉点投影至其它剖面 (Place Profile Intersection Point)

用于在纵断面视图中指示两个元素的交叉位置。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 纵断面创建拆分按钮

使用“放置 - 平面交叉点投影至其它剖面 (Place Profile Intersection Point)”命令在纵断面视图中指示两个元素的交叉位置。点放置在相交元素的桩号和高程处。相交元素必须具有指定的激活纵断面。

  1. 选择“打开纵断面模型”图标。

  2. 将光标移动到“平面视图”时，它将显示命令提示，显示“定位平面图元素”，因此选择要在纵断面中使用的元素。

  3. 光标现在带有提示，显示“选择或打开视图”。

    • 如果打开了另一个视图，则点击确认（例如，左键单击该视图以在纵断面中呈现选定元素。

    • 如果未打开其他视图，则单击“视图组”工具栏上的 2 号图标，然后再次单击新视图。

  4. 打开“土木工具”任务窗格的“纵面几何”部分，然后单击“放置 - 平面交叉点投影至其它剖面 (Place Profile Intersection Point)”图标。

  5. 将光标移动到“平面视图”时，它带有提示，显示“定位要显示交点的元素”，因此将光标移动到相交元素，然后点击确认。

  6. 光标现在带有提示，显示“定位相交的元素”，因此选择其他相交元素。

    • 在“纵断面视图”中，点元素指示交点高程。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“纵断面视图”中选择所需的元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵断面


纵面几何线

各种纵断面线放置工具。（两点间、至元素、从元素、元素之间）

在工具箱中选择 | 描述
直线坡 | 在用户定义的两个点之间构造纵断面线。
任意坡连接 | 按相对坡度从指定位置到参考元素构造纵断面线。
任意坡延长 | 按相对坡度从参考元素到指定位置构造纵断面线。
插入切线坡 | 在先前放置的两个纵断面曲线之间构造纵断面线。
直线坡
任意坡连接
任意坡延长
插入切线坡
父主题: 纵断面


直线坡

用于在两个指定点之间构造一条纵断面线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 直线拆分按钮

使用“两点间平面图纵断面 (Plan Profile between Points)”命令可在两个指定点之间构造纵断面线。

  1. 选择“两点间平面图纵断面 (Plan Profile between Points)”图标。
    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。
    • 将打开“放置两点间平面图纵断面 (Place Plan Profile between Points)”对话框。
    • 选中任一字段旁边的框将会锁定关联的值。
  2. 将光标移动到“纵断面视图”中时，它附有提示。通过数据指向（即左键单击）所需位置，输入“视图”中的“起始点”。
  3. 当系统提示“输入终点”时，将光标移动到要绘制直线的点，然后点击确认。
  4. 使用以下方法之一建立坡度或长度（使用向左和向右箭头键在二者之间切换）：
  • 在不移动光标的情况下，键入所需的值，然后点击确认。
  • 移动光标时，会在提示框中显示值。在所需值处点击确认。
  • 如果字段在“放置两点间平面图纵断面 (Place Plan Profile between Points)”对话框中锁定，则无法设置新值。

对话框自定义

右键单击“放置两点间平面图纵断面 (Place Plan Profile between Points)”对话框，以针对特定任务或个人首选项进行自定义。

操控器

  • 相对坡度
  • 长度
  • 拖动夹点以动态调整起点和终点距离
  • 终点的桩号和高程
父主题: 纵面几何线


任意坡连接

以相对坡度构造从指定位置到参考元素的纵断面线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 垂直 > 直线拆分按钮

使用“任意坡连接”工具以相对坡度构造从指定位置到参考元素的纵断面线。

  1. 选择“任意坡连接”图标。
    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

    • 将打开“放置任意坡连接 (Place Profile Line to Element)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 当系统提示“定位参考纵断面”时，将光标移动到要将线绘制到的元素，然后点击确认。

  3. 使用以下方法之一建立竖向偏移：

    • 键入所需的距离，按 Enter 键以锁定，然后点击确认。

    • 移动光标时，提示中将显示距离。在所需距离处点击确认。

  4. 建立相对坡度或者长度；使用向左和向右箭头键在二者之间切换。

    • 键入所需的距离，按 Enter 键以锁定，然后点击确认。

    • 移动光标时，提示中将显示距离。在所需距离处点击确认。

  5. 要使用纵断面线修剪交叉点处的元素，或者将元素延伸到纵断面线相交，请点击向上或向下箭头键以选择“修剪/延长”选项。

使用 ALT 键

在命令操作期间，可以使用 ALT 键在备选解决方案之间切换。当相对坡度被锁定时，按 ALT 键在两个备选项之间切换。

对话框自定义

右键单击“放置任意坡连接 (Place Profile Line to Element)”对话框，以针对特定任务或个人首选项进行自定义。

操控器

操控器可用于：

  • 终点的桩号

  • 终点的高程

  • 拖动夹点以动态调整终点位置

  • 只要值不为零，操控器就可用于偏移。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意坡连接”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 切线坡连接 - 在零度斜交角创建到另一元素的纵面断线，仅当“连接 (To element)”为纵断面曲线且偏移锁定在零时，此选项才适用

父主题: 纵面几何线


任意坡延长

以相对坡度构造从参考元素到指定位置的纵断面线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 垂直 > 直线拆分按钮

使用“任意坡延长”命令以相对坡度构造从参考元素到指定位置的纵断面线。

  1. 选择“任意坡延长”图标。

    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。

    • 将打开“任意坡延长”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。
  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位参考纵断面”，因此将光标移动到要从中绘制直线的元素，然后点击确认（例如左键单击）。
  3. 使用以下方法之一建立竖向偏移：

    • 键入所需距离，然后点击确认。

    • 移动光标时，提示中将显示距离。在所需距离处点击确认。

  4. 沿着纵断面线穿过的位置处的偏移线标记起点。
  5. 要建立相对坡度或者长度，使用向左或向右箭头键在二者之间切换，然后执行以下步骤之一：

    • 键入所需值，然后点击确认。

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

  6. 要使用纵断面线修剪交叉点处的元素，或者将元素延伸到纵断面线相交，请点击向上或向下箭头键以选择“修剪/延长”选项。

对话框自定义

右键单击“任意坡延长”对话框，以针对特定任务或个人首选项进行自定义。

操控器

操控器可用于：

  • 相对基准元素的偏移（此处未显示）

  • 相对坡度

  • 长度

  • 拖动夹点以动态调整起点和终点距离

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意坡延长”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 切线坡延长 - 在零度倾斜角度从另一个元素创建具有弧过渡段的直线，仅当“延长 (From element)”为曲线且偏移锁定在零时，此选项才适用。

父主题: 纵面几何线


插入切线坡

用于在两个先前放置的纵断面曲线之间构造插入切线坡。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 直线拆分按钮

使用“插入切线坡”命令可以在两个先前放置的纵断面曲线之间构造插入切线坡。

  1. 选择“插入切线坡”图标。

    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。
    • 将打开“插入切线坡”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位后参考纵断面”，因此将光标移动到要从中绘制直线的元素，然后点击确认（例如左键单击）。

  3. 使用以下方法之一从第一元素建立竖向偏移：
    • 键入所需距离，然后点击确认。
    • 移动光标时，提示中将显示距离。在所需距离处点击确认。

  4. 当系统提示“定位后参考纵断面”时，将光标移动到要将线绘制到的元素，然后点击确认。

  5. 使用以下方法之一从第二个元素建立竖向偏移：

    • 键入所需距离，然后点击确认。
    • 移动光标时，提示中将显示距离。在所需距离处点击确认。

  6. 使用数据点建立解决方案。如果有多种解决方案，请通过按左或右箭头键来导航选项。

  7. 要在纵断面线的交点处修剪一个或两个元素，或者将一个或两个元素延伸到与纵断面线相交，则“偏移”值必须为零。按向上或向下箭头键选择前曲线和/或后曲线。

使用 ALT 键

在命令操作期间，可以使用 ALT 键在备选解决方案之间切换。当屏幕动态显示（最多）四个解决方案时，按 ALT 键可在备选解决方案之间切换。

对话框自定义

右键单击“插入切线坡”对话框，以针对特定任务或个人首选项进行自定义。

操控器

  • 相对源绘制曲线的偏移

  • 相对目标绘制曲线的偏移

  • 拖动夹点可动态调整两条曲线的可选偏移距离

注释: 仅当使用的偏移大于或小于零时，操控器才可用。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵面几何线


纵面几何曲线

各种纵面曲线放置工具。（两点间、至元素、从元素、元素之间）

在工具箱中选择 | 描述
按点创建竖曲线 | 在指定点之间构造纵面曲线。
任意竖曲线连接 | 从指定点到元素构造纵面曲线。
任意竖曲线延长 | 在现有元素和要指定的点之间构造纵面曲线。
插入任意竖曲线 | 在两个指定点之间构造纵面曲线。
按点创建竖曲线
任意竖曲线连接
任意竖曲线延长
插入任意竖曲线
父主题: 纵断面


按点创建竖曲线

在指定点之间构造竖曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 曲线拆分按钮

使用“按点创建竖曲线”工具在指定点之间构造竖曲线。

  1. 选择“按点创建竖曲线”图标。

    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

    • 将打开“按点放置纵断面曲线 (Place Profile Curve between Points)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”中时，它将显示命令提示，允许您选择“绘制方法”。通过按向上和向下箭头键来导航选项。

起点\终点\VPI

  1. 要创建由起点、终点和竖交点定义的对称竖曲线，请通过在“绘制方法”提示上按向下箭头键选择“起点\终点\VPI”。按 Enter 键以启动“起点\终点\VPI”方法。

  2. 当系统提示“输入起始点”时，将光标移动到您希望曲线起始的点，然后点击确认。

  3. 当系统提示“输入终点”时，使用以下方法之一来建立曲线的终点：

    • 将光标移动到所需位置并点击确认。

    • 按向左和向右箭头键，在提示中选择“长度”选项，键入值，然后按 Enter 键。

  4. 使用以下方法之一设置 VPI（通过按向左或向右箭头键来导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入起点坡度值并按 Enter 键，然后点击确认。

    • 输入终点坡度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

起点\终点\通过点

  1. 要创建由起点、终点和曲线必须通过的点定义的对称竖曲线，请通过在“绘制方法”提示上按向下箭头键选择“起点\终点\通过点”。按 Enter 键以启动“起点\终点\通过点”方法。

  2. 当系统提示“输入起始点”时，将光标移动到您希望曲线起始的点，然后点击确认。

  3. 当系统提示“输入终点”时，使用以下方法之一来建立曲线的终点：

    • 将光标移动到所需位置并点击确认。

    • 按向左和向右箭头键，在提示中选择“长度”选项，键入值并按 Enter 键，然后点击确认。

  4. 使用以下方法之一指定曲线必须经过的点（通过按向左或向右箭头键导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入起点坡度值并按 Enter 键，然后点击确认。

    • 输入终点坡度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

高点\低点\终点 (High\Low\End)

  1. 要创建由高点、低点和终点定义的对称竖曲线，请通过在“绘制方法”提示上按向下箭头键选择“高点\低点\终点 (High\Low\End)”。按 Enter 键以启动“高点\低点\终点 (High\Low\End)”方法。

  2. 当系统提示“输入高低点”时，将光标移动到曲线的最高或最低点，然后输入点 X。

  3. 使用以下方法之一设置曲线终点（通过按向左或向右箭头键来导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入起点坡度值并按 Enter 键，然后点击确认。

    • 输入终点坡度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

竖曲线类型

可以在对话框中或通过按键盘上的 Shift 键更改曲线类型选项：支持的曲线类型为：

  • 抛物线 - 对称抛物线

  • 非对称 - 非对称抛物线

  • 圆形 - 由半径定义的简单曲线

操控器

操控器可用于：

  • 起点

  • 终点

  • 高点

  • 通过点

  • VPI 点

  • 长度

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵面几何曲线


任意竖曲线连接

从指定点到元素构造一条竖曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 曲线拆分按钮

使用“任意竖曲线连接”工具从指定点到元素构造一条竖曲线。

  1. 选择“抛物线连接”图标。

    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

    • 将打开“任意竖曲线连接”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您选择“终点”，因此将光标移动到曲线所需的起点，然后点击确认（例如左键单击）。

  3. 当系统提示“定位参考纵断面”时，将光标移动到要将曲线绘制到的元素，然后点击确认。

  4. 使用以下方法之一设置“竖向偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  5. 当系统提示“输入通过点”时，使用以下方法之一指定曲线必须经过的点（通过按向左或向右箭头键导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入起点坡度值并按 Enter 键，然后点击确认。

    • 输入终点坡度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

  6. 要在曲线的交点处修剪元素或将新曲线延伸到与旧曲线相交，“偏移”值必须为零。按向下箭头键以选择“后”选项，然后按 Enter 键。

竖曲线类型

可以在对话框中或通过按键盘上的 Shift 键更改曲线类型选项：支持的曲线类型为：

  • 抛物线 - 对称抛物线

  • 圆形 - 由半径定义的简单曲线

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意竖曲线连接”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 抛物线连接 - 创建到元素的一条抛物线，偏移锁定在零

  • 圆曲线连接 - 创建到元素的一个简单纵断面半径，偏移锁定在零

注释: 自定义版本预先配置为选择抛物线或曲线类型，而不需要使用 ALT 键来循环类型。
父主题: 纵面几何曲线


任意竖曲线延长

用于在现有元素和要指定的点之间构造一条竖曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 曲线拆分按钮

使用“任意竖曲线延长”工具在现有元素和要指定的点之间构造一条竖曲线。

  1. 选择“任意竖曲线延长”图标。

    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

    • 将打开“放置 - 任意竖曲线延长 (Place Profile Curve from Element)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位参考纵断面”，因此将光标移动到要从中绘制曲线的元素，然后点击确认（例如左键单击）。

  3. 使用以下方法之一设置“竖向偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  4. 当系统提示选择“起点”时，将光标移动到曲线所需的起点，然后点击确认。

  5. 使用以下方法之一提供“竖曲线参数”（通过按向左或向右箭头键导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入长度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

  6. 当系统提示选择“终点”时，将光标移动到曲线所需的终点，然后点击确认。

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入长度值并按 Enter 键，然后点击确认。

    • 输入终点坡度值并按 Enter 键，然后点击确认。

  7. 要在曲线的交点处修剪元素或将新曲线延伸到与旧曲线相交，“偏移”值必须为零。按向下箭头键以选择“后”选项，然后按 Enter 键。

竖曲线类型

可以在对话框中或通过按键盘上的 Shift 键更改曲线类型选项：支持的曲线类型为：

  • 抛物线 - 对称抛物线
  • 圆形 - 由半径定义的简单曲线

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意竖曲线延长”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 抛物线延长 - 从元素创建一条抛物线，偏移锁定在零

  • 圆曲线延长 - 从元素创建一个简单纵断面半径，偏移锁定在零

注释: 自定义版本预先配置为选择抛物线或曲线类型，而不需要使用 ALT 键来循环类型。
父主题: 纵面几何曲线


插入任意竖曲线

用于在两个指定元素之间构造一条竖曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 曲线拆分按钮

使用“插入任意竖曲线”工具在两个指定元素之间构造一条竖曲线。

  1. 选择“插入任意竖曲线”图标。

    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。

    • 将打开“放置 - 插入任意竖曲线 (Place Profile Curve between Elements)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位第一个纵断面元素”，因此将光标移动到要从中绘制曲线的元素，然后点击确认（左键单击）。

  3. 使用以下方法之一设置“后竖向偏移”：

  4. 当系统提示“定位第二个纵断面元素”时，将光标移动到曲线必须延伸到的元素，然后点击确认。

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  5. 当系统提示“定位第二个纵断面元素”时，将光标移动到曲线必须延伸到的元素，然后点击确认。

  6. 使用以下方法之一设置“前竖向偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  7. 使用以下方法之一指定曲线必须经过的点（通过按向左或向右箭头键导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入长度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

  8. 要在曲线的交点处修剪元素或将新曲线延伸到与旧曲线相交，“偏移”值必须为零。按向下箭头键以选择“后”选项，然后按 Enter 键。

竖曲线类型

可以在对话框中或通过按键盘上的 Shift 键更改曲线类型选项：支持的曲线类型为：

  • 抛物线 - 对称抛物线
  • 非对称 - 非对称抛物线
  • 圆形 - 由半径定义的简单曲线

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“插入任意竖曲线”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 插入抛物线 - 在两个元素之间创建一条抛物线，偏移锁定在零

  • 非对称抛物线 - 在两个元素之间创建一条非对称抛物线，偏移锁定在零

  • 插入圆形竖曲线 - 在两个元素之间创建一个简单纵断面半径，偏移锁定在零

注释: 自定义版本预先配置为选择抛物线或曲线类型，而不需要使用 ALT 键来循环类型。
父主题: 纵面几何曲线


纵面几何复合

创建并重新定义复杂的纵面路线、最佳拟合、偏移工具（平行复制）自由反向曲线连接。

在工具箱中选择 | 描述
按竖曲线单元创建纵断面 | 从先前放置的元素构造复杂纵断面元素。
按竖交点创建纵断面 | 构造由垂直交点 (VPI) 定义的纵断面复合体。
按最佳拟合定义纵断面 | 通过选定的纵断面构造由最佳拟合定义的纵断面复合体。
插入变坡点及竖曲线 | 将纵面曲线插入纵断面元素中。
添加竖曲线单元至纵断面 | 将其他元素附加到先前建立的复杂元素。
插入反向曲线坡 | 在先前绘制的元素之间构造反向曲线，两条曲线之间的切线长度可选。
纵断面偏移 | 按照与基本元素的偏移构造纵断面元素。基本元素可以是线、弧、缓和曲线或复合体。
按竖曲线单元创建纵断面
按竖交点创建纵断面
按最佳拟合定义纵断面
插入变坡点及竖曲线
添加竖曲线单元至纵断面
插入反向曲线坡
纵断面偏移
父主题: 纵断面


按竖曲线单元创建纵断面

用于从先前放置的元素构造复合纵断面元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

使用“按竖曲线单元创建纵断面”命令以从先前放置的元素构造复合纵断面元素。

  • 选择“按竖曲线单元创建纵断面”图标。

注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

  • 选中任一字段旁边的框将会锁定关联的值。

手动

  1. 在“按竖曲线单元创建纵断面”对话框上，展开“方法”下拉菜单，然后选择“手动”选项。
  2. 将光标移动到“纵断面视图”中时，它将显示命令提示，要求您“定位第一个元素”，因此将光标移动到其中一个要包括在复合元素的元素，然后单击它。
  3. 当系统提示“定位第一个元素”时，将光标移动到要包括在复合元素的另一个元素，然后点击确认（即左键单击）。
  4. 当系统提示“定位第一个元素”时，将光标移动到要包括在复合元素的另一个元素，然后点击确认。

  5. 当显示一行以链接元素时，点击确认以创建新的复合元素。

注释: 确认之后，元素之间显示的线将消失。它只是标识组件元素的视觉辅助工具。
父主题: 纵面几何复合


按竖交点创建纵断面

用于...

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

使用“按竖交点创建纵断面”工具构造由竖交点 (VPI) 定义的纵断面复合。

  1. 选择“按竖交点创建纵断面”图标。

    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。
    • 将打开“按竖交点放置纵断面复合 (Place Profile Complex by VPI)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”中时，它将显示命令提示，要求您“输入第一个 PI”。通过在所需位置点击确认（左键单击）来将光标放置在初始交点上方。
  3. 当系统提示“输入下一个 VPI”时，以便使用以下其中一种方法来指定曲线必须穿过的点（通过按向左或向右箭头键来导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入“曲线长度”的值，然后按 Enter 键。

    • 输入“曲线参数 (Curve Parameter)”的值，然后按 Enter 键以锁定该值。

    • 输入“斜率”的值，然后按 Enter 键以锁定该值。始终可以独立于长度或曲线参数锁定斜率。

    注释: VPI 可以动态定位或借助“土木精确绘图”定位。危险警告提示也可用于将所需的斜率值从先前的 VPI 锁定到当前的 VPI。

  4. 在第 3 个和随后的 VPI 上，“长度”和/或“曲线参数 (Curve Parameter)”可用于控制放置在先前 VPI 处的曲线。例如，在第 3 个 VPI 提示下输入的长度用于定义 VPI 2 处的曲线。

竖曲线类型

可以在对话框中或通过按键盘上的 Shift 键更改曲线类型选项：支持的曲线类型为：

  • 抛物线 - 对称抛物线

  • 非对称 - 非对称抛物线

  • 圆形 - 由半径定义的简单曲线

父主题: 纵面几何复合


按最佳拟合定义纵断面

用于构造通过所选纵断面按最佳拟合定义的纵断面复合。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

使用“按最佳拟合定义纵断面”工具构造通过所选纵断面按最佳拟合定义的纵断面复合。例如，拾取现有地面纵断面并对纵断面进行最佳拟合以匹配地面。

  1. 选择“按最佳拟合定义纵断面”图标。

    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。

    • 将打开“放置‘按最佳拟合定义纵断面’轮廓 (Place Define Profiles by Best Fit Profile)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 通过按向下箭头键导航“最佳拟合”选项，然后点击确认（左键单击）以执行您的选择。

  3. 在将用于创建新元素的线性对象上点击确认。

  4. “包络”将定义最佳拟合工具的工作空间，因此必须通过以下方法之一定义上限：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 在提供的空间中输入一个值，然后点击确认。

  5. 通过以下方法之一定义下限：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 在提供的空间中输入一个值，然后点击确认。

  6. 为“需要凸曲线长度”输入一个值，然后点击确认。

  7. 为“需要凹曲线长度”输入一个值，然后点击确认。

  8. 为“最小曲线长度”输入一个值，然后点击确认。

  9. 根据给定的参数绘制一个新的纵断面。

父主题: 纵面几何复合


插入变坡点及竖曲线

用于向纵断面元素插入竖曲线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

使用“插入变坡点及竖曲线”工具向纵断面元素插入竖曲线。

  1. 选择“插入变坡点及竖曲线”图标。

    注释: 如果“视图”不处于“纵断面”模式，则会显示一条错误消息，表明您需要打开纵断面模型。

    • 将打开“插入变坡点及竖曲线”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位插入曲线的切线”，因此将光标移动到要从中绘制曲线的元素，然后点击确认（例如左键单击）。

  3. 当系统提示“定位顶点”时，将指针移到交汇点并点击确认。

  4. 使用以下方法之一指定曲线必须经过的点（通过按向左或向右箭头键导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入长度值并按 Enter 键，然后点击确认。

    • 输入竖曲线参数值并按 Enter 键，然后点击确认。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择相应的元素，然后将光标悬停在选定元素上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵面几何复合


添加竖曲线单元至纵断面

用于将其他元素附加至先前建立的复合元素。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

使用“添加竖曲线单元至纵断面”工具可将其他元素附加至先前建立的复合元素。

  1. 选择“插入/添加竖曲线单元至纵断面”图标。
    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。
  2. 将光标移至纵断面视图中后，系统会给出命令提示，要求您“定位复合元素”，请将光标移至现有复合元素，并将其选中。
  3. 系统提示“定位要添加/插入的元素”时，将光标移至要加入到复合元素的其中一个元素，然后单击该元素。
父主题: 纵面几何复合


插入反向曲线坡

用于创建包括有关所选纵面路线的信息的 XML 报告数据文件。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

“插入反向曲线坡”在先前绘制的元素之间构造反向曲线，两条曲线之间的切线长度可选。

  1. 选择“插入反向曲线坡”图标。
    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。
    • 将打开“放置插入反向曲线坡 (Place Profile Reverse Transition)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，它将显示命令提示，要求您“定位第一个元素”，因此将光标移动到要从中过渡的元素，然后点击确认（左键单击）。
  3. 使用以下方法之一设置“起点偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  4. 当系统提示“定位第二个元素”时，将光标移动到过渡段必须延伸到的元素，然后点击确认。
  5. 使用以下方法之一“输入终点偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  6. 将光标移至两个元素之间的空白处。当系统提示“定义切线长度”时，使用以下方法的组合来定义过渡（通过按向左或向右箭头键导航选项）：

    • 输入“线性过渡段长度”的值，然后按 Enter 键。

    • 输入“线性过渡段坡度”的值，然后按 Enter 键。

    • 输入“后竖曲线参数”的值，然后按 Enter 键。

    • 输入“前竖曲线参数”的值，然后按 Enter 键。

    注释: 这些条目并非完全独立，也不完全排他。锁定一个或多个值可能会限制另一个值。例如，如果锁定切线的长度和坡度，则曲线长度和参数将被强制为特定值以满足解决方案。（曲线长度和曲线参数互相排斥。）

    输入用于定义过渡的值后，点击确认以执行命令。

  7. 当系统提示“输入起始点”时，将光标移动到过渡段的原点并点击确认。
  8. 要在曲线的交点处修剪元素或将新曲线延伸到与现有元素相交，“偏移”值必须为零。按向下箭头键以选择“后”选项，然后按 Enter 键。
父主题: 纵面几何复合


纵断面偏移

用于构造偏离基本元素的纵断面元素。基本元素可以是线、弧、缓和曲线或复合体。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 复杂几何图形拆分按钮

“纵断面偏移”构造偏离基本元素的纵断面元素。基本元素可以是线、弧、缓和曲线或复合体。

  1. 选择“纵断面偏移”图标。

    注释: 如果视图未处于“纵断面”模式，系统将显示一条消息，指出您需要打开纵断面模型。

    • 将打开“纵断面偏移”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“纵断面视图”时，命令提示会要求您“定位元素”，因此将光标移动到基本元素并点击确认（例如左键单击）。

  3. 使用以下方法之一设置“偏移”和/或“起点距离”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  4. 使用以下方法之一设置“长度”和/或”终点距离”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  5. 命令提示显示“镜像”选项；使用向下箭头键进行导航，然后点击确认以执行您的选择。

父主题: 纵面几何复合


纵面几何定义元素纵断面

站点建模工具（过渡、按坡度、按偏移），同时创建土木规则。

在工具箱中选择 | 描述
插入过渡纵断面 | 通过匹配相邻元素的坡度和高程来定义元素的纵断面。根据相邻元素的配置，创建单个凸曲线/凹曲线或自由反向曲线连接。
按固定高程绘制纵断面 | 按给定高程为整个元素定义平面纵断面。
从固定点按坡率绘制纵坡 | 通过计算相对于三维点的坡度来定义元素的纵断面。
基于参照纵坡按固定坡度绘制纵断面 | 通过使用设计纵断面投影一个元素的固定坡度来定义另一个元素的纵断面。
基于参照纵坡按可变坡度绘制纵断面 | 通过使用设计纵断面投影一个元素的可变坡度来定义另一个元素的纵断面。此命令与“按坡度绘制纵断面 (Profile by Slope)”命令的区别仅在于您可以选择其他选项。具体来说，您可以定义一个范围而不是整个元素，并且有多种坡度方法可供使用，而不是只有固定坡度。
基于元素按竖向偏移绘制纵断面 | 根据竖向偏移定义元素的纵断面。结果与“按可变坡度绘制纵断面 (Profile by Variable Slope)”命令类似，不同的是它使用两个竖向偏移，而不是在两个坡度之间过渡。
按三维元素绘制纵断面 | 根据绘图中的三维元素（在纵断面空间中）生成纵断面。
创建土木规则特征 | 将土木几何图形规则分配给由土木几何图形命令以外的工具创建的元素。
插入过渡纵断面
按固定高程绘制纵断面
基于固定点按指定坡度定义纵断面
基于参照纵坡按固定坡度绘制纵断面
基于参照纵坡按可变坡度绘制纵断面
基于元素按竖向偏移绘制纵断面
按三维元素绘制纵断面
父主题: 纵断面


插入过渡纵断面

用于通过匹配相邻元素的坡度和高程来定义元素的纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮
使用“插入过渡纵断面”工具，通过匹配相邻元素的坡度和高程来定义元素的纵断面。根据相邻元素的配置，创建单个凸曲线/凹曲线或自由反向曲线连接。
注释: 相邻元素必须具有设计纵断面。

  1. 选择“定义元素之间的插入过渡纵断面 (Define Quick Profile Transition between Elements)”图标。

    • 将打开“放置 - 插入任意竖曲线 (Place Profile Curve between Elements)”对话框。

  2. 当您将光标移动到“平面视图”后，它将显示命令提示，要求您选择“快速过渡方法”，并按向下箭头键导航选项，然后按 Enter 键执行您的选择。

    • 抛物线方法在相邻元素的纵断面之间形成平滑的凸起或反向曲线。瞬时高程和坡度用于约束纵断面。

    • 线性方法仅在相邻元素的纵断面之间连接直线纵断面线。不考虑坡度。

  3. 当系统提示“定位要定义的元素”时，将光标移动到要连接两条腿的元素，然后点击确认（例如左键单击）。
  4. 要查看元素的纵断面，请单击“打开纵断面模型”图标。
  5. 将光标移动到“平面视图”，并注意附有提示，要求您“定位平面图元素”。点击确认新创建纵断面的元素。
  6. 现在，该光标将显示提示，指示“选择或打开视图”，因此将光标移动到视图 4 并点击确认。
父主题: 纵面几何定义元素纵断面


按固定高程绘制纵断面

用于在给定高程处为整个元素定义平面纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“按固定高程定义纵断面 (Define Profile by Constant Elevation)”工具在给定高程处为整个元素定义平面纵断面。

  1. 选择“按固定高程定义纵断面 (Define Profile by Constant Elevation)”图标。

    • 将打开“按固定高程定义纵断面 (Define Profile by Constant Elevation)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”中时，它将显示命令提示，要求您“定位第一个元素”。点击确认要提供固定高程的元素。

    • 选择完所有所需元素之后，右键单击空白区域以结束选择命令阶段。

  3. 当系统提示“输入高程”时，输入所需高程的值，按 Enter 键，然后点击确认或输入。

父主题: 纵面几何定义元素纵断面


基于固定点按指定坡度定义纵断面

用于通过计算三维点的斜率来定义元素的纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“基于固定点按指定坡度定义纵断面”工具以通过计算三维点的斜率来定义元素的纵断面。

  1. 选择“基于固定点按指定坡度定义纵断面”图标。

    • 将打开“基于固定点按指定坡度定义纵断面”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”中时，它将显示命令提示，要求您“定位第一个元素”，因此点击确认（例如左键单击）要提供高程的元素。

    • 选择完所有所需元素之后，右键单击空白区域以结束选择命令阶段。

  3. 当系统提示“定位三维参考点”时，将光标移动到将充当纵断面参考的三维点，然后点击确认。

  4. 出现提示时，提供所需的“斜率”时，输入值，然后按 Enter 键。

  5. 当系统提示选择“点选择”时，通过按向上或向下箭头键来导航选项，然后按 Enter 键。选项有：

    • 全部 - 整个元素均用于确定高程

    • 顶点 - 仅计算元素顶点处的高程

    • 终点 - 仅计算元素终点处的高程

    • 质心 - 仅计算质心处的高程

  6. 当系统提示选择“投影选项”时，通过按向上或向下箭头键来导航选项，然后按 Enter 键。点选择的选项包括：

    • 径向 - 使用上面的点选择选项将斜率从点投影到整个元素。

    • 穿过 (Through) - 斜率从点投影到元素上的最近点，然后沿元素投影相同的斜率。

  7. 当系统提示选择“纵断面调整”时，通过按向上或向下箭头键来导航选项，然后按 Enter 键。此处的选项包括：

    • 无 - 不执行调整

    • 最小值 - 在上一步中使用的点的最小值，选择最小高程并将此值用于整个纵断面

    • 最大值 - 在上一步中使用的点的最大值，选择最大高程并将此值用于整个纵断面

  8. 出现提示时，提供所需的“竖向偏移”时，输入值，然后按 Enter 键。在完成所有上述斜率计算之后，竖向偏移是一项附加调整。

父主题: 纵面几何定义元素纵断面


基于参照纵坡按固定坡度绘制纵断面

用于通过使用设计纵断面从另一个元素投影固定斜率来定义元素纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“基于参照纵坡按固定坡度定义纵断面 (Define Profile by Slope from Element)”工具来通过使用设计纵断面从另一个元素投影固定斜率来定义元素纵断面。

  1. 选择“基于参照纵坡按固定坡度定义纵断面 (Define Profile by Slope from Element)”图标。

    • 将打开“基于参照纵坡按固定坡度定义纵断面 (Define Profile by Slope from Element)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”中时，它将显示命令提示。选择要定义纵断面的元素。

  3. 当系统提示“定位参考元素”时，将光标移动到将充当纵断面参考的元素，然后点击确认（左键单击）。

  4. 出现提示时，提供所需的“斜率”时，输入值，然后按 Enter 键。

  5. 当系统提示选择“点选择调整”时，通过按向上或向下箭头键来导航选项，然后按 Enter 键。

  6. 当系统提示选择“纵断面调整”时，通过按向上或向下箭头键来导航选项，然后按 Enter 键。选项有：

    • 无 - 不执行调整

    • 最小值 - 在上一步中使用的点的最小值，选择最小高程并将此值用于整个纵断面

    • 最大值 - 在上一步中使用的点的最大值，选择最大高程并将此值用于整个纵断面

  7. 在完成所有上述斜率计算之后，竖向偏移是对纵断面的一个附加调整。

父主题: 纵面几何定义元素纵断面


基于参照纵坡按可变坡度绘制纵断面

用于通过使用设计纵断面从另一个元素投影可变斜率来定义元素纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“基于参照纵坡按可变坡度定义纵断面 (Define Profile by Variable Slope from Element)”工具，可通过使用设计纵断面从另一个元素投影可变斜率来定义元素纵断面。此工具与“按坡度绘制纵断面 (Profile by Slope)”工具的不同之处仅在于：为您提供其他选项。具体来说，您可以定义一个范围而不是整个元素，并且有多种坡度方法可供使用，而不是只有固定坡度。

  1. 选择“基于参照纵坡按可变坡度定义纵断面 (Define Profile by Variable Slope from Element)”图标。

    • 将打开“基于参照纵坡按可变坡度定义纵断面 (Define Profile by Variable Slope from Element)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”中时，它将显示命令提示，要求您选择“边坡样式”，以便通过按向上或向下箭头键来导航选项并按 Enter 键。

    • 边坡样式的选项包括：

      • “常数”使用常数固定边坡

      • 线性：边坡使用线性方法在起始值和结束值之间过渡

      • 反向四次曲线：边坡使用反向四次曲线过渡方法在起始值和结束值之间过渡

      • 反向三次曲线：边坡使用反向三次曲线过渡方法在起始值和结束值之间过渡

  3. 当系统提示“定位纵断面的平面图元素”时，点击确认（例如左键单击）要提供高程的元素。

  4. 当系统提示“定位参考元素”时，将光标移动到将充当纵断面参考的元素，然后点击确认。

  5. 可以用以下方法设置起点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  6. 可以用以下方法设置终点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  7. 出现提示时，提供所需的“斜率”时，输入值，然后按 Enter 键。

  8. 出现提示时，提供所需的“竖向偏移”时，输入值，然后按 Enter 键。

注释: 在计算完所有上述斜率之后，将应用竖向偏移。
父主题: 纵面几何定义元素纵断面


基于元素按竖向偏移绘制纵断面

用于基于竖向偏移定义元素的纵断面。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“基于元素按竖向偏移定义纵断面 (Define Profile by Vertical Offset from Element)”工具，可基于竖向偏移定义元素的纵断面。结果类似于“按可变坡度绘制纵断面 (Profile by Variable Slope)”工具，除了使用两个竖向偏移而不是过渡两个斜率以外。

  1. 选择“基于元素按竖向偏移定义纵断面 (Define Profile by Vertical Offset from Element)”图标。

    • 将打开“基于元素按竖向偏移定义纵断面 (Define Profile by Vertical Offset from Element)”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移动到“视图”中时，它将显示命令提示，要求您选择“边坡样式”，以便通过按向上或向下箭头键来导航选项，然后按 Enter 键。

  3. 当系统提示“定位纵断面的平面图元素”时，点击确认（例如左键单击）要提供高程的元素。

    边坡样式的选项包括：

    • 常数 - 使用常数固定边坡
    • 线性 - 边坡使用线性方法在起始值和结束值之间过渡
    • 反向四次曲线 - 边坡使用反向四次曲线过渡方法在起始值和结束值之间过渡
    • 反向三次曲线 - 边坡使用反向三次曲线过渡方法在起始值和结束值之间过渡

  4. 当系统提示“定位参考元素”时，将光标移动到将充当纵断面参考的元素，然后点击确认。

  5. 可以用以下方法设置起点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  6. 可以用以下方法设置终点距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  7. 出现提示时，提供所需的“竖向偏移”时，输入值，然后按 Enter 键。

注释: 如果样式是“常数”之外的任何类型，则将输入起点竖向偏移和终点竖向偏移。
父主题: 纵面几何定义元素纵断面


按三维元素绘制纵断面

用于从绘图中的三维元素生成纵断面（在纵断面空间中）。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 纵断面 > 元素纵断面(Element Profiles ) 拆分按钮

使用“按三维元素绘制纵断面”工具从绘图中的三维元素生成纵断面（在纵断面空间中）。

  1. 选择“按三维元素绘制纵断面”图标。

  2. 将光标移动到“视图”中时，它要求您“定位纵断面的元素”，因此点击确认（例如左键单击）要提供高程的元素。

  3. 当系统提示“定位纵断面的平面图元素”时，点击确认要提供高程的元素。

  4. 要查看新的纵断面，请单击“打开纵断面模型”图标。

  5. 将光标移动到“平面视图”，并注意附有提示，要求您“定位平面图元素”。点击确认新创建纵断面的元素。

  6. 该光标现在附有提示，指示“选择或打开视图”，因此将光标移动到“纵断面视图”中并点击确认。

属性

要查看新元素的属性，请使用“选择元素”工具。

在“视图”中选择元素，然后将光标悬停在其上方。单击“属性”图标可访问选定元素的规则数据。

父主题: 纵面几何定义元素纵断面


常用工具

您将在“常用工具”中找到以下主题：

简化几何图形
复合重新定义
转换
父主题: 几何图形


简化几何图形

“简化几何图形”工具用于移除平面和纵面几何图形的间隔和外部参考规则。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 常用工具

该工具将规则减少至定义几何图形范围内。换言之，它会移除来自其他元素的规则和关系，包括构造了几何图形的其他元素中的捕捉规则、偏移规则和间隔。运行该工具后，几何图形将反映从 ALG、GPK、FIL 和 LANDXML 导入的几何图形的规则。

应谨慎使用此工具，因为构造了几何图形的参考规则会被移除。这意味着原始设计意图不再存在，几何图形也不再更新，因为其不再监控这些元素的更改。

父主题: 常用工具


复合重新定义

用于保留原始“路线”名称，从而使基于原始几何图形构建的所有规则均可根据新几何图形进行更新。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 常用工具

此命令允许在一定范围内对现有复杂路线进行部分重新定义，以在新平面几何图形中进行替换。

该命令保留原始“路线”名称，从而使基于原始几何图形构建的所有规则均可根据新几何图形进行更新。“复合重新定义”影响与路线相关的所有规则，这意味着需要重新处理其他几何图形、超高、廊道、地形、土木单元等。原始路线中的纵面几何图形会保留，并转至新形成的路线中。原始路线中被替换的段保留在模型中，并分配有一个新名称。

请注意，需开启优先于参考文件的规则才能启动更新。

命令序列

  1. 定位复合元素 - 选择需要修改的路线。
  2. 定位元素重新定义复合 - 选择要插入到原始路线中的复杂路线。
  3. 要接受的数据点。
父主题: 常用工具


转换

另请参阅转换。

父主题: 常用工具


廊道

此帮助提供有关廊道的参考信息。提供了以下主要主题领域：

廊道模型概述
选择
廊道创建
廊道编辑
廊道杂项
超高
检查
父主题: OpenRoads Designer CONNECT Edition帮助


廊道模型概述

“廊道模型”工具集是一组高度交互的命令，用于创建表示新路面或其他类型曲面的新设计曲面。它支持用于创建、修改、管理和报告功能的工具。

廊道模型工具汇总了各种土木数据。几何图形使用平面和纵面几何工具创建，而现有地面板则由 MicroStation 网格或土木地形模型定义。平面视图元素（例如路面边缘、路肩、边饰等）可以是二维或三维元素。通过使用标准或导入的数据，可以在设计文件内定义超高信息。模板可从一个或多个模板库中使用。

参考文件可在廊道模型中广泛使用。对于简单的项目，数据可能都在一个文件中；而对于较大的项目，几何图形可能位于某一文件中，平面视图图形可能位于另一个文件中，地形则位于第三个文件中，超高和实际模型则分别位于第四和第五个文件中。所有文件均可参考其他文件，以显示项目的完整视图。

使用廊道模型时，可以使用二维或三维进行绘制。使用二维（例如，用于平面视图图形）时，系统将自动创建和维护三维视图。例如，最初为平面几何元素定义纵面几何元素时，系统将创建默认三维模型（如果没有）。三维基线（平面和纵面元素的组合）将绘制到三维模型中。随着三维路面的添加和推进，它们会自动添加到三维模型中。

开始创建廊道时，可以使用基本信息。可以使用单个模板，以及初步几何和高级地形模型。随着设计的推进，可以添加更多细节。与单个三维路面相比，也许更多的模板可以更好地定义路面。可以添加过渡段，从一个模板平滑移动到另一个模板。可能存在多个使用目标别名工具全部互连的路面。这样，一旦做出更改，廊道模型便会实时更新，使您能够实时查看最新结果。简单项目可能不需要所有工具，有基本廊道模型便已足够。但是，所有工具都可用于处理从基础到复杂、从小到大的各种规模的项目。

廊道建模工作流
廊道设计阶段
管理廊道数据
报告浏览器
父主题: 廊道


廊道建模工作流

以下列出了廊道模型的常规工作流。任务 5-9 可以不同的顺序完成，且所有任务并非均必需。

  1. 创建土木平面和纵面几何元素。这是在廊道模型工具之外完成的。

  2. 如果模板绑定到地面，则设置激活地形（现有地面）。

  3. 根据土木平面和纵面元素创建廊道。

  4. 添加三维路面。

  5. 为特定点添加水平和/或垂直控件（可选）。

  6. 定义任何过渡和连接。

  7. 关联超高信息。

  8. 检查结果并调整（根据需要使用其他控件，例如末端条件异常、二级对齐、参数约束或目标别名）。

  9. 继续进行/检查/修改，直到结果符合您的要求为止。

创建土木平面和纵面几何元素
设置激活
创建廊道
添加三维路面
水平和垂直点控件
定义过渡和连接
查看结果并进行调整
父主题: 廊道模型概述


创建土木平面和纵面几何元素

为了创建廊道，至少分别需要一个平面和纵面土木几何元素。这些元素是在创建廊道之前使用几何工具创建的。创建廊道之后，软件会提示输入基线参考（水平）元素。如果所选元素具有激活纵断面，则仅需重置即可继续。否则，您可以选择与所选水平元素关联的任何纵断面。尽管土木元素用于创建廊道，但几何设计工作仍可继续。土木几何元素可以编辑、延长、缩短等，利用各种变化不断更新廊道。但是，如果删除土木几何元素，则它所基于的廊道也将被删除，且不会显示任何警告。

父主题: 廊道建模工作流


创建廊道

用于...

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建

“创建廊道”工具是廊道设计的初始步骤；命名廊道并标识几何。模板处理不在此工具内进行，而是指在模板工作之前进行的设置步骤。

绘制闭合形状以标出廊道（使用土木几何元素的完整长度）。在下一步“三维路面”中，可以使用桩号范围以更好地定义廊道。将鼠标悬停在廊道上方时，将显示两个弹出窗口：

  • “快速属性”：显示廊道名称、平面几何元素（平面）、纵面几何元素（剖面）和廊道的层数。

  • 上下文相关菜单：含适用于廊道的工具。

创建/绘制廊道后，软件自动进入“创建三维路面”工具。

父主题: 廊道建模工作流


添加三维路面

创建廊道后，软件自动进入“创建三维路面”工具。三维路面根据用户定义的桩号范围定义路面的横截面对该部分道路的外观。项目可以由单个或多个三维路面组成。通常在两个三维路面之间使用过渡段，而不是从一个模板突然切换到另一个模板。选择（或在“创建廊道”过程中自动选择）此工具后，软件将提示输入：

  • 模板（使用由配置变量 Civil_Roadway_Template_Library 定义的默认模板库）

  • 起点桩号

  • 终点桩号

  • 划分间隔 - 指定处理模板的位置（以主单位表示）。这受设计阶段影响。

  • 三维路面前最小过渡段长/三维路面后最小过渡段长 - 如果为非零，则在长度大于或等于输入值的三维路面起点/终点处创建过渡段三维路面。实际长度由新的三维路面和新三维路面前/后的三维路面之间相隔的距离确定。如果空间不足无法满足最小要求，则缩短上一个/下一个三维路面以容纳过渡段。如果不存在上一个/下一个三维路面，则不会创建过渡段三维路面。

以下示例演示了将两个三维路面（以及二者之间的过渡段）添加到廊道（并自动处理廊道）之后平面视图的外观。请注意，绘制的三维路面显示为黄线，在三维路面的起点和终点处分别垂直于左侧和右侧的廊道。

将鼠标悬停在三维路面限制上方时，弹出窗口将显示相关信息。

父主题: 廊道建模工作流


水平和垂直点控件

点控件用于替代一个或多个点和/或组件在横截面中的正常位置。此类示例包括：车道加宽、保持路权、保持沟渠的特定坡度以及超高。

父主题: 廊道建模工作流


定义过渡和连接

在含多个模板的项目中，不同的模板之间通常无法实现瞬时更改。需要一个工具或程序来定义如何在不同的模板之间进行调整；“创建过渡段”工具用于在不同名称的模板之间创建过渡。

“创建过渡段”工具的输入字段非常少：选择需要过渡的两个模板即可。创建过渡之后，需要对其进行编辑以定义在不同的模板之间进行调整。

过渡编辑

编辑过渡分为两步。第一步是根据需要将第一个模板的骨干点连接到第二个模板的骨干点。请注意，末端条件不会显示，因为它们将通过末端条件异常进行处理。

连接创建方式如下：单击一个模板上的未连接点，将鼠标移动到另一个模板上的某个点，然后再次单击。连接线将动态显示。

根据需要连接点之后，软件就会尝试为过渡创建组件。将显示“最佳猜测”结果。可以根据需要进行调整，直到达到所需的结果为止。

父主题: 廊道建模工作流


查看结果并进行调整

由于设计较详尽且经过细化，因此可使用下表中列出的其他工具完成特定任务。

工具 | 目的
末端条件异常 | 定义末端条件异常，用于修改末端条件解决方案的行为，而无需使用其他三维路面。添加末端条件异常时，必须对其进行编辑以更改其行为。
参数化约束 | 约束指定桩号范围的值覆盖。从列表中选择参数约束时，要应用的所有点均在横截面视图中突出显示。
目标别名 | 用途是在使用多个表面的情况下，一个廊道可以另一个廊道的解决方案为目标。
廊道参考 | 用于在廊道中添加（或减去）图形元素。
廊道剪切 | 用于在使用多个廊道或单个廊道以及 MicroStation 形状或网格时，移除重叠区域。例如，在与交叉路面相交的廊道中，剪切将用于移除交集内的所有重叠特征。
调整竖向覆盖关系 | 在每个已处理的桩点处，此命令根据输入条件和模板顶部到现有地面的距离来确定理想的 PGL 点。通过测量地面点与模板顶部之间的垂直距离来测试横截面中的每个现有地面顶点。
次要路线 | 用于修改横截面的处理方向。缺省情况下（在任何给定桩号处），创建的横截面与廊道路线正交。如果存在次要路线，则位于次要路线之外的那部分横截面将与次要路线（而非主路线）正交。

父主题: 廊道建模工作流


廊道设计阶段

廊道设计阶段是一种简单的方法来保存廊道的常用设置，然后调用其他廊道而无需再次定义设置。每个廊道都可以在项目内拥有自己的设计阶段，并且可以随时更改。组织可以创建用作企业级别标准的阶段，并存储在 DGNlib 中以便于访问。使用后，将阶段复制到实际设计文件中，并可根据项目参数进行调整。

设计阶段工件已得到增强，确保无论激活设计阶段如何，一旦创建顶网格和廊道几何的共同目标廊道特征，就会保留它们。关闭这些廊道工件将禁用仅显示该工件，因此保留任何关系并使用规则传播进行更新。此更改允许为几何/廊道/曲面/土木单元中使用的元素/曲面目标创建和维护规则，并提供对对象模型的更佳管理。

廊道设计阶段位于“资源管理”>“OpenRoads 标准”>“特征定义”>“廊道”中。

右键单击“设计阶段”将打开“元素信息”对话框，在此示例中，使用默认设置填充该对话框。

四个部分定义了各种设置和选项：

  1. 特征定义
  2. 处理剖面与临界剖面
  3. 显示设置
  4. 操纵器设置
注释: 如果更改廊道的特征定义，则必须手动重新处理受影响的廊道。
模板管理
显示设置
操纵器设置
父主题: 廊道模型概述


模板管理

“三维路面间距乘数”与创建三维路面时指定的“路面间距”一起使用。其目的在于使设计人员能够使用更大的间距完成初步工作，并在细化设计时轻松缩短间距。为了确定用于处理的间距，路面间距需乘以三维路面间距乘数，且系统将使用该结果。让我们回顾一个间隔划分为 5 的示例。下表解释了五个示例阶段。

暂存区 | 倍增系数 | 产生的处理间隔 | 描述
计划 | 100 | 500 | 高级廊道研究等不需要高精度。
预备值 | 40 | 200 | 因为已确定廊道，所以可检查影响区域和问题。
设计 | 20 | 100 | 用于常规设计工作，直至项目结束时才需要高级精度。
终稿 | 5 | 25 | 用于剖面之间距离为 25 或 50 英尺的横截面图纸。
构造 | 1 | 5 | 用于立桩和自动化机器指导模型。
父主题: 廊道设计阶段


显示设置

选项 | 描述
顶网格显示 |
顶网格特征定义 |
底网格显示 |
底网格特征定义 |
组件显示 |
线性特征显示 |
包括空点线性特征显示 |
计曲线显示 |
计曲线间距 |
计曲线特征定义 |
间曲线显示 |
间曲线间距 |
间曲线特征定义 |
横向显示 |
输出设置
父主题: 廊道设计阶段


操纵器设置

选项 | 描述
廊道 - 元素模板 | 元素模板用于在“创建廊道”工具中绘制廊道边界。作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
廊道手柄长度系数 | 长度系数是指手柄长度与廊道宽度的比率。因此，1.0 将使手柄与该点处的廊道宽度一样长。
廊道手柄间距 | 手柄间距可设置为如图所示的物理距离，或设置为零。如果设置为零，则每个廊道将获得 11 个手柄，无论其长度如何。任何非零值都用作沿纵面路线在主单位中测量的手柄之间的距离。
三维路面元素模板 | 用于在“创建三维路面”工具中绘制三维路面边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
三维路面手柄长度系数 |
单桩号点元素模板 |
单桩号点手柄长度系数 |
过渡段元素模板 | 用于在“创建过渡段”工具中绘制过渡边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
缓和手柄长度系数 |
显示设置
父主题: 廊道设计阶段


管理廊道数据

可使用多个工具来帮助管理廊道模型数据。根据选择的工具，数据可能为只读，也可能受操控。这些包括：

  • 元素信息

  • 属性

  • 廊道对象 - 在一个位置查看和管理廊道中的所有输入对象

  • 项目浏览器 - 在一个位置查看所有廊道信息

  • 设计阶段

属性

属性显示反映选定元素的数据。例如，选择廊道与选择三维路面时显示的数据不同。

右键单击上下文相关菜单可访问“属性”工具。

当选择廊道时，显示屏显示名称和设计阶段。

廊道对象

用于在一个位置查看和管理廊道中的所有输入对象。

资源管理器

廊道模型数据也可在资源管理器中组织和显示。随着设计的推进，将会不断自动创建/更新信息。这些信息位于“土木模型”选项卡下。

每个廊道（和关联数据）均单独列出。导航树时，将显示其他数据。此外，单击右键时显示的上下文相关菜单中也有常见任务和信息。

父主题: 廊道模型概述


报告浏览器

在 Bentley Civil 中，土木工程报告浏览器应用程序用于生成和打印报告。该浏览器可从多个位置访问：

  • “分析与报表”工具组 - 包括几何报告和超高报告

  • “平面几何”工具组 - 访问“平面曲线数据表”

  • “廊道模型”工具组 - 访问“设计输入报表”、“结果报表”和“清表报表”

  • “测量处理”工具组 - 访问测量报告

  • 土木几何元素弹出式菜单

选择报告时，系统将提示用户输入报告所需的数据。完成输入后，土木工程报告浏览器将自动打开。

对话框左上角（下拉菜单正下方）的字段指示定位 XSL 文件的目录路径。对话框左窗格中的列表代表指定目录或其任何子目录中的所有 XSL 文件。每个 XSL 文件代表不同的报告。单击每个报告可在右窗格的面板中显示您的数据。

如果在选择 XSL 文件时难以获得结果，可以右键单击 XSL 文件并选择“样式表帮助”来显示该样式表的帮助主题。该帮助主题包含使用该样式表生成报告所需的注释或提示。

注释: 必须在该浏览器中打开 XML 文件才能显示“样式表帮助”。

在右键菜单上，您还可以从要将所选样式表设置为默认值的报告类型列表中进行选择。默认样式表由用户存储在注册表中，您可以随时对其进行更改。如果您没有为特定报告类型设置默认样式表，每次创建该报告类型时都会显示一条消息，指示您未选择默认样式表。

“土木工程报告浏览器”菜单具有以下选项：

  • 文件

  • 工具

  • 帮助

文件选项

报告

设置 | 描述
打开 | 激活“打开”对话框，打开 XML 数据文件。打开 XML 文件之后，将在对话框顶部的标题栏中报告该文件的名称。
另存为 | 显示“另存为”对话框，用于将报告输出保存到 HTML 文件、XML 文件、DOC 文件、XLS 文件或文本文件中。 许多报告均为格式化的 HTML 内容。这些报告可以另存为 HTML 文件。但是，某些报告由简单文本组成。这些报告另存为文本文件 (*.txt)。 注释: 如果用于报告的样式表包含嵌入式层叠样式表参考，则需要定位任何打开 DOC 文件的用户均可在其中找到该参考的 CSS，否则将显示一条警告，指示找不到该参考。
附加 | 显示“附加”对话框，用于将右窗格的内容附加到现有 .txt 文件。
页面设置 | 显示“页面设置”对话框，用于选择纸张大小、方向、边距以及页眉和页脚进行打印。
打印 | 显示“打印”对话框，用于打印报告。
打印预览 | 提供打印报告的预览。打印预览反映“页面设置”对话框中的当前设置。
退出 | 关闭 Bentley 土木工程报告浏览器程序。

工具

设置

描述

样式表根目录 (Style Sheet Root)

指定用于定位 XSL 文件的目录。InRoads 在指定目录及其任何子目录中查找 XSL 文件。

更改“样式表根目录 (Style Sheet Root)”时，新的根目录必须包含来自随附目录结构的以下内容的副本：

  • _Themes 目录。

  • format.xsl。

  • raw-xml.xsl。

没有这些副本，该浏览器将无法正常运行。唯一的例外是修改了新的根目录中包含的所有样式表以移除指向层叠样式表的链接。在这种情况下，不再需要 _Themes 目录。复制文件后，可以对其进行修改。

格式选项

激活“格式选项”对话框，用于设置在报告中显示各类数据的精度和格式。

格式选项

格式选项（报告浏览器）

从 Bentley InRoads 报告浏览器程序激活的“格式选项”对话框用于设置在报告中显示数据的精度和格式。

设置

描述

纵坐标/横坐标（精度）

指定用于表示纵坐标或横坐标值的小数位数。

高程（精度）

指定用于表示高程值的小数位数。

角度模式

指定用度、梯度、弧度还是密耳表示角度测量值。

角度精度

指定用于表示角度测量值的小数位数。

角度格式

指定角度模式设置为“度”时用于显示角度测量值的格式。选择 ddd^mm'ss.s" 表示度-分-秒，选择 ddd.ddd 表示十进制度。角度模式设置为“梯度”或“弧度”时，角度测量值显示为十进制。

包括角度后缀 (Include Angular Suffix)

选中时，角度值的后面将附加“r”或“g”，具体取决于“模式”设置为“梯度”还是“弧度”。

坡度精度

指定用于表示坡度测量值的小数位数。

坡度格式

指定用于显示坡度测量值的格式。有关详细信息，请参阅“坡度格式”。

如果坡度超过精度，则使用备选坡度 (Use Alternate Slope if Slope Exceeds Precision)

指定一个值，如果该值大于或小于指定值，则报告一组不同的参数。

备选坡度精度

指定用于表示备选坡度的小数位数。

备选坡度格式

指定用于显示备选坡度测量值的格式。有关详细信息，请参阅“坡度格式”。

线性精度

指定用于表示线性测量值的小数位数。

桩号精度

指定用于表示桩号设置值的小数位数。

桩号格式

指定用于显示桩号值的格式：ssss.ss、ss+ss.ss 或 s+sss.ss。

以下报告中的桩号值不遵循“桩号格式”：HorizontalAlignmentToASCII.xsl、VerticalAlignmentToASCII.xsl 和 VerticalAlignmentToTIW.xsl。这些报告中的桩号值始终以 ssss.ss 格式显示。

英亩/公顷精度

指定用于表示以英亩或公顷为单位的面积的小数位数。

面积单位精度

指定用于表示以除英亩或公顷外的单位计的所有面积测量值的小数位数。

立方单位精度

指定用于表示体积等立方测量值的小数位数。

转换为立方码 (Convert to Cubic Yards)

选中时，以立方码为单位报告所有英制体积。如果勾掉，则以立方英尺为单位报告所有英制体积。默认为选中。

方向模式

指定用于表示方向的模式：“象限角 (Bearings)”、“仅北向象限角 (Bearings North Only)”、“北向方位角 (Azimuths from North)”或“南向方位角 (Azimuths from South)”。

方向精度

指定用于表示指示方向的测量值的小数位数。

方向格式

指定用于显示方向测量值的格式。选择 ddd^mm'ss.s" 表示度-分-秒，选择 ddd.ddd 表示十进制度。

面

定义使用经纬仪在左面还是右面方位收集测量数据。如果使用右面方位收集数据，请将此选项设置为“向右”。在美国，文件几乎始终为右面，也称为正面。如果使用经纬仪沿反转或下降方位执行测量，则将“面”设置为“只在左侧”。

下面定义了左面测量和右面测量之间的关系：

右面角度 + 左面角度 = 360 度

“左面”将 xslFaceFormat 设置为 FACE_MODELEFT_FACE

“右面”将 sxlFaceFormat 设置为 FACE_MODE_RIGHT_FACE

注释: 默认情况下，测量 XML 报告中的方向为“右面”。如果是这种格式，faceFormat 函数不会修改方向。

垂直观测

定义垂直观测的方位。以下描述了可用的方法：

“天顶”指定从正向 Z 轴（从地球向上延伸到天顶）开始在垂直面中测量垂直观测值（0 到 360 度）。使用“天顶”时，垂直角度 0 在头顶正上方，90 在您正前方，180- 表示垂直向下，270 在您正后方。

“地平线”指定从地平面（水平面）开始在垂直面中测量垂直观测值（0 到 360 度）。使用“地平线”时，垂直角度 0 在您正前方，90 在头顶正上方，180 在您正后方，270 表示垂直向下。

“地平线 +/-”指定从地平面（水平面）开始在垂直面中测量垂直观测值（-180 到 +180 度）。垂直角度 0 在您正前方，90+ 在头顶正上方，-90 表示垂直向下，+180 和 -180 在您正后方。默认情况下，测量 XML 报告中的方向为“右面”。如果是这种格式，faceFormat 函数不会修改方向。

注释:

关闭

存储设置并关闭对话框。

帮助

显示帮助。

坡度格式

本部分介绍了软件中使用的各种坡度格式。各种工具使用“坡度”组合框，可在其中选择特定格式来表示坡度。以下列表解释了该列表中的每种格式。在每种情况下，表示的坡度为 0.5。

注释: 所有坡度均以高度:长度为格式，但最后一个除外 (2.0:1)。
格式 | 坡度表示为
0.50 | 十进制值。
50% | 百分比值。
0.5:1 | 十进制比率，其中第二个值始终为 1。
0.5':1' | 十进制比率，其中第二个值始终为 1（以英尺为单位）。
6":1' | 英寸与值 1 英尺的比率。
12/2":1' | 英寸与值 1 英尺的比率，其中英寸表示为分子为 12 的分数。
24/4":1' | 英寸与值 1 英尺的比率，其中英寸表示为分子为 24 的分数。
48/8":1' | 英寸与值 1 英尺的比率，其中英寸表示为分子为 48 的分数。
96/16":1' | 英寸与值 1 英尺的比率，其中英寸表示为分子为 96 的分数。
1:2.0 | 十进制比率，其中第一个值始终为 1。
500%o | 千分率值（每 1000），而不是百分比值。
2.0:1 | 十进制比率，以高度:长度为格式，其中第二个值始终为 1。
父主题: 廊道模型概述


选择

另请参阅选择

父主题: 廊道


廊道创建

开始设计廊道时，使用第一个工具箱，其中包括用于创建廊道、三维路面、过渡的工具，以及可以使用模板库的各种工具。

在工具箱中选择 | 描述
新建廊道 | 通过定义廊道名称、标识基线参考和纵断面并指定设计阶段，可以创建廊道。创建廊道后，该软件会自动前进到“创建三维路面”工具。
新建三维路面 | 根据桩号限制以及从当前模板库中选择的模板，为道路设计创建三维路面。
创建过渡段 | 根据选择先前创建的两个三维路面，在两个三维路面之间创建过渡。
编辑过渡段 | 修改先前在两个三维路面之间创建的过渡。
复制三维路面 | 作为创建和修改三维路面的替代方法，此工具将现有的三维路面复制到根据相同基线参考新定义的桩号范围中。
创建模板 | 打开当前模板库以添加新模板、删除或修改现有模板。
显示模板 | 通过使用激活 MicroStation 线符，可在绘图文件中用户定义的数据点处绘制当前模板库中的选定模板。所有末端条件均会绘制，且没有标注。该绘图作为模板库文档的起点非常有用。
创建廊道
创建三维路面
复制三维路面
导入 IRD
过渡段
模板
父主题: 廊道


创建廊道

用于...

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建

“创建廊道”工具是廊道设计的初始步骤；命名廊道并标识几何。模板处理不在此工具内进行，而是指在模板工作之前进行的设置步骤。

绘制闭合形状以标出廊道（使用土木几何元素的完整长度）。在下一步“三维路面”中，可以使用桩号范围以更好地定义廊道。将鼠标悬停在廊道上方时，将显示两个弹出窗口：

  • “快速属性”：显示廊道名称、平面几何元素（平面）、纵面几何元素（剖面）和廊道的层数。

  • 上下文相关菜单：含适用于廊道的工具。

创建/绘制廊道后，软件自动进入“创建三维路面”工具。

父主题: 廊道创建


创建三维路面

用于根据用户定义的桩号范围来定义道路部分的路面横截面外观。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建

“创建三维路面”工具根据用户定义的桩号范围来定义道路部分的路面横截面外观。一个项目可能包含单个三维路面，也可能包含多个三维路面。通常在两个三维路面之间使用过渡段，而不是从一个模板突然切换到另一个模板。

应仔细考虑用于廊道的“划分间隔”，尽管其可随时更改。它指定每次处理模板之间的距离（以主单位计）。通常，此值等于或小于（但仍为倍数）最终横截面的所需间隔，因为横截面桩号应与处理桩号一致。无需将间隔设置过小以包含所有所需的横截面桩号，因为可以使用“关键桩号”工具向模型中添加特定项目相关的桩号。如果要在构造中使用模型，则间隔越小，模型越详细，但处理所需时间越长。

廊道创建工具中的三维路面描述有助于管理模型和下游报告。用户可在创建时（在面板上或危险警告提示处）为任何三维路面添加描述。描述包含在廊道对象对话框中，也可从三维路面属性进行访问。对于现有项目，用户可以编辑廊道对象并根据需要添加模板描述。

请注意，此操作受设计阶段影响。

“三维路面前最小过渡段长”和“三维路面后最小过渡段长”是“创建三维路面”工具中的输入。如果它们为非零值，则在三维路面的起点/终点处创建过渡路面，长度大于或等于所输入的值。实际长度由新的三维路面和新三维路面前/后的三维路面之间相隔的距离确定。如果空间不足无法满足最小要求，则缩短上一个/下一个三维路面以容纳过渡段。如果不存在上一个/下一个三维路面，则不会创建过渡段三维路面。

从配置变量“Civil_Roadway_Template_Library”所定义的缺省模板库中选择模板。

完成提示操作后，系统会自动处理廊道，您可以在二维和三维视图中查看廊道。如果需要，可以对廊道进行渲染。

注释: 三维路面的范围可以超出路线的有效范围。出现这种情况时，软件无法计算三维路面终点与廊道边界的交点，因此缺省设置恢复为“方框”。

符号以模板内的特征定义为基础。项目浏览器也会使用包括三维路面、组件和特征在内的廊道信息进行更新。

操控三维路面
三维路面上下文相关菜单
创建三维路面工作流
父主题: 廊道创建


操控三维路面

三维路面具有可操控的编辑图柄。您可以动态移动开始和结束桩号，也可以在编辑字段中键入值。切记，如果移动与另一个三维路面毗连的三维路面，则需逐个移动它们。例如，如果一个三维路面在 14+00 处结束，而另一三维路面在该处开始，且您要将桩点更改为 13+50，则需逐个移动这两个三维路面。

要操控三维路面，右键单击三维路面并从上下文相关菜单中选择“编辑三维路面”。

父主题: 创建三维路面


三维路面上下文相关菜单

创建三维路面后，可以通过上下文相关菜单访问常用工具。

工具 | 描述
属性 | 弹出窗口包括“间隔”、“模板名称”、“平面路线”和“桩号”范围。
编辑三维路面 | 打开模板库并显示当前模板。
复制三维路面 | 启动“复制三维路面”工具。由于它使用当前三维路面，因此用户仅需输入要复制三维路面的起点和终点桩号。
同步模板 | 使用当前模板库中的同名模板更新三维路面内的模板。系统会覆盖之前对三维路面中的模板所做的全部更改且无警告。
删除 | 删除三维路面。

父主题: 创建三维路面


创建三维路面工作流

  1. 选择“创建三维路面”工具。此工具在“创建廊道”工具结束时自动调用，但您可以独立于“创建廊道”工具使用它。

  2. 选择要添加三维路面的廊道。

  3. 选择模板 - 从最近使用的模板的下拉列表中选择模板，或者在键盘上选择 <Alt> + <向下箭头> 打开激活模板库并选择模板。点击确认模板并移至下一提示。

  4. 起点桩号 - 以图形方式定义起点桩号或在编辑字段中输入值。点击确认，以接受并移动到下一提示。可通过键入桩号或选择 <Alt> 之后按 <enter> 来锁定“起点”桩号。再次选择 <Alt> 可解锁字段。

  5. 终点桩号 - 以图形方式定义终点桩号或在编辑字段中输入值。点击确认，以接受并移动到下一提示。可通过键入桩号或选择 <Alt> 之后按 <enter> 来锁定“终点”桩号。模板即复制到新桩号范围。再次选择 <Alt> 可解锁字段。

  6. 划分间隔 - 指定每次处理模板所间隔的距离（以主单位表示）。通常，此值等于或小于（但仍为倍数）最终横截面的所需间隔，因为横截面桩号应与处理桩号一致。请注意，此操作受设计阶段影响。

以下示例演示了将两个三维路面（以及二者之间的过渡段）添加到廊道（并自动处理廊道）之后平面视图的外观。请注意，绘制的三维路面显示为黄线，在三维路面的起点和终点处分别垂直于左侧和右侧的廊道。

父主题: 创建三维路面


复制三维路面

用于沿同一廊道内的同一基准参考将现有三维路面复制到新定义的桩号范围。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建

“复制三维路面”工具可用于替代创建和修改三维路面，因为该工具沿同一廊道内的同一基准参考将现有三维路面复制到新定义的桩号范围。

工作流

  1. 选择“复制三维路面”工具。

  2. 定位三维路面 - 选择想要复制到不同位置的之前创建的模板。

  3. 起点桩号 - 以图形方式定义起点桩号或在编辑字段中输入值。点击确认，以接受并移动到下一提示。可通过键入桩号或选择 <Alt> 之后按 <enter> 来锁定“起点”桩号。再次选择 <Alt> 可解锁字段。

  4. 终点桩号 - 以图形方式定义终点桩号或在编辑字段中输入值。点击确认，以接受并移动到下一提示。可通过键入桩号或选择 <Alt> 之后按 <enter> 来锁定“终点”桩号。模板即复制到新桩号范围。再次选择 <Alt> 可解锁字段。

父主题: 廊道创建


导入 IRD

导入 Roadway Designer (IRD) 文件中包含的 SELECTseries 2 和以前版本的廊道。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建

“导入 IRD”工具可导入 Roadway Designer (IRD) 文件中包含的 SELECTseries 2 和以前版本的廊道。

本部分包括以下主题：（详细信息链接如下）

  • 建议和限制
  • 点控制目标比较
  • 末端条件目标比较
  • 将 SS2 IRD 导入 SS3 后需要手动执行程序
  • 工作流: 导入 IRD

建议和限制

  1. 每次只能导入一个廊道。
  2. 廊道基线的平面和纵面几何必须已经存在于设计文件或附加的参考文件中。此外，必须存在包含由平面几何与纵面几何形成的三维线性元素的三维模型。如果不满足这些条件，则无法导入廊道。
  3. 导入的廊道将始终以激活地形模型为目标，该模型必须已经存在于设计文件或附加的参考文件中。如果没有地形模型处于激活状态，则仍然可以导入廊道，但是无法导入末端条件。（结果与在没有激活地形模型的情况下创建廊道相同。）
  4. 如果廊道中的第一个三维路面是过渡段，则不会将其导入。
  5. 为了导入次要路线控制，次要路线控制所依赖的平面路线必须存在于设计文件或附加的参考文件中。如果次要路线控制依赖关系缺失，则会将其导入，同时仍然可以导入廊道，但是不具有次要路线控制。
  6. 为了导入点控制，该点控制的所有依赖关系必须存在于设计文件或附加的参考文件中。如果点控制依赖关系缺失，则会将其导入，同时仍然可以导入廊道，但是无法导入该点控制。例如，如果点控制是廊道特征点控制，则廊道和廊道特征必须已经存在。如果不存在，则不会导入点控制。
  7. 目标别名。为了导入目标，该目标至少有一个依赖关系必须存在于设计文件或附加的参考文件中。如果找不到依赖关系，则不会将其添加到该目标的别名列表中。如果找不到目标的任何依赖关系，则不会将该目标添加到目标列表中。将报告所有缺失的目标别名依赖关系，可以导入缺少目标别名依赖关系的廊道，但是无法导入缺少所有依赖关系的目标。
  8. 所有依赖关系将按名称与设计文件和/或附加的参考文件中的土木对象匹配。例如，如果点控制依赖于廊道“廊道 2”和特征“LEP”，则名为“廊道 2”的廊道必须存在于设计文件或附加的参考文件中，并且“廊道 2”必须包含名为“LEP”的特征。
  9. 要按名称匹配次要路线依赖关系，包含次要路线几何的 .alg 文件必须存在于与 .ird 文件相同的文件目录中。这是因为 .ird 文件不包含次要路线依赖关系的名称，必须搜索 .alg 文件才能获得该名称。

点控制和目标比较

SS2 点控制 7 个潜在目标

SS3 点控制 6 个潜在目标

SS2 与 SS3 的比较

  1. SS2“路线”= SS3“线性几何”（名称更改）
  2. SS2“特征”= 不支持 SS3（地形特征定位）
  3. SS2“样式”= SS3“特征定义”（名称更改）
  4. SS2“廊道点”= SS3“廊道特征”（名称更改）
  5. SS2“高程和坡度”= SS3“高程和坡度”（未更改）
  6. SS2“高程偏差”= SS3“高程偏差”（未更改）

末端条件比较

SS2 末端条件查找 11 个潜在目标组合

SS3 末端条件查找 8 个潜在目标组合

SS2 与 SS3 的比较

  1. SS2“曲面”= SS3“地形模型”（未更改）
  2. SS2“高程”= SS3“高程”（未更改）
  3. SS2“特征 XY”= 不支持 SS3（地形特征定位）
  4. SS2“特征高程”= 不支持 SS3（地形特征定位）
  5. SS2“特征 XYZ”= 不支持 SS3（地形特征定位）
  6. SS2“路线 XY”= SS3“线性平面”（名称更改）
  7. SS2“路线高程”= SS3“线性纵断面”（名称更改）
  8. SS2“路线 XYZ”= SS3“线性两者”（名称更改）
  9. SS2“样式 XY”= SS3“特征定义平面”（名称更改）
  10. SS2“样式高程”= SS3“特征定义纵断面”（名称更改）
  11. SS2“样式 XYZ”= SS3“特征定义两者”（名称更改）

将 SS2 IRD 导入 SS3 后需要手动执行程序

  1. 通过点控制定位 SS2 样式 ? SS3 特征定义时，必须将指定为点控制的线性特征作为廊道参考手动添加到要修改的廊道。
  2. 如果点控制定位的路线（SS3 线性几何）中三维路面和路线起自完全相同的桩号位置，则在 SS3 中，很可能需要将目标路线和可选纵断面延伸一小段距离，使起点在三维路面之前，从而找到目标。这是由于转换过程和双精度计算所致。通常将路线延伸 0.001' 便已足够。虽然路线仍会正确显示在绘图中，但第 16 位小数点中的双精度数学可能会引入一个不等式，除非略微延伸此路线，否则三维路面看不到基于计算机的路线。归根到底，这只是一个精度问题。通常，如果缺少目标路线，三维模型中会显示“异常”。

模板点样式目标

在 SS2 中，模板点可以定位“样式约束”，有时也称为“制图标准”。

在 SS3 中，存在相同的功能，但新名称现在如下所示

请注意，在 SS3 中，该方法现在仅支持平面目标。

  1. 与点控制类似，通过模板点属性在 SS3 中定位“平面特征约束”时，必须将线性特征作为廊道参考手动添加到要修改的廊道。

末端条件目标

  1. 如果末端条件 (E/C) 定位路线，则必须将路线作为参考添加到廊道。
  2. 如果末端条件 (E/C) 定位路线“线性纵断面”或“线性两者”，则必须在廊道的“目标别名”对话框中定义目标，如示例中所示。
    注释: 如果此方法仅用于平面定位，则不需要设置目标别名，因为在添加为廊道参考之后，系统会自动找到平面路线。
  3. 与上述点控制类似，通过末端条件在 SS3 中以水平和/或垂直方式定位“特征定义”时，必须将线性特征作为廊道参考手动添加到要修改的廊道。

    此外，如前面的步骤 1 所示，如果末端条件 (E/C) 定位“特征定义纵断面”或“两者”，则必须在廊道的“目标别名”对话框中定义目标，才能找到线性特征的垂直纵断面。

参数化约束

如果使用在 08.11.09.722 之前发布的 GEOPAK/InRoads/MX 版本，则与坡度约束替代 (%) 相关的所有参数化约束标签的值将错误地转换为公制数。所有高于 08.11.09.722 的内部版本都将修复此缺陷。

超高

在导入包含超高点控制的廊道之前，请务必相应地设置激活 MicroStation 线符，以确保按照正确的高度绘制超高断面。

父主题: 廊道创建


过渡段

创建过渡段
编辑过渡段
父主题: 廊道创建


创建过渡段

用于编辑两个三维路面之间的过渡。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建 > 过渡拆分按钮

在不同名称的模板之间创建过渡，因为模板通常不会立即从一个模板更改为另一个模板。此工具通过选择两个与之邻近的三维路面来创建过渡。它不定义如何在三维路面之间过渡，此操作在“编辑过渡段”工具中完成。

如果两个三维路面中的路面间距不相等，则使用桩号较低的三维路面的路面间距。但是，可以在“过渡段属性”中对此进行更改。

工作流

  1. 选择“创建过渡段”工具。

  2. 选择与过渡段相邻的第一个三维路面。这两个三维路面的选择顺序无关紧要。

  3. 选择与过渡段相邻的第二个三维路面。创建过渡段（并自动处理廊道）。请注意，过渡段的绘制方式与三维路面相同，绘制的黄线在过渡段起点左侧和过渡段终点右侧与廊道正交（基于桩号设置）。

操控过渡段
创建过渡段上下文相关菜单
父主题: 过渡段


编辑过渡段

用于...

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建 > 过渡拆分按钮

编辑过渡分为两步。

  1. 根据需要，将第一个模板的主结构点连接到第二个模板的主结构点。未连接的点使用粗 + 符号表示；连接点使用细 + 符号表示。末端条件未显示。末端条件过渡段通过末端条件异常进行处理。

  2. 编辑过渡段组件。

过渡段颜色表示过渡段的状态。

  • 红色 - 表示第一个模板的主结构点均未连接到第二个模板的主结构点。

  • 黄色 - 表示某些主结构点已连接（最初是将具有相同名称的点连接起来）。

  • 浅蓝色 - 表示并非所有点均已连接，但您至少已查看和/或编辑过渡段一次。

  • 深蓝色 - 表示两个模板的所有点均已连接。

编辑过渡组件
编辑过渡段工作流
连接点
父主题: 过渡段


模板

创建模板
显示模板
父主题: 廊道创建


创建模板

创建、编辑和预览路面模板。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建 > 模板拆分按钮

使用此对话框可创建、编辑、管理和预览路面模板。有关使用模板的详细信息，请参阅创建模板概述主题。

模板库

显示树视图，其中列出激活模板库 (*.itl) 中的所有可用模板。此视图还包括其他模板级命令，例如：设置激活、剪切、复制、粘贴、重命名、模板文档链接和显示。要访问这些命令，请右键单击视图中的模板。该视图还显示缺省点名称列表，通过它可在模板中添加或修改点的名称和样式。要编辑点名称列表，请右键单击或双击树视图中的“点名称列表”项。有关此选项的详细信息，请参阅点名称列表主题。

模板库（选项卡）

可以在标准模板库树视图和激活模板树视图之间进行选择。

库

显示标准模板库树视图。

激活模板

显示激活模板树视图。此视图还列出模板中所选（激活/高亮显示）组件、点或显示规则的属性。可以访问（双击）和编辑对象的属性，或者从列表视图中删除对象。

选择“点”文件夹之后，文件夹/树视图下方将显示所有点的列表。可以使用 Shift 和 Ctrl 键功能选择多个点。右键菜单可用于编辑或删除点，更改样式和显示状态，以及设置“特征名称覆盖”。

将一个组件拖到另一个组件之上可使其成为该组件的子项，或者将其拖到组件文件夹可删除其父项。

“文件”菜单

新建

新建 > 文件夹

在模板库的当前位置创建一个新文件夹。

新建 > 模板

在模板库的当前位置创建一个新模板。

新建 > 模板库

可以创建一个新模板库并打开该库。

打开

显示“打开”对话框。

保存

保存当前模板库。

另存为

可以使用其他名称保存模板库。在“另存为”对话框上，“选项”按钮允许您选择保存文件时使用的单位。

导入模板

可以从先前在选择集中标识的图形导入模板。有关详细信息，请参阅从图形导入模板主题。

关闭

关闭“创建模板”对话框。如果已修改模板库，系统会提示您在退出之前保存。

编辑菜单

以下所有命令适用于激活或当前选定的模板或文件夹。

撤消

撤消对当前模板的最后一次编辑。

恢复

恢复上一撤消操作

挖方量

从模板库中删除所选模板或文件夹并将其放置在粘贴缓冲区中。

复制

将所选模板或文件夹复制到粘贴缓冲区。

粘贴

将粘贴缓冲区中的任何内容复制到模板库中的当前位置

删除

从模板库中删除所选模板或文件夹。

重命名

可以重命名所选模板或文件夹。

清除

可以擦除当前模板中的所有点和组件。

添加菜单

简单

向当前模板添加特殊组件类型。有关简单组件的详细信息，请参阅创建模板概述主题。

受约束

添加一个组件，其中除第一点外的所有点完全受上一个点约束。有关约束组件的详细信息，请参阅创建模板概述主题。

无约束

添加包含所有自由点的组件。有关无约束组件的详细信息，请参阅创建模板概述主题。

空点

添加与任何特定组件无关的空点。有关空点的详细信息，请参阅创建模板概述主题。

末端条件

向当前模板添加末端条件。末端条件组件中的点具有以下附加属性：

  • 检查拦截 - 如果启用了此属性，则在求解末端条件时将检查前一段是否拦截了目标。如果关闭此选项，则在检查拦截时将忽略该线段。

  • 在拦截处放置点 - 如果启用了此属性并且沿前一段发现拦截，则该线段将绘制到拦截处。否则，如果找到拦截，则线段将被绘制到其最大宽度中。

  • 末端条件为无穷大 - 此标志仅适用于末端条件上的最后一个点。如果已设置此属性，则在尝试拦截目标时，将把最后一段视为无限长。

  • 不构建 - 如果启用了此标志，则该点的求解方法与末端条件中的所有其他点相同，但在绘制组件分段时将跳过该点。

当前组件名称

可以查看/编辑当前组件的名称。仅在添加组件时才适用。

当前组件特征样式

可以查看/编辑当前组件的样式。仅在添加组件时才适用。

当前组件的其他字段

放置简单组件或末端条件组件时，“当前组件”区域中将显示其他字段。有关详细信息，请参阅有关“添加简单组件”和“添加末端条件组件”的部分。

重叠/剥离

向当前模板添加重叠/剥离组件。重叠/剥离组件的放置方式与其他组件相同，都是通过选择/创建点来定义组件。

对于剥离组件，该组件的点仅定义组件顶部。然后，根据顶部和底部选项绘制该组件。

该过程计算组件顶部和底部的值，方法是查看组件起点和终点之间的所有曲面点，以及所有组件点和组件分段与曲面相交的所有交点。

有关添加重叠/剥离组件的详细信息，请参考添加新的重叠/剥离组件。

“工具”菜单

模板库管理器

显示模板库管理器对话框。

应用特征名称覆盖

显示应用特征名称覆盖对话框。

应用组件名称覆盖

显示应用组件名称覆盖对话框。

选项

显示模板选项对话框，可在其中指定当前模板的命名和步骤选项。使用“动态”对话框可打开/关闭这些设置。

动态设置

显示动态设置对话框，可在其中指定精度输入。

模板库报表（itl 文件）

显示 Bentley Civil 报表浏览器，可在其中查看可用的模板库报表。

当前模板

名称

显示当前模板的名称。

描述

可以查看/编辑当前模板描述。

显示

组件/约束

确定模板的显示模式。如果已设置显示组件字段，则会显示组件。如果已设置显示约束字段，则会显示点约束。点将始终显示。

显示点名称

指定在选中此选项时显示的点名称（白色）。如果点具有特征名称覆盖（应用于“点属性”对话框），则显示为红色。

显示所有组件

指定在选中此选项时由于显示规则用虚线显示而隐藏的所有组件。有关定义显示规则的具体详细信息，请参阅显示规则帮助主题。

模板预览窗口

显示在库资源管理器中高亮显示的模板的预览。浅蓝色框表示模板的拖曳点。可以通过在预览窗口中左键单击所需的拖曳点来更改拖曳点。还可以直接将模板从预览窗口拖曳到当前模板。

测试

显示测试末端条件对话框。

镜像/反射

显示镜像和反射设置的状态。如果打开此设置，则标签为黑色。如果关闭此设置，则标签将灰显。

创建模板概述
文件工具
编辑工具
添加（组件）命令
工具命令（创建模板）
模板文档链接
检查点的连接性
删除组件
更改模板原点
从所有点删除约束
添加点
移动点
合并点
删除点
删除组件
从组件中删除(清空)
取消合并组件点
设置动态原点
添加约束
点属性
价值公式
组件特性
点名称列表
测试末端条件
末端条件优先级
修复优先级
组件显示条件表达式
组件选择
点选择
合并组件
父主题: 模板


显示模板

用于根据您的规范在绘图文件中绘制模板。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 创建 > 模板拆分按钮

“显示模板”命令用于根据您的规范在绘图文件中绘制模板。您从该对话框中选择的所有端点和非末端条件组件均根据竖向比例系数设置进行绘制。

竖向放大系数

指定应用于显示中的竖向值的放大系数量。

如坡度超过以下值，则使用备选坡度 (Use Alternate Slope If Slope Exceeds)

如果选择，则表示当组件坡度超过指定值时使用备选坡度。

显示控制

精度/格式

宽度

指定组件精度。

斜率

指定组件坡度的精度和格式

备选坡度 (Alternate Slope)

指定备选坡度的精度和格式。

定义末端条件

指定当模板中存在末端条件时，通过在预览窗口中左键单击所需的末端条件将显示哪些末端条件。此外，通过再次左键单击，也可以从绘图中移除末端条件。

线符

标识组件标题、尺寸标注线、尺寸文本、组件标签、引线和点名称的显示选项和线符。

如果选择了“标题”，则标题将放置在绘图的中心顶部，并带有指定的标题文本线符。如果选择了“尺寸标注线”，则标题下方将放置尺寸标注线，指示最顶部非末端条件组件的每个点。如果选择了“尺寸标注文本”，则放置沿尺寸标注线的每个点之间的距离，以及沿最顶部组件（包括末端条件）的坡度。宽度和坡度将考虑指示的精度和格式，如果坡度超过指定值，则应使用替代坡度格式或精度。仅当该模板包含闭合组件时，才会确认“组件标签”和“引线”设置。在这种情况下，组件的描述放置在每个闭合组件下方，并有一条指向该组件的引线。这些标签类似于“制图”>“放置注释”命令标签，可以使用“移动注释”命令重新定位。选择“点名称”之后，将显示模板中的点名称。

应用

激活设置并在设计文件中绘制相应的模板。

父主题: 模板


廊道编辑

此工具箱包含用于操作之前创建的廊道以及关联三维路面的工具。借助这些工具，可以添加更详细的信息来响应项目特定的要求和约束，从而优化模型。

在工具箱中选择 | 描述
编辑三维路面 | 打开当前模板库并显示包含选定三维路面的模板。
点控制 | 通过指定先前创建的廊道中的桩号范围、点的选择（来自模板中的可用点）和控件选项类型，定义廊道中水平和/或垂直控件。
创建关键桩号 | 在提示廊道选择和桩号（动态输入或通过键入命令）之后，桩号将添加到廊道进行处理。这用于当项目发生特殊情况且需要将不与模板间隔重合的桩号包括在处理中时添加相应桩号。
创建次要路线 | 设置次要路线的参数，用于修改横截面处理的方向。要求包括廊道选择，次要路线定义、起点和终点桩号（在仅使用部分路线元素的情况下）以及起点和终点偏移。
参数化约束 | 为替代指定的桩号范围设置约束值。
曲线加宽 | 将水平控件应用于点，使其在控制路线的每条曲线处朝远离中心线的方向移动。
创建末端条件异常 | 定义末端条件异常，它们用于修改末端条件解的行为，而无需使用其他三维路面。
廊道对象 | 一站式查看与廊道对象相关的数据。非常适合管理廊道数据，因为它包含三维路面、关键桩号、参数化约束、点控件、各种参考和末端条件异常，所有这些内容都在一个对话框内。
更新廊道 | 处理廊道以确保它为最新版本。
编辑三维路面
编辑
廊道对象
更新廊道
父主题: 廊道


编辑三维路面

用于编辑选定三维路面内的模板。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑

“编辑三维路面”工具显示在选定三维路面内定义的模板。尽管该对话框为模板库界面，但记住，仅对三维路面内的模板（而不是实际的模板库）进行编辑。因此，如果已进行任何更改，则与三维路面关联的模板将不再与模板库同步。对于项目特定情况，可能需要这样做。除了“文件”工具不可用以外，编辑三维路面内的工具和选项与模板库中的工具和选项其功能完全相同。

如果模板库中需要更改，则使用“创建模板”工具。

要更新与三维路面关联的模板以匹配模板库中的模板，请使用“与库同步”工具。使用此工具后，模板库中的模板将覆盖与三维路面关联的模板，因此所有更改均会丢失且不会发出警告。

有关功能的详细讨论，请参阅“模板库”帮助。

工作流

  1. 选择“编辑三维路面”工具。

  2. 定位三维路面。选择需要编辑其模板的三维路面。将打开“编辑 Roadway Designer 三维路面”对话框（其界面与“模板库”对话框相同）以及当前模板。

  3. 根据需要进行编辑。单击“确定”关闭此对话框。不必使用“文件”>“保存”来保存编辑（大多数“文件”功能均已变为重影）。

父主题: 廊道编辑


编辑

创建末端条件异常
创建关键桩号
创建次要路线
创建参数化约束
创建曲线加宽
创建点控制
父主题: 廊道编辑


创建末端条件异常

用于修改末端条件解的行为，而无需使用其他三维路面。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

在许多情况下，需要使道路的主结构保持不变，但需要更改新设计与曲面相交的条件。执行此操作的方法之一是用相同的主结构组件和新的或不同的末端条件组件创建新模板；然后，将这个新模板放在相应的桩号。这种方法的问题在于 1) 创建的模板过渡必须进行解析；2) 设计左右两侧的条件可能在不同的位置发生变化，可能需要大量略有不同的模板来满足所有可能的组合（还需要很多三维路面）。这种情况的解决方案是末端条件异常。末端条件异常用于修改末端条件解的行为，而无需使用其他三维路面。添加末端条件异常时，必须对其进行编辑以更改其行为。末端条件异常分为两类：

• 替代

• 过渡

对话选项

名称 | 显示激活廊道的名称。
将 ECT 应用于 | 左侧替代 - 替代左侧末端条件解。 右侧替代 - 替代右侧末端条件解。 左侧缓和段 - 在指定范围内为左侧末端条件解设置过渡区。 右侧缓和段 - 在指定范围内为右侧末端条件解设置过渡区。 仅主结构(左) - 表示在左侧的桩号范围内不应用末端条件。 仅主结构(右) - 表示在右侧的桩号范围内不应用末端条件。
起点 | 指定末端条件异常的起点桩号。通过键入命令或使用定位功能标识桩号。
停止 | 指定末端条件异常的终点。通过键入命令或使用定位功能标识桩号。
末端条件异常替代
末端条件异常过渡
父主题: 编辑


创建关键桩号

用于当项目发生特殊情况且需要在处理中加入不与模板间隔重合的桩号时添加相应桩号。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

“创建关键桩号”工具用于当项目发生特殊情况且需要在处理中加入不与模板间隔重合的桩号时添加相应桩号。

工作流

  1. 选择“创建关键桩号”工具。

  2. 定位廊道 - 选择要添加桩号的廊道。将显示一条动态垂直于参考基线的显示线。

  3. 桩号 - 通过以下方式定义关键桩号：将显示内容动态移至所需的位置（并点击确认），或者通过键入关键桩号，在按住 <Enter> 键的同时点击确认进行接受。关键桩号将添加到“关键桩号”列表，廊道会自动重新处理以包括新桩号。

父主题: 编辑


创建次要路线

用于修改横截面处理的方向。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

次要路线用于修改横截面处理的方向。缺省情况下，在任何给定桩号，创建的横截面与主路线正交。如果存在次要路线，则位于次要路线之外的那部分横截面将与次要路线（而非主路线）正交。

在左图中，路面的坡道边缘（用绿色表示）添加为廊道参考，而不是作为次要路线添加到南北向廊道。请注意，垂直于南北向廊道处理横截面将斜切坡道。在右图中，坡道作为次要路线添加到南北向廊道。请注意，垂直于南北向廊道处理横截面将在与次要路线的交点处“纽结”，因此垂直于路面坡道边缘。结果是，坡道上 1:6 的末端条件斜率为从路面边缘（本例中为右坡道边缘）开始的真实 1:6 斜率。

注释: 左图 - 坡道边缘（深绿色）不用作次要路线

右图 - 坡道边缘（深绿色）用作次要路线

工作流

  1. 选择“次要路线”工具。

  2. 定位廊道 - 选择要添加次要路线的廊道。

  3. 定位次要路线 - 选择要用作次要路线的元素。

  4. 起点桩号 - 可以动态定义或通过键入值来定义。这样可以使用所选元素的一部分作为次要路线。

  5. 终点桩号 - 可以动态定义或通过键入值来定义。这样可以使用所选元素的一部分作为次要路线。

  6. 起点偏移 - 与次要路线的起点桩号的水平偏移。如果不需要偏移，则设置为 0。

  7. 终点偏移 - 与次要路线的终点桩号的水平偏移。如果不需要偏移，则设置为 0。廊道会自动重新处理以合并次要路线数据。

父主题: 编辑


创建参数化约束

用于在 Roadway Designer 中处理模板时更改模板的一个或多个标记约束值。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

参数化约束可用于在 Roadway Designer 中处理模板时更改模板的一个或多个标记约束值。单击“工具”>“参数化约束”。这样只需使用一个模板即可处理许多不同的条件。该过程包括两个步骤。

  1. 向要控制的约束添加标签。此操作在“创建模板”命令中完成。

  2. 指定新的约束值及其在 Roadway Designer 中适用的桩号范围。这通常用于在指定范围内更改路面厚度。

所有约束均可包含参数化标签。

父主题: 编辑


创建曲线加宽

用于自动创建和应用水平控件以拓宽曲线附近的车道和/或铺装线边缘，使其在控制路线的每条曲线进一步远离中心线。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

曲线加宽用于自动创建和应用水平控件以拓宽曲线附近的车道和/或铺装线边缘，使其在控制路线的每条曲线进一步远离中心线。此工具与包含加宽参数的 ASCII 文件 (*.wid) 结合使用。

加宽表文件格式

加宽表是一种 ASCII 格式，用户在使用曲线加宽工具时将指向该格式。因此，该文件可以存储在中央服务器位置，供企业使用。虽然可能有多个加宽表，但是每次处理只能使用一个表。如果廊道的设计速度发生变化，需要不同的表，则必须多次使用该工具。

位置:

Rad = 半径

Wi = 曲线内侧加宽

Li = 曲线内侧过渡长度

Wo = 曲线外侧加宽

Lo = 曲线外侧过渡长度

构建该表时，任何以 ; 或 * 开头的行都将被忽略。半径值需要按从最小到最大的顺序排列，并且应该有一个 0 值，以便处理所有情况。

计算加宽
曲线加宽工作流
父主题: 编辑


创建点控制

用于替代一个或多个点和/或组件在横截面中的正常位置。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑 > 编辑拆分按钮

点控件用于替代一个或多个点和/或组件在横截面中的正常位置。此类示例包括：车道加宽、保持路权、保持沟渠的特定坡度以及超高。

在以下示例中，坡道正合并到主干道中。坡道左边缘由路面的主干道右边缘垂直控制。坡道左边缘由主干道右边缘从 0+00 到 1+00 水平控制，然后由名为 rampLeft 的平面路线控制。

桩号限制（起点/终点）

指定要控制的起点和终点桩号。

控制描述

您可以输入控制的描述。

点

您可以选择要控制的点。从列表中选择或使用“定位”按钮标识横截面中的点。选定的点在平面图/横截面和纵断面或超高视图（如果适用）中高亮显示。

模式

您可以选择控制模式：“平面”、“纵面”或“两者”。

控制类型

指定控制类型。

如果模式为“平面”或“两者”，则有效控制类型为“线性几何”、“特征定义”或“廊道特征”。

如果模式为“纵面”，则有效控制类型为“线性几何”、“特征定义”、“廊道特征”、“超高”、“高程偏差”、“高程和坡度”。

显示的选择组合框和/或字段取决于选定的“模式”和“控制类型”。

类型 - 线性几何

如果类型为“线性几何”，则显示“水平偏移”组合框。如果模型为“两者”，则还显示“竖向偏移”组合框。

类型 - 特征定义

如果类型为“特征定义”，则显示“特征定义”和“范围”文本字段。

类型 - 廊道点

对于所有模式，将显示“廊道”和“参考特征”组合框。这些选项允许您根据另一个廊道点设置一个廊道点的控制。

瞄准另一个廊道点不能与同一廊道的“目标别名”同时进行。如果已定义“目标别名”，则在“点控制 (Point Control)”对话框内无法选择“廊道点”。这会产生递归情况，使得廊道点控制无法选择，直到移除目标别名为止。

类型 - 超高

此选项显示“超高”控制线组合框和“参考点”组合框。超高控制线存储在路面设计中，而不是在路线上。参考点是点旋转时所围绕的枢轴点（特征）。

类型 - 高程偏差

此选项显示“平面路线”和“纵面路线”组合框。纵面路线表示要应用于点的当前高程的纵面偏差值。

类型 - 高程和坡度

此选项显示“高程”字段和“坡度”字段。该控制将起点桩号处的点高程设置为指定的高程。然后，点线的斜率为指定的坡度，直到达到终点桩号为止。

用作次要路线

指定平面点控制也用作次要路线。此选项仅在使用二维实体时可用。如果使用的是三维对象，则软件会跳过次要路线选项。

水平偏移（起点/终点）

指定廊道水平偏移控制的起点和终点。如果值不同，则使用线性算法计算在给定桩号处应用的值。

竖向偏移（起点/终点）

指定廊道竖向偏移控制的起点和终点。

优先级

确定点上的控制顺序。仅当点上的控制存在冲突时，此值才适用。如果存在冲突，则应用具有较低优先级的控制（即，首先应用较低的数字）。

父主题: 编辑


廊道对象

用于管理数据，因为它是所有廊道建模对象的摘要。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑

“廊道对象”对话框是所有廊道建模对象的摘要，提供绝佳的数据管理方法。单击位于对话框左侧的各种类别将显示中心剖面中的相应数据。单击任意显示中的单线会将信息放置在对话框的右侧布局上，在此处可以编辑大多数信息。

仅在已选择起点或终点桩号时，才能执行图形编辑。

父主题: 廊道编辑


更新廊道

用于选择重新处理的廊道。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 编辑

选择重新处理的廊道。选定廊道中的所有对象均会重新处理。

父主题: 廊道编辑


廊道杂项

在工具箱中选择 | 描述
定义目标别名 | 为廊道定义目标别名。处理多个曲面时可以使用目标别名创建所需结果，而不必编辑模板库中的模板。
同步模板 | 使用当前模板库中的同名模板更新三维路面内的模板。系统会覆盖之前对三维路面中的模板所做的全部更改且无警告。
添加廊道参考 | 用于向廊道中添加选定的图形元素并重新进行处理。廊道建模中通过特征成为目标的图形元素在添加为廊道参考后才能使用。示例包括路肩、路缘、人行道等。这样，用户便可以一个路面上的特定路肩为目标，同时通过将元素引用至特定廊道来忽略相邻路面上的路肩。元素可被引用至多个廊道。
删除廊道参考 | 用于从廊道中移除选定的图形元素（之前通过“添加廊道参考”加入的元素）并重新进行处理。
添加剪切参考 | “剪切”功能可用于在使用 MicroStation 元素或多个廊道时移除重叠区域。在下面的插图中，矩形（MicroStation 元素）被定义为廊道的剪切参考。因此，系统会“剪切”或删除矩形内廊道的所有元素，只剩下平面几何图形元素。如果处理多个廊道且某个廊道与交叉路面（由另一个廊道定义）相交，则可使用剪切来移除交叉部分内的所有重叠特征。
删除剪切参考 | 移除剪切参考并在无任何参考的情况下重新处理廊道模型。此操作并不删除实际的剪切参考元素。
调整竖向覆盖关系 | 在每个已处理的桩点处，此命令根据输入条件和模板顶部到现有地面的距离来确定理想的 PGL 点。
导入 IRD | 导入 (SELECTseries 2) 和 Roadway Designer (IRD) 文件中包含的较低版本的廊道。
定义目标别名
廊道参考
廊道剪切
同步模板
调整竖向覆盖关系
父主题: 廊道


定义目标别名

用于瞄准其他廊道表面或特征，或者为表面、特征和对齐的末端条件解决方案设置已区分优先级的目标列表。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项

目标别名用于瞄准其他廊道表面或特征，或为表面、特征和对齐的末端条件解决方案设置已区分优先级的目标列表。这意味着在某项现有表面可能被打碎成多个表面的大型作业中，则无需担心这些断点发生在何处，也无需为每个现有表面创建不同的模板。使用目标别名查找适当的解决方案。

在激活表面为目标的任何情况下，由于您已启用该选项，因此该软件将查找主线廊道表面并使用较近的表面。如果未设置“使用最接近的值”选项，则该软件将按照显示顺序搜索表面，并在找到解决方案之后立即停止。

目标别名不能定义为使用“廊道点控制”瞄准该特定廊道的廊道。这会产生递归情况，使廊道不可用于目标别名，直到移除该廊道点控制为止。

设置 | 描述
目标 | 列出当前廊道的末端条件目标，不列出特征定义目标。
表面或廊道 | 列出当前目标的所有可用别名。如果目标是表面，则显示备选表面和廊道的列表。如果目标是特征，则列表显示可用的表面特征和廊道点。如果目标是对齐，则显示可用对齐的列表。
别名 | 列出当前目标的别名。列表顺序表示目标别名的优先级。
“添加”、“移除”、“上移”、“下移” | 在选择项时激活。左右按钮用于在列表之间移动项。可以选择和移动多个项。上下按钮用于通过在列表中上移或下移来更改单个项在别名列表中的优先级。
使用最接近的值 | 选中后，将忽略别名顺序。该解决方案查找满足该解决方案（末端条件）的最近的别名。

工作流

  1. 选择“定义目标别名”工具。
  2. 选择廊道，这将打开“目标别名”对话框。
  3. 使用“添加”、“移除”、“上移”、“下移”和“使用最接近的值”设置“目标别名”。
父主题: 廊道杂项


廊道参考

添加廊道参考
删除廊道参考
父主题: 廊道杂项


添加廊道参考

用于将图形元素添加到廊道处理中。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项 > 廊道参考拆分按钮

“添加廊道参考”工具将图形元素添加到廊道处理中。即使在模板中以特征为目标，也必须执行此操作，否则将不会处理元素。它仅启用与要处理的特定廊道相关联的那些元素，而不是特定特征定义的所有元素。这可以加速处理，而且不处理相同特征定义中不需要的元素。您可以在工具中选择元素，也可以在开始使用工具之前创建一个选择集。

工作流

  1. 选择“添加廊道参考”工具。
  2. 选择“廊道”。
  3. 选择第一个参考元素 - 选择要添加为参考的图形元素。
  4. 继续选择，直至所有元素均被参考，然后重置以退出工具。
父主题: 廊道参考


删除廊道参考

用于从廊道处理中移除图形元素，但不删除该元素。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项 > 廊道参考拆分按钮

“删除廊道参考”工具将从廊道处理中移除图形元素，但不删除该元素。您可以在工具中选择元素，也可以在开始使用工具之前创建一个选择集。

工作流

  1. 选择“删除廊道参考”工具。
  2. 选择“廊道”。
  3. 选择“第一个参考元素” - 选择要移除的图形元素作为参考。
  4. 继续选择，直至所有元素均被参考，然后重置以退出工具。
父主题: 廊道参考


廊道剪切

添加剪切参考
删除剪切参考
父主题: 廊道杂项


添加剪切参考

用于在单个表面中使用多个廊道的情况下移除重叠区域。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项 > 廊道剪切拆分按钮

“剪切”功能可用于在单个表面中使用多个廊道的情况下移除重叠区域。例如，在与交叉路面相交的廊道中，剪切将用于移除交集内的所有重叠特征。

工作流

  1. 选择“添加剪切参考”工具。
  2. 选择要剪切的廊道。
  3. 定位剪切参考 - 选择元素，直至全部都定义完毕，然后重置以完成。系统即会处理廊道并添加剪切参考。
父主题: 廊道剪切


删除剪切参考

用于移除剪切参考、重新处理廊道、将剪切区域恢复到剪切之前的状态。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项 > 廊道剪切拆分按钮

“删除剪切参考”工具将移除剪切参考、重新处理廊道、将剪切区域恢复到剪切之前的状态。

工作流

  1. 选择“添加剪切参考”工具。选择要移除剪切的廊道。定位剪切参考 - 选择元素，直至全部都定义完毕，然后重置以完成。系统将处理廊道并移除剪切参考。
父主题: 廊道剪切


同步模板

用于从库中重新加载模板。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项

“同步模板”工具从库中重新加载模板。之前对“廊道模型 (Corridor Model)”中的模板所做的任何编辑都将丢失，并且未给出警告。

工作流

选择“同步模板”工具。

父主题: 廊道杂项


调整竖向覆盖关系

根据输入标准以及从模板顶部到现有地面的距离确定理想的 PGL 点。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 杂项

在每个已处理的桩点处，此命令根据输入条件和模板顶部到现有地面的距离来确定理想的 PGL 点。通过测量地面点与模板顶部之间的垂直距离来测试横截面中的每个现有地面顶点。

几何图形和廊道必须在同一 DGN 文件中，此命令才能操作。

如果几何图形在参考文件中，则此命令不可用，因为此命令会创建纵面路线，廊道必须重新处理以确定纵面路线标准。

调整竖向覆盖关系对话框

设置 | 描述
主结构厚度 | 指定从纵断面梯度线 (PGL) 高程到主结构组件底部的厚度（竖向距离）。此值将添加到通过查找“最小压碾/重叠”控制点计算得出的中心线高程。

下面 4 幅图像均定义了主结构厚度。

  1. 调整垂直高程
  2. 主结构厚度
  3. 最小重叠
  4. 最小重叠 = 0.0'
  5. 最小压碾点
  6. 最大压碾
设置 | 描述
最小模式 = 最小重叠 | 指定后，对在垂直方向上最靠近主结构底部的点进行曲面求值。然后，使用此控制点的高程沿主结构底部计算中心线处的高程。 在该图中，红色圆圈表示最靠近主结构的点。黄色虚线表示放置在该控制点上的模板底部。将中心线位置处的“最小重叠”值与“主结构厚度”相加即得出新的调整垂直高程。 该图显示“最小重叠”值为 0.0'，并定义了主结构厚度。
最小模式 = 最小压碾 | 指定后，对在垂直方向上距离主结构最远的点进行曲面求值。然后进行纵面调整，将主结构直接放在该控制点上。
启用“使用最大压碾”情况下的“最小压碾” | 该图显示在指定了“最大压碾”值的情况下使用“最小压碾”放置的模板。若无“最大压碾”值，模板将放置在红色控制点上；但是，将模板放置在该点将违反所示位置（以及右侧区域）的最大值。因此，改为将模板放置在“最大压碾”深度的点。
最大纵面偏差 | 如果此值大于 0.0，则程序会将当前桩号的调整垂直高程与在上一个桩号计算得出的高程进行比较，并确保两个高程之差不超过此值
父主题: 廊道杂项


超高

此工具箱包含用于创建、计算和编辑超高车道的工具。这些工具还支持导入 CSV 数据和报告。

在工具箱中选择

描述
创建
  • 创建超高区间
  • 创建超高车道
  • 使用道路模板创建超高车道

创建超高区间 - 为基线参考上的指定桩号范围添加超高区间（每个曲线集通常一个）。

创建超高车道 - 基于宽度和相对于基线参考的偏移创建彩色填充的车道，作为超高计算的前体。

使用道路模板创建超高车道 - 这是创建可以应用超级计算的超高车道的替代方法。
计算
  • 计算超高
  • 编辑超高规则文件
  • 导入超高
  • 将超高指定给廊道

计算超高 - 基于规则文件计算桩号和超高过渡比率。基于横坡，将这些值扩充到超高车道、创建编辑操控器、重新着色颜色填充。

编辑超高规则文件 - 编辑 XML 格式的超高规则文件。

导入超高 - 通过 CSV 文件导入超高值。

将超高指定给廊道 - 将超高与廊道关联，这样，路面将反映超高桩号/横坡，而不是模板中的路面横坡缺省值。
编辑
  • 插入超高桩号/横坡
  • 超高编辑器

插入超高桩号/横坡 - 将单个桩号/超高过渡（横坡）插入之前创建和计算的超高车道。

超高编辑器 - 打开超高编辑器。

超高报表

创建超高 XML 报表并打开 Bentley Civil 报表浏览器。

打开超高视图

直接在 MicroStation 视图中打开可编辑的超高图。
超高概述
创建
计算
编辑
超高报表
打开超高视图
父主题: 廊道


超高概述

超高工具用于计算在平面路线中应用于曲线与缓和曲线的倾斜程度，以帮助抵消离心力。这些命令还可计算路面如何形成从普通路拱到完全倾斜曲线再从完全倾斜曲线返回到普通路拱的过渡。

可以通过两种方式计算超高：

  • 基于规则 - 使用基于 XML 的规则文件，过渡中的桩号和关联横坡基于设计速度、曲率和其他设计参数。随着设计进度和参数的变化（即，设计速度例外情况），可以重新处理超高的修订参数。

  • 导入 - 使用逗号分隔值 (CSV) 文件，导入每个过渡的桩号和关联横坡。在此选项中，不使用这些规则；数据仅应用于超高车道。

超高的计算结果是超高车道图形，并且横坡属性存储在 DGN 文件中。超高数据可以位于自己的 DGN 文件中，也可以使用几何图形、廊道等元素绘制成任何其他项目 DGN 文件。可以在廊道模型中引用此文件并与其相关联，这样，超高过渡将融入廊道模型中。

先决条件

要创建超高，至少需要满足以下要求：

  • 一个土木平面几何图形元素。

  • 超高率和过渡值，这些数值可以使用“超高规则”文件计算、可以在 CSV 文件中定义，也可以导入。

要向廊道添加超高数据，您将需要：

  • 超高车道。

  • 为车道分配超高率和过渡（已计算或已导入）。

  • 廊道，其模板具有针对控制点的超高标记（适用于关联步骤）。

设置

在超高工具中使用以下两组设置。应该先在绘制车道前对它们进行设置。这些值并非必填值，而是用户首选项。

  • 超高车道的填充设置。

  • 元素处理程序的小数位设置。

填充设置

位于“文件”>“设置”>“用户”>“首选项”>“视图选项 - 土木”下。“超高设置”类别具有控制超高车道显示的选项。这些设置是用户首选项，将应用于用户打开的所有文件。

选项 | 描述
彩色阴影填充 | “彩色阴影填充”将在计算完成后填充超高通道。着色是基于横坡的硬编码： 坡度 < -10% = 蓝色。 -10% <= 坡度 <= -0.5% = 计算的颜色介于绿色与蓝色之间。 -0.5% < 坡度 < 0.5% = 白色。 0.5% <= 坡度 <= 10% = 计算的颜色介于黄色与红色之间。 坡度 > 10% = 深红色。 基于道路的一边，颜色翻转。除了设置此选项以外，还必须打开“填充视图属性”。
仅边界 | 在此选项中，仅显示每条车道的外部边界，并可选择。
无 | 超高车道/编辑图柄不会显示，但它们仍在文件中。要显示它们，请设置为其他两个选项之一。

桩号设置和小数位设置

位于“文件”>“设置”>“文件”>“设计文件设置”下。“土木格式设置”类别列表具有控制元素处理程序显示的选项。这些设置对于超高来说不唯一；在所有土木产品中使用相同的设置。这些设置特定于文件，应在种子文件中进行设置，因此，这些设置会自动传播到所有项目 dgn 文件。

选项 | 描述
桩号设置：格式 | 控制分隔符后的位数。
桩号设置：格式分隔符 | 控制分隔符，通常为加号 (+)。
桩号设置：精度 | 定义桩号设置的小数位数。
纵断面设置：坡度格式 | 用于横坡编辑处理程序。对于超高，通常设置为百分比。
纵断面设置：坡度精度 | 定义横坡编辑处理程序中的小数位数。
超高常规工作流
浏览器 - 超高
属性 - 超高
父主题: 超高


超高常规工作流

在以下步骤中介绍超高的常规工作流。步骤 4-6 可以不同的顺序完成，且所有步骤并非均必需。

  1. 创建超高区间。

  2. 定义车道。

  3. 计算超高过渡段和横坡。

  4. 查看并根据需要编辑。

  5. 添加辅助车道。

  6. 关联到廊道。

  1. 创建超高区间

    在此第一步中，已确定土木平面几何元素并定义超高桩号限制。如果平面几何元素的长度明显超过项目限制，则桩号限制非常有用。

    在基本项目中，通行车道路面配置一致（即，所有双车道乡村道路都有几个转弯车道），可以使用单个剖面。但是，如果道路发生重大变化，例如，从双车道乡村道路变为四车道分隔式道路，则应创建独立剖面。

    原则上，如果您使用基于规则的计算，并且通行车道配置或枢轴法发生更改，则创建一个新的剖面。这些变化应以通行车道为基础，因为转弯车道、坡道入口和出口以及重车爬坡道等辅助车道单独进行处理。如果导入超高，则可以对整条路线使用一个剖面。

    或者，可以选择廊道而不是路线。选择廊道时，会提示您输入超高 xml 文件，程序将创建沿廊道路线的剖面，根据廊道横截面自动创建车道（第 2 步），计算超高（第 3 步），并为廊道分配超高（第 6 步），所有操作均在一个步骤中完成。注意：要为廊道分配超高（第 6 步），廊道必须存在于激活 dgn 文件中。

    另请参阅创建超高区间

  2. 定义车道

    定义区间之后，定义车道。专注于通行车道，因为可以随时添加转弯车道和间歇车道。通过选择平面几何和偏移来定义车道。还定义了用于后续计算的默认横坡。此步骤的结果是绘制图形车道（使用绿色和黄色填充，没有颜色选择）。

    另请参阅创建超高车道

  3. 计算超高过渡段和横坡

    在此步骤中，使用超高率文件中的参数计算过渡段长度和横坡，并将其存储为超高车道图形的一部分。如果启用填充，则很容易看到结果，因为车道根据横坡从纯黄色和绿色变为渐变颜色。选择车道时，桩号和横坡显示为可编辑文本。

    或者，可以从包含桩号和横坡的文本文件中将横坡导入为逗号分隔值 (CSV)，这些文件由外部程序（或手动）计算。

    另请参阅计算超高

  4. 查看并根据需要编辑

    有多种方法可以查看超高数据并根据需要进行编辑。高亮显示区间将显示桩号和横坡值以供查看和编辑。通过选择灰色楔体并拖到所需的桩号，可以动态更改桩号设置。可以独立于相邻车道操作每个车道。可以通过选择桩号文本来键入所有桩号。

    超高编辑器可用于以表格格式编辑数据。在编辑器中进行的任何更改都会自动与图形车道同步，反之亦然。可以自定义编辑器中的字段，以便隐藏未使用或不需要的字段。由于计算期间使用的约束，无法编辑任何灰色数据。

    显示动态超高图的超高视图也可用于编辑定义。

  5. 添加辅助车道

    在此过程中，可以随时在任何剖面添加额外的通道。可以添加主车道（基于规则的车道）或辅助车道（具有用户指定的横坡的车道）。这一步的结果是图形超高车道。

  6. 关联到廊道

    在该过程中，可以随时将超高车道与廊道相关联。如果超高车道与廊道位于不同的文件中，则您必须位于廊道文件中，并附加超高车道作为参考。它们可以处于同一文件中。

    此步骤的操作结果是超高路面会反映在廊道模型中。

    另请参阅将超高指定给廊道

父主题: 超高概述


浏览器 - 超高

可以在资源管理器中查看（并在某些情况下修改）超高信息。上下文相关菜单因区间、车道或过渡段的选择而异。

选定区间之后，完整的超高工具集位于上下文相关菜单内，同时还有“属性”和“删除”。选定车道之后，可以移除过渡段而不删除车道。可以在车道的桩号范围内添加新桩号/过渡段。

父主题: 超高概述


属性 - 超高

属性提供不同的信息，具体取决于选定的是区间、车道还是过渡段。

区间

区间的属性提供标准文件，以及在“创建超高车道”过程中使用的其他信息（即设计速度、过渡段类型等）和桩号范围。

对象

车道

车道的属性提供了桩号范围、偏移、车道类型和默认横坡。

过渡段

过渡段的属性提供了过渡段数据（例如过渡段类型、旋转轴位置和横坡）、桩号和约束信息。

尽管超高工具位于“廊道模型”任务导航面板内，但车道的定义和计算独立于廊道模型完成。超高的结果是图形车道，其中附加超高过渡段/属性。它们可以与廊道模型位于同一文件中，也可以位于自己的 DGN 文件中并进行参考。

在利用超高信息之前，路面坡度由模板指示。超高车道可以在设计过程中随时应用于廊道。请记住，您必须位于包含廊道的设计文件中，因为关联超高会更改廊道内的路面坡度。

“将超高指定给廊道”工具将提示输入以下信息：

  • 要分配给廊道的超高区间

  • 廊道选择

将超高分配给廊道，并从模板自动确定点控制并显示。

如果信息正确，请单击“确定”以完成该过程。如果不正确，请调整错误的点并单击“确定”，或单击“取消”关闭对话框，然后查看廊道和/或模板以确定问题。

父主题: 超高概述


创建

创建超高区间
创建超高车道
使用道路模板创建超高车道
父主题: 超高


创建超高区间

为基线参考中指定的桩号范围创建超高区间，以标出一段路面进行超高计算。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 创建拆分按钮

在此工具中，已确定土木平面几何元素并定义了超高桩号限制。如果平面路线的长度明显超过项目限制，则桩号限制非常有用。使用所选特征定义绘制剖面。

如果选择了廊道，则会提示用户提供超高 xml 文件，程序将创建沿廊道路线的剖面，根据廊道横截面自动创建车道，计算超高，并为廊道分配超高，所有这些操作均在一个步骤中完成。要为廊道分配超高（最后一步），廊道必须存在于激活 dgn 文件中。

剖面确定

通行规则是，如果您使用基于规则的计算，并且通行车道配置、速度或枢轴/旋转法发生了更改，则创建一个新的剖面。在基于规则的基本项目中，如果通行车道路面配置一致（例如，均为具有几个转弯车道的双车道乡村道路），则可以使用单个剖面。但是，如果道路发生重大变化，例如，从双车道乡村道路变为四车道分隔式道路，则应创建独立剖面。这些变化应以通行车道为基础，因为转弯车道、坡道入口和出口以及重车爬坡道等辅助车道单独进行处理。但是，必须在单个剖面内绘制辅助车道。

如果从 CSV 文件导入超高，则可以对整条路线使用一个剖面。与使用一个大剖面相比，为每条曲线提供曲线集的优点在于能够针对单个或两个曲线集重新处理规则。由于在导入的项目中不使用规则，因此除了在编辑器中提供更短的零散报告和更细的粒度之外，单独的曲线集没有任何用处。

曲线间的最小切线 (Minimum Tangent Between Curves)

“曲线间的最小切线 (Minimum Tangent Between Curves)”值是如何定义曲线集的决定因素。使用基于规则的计算时，有时您需要重新处理部分超高计算，这可能是由于平面几何变化或设计速度修订所致。如果您的项目是一个大剖面，则将对整个剖面执行重新处理，并覆盖任何手动编辑。曲线集支持处理一条或多条曲线，同时手动操控集保持不变，十分灵活。在以下示例中，曲线间的距离为 234.57 主单位。

以下结果说明了“曲线间的最小切线 (Minimum Tangent Between Curves)”产生的影响。

基于剖面的平面几何工作流

  1. 将 MicroStation 线符设置为所需的线符。

  2. 选择“创建超高区间”工具。

  3. 按照危险警告提示操作。

    提示

    用户操作

    名称

    为每个剖面命名，对于具有多个剖面的项目，建议通过软件向路线名称附加 -1、2 等。如果您有多个廊道，请对剖面使用唯一的名称。

    定位廊道或路线

    选择要用作超高车道和计算依据的路线。

    起点桩号

    以图形方式定义（基于垂直于参考单元的虚线）剖面的起点。也可以键入和锁定桩号。在键盘上按 <ALT> 键将起点桩号缺省为并锁定到元素的起点。

    终点桩号

    以图形方式定义（基于垂直于参考单元的虚线）剖面的终点。也可以键入和锁定桩号。在键盘上按 <ALT> 键将终点桩号缺省为并锁定到元素的终点。

    曲线间的最小切线 (Minimum Tangent Between Curves)

    输入一个值（以主单位表示）。如果两条相邻曲线之间的切线距离小于指定值，则两条曲线和相邻切线将包括在一个超高区间中。如果两条相邻曲线之间的切线距离大于指定值，则每条曲线和相邻切线的一半将包括在每个超高区间中。输入一个大于总路线长度的值，以创建单个超高区间。

    完成此提示操作后，绘制各个剖面，软件自动进入“创建超高车道”工具。

基于廊道的剖面工作流

  1. 将 MicroStation 线符设置为所需的线符。

  2. 选择“创建超高区间”工具。

  3. 按照危险警告提示操作。

    提示

    用户操作

    名称

    为每个剖面命名，对于具有多个剖面的项目，建议通过软件向路线名称附加 -1、2 等。如果您有多个廊道，请对剖面使用唯一的名称。

    定位廊道或路线

    选择要用作超高车道和计算基础的廊道。

    选择 XML 规则文件 (Select XML Rule File)

    选择包含超高标准/参数的 XML 格式的规则文件。使用 <ALT> + 向下箭头键可打开“文件管理器”以选择目录/文件。接受数据提示并移至下一提示。

    曲线间的最小切线 (Minimum Tangent Between Curves)

    输入一个值（以主单位表示）。如果两条相邻曲线之间的切线距离小于指定值，则两条曲线和相邻切线将包括在一个超高区间中。如果两条相邻曲线之间的切线距离大于指定值，则每条曲线和相邻切线的一半将包括在每个超高区间中。

    输入一个大于总路线长度的值，以创建单个超高区间。

    完成此提示后，绘制各个剖面，软件自动进入“创建超高车道”。
父主题: 创建


创建超高车道

创建可以应用超级计算的超高车道。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 创建拆分按钮

超高车道定义超高区域的平面几何、偏移和横坡。有两种类型的超高车道。

  • 主车道 - 在定义车道时指定标准段横坡，然后在计算超高时根据超高率文件计算横坡或从 CSV 文件导入横坡。主车道延伸整个剖面长度。起点和终点桩号由剖面定义。主车道通常是贯穿整个项目的通行车道。

  • 辅助车道 - 横坡是用户指定的固定值或自动设置为与邻近超高车道匹配。辅助车道具有用户指定的起点和终点桩号，但必须在单个剖面内。辅助车道是沿路线添加和删除的车道，如转弯车道。

生成的超高车道在 DGN 文件中绘制为图形。超高车道的颜色（绿色和黄色）属于硬编码，不能更改。

在此过程中，可以随时在任何剖面添加额外的通道。

通行车道的工作流
辅助项的工作流
父主题: 创建


使用道路模板创建超高车道

此备选方法用于创建可以应用超级计算的超高车道。

您可以通过以下方式访问此工具：

功能区：“廊道”>“超高”>“创建”拆分按钮。

主要超高车道可以通过读取道路模板自动进行定义。这是一种创建超高车道的备选方法，它将使用指定模板的宽度和横坡以及超高规则文件中指定的参数。如果该模板已标记超高点，则可从道路模板获取车道宽度和坡度，而不必输入。

生成的超高车道在 DGN 文件中绘制为图形。超高车道的颜色（绿色和黄色）属于硬编码，不能更改。

在此过程中，可以随时在任何剖面添加额外的通道。

工作流

  1. 验证模板是否已为用作候选超高点的所有路面点设置超高标记。除了提到的其他用途之外，此标记还可用于自动设置车道宽度和横坡。结果将生成图形主车道。由于尚未进行任何计算，因此尚无过渡。
  2. 依次选择“超高”和“使用道路模板创建超高车道”命令。
  3. 按照危险警告提示操作。
提示 | 用户操作
定位第一个超高断面 | 选择第一个剖面。
定位下一个超高剖面 - 或重置可完成 | 重置以移动到下一个提示。
选择模板 - 按 <Alt> + 下箭头键浏览模板 | 选择键盘上的 <Alt> <Down> 以打开激活模板库并选择模板。点击确认以接受模板并完成命令。
父主题: 创建


计算

计算超高
编辑超高规则文件
导入超高
指定给廊道
父主题: 超高


计算超高

计算过渡的桩号和横坡。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 计算 (Calculate) 拆分按钮

有两种方法可以定义超高率和过渡长度：在软件中计算该数据，或者导入该数据。通常选择一种方法即可；不过，也可以混合使用这两种方法，即对某部分项目使用计算，对其他部分使用导入。

“计算超高”工具用于计算关键桩号处的横坡，以沿超高车道定义过渡。横坡和过渡长度使用“超高规则”文件中定义的规则、表和设置进行计算。

计算的超高结果将添加到之前创建的超高车道。如果填充视图属性开启，很容易看到结果，因为车道会根据横坡从纯黄色和绿色更改为渐变色。

选择超高车道时，将显示可用于直接编辑桩号和横坡的文本操控器。下图显示的是道路的同一剖面在未选择超高车道（上图）的情况以及在选择超高车道（下图）时每个过渡桩号处有文本操控器的情况。此外，也可以在“超高编辑器”和“超高”视图中编辑这些桩号和横坡，如其他部分所述。

工作流

1.选择“计算超高”工具。

2.按照危险警告提示操作：

提示 | 用户操作
定位第一个超高断面 | 选择第一个剖面。沿对角线方向拖动光标框选所需的全部区间，而不必分别选择每个区间。对角线定义一个正方形，该正方形必须包围整个区间才能将其包含在内。
定位下一个超高区间，或重置以完成操作 | 继续选择区间直到所有区间均高亮显示，然后重置以移至下一个提示。
规范文件 | 选择包含超高标准/参数的 XML 格式的规则文件。使用 <ALT> + 向下箭头键可打开“文件管理器”以选择目录/文件。接受数据提示并移至下一提示。
注意：下面的提示及其选项可能因规则文件内的选项而异。
e 选择 L | 可用的 e 和长度“选择”字段将根据规则文件进行填充。
设计速度 | 对于 e 和长度计算，将在表或公式中使用设计速度。
旋转方式 | 此处的有效值包括：“路拱”、“内侧边缘”、“外侧边缘”、“左边缘”、“右边缘”、“内部分割”和“中心线”。如果在未划分的路面上使用“内部分割”，效果将与使用“路拱”相同。如果输入的值无效，缺省将使用“路拱”。“中心线”始终使用基准对齐半径来计算 e-比率。所有其他方法都使用“半径 +/- 枢轴偏移”来计算 e-比率。
打开编辑器 | 完成计算并更新车道后，超高编辑器将打开并填充新计算的车道。
父主题: 计算


编辑超高规则文件

编辑现有超高规则文件。使用此工具打开规则文件时，将根据架构验证该文件。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 计算 (Calculate) 拆分按钮

超高规则文件

超高计算器使用 XML 格式规则文件计算超高的各个方面。此文件用于计算路线中每条曲线的 Max E 比率以及将路基从标准路拱段横坡旋转到全超高横坡 (Max E) 所需的过渡段长度。

下面几节将介绍：

  • 如何在计算超高期间应用超高规则文件
  • “编辑超高规则文件”命令的工作方式
  • 在规则文件中编写公式
  • 公式示例

如何在计算超高期间应用超高规则文件

Max E 比率由比率表或比率公式这两种可能的方法之一来计算。

如果使用比率表，则通过查看规则文件中存在哪些比率表来填充“设计速度”。

如果用户选择比率公式，则使用该公式下的“速度”集合中存在的“速度”元素填充“设计速度”。速度不必是简单的数值。例如，可以使用“60 Urban”、“Loop Ramp”或“All Speeds”速度定义规则文件。当比率公式从另一个源（如用户变量）确定实际速度时，字母数字“速度”名称可能很有用。

过渡段计算也由过渡段表或过渡段公式这两种可能的方法之一来执行。

如果使用定义过渡段长度的表，则必须为每个可能的速度（数字或字母数字）定义一个过渡段表。过渡段公式不一定使用速度作为变量。

如果用户要使用速度表执行过渡段计算，则必须为每个可能的速度定义一个过渡段表。过渡段公式不一定使用速度作为变量。

选择 Max E 比率和过渡段之后，规则文件中定义的任何运行时用户变量将显示在弹出对话框中，允许用户更改任何/所有这些值。

代码将计算每条曲线的超高关键点（正常路拱、零度路拱、反向路拱和全超高）的 Max E 比率、过渡段长度和桩号位置。

接下来，代码检查规则文件是否具有任何自定义关键桩号定义。如果是，则处理这些定义。自定义关键桩号可以替换任何标准超高关键点或添加其他自定义关键桩号，例如，在 1% 横坡处。

调整任何关键桩号之后，代码将查看反向曲线或背对背曲线之间的过渡重叠。如果任何超高定义重叠或小于定义的最小间距，则根据过渡重叠调整选项的定义对计算的桩号进行额外调整。

最后，将超高值从外侧车道复制到其他车道。

重要注意事项：通过选择 SuperelevationCalculation.xsl 报告样式表，您可以获得一份详细的超高报表。

“编辑超高规则文件”命令的工作方式

“编辑超高规则文件”命令用于编辑 XML 规则文件。尽管 XML 文件可以直接编辑，但建议通过此界面进行所有编辑，以确保 XML 数据的格式正确。当打开现有规则文件时，编辑器还将根据适当的 XML 架构和等式语法验证规则文件。

“创建/编辑超高规则文件”对话框将打开一个几乎完全空白的定义（尚未保存到 XML 文件）。当前 XML 文件的名称显示在对话框标题中。在保存文件之前，这将报告为 Untitled.xml。我们之所以说几乎完全空白是因为缺省对话框预装有 AASHTO 方法 5 比率公式和 AASHTO 相对梯度过渡段长度公式。您可以选择保留并使用这些公式或将其删除。

该对话框有七个部分。下面将讨论每个部分及其设置。

  • 常规

    长度 - 描述用户正在使用的单位。</p>

    桩号舍入 - 值 0 定义无舍入。如果存在非零值，则计算的所有桩号值将取整为此值。例如，如果值为 0.2，则桩号 10+23.48 将取整为 10+23.4。

    水平坡度取整 - 值 0 定义无舍入。如果存在非零值，则所有横坡值将取整为此值。例如，值 0.01 将横坡 2.3456% 取整为 2.35%。

    按廊道设置创建 - 这些是可选设置，定义通过选择廊道使用创建超高区间工具创建超高时所用的缺省方法。系统将自动使用这些缺省方法，并且在使用此工作流时不会提示用户进行任何选择。

  • 表

    此部分中显示比率和过渡段查找表。这些表通常是从现有 SUP 或 SEP 文件导入。如果需要，还可以通过界面创建和编辑这些表。

    比率表定义不同曲线半径的最大横坡。单个比率表可以有多个基于不同设计速度的半径/横坡查找表。

    过渡段表定义不同最大横坡的过渡段长度。单个过渡段表可以有多个基于不同旋转车道数量的最大 eMax/过渡段长度查找表。

    注释: 必须至少定义一个比率表或比率公式。同样，必须至少定义一个过渡段长度表或过渡段长度公式。

  • 公式

    公式是确定 eMax 和过渡段长度的替代方法，功能比查找表更强大。几乎可以使用常量值、查找表、软件变量以及用户可在运行时定义的变量编写任何公式来计算这些值。这样便可极为灵活地计算 eMax 和过渡段长度。

    公式以双精度格式计算并返回曲线的最大横坡（例如，返回 0.03，表示 3%）或过渡段长度（例如，127.92）。

    缺省情况下，包括 AASHTO 方法 5 比率公式和 AASHTO 相对梯度过渡段长度公式作为

    示例。

    有关编写公式的信息，请参阅<xref>在规则文件中编写公式</xref>主题。

    注释: 必须至少定义一个比率表或比率公式。同样，必须至少定义一个过渡段长度表或过渡段长度公式。

  • 偏转和过渡选项

    以下设置控制如何计算 eMax 和过渡段的值。它们通常在规则文件中设置为标准，但如果需要在运行时更改这些值中的一个或多个，也可以通过用户变量将其公开给用户。

    • 偏转选项、固定长度 - 禁用后，使用与径流剖面相同的坡度计算偏转长度。启用后，可以指定固定长度的偏转长度。如果需要更复杂的选项来计算偏转，则使用“自定义关键桩号”。
    • 过渡段类型 - 定义横坡如何过渡以实现全超高横坡。以下类型描述了在超高图上绘制的超高车道外侧点的路径。

      线性 - 顶点处无过渡，所有线段都是直的。

      抛物线 - 在每个顶点处创建一个抛物线过渡段。抛物线的长度由非线性“曲线长度”参数和最短相邻线段中的较小值确定。

      反向抛物线 - 拟合普通路拱点和全超高点之间的反向抛物线（整个过渡段）。

      反向四次曲线 - 与“反向抛物线”相同，但公式不同。

      反向三次曲线 - 与“反向抛物线”相同，但公式不同。

      反向非对称抛物线 1 - 与“反向抛物线”相同，但凹抛物线的长度为 45，凸抛物线的长度为 55。可以使用配置变量 CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_1_SAG 和 CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_1_CREST 定义备选抛物线长度。

      反向非对称抛物线 2 - 与“反向抛物线”相同，但凹抛物线的长度为 30，凸抛物线的长度为 40。可以使用配置变量 CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_2_SAG 和 CIVIL_SUPER_REVERSE_PARABOLIC_NONSYMMETRICAL_2_CREST 定义备选抛物线长度。

      反向对称抛物线 - 此对称选项利用不相切的抛物线过渡段，每条抛物线的长度是过渡段长度的一半。

    • 非线性曲线长度 - 定义抛物线过渡段的最大长度。
    • 相切百分比 - 不在曲线上的过渡段长度的百分比。
    • 使用缓和曲线长度 - 如果启用且缓和曲线存在，则缓和曲线长度将用作过渡段长度，而不是计算得出的过渡段长度。在这种情况下，“相切百分比”值将被忽略。如果禁用，将使用计算得出的过渡段长度。
    • 开始将内侧车道与外侧车道一起旋转 - 如果启用，则内侧车道将在外侧车道的旋转起始位置开始旋转（最早开始时间）。如果禁用，则内侧车道在外侧车道达到反向路拱的位置开始旋转。换而言之，内侧车道和外侧车道较平或具有相同的横坡。
    • 长度为过渡段总长 - 如果启用，则过渡段长度为从普通路拱到全超高（径流长度 + 偏转长度）。如果禁用，则过渡段长度为从水平或零度路拱到全超高（偏转长度）。
    • 内插表 - 如果启用，则将内插所有 e 比率和过渡段表。否则，e 比率和过渡段长度将是更高的值。
  • 曲线重叠调整

    以下选项定义当一条曲线的出口过渡段与下一条曲线的入口过渡段重叠时如何调整超高桩号。

    如果为某种曲线类型（反向曲线或曲线-曲线）定义了多个选项（“滑动”、“缩短”等），将使用最小的“最小超高过渡间隙”大于实际间隙的选项。例如，如果实际间隙为 0，一个选项的“最小超高过渡间隙”为 50，另一个选项的“最小超高过渡间隙”为 100，将使用“最小超高过渡间隙”为 50 的选项。

    • 曲线类型 - 与在对话框的其余部分中定义的调整相关的曲线类型。有两组调整；一组用于反向曲线，一组用于曲线-曲线。
    • 最小超高过渡间隙 - 普通路拱桩号之间的任何实际间隙小于此数字将导致调用此选项（上述存在多个选项的情况除外）。
    • 滑动 - 每条曲线的整个过渡段将进一步移入每条曲线，直至达到“最小超高过渡间隙”。过渡段长度保持不变。
    • 缩短 - 保留全超高点并缩短过渡段，直至达到“最小超高过渡间隙”。缩短的幅度与过渡段长度成比例。
    • 反向路拱 -（仅限曲线-曲线调整选项）- 道路将从平面向下过渡到反向路拱，然后回到全超高。消除“零度路拱”和“普通路拱”桩号。
    • 平面 - 道路将从全超高平面过渡全超高。消除“零度路拱”和“普通路拱”桩号。
    • 可以定义自定义公式来计算曲线之间的过渡。有关编写公式的信息，请参阅在规则文件中编写公式主题。
  • 自定义关键桩号

    自定义关键桩号可以替代为超高计算的标准过渡桩号，或者是要添加到车道的其他桩号。

    通过将相应变量类型的公式设置为 FALSE，可以清除或排空现有超高关键桩号。

    注释: 为曲线条目编写自定义关键桩号的公式 (NC - FS)。曲线出口过渡段计算将自动镜像。
    • 创建自定义关键桩号公式 - 启用后，可以定义自定义关键桩号。
    • 描述 - 描述这些自定义关键桩号的用途。
    • 条件 - 计算结果必须为 True 才会计算自定义关键桩号的逻辑表达式。空值的计算结果为 True。
    • 桩号 - 现有自定义关键桩号的列表。
    • 变量 - 打开“公式编辑器”，用于定义新变量和公式。请参阅在规则文件中编写公式主题。
    • 新建 - 定义新的自定义关键桩号。

      公式 - 定义新的自定义关键桩号位置的公式。此公式可以使用全局（内置）变量和局部变量，这些变量通过在“公式编辑器”中定义的公式得出。例如，可以使用自定义公式计算从全超高到反向路拱的新过渡段长度。假设结果存储在名为 ReverseCrownLength 的变量中。那么定义“零度横坡”关键桩号的公式就是 FullSuperStation - ZeroCrownLength。FullSuperStation 是软件定义的全局变量。请参阅在规则文件中编写公式主题。

      类型 - 定义所定义的关键桩号类型。如果关键桩号类型是标准类型（“普通路拱”、“零度横坡”、“反向路拱”或“全超高”）之一，则替换标准关键桩号。如果类型是“自定义”，则向车道添加一个新的关键桩号。

  • 运行时变量

    运行时变量是用户可在运行时设置其值的变量。因为这些变量允许代理锁定规则文件，使其无法编辑，但仍然为用户提供有限的访问权限，以便在创建超高期间更改值或控制计算。

    运行时变量可以替代偏转或过渡选项，或者定义可用于其他公式的新值。

    • 名称 - 新变量的名称。
    • 描述 - 新变量的描述。
    • 替代 - 定义如何使用变量。“无”是一个自定义变量，定义后可用于 eMax 和过渡段长度公式。其他选项用于替代偏转或过渡设置。其中包括“内插表”、“切线曲线缓和百分比”、“使用缓和曲线长度”、“长度为过渡段总长”、“过渡段类型”、“非线性曲线长度”、“开始将内侧车道与外侧车道一起旋转”、“偏转是固定的长度”和“偏转长度”。
    • 类型 - 定义自定义变量的类型。

      字符串 - 在运行时作为自由格式输入的键入命令字段或用于从预置列表中选择的组合框呈现给用户。

      整型 - 在运行时作为自由格式输入的键入命令字段或用于从预置列表中选择的组合框呈现给用户。可以定义最小值和最大值范围。

      十进制 - 在运行时作为键入命令字段呈现给用户（将验证输入）。可以定义最小值和最大值范围。

      布尔 - 在运行时作为复选框呈现给用户。

      缺省值 - 变量的缺省（起始）值。

  • 导入 SUP/SEP 文件

    “导入 SUP”和“导入 SEP”工具有助于设置 XML 规则文件。导入过程不会从原有文件导入并定义所有设置，但会导入大部分表。

    “导入 SUP”将引入现有比率表和过渡段长度表。其余的设置需要手动配置。

    “导入 SEP”将引入现有比率表、过渡段长度表和相对梯度表。它不导入比率公式或过渡段长度公式。其余的设置需要手动配置。

  • 在规则文件中编写公式

    公式在公式编辑器中开发。

    • 名称 - 比率公式或过渡段长度公式的名称。在计算超高时，此名称将显示在界面中供用户选择。
    • 公式 - 定义将返回的最终值。如果这是比率公式或过渡段长度公式，则该值将是 eMax 比率或过渡段长度。如果此公式用于曲线重叠调整或自定义关键桩号，则最终值可以是用于其他公式的任何变量，定义这些相应的值。建议将此“公式”值设置为单个变量，该变量在对话框的“公式变量”部分中计算（如下所示），包括 TransitionLength 变量。
    • 显示变量和运算符 - 展开对话框以显示可用的运算符和变量。全局、局部（公式）和运行时（用户）变量如图所示。下面将更详细地定义这些变量。
    • 公式变量 - 对话框的这一部分定义最终用于计算此公式的最终值的变量。

    公式变量用于生成公式中使用的中间值。这些变量用于规则文件中的公式，用户不能在运行时更改它们。

    变量可以由公式或表定义，但不能同时由两者定义。如果变量由公式定义，则在“公式”字段中编写公式。在示例中，变量 TransitionLength 由公式 100*(WidthLane*NRotatedLanes)*MaxE*bw/gradient 定义。在此示例中，WidthLane、NRotatedLanes 和 MaxE 是软件提供的全局变量。gradient 和 bw 是此对话框中定义的局部变量。gradient 变量从表中读取（请注意空白公式）。选择“创建/编辑”按钮以打开表。

    表有两列用于“输入”和“输出”值。“输出”值是变量（本例中为 gradient）的值。“输入”列表示的内容由“输入变量名称”设置定义。在此示例中，使用全局变量 Speed。因此，对于每条曲线，在“输入”列中找到 Speed，并返回相应的梯度。

    如果输入变量是数字，则根据“内插类型”（useLowerBound、linearInterpolation、useUpperBound）内插输出值。否则，输入变量值必须与表的某个输入值精确匹配。

    编写公式时，可用的变量类型如下。

    • 全局变量 - 由系统定义或在处理过程中计算。根据所计算的公式类型（如下表中所示），可以使用不同的全局变量。
    • 局部（公式）变量 - 在规则文件中定义。这些变量用于规则文件中的公式，用户不能在运行时更改它们。
    • 运行时（用户）变量 - 在规则文件中定义。用户可在运行时更改这些变量。

    下面列出了全局变量：

    最大 e-比率

    过渡段长度

    自定义关键桩号

    过渡查询选项

    全局变量
    X | X | Radius - 曲线的半径
    X | X | Speed - 设计速度
    X | X | X | InitialCrossSlope - 普通路拱横坡
    X | X | NRotatedLanes - 从枢轴旋转的车道数量
    X | X | PivotType - 0 - 路拱，1 - 内侧，2 - 外侧，3 - 左侧，4 - 右侧，5 - 内部分割
    X | X | WidthLane - 平均车道宽度
    X | MaxE
    X | TransitionLength - 计算得出的过渡段长度值
    X | SpiralExists - 如果存在缓和曲线则为 true，否则为 false
    X | StartOfSpiral - 缓和曲线起点桩号
    X | SpiralLength - 缓和曲线长度
    X | StartOfArc - 弧（曲线）起点桩号
    X | NCRadius - E 比率计算为普通路拱坡度的半径（最大半径）
    X | RunoutStation - 计算得出的过渡段起点
    X | RunoffStation - 计算得出的零度横坡位置
    X | ReverseCrownStation - 计算得出的反向路拱桩号
    X | FullSuperStation - 计算得出的全超高位置
    X | OutLength - 第一条曲线出口的过渡段长度
    X | OutFullSuper - 第一条曲线的全超高桩号
    X | OutRunoffStation - 第一条曲线的零度横坡位置
    X | OutRunoutStation - 第一条曲线的普通路拱位置
    X | InLength - 第二条曲线入口的过渡段长度
    X | InRunoutStation - 第二条曲线的普通路拱位置
    X | InRunoffStation - 第二条曲线的零度横坡位置
    X | InFullSuperStation - 第二条曲线的全超高桩号
    X | Curve1StartOfArc
    X | Curve1EndOfArc
    X | Curve1EndOfSpiral -“False”值表示无缓和曲线
    X | Curve1FullSuperStation
    X | Curve1ReverseCrownStation
    X | Curve1ZeroCrossSlopeStation
    X | Curve1NormalCrownStation
    X | Curve1MaxE
    X | Curve2StartOfArc
    X | Curve2EndOfArc
    X | Curve2StartOfSpiral -“False”值表示无缓和曲线
    X | Curve2FullSuperStation
    X | Curve2ReverseCrownStation
    X | Curve2ZeroCrossSlopeStation
    X | Curve2NormalCrownStation
    X | Curve2MaxE

    编写公式时，可以使用各种数学函数、运算符和逻辑表达式。

    • 数学运算符：+、-、/、*、^ - 指数运算符、%
    • 数学函数：ABS、ACOS、ASIN、ATAN、CEILING、COS、COSH、FLOOR、LOOKUP、LOG、LOG10、MAX、MIN、MOD、ROUND、SIGN、SIN、SINH、SQRT、TAN、TANH、TRUNCATE。
    • 逻辑运算符：IF、AND、OR、NOT。
    • 条件运算符：<、<=、=、==、>=、>、<>。

      直接在 XML 文件中工作时要注意，因为“<”和“>”是特殊字符，在原始 xml 中必须写成“&lt;”和“&gt;”。通过对话框编写公式时，它将为您进行转换。

    • 值: FALSE、INFINITY、PI、TRUE。
    • 逻辑表达式：IF(逻辑表达式)? execute if true : execute if false 例如：equation="if(altDel == 0.0 and AltSuper == 0.0) ? Delta : altDel" 还可以嵌套逻辑表达式，使另一个 IF 语句可以位于 true 和/或 false 执行语句内部。
  • 公式示例

    此部分包含各种演示正确设置格式的公式。

    • 此示例显示了一些嵌套的数学表达式。(frictionFactor - hPI) / (5729.58*((1/MinRadius) - (1/rPI)))
    • 此示例显示了 IF 语句的简单用法。if(R < MinRadius ? MaxERate : if(R >= NCRadius ? InitialCrossSlope : (EFD - F)))
    • 此示例显示了一个更复杂的嵌套 IF 语句，其中用户设置一个名为 LaneWidthIndex 的变量，因为将计算运行时变量以确定要使用哪个过渡段长度查找表。if(LaneWidthIndex == 1) ? LengthAt45mWidth : (if(LaneWidthIndex == 2) ? LengthAt5mWidth : (if(LaneWidthIndex == 3) ? LengthAt55mWidth : (if(LaneWidthIndex == 4) ? LengthAt6mWidth : (if(LaneWidthIndex == 5) ? LengthAt65mWidth : (if(LaneWidthIndex == 6) ? LengthAt7mWidth : (if(LaneWidthIndex == 7) ? LengthAt75mWidth : (if(LaneWidthIndex == 8) ? LengthAt8mWidth : (if(LaneWidthIndex == 9) ? LengthAt85mWidth : (if(LaneWidthIndex == 10) ? LengthAt9mWidth : (if(LaneWidthIndex == 11) ? LengthAt95mWidth : (if(LaneWidthIndex == 12) ? LengthAt10mWidth : (if(LaneWidthIndex == 13) ? LengthAt12mWidth : 0))))))))))))
父主题: 计算


导入超高

通过 CSV 文件合并超高值。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 计算 (Calculate) 拆分按钮

导入超高

可以从 CSV 文件导入数据，即在 Civil 产品之外完成计算且仅导入结果，而不是使用基于规则的超高过渡段。在这种情况下，规则不适用，因此不需要或未指定规则文件。

可以导入整个项目，在这种情况下，只需要一个超高断面。但是，也可以仅导入一两个转弯车道或项目的一部分。请记住，必须在导入之前创建超高断面和车道，与图形关联的车道名称必须与导入文件中的名称匹配。另请注意，一次只能将 CSV 导入到一个超高断面中。您可能需要为整个项目创建单个超高断面，方法是将“最小切线长度”设置为 5000 或另一个同样大的数。

将使用 Windows 分隔符值，该值通常设置为逗号；但是，如果遇到问题，则可能需要在工作站或笔记本电脑上对此进行验证。

一个文件被导入两次时，并不会创建重复的车道；而是会用导入文件的值覆盖车道的任何值（包括手动编辑）。

文件格式

逗号分隔值文件的文件格式为：

SuperelevationLane,Station,CrossSlope,PivotAbout,PointType,TransitionType,NonLinearCurveLength

一条示例线使用所有选项：

CL_RT1,2+50.000,-0.02,LS,NCIN,L,0

另一个示例只有所需的信息：

CL_RT1,2+50.000,-0.02,LS

以下详细信息是必需信息：

数据 | 描述
超高车道 | 必需 - 将数据链接到现有超高车道，因此，CSV 文件中的名称必须与导入之前创建的车道名称匹配。
桩号 | 必需 - 定义横坡的桩号。 支持的桩号公式基于断面的参考路线和“设计文件设置”>“土木格式设置”>“桩号设置”>“公式”设置。
横坡 | 必需 - 指定桩号的横坡，设为双精度值格式：(-2% = -0.02)。
旋转轴位置 | 必需 - 标识作为旋转轴位置的边。通常，如果绕中心线旋转，则右车道将围绕左边缘 (LS) 旋转，而左车道则围绕右边缘 (RS) 旋转。 LS = 左侧（边缘） RS = 右侧（边缘）
点类型 | 可选 - 此桩号的超高点类型和横坡。可能值包括： NC = 普通路拱 NCIN = 内侧普通路拱 NCOUT = 外侧普通路拱 LC = 水平路拱 LCIN = 内侧水平路拱 LCOUT = 外侧水平路拱 RC = 反向路拱 RCIN = 内侧反向路拱 RCOUT = 外侧反向路拱 FS = 全超高 FSIN = 内侧全超高 FSOUT = 外侧全超高 U = 未定义
过渡段类型 | 可选 - 此桩号的超高过渡段类型和横坡。可能值包括： L = 线性 PC = 抛物线 PRC = 反向抛物线 BRC = 四次反向曲线 CRC = 三次反向曲线 SRC = 对称反向曲线
非线性曲线长度 | 可选 - 定义抛物线过渡段的最大长度。如果给定长度超过点任一侧的切线长度，则会缩短此长度。当“过渡段类型”为“线性”时，此参数不适用。

工具工作流：

  1. 基于文件格式创建 CSV 文件。
  2. 创建超高断面和车道，确保车道名称与 CSV 文件中使用的名称匹配。
  3. 选择“导入超高”工具。
  4. 按照危险警告提示操作：

    提示

    用户操作

    定位第一个超高断面

    选择第一个剖面。每次只能导入一个断面，但是可以为多个断面调用同一 CSV 文件。它将利用超高断面的桩号范围，而忽略 CSV 文件中超出该范围的任何行。

    导入文件

    使用 <ALT> + 下箭头以打开文件管理器来选择目录/CSV 文件。

    结果与超高车道的计算结果基本相同。除了重新处理之外，计算车道支持的所有功能（编辑器、图形操作等）也受导入车道支持

父主题: 计算


指定给廊道

将在超高车道上定义的横坡应用到廊道，以便在廊道模型中反映超高路面。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 计算 (Calculate) 拆分按钮。

最常见的工作流是将超高车道存储在与廊道不同的文件中。然而，它们可以位于同一文件中。必须打开廊道文件才能将超高指定给廊道。如果超高车道与廊道位于不同的文件中，必须先在廊道文件中参考超高文件，之后才能将超高指定给廊道。

在该过程中，可以随时将超高车道与廊道相关联。

此步骤的操作结果是超高路面会反映在廊道模型中。

工作流

  1. 验证对于用作备选超高点的所有路面点，廊道中使用的模板已设置“超高标记”。此标记用于自动设置点控制。

  2. 在包含廊道模型的 DGN 中，选择“将超高指定给廊道”工具。

  3. 按照危险警告提示操作。

    提示

    用户操作

    定位第一个超高断面

    选择第一个剖面。沿对角线方向拖动光标框选所需的全部区间，而不必分别选择每个区间。对角线定义一个正方形，该正方形必须包围整个区间才能将其包含在内。

    定位下一个超高区间，或重置以完成操作

    继续选择区间直到所有区间均高亮显示，然后重置以移至下一个提示。

    定位廊道

    选择要在其中应用超高过渡的廊道。

  4. 此时将显示“关联超高”对话框。此对话框用于将模板内的点指定给超高车道的边。如果已为模板中的每个点启用“超高标记”并且定义了相应数量的超高车道，软件会自动设置该对话框中的值。

    例如，具有以下点名称的四车道模板最多与名为 LT-1、LT-2、RT-1 和 RT-2 的四个超高车道匹配，如下所示。

  5. 如果信息正确，请单击“确定”。如果不正确，请单击“取消”并检查模板。

  6. 超高已合并到廊道模型中。生成动态横截面视图以查看超高。

父主题: 计算


编辑

插入桩号横坡
超高编辑器
父主题: 超高


插入桩号横坡

向现有超高车道添加其他桩号和横坡过渡段。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 编辑拆分按钮

有时可能需要向现有超高车道添加其他桩号和横坡过渡段。可以使用“插入超高桩号/横坡”工具，而不是删除车道并重新创建。

工作流

  1. 插入超高桩号/横坡。

  2. 按照危险警告提示操作。

提示 | 用户操作
定位超高 | 选择先前创建的超高车道，该车道已分配超高计算。
超高约束类型 | 无 = 偏移距离 = 带坡度矢量 =
坡度约束类型 | 无 = 横坡 = 镜像横坡 = 匹配横坡 = 带坡度矢量 =
旋转轴位置 | 标识作为旋转轴位置的边。
过渡段类型 | 可选 - 此桩号的超高过渡段类型和横坡。可能值包括： L = 线性 PC = 抛物线 PRC = 反向抛物线 BRC = 四次反向曲线 CRC = 三次反向曲线 SRC = 对称反向曲线
桩号 | 必需 - 定义横坡的桩号。 支持的桩号公式基于断面的参考路线和“设计文件设置”>“土木格式设置”>“桩号设置”>“公式”设置。
横坡 | 必需 – 指定桩号的横坡，设为双精度值格式 (-2% = -0.02)。
点类型 | 可选 – 此桩号的超高点类型和横坡。可能值包括： NC = 普通路拱 NCIN = 内侧普通路拱 NCOUT = 外侧普通路拱 LC = 水平路拱 LCIN = 内侧水平路拱 LCOUT = 外侧水平路拱 RC = 反向路拱 RCIN = 内侧反向路拱 RCOUT = 外侧反向路拱 FS = 全超高 FSIN = 内侧全超高 FSOUT = 外侧全超高 U = 未定义
定位参考元素 | 选择要用作超高车道和计算基础的土木平面元素。
起点桩号 | 以图形方式定义（基于垂直于参考单元的虚线）剖面的起点。可以键入和锁定桩号。
父主题: 编辑


超高编辑器

以表格格式编辑数据。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高 > 编辑拆分按钮

超高编辑器是以表格格式编辑数据的另一种方式。在编辑器中进行的任何更改都会自动与图形车道同步，反之亦然。由于计算期间使用的约束，无法编辑任何灰色数据。

通过选择工具，然后选择超高区间来打开编辑器。曲线集列在左侧。高亮显示任何曲线集会填充表。着色的点指示：

  • 红色 - 完全约束

  • 黄色 - 部分约束

  • 绿色 - 没有约束

在图和表之间有许多超高工具的快捷方式图标。

仅显示顶部的超高图。右键单击超高图以显示“超高显示列表”对话框。

可以自定义编辑器中的字段，以便隐藏未使用或不需要的字段。通过右键单击表格数据区域中的任何标题打开弹出式菜单，即可完成此操作。

父主题: 编辑


超高报表

创建桩号、过渡段、横坡以及其他超高数据的超高 XML 报告并打开 Bentley 土木工程报告浏览器。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高
  • 功能区：主页 > 模型分析与报表 > 廊道报表
  • 功能区：主页 > 模型分析与报表 > 报表
  • 功能区：廊道 > 查看 > 廊道报表
  • 功能区：几何图形 > 通用工具 > 报表

可以为单个或多个区间生成超高报告。这些报告显示在土木工程报告浏览器中。

工作流

最佳实践：

要为多个区间生成报告而不必逐个选择每个区间，请在选择工具之前将它们放入选择集（沿对角线在所有所需区间中拖动鼠标）。如果选择非超高区间，软件会将其过滤掉，并且仅使用超过区间，请勿担心。

  1. 选择“超高报表”。

  2. 按照危险警告提示操作，选择超高区间。

    继续选择区间，然后在完成时重置。请注意，如果您已创建选择集，系统将提示您接受选择集中的区间。

    将打开“土木工程报告浏览器”，其中包含默认的超高报告。

  3. 按照危险警告提示操作。

    提示

    用户操作

    定位第一个超高区间

    选择要包括在报告中的第一个区间。

    定位下一个超高剖面 - 或重置可完成

    继续选择区间，直到全部高亮显示为止，然后重置以创建报告。

  4. 将打开土木工程报告浏览器，其中包含默认的超高报告。

父主题: 超高


打开超高视图

在 MSTN 视图中直接打开可编辑的超高图。

键入：几何图形超高，打开视图或从平面线形的浮动任务栏中选择。提示用户选择平面线形，然后选择用于打开模型的视图。

父主题: 超高


检查

动态截面
三维漫游
廊道报表
父主题: 廊道


动态截面

选择 | 描述
打开横断面视图 | 使用对廊道或任何土木平面几何的指定基线参考，可在用户选择的 MicroStation 视图中创建动态横截面视图。廊道间隔用于横截面间隔。专用视图具有放大功能、横截面滚动以及放置临时尺寸标注线的功能。这些截面不用作绘制横截面或图纸的基础。
通过桩号定位横断面 | 使用此工具放置数据点（在平面视图中），以查看列表中未包括的桩号的动态横截面。
编辑桩号 | 编辑桩号的横截面实例。
显示横断面标注 | 根据两个数据点将显示文本（宽度、斜率）放入动态横截面视图中。多个显示横断面元素尺寸标注可以放置在单个横截面视图中。
移除临时尺寸标注 | 移除使用“显示横断面标注”工具放置的动态横截面视图中的尺寸标注。
打开横断面视图
通过桩号定位横断面
编辑桩号
显示横断面标注
删除临时标注
父主题: 检查


打开横断面视图

用于在选定的 MicroStation 视图中创建动态横截面视图。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 动态截面拆分按钮

使用对廊道或任何土木平面几何的指定基线参考，可在选定的 MicroStation 视图中创建动态横截面视图。廊道间隔用于横截面间隔。专用视图具有放大功能、横截面滚动以及放置临时尺寸标注线的功能。这些截面不用作绘制横截面或图纸的基础。

父主题: 动态截面


通过桩号定位横断面

用于放置数据点（在平面视图中），以查看列表中未包括的桩号的动态横截面。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 动态截面拆分按钮

使用此工具放置数据点（在平面视图中），以查看列表中未包括的桩号的动态横截面。

父主题: 动态截面


编辑桩号

用于编辑桩号的横截面实例。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 动态截面拆分按钮

编辑桩号的横截面实例。右键单击横截面视图并选择“编辑桩号”以编辑桩号。

单桩号模板不受“廊道模型”中的任何其他修订影响。这包括更改纵面几何、点约束以及影响设计的其他项。

接受桩号编辑时，将创建一个单桩号三维路面。

单桩号条目在平面视图中显示为一行（正常模式）。

父主题: 动态截面


显示横断面标注

用于根据两个数据点将显示文本（宽度、斜率）放入动态横截面视图中。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 动态截面拆分按钮

根据两个数据点将显示文本（宽度、斜率）放入动态横截面视图中。

多个显示横断面元素尺寸标注可以放置在单个横截面视图中。

父主题: 动态截面


删除临时标注

用于移除使用“显示位置标注”工具放置的动态横截面视图中的标注。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 动态截面拆分按钮

移除使用“显示横断面标注”工具放置的动态横截面视图中的尺寸标注。

父主题: 动态截面


三维漫游

用于以更加真实的可视化方式查看三维模型。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 检查
  • 功能区：主页 > 模型分析与报表 > 土木分析拆分按钮

使用“三维漫游”工具，用户可以用更为逼真的可视化查看三维模型。利用一个基本对话框，用户便可以第一视角在模型中移动，每次停顿都可从一侧平移至另一侧。此外，还可以将可视化发布至 MicroStation 相机脚本文件，在“动画制作器”工具中使用。

最佳实践

该工具跟随三维元素而不是三维模型作为路径。可能需要打开两个视图：一个二维视图，一个三维视图。三维视图可用于漫游，而二维视图可用于为中心线或横坡旋转选择元素。二维元素必须具有激活纵断面，该命令才能跟随三维路径。如果不慎将二维元素或高程为 0 的三维元素选作中心线，由于中心线与模型之间的高程差，可能不会显示三维模型。使用该工具后，三维视图不会恢复。因此，可能需要打开另一个三维视图，以防丢失当前视图中的设置。

调用三维漫游工具
常规控制
高级控制
漫游模型
将横坡旋转应用于三维漫游模型
发布模型
父主题: 检查


调用三维漫游工具

路径需要三维元素才能漫游。这可以是 MicroStation 三维元素，也可以是漫游的土木平面元素和相关的纵面元素。

具有显示三维路面的图形；地形模型、廊道模型、网格、实体或其他三维元素。

  1. 设置视图。请注意，至少需要一个三维视图。
  2. 选择该工具并按照警告提示操作。首先，选择显示漫游的三维视图。接着选择中心线。请注意，它不必是路面的中心线，可以使用任何 MicroStation 三维或土木平面/激活纵断面元素。选择后，将设置漫游视图并移至三维元素的开头，并打开“漫游 (Drive Through)”对话框。
    注释: 如果选择了二维土木元素（包含激活纵面纵断面）或“当前激活三维线性元素 (Current Active 3D Linear Element)”，则非 0.0 的起点桩号和桩号等式将仅显示在“桩号”文本框中。起点桩号和公式不会显示为 Microstation 元素或称为“附加三维线性元素”的土木元素，因为这些元素不包含土木桩号设置对象。

    对话框设置

    导航对话框包括三个选项卡：

    选项卡

    描述

    常规控制

    包含用于运行、平移、前后移动等的导航控件。

    高级控制

    包含横坡旋转调整（以模拟超高）和可选剪切面切换。

    相机/目标控制

    设置相机的位置（即驾驶员的位置）和目标点、驾驶员正在看的投影位置。相机和目标位置均支持可选的水平偏移和竖向偏移。

父主题: 三维漫游


常规控制

“常规控制”选项卡包含用于运行、平移、前后移动等的导航控件。

导航按钮

图标 | 移动
 | 播放 - 开始漫游过程，该过程可以随时停止或暂停。为了提供平滑的动画，软件确定了播放时的步长间隔。因此，单击“暂停”按钮最有可能在不是“常规设置”中步长值（仅用于阶跃函数）的倍增系数的位置暂停。
 | 暂停 - 在当前桩号停止漫游。
 | 停止 - 停止漫游并将视图返回到开始桩号。
 | 转至开头 - 将视图返回到开始桩号。
 | 后退 - 每单击一次，漫游后退一步（降低桩号设置），并显示更新后的桩号。步长值在“常规设置”选项卡（与导航按钮相同的选项卡）中指定。
 | 前进 - 每单击一次，漫游前进一步（提高桩号设置），并显示更新后的桩号。步长值在“常规设置”选项卡（与导航按钮相同的选项卡）中指定。
 | 转至末尾 - 将视图移动到终点桩号。
 | 反转 - 单击“反转”，然后单击“播放”。现在沿中心线漫游，会降低桩号设置。
 | “平移”控件 – 单击顶部箭头将在目标点处提升视图，单击底部箭头将在目标点处降低视图。单击左右箭头可向右或向左平移。要返回到原始视图（在平移之前），请单击中间的眼睛。“平移”功能可在漫游运行或暂停时使用。

其他字段

字段 | 描述
速度 | 定义车辆的速度。此值用于计算帧间距离（单位是英尺或米/秒）和帧数。漫游将以英里/小时或公里/小时为单位运行，具体取决于设计文件的设置。
桩号 | 选择中心线后，软件确定桩号范围（如果使用土木元素）并在“桩号”键入命令字段中显示开始桩号。设计师可以通过键入所需的桩号来更改开始桩号，但该桩号必须在中心线的范围内。如果选择了 MicroStation 元素，则为该元素的原点分配桩号 0+00。请注意，软件不是从三维元素的起点开始，而是以中心线作为起点。
步长 | 定义使用“后退”和“前进”按钮（而非“运行”选项）时在各个相机视图之间移动的距离。
父主题: 三维漫游


高级控制

“高级控制”选项卡包含横坡旋转调整（以模拟超高）和可选剪切面切换/设置。

字段 | 描述
应用横坡旋转 | 由于漫游过程遵循三维中心线，因此不会对任何三维模型的斜率作出反应。当路面倾斜（超高）时，相机不会反映斜率。这可以用“应用横坡旋转”功能来解决。
添加剪切面 | 切换为关闭状态后，将显示所有元素。切换为打开状态后，将建立（垂直）剪切面。
距离 | 当“添加剪切面”切换为打开状态时使用。这是到建立垂直剪切面的相机位置的水平距离。超出此距离的任何元素都不会显示。沿中心线行驶时，该剪切面会动态更新。例如，当中心线上的曲线显示背景中不需要的元素时，这很有用。
发布 | 单击“发布”将创建一个相机脚本文件，该文件可在 MicroStation 动画制作器工具中打开。在动画制作器中，可以使用工具动画制作器以各种格式保存该文件。有关更多详细信息，请参考 MicroStation 帮助。
父主题: 三维漫游


漫游模型

  1. 设置视图。
  2. 选择“三维漫游”工具。
  3. 按照危险警告提示操作。

    危险警告提示

    用户响应

    选择三维视图

    在视图中选择用于实际漫游的数据点。如果已选择二维视图，则显示一条消息。

    选择道路的中线

    选择 MS 三维元素或土木平面几何元素（必须具有激活纵断面）

  4. 设置“常规控制”（速度和步骤）。
  5. （可以在会话期间随时）调整相机/目标控制。
  6. （可以在会话期间随时）设置高级控制。
  7. 单击“运行”以启动漫游。如果中心线元素在三维模型区域之外，单击“暂停”，然后键入相关区域附近的桩号。
  8. 使用“常规控制”选项卡中的导航工具，在三维模型中移动。
父主题: 三维漫游


将横坡旋转应用于三维漫游模型

  1. 设置视图。
  2. 选择“三维漫游”工具。
  3. 按照危险警告提示操作，选择视图和中心线。
  4. 选择“高级控制”选项卡。
  5. 单击“应用横坡旋转”开关。注意：复选标记尚未显示。
  6. 将光标移离对话框并进入三维视图，然后按照危险警告提示操作。

    危险警告提示

    用户响应

    选择“左转约束”、“重置为跳过约束”。

    选择 MS 三维元素或土木平面几何元素（必须具有激活纵断面）才能开始滚动限制。重置退出特征。

    选择“右转约束”、“重置为跳过约束”。

    选择 MS 三维元素或土木平面几何元素（必须具有激活纵断面）才能开始滚动限制。重置退出特征。

    定义两个约束之后，将选中“高级控制”对话框中“应用横坡旋转”左侧的开关。这指示两个约束均为可接受的元素。
  7. 运行或逐步执行以查看采用旋转的结果。
父主题: 三维漫游


发布模型

  1. 设置视图。
  2. 选择“三维漫游”工具。
  3. 按照危险警告提示操作，选择视图和中心线。
  4. 单击“运行”以漫游模型。如果需要，可随时暂停。
  5. 选择“高级控制”选项卡。
  6. 单击“发布”。
  7. 在“相机脚本”工具设置中，输入“名称”（必填）和“描述”（可选）。
  8. 单击“确定”。 “消息中心”将显示一条消息“三维漫游: 已创建关键帧动画模型。”
  9. 从“MS 动画 (MS Animation)”任务导航中选择“MicroStation 动画制作器”。注意：要访问该工具，您的焦点必须在三维视图中。 对话框将在当前“相机脚本”文件。因此，您可能需要打开由“三维漫游”工具创建的新脚本文件。可以使用“动画制作器”对话框中的“文件”>“报告脚本”工具来将脚本保存为多种格式。
父主题: 三维漫游


报表概述

此工具箱包含多个廊道报表。所有报表都需要选择一个廊道才能在 Civil 报表浏览器中生成报表。缺省报表在安装包中提供，不过，您可以从若干不同报表中任意选择一个作为缺省报表。

父主题: 廊道报表


组件数量

用于生成报表，其中包括组件（混凝土、表层土、路肩、挖方和填方土方量）表面积、体积、测量单位、单位成本、组件成本和总成本。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 廊道报表拆分按钮
  • 功能区：主页 > 模型分析与报表 > 廊道报表拆分按钮

报告包括组件（混凝土、表层土、路肩、挖方和填方土方量）表面积、体积、计量单位、单位成本以及组件和总成本。预览窗口将显示相关信息，单击报表按钮则会在 Civil 报表浏览器中打开该窗口。

父主题: 廊道报表


设计输入报表

用于打开土木工程报告浏览器并显示默认的“Roadway 设置报告”。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 廊道报表拆分按钮

“设计输入报告”将打开土木工程报告浏览器并显示默认的“Roadway 设置报告”，其中包括廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡、末端条件异常和超高区间信息。

工作流

  1. 选择“设计输入报告”工具。

  2. 选择廊道，这将打开土木工程报告浏览器。

父主题: 廊道报表


结果报表

用于打开土木工程报告浏览器并显示默认的“Roadway 设置报告”。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 廊道报表拆分按钮

“结果报表”将打开带有默认路面设置报告的土木工程报告浏览器，其中包括详细的廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡段、末端条件异常和超高区间信息。

工作流

  1. 选择“结果报表”工具。

  2. 选择廊道，这将打开土木工程报告浏览器。

父主题: 廊道报表


清表报表

用于打开带有压碾/剥离组件报告的土木工程报告浏览器。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 查看 > 廊道报表拆分按钮

“清表报表”可打开带有压碾/剥离组件报告的土木工程报告浏览器。

父主题: 廊道报表


超高报表

创建桩号、过渡段、横坡以及其他超高数据的超高 XML 报告并打开 Bentley 土木工程报告浏览器。

您可以通过以下方式访问此工具：

  • 功能区：廊道 > 超高
  • 功能区：主页 > 模型分析与报表 > 廊道报表
  • 功能区：主页 > 模型分析与报表 > 报表
  • 功能区：廊道 > 查看 > 廊道报表
  • 功能区：几何图形 > 通用工具 > 报表

可以为单个或多个区间生成超高报告。这些报告显示在土木工程报告浏览器中。

工作流

最佳实践：

要为多个区间生成报告而不必逐个选择每个区间，请在选择工具之前将它们放入选择集（沿对角线在所有所需区间中拖动鼠标）。如果选择非超高区间，软件会将其过滤掉，并且仅使用超过区间，请勿担心。

  1. 选择“超高报表”。

  2. 按照危险警告提示操作，选择超高区间。

    继续选择区间，然后在完成时重置。请注意，如果您已创建选择集，系统将提示您接受选择集中的区间。

    将打开“土木工程报告浏览器”，其中包含默认的超高报告。

  3. 按照危险警告提示操作。

    提示

    用户操作

    定位第一个超高区间

    选择要包括在报告中的第一个区间。

    定位下一个超高剖面 - 或重置可完成

    继续选择区间，直到全部高亮显示为止，然后重置以创建报告。

  4. 将打开土木工程报告浏览器，其中包含默认的超高报告。

父主题: 廊道报表


模型细部设计

选择
土木单元
三维工具
父主题: OpenRoads Designer CONNECT Edition帮助


模型细部设计 模型细部设计 模型细部设计

选择

另请参阅选择

父主题: 模型细部设计


土木单元

此帮助提供有关 Bentley 土木单元的参考信息。提供了以下主要主题领域：

土木单元概览
土木单元工具箱
土木单元和特征定义
浏览土木单元
土木单元创建指导
父主题: 模型细部设计


土木单元概览

土木单元是几何图形、模板和地形模型这些土木元素的集合，可以在设计中重复放置。土木元素的集合是相对于一个或多个参考元素创建的。放置土木单元时，需选择新的参考元素，之后即可相对于这些元素创建新的土木元素集合。因此，可将土木单元视为原始土木元素集合相对于新参考元素几何图形的副本。土木单元可以是二维单元，也可以是三维单元。它们可以仅包含二维（平面）元素或三维元素（具有纵断面的二维元素），并且可以包括地形、线性模板、区域模板和简单廊道。

创建新的土木元素时，还会同时创建与之关联的所有规则。这意味着，新土木元素会保留彼此间关系以及与参考元素之间的关系，因此，它们知道在这些关系更改时如何做出反应。此外，仍可对新的土木元素使用“土木”和 MicroStation 工具集，以根据需要调整和进一步细化设计，因为通过土木工具创建的土木元素与通过放置土木单元创建的土木元素之间没有区别。

使用土木单元可以节省大量的时间和精力，因为它们可以复制在创建土木元素时所需的全套步骤。它们支持设计团队使用土木单元，因而有助于确保符合设计标准。

使用示例

土木单元可用于重新创建任何明确定义的土木元素集合。土木单元的常见使用示例包括：

  • 交通岛和行人安全岛

  • 车道和通道

  • 交通稳静化功能

  • 路侧停车带

  • 交点

  • 多头转塔/庭院圆形凹陷部分

  • 合并和分散坡道

  • 建筑地坪

  • 环形交通枢纽

共享土木单元

尽管可以在当前 DGN 中创建和放置土木单元，但您可能希望在其他 DGN（可能代表当前设计的其他部分或者完全不同的设计）中使用它们。为了获得最大的灵活性，请在库文件 (DGNLib) 中创建土木单元。

Civil_Civilcelldgnliblist

此配置变量定义文件夹结构或单个文件。

CIVIL_CIVILCELLDGNLIBLIST > $(_USTN_PROJECTDATA)/dgnlib/Civil Cell Examples/*.dgnlib

CIVIL_CIVILCELLDGNLIBLIST > $(_USTN_PROJECTDATA)/dgnlib/Civil Cell Examples /example civil cell.dgnlib

可以引用包含土木单元的 DGN，而且可以将来自这些参考文件的单元置于新参考上以在当前设计模型中创建新的实例。当前土木单元实例放置在 DGN 中后，即可立即重复使用并在本地进行编辑。

使用 SELECTseries 2 和 SELECTseries 3 的土木单元

如果在 MicroStation V8i (SELECTseries 3) 中创建具有土木单元的 DGN 文件并且随后在 MicroStation V8i (SELECTseries 2) 中打开该 DGN 文件，则土木单元创建的元素可见，但不可编辑。例外的情况是土木单元包含地形模型，因为在 MicroStation V8i (SELECTseries 3) 之前不识别“地形”元素类型。尽管地形模型不可见，但数据不会丢失，而且可以在 MicroStation V8i (SELECTseries 3) 中重新打开 DGN 文件，此时，地形模型将再次可见。

父主题: 土木单元


土木单元工具箱

在工具箱中选择 | 描述
放置土木单元 | 激活浏览器以选择要放置的土木单元。可以从激活 DGN 的图形或浏览器（提供来自当前 DGN 中所有设计模型的可用土木单元的示意图预览）中选择土木单元，或者通过当前定义的配置选择土木单元。
创建土木单元 | 激活命令。提示您为新的土木单元命名并选择参考元素。将标识并高亮显示相依元素以供验证。
处理土木单元 | 重新处理所有线性模板和所选土木单元的模板。如果激活地形已更改或需要刷新参考文件交互，可能需要执行此操作。
移除土木单元 | 激活打散命令并锁定土木单元。 标准 MicroStation“打散”命令适用于土木单元，但选择取决于模型中的元素优先级，可能需要循环元素才能选择土木单元。
放置土木单元
处理土木单元
创建土木单元
移除土木单元
父主题: 土木单元


放置土木单元

用于将先前定义的土木单元放置到激活模型中。

您可以通过以下方式访问此工具：

功能区：模型细部设计 > 土木单元

可以通过多种方式放置土木单元：

• 项目浏览器\土木标准 - 导航到土木单元库并右键单击要放置的土木单元。

• 从在 DGN 中找到的现有土木单元，使用对象快捷工具栏选择“放置土木单元”选项。

• 要从任务列表放置土木单元，请使用“放置土木单元”工具，然后按照下面用粗体显示的提示操作。

选择元素

选择要放置的土木单元。如果该单元在当前 DGN 中，则可以从此处选择它，或者您可以使用对话框中的浏览按钮。对话框显示当前 DGN 及任何已加载 DGNLib 中的土木单元，并提供预览来帮助您标识正确的单元。预览以红色显示参考和可选参考元素，从而帮助您了解它们是什么。选择要放置的土木单元并单击“确定”。

定位参考元素

选择第一个参考元素。此提示包括创建土木单元时键入的名称，并显示此参考元素在要求选择的总数中所处的编号，例如，选择两个参考元素中的第一个时则为 1/2。此提示将重复到您选择所有必需的参考元素为止。

选择要查看备选项的元素(重置可跳过)

此提示允许您更改土木单元的构造方式。在该过程的此阶段中，假定每个参考元素都有一定的方向，并相应地构造相依元素。假定的方向并不一定正确，放置在两条线之间时，“插入直-缓-圆-缓-直曲线”可能有几个同样有效的解决方案，因此可以使用此提示更改假定的方向，以便在正确的位置中构造相依元素。将光标置于任何参考元素上方，将显示一个方向箭头，单击鼠标左键以更改此箭头的方向。准备就绪后按“重置”。请注意，此操作不会实际反转参考元素。

选择要剪切的廊道(重置可跳过)

如果您已设置土木单元，使地形模型可用作廊道剪切边界，则可以选择地形将作为剪切元素添加到的廊道。

将地形添加为廊道剪切元素时，还会添加土木单元中的所有线性模板。如果需要，稍后可以从廊道对象列表中移除这些模板。

接受土木单元放置

此提示用于确认您已准备好放置土木单元。点击确认或取消（通过单击“元素选择”工具）。

放置土木单元后，它所包含的元素构成一个集合。如果将光标置于其中的任一元素上方，将看到所有元素均高亮显示。您可以使用键盘上的 Tab 键或鼠标上的“重置”按钮在土木单元及其元素之间循环，或者可以使用 MicroStation“打散元素”工具将土木单元重新打散为其各个元素。

父主题: 土木单元工具箱


处理土木单元

用于重新处理所有线性和区域模板。

您可以通过以下方式访问此工具：

功能区：模型细部设计 > 土木单元

对于选定的土木单元，此命令将重新处理所有线性和区域模板。如果激活地形已更改或需要刷新参考文件交互，可能需要执行此操作。

父主题: 土木单元工具箱


创建土木单元

用于创建土木单元。

您可以通过以下方式访问此工具：

功能区：模型细部设计 > 土木单元

要创建土木单元，请使用“创建土木单元”工具，然后按照下面用粗体标明的提示操作：

土木单元名称

键入土木单元的名称。最好提供一个有意义的名称，这样有助于您在放置过程中识别相应的土木单元。创建土木单元之后，可以在“元素信息”中更改土木单元的名称。

定位参考元素

选择第一个参考元素。参考元素是您希望土木单元所含元素的“父项”，如道路边缘。在放置土木单元时，系统将提示您选择相应的参考元素。请注意，在“创建土木单元”对话框中，可以键入参考元素的名称，您应在选择参考元素之前执行此操作。此名称将用于有关放置土木单元的提示中，因此最好提供一个有意义的名称。创建土木单元之后，可以在“元素信息”中更改此名称。

定位参考元素时，任何相关元素（即，定义完全依赖于参考元素的元素）用实线表示。这意味着在放置土木单元时，该元素已完全定义，“创建土木单元”工具有足够的信息来重新创建该元素。例如，使用“平面几何”工具集中的“过渡偏移”工具创建的元素（如果在土木单元中选择用于创建土木单元的元素作为参考）。

如任何相关元素的定义部分依赖于参考元素，且依赖于另一个尚未选为参考元素的元素，则这些相关元素都将用虚线显示。例如，使用“平面几何”工具集中的“插入直-缓-圆-缓-直曲线”工具创建的元素。该元素在创建时需要两个参考元素，因此在土木单元中拾取其中一个参考元素作为参考只会对其进行部分定义，因此该元素将以虚线显示，直到拾取第二个参考后，才会成为土木单元的一部分。

定位下一个参考元素 - 重置可完成

根据需要选择第二个和后续参考元素，然后重置以完成。使用上面的“插入直-缓-圆-缓-直曲线”示例，需要选择用于创建弧的第二个参考元素才能确保弧已完全定义。完成此操作后，该元素将用实线表示。

定位可选参考 - 重置可完成

按“重置”选择完参考元素之后，可以再选择可选参考。这些参考元在放置土木单元时可能存在，也可能不存在。如果存在，您可以选择这些元素，将使用提供的几何图形。如果不存在，土木单元将使用在创建期间捕获的预定义几何规则创建这些元素。

要创建交点的旁路就是这样的例子。如果旁路很长，您可能已经设计完整的道路廊道，包括道路边缘。如果旁路不太明显，您可能只为其设计了中心线。可以创建交点的土木单元，使旁路中心线成为参考元素，因为它在两种情况下都存在，而旁路的道路边缘可以作为可选参考。在完整的旁路廊道上放置此土木单元时，应选择可选的旁路参考，因为您已经设计这些参考，所以需要使用它们。在旁路中心线上放置土木单元时，应在系统要求您选择可选参考时按“重置”，土木单元将会创建这些参考。

接受土木单元

此提示用于确认土木单元包含所需元素。此时，您已经选择所有参考和可选参考，因此每个元素（包括几何图形、模板和地形模型）将用实线表示。要接受的数据点。

如果有任何元素用虚线显示，这意味着在放置土木单元时，“创建土木单元”工具没有足够的信息来重新创建该元素。在这种情况下，您不应接受土木单元，而应该取消（通过单击“元素选择”工具）。然后，应该查看未完全定义的元素以了解原因。执行此操作的方法之一是选择该元素并在“元素信息”中查看，因为这样可以显示其依赖关系。

父主题: 土木单元工具箱


移除土木单元

用于专为土木单元激活“打散”工具

您可以通过以下方式访问此工具：

功能区：模型细部设计 > 土木单元

专为土木单元激活“打散”工具。

标准 MicroStation“打散”工具适用于土木单元，但选择取决于模型中的元素优先级，可能需要循环元素才能选择土木单元。

父主题: 土木单元工具箱


土木单元和特征定义

在 DGN 文件中使用的土木单元名称必须唯一，并且遵循与土木特征相同的增量命名。土木单元为其内部的所有几何图形特征和土木对象（线性模板、区域模板和廊道）提供了一个容器。

作为唯一的容器 ID，土木单元保留其内部定义的特征定义和特征名称，并将相同的名称转发给每个新实例。在土木单元的每个新实例中，生成的新特征保持不变，因为土木单元名称会保持内部全部对象的标识唯一。

例如，名为“Approach”的平面几何图形可以位于当前设计模型以及任意数量的土木单元中，例如，名为 Type 1、Type 2 和 Type 3 的土木单元中。在此示例中，尽管同一特征具有 4 个实例，但它们全部可唯一标识，因为其他实例所在的土木单元的名称可确保所有实例均唯一。删除这些单元时，其包含的特征和对象会根据标准重命名增量进行重命名，并采用下一个可用名称。

父主题: 土木单元


浏览土木单元

可采用多种方式浏览土木单元的内容。

项目浏览器中的土木单元

项目浏览器可显示土木单元的结构：

所有已从 DGNLibs 加载的土木单元在“土木标准”选项卡中可见：

在这两个位置，可以右键单击土木单元并选择弹出式菜单中的“放置土木单元”选项。也可以选择弹出式菜单中的“属性”选项，此操作将调用“元素信息”对话框。

元素信息中的土木单元

“元素信息”将显示土木单元的结构：

可以使用此对话框来修改土木单元的名称和参考名称。

土木单元的快速属性

选择土木单元即可显示上下文相关工具栏。这包含“快速属性”和“放置土木单元”的图标。

父主题: 土木单元


土木单元创建指导

要创建最灵活的土木单元（即尽量在更多情况下均正确放置的单元），需要考虑几个方面。从根本上说，土木单元是指用于创建新元素的规则集合。因此，规则的构建应当始终采用一种有助于在放置土木单元时正确予以评估的方式。

使用 DGNLib

如果需要能够在不同设计中重用土木单元，则在 DGNLib 中创建它，然后将其放在 MicroStation 启动时会读取的位置。这可确保土木单元始终可用。

如果打算创建大量的土木单元，则有必要组织它们，以便每种类型都有一个 DGNLib，例如一个用于接头，另一个用于坡道。这样做的一个原因是有助于更轻松地导航到土木单元，因为初始选择以类型为依据。另外，将每个土木单元放入适当命名的 MicroStation 模型中也是可取的。

如果已在 DGN 中创建一些希望能够在 DGNLib 中共享的土木单元，则可以使用以下过程：

  1. 在 DGN 中创建土木单元

  2. 打开要包含土木单元的 DGNLib

  3. 参考包含 DGNLib 中土木单元的 DGN

  4. 在 DGNLib 中创建元素以用作参考元素

  5. 使用“放置土木单元”工具将土木单元放置在这些参考元素上

DGNLib 现在将包含土木单元且可根据需要共享。

尽可能减少内容

考虑土木单元真正需要包含的内容，并仅包括最少内容。例如，如果要为接头创建土木单元，则很可能只需要包含一个参考元素以表示主干道的道路边缘。它不应包括道路的任何廊道或其他元素，因为它们不属于接头，而且会导致额外的处理。不能删除土木单元中的相依元素。因此，一旦放置土木单元，就必须删除任何额外的元素。同样，如果路面构造深度经常变化，则在放置土木单元之后应用模板对层建模可能比删除表面模板并应用不同的模板更容易。如果构造深度十分标准，则土木单元中的表面模板可能是最有效的程序。

选择合适的参考元素

考虑以下显示的情况：

如果要为此交点创建一个土木单元，则选择两条白色虚线作为参考似乎较为明智。但是，这不太可能生成最灵活的土木单元。我们已使用“水平偏移过渡”工具创建黄色元素（表示道路边缘），其中利用白色虚线作为参考。如果选择白色虚线作为参考，则道路边缘将包括在土木单元中，这不一定是必需操作，因为每次放置土木单元时都会创建道路边缘。如果将土木单元放置在道路的几个位置中，这可能会产生多个副本。

在这种情况下，最好选择道路边缘作为参考：

橙色线是选定的参考，蓝色线是将包括在土木单元中并由其创建的元素。

如果交点实际上是一个通道或车道，则可能需要土木单元包括两条边。如果是这样，则选择主干道的边和侧面道路的中心：

注意，在此示例中，土木单元将延伸前路径参考元素的整个长度。通常，要求土木单元的总长度受到约束。此约束可以通过使用来自交点的已定义长度从主要参考部分构造控制元素来实现。

使用土木单元剪切廊道

当放置一个土木单元时，它往往会重叠其他土木元素，有时会需要通过在土木单元范围内剪切其他土木元素来整理它。为此，需要创建一个地形模型作为土木单元的一部分，以充当剪切边界。

创建土木单元时，将包括用于创建地形模型的元素和地形模型本身：

现在选择土木单元，并在“元素信息”中查看它。展开“相关元素”的树视图节点，将看到列出的地形模型。右键单击它以显示弹出菜单，然后选择“添加边界地形”：

放置土木单元时，可以选择此地形来剪切接收廊道。

在上述情况下，最好沿着停止点或屈服线在交点的顶部包括边界元素。如果主干道的参考元素已弯曲，则应当完成此操作以确保剪切边界的形状仍然正确。

起点和终点位置

如果要在土木单元中创建一定长度的元素，则可以使用“土木精确绘图”相对于已知位置（通常是两个元素的交点）将起点和终点桩号指定为“增量桩号”。

如果土木单元在绝对桩号处创建，则这些土木单元在接收几何图形中可能不存在，因此不会放置土木单元。

使用点

二维点可用于定位土木单元。例如，对于人行横道孤岛，孤岛两侧与参考元素平行，您需要能够将该孤岛放置在沿参考元素的任何位置。这意味着创建两侧时不应指定起点和终点桩号，因为它们会存储在土木单元中，且始终放置在这些桩号上。更有效的技巧是放置一个点，然后放置元素以形成相对于该点的孤岛。例如，使用相对参考元素的偏移为孤岛各侧创建偏移过渡元素，但通过捕捉到该点来定义起点，并使用长度来定义终点。现在，选择并移动该点，孤岛两侧将随之移动。创建土木单元时，需将该点定义为参考元素，以便在放置土木单元时系统提示您选择该点。不必创建一个点来执行此操作，可以使用捕捉，或使用“土木精确绘图”来定义点的位置，或者只使用数据点，这意味着定义位置时具有很大的灵活性。

还有其他类型的构造也可以从这种技术中受益，例如，公交车站、交通宁静特征和合并/分散坡道。

三维点可用于实现两个目标，因为它不仅可用于定位土木单元，而且还可用于定义土木单元的高程。例如，在转动头的情况下，几何图形可能会由一个圆构成，两个圆角将转动头连接到道路的末端。在这种情况下，点可用于定位圆的中心。如果是三维点，则也可用于将高程应用于圆。放置土木单元时，可以使用“土木精确绘图”捕捉到合适元素的轮廓，例如道路的中心线或地形模型。

土木精确绘图

“土木精确绘图”提供在土木单元中创建完全约束几何图形所需的几何结构。它可以使用两个纵坐标约束点，这两个纵坐标是相对于它们构造的元素，例如距离或偏移约束。此技术的一个有用示例是为交点创建转弯车道，其中需要长度距两个道路中心线的交点有一定的距离。在这种情况下，“增量桩号”选项可能会提供最灵活的解决方案。

测试土木单元

创建土木单元时，需测试要捕获的几何规则。在创建土木单元中所需的所有元素之后，但在创建土木单元本身之前，需要彻底测试这些元素是否均可对多个更改做出正确反应。这可以通过移动参考元素并检查所有相关元素是否也移动来完成。如果任何元素未正确更新，则需要在创建土木单元之前解决此问题。

父主题: 土木单元


三维工具

您将在“三维工具”中找到以下主题：

三维几何图形三维工具
父主题: 模型细部设计


三维几何图形三维工具

包含用于绘制 Civil 3D 元素、应用线性和表面模板的工具。其他工具包括“通过土方量创建三维元素”（可用于水塘设计）和“通过放坡创建到目标的三维元素”。

在工具箱中选择

描述

应用线性模板

访问“拾取模板”对话框，然后在相对于线性元素的绘图中插入所选模板。

应用表面模板

访问“拾取模板”对话框，然后在相对于地形模型的绘图中插入所选模板。

三维元素

  • 通过放坡将三维元素应用到目标

  • 通过土方量创建三维元素

  • 按平面图纵断面的附加三维体

  • 按三维元素的平面图

创建从线性元素计算到表面的三维元素。

从另一个参考表面创建按土方量计算的地形模型。

“按平面图纵断面的附加三维体”工具从纵断面线的一部分创建三维元素。

从三维 MicroStation 元素创建二维元素并利用激活纵断面的原始三维元素。

应用线性模板
应用表面模板
通过放坡将三维元素应用到目标
通过土方量创建三维元素
按平面图纵断面的附加三维体
通过三维元素创建平面元素
父主题: 三维工具


应用线性模板

用于访问“拾取模板”对话框，然后将选定模板相对于线性元素插入图纸中。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具
  1. 打开“土木工具”任务窗格，找到“三维几何图形”部分，然后单击“应用线性模板”图标。
    将打开“应用线性模板”对话框。

    选中任一字段旁边的框将会锁定关联的值。

  2. 将光标移至视图中后，系统将给出命令提示，要求您“定位要应用模板的元素”，请将光标移至要应用模板的线性元素，然后点击确认，例如单击鼠标左键。

  3. 系统提示“选择模板”时，必须按住 Alt 键并单击向下箭头键，打开“拾取模板”对话框。
  4. 对话框打开后，导航树以选择可用模板，然后单击“确定”，并在视图中点击确认。
注释: “选择模板”命令提示会保留您上次的选择，如果要应用相同模板的多个实例，只需在显示填充的提示时点击确认即可。
父主题: 三维几何图形三维工具


应用表面模板

用于访问“拾取模板”对话框，然后将选定模板相对于地形模型插入图纸中。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具

使用“应用表面模板”命令可以访问“拾取模板”对话框，然后将选定模板相对于地形模型插入图纸中。

  1. 从如上所示的“三维工具”组中选择“应用表面模板”按钮。

  2. 将光标移至视图中后，系统将给出命令提示，要求您“定位地形模型”，请将光标移至要应用模板的地形模型上，然后点击确认，例如单击鼠标左键。

  3. 系统提示“选择模板”时，必须按住 Alt 键并单击向下箭头键，打开“拾取模板”对话框。

  4. 对话框打开后，导航树以选择可用模板，然后单击“确定”，并在视图中点击确认。

注释: “选择模板”命令提示会保留您上次的选择，如果要应用相同模板的多个实例，只需在显示填充的提示时点击确认即可。

应用外部剪切边界

选中此工具可以在选定地形模型中选择闭合的形状特征，从而限制应用表面模板的区域。

父主题: 三维几何图形三维工具


通过放坡将三维元素应用到目标

用于创建从线性元素计算的到曲面的三维元素。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具 > 三维元素拆分按钮

通过放坡创建到目标的三维元素使用“通过放坡创建到目标的三维元素”工具可以创建从线性元素计算的到曲面的三维元素。

注释: 工作空间必须包含平面视图和打开纵断面模型才能使用此工具。

  1. 打开“土木工具”任务窗格，找到“三维几何图形 (3D Geometry)”部分，然后单击“通过放坡创建到目标的三维元素”图标。

  2. 将光标移至视图中后，系统将给出命令提示，要求您选择“边坡选项”，请单击向下箭头键以导航可用的选项，然后点击确认，例如单击鼠标左键。

    • 将打开“通过放坡创建到目标的三维元素”对话框。

    • 选中任一字段旁边的框将会锁定关联的值。

  3. 系统提示选择“边坡选项”时，单击向上或向下箭头键导航选项，然后按 Enter 键。

  4. 系统提示选择“挖方/填方选项”时，单击向上或向下箭头键导航选项，然后按 Enter 键。

  5. 使用以下其中一种方法设置挖方和/或填方值：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后点击确认。

  6. 使用以下其中一种方法定位前延伸距离：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入值并按 Enter 键，然后单击鼠标左键。

  7. 系统提示选择“过渡类型”时，单击向上或向下箭头键导航选项，然后按 Enter 键。

  8. 系统提示选择“弯头选项”时，单击向上或向下箭头键导航选项，然后按 Enter 键。

  9. 使用以下其中一种方法指定“放坡位置”（单击向左或向右箭头键导航选项）：

    • 使用向上或向下箭头键进行导航并按 Enter 键，选择一个边。

    • 要设置“起点”或“终点”，请移动光标；会在提示框中显示值，在所需值处点击确认。

父主题: 三维几何图形三维工具


通过土方量创建三维元素

用于创建通过另一参考表面中的土方量计算所得的地形建模。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具 > 三维元素拆分按钮

使用“通过土方量创建三维元素”工具可创建通过闭合参考土木元素中的土方量计算所得的三维元素。还可以使用该工具从水塘参考元素（可向其中添加线性模板作为绑定到地形模型的末端条件）底部创建水塘元素顶部。

前提条件：

要使用此工具，激活文件必须包含平面（闭合）和关联的纵面几何图形元素或三维闭合元素。

设置 | 描述
设计方法 | 由下至上 - 通过将斜率向上和向外投影来设计三维元素（不考虑标记）。如果输入负斜率，则忽略标记。 由上至下 - 通过将斜率向下和向内投影来设计元素（不考虑标记）。
净高 | 使用“由下至上”方法时，净高为从土方量顶部到所创建元素的高度。例如，如果土方量计算高程为 205.00，净高为 6，则在 211.00 处绘制三维元素。 使用“由上至下”方法时，净高为从土方量底部到所创建元素的高度。例如，如果土方量计算高程为 205.00，净高为 6，则在 199.00 处绘制三维元素。
边坡 | 从参考的几何图形元素绘制的斜率。字段使用百分比，但可以输入替代值（例如 1:50），该值会自动转换。忽略标记，因为方向由选择的“设计方法”决定。
目标土方量 | 元素的土方量（以主单位计，立方英尺或立方米），使用两个三维元素和投影斜率来构成闭合体积块。如果无法得出土方量，则会显示一条消息，指示无解决方案。
平面面积（仅显示） | 创建之后，新创建的闭合元素的平面面积显示在工具设置中（以主单位计，平方英尺或平方米）。
特征定义 | 用作所创建元素的符号基础的特征定义。
名称 | 所创建元素的名称，缺省值基于“特征定义”设置。

元素处理程序和属性

有三个元素处理程序与元素一起放置且可编辑：

  • 目标土方量
  • 净高
  • 边坡

选择三维元素的属性会显示相关属性：

工作流: 通过土方量创建三维元素

  1. 选择“通过土方量创建三维元素”工具。

  2. 在“工具设置”中，选择“特征定义”并输入“名称”（如果需要）。

  3. 按照提示操作：

提示 | 用户操作
选择元素 | 以图形方式选择闭合土木元素。
设置设计选项 | 选择“由下至上”或“由上至下”。（使用键盘箭头键可更改选择。）点击确认以移动到下一提示。
设置边坡 | 键入边坡，按 Enter，然后点击确认以移动到下一提示。
设置净高 | 键入净高（设置为 0 代表无），按 Enter，然后点击确认以移动到下一提示。
目标土方量 | 键入目标土方量，按 Enter，然后点击确认以移动到下一提示。
点击确认 | 现在即会填充“工具设置”中的平面面积字段。点击确认以完成序列并绘制所创建的三维元素。如果无法求解目标土方量，则会显示错误消息。
父主题: 三维几何图形三维工具


按平面图纵断面的附加三维体

用于从纵断面线的一部分创建三维元素。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具 > 三维元素拆分按钮

“按平面图纵断面的附加三维体”工具从纵断面线的一部分创建三维元素。该部分通过指定起点距离和终点距离来定义，从平面几何图形元素的开头以主单位进行测量。除非已指定桩号设置，否则元素起始点的起点距离为 0.0。如果已指定桩号设置，则将其用于起点和终点距离字段。

前提条件：激活文件必须包含平面视图和纵断面视图才能使用此工具。参考元素必须具有激活纵断面，不过，可以在工具中选择另一纵断面。

输入值并激活复选标记开关将锁定该值。

工作流: 按平面图纵断面创建附加三维元素

  1. 选择“按平面图的附加三维体”工具。

  2. 在“工具设置”中，设置“特征定义”和“名称”。

  3. 将光标移动到平面视图中并按危险警告提示进行操作：

    危险警告提示

    用户操作

    定位平面图元素

    以图形方式选择要用作三维元素参考元素的元素。如果该元素没有纵面几何图形，则会显示一条消息，并且不会创建任何元素。

    起点距离

    以图形方式定义（以垂直于参考元素的虚线为基础）三维元素的起始点。也可以键入并锁定距离（桩号）。按键盘上的 <ALT> 键会缺省将起点距离锁定至元素开头，即 0。

    终点距离

    以图形方式定义（以垂直于参考元素的虚线为基础）三维元素的终点。也可以键入并锁定距离（桩号）。按键盘上的 <ALT> 键会缺省将终点距离锁定至元素结尾。

    定位纵断面 - 重置可激活纵断面

    将光标移动到纵断面视图中，并在所需的纵断面元素上点击确认。

    系统即会使用“特征定义”符号在激活文件中绘制三维元素。

父主题: 三维几何图形三维工具


通过三维元素创建平面元素

用于从三维 MicroStation 元素创建二维元素并利用激活纵断面的原始三维元素。

您可以通过以下方式访问此工具：

  • 功能区：模型细部设计 > 三维工具 > 三维元素拆分按钮

“通过三维元素创建平面元素”工具从三维 MicroStation 元素创建二维元素并利用激活纵断面的原始三维元素。请注意，如果三维元素已具有二维表示，则选择时会显示一条消息，且不会采取进一步操作。对三维元素所做的任何修改均会反映在二维元素中。由于二维元素带形线，因此不能独立于三维元素进行修改。（要修改二维元素，请先移除规则。）如果删除三维元素，则还会删除二维平面元素，且不会发出警告。

前提条件：需要三维 MicroStation 元素，且必须打开三维视图以供选择。

工作流: 从三维元素创建二维平面元素

  1. 选择“通过三维元素创建平面元素”工具。

  2. 在“工具设置”中，设置“特征定义”和“名称”。

  3. 按照危险警告提示（“定位三维元素”）操作，以图形方式选择三维 MicroStation 元素。

父主题: 三维几何图形三维工具


绘图制作

从选取列表中选择 OpenRoads Designer 绘图制作。

该菜单更改为组织在功能区选项卡中的 OpenRoads Designer 工具，以查找以下工具：元素选择，剪切体积块、保存的视图、表、批注、文本、注释和命名边界工具。

注释
命名边界
标签
父主题: OpenRoads Designer CONNECT Edition帮助


注释

标注元素
移除元素标注
标注模型
移除模型标注
父主题: 绘图制作


标注元素

功能区： OpenRoads Designer 制图 > 注释
  1. 选择“组件标注”>“标注元素”，然后标识元素和所含元素要添加注释的选择集。 要使“标注元素”工作，元素特征定义需要定义的标注组。
  2. 重置以完成。 例如，选择路线和沿路线显示的注释。 例如，选择选择集、数据点和显示在选择集内所有元素上的注释。
  3. OpenRoads Designer 制图 > 绘图比例注释比例识别 (Drawing Scales Annotation scale aware)。更改比例以自动更改注释。
注释自动以适当比例显示在元素上。
父主题: 注释


移除元素标注

功能区： OpenRoads Designer 制图 > 注释
  1. 选择“组件标注”>“移除元素标注”并标识要移除注释的元素。
  2. 重置以完成。
注释将从元素中移除。
父主题: 注释


标注模型

功能区： OpenRoads Designer 制图 > 注释
  1. 选择工具并标识要添加注释的模型。
  2. 在提示下，是否要注释所有模型？

    选中“所有绘图模型”以显示“是”，以标注所有模型并处理同一图纸集中的所有模型。

    取消选中“所有绘图模型”以显示“否”，以禁用注释。

  3. 选择标注组。
  4. 点击确认或输入。 重新注释剖面并更新图纸模型。
父主题: 注释


移除模型标注

功能区： OpenRoads Designer 制图 > 注释
选择“标注设置”>“移除模型标注”并标识要仅按当前模型移除注释或添加标记以从所有模型中移除。
父主题: 注释


命名边界

管理、查看和应用命名边界和命名边界组。

通过以下方式访问此对话框：

功能区： OpenRoads Designer 建模 > 视图 > 命名边界。

功能区： OpenRoads Designer 制图 > 命名边界。

设置 描述
放置命名边界
打开用于创建放置命名边界的“放置命名边界”工具。
“命名边界”列表框 “命名边界”可管理命名边界和命名边界组。
  • 名称 - 命名边界或命名边界组的名称。
  • 描述 - 命名边界或命名边界组的描述。
  • 文件名 - 设置要创建的命名边界或命名边界组的名称。
  • 显示 - 选中此复选框可打开或关闭命名边界或命名边界组的显示。
“命名边界”对话框
GUID-516EC5B6-E87A-4E73-BAF4-E2015AF4AB68
放置命名边界土木平面图
按元素放置命名边界土木平面图
放置命名边界土木剖面图
按土木横断面放置命名边界
放置命名边界土木横断面 2 点
命名边界平面组
命名边界链接平面纵断面组
命名边界纵断面组
命名边界横截面组
命名边界其他组
命名边界管理器
调整纵断面命名边界
父主题: 绘图制作


“命名边界”对话框

此对话框可管理、查看和应用命名边界和命名边界组。

通过以下方式访问此对话框：

  • OpenRoads Designer 制图 > 命名边界。
  • OpenRoads Designer “制图”>“视图”>“命名边界”。
设置 | 描述
放置命名边界 | 打开用于创建放置命名边界的“放置命名边界”工具。
土木平面图 | “放置命名边界土木平面图”模式工具。
土木平面图(按元素) | “按元素放置命名边界土木平面图”模式工具。
土木剖面图 | “放置命名边界土木剖面图”模式工具。
土木横断面 | 创建土木横断面图纸。
土木横断面 2 点 | “放置命名边界土木横断面 2 点”模式工具。
父主题: 命名边界


放置命名边界土木平面图

工作流

  1. 访问或参考平面几何图形。
  2. 以图形方式标识平面几何图形。
  3. 选择要使用的绘图种子。
  4. 设置比例以及“起点桩号”值和“终点桩号”值。
  5. 根据需要修改其他字段。
  6. 启用“创建图纸”开关。
  7. 在 DGN 文件中点击确认以放置边界，然后再次点击确认以接受。
  8. 在“创建图纸”对话框上选择“确定”。
设置 | 描述
绘图种子 | 指定绘图种子，用于为对话框中除起点和终点位置之外的所有值设置默认值。此外，还包含用于创建横截面图纸和种子模型的种子文件的定义，包括绘图在图纸上的定位方式。
详细比例 | 设置放置命名边界所依据的比例。
名称 | 输入命名边界的名称。 注释: MicroStation 模型不能在名称或组中包含以下字符：\\/:*?<>|\"\t\n&=,'
描述 | 输入新组的简短描述。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。 注释: MicroStation 模型不能在名称或组中包含以下字符：\\/:*?<>|\"\t\n&=,'
名称 | 输入新组的名称。
描述 | 输入新组的简短描述。
起点位置 | 设置起点桩号。
终点位置 | 设置终点桩号。
长度 | （仅当选择“按长度”时才可用）设置命名边界元素沿路径元素的长度。此外，还要确定后续边界元素沿该路径的位置。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“长度”字段中。
左偏移 | （仅当选择“按长度”时才可用）设置路径的左边距。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“左偏移”字段中。
右偏移 | （仅当选择“按长度”时才可用）设置路径的右边距。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“右偏移”字段中。
重叠 | （仅当选择沿路径放置命名边界阵列时才可用）设置命名边界元素要沿路径元素延伸的距离。正值会延伸命名边界元素，负值会缩短该元素。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“重叠”字段中。
边界弦 | （仅当选择“按长度”时才可用）设置命名边界中的弦数。弦越多，在曲线中划命名边界的效果越好。
创建图纸 | 在创建命名边界之后打开“创建图纸”对话框，以根据选定的命名边界创建保存的视图并自动化动态视图。
显示对话框 | 启用时，系统将显示一个对话框，其中包含由“绘图种子”设置的其他参数。
父主题: 命名边界


按元素放置命名边界土木平面图

“命名边界”工具，用于将命名边界替换为自定义命名边界。例如，交点。

工作流

  1. 访问或参考平面几何图形以及其他所需文件。
  2. 以图形方式标识平面几何图形。
  3. 以图形方式标识要用于剪切的 MicroStation 形状。
  4. 选择“绘图种子”。
  5. 根据需要修改其他字段和开关。
  6. 启用“创建图纸”开关。
  7. 在 DGN 文件中点击确认以接受。
  8. 在“创建图纸”对话框上选择“确定”。
设置 | 描述
绘图种子 | 指定绘图种子，用于为对话框中的所有值设置默认值。此外，还包含用于创建横截面图纸和种子模型的种子文件的定义，包括绘图在图纸上的定位方式。
名称 | 输入命名边界的名称。
描述 | 输入新组的简短描述。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。
名称 | 输入新组的名称。
描述 | 输入新组的简短描述。
重叠 | 设置命名边界元素要沿路径元素延伸的距离。正值会延伸命名边界元素，负值会缩短该元素。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“重叠”字段中。
创建图纸 | 在创建命名边界之后打开“创建图纸”对话框，以根据选定的命名边界创建保存的视图并自动化动态视图。
显示对话框 | 启用时，系统将显示一个对话框，其中包含由“绘图种子”设置的其他参数。
父主题: 命名边界


放置命名边界土木剖面图

工作流

  1. 访问或参考纵面几何图形。
  2. 选择“绘图种子”。
  3. 根据需要设置比例和桩号设置方法。
  4. 根据需要修改其他字段和开关。
  5. 启用“创建图纸”开关。
  6. 在纵断面模型中点击确认以放置边界，然后再次点击确认以接受。
  7. 在“创建图纸”对话框上选择“确定”。
设置 | 描述
绘图种子 | 指定绘图种子，用于为对话框中除起点和终点位置之外的所有值设置默认值。此外，还包含用于创建横截面图纸和种子模型的种子文件的定义，包括绘图在图纸上的定位方式。
详细比例 | 设置放置命名边界所依据的比例。
名称 | 输入命名边界的名称。
描述 | 输入新组的简短描述。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。
方法
  • 桩号限制
  • 从平面图组。纵断面边界的限制将与指定平面图组中的平面图边界相匹配。
平面图组 | 选择“从平面图组”作为方法时可用。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。
名称 | 输入新组的名称。
描述 | 输入新组的简短描述。
竖向放大系数 | 指定所显示纵断面的竖向放大系数。此参数的值大于 1.0 会增加放大系数。
可用纵断面高度 | 在需要调整和步进视图之前，纵断面视图可以显示的视图深度（采用模型单位，无缩放）。
顶部净距 | 在纵断面上方相对于视图中的设计和/或地形模型保留的高度（采用模型单位，无缩放）。
底部净距 | 在纵断面下方相对于视图中的设计和/或地形模型保留的高度（采用模型单位，无缩放）。
高程基准间距 | 移动纵断面时，起始高程将始终是该值的倍数。
桩号基准间距 | 在分割纵断面以生成阶梯纵断面时，对桩号位置应用的取整。
纵断面移位 | 基准桩号、所需位置或不移位
使用地形 | 启用时，将在绘制纵断面时使用激活表面信息。
使用激活纵面 | 启用时，将在绘制纵断面时使用激活纵面信息。
创建图纸 | 在创建命名边界之后打开“创建图纸”对话框，以根据选定的命名边界创建保存的视图并自动化动态视图。
显示对话框 | 启用时，系统将显示一个对话框，其中包含由“绘图种子”设置的其他参数。
父主题: 命名边界


按土木横断面放置命名边界

工作流

  1. 访问或参考几何图形、地形和廊道以及其他所需文件。
  2. 同时启用二维和三维视图。
  3. 以图形方式标识二维视图中的平面几何图形。
  4. 选择“绘图种子”。
  5. 设置比例以及“起点”和“终点”桩号值。
  6. 根据需要修改其他字段和开关。
  7. 启用“创建图纸”开关。
  8. 二维视图中点击确认以放置边界，然后再次点击确认以接受。
  9. 在“创建图纸”对话框上选择“确定”。
设置 | 描述
绘图种子 | 指定绘图种子，用于为对话框中除起点和终点位置之外的所有值设置默认值。此外，还包含用于创建横截面图纸和种子模型的种子文件的定义，包括绘图在图纸上的定位方式。
详细比例 | 设置放置命名边界所依据的比例。
名称 | 输入命名边界的名称。
描述 | 输入新组的简短描述。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。
名称 | 输入新组的名称。
描述 | 输入新组的简短描述。
起点位置 | 设置起点桩号。
终点位置 | 设置终点桩号。
长度 | （仅当选择“按长度”时才可用）设置命名边界元素沿路径元素的长度。此外，还要确定后续边界元素沿该路径的位置。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“长度”字段中。
左偏移 | （仅当选择“按长度”时才可用）设置路径的左边距。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“左偏移”字段中。
右偏移 | （仅当选择“按长度”时才可用）设置路径的右边距。如果使用该字段旁边的“测量距离”工具，测量的距离将显示在“右偏移”字段中。
间隔 | 指定连续横截面之间的间距。
竖向放大系数 | 指定所显示横截面的竖向放大系数。此参数的值大于 1.0 会增加放大系数。
顶部净距 | 启用顶部净距以输入值。
底部净距 | 启用底部净距以输入值。
高程基准间距 | 移动纵断面时，起始高程将始终是该值的倍数。
包括控制点 | 在平面控制点（如 PC 和 PT）处添加横截面。
创建图纸 | 启用时，创建命名边界后将自动启动横截面图纸创建过程。禁用时，系统将创建命名边界，但不创建图纸。
显示对话框 | 启用时，系统将显示一个对话框，其中包含由“绘图种子”设置的其他参数。
父主题: 命名边界


放置命名边界土木横断面 2 点

工作流

  1. 访问或参考几何图形、地形和廊道以及其他所需文件。
  2. 同时启用二维和三维视图。
  3. 以图形方式标识二维视图中的平面几何图形。
  4. 选择“绘图种子”。
  5. 根据需要修改其他字段和开关。
  6. 启用“创建图纸”开关。
  7. 通过放置 2 个数据点（基线两侧各一个）以图形方式标识线。
  8. 二维视图中点击确认以接受。
  9. 在“创建图纸”对话框上选择“确定”。
设置 | 描述
绘图种子 | 指定绘图种子，用于为对话框中除起点和终点位置之外的所有值设置默认值。此外，还包含用于创建横截面图纸和种子模型的种子文件的定义，包括绘图在图纸上的定位方式。
组 | 选择命名边界组。您还可以通过从下拉列表中选择“新建”来创建新组。 注释: MicroStation 模型不能在名称或组中包含以下字符：\\/:*?<>|\"\t\n&=,'
名称 | 输入新组的名称。
描述 | 输入新组的简短描述。
竖向放大系数 | 指定所显示横截面的竖向放大系数。此参数的值大于 1.0 会增加放大系数。
顶部净距 | 启用顶部净距以输入值。
底部净距 | 启用底部净距以输入值。
高程基准间距 | 移动纵断面时，起始高程将始终是该值的倍数。
创建图纸 | 在创建命名边界之后打开“创建图纸”对话框，以根据选定的命名边界创建保存的视图并自动化动态视图。
显示对话框 | 启用时，系统将显示一个对话框，其中包含由“绘图种子”设置的其他参数。
父主题: 命名边界


命名边界平面组

工作流

  1. 访问或参考命名边界。
  2. 参考几何图形以及所有其他所需文件。
  3. 选择所需的平面图组。
  4. 单击“创建平面图纸”图标。
父主题: 命名边界


命名边界链接平面纵断面组

工作流

  1. 访问或参考命名边界。
  2. 参考几何图形以及所有其他所需文件。
  3. 打开纵断面模型。
  4. 选择所需的平面图组或纵断面组。
  5. 单击“创建平面/纵断面图纸”图标。
父主题: 命名边界


命名边界纵断面组

工作流

  1. 访问或参考命名边界。
  2. 参考几何图形以及所有其他所需文件。
  3. 选择所需的纵断面组。
  4. 单击“创建纵断面图纸”图标。
父主题: 命名边界


命名边界横截面组

工作流

  1. 访问或参考命名边界。
  2. 参考几何图形、地形和廊道以及其他所需文件。
  3. 同时启用二维和三维视图。
  4. 选择所需的横截面组。
  5. 单击“创建横截面图纸”图标。
父主题: 命名边界


命名边界其他组

这些是 MicroStation 生成的命名边界。有关详细信息，请参阅 MicroStation 帮助。
父主题: 命名边界


命名边界管理器

工作流

  1. 访问或参考包含命名边界的文件或模型。
  2. 选择所需的命名边界组并根据需要使用工具。
父主题: 命名边界


调整纵断面命名边界

此工具允许在初始布局后动态调整纵断面命名边界，其中需要调整视图以更好地适应纵断面视图中的信息。

此选项提供对初始图纸条件的覆盖，并允许根据激活纵断面模型中选定纵断面命名边界的“基准间距”取整值向上和向下调整。动态调整符合用户定义的基准高程取整值。通过调整初始布局，可以引入、调整或移除阶梯式纵断面。
  1. 激活纵断面模型之后，选择“调整纵断面命名边界”工具。
  2. 以图形方式为需要调整的纵断面命名边界拾取轮廓形状。
  3. 动态向上或向下拖到所需的基准取整位置。
父主题: 命名边界


标签

标签是可以维护与所标记元素之关联的单元。如果单元定义包含字段，这些字段将根据添加标签的元素进行更新。标签可以保持两种类型的关联。一种是常规关联，在这种关联中，当您移动元素时，标签将保持原位不动，只有引线随元素一起移动。另一种是相对关联，在这种关联中，标签与原始捕捉点的相对位置将保持不变。也就是说，当您移动元素时，标签也会随之移动。

可以在位于下列位置之一的 .cel 文件中定义标签：
  • 与激活文件相同的文件夹。
  • 由 MS_CELLLIST 配置变量定义的路径。
放置带引线的标签
放置不带引线的标签
放置标签
父主题: 绘图制作


放置带引线的标签

  1. 在制图工作流中的批注组中，选择放置标签工具。
  2. 选择放置带引线的标签图标。
  3. 选择单元名、尺寸标注样式、标签旋转方法和水平连接方法。
  4. (可选) 依次选择放置带常规关联的标签 [image] 和放置带相对关联的标签 [image] 。
  5. 点击确认以选择要将标签捕捉到的元素。
  6. 输入一个数据点以放置带引线的标签。

    放置带引线的标签

父主题: 标签


放置不带引线的标签

  1. 在制图工作流中的批注组中，选择放置标签工具。
  2. 选择放置不带引线的标签图标。
  3. 选择单元名、尺寸标注样式和水平连接方法。
  4. (可选) 打开放置带相对关联的标签。
  5. 点击确认以选择要将标签捕捉到的元素。
  6. 输入一个数据点以放置标签。

    放置不带引线的标签

父主题: 标签


放置标签

放置标签。

  • 功能区：制图 > 批注
  • 功能区：绘图 > 注释 > 批注
设置 | 描述
放置带引线的标签 | 放置带引线的标签。
放置不带引线的标签 | 放置不带引线的标签。
类型 | 从下拉列表中选择单元类型。
单元名称 | 从下拉列表中选择单元名称。 注释: 拾取单元名称时，如果存在相同的名称，该工具将加载尺寸标注样式。
尺寸标注样式 | 选择引线的尺寸标注样式。 要新建尺寸标注样式，请单击“尺寸标注样式”选项菜单旁边的浏览图标 [image] 以打开“尺寸标注样式”对话框。 要将任何尺寸标注相关的工具设置恢复为缺省尺寸标注样式设置，请单击重置样式图标。
标签旋转 | 相对于引线设置标签旋转：“水平”、“垂直”或“线内”。
起自 | 设置标签应从端符还是从单元开始。
水平连接 | 设置引线连接端：“自动”、“左”或“右”。
注释比例 | 打开注释比例。打开此锁时，注释比例应用于剖面索引符号。缺省情况下，注释比例从模型的“注释比例”设置中获取。只能在“属性”对话框的模型属性中更改此比例。但在模型的“传播注释比例”属性关闭时例外。这种情况下，可以通过每个元素的属性单独控制该元素的注释比例。
放置带常规关联的标签 | 设置与元素的常规关联。如果在放置标签时打开此设置并关闭放置带相对关联的标签，则放置标签时将带常规关联。在这种情况下，如果移动元素，则标签保留在相同的位置，只有引线随元素一起移动。
放置带相对关联的标签 | （仅当启用“放置带关联的标签”时才启用）设置与元素的相对关联。如果放置的标签带有与元素的相对关联，则该标签相对于原始捕捉点保留在相同的位置。也就是说，当您移动元素时，标签也会随之移动。
尺寸标注样式
父主题: 标签


尺寸标注样式

尺寸标注样式是保存的一组尺寸标注设置。在“尺寸标注样式”对话框中，您可以创建和管理尺寸标注样式。

选项按选项卡组织，您可以在预览区域中快速查看样式修改。尺寸标注样式可以存储在打开的 DGN 文件或 DGN 库中。

您可以定义尺寸标注样式，并在放置期间将其应用于元素尺寸标注。您可以创建尺寸标注样式并对其进行自定义和保存，以便于调出。对某个尺寸标注样式所做的更改会传播到 DGN 文件中先前使用该尺寸标注样式设置的所有尺寸标注。

尺寸标注样式可以存储在 DGN 库中并在 DGN 文件中加以使用。在 DGN 文件中对尺寸标注样式（来自尺寸标注样式库）进行更改后，如果未保存该样式，则所做更改称为替代 。如果更改且保存了该样式，则使用替代放置的尺寸标注不会更改。要移除替代，可以使用“更改尺寸标注”工具来匹配尺寸标注样式。

“尺寸标注”工具使用激活尺寸标注样式。

尺寸标注样式
父主题: 放置标签


测量

从选取列表中选择“测量”。

该菜单更改为“测量”工具，这些工具已组织为功能区选项卡，可查找以下内容：

测量处理
数据
测量外业薄
分析
测量编辑
测量工具
父主题: OpenRoads Designer CONNECT Edition帮助


测量处理

项目浏览器
特征管理
显示细节
重置细节
重新绘图
父主题: 测量


项目浏览器

显示“土木标准”选项卡和“测量”选项卡。

土木标准选项卡
“测量”选项卡
父主题: 测量处理


土木标准选项卡

为选定命令定义首选项。有关详细信息，请参阅 OpenRoads 标准。

父主题: 项目浏览器


“测量”选项卡

将信息按逻辑分组进行组织，以便进行选择并提高可视性。有关详细信息，请参阅 “测量”选项卡。

父主题: 项目浏览器


特征管理

链接测量特征定义
工作流
父主题: 测量处理


链接测量特征定义

特征定义 - 指定将使用哪个特征表。支持的特征表包括：

  • GEOPAK（smd 文件）

    注意：SMD 文件必须先在 GEOPAK 中导出到 XML，才能“测量”中使用。

  • InRoads（xin 文件）

  • MX（pss 文件）

    注释: 必须先安装 MX，才能通过“测量”成功读取 PSS 文件。

父主题: 特征管理


工作流

  1. 右键单击“特征定义”并从菜单中选择“链接测量特征定义”。

  2. 选择 GEOPAK SMD (* .xml)、InRoads 样式 (* .xin) 或 MX 样式 (* .pss) 等样式文件。

    GEOPAK

    选择 * .xml（XML格式的 SMD 文件），然后选择“打开”将文件处理到 DGNLIB 中。

    InRoads

    选择 * .xin 和“打开”将文件处理到 DGNLIB 中。

    MX

    创建新分类并选择 * .pss。

如果不存在测量特征，则会创建测量特征。如果存在该特征，则将测量信息添加到现有特征中。

条目将重新链接到定义本地产品线符的 XIN、DDB 或 PSS，或链接到 DGNLIB 的元素模板中。

父主题: 特征管理


显示细节

调整以显示选定分支的细节。

有关详细信息，请参阅细节。

父主题: 测量处理


重置细节

将“测量”详细信息重置为默认设置。

有关详细信息，请参阅细节。

父主题: 测量处理


重新绘图

“重新绘图”工具位于“测量处理”任务下（见下图），用于根据当前附加的特征定义与样式文件重新访问和重绘每个测量元素。这意味着，系统会更新所有图形、重绘所有标注，并重新调用附加到元素的所有 VBA 宏。当测量需要强制重绘所有标注时，如将 DGN 首选项更改为以 2 位小数显示高程的情况下，此工具非常有用。或者，当由 VBA 绘制的图形因为在 VBA 宏中发生变化而需刷新时，此工具也会非常有用。如果用户更改“特征”定义，则此工具用处不大，因为测量会自动跟踪这些类型的更改，很少会出现软件对某种类型更改“视而不见”的情况。

父主题: 测量处理


数据

加载数据
工作流
使用文本导入向导加载文件
文本导入向导
数据类型
向导和过滤器
创建向导
修改现有文本导入向导
导入“经典”ASCII 文件
导入所需的列
保存向导
多个过滤器的运行方式
导入各种数据类型
导出
父主题: 测量


加载数据

指定要加载的数据文件类型以及要在“测量”内使用的外业薄。

父主题: 数据


工作流

选择外业簿并指定导入数据文件类型。

父主题: 数据


使用文本导入向导加载文件

使用向导导入文件的步骤。此工作流假设您已创建可用于导入特定文件类型的向导。

  1. 选择要导入的文件（文件名）。

  2. 指定文件包含的数据类型（数据类型）。

  3. 选择用于导入文件的向导（向导名称）。

  4. 单击“确定”导入文件。

选择“加载”>“文件使用文本导入向导”时，将显示“选择对话框 (Select Dialog)”菜单，用于指定要加载的文件。

完成 | 使用当前定义的向导导入文件。
取消 | 关闭对话框，且不执行任何操作。您所做的选择和键入命令均不会保存。
上一步 | 移动到向导中的上一步。
下一步 | 移动到向导中的下一步。
打开 | 显示“选择文本导入向导文件”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。
保存 | 保存打开的向导。如果为先前未保存为 xin、gpk 或 mss 文件的向导选择“保存”按钮，则会遵循“另存为”工作流。
另存为 | 保存向导，以便您可以使用它导入其他类似格式的文件。
打开文本 | 显示“选择数据文本文件”对话框

定义文本文件类型

投影 | 显示“投影”对话框以设置投影设置。选择以显示“源”对话框。指定从设置的“地理库 (Geographic Libraries)”中选择的设置。“搜索”变得可用。选择“确定”以调用。单击“投影”对话框上的“接受”。
记录格式 | 统一 指定所有记录具有相同的格式。 非统一 指定记录具有不同的格式。
数据类型 | 分隔 指定逗号等字符分隔每个字段。 固定宽度 指定字段按列对齐。
起始行 | 指定导入文件时开始读取数据的行。默认行为 1。
父主题: 数据


文本导入向导

以各种 ASCII 格式导入路线、事件点、坐标几何点和表面数据。在导入文件之前描述文件的格式。

父主题: 数据


数据类型

“文本导入向导”可导入以下类型的数据：

  • 曲面特征

  • 单个平面路线

  • 单个纵面路线

  • 纵面事件点

  • 平面事件点

  • 坐标几何点

  • 回归点

有关每个数据类型的处理方式的详细信息，请参阅导入各种数据类型。

父主题: 数据


向导和过滤器

在使用“文本导入向导”导入文件之前，请定义一般格式（称为向导），可以重复使用该格式导入任意数量的相同类型的文件。向导描述 1) 每列数据的内容，2) 列是固定宽度还是由分隔符分隔，3) 要导入的行。

向导由一个或多个过滤器组成。过滤器是一组描述要导入的文件内不同行组的参数。在许多情况下，向导包含一个过滤器。统一的数据文件便是如此。在统一的数据文件中，要读取的所有数据行均具有相同的格式。由于格式的一致性，因此向导仅需一个过滤器即可描述统一的数据文件。为导入统一数据文件定义向导时，向导和过滤器完全相同。

另一方面，非统一的数据文件在单个数据文件中包含不同格式的行（不同的行表现出不同的格式）。要适应多种行格式，向导必须包含多个过滤器。具体地说，向导需要为每种类型的行格式提供一个过滤器。在为导入非统一数据文件定义向导的过程中，可以定义多个过滤器，这些过滤器组合在一起构成向导。

父主题: 数据


创建向导

本节旨在解释使用“文本导入向导”的过程。本节不会尝试解释“文本导入向导”命令中显示的所有参数。有关所有参数的详细信息，请参考各种对话框主题（每个主题对应“文本导入向导”中的每个对话框）。

父主题: 数据


修改现有文本导入向导

有两种编辑向导方法。

“文本导入向导”初始对话框中的“编辑”按钮显示文本导入向导，其中已打开选定向导。可以对此向导进行任意数量的编辑。您可以保存向导，可以使用其他名称保存向导，或者只需完成导入过程以及对向导的修改，而无需永久修改向导。

向导创建对话框的“打开”按钮显示“打开向导 (Open Wizard)”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。

使用向导导入文件

本部分介绍了使用向导导入文件的步骤。此工作流假设您已创建可用于导入特定文件类型的向导。

调用“文本导入向导”命令。

选择要导入的文件（文件名）。

指定文件包含的数据类型（数据类型）。

选择用于导入文件的向导（向导名称）。

单击“确定”导入文件。

有关每个数据类型的处理方式的详细信息，请参阅“导入各种数据类型”。

父主题: 数据


导入“经典”ASCII 文件

要导入 ASCII 文件，请在“文本导入向导”上选择“经典文件 (Classic File)”作为“向导名称 (Wizard Name)”。“经典文件 (Classic File)”导入支持的数据类型包括：

  • 平面路线

  • 平面事件点

  • 纵面路线

  • 纵面事件点

  • 坐标几何点

此功能不适用于表面数据或平面回归点。

导入平面路线时，路线将添加到激活的几何图形项目中。导入的纵面路线将添加到激活的平面路线中。坐标几何点以及平面和纵面事件点都将导入到激活点缓冲区。有关详细信息，请参考“文件”>“导入”>“几何图形”的文档。

以下步骤描述了导入“经典”几何图形文件的过程。

选择“文件”>“文本导入向导”命令，这将显示“文本导入向导”对话框。

将“向导名称 (Wizard Name)”设置为“经典文件 (Classic File)”之后，指定相应的“数据类型”以及要导入的文件的名称。

单击“确定”。

如果要导入平面或纵面路线，则会打开“几何图形选项 (Geometry Options)”对话框。否则，“文本导入向导”将导入文件。

如果打开“几何图形选项 (Geometry Options)”对话框（如果要导入路线，则会显示），请指定新路线的“名称”、“描述”和“样式”，然后单击“确定”。

“文本导入向导”将导入文件。

父主题: 数据


导入所需的列

向导中的每个过滤器必须在允许导入之前为每种类型定义以下内容：

  • 表面 - 纵坐标和横坐标

  • 平面路线 - 纵坐标和横坐标

  • 平面事件点 - 纵坐标和横坐标，或者桩号

  • 平面回归点 - 纵坐标和横坐标，或者桩号

  • 纵面路线 - 纵坐标和横坐标，或者桩号和高程

  • 纵面事件点 - 纵坐标和横坐标，或者桩号

  • 坐标几何点 - 纵坐标和横坐标，或者桩号

父主题: 数据


保存向导

通过单击“文本导入向导”中不同对话框上显示的“另存为”按钮，您可以保存向导。但是，除非向导包含至少一个完全定义的过滤器，否则“文本导入向导”将不允许您保存向导。

例如，假设您正在创建一个向导，以导入包含平面路线数据的文件。在“第 3 步”对话框中至少指定纵坐标和横坐标数据列之前，“文本导入向导”不允许您保存此特定向导（有关每种数据类型需要哪些列的详细信息，请参阅“导入所需的列”一节）。如果在满足过滤器的最低要求之前尝试保存向导，则该软件将显示错误消息，该消息尝试明确描述向导未能满足的要求。

至少定义一个过滤器之后，即使正在定义其他过滤器，也可以保存向导。（请记住：用于导入非统一文件的向导可能会包含多个过滤器。）

向导保存在 XIN 文件中。向导保存之后，下次调用“文本导入向导”命令时可以使用该向导

父主题: 数据


多个过滤器的运行方式

本部分介绍了如何使用多个过滤器处理非统一数据文件，这些文件的各行显示不同的数据格式。

您定义的每个过滤器均可通过“文本导入向导 - 第 2 步”对话框中的“添加”按钮添加到向导中。添加过滤器的顺序非常重要，因为当该行满足多个过滤器时，该顺序将确定将哪个过滤器应用于特定行。

数据文件中的单行可以满足多个过滤器的条件。

该向导一次传输数据文件，一次读取一行。对于每一行，向导按照“文本导入向导 - 第 2 步”对话框中添加到列表的顺序应用过滤器。过滤器一次应用一个，直到其中一个过滤器成功匹配特定的数据行，或直到所有过滤器全部失败为止。当数据行满足在“文本导入向导 - 第 2 步”对话框中定义的过滤器的“包含”参数时，会发生匹配。

在数据行和过滤器之间发生匹配之后，将根据相应过滤器中指定的所有参数导入数据行。导入数据行之后，该向导将移到数据文件中的下一行。如果在尝试所有过滤器之后仍未发生匹配，则忽略数据行，向导将移到数据文件中的下一行。

父主题: 数据


导入各种数据类型

本主题提供有关可使用“文本导入向导”导入的数据类型的导入过程详细信息。

坐标几何点

每行均作为一个坐标几何点处理。如果过滤器未指定点名称，则会以与“添加坐标几何点 (Add Cogo Point)”命令相同的方式生成名称。如果提供了桩号偏移数据而不是纵坐标、横坐标、高程数据，则必须存在激活的平面路线。如果一个点的桩号偏移数据不在水平桩号范围内，则不会导入该点。然后将每个坐标几何点添加到激活的坐标几何缓冲区，并在添加所有点之后更新 InRoads Explorer。

数据示例 - 点名称、纵坐标、横坐标、高程

Cogo1 417289.44 194301.93 0.00

Cogo2 417233.32 194384.69 0.00

Cogo3 417179.75 194468.90 0.00

Cogo4 417186.60 194566.65 0.00

Cogo5 417211.60 194663.48 0.00

Cogo6 417236.60 194760.30 0.00

Cogo7 417255.53 194857.96 0.00

平面路线

除了最后一行（被处理为路线的最后一个点）之外，每行都被处理为水平 PI。每个 PI 在处理时，均会添加到数组中。加载完所有数据之后，每个 PI 及相关的圆弧和过渡螺线将插入到新创建的路线中，其对应的名称、描述和样式由用户通过“几何图形选项 (Geometry Options)”对话框指定。添加完所有 PI 之后，路线将插入到 InRoads Explorer 中的激活几何图形项目中并激活。

数据示例 - 纵坐标、横坐标、半径、第一缓和曲线长度、第二缓和曲线长度

平面路线数据以 PI 为基础。

1000 1000

2000 2000 500 100 100

3000 1000 500

4000 2000 500 75 125

5000 1000

上面的示例与在以下坐标处使用“几何图形”>“平面曲线集”>“添加 PI (Add PI)”添加 PI 相同：

1000, 1000

2000, 2000

3000, 1000

4000, 5000 和

5000, 1000。

然后使用“几何图形”>“平面曲线集”>“定义曲线 (Define Curve)”添加以下曲线集：

半径为 500 的 SCS 类型的曲线集、长度为 100 的前缘回旋缓和曲线和长度为 100 的尾缘回旋缓和曲线

半径为 500 的 SCS 类型的曲线集，无缓和曲线

半径为 500 的 SCS 曲线集、长度为 75 的前缘回旋缓和曲线和长度为 100 的尾缘回旋缓和曲线

平面事件点

每条线表示一个平面事件点。必须存在激活的平面路线，并且仅导入路线的桩号范围内的点。每个成功处理的点都将添加到激活的平面路线中。

数据示例 - 跳过、跳过、跳过、纵坐标、横坐标、高程

N+E -28+98.05 5.00 417039.23 194583.97 0.00

N+E -28+90.00 5.02 417042.57 194589.47 0.00

N+E -28+80.00 5.05 417046.73 194596.31 0.00

N+E -28+70.00 5.07 417050.88 194603.15 0.00

N+E -28+60.00 5.10 417055.03 194609.98 0.00

平面回归点

每条线表示一个平面回归点。这些点按照它们在文件中列出的顺序导入；没有排序。每个成功处理的点都将添加到回归缓冲区中。

数据示例 - 点名称、纵坐标、横坐标、高程

1 417289.44 194301.93 0.00

2 417261.38 194343.31 0.00

3 417233.32 194384.70 0.00

4 417205.25 194426.08 0.00

表面数据

表面数据文件可以仅包含随机点、切断线、内部、外部或轮廓特征信息，并且一个文件可以不包含多于一种类型的特征数据。每行表示一个点。处理每行时，将计算该行中所述的点。接下来，该向导将处理“表面选项 (Surface Options)”对话框中指定的围栅选项和特征类型。如果存在围栅且选择模式不是“忽略”，如果点采用围栅边界，则该点将添加到数组中。如果选择的特征类型为“随机”，则所有点在导入过程结束时插入，否则将处理笔代码。（如果已选择需要笔代码的特征类型，并且向导未将列定义为包含笔代码数据，则会显示错误消息并中止导入。）如果读取的点是第一个点，或者如果笔代码指示应开始新特征，则特征名称将通过提供的名称或种子名称进行更新。读取一个特征的数据之后，该特征将添加到指定的表面，且该过程将会继续，直到添加完所有特征为止。

数据示例 - 横坐标、纵坐标、高程、笔代码

194690.47 417919.93 25.00 1

194704.57 417912.36 27.97 0

194718.67 417904.80 30.95 0

194732.77 417897.23 33.92 0

194746.87 417889.67 36.89 0

194760.96 417882.11 39.87 0

194775.06 417874.54 42.84 0

194789.16 417866.98 45.81 0

纵面路线

除了最后一行（表示路线的最后一个点）之外，每行都表示纵面 PVI。每个 PVI 在处理时都存储在一个数组中。加载完所有数据之后，每个 PVI 都将插入到新创建的路线中，其对应的名称、描述和样式通过“几何图形选项 (Geometry Options)”对话框指定。然后，路线将插入到 InRoads Explorer 中的激活平面路线并激活。

不支持纵面回旋曲线

数据示例 - 桩号、高程、半径

13.69 9.93

248.72 18.14 50.00

586.43 8.33 20.00

967.49 16.54 50.00

1086.14 10.38

纵面事件点

每行表示一个纵面事件点。如果提供了横坐标、纵坐标、高程数据，则转换为桩号偏移数据。必须存在激活的平面路线，并且仅导入路线的桩号范围内的点。如果未给出高程，则将根据激活的纵面路线计算得出，除非点的桩号不在纵面路线的桩号范围内（在这种情况下，高程设置为 0.0）。随后，每个成功处理的事件点均会添加到激活的纵面路线中。

数据示例 - 跳过、桩号、高程

S+E -28+98.05 9.70

S+E -28+90.00 10.15

S+E -28+80.00 10.71

S+E -28+70.00 11.27

S+E -28+60.00 11.83

S+E -28+50.00 12.38

S+E -28+40.00 12.94

导入 ASCII 文件

通过在“文本导入向导”中选择“经典文件 (Classic File)”作为“向导名称 (Wizard Name)”，可以使用“文本导入向导”导入 ASCII 文件。“经典文件 (Classic File)”导入支持的数据类型包括：

平面路线

平面事件点

纵面路线

纵面事件点

坐标几何点

此功能不适用于表面数据或平面回归点。

导入平面路线时，路线将添加到激活的几何图形项目中。导入的纵面路线将添加到激活的平面路线中。坐标几何点以及平面和纵面事件点都将导入到激活点缓冲区。有关详细信息，请参考“文件”>“导入”>“几何图形”的文档。

数据示例 - 平面路线

{TYPE STATION RADIUS X_CRD Y_CRD DIRECTION SPI_LENGTH

LIN 0+00.00 0.00 194301.93 417289.44 124^08'37" 0.00

CIR 1+75.74 -100.00 194447.38 417190.81 124^08'37" 0.00

LIN 2+60.60 0.00 194528.51 417176.75 75^31'13" 0.00

CIR 5+64.90 100.00 194823.14 417252.83 75^31'13" 0.00

LIN 6+50.40 0.00 194904.80 417238.41 124^30'31" 0.00

CIR 7+58.88 -100.00 194994.19 417176.96 124^30'31" 0.00

LIN 8+51.59 0.00 195082.76 417164.59 71^23'14" 0.00

CIR 11+91.21 100.00 195404.62 417272.99 71^23'14" 0.00

LIN 12+64.50 0.00 195476.21 417270.01 113^22'36" 0.00

CIR 15+33.90 -100.00 195723.49 417163.12 113^22'36" 0.00

LIN 16+21.93 0.00 195808.67 417165.86 62^56'07" 0.00

LIN 18+98.15 0.00 196054.64 417291.54 62^56'07" 0.00
父主题: 数据


导出

完成创建和编辑之后，您可能希望导出为 Bentley 的本地曲面格式之一或 LandXML。

从菜单中选择导出类型。

导出到:

  • GEOPAK (TIN)

  • InRoads (DTM)

  • MX (FIL)

  • LandXML

父主题: 数据


测量外业薄

基本
选择
创建
导入
导出
父主题: 测量


基本

在工具箱中选择 | 描述
资源管理器 | 浏览和管理文件中的内容。
细节 | 显示测量详细轴网。
重置细节 | 重置测量详细轴网。
父主题: 测量外业薄


选择

另请参阅选择

父主题: 测量外业薄


创建

功能区：测量 > 外业薄 > 创建

在工具箱中选择 | 描述
新建外业簿 | 创建空的测量外业薄。默认情况下，此新外业薄处于激活状态。
删除外业簿 | 删除所选外业薄。
新建外业簿
删除外业簿
父主题: 测量外业薄


新建外业簿

此工具创建空的测量外业簿。默认情况下，此新外业薄处于激活状态。

父主题: 创建


删除外业簿

此工具删除选定的外业簿。

父主题: 创建


导入

指定要加载的数据文件类型以及要在“测量”内使用的外业薄。

功能区：测量 > 外业薄 > 导入

在工具箱中选择 | 描述
文件 | 指定要加载的数据文件类型以及要在其中使用的外业薄。
文本向导 | 导入坐标类型 ASCII 文件以及经纬度 ASCII 文件。
Trimble 链接 | 借助 Trimble 链接引擎，导入 Trimble JOB 文件。
Leica DBX | 导入包含“点”和/或“测量”的 Leica DBX 文件。
图形 | 从当前 dgn 导入图形并创建线性和点特征。
父主题: 测量外业薄


导出

导出为 Bentley 的某一本地曲面格式或导出到 LandXML。

功能区：测量 > 外业薄 > 导出

在工具箱中选择 | 描述
LandXML | 将外业薄数据导出为 Land XML 格式。
Trimble 链接 | 借助 Trimble 链接引擎，将外业薄数据导出为 Trimble 格式。
Leica DBX | 将外业薄数据导出为 Leica DBX 点格式。
图形 | 仅以“图形”模式将所有点和线性特征导出到另一 DGN。
父主题: 测量外业薄


分析

另请参阅基本。

另请参阅选择。

测量视图
注释
修饰
父主题: 测量


测量视图

功能区：测量 > 分析 > 视图

重新绘图 | 强制重绘所有测量数据。
报表 | 查看报表。
介质 | 查看介质。
测量报表
介质
父主题: 分析


测量报表

“测量 XML 报表 (Survey XML Report)”命令可生成临时 XML 数据文件，在您选择外业簿并单击“应用”按钮时，该文件的格式将变为报表。

注释: 查看 InRoads Group 的 XML 输出时需要 Microsoft Internet Explorer 6.0 版本或更高版本。

选项

外业簿 (Fieldbooks)

列出可用的外业簿。必须选择要用于创建 XML 报表的外业簿。

应用

使用在对话框中定义的信息执行该命令，并调用 Bentley InRoads 报表浏览器。

关闭

关闭对话框。

工作流

选择“测量报表 (Survey Report)”以显示“测量 XML 报表 (Survey XML Report)”对话框。

随即显示“测量 XML 报表 (Survey XML Report)”对话框。

指定外业簿并单击“应用”。

随即显示 Civil 报表浏览器。

父主题: 测量视图


介质

所有点均支持介质附件。用户可以从 Leica 原始数据抓取图片、声音、电影等。测量数据得到处理之后，其他格式的用户必须手动附加它们。

此命令用于提示定位已附加介质文件的测量点或线性特征。如果元素已附加介质，命令将显示介质浏览器，其中显示已附加到该元素的所有介质文件。如果元素不包含任何介质，命令则显示消息“未找到介质”。

父主题: 测量视图


注释

功能区：测量 > 分析 > 标注

在工具箱中选择 | 描述
所有标注 | 切换所有标注
VBA 标注 | 切换 VBA 标注
父主题: 分析


修饰

功能区：测量 > 分析 > 修饰

在工具箱中选择 | 描述
名称 | 切换名称修饰。
特征 | 切换特征修饰。
设置 | 切换设置修饰。
观测 | 切换观测修饰。
图标 | 切换消息图标修饰。
父主题: 分析


测量编辑

编辑线性

功能区：测量 > 编辑

设置 | 描述
打断线性特征 | 将一个线性特征打断为两个不同的线性特征。
关闭线性特征 | 将线性特征的第一个点与最后一个点连接起来。
连接线性特征 | 连接两个线性特征以构建新的单个线性特征。
移动线性特征 | 沿现有线性特征移动点特征。
转置线性特征 | 逆排选定平面路线内的所有数据。第一个元素变为最后一个元素，以此类推。

编辑线性点

功能区：测量 > 编辑

在工具箱中选择 | 描述
将点附加在线性特征中 | 将土木点附加到现有线性特征。
沿线性特征移动点 | 沿现有线性特征移动点特征。
将点插入线性特征中 | 将土木点插入到现有线性特征中。
从线性特征移除点 | 从线性特征移除土木点。
移动线性特征
转置线性特征
打断线性特征
关闭线性特征
将点插入线性特征中
沿线性特征移动点
将点附加在线性特征中
从线性特征移除点
连接线性特征
父主题: 测量


移动线性特征

  1. 选择“移动线性特征”工具。

  2. 选择线性特征。

  3. 点击确认，为线性特征重新定位。

父主题: 测量编辑


转置线性特征

逆排选定平面路线内的所有数据。第一个元素变为最后一个元素，以此类推。左手弧（圆或缓和曲线）成为右手弧，右手弧成为左手弧。

  1. 定位线性特征。

  2. 要接受的数据点。

  3. 过滤器指定要使用的对齐点或限制点。

父主题: 测量编辑


打断线性特征

将一个线性特征打断为两个不同的线性特征。

  1. 选择“打断线性特征”。

  2. 定位要打断的线性特征。

  3. 标识沿特征创建断点位置。

  4. 线性特征保持不变，直到断点位置为止。

  5. 在断点处，线性特征将另存为单独的特征。

父主题: 测量编辑


关闭线性特征

将线性特征的第一个点与最后一个点连接起来。

  1. 选择“关闭线性特征”工具。

  2. 定位线性特征。

  3. 指定使用“闭合形状”、“True”或“False”。

父主题: 测量编辑


将点插入线性特征中

将土木点插入到现有线性特征中。

  1. 选择“将点插入线性特征中”工具。

  2. 在端点或中点定位线性特征。

  3. 定位点特征以插入到线性特征中。

父主题: 测量编辑


沿线性特征移动点

沿现有线性特征移动点特征。

  1. 选择“沿线性特征移动点”工具。

  2. 在端点或中点定位线性特征。

  3. 定位点特征。

  4. 指定是否保持高程，True 或 False。

  5. 点击确认，以定位新位置中的点。

父主题: 测量编辑


将点附加在线性特征中

将土木点附加到现有线性特征。

  1. 选择“将点附加在线性特征中”工具。

  2. 在端点定位线性特征。

  3. 定位点特征以定位新点。

父主题: 测量编辑


从线性特征移除点

从线性特征移除土木点。

  1. 选择“从线性特征删除点”工具。

  2. 在端点或中点定位线性特征。

  3. 定位要删除的点特征。

父主题: 测量编辑


连接线性特征

连接两个线性特征以构建新的单个线性特征。

  1. 选择“连接线性特征”。

  2. 定位要连接的第一个线性特征。

  3. 定位要连接的第二个线性特征。

  4. 第一个线性特征将延伸以满足第二个线性特征。

父主题: 测量编辑


测量工具

测量工作流
“测量”选项卡
细节
最小二乘法调整
OpenRoads 标准
附录
测量工具集
父主题: 测量


测量工作流

注释:

创建新外业簿

右键单击“测量”选项卡的“外业簿”分支，然后在菜单上单击“新建”。

注释: 要更改外业簿的名称，请在“测量”选项卡上选择外业簿，然后打开“显示细节”的“元素列表”选项卡。在“显示细节”的“名称”单元中选择外业簿名称，删除现有文本，然后输入新名称并按 Enter。新名称将显示在“测量”选项卡和“显示细节”元素列表的“名称”单元中。

添加控制点

如果标准 CTL 文件包含控制点，则将文件拖放到“测量”选项卡上。这会将控制点添加至项目。

  • 或者，也可以通过右键单击“测量”选项卡中的“外业簿”分支来添加 CTL 文件（或任何文件类型）。

  1. 在菜单上单击“加载”，然后从子菜单中选择“文件”。

  2. 导航到所需的 CTL 文件，然后双击该文件。

添加测量原始数据

从 Windows 资源管理器中拖动相应的文件，然后将其放在“测量”选项卡上。

  • 或者，也可以通过右键单击“土木标准”中的“外业簿”分支来添加文件。

  1. 在菜单上选择“加载”，然后从子菜单中选择“文件”。

  2. 导航到所需的文件，然后双击该文件。

注释: 如果所拖放文件的文件扩展名不明确，系统将提示您标识文件的格式。从“数据格式”对话框上的可用选项中进行选择，然后单击“接受”。
注释: 为避免出现此提示，请在“项目浏览器”中打开“项目设置”对话框（“土木标准”>“项目设置”>“测量”），右键单击设置并选择“属性”。展开“数据文件解析”，选择“数据导入项”，单击相邻单元，然后单击“浏览”按钮。在“数据文件类型”对话框上，添加新文件类型或编辑现有文件扩展名，单击相邻单元，然后单击“浏览”按钮。在“数据文件类型”对话框上，添加新文件类型或编辑现有文件扩展名。

在加载原始数据的过程中，系统会执行以下操作：

  • 减少原始数据以生成点特征和线性特征。

  • 如果已选中“调整”框（位于“测量”选项卡上的外业簿名称之下），则应用“最小二乘法平差”。

  • 在 DGN 中存储“点特征”和“线性特征”、“设置”以及“观测”数据。请注意：“设置”、“观测”和“控制点”将绘制在 DGN 文件的特定层上。

  • 处理链接代码以创建线条（线性特征）。

  • 根据“特征样式”表对“点特征”和“线性特征”进行符号化。

  • 使用原始数据中的点和线生成名为“所有外业簿”的曲面。

测量使用三 (3) 种类型的线性特征：“动态链接”、“点列表”和“图形”。这些线性特征类型具有层次结构。“动态链接”类型可以转换为“点列表”或“图形”类型。“点列表”类型可以转换为“图形”类型。

通过使用“链接方法”之一（外业代码、连续或非连续）自动生成的线性特征被创建为“动态链接”线性特征，其属性类型为 GeneratedByLinking。这些线性特征基于链接和/或外业代码组合以及外业点的收集顺序而构造。如果线性特征已开始，它将链接所有外业代码相同的后续点，直至遇到另一个起点或终点，具体视所用的“链接方法”而定。

动态链接：创建过程如上所述。这些线性特征内所有点的外业代码均相同，这些点的链接顺序即为其在外业中的收集顺序。这些线性特征几何图形的开始、停止和更改由链接和/或外业代码的组合来控制。编辑包含修改链接和/或外业代码，或者移动测量点特征的位置。

点列表：这些线性特征由可以具有任意外业代码的点的列表生成。其属性类型为 GeneratedByPointList。这些点在线性特征中的顺序与其在外业中的收集顺序无关，而是仅取决于它们在列表中的显示顺序。此类型的“几何图形”仍由链接代码控制，但线性特征的起点和终点并非如此。起点和终点由点列表控制。编辑包含修改链接和/或外业代码或者移动测量点特征的位置，此外还包括修改或管理列表中点的顺序。

图形：图形线性特征可以是任意 MicroStation 图形元素，且未绑定至任何测量点特征。其属性类型为“图形”。编辑包含使用任何 MicroStation 编辑工具。这些线性特征的符号化可以由已指定的特征控制，但指定特定特征为可选操作，并非强制操作。

原始数据文件中的观测

从原始数据文件创建的点特征和线性特征

从原始数据文件创建的曲面三角形 - 该曲面根据已导入的点特征和线性特征的曲面设置自动生成。

另请参阅

导出

创建新外业簿
添加测量原始数据
动态链接
点列表
图形
父主题: 测量工具


创建新外业簿

  1. 右键单击“测量”选项卡的“外业簿”分支，然后单击菜单上的“新建”。

    注释: 要更改外业簿的名称，请在“测量”选项卡上选择外业簿，然后打开“显示细节”的“元素列表”选项卡。选择“显示细节”的“名称”单元中的外业簿名称，删除现有文本，输入新名称，然后按 Enter 键。新名称将显示在“测量”选项卡和“显示细节”元素列表的“名称”单元中。

  2. 添加控制点。

    如果标准 CTL 文件包含控制点，则将文件拖放到“测量”选项卡上。这会将控制点添加至项目。

  3. (可选) 或者，也可以通过右键单击“测量”选项卡中的“外业簿”分支来添加 CTL 文件（或任何文件类型）。在菜单上单击“加载”，然后从子菜单中选择“文件”。导航到所需的 CTL 文件，然后双击该文件。
父主题: 测量工作流


添加测量原始数据

  1. 从 Windows 资源管理器中拖动相应的文件，然后将其放在“测量”选项卡上。
  2. (可选) 或者，也可以通过右键单击“土木标准”中的“外业簿”分支来添加文件。在菜单上选择“加载”，然后从子菜单中选择“文件”。导航到所需文件，然后双击它。

    注释: 如果所拖放文件的文件扩展名不明确，系统将提示您标识文件的格式。从“数据格式”对话框的可用选项中进行选择，然后单击“接受”。

    提示: 为避免出现此提示，请在“项目浏览器”中打开“项目设置”对话框（“土木标准”>“项目设置”>“测量”），右键单击设置并选择“属性”。展开“数据文件解析”，选择“数据导入项”，单击相邻单元，然后单击“浏览”按钮。在“数据文件类型 (Data File Type)”对话框上，添加新文件类型或编辑现有文件扩展名，向下滚动以单击相邻单元，然后单击“浏览”按钮。在“数据文件类型”对话框上，添加新文件类型或编辑现有文件扩展名。

    在加载原始数据的过程中，系统会执行以下操作：

    减少原始数据以减少点特征和线性特征

    如果已选中“调整”框（位于“测量”选项卡上的外业簿名称之下），则应用“最小二乘法平差”。

    处理链接代码以创建线条（线性特征）。

    根据“特征样式”表对“点特征”和“线性特征”进行符号化。

    使用原始数据中的点和线生成名为“所有外业簿”的曲面。

父主题: 测量工作流


动态链接

创建过程如上所述。这些线性特征内所有点的外业代码均相同，这些点的链接顺序即为其在外业中的收集顺序。这些线性特征几何图形的开始、停止和更改由链接和/或外业代码的组合来控制。编辑包含修改链接和/或外业代码，或者移动测量点特征的位置。

父主题: 测量工作流


点列表

这些线性特征由可以具有任意外业代码的点的列表生成。其属性类型为 GeneratedByPointList。这些点在线性特征中的顺序与其在外业中的收集顺序无关，而是仅取决于它们在列表中的显示顺序。此类型的“几何图形”仍由链接代码控制，但线性特征的起点和终点并非如此。起点和终点由点列表控制。编辑包含修改链接和/或外业代码或者移动测量点特征的位置，此外还包括修改或管理列表中点的顺序。

父主题: 测量工作流


图形

图形线性特征可以是任意 MicroStation 图形元素，且未绑定至任何测量点特征。其属性类型为“图形”。编辑包含使用任何 MicroStation 编辑工具。这些线性特征的符号化可以由已指定的特征控制，但指定特定特征为可选操作，并非强制操作。

从原始数据文件创建的点特征和线性特征

从原始数据文件创建的曲面三角形 - 该曲面根据已导入的点特征和线性特征的曲面设置自动生成。

另请参阅

导出

父主题: 测量工作流


“测量”选项卡

将信息按逻辑分组进行组织，以便进行选择并提高可视性。

缺省
测量数据分支
外业簿
数据文件
设置
占用、后视和观测
点特征和线性特征扩展
构成表面
父主题: 测量工具


缺省

“测量”选项卡的顶部是激活 DGN 模型的名称。所有已导入数据均存储在此模型中。

父主题: “测量”选项卡


测量数据分支

使用数据填充时，“测量”选项卡包含一个或多个分支。每个分支都附有一个复选框，用于启用或禁用分支与子分支的可视化。

父主题: “测量”选项卡


外业簿

此分支可展开以显示加载到项目中的外业测量数据。使用此分支可查看或编辑项目中“外业簿”的信息。如果选择了单个外业簿，则仅显示该外业簿。

注释: 根据外业数据类型，仅某些外业可供编辑，以保持数据完整性。

父主题: “测量”选项卡


数据文件

此分支在详情面板中显示所选数据文件的信息。可以通过在“文件名”单元中单击来编辑数据文件的名称。如果选择单个数据文件，将仅显示这一个数据文件。

此分支可展开以显示当前加载到项目中的原始测量数据文件。每个数据文件均可展开以显示设置和观测内容。有关详细信息，请参阅添加测量原始数据。

父主题: “测量”选项卡


设置

此分支显示在各个“数据文件”下方，支持编辑设置信息。选择单个设置分支将仅显示单个设置。

父主题: “测量”选项卡


占用、后视和观测

如果选择相应分支，详情面板会显示占用点、后视点信息或者与观测关联的数据。

父主题: “测量”选项卡


点特征和线性特征扩展

通过展开“点特征”或“线性特征”分支，可以按各个特征样式定义查看数据。

“点特征”分支显示在“外业簿”中已分配给点的不同特征类型。如果选择其中一个子分支，则详情面板仅显示已分配给选定特征定义的点。

“线性特征”分支可以采用相似形式展开并以相同方式进行操作。

父主题: “测量”选项卡


构成表面

请参考地形模型工具集。

父主题: “测量”选项卡
相关概念
地形


细节

细节调整以显示选定分支的细节。

显示细节
隐藏细节
重置细节
父主题: 测量工具


显示细节

调整以显示选定分支的细节。

外业簿
数据文件
设置
占用、后视和观测
控制点
点特征
线性特征
调整
父主题: 细节


隐藏细节

调整以隐藏选定分支的“测量”详细信息。

父主题: 细节


重置细节

将“测量”详细信息重置为默认设置。

父主题: 细节


最小二乘法调整

可以对测量原始数据进行最小二乘法调整和粗差检测。选中“调整”框时，将自动进行调整并生成报告。调整和调整设置应用于整个外业簿。除非已存储了控制点，否则不会调整导线数据。

注释: 只能使用最小二乘法调整方法。

进行最小二乘法平差
调整设置
调整
校正误差
父主题: 测量工具


进行最小二乘法平差

  1. 选择“项目设置”>“测量”>“设置”。
  2. 右键单击“设置”并选择“复制”、“删除”、“重命名”或“属性”。
  3. 选择“属性”。

父主题: 最小二乘法调整


调整设置

选中“调整”框时，可以编辑调整设置。这些设置中的大部分都有设备相关。例如，距离常数取决于用于测量距离的设备。大多数现代电子距离测量 (EDM) 设备的固有精度均为 0.01 - 0.02 英尺。

对于创建的每个外业簿，这些设置均复制到“项目浏览器”的“测量调整”树中。您可以在树中设置这些值，将这些值作为种子或缺省设置。

对于创建的每个外业簿，这些设置均复制到“项目浏览器”的“测量调整”树中。您可以在树中设置这些值，将这些值作为种子或缺省设置。

组合比例系数选项 | 选择“不使用”、“从控制点计算”、“计算每个观测”、“使用手动组合系数”
组合比例系数值 | 指定“组合比例系数值”
在消息中心显示错误 | True 或 False
距离常数增量 | 基于一组冗余测量的实测距离精度
距离 PPM 增量 | 基于误差与线长成比例的原理对实测距离的等份/百万校正。该值也与设备相关，但不应与对仪器自身大气条件所应用的校正 PPM 相混淆。
水平角增量 | 基于一组冗余测量的实测角度的固有精度
方位角增量 | 方位角精度 - 该值与角度精度不同；根据用作后视方向的预定义方向计算得出。
触发电平常数增量 | 使用总桩号距离/垂直角度计算测得的高程的精度
触发电平 PPM 增量 | 测得的触发电平高程的等份/百万加数。与距离 PPM 相同，该值根据误差（与线长成比例）的长度计算得出。
微差水准测量常数增量 | 在使用水准测量仪器和水准测量杆并考虑后视和前视等长且读数取自垂直标尺的情况下，从微差水准派生的高程的精度。
缺省距离误差估计 | 根据与预定义的横向控制坐标相关的那些测量的精度或可重复性，对一组实测距离应用的计算所得系数
缺省距离 PPM | 根据误差距离常数实际应用的校正系数
缺省水平角误差估计 | 根据与预定义的横向控制坐标相关的那些测量的精度或可重复性，对一组实测角度应用的计算所得系数
缺省方位误差估计 | 根据横向的重复角度测量和预定义坐标所决定的实际方位角方向应用的校正系数
父主题: 最小二乘法调整


调整

选中“调整”框时，会自动生成调整和报告。

在“调整结果”选项卡的详情面板中查看报告。

在“错误”选项卡的详情面板中查看误差（粗差）。

父主题: 最小二乘法调整


校正误差

右键单击误差选项卡并选择“缩放至”可以隔离误差。也可以使用报告来帮助隔离误差。完成隔离后，便可编辑原始数据来校正粗差。校正误差后，所有相关数据都会更新，包括报告、线条、点位置和曲面。

父主题: 最小二乘法调整


OpenRoads 标准

OpenRoads 标准选项卡
常规设置
点
链接和控制代码
数据文件解析
父主题: 测量工具


OpenRoads 标准选项卡

“OpenRoads 标准”选项卡用于访问存储在 DGNLIB 或设计文件中的功能和设置。

顶层包含当前设计文件和库。库是与 MicroStation 项目关联的 DGNLIB 文件的集合。使用的设置和标准将复制到设计文件中。

项目设置

此项定义用于创建廊道设计和测量的默认设置。廊道设计设置创建可在项目中的不同时间增量使用的多个设置。例如，可以创建概念、初步和最终项目设置，以便在设计项目生命周期中的 3 个不同阶段定义模板管理和廊道模型创建，从而使用户只需为廊道选择适用的项目设置即可更新廊道。廊道设置包括模板管理、临界截面包含以及创建的输出。

测量设置定义创建外业簿和由测量数据生成的对象对象时所用的标准和行为。

测量设置

测量设置定义创建外业簿和由测量数据生成的对象对象时所用的标准和行为。有关详细信息，请参考“土木测量”。

父主题: OpenRoads 标准


常规设置

以下设置存储在 DGN 设置中（“设置”>“设计文件”>“测量”）。

创建日志文件 | True 指定创建更改的历史日志。
将批注附加到描述 | True 或 False
使用注释比例 | True 或 False
使用 VBA 宏 | True 指定使用 VBA 应用程序对测量数据执行高级功能。
VBA 特征宏 | 单击相邻单元格，然后单击“浏览”按钮以打开“VM 特征宏”对话框。从可用宏中进行选择，然后单击“接受”以部署选择。
验证规则 | 单击相邻单元格，然后单击“浏览”按钮以打开“验证”对话框。从可用规则中进行选择，然后单击“接受”以部署选择。
父主题: OpenRoads 标准


点

导入坐标记录 | 总是 从不 控制 特征定义控制
控制点特征 | 单击相邻单元格，然后单击“浏览”按钮以打开“控制点特征”对话框。从可用特征中进行选择，然后单击“接受”以部署选择。
父主题: OpenRoads 标准


链接和控制代码

在实地测量数据中收集的数据可以使用链接代码，以便在处理数据时创建线性特征并更改其几何图形。

控制代码能够在数据处理过程中自动实现对特定点的特殊处理。

链接代码可以是 Alpha 值或数值。控制代码只能处理 Alpha 值。

父主题: OpenRoads 标准


数据文件解析

数据导入项 | 打开可导入的各种文件格式的列表。为了获得最大效率，通过将“使用”字段设置为 False，将该列表修剪为所使用的格式。 “接受”可确认列表并关闭对话框 “添加”可在列表中添加另一行 “删除”可从列表中移除所选行 “使用”指定在数据导入函数中使用此行项 “排除”指定在数据导入函数中忽略此行项 “重置”可将设置恢复为默认设置
使用替代字符串 | 设置为 True 时，在处理之前对原始数据执行搜索和替换
替代字符串 | 打开搜索替换字符串的列表 “接受”可确认列表并关闭对话框 “新建”可在列表中添加另一行以进行其他替代 “删除”可从列表中移除所选行 选择性粘贴 “全字”要求整词匹配，指定 True 或 False “替代”要替换的搜索字符串 “为”替换搜索字符串的字符串
描述分隔符 | 该分隔符将特征与点描述分隔开来
属性分隔符 | 该分隔符将特征与任何点特性分隔开来

警告: 对于 InRoads 用户，特征代码不应包含链接代码字符串。如果需要，使用替代字符串。

工作流
父主题: OpenRoads 标准


附录

提示和技巧
父主题: 测量工具


提示和技巧

提示 1：测量种子文件
提示 2：点重命名
提示 3：外业簿可视化
父主题: 附录


测量工具集

管理点列表
转换为点列表线性特征
父主题: 测量工具


管理点列表

打开一个对话框，用于对由“点列表”生成的线性特征执行操作。点列表线性特征包含一个点列表，点的顺序指示线性特征几何图形。链接代码还指示线性特征的形状。在“管理点列表”对话框中，用户可以对点列表线性特征中的点进行添加、移除、替换和重新排序。此外，还可以使用此对话框更改线性特征中任一点的链接代码。

管理点列表
父主题: 测量工具集


转换为点列表线性特征

获取由起始代码和通用特征代码（此类型线性特征称为“动态线性特征”）生成的线性特征，将其转换为通过组成该线性特征的点列表所定义的线性特征。点列表线性特征可以包含具有不同特征的点，而动态线性特征则包含具有相同特征的点。多数情况下，最好通过构成线性特征的点来操作该线性特征。因此，存在一个用于将动态线性特征转换为点列表线性特征的命令。

示例中的链 DGN 是动态链，由链接代码将具有相同特征代码的点连接起来创建而成，也称为图形线性特征。

父主题: 测量工具集


MicroStation

请参考 MicroStation 帮助。

要在本地查找帮助，请参考文档文件夹。

父主题: OpenRoads Designer CONNECT Edition帮助


Descartes

请参考 Descartes 帮助。

要在本地查找帮助，请参考文档文件夹。

父主题: OpenRoads Designer CONNECT Edition帮助


地下公共设施

请参考地下管网帮助。

要在本地查找帮助，请参考文档文件夹。

父主题: OpenRoads Designer CONNECT Edition帮助


地理技术

请参考地理技术帮助。

要在本地查找帮助，请参考文档文件夹。

父主题: OpenRoads Designer CONNECT Edition帮助


自述

Bentley OpenRoads Designer CONNECT Edition
新增功能
一般信息
软件兼容性
快速入门指南
OpenRoads Designer 培训
系统要求
产品激活
工作空间配置
服务和支持信息
安全发行说明
父主题: OpenRoads Designer CONNECT Edition帮助


Bentley OpenRoads Designer CONNECT Edition

OpenRoads Designer CONNECT Edition 这款全新的应用程序能够在一个产品中提供 InRoads、GEOPAK、MX、PowerCivil for Civil 和 GeoMacao 产品线的所有功能。OpenRoads Designer 依托于 OpenRoads 建模技术，将提供全新的设计建模、分析建模和项目协作等重要功能。有关详细的功能概述，可以通过 OpenRoads 在线获得。

OpenRoads Designer 重新定义了生成设计和建筑交付物的最佳实践，并确保能够在项目交付和资产生命周期内进行数据交换。使用 OpenRoads Designer 可以：

  • 从点云、三维实景网格、地形数据、图像和地理空间信息等来源快速收集背景数据，从而为您的项目带来真实感。
  • 以模型为中心生成设计交付物，显著提升建模性能。
  • 让用户以精确且安全的方式在各种团队、地点和专业领域之间共享项目信息。
  • 使用目录服务管理和交付功能组件，从而在整个设计工作组中实现一致的生成式设计。
  • 访问文档中心，为整个项目中的所有在用资产生成多专业领域文档。
  • 与公众和利益相关者分享真实的可视化结果，收集反馈，提高公众参与度，并加快项目审批速度。
父主题: 自述


一般信息

项 | 描述
产品 | OpenRoads Designer CONNECT Edition
版本 | 10.06.00.38
日期 | 2018 年 12 月

CONNECT 许可：

此产品版本使用不受 SELECT 激活密钥支持的 CONNECT 许可。CONNECT 许可采用了新的操作方式，强制用户通过 CONNECTION Client 登录才能访问应用程序，增强了您的组织的用户管理和安全性。如果您以登录 CONNECTION Client，则已满足此先决条件。如果未登录，请参考“管理员资源中心”，以及/或者联系您的管理员，以获取有关注册和登录流程的帮助。

本地访问获取帮助：

对于在线帮助，配置变量 MS_HELPLOAD_USEBROWSER 必须为 1，而对于本地帮助，则必须为 0。

父主题: 自述


软件兼容性

项 | 以前的自述文件
PW 版本 | ProjectWise CONNECT Edition (V10.00.03.49) (V10.00.03.14X)
MS 版本 | 10.11.00.38
LumenRT | 与产品一起安装（可选）
Connection Client | 与产品一起安装
Connect Advisor | 与产品一起安装
父主题: 自述


快速入门指南

《快速入门指南》可通过 LEARN 服务访问。

http://learn.bentley.com

试验性课程的详情如下（可能会有变化）：

模块 1（概述和地形）

模块 2（几何图形）

模块 3（建模）

模块 4（超高）

模块 5（与 OpenBridge Modeler 的集成）

模块 6（子表面）

模块 7（横断面）

模块 8（横断面 - 动态）

模块 9（平面 - 纵断面图纸）

模块 1（概述和地形）

模块 2（几何图形）

模块 3（建模）

模块 4（超高）

模块 5（与 OpenBridge Modeler 的集成）

模块 6（子表面）

模块 7（横断面）

模块 8（横断面 - 动态）

模块 9（平面 - 纵断面图纸）

父主题: 自述


OpenRoads Designer 培训

OpenRoads Designer 培训可通过产品界面右上角帮助图标旁的 CONNECT Advisor 图标或通过 LEARNserver http://learn.bentley.com 访问。产品发布后课程库将持续扩大。

下列课程以 OpenRoads Designer 中的建模工作流为重点，建议先从这些课程开始学起。学完每项课程的时间约为 2 小时。

  • OpenRoads Designer 使用入门

    此课程介绍了 OpenRoads Designer 软件，该软件非常适合熟悉 SELECTseries 4 OpenRoads Technology 工具的用户。您将会熟悉新界面、导入地形、导入几何图形、廊道建模、超高、地下公共设施、创建横断面图纸，以及创建平面图和纵断面图纸。

  • OpenRoads Designer Geometry 快速入门

    此课程既适合新用户，也适合从旧版本 PowerCivil、GEOPAK、MXROAD 和 InRoads 软件升级为新版本的用户。在此课程中，您将利用 OpenRoads Designer Geometry 工具创建平面和纵面线形。您将了解如何创建、编辑、检查和注释几何元素。此课程还包含使用现有地面地形和航空图像以及定义二维/三维视图的内容。

  • OpenRoads Designer 廊道建模快速入门

    此课程既适合新用户，也适合从旧版本 PowerCivil、GEOPAK、MXROAD 和 InRoads 软件升级为新版本的用户。在此课程中，您将创建双车道乡村道路的廊道和三维模型。您将了解如何创建廊道、指定三维路面、创建动态横断面以及检查廊道和三维模型。您还将了解如何使用参数化约束和点控制来改变路面厚度和路肩宽度。此课程还包含如何为廊道创建和指定超高的内容。学习此课程前，我们建议您先完成 OpenRoads Designer Geometry 快速入门。

  • OpenRoads Designer 计划制定快速入门

    此课程既适合新用户，也适合从旧版本 PowerCivil、GEOPAK、MXROAD 和 InRoads 软件升级为新版本的用户。您将了解如何创建包含标准注释的横断面图纸以及平面和纵断面图纸。您还将了解如何向特定于标签的位置坐标、桩号偏移值、高程等数据添加个人注释

下列课程以 OpenRoads Designer 的“地下公共设施”工作流为重点。学完每项课程的时间约为 1 小时。

  • 快速入门：评估 OpenRoads Designer 中的“地下公共设施”

    在此课程中，您将了解如何使用包括特性对话框、分析视图（标签和颜色编码）和 FlexTables 在内的不同技术来评估排水结构。您还将了解如何自定义、导出和打印 FlexTables，并创建根据特定条件进行过滤的查询。

  • 快速入门：在 OpenRoads Designer 中规划排水网

    在此课程中，您将了解如何规划简单的排水网，并将水流附加到系统中。您将了解如何在节点（入口和端墙）之间放置排水口端墙、入口和管道。最后，您将从多边形创建汇水区域，并将各个汇水区域指定到入口。

  • 快速入门：OpenRoads Designer 中的水力计算

    在此课程中，您将了解与在 OpenRoads Designer 中计算水力以及场景和替代方案有关的内容，以及如何计算场景和确认计算是否成功。

下列课程对您学习 OpenRoads Designer 的其他功能非常有用。学完每项课程的时间约为 2 小时。

  • 在 OpenRoads Designer 中使用实景建模工具的快速入门

    探索地理坐标系以及从多个不同来源导入数据时该坐标系的重要性。了解连接和控制光栅图像、GIS 形状文件、Lidar 点云和实景模型数据类型的显示的方法。最后，该课程将让您在实景建模工作流下熟悉工具。

  • gINT Civil 工具快速入门

    介绍 gINT Civil 工具，该工具允许用户在二维和三维模型中加载 gINT 数据（钻孔平面创建的测绘工作流和初步研究），以用于子表面解析和 BIM 工作流。

父主题: 自述


系统要求

OpenRoads Designer CONNECT Edition 是原生 64 位应用程序，可以在 Windows 7 和更高版本上运行。

操作系统 | Windows 10（64 位） Windows 8 和 8.1（64 位） Windows 7（64 位） 注释: Windows 7 操作系统仅在安装了相应的 Service Pack (SP1) 后才受支持。 Bentley 不支持在 Microsoft 已停用的 Microsoft 操作系统版本上运行其软件。有关详细信息，请参阅 Microsoft 的应用程序退役政策和 Bentley 应用程序支持生命周期。
处理器 | Intel® 或 AMD® 处理器（1.0 GHz 或更高）。在不支持 SSE2 的 CPU 上，OpenRoads Designer 不受支持。
内存 | 最低 8 GB，建议为 16 GB。内存越多，性能越高，这一点在处理较大模型时尤为明显。
硬盘 | 9 GB 可用磁盘空间（其中包含完全安装所需占用的 5.6 GB 空间）
视频 | 请向显卡制造商咨询有关 DirectX 驱动程序的最新信息。建议提供 1,024 MB 或更高的视频 RAM。如果不具备足够的视频 RAM 或找不到 DirectX 支持的显卡，OpenRoads Designer 将尝试使用软件模拟。为了达到最佳性能，图形显示颜色深度应设置为 24 位或更高。当使用 16 位的颜色深度设置时，会出现一些不一致的情况。
屏幕分辨率 | 1600 x 1200 或更高
MSAccess 64 位引擎 | 要连接到 Access 数据库，您必须下载并安装 Microsoft Access Database Engine 2010 Redistributable。通过下面的链接下载并安装 MS Access Database Engine 2010 Redistributable。访问 gINT 项目和导入 InRoads 排水文件功能需要该组件。 注释: https://www.microsoft.com/en-us/download/details.aspx?id=13255
父主题: 自述


产品激活

可通过连接到 SELECTserver，验证 SELECTserver 名称和激活密钥的正确性并成功发布使用日志来实现产品激活。产品激活不同于签出许可证。本节介绍如何配置 OpenRoads Designer 以进行激活。进行初始配置后，OpenRoads Designer 在每次运行时都会自动显式地尝试激活，在最后一次成功激活后，有 7 天的自由运行期。但是，如果激活未在 7 天内获得成功，OpenRoads Designer 将在下一次成功激活前以未授权模式运行，其会话不得超过 15 分钟。

注释: 如果将要运行 OpenRoads Designer 的工作站不能经常访问网络以进行定期激活（至少每 7 天），请考虑使用检出许可证。检出许可证是为需要不间断使用的情况设计的，OpenRoads Designer 将不会在许可证有效期内发布使用情况。有关获取检出许可证的详细信息，请参阅 OpenRoads Designer 文档。

父主题: 自述


工作空间配置

与 OpenRoads Designer 一同提供的工作空间配置能够带来灵活且高效的“开箱即用”体验。它可利用 CONNECT Edition 软件新的工作空间和工作集配置层，这些配置层可通过界面选择，因而更容易根据需要在不同的标准之间进行切换。

一种理解这些配置层的有用方法是将工作空间视为适用于公司或客户端标准，将工作集视为适用于个人项目标准。该配置将项目标准分层放置在公司/客户端标准上，而后两者均分层放置在一系列基础标准上。

开始使用时，OpenRoads Designer 在 Organization-Civil 文件夹中提供有通用的英制和公制基础标准。还可轻松添加针对特定区域、国家和机构定制的其他基础标准。Bentley 提供未来版本的部分其他基础标准，以及其他机构和公司制定的其他标准。

要通过 OpenRoads Designe 创建自己的工作集，请执行以下操作：

  1. 启动软件，
  2. 选择“英制标准”或“公制标准”工作空间，
  3. 为各个项目创建新的工作集。

创建工作集是一件简单的事情。选择界面中的“创建工作集”按钮，然后提供新工作集的名称（可能是您的项目名称/编号）。

请注意，V8i 工作空间中的许多 dgnlib 和其他文件在升级后才可用于 OpenRoads Designer。详述此过程的视频和支持材料通过 CONNECT Advisor 和 LEARNserver 提供。

要将 cell、dgnlib、种子文件等自定义标准和模板库加入工作空间（公司/客户端）或工作集（项目）中，须将文件复制到已经设置的空文件夹中。在大多数情况下，无需编辑任何 cfg 文件，因为配置已设置为搜索文件夹和分层放置标准。种子文件和模板库是例外情况，需要对其 cfg 文件进行少量修改，以提供要加载的特定文件名。有关详细信息，请参见各个 cfg 文件内部的文档和上述视频。

有关 CONNECT 工作空间配置的详细信息，请参见帮助或搜索 CONNECT Advisor。

父主题: 自述


服务和支持信息

有关服务和支持信息技术说明、常见问题解答和其他 Bentley 产品信息，请参见

Bentley 社区 » 技术预览 » OpenRoads。

注释: 要访问此网页，您必须注册 Bentley 社区的 OpenRoads Designer 社区并登录。
父主题: 自述


安全发行说明

本版本不适用。

父主题: 自述


 Your browser does not support frames.


“转换通用文本”对话框

用于描述导入 STM 的 XYZ 文件中的 X、Y 和 Z 值列。

在“导入选项”对话框的“通道信息”部分中单击“选择...”按钮时打开。

某些 XYZ 文件可能有其他列定义更多信息，例如，红色、绿色和蓝色或强度。此外，还可以指定 XYZ 值的单位和地理坐标系 (GCS)。

设置 | 描述
“点 X”、“点 Y”和“点 Z”列 | 缺省情况下，从输入数据的前三列中选择 X、Y 和 Z 列。如果不正确，请选择通道部分中的小图标以打开“转换通用文本”对话框。使用此对话框可选择 X、Y 和 Z 值列，而忽略其他列。
父主题: 可缩放的地形模型


“新建 STM 设置”对话框

用于指定新的可扩展地形模型的设置。

当您在“可扩展地形模型管理器”中选择“文件”>“新建”时打开。

设置 描述
常规

为三角形显示设置线符选项。

可缩放的地形模型

  • 描述 — STM 的描述。

  • 着色视图密度 — 1-100，调整着色模式下的显示密度。

  • 不是着色视图密度 — 1-100，调整非着色模式下的显示密度。

  • 视图 — 应显示 STM 的视图。

  • 定位 — 启用 STM 的定位。

计算的特征显示

打开或关闭 STM 的各种显示模式。

  • 等高线 — 将 STM 显示为等高线。

  • 三角形 — 将 STM 显示为三角形。

  • 覆盖光栅(仅用于三维) — 显示覆盖在 STM 上的光栅。

扩展

显示其他选项。

  • 可捕捉 — STM 特征可捕捉。

  • 剪切 — 使用剪切边界显示 STM 元素。

地理信息

设置地理坐标系 (GCS)。

  • 名称 — 库中的 GCS 名称。

  • 描述 — GCS 描述。

父主题: 可缩放的地形模型


“STM 高程源编辑器”对话框

用于向 STM 文件添加高程数据

当您创建新的 STM 文件时打开。

STM 文件可以由多个高程和剪切数据源组成。列表中文件的顺序非常重要，因为文件按顺序进行处理。因此，如果要剪切某个区域，则应根据这些数据文件定义剪切。通过右键单击所选文件并使用上下文菜单或“编辑”菜单项对文件进行排序，可以更改“高程源”对话框中文件的顺序。

可以对文件进行分组用于自定义处理。例如，将新文件的一部分添加到现有 STM 时，将源文件和表示剪切区域的文件添加到一个组中。这样，只有源文件才会被剪切，而不剪切在列表中位于其上方的文件。通过右键单击所选文件并使用上下文菜单或“编辑”菜单项，可以对文件进行分组。

可以使用下述支持的格式创建 STM 文件。

设置 描述
DTM

DTM 文件是其他软件处理过的高程模型

类型 | 文件扩展名
InRoads | .DTM
GeoPak、GeoMacao | .TIN、.BCDTM、.DAT
Descartes 可扩展地形模型 | .STM
LandXML | .XML
DGN 层 | .DGN
高程

高程文件是纯 XYZ 点。

类型 | 文件扩展名
InRoads | .DTM
GeoPak | .TIN、.BCDTM、.DAT
GeoMacao（与 GeoPak 相同） | .TIN、.BCDTM、.DAT
STM | .STM
LandXML | .XML
DGN 层（点元素） | .DGN
点云* | .POD
ASCII XYZ | .XYZ
二进制 XYZ | .XYZ
光栅 DEM | 与以下软件支持的相同： OpenRoads Designer

*将 .Pod 文件作为“点”源添加到 STM 时，如果 .Pod 文件已分类，则仅导入属于“地面”类的点。
切断线

切断线定义由于脊、陡坡、道路边缘等引起的地形突变。

类型 | 文件扩展名
DGN 层（线性元素） | .DGN
剪切

剪切多边形将 DTM 限制为多边形内的区域。

类型 | 文件扩展名
DGN 层（闭合形状） | .DGN

指定包含要应用于源高程文件的剪切元素的层。这些层来自激活 DGN 文件。在左侧选择“所有层”或在右侧选择指定层。
掩码

遮罩多边形将 DTM 限制为多边形外的区域。它们可用于防止 DTM 处理湖泊等不重要的区域。

类型 | 文件扩展名
DGN 层（闭合形状） | .DGN

指定包含要应用于源高程文件的遮罩元素的层。这些层来自激活 DGN 文件。在左侧选择“所有层”或在右侧选择指定层。
检查是否为最新

用于验证是否对源文件进行了任何更改。

STM 系统将跟踪记录用于创建每个 STM 的文件。“检查是否为最新”工具可用于确定创建 STM 所用的任何文件是否比 STM 本身更新。通过这种方式，用户可以决定是否应该重新生成 STM，使其变为最新。
生成

用于生成 STM。
父主题: 可缩放的地形模型


“STM 导入选项”对话框

用于设置单位和地理坐标系的配置选项。

当您在“STM 高程源编辑器”对话框中选择“文件”>“导入”时打开。

设置 描述
单位

指定地理信息的单位。

地理编码

使用下拉菜单显示地理坐标系 (GCS) 菜单。

  • 显示细节 — 显示现有坐标系的细节。

  • 打开 GCS — 打开“坐标系选择”对话框。

  • 删除 GCS — 删除现有坐标系。

通道

二进制 XYZ 文件是可识别的格式，无需特殊配置。但是，必须正确配置 ASCII XYZ 文件才能确保其正确导入。选择 ASCII XYZ 文件后，将显示“导入选项”对话框以及附加的“通道信息”部分。单击省略号“...”按钮将打开转换通用文本对话框。

层

用于选择要导入的地形模型。可以展开每个节点，并根据需要调整“导入”开关。

为了便于选择，还可以使用省略号“...”按钮打开“层导入”对话框。

父主题: 可缩放的地形模型


“可扩展地形模型管理器”对话框

用于处理与 STM 对象相关的所有操作。STM 管理器附加和卸载 STM 文件以及创建和管理这些文件。其他操作包括显示特征和坐标系选择。

当您从 MicroStation“文件”菜单或“光栅管理器实用工具”菜单中选择“可扩展地形模型”时打开。

键入命令： STMMANAGERDLG DIALOG OPEN
键入命令： STMMANAGERDLG DIALOG CLOSE
键入命令： STMMANAGERDLG DIALOG TOGGLE
设置 | 描述
文件 > 新建 | 打开“新建”对话框以创建新的 STM 文件。 键入命令： STM STMMANAGERDLG NEWSTM
文件 > 修改 | 打开“STM 高程源编辑器”对话框以修改 STM 文件的参数。 键入命令： STM STMMANAGERDLG MODIFYSTM
文件 > 连接 | 显示“连接文件”对话框，您可以在其中连接 STM。 <在按住 Ctrl 键的同时单击> 可同时连接多个文件。 键入命令： STM STMMANAGERDLG ATTACH < 文件名 >
文件 > 卸载 | 卸载 STM 文件。 键入命令： STM STMMANAGERDLG DETACH
文件 > 另存为 | 打开“新建”对话框以新名称保存 STM 文件的副本。 键入命令： STM STMMANAGERDLG SAVEAS
文件 > 将 STM 导出到 TM | 用于将 STM 导出到 MicroStation 本地地形模型。 键入命令： STM STMMANAGERDLG EXPORTSTMTOTM
编辑 > 检查是否为最新 | STM 系统将跟踪记录用于创建每个 STM 的文件。“检查是否为最新”工具可用于确定创建 STM 所用的任何文件是否比 STM 本身更新。通过这种方式，用户可以决定是否应该重新生成 STM，使其变为最新。 用于验证是否对源文件进行了任何更改。 键入命令： STM STMMANAGERDLG CHECKUPTODATE
编辑 > 生成 | 用于生成 STM。 键入命令： STM STMMANAGERDLG GENERATE
编辑 > 提取 TM 元素 | 用于从 STM 的所选区域中提取本地 MicroStation 地形模型 TM。 键入命令： STM STMMANAGERDLG EXTRACTDTM < BLOCK > < ORIBLOCK > < 元素 > < 形状 > < 视图 > < 围栅 >
编辑 > 提取光栅网格 | 将 STM 的一部分提取到光栅网格格式。 键入: STM STMMANAGERDLG EXTRACTRASTERGRID
编辑 > 提取等高线 | 将 STM 等高线的所选区域保存到 DGN 元素。 键入命令： STM STMMANAGERDLG VIEWSHEDANALYSIS
编辑 > 视域 | 用于打开“视域分析”对话框。 键入命令： STM STMMANAGERDLG VIEWSHEDANALYSIS
编辑 > 设置覆盖 | 用于分配要覆盖 STM 的光栅。 键入命令： STM STMMANAGERDLG SETDRAPING
编辑 > 剪切 | 用于剪切部分 STM。“剪切”工具设置可用于选择剪切方法和模式。 键入命令： STM STMMANAGERDLG CLIP < BLOCK > < ORIBLOCK > < 元素 > < 形状 > < 视图 > < 围栅 > < BOUNDARYMODE > < MASKMODE >
编辑 > 取消剪切 | 从 STM 中删除剪切。 键入命令： STM STMMANAGERDLG UNCLIP
编辑 > 修改剪切 | 用于修改被剪切 STM 的剪切多边形。 键入命令： STM STMMANAGERDLG MODIFYCLIP
编辑 > 覆盖元素 | 覆盖地形上的线性元素。 键入命令： STM STMMANAGERDLG DRAPELINE
视图 > 自动排列图标 | 如果打开，当调整对话框大小时，对话框工具栏中的图标将换行。
视图 > 显示层次 | 启用此项后，将会显示一个树，树中显示激活文件和直接与该文件连接的参考。关闭树时，可以使用“显示层次”图标旁边的箭头按钮列出激活文件以及直接与该文件连接的所有参考。
视图 > 展平模式 | 当打开“展平模式”且在“层次”窗格中选择激活设计时，将在右侧窗格中列出连接到激活设计的所有参考及其嵌套参考。当打开“展平模式”且在“层次”窗格中选择参考的 DGN 时，将在右侧窗格中列出连接到该 DGN 的所有参考及其嵌套参考。
显示 > 全景视图 | 全景显示所选 STM 或所有 STM。 键入命令： STM STMMANAGERDLG FITTOVIEW
显示 > 全景显示全部 | 在所选视图中全景显示连接的所有 STM。 键入命令： STM STMMANAGERDLG FITALLTOVIEW
实用工具 > GeoCS > 选择 | 用于从库中选择 GeoCS。 键入命令： STM STMMANAGERDLG COORDSYS SELECT
实用工具 > GeoCS > 删除 | 用于删除 GeoCS。 键入命令： STM STMMANAGERDLG COORDSYS DELETE
实用工具 > 文件名 | 用于选择新的 STM 文件。 键入命令： STM STMMANAGERDLG FILENAME
显示参考层次 | 与选择视图 > 显示层次菜单项相同。
展平模式 | 与选择视图 > 展平模式菜单项相同。
连接 | 与选择文件 > 连接菜单项相同。
卸载 | 与选择文件 > 卸载菜单项相同。
新建 | 与选择文件 > 新建菜单项相同。
修改 | 与选择文件 > 修改菜单项相同。
检查是否为最新 | 与选择编辑 > 检查是否为最新菜单项相同。
生成 | 与选择编辑 > 生成菜单项相同。
剪切 | 与选择编辑 > 剪切菜单项相同。
修改剪切 | 与选择编辑 > 修改剪切菜单项相同。
取消剪切 | 与选择编辑 > 取消剪切菜单项相同。
设置覆盖 | 与选择编辑 > 设置覆盖菜单项相同。
全景视图 | 与选择显示 > 全景视图菜单项相同。
文件名 | 显示文件名。双击文件名将打开“元素信息”对话框。 注释: 有关“元素信息”对话框的信息，请参阅 MicroStation 文档。
描述 | 显示 STM 的描述。
只读 | 显示 STM 的只读状态。如果打开，文件以只读模式打开，并且“只读”列中会显示一个复选标记。
捕捉 | 如果打开，则可以捕捉 STM 中的元素。列中的复选标记指示“捕捉”已打开。
定位 | 如果打开，则可以选择 STM 中的元素进行构造。列中的复选标记指示“定位”已打开。
剪切 | 可用于打开或关闭“剪切”功能。
显示覆盖光栅 | 如果打开，将显示覆盖光栅。列中的复选标记指示“显示覆盖光栅”已打开。
视图按钮 | 带编号的按钮用于定义在哪个（些）视图中显示点云。
只读 | 可用于打开或关闭“只读”功能。如果按下图标，则打开设置。
捕捉 | 可用于打开或关闭“捕捉”功能。如果按下图标，则打开设置。
定位 | 可用于打开或关闭“定位”功能。如果按下图标，则打开设置。
剪切 | 可用于打开或关闭“剪切”功能。如果按下图标，则打开设置。
显示三角形 | 可用于打开或关闭“显示三角形”功能。如果按下图标，则打开设置。 键入命令： STM STMMANAGERDLG DISPLAY TRIANGLES
显示等高线 | 可用于打开或关闭“显示等高线”功能。如果按下图标，则打开设置。 键入命令： STM STMMANAGERDLG DISPLAY CONTOURS
显示覆盖光栅 | 可用于打开或关闭“显示覆盖光栅”功能。如果按下图标，则打开设置。 键入命令： STM STMMANAGERDLG DISPLAY DRAPING

右键单击

右键菜单提供下列 STM 相关操作的选项。

  • 设置覆盖 — 用于选择要覆盖的光栅连接。
  • 检查是否为最新 — 用于验证 STM 是否为最新。
  • 生成 — 用于生成 STM。
  • 另存为 — 用于创建新的 STM。
  • 将 STM 导出到 TM — 用于将 STM 导出到 MicroStation 本地地形模型。
  • 全景视图 — 用于在当前视图中全景显示 STM。
  • 剪切 — 用于剪切部分 STM。
  • 取消剪切 — 用于取消剪切 STM。
  • 修改剪切 — 用于修改剪切多边形。
父主题: 可缩放的地形模型


“地理坐标系”对话框

您可以通过以下方式访问此对话框：
  • 功能区：实用工具 > 地理 > 坐标系
  • 工具箱：地理
设置 | 描述
细节

打开地理坐标系属性对话框。
GEOCOORDINATE DETAILS
从库

打开选择地理坐标系对话框。
GEOCOORDINATE SELECT LIBRARY
GEOCOORDINATE ASSIGN NOQUERY [ GCSName ]
GEOCOORDINATE ASSIGN REPROJECT [ GCSName ]
GEOCOORDINATE ASSIGN MATCHUNITS [ GCSName ]
注释: 如果之前未向文件分配地理坐标系，则通常使用 GEOCOORDINATE ASSIGN NOQUERY 键入命令。该键入命令可分配指定的地理坐标系，但不会查询用户、重投影或更改存储单位。其可用于分配地理坐标系（如果存储单位正确）。它采用存储在用户首选项文件 (*.UPF) 中的值。
注释: GEOCOORDINATE ASSIGN REPROJECT 键入命令将数据重投影到新的 GCS。该键入命令可分配指定的地理坐标系，但不会查询用户，因为它不可能更改单位。此键入命令将文件从一个地理坐标系重投影到另一个地理坐标系，因此该文件必须已定义地理坐标系。
注释: GEOCOORDINATE ASSIGN MATCHUNITS 键入命令会校正 GCS，但不会更改数据。其可分配指定的地理坐标系，并将存储单位与地理坐标系的存储单位相匹配，但不会查询用户或重投影。此键入命令将为文件分配地理坐标系，并且应更改其单位以匹配地理坐标系。当文件中的单位不正确时使用此键入命令。“状态平面”映射中常发生此情况。许多用户在 OpenRoads Designer 中选择英尺单位。但是，这些英尺是国际英尺，而状态平面坐标系以美国测量英尺为单位进行定义，因此长距离时会发生微小但显著的变化。此键入命令将设计文件单位更改为适用于指定坐标系的正确值。
从地标

打开来自地标的地理坐标系对话框。如果激活模型中没有地标界碑，则会禁用此工具。
GEOCOORDINATE SELECT PLACEMARK
从参考

打开来自参考的地理坐标系对话框。如果没有可用的参考连接，则会禁用此工具。
GEOCOORDINATE SELECT REFERENCE
到参考

打开在参考中设置地理坐标系对话框。如果没有可用的参考连接，则会禁用此工具。
GEOCOORDINATE TOREFERENCE
从文件

您可以将另一个设计文件中的模型 GCS 应用到当前文件，即使没有将其作为参考进行连接。
GEOCOORDINATE SELECT FILE
编辑重新投影设置

打开重投影设置对话框。
GEOCOORDINATE SETTINGS
删除地理坐标系

删除已连接到模型的地理坐标系。
GEOCOORDINATE DELETE
名称 | 显示库中指定的当前地理坐标系的名称。
描述 | 显示库中指定的当前地理坐标系的描述。
来源 | 显示库中指定的当前地理坐标系的来源。
“属性”对话框
父主题: 从文件创建


“来自地标的地理坐标系”对话框

用于在使用以结构为中心的坐标系时选择地标定义的 GCS。地理地标，即包含名称、经度、纬度和高度的单元，表示您的设计的地理位置。经度、纬度和高度字段指定相对于 WGS 84 基准的地理位置，WGS 84 基准是 GPS 设备报告的基准，且 Google Earth 也使用该基准。设计文件中的相应位置由单元的放置点指定。单元的比例和旋转不会影响其作为地理地标的含义。

您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框 - 选择从地标图标。

当提供了关于模型地理位置的信息时，将计算等积方位 GCS。需要至少两个地标才能计算此 GCS，且这些地标应跨越感兴趣的整个范围。使用“定义地标界碑”工具创建地标。

根据地标计算出的地理坐标系的精确程度仅与用于计算该坐标系的地标数据相当。如果使用计算出的 GCS 来参考其他地理定位的设计，则错误可能会累积。因此，请将参考设计中的要素之间的测量值视为近似值。

设置 | 描述
找到地标标记 | 显示模型中的地标列表，其中每个地标都具有地理坐标和笛卡尔坐标。 最重要的地标用作原点。点位于第二列中的地标用作根据地标计算出的等积方位 GCS 的中心。可通过计算出的参数部分中的经度、纬度、东伪偏移和北伪偏移的值来验证这一点。 “距离错误”和“方位角错误”列可以帮助您了解地标集在内部是否一致。理想情况下，所有误差值都很小。 “最大畸变角”和“最大畸变比例”提供在模型中的元素范围内出现的最大畸变值。如果最大畸变比例大于 0.01%，或最大畸变角大于 2’，则模型覆盖的面积过大，导致方位坐标系无法正常工作。
从地标标记计算坐标系 | 显示使用地标计算出的坐标系。
父主题: 从文件创建


“来自参考的地理坐标系”对话框

用于将连接的参考的 GCS 分配给激活模型。当连接的参考已指定标准 GCS 且尚未缩放或旋转时，或者已计算了等积方位 GCS 的参考已连接但未缩放（可以移动和/或旋转）时，可以使用参考来定向激活模型。

您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框 - 选择从参考图标。

如果连接了参考的地理坐标系已打开地理参考模式，则不能将该参考用作 GCS 的来源。该参考的位置根据其 GCS 和激活模型的当前 GCS 来计算，因此选择该参考作为来源将不会更改当前 GCS。“备注”列提供了有关特定连接无法用作 GCS 来源的原因。

设置 | 描述
选择参考作为地理坐标系源 | 显示已连接到激活模型的参考。
来自所选参考的地理坐标系 | 显示所选参考的 GCS 的坐标系属性。
父主题: 从文件创建


“在参考中设置地理坐标系”对话框

用于根据激活模型的 GCS 设置连接参考的地理空间坐标系 (GCS)。如果从标准库中选择 GCS，则可以使用 GCS 为重合、无缩放和不旋转的参考连接设置 GCS。如果 GCS 通过地标界碑计算得出，则可以用于为无缩放参考设置 GCS。

您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框 - 选择到参考图标。

设置 | 描述
选择要设置地理坐标系的参考 | 显示已连接到激活模型的参考。
应用 | 使用 OpenRoads Designer 的参考激活功能（该功能具有参考激活的全部要求和特征）将 GCS 写入所选的参考。所做的更改只有在可写参考释放之后才可撤消。
父主题: 从文件创建


“地理坐标系属性”对话框

用于显示地理坐标系 (GCS) 的属性。

您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框：选择细节图标

设置 | 描述
坐标系 | 显示坐标系信息。
基准 | 显示 GCS 的基准信息。
椭圆体 | 显示 GCS 的椭圆体信息。
坐标系修饰符 | 显示 GCS 的垂直基准和本地转换类型信息。
GUID-B70B0FAC-63A3-0F76-4ECE-73B93215CD52
Reprojection Settings Dialog
父主题: 从文件创建


定义地标界碑

用于将地理位置关联到模型中的界碑点。

您可以通过以下方式访问此工具：

地标界碑即名为“KmlPlacemark”的单元，其中的输入数据字段用于显示界碑的名称、经度、纬度和高度。单元原点代表地标在模型中的位置。可以输入多个地标，而且可以使用“激活比例”设置控制地标单元的大小。

由于它们是标准单元元素，因此仅需移动单元即可修改其设计文件位置。同样，也可以通过编辑相应文本元素直接修改经度、纬度和高度值。地标单元位于

您可以在的“地标属性”选项卡中查看地标属性。

要移除模型中的所有地标界碑，可以使用键入命令 GOOGLEEARTH PLACEMARK DELETE。

当选择的“来源”为“Google Earth 地标文件”时的“定义地标界碑”工具设置窗口

当选择的“来源”为“经纬度值”时的“定义地标界碑”工具设置窗口

当选择的“来源”为“笛卡尔坐标”时的“定义地标界碑”工具设置窗口

设置 | 描述
来源 列出地标的来源。提供以下来源：
  • Google Earth 地标文件 — 可将 Google Earth 地标文件中的地理位置与模型中的界碑点关联。要使用此选项，必须已在 Google Earth 中创建了地标文件，并将其保存为 KML 类型的文件。
  • 经纬度值 — 用于直接在工具设置窗口中输入经纬度值以及选择基准。如果设计中有建筑物拐角或其他标志性要素的经纬度，则此地标模式适用。
  • 笛卡尔坐标 — 用于在给定地理坐标系中输入“东移”和“北移”值。如果设计中有建筑物拐角或其他标志性要素在州平面（或类似地理坐标系）中的坐标，则此地标模型适用。

工具设置窗口中的其他选项因所选来源类型的不同而异。

GOOGLEEARTH PLACEMARK DEFINE FILE
GOOGLEEARTH PLACEMARK DEFINE DATUM
GOOGLEEARTH PLACEMARK DEFINE CARTESIAN
激活 | （仅限“Google Earth 地标文件”）显示当前激活的地标的名称；该选项菜单可用于选择其他地标。
浏览地标 | （仅限“Google Earth 地标文件”）打开“选择地标文件”对话框，该对话框用于选择地标文件。
基准 | （仅限“经纬度值”）选择地标的基准。如果选择的基准不是 WGS84（缺省值），则工具设置窗口将显示根据在相应字段中输入的经度和纬度计算得到的 WGS84 经度和纬度值。
经度 | （仅限“经纬度值”和“全球定位系统”）键入地标的经度值。
纬度 | （仅限“经纬度值”和“全球定位系统”）键入地标的纬度值。
高度 | （仅限“经纬度值”和“全球定位系统”）键入地标的高度值。
地标名称 | 键入地标的名称。
GCS 名称 | （仅限“笛卡尔坐标”）显示选择的坐标系。单击它旁边的浏览图标，将打开“选择地理坐标系”对话框。您可以在此对话框中选择地理坐标系。
东移 | 键入地标的东移值。
北移 | （仅限“笛卡尔坐标”）键入地标的北移值。
键入: GOOGLEEARTH PLACEMARK DELETE
父主题: 从文件创建


模板文档链接

添加各种模板属性。

（属性字段）

可以键入包含模板信息的文件的名称；此文件可以为任何类型。此外，还可以指定用于打开所需文件的程序。以“|”分隔程序与文件路径。例如：

iexplore | c:\DOT\Phase1\TemplateDocumentation\EndConditions_Detailed.html#ClassP6

这将使用 Internet Explorer 打开 html 文件，并转到书签 ClassP6。指定文件名仅会打开 html 文件，但不会继续转到指定的书签。

（浏览）

支持您选择用于与模板关联的文件。

打开链接

使用缺省程序打开属性文件。如果未与文件关联任何缺省程序，则会显示关于此影响的消息。

父主题: 创建模板


显示可扩展地形模型

STM 具有多种显示模式。其中每个模式均可从“STM 管理器 (STM Manager)”或“元素信息”对话框中打开或关闭。可以使用“元素信息”设置线符。在“STM 管理器 (STM Manager)”框中或通过使用元素选择器选择 STM。选择“元素信息”工具。

展开“可扩展地形模型”节点以显示“计算的特征显示”，然后选择相应的选项。

三角形
等高线
覆盖光栅
动画和渲染
父主题: 可缩放的地形模型


保存向导

通过单击“文本导入向导”中不同对话框上显示的“另存为”按钮，您可以保存向导。但是，除非向导包含至少一个完全定义的过滤器，否则“文本导入向导”将不允许您保存向导。

例如，假设您正在创建一个向导，以导入包含平面路线数据的文件。在“第 3 步”对话框中至少指定纵坐标和横坐标数据列之前，“文本导入向导”不允许您保存此特定向导（有关每种数据类型需要哪些列的详细信息，请参阅“导入所需的列”一节）。如果在满足过滤器的最低要求之前尝试保存向导，则该软件将显示错误消息，该消息尝试明确描述向导未能满足的要求。

至少定义一个过滤器之后，即使正在定义其他过滤器，也可以保存向导。（请记住：用于导入非统一文件的向导可能会包含多个过滤器。）

向导保存在 XML 文件中。向导保存之后，下次调用“文本导入向导”命令时可以使用该向导

父主题: 从 ASCII 文件创建地形模型


末端条件异常过渡

由于现有曲面或其他原因的变化，末端条件可能会突然改变，并且需要过渡在指定的桩号范围内平滑而不是在一小段上突然变化，因此使用末端条件过渡。这有一个常见实例：末端条件规则可能导致斜率在 5 英尺处理长度上从 1:6 变为 1:2。在这种情况下，在 100 英尺范围内从 1:6 到 1:2 的平滑过渡会比较理想。可以创建一个过渡，从 2:1 斜坡桩号开始返回 100 英尺，并在 2:1 斜坡桩号结束。另一个实例是从无肩的末端条件到有肩的末端条件。在此处，可以对肩部逐渐出现进行建模，而不是对在 5 英尺的间隔内从无肩到全肩的过程建模。

与替代异常一样，需要在放置后编辑过渡异常。下图是编辑从无肩到有肩的过渡的示例。请注意，首先选择肩点，以便过渡线使用该特征样式。

父主题: 创建末端条件异常


“标注地形等高线”工作流

工作流

  1. 从地形建模杂项工具组中选择“标注地形等高线”。
  2. 选择要标注的地形模型。
  3. 选择需要的工具设置。
  4. 画一条与要标注的等高线交叉的线。

将根据命令选项和文本样式设置向与该线交叉的等高线添加标高标签。

父主题: 标注地形等高线


“表面”选项

当导入包含曲面的文件时，将显示“曲面选项”对话框。文件名称显示在对话框标题中。如果关闭“文本导入向导”的“第 4 步”对话框上的“导入时指定 (Specify at Import)”开关，则此对话框上的选项将分别应用于每个过滤器。

如果为任何过滤器启用此开关，则所有过滤器将使用每次导入时“表面选项 (Surface Options)”对话框中提供的任何参数。

对话框选项

曲面

定义待导入的曲面的名称。您可以键入任何想要的名称。

围栅模式

定义区域/围栅如何影响此命令。如果忽略此模式，则放弃区域/围栅，该命令将在区域/围栅内外部运行。否则，此参数定义命令是在区域/围栅的内部还是外部运行。

特征

种子名称

指定要为添加到曲面的特征生成名称所用的种子名称。

特征样式

显示包含可用特征样式的下拉菜单。

点类型

显示包含可用点类型的下拉菜单。

钢笔顺序

在 ASCII 文件中指定提笔/落笔顺序信息：“先一后零”或“先零后一”。如果笔顺设置为“先一后零”，ASCII 文件的最后一列中的 1 代表线的开头，0 代表线上的点。

父级

指定使用特征过滤器时可用作过滤依据的数据。“父”值用于表示某些有共同特征的组。

从三角网中排除

选中后，将从三角网中排除每个特征。

相对路线 (Relative Alignment)

该对话框的此部分仅在某一过滤器中存在“相对标高”列标题时才会激活。

几何项目 (Geometry Project)

表示父项目。

平面路线

表示父平面路线。

纵面路线

高程将相对于此路线绘制。

确定

使用在对话框中定义的信息启动该命令，稍后关闭该对话框。

取消

关闭对话框。

过滤器

显示“特征选择过滤器 (Feature Selection Filter)”对话框。

帮助

显示帮助。

父主题: 从 ASCII 文件创建地形模型


“水膜效应”对话框

您可以通过以下方式访问此工具：

功能区：“地形”>“分析”>“水膜效应”

公式参数 |
纹理深度 | 路面纹理深度（视材质而异）。
公式 | Gallaway - 用于评估水膜效应风险的公式。 道路研究实验室 - 用于评估水膜效应风险的公式。
地形分析参数 |
流线间隔 | 缺省值为 500 毫米，2 英尺。
降雨强度 | 缺省值为 50 毫米/小时，2 英寸/小时。
使用等面积坡度 | 控制如何测量跨过路面的坡度。
屋脊坡度过缓 | 定义脊线两侧相邻三角形之间的坡度差，低于该值则视为浅脊。这会影响流线的创建方式。
特征 |
特征定义 | 选择描述所创建元素的特征定义。
名称 | 该名称通过选定的特征定义进行填充。根据需要使用新名称覆盖此值。

屋脊坡度过缓

当超高沿道路出现反向或翻转时，可以创建浅脊。“水膜效应”工具用于创建流线，一个脊将会创建两条流线 - 脊的两侧各一条。这可能导致不良结果，如下所示：

下图解释了具体情况。图中显示的数据与上述相同，但增加了路面三角形（以灰色表示）和流向箭头（以青色表示）。

两个流向箭头以红色绘制。这两个点远离其公共三角形边，这表明三角形边为脊，以更粗的红色线显示。因为它是脊，所以创建了两条流线（以深蓝色显示）- 均起始于脊的起点。此外，还创建了第三条流线（以紫色显示），起始于脊的终点。如果该脊的长度大于“流线间隔”属性所用值，则会创建另外的流线对，流向为远离脊的两侧。

“屋脊坡度过缓”属性可用于改善流线，如下所示：

图中再次显示相同的数据，但“屋脊坡度过缓”的值为 0.5%。以红色高亮显示的两条流线之间的坡度差小于 0.5%，因此该脊被视为浅脊并忽略不计。

应注意不要使用过高的值，因为这样可能会移除作为路面几何图形有效结果的脊。

父主题: 水膜效应


调整

在“数据树”中选择“调整”分支时，“显示面板”将显示“最小二乘法平差”引擎所使用的属性。有关详细信息，请参阅“最小二乘法平差”主题。

父主题: 显示细节


管理可扩展地形模型

使用可扩展地形模型管理器对话框管理 STM 对象。

父主题: 可缩放的地形模型


OpenRoads Designer CONNECT Edition帮助

上次更新时间： 2019 年 1 月 30 日

OpenRoads Designer CONNECT Edition
新增功能
入门
功能区
文件
主页
地形
几何图形
廊道
模型细部设计
绘图制作
测量
MicroStation
Descartes
地下公共设施
地理技术
自述
OpenRoads Designer 工具索引
OpenRoads Designer 键入索引


视域分析工具设置

设置 | 描述
面积 定义要处理的区域。STM 非常大，在许多情况下，远离所选视点的区域无需处理。使用选择工具标识适当的区域或选择元素或视图。选项如下：
  • 块
  • 定向块
  • 元素
  • 形状
  • 视图
键入命令： STM VIEWSHEDANALYSISDLG DEFINEAREA < BLOCK > < ORIBLOCK > < 元素 > < 形状 > < 围栅 > < 视图 >
查看位置 描述查看器的位置。
键入命令： STM VIEWSHEDANALYSISDLG IDENTIFYVEWERPOS
方法 输入静态点或路径。
键入命令： STM VIEWSHEDANALYSISDLG IDENTIFYVEWERPATH
位置 | 如果选择“静态”位置，则激活。键入 X、Y 和 Z 值或使用选择工具进行定义。
增量 | 指定计算结果所沿路径的增量距离。增量越小，处理时间越长。
高程 指定要使用的高程：
  • 指定的点或元素 - 使用点或选定路径元素定义的高程。
  • STM 高程 - 该点的 STM 高度。
  • 高于 STM 的高度 - 高于 STM 的指定高度。
  • 用户定义的高程 - 用户定义的高程。只有点或路径的 X 和 Y 值可用于由此参数确定其高程值的位置。
像素大小 | 生成的栅格文件中的输出像素大小。值越小，处理时间越长。
测量工具 用于测量像素大小。
键入命令： STM MEASURER
栅格文件名 | 生成的栅格文件的名称。
运行 启动视图分析过程。
键入命令： STM VIEWSHEDANALYSISDLG RUN
父主题: 视域分析


连接工具

功能区：“主页”>“基本”

参考 | 使用“参考”对话框管理参考连接。
光栅管理器 | 使用“光栅管理器”对话框管理光栅参考连接。
点云 | 使用“点云”对话框导入、控制、呈现和操作点云图像。
实景网格 | 使用“实景网格连接”对话框连接和操作实景网格。
父主题: 基本


线性特征

当在“数据树”中选择“线性特征”分支时，“显示面板”将显示从测量原始数据派生的所有线性特征以供查看/编辑。

展开“线性特征”分支，然后选择特定特征样式以便仅在详情面板中列出该类型的线性特征。

父主题: 显示细节


覆盖元素

将矢量元素覆盖到地形上。

从 STM 对话框的“编辑”菜单中，选择“覆盖元素”。

选择要覆盖的元素。如果要覆盖多个元素，请在启用“覆盖元素”工具之前将它们作为选择集的一部分。

以下元素对于覆盖有效：

  • 直线
  • 点
  • 线串
  • 复杂链
  • 曲线
  • 弧
  • B 样条曲线
  • 圆
  • 椭圆
  • 文本
  • 文本节点
  • 图形单元
  • 共享单元
  • 注释单元
  • 孤立单元
  • 点单元
设置 | 描述
保留原始元素 | 保留原始元素。如果未选择，则将删除原始元素。
使用所有 STM | 在处理期间使用所有连接的可扩展地形模型。
小平面曲线 | 曲线和弧将根据“最大弦高”设置中指定的公差进行划线。测量工具可用于直接从模型测量弦高。
简化 | 将指定的简化应用于生成的覆盖元素。此过程将从原始结果中移除点，仅保留那些被视为具备矢量线原始路径特征所必需的点。可使用以下选项。
流线参数 | 此方法使用与 MicroStation Place Stream 工具相同的参数来简化多义线。
Douglas-Peucker | 这可能是减少多义线点的最常用方法。它排除从连接 2 个相邻点的基线偏离已设置公差的点。使用由点 A、B 和 C 组成的多义线。如果点 B 与段 A 到 C 的距离大于公差，则点 B 将从多义线中移除。
公差 | 对于“流线参数”类型，请在以下位置设置公差：流线增量 - 设置多义线点之间的最小距离（采用工作单位）。流线公差 - 设置点之间的最大距离（采用工作单位）。流线角度 - 设置角度（以度为单位）。流线面积 - 设置超出范围时保留采样点的区域。相关区域是通过分别在最后记录的两个数据点和该采样点之间拉伸直线而形成的三角形。该值采用平方主单位表示，且必须指定为浮点数（例如，110.0 或 1.1E2）。对于 Douglas-Peucker 类型，请设置最大距离的公差（采用工作单位）。

接受操作之后，选定的线将覆盖到 STM 的表面上。

变量 STM_ DRAPEELM_USESUBRES 控制所使用的 STM 的分辨率。设置为 0 时，使用全分辨率。设置为 1 时，使用子分辨率。

父主题: 可缩放的地形模型


取消合并组件点

将组件与模板分开。如果将组件点与另一个组件共享，则会创建此点的副本。组件的点与模板中其他点之间的所有约束关系将会移除（请注意约束颜色指示符将会修改）。

父主题: 创建模板


计算加宽

执行曲线加宽时，首先使用曲线半径查找内外过渡段长度和宽度。使用此表，如果半径或曲线为 750 英尺，则表值将是下一个较小半径（本例中为 700 米）或宽度和过渡段长度的值，分别为 3、150、3 和 150。确定这些值后，在桩号范围内的每条曲线处，通过创建 3 个平面点控制将适用的宽度添加到指定线。第一个和最后一个控制是从点相对控制路线的当前偏移过渡到当前偏移 + 加宽宽度的偏移。这些过渡控制的起点和终点位置由对话框中的过渡属性确定。中间平面控制处于当前点偏移 + 加宽宽度的常量偏移。

父主题: 创建曲线加宽


镜像

向模板中添加新组件时，使用此命令可在放置组件时在水平方向创建组件的镜像副本。

在添加过程中右键单击可访问此选项。放置组件后，此选项不再可用。

父主题: 添加（组件）命令


地形过滤器管理器

设置 | 描述
名称 | 用于标识过滤器的唯一短名称。
描述 | 用于进一步标识过滤器的可选描述（如果“名称”不足）。
特征类型 | 选择与数据类型对应的特征。另请参阅特征。
过滤器类型 |
链接到地形特征 | 关闭： 从图形创建地形模型，但不保留与图形的任何关联。因此，如果稍后编辑图形，地形模型不会更新，而是需要重新生成。使用此选项可提高性能。 打开： 创建地形模型并将其关联到图形元素。因此，对图形的编辑将立即更新地形模型。如果对大型数据集使用此选项，则构建地形模型需要很长时间。将扫描 DGN，找到的前 15,000 个元素将添加到已附加到所创建的地形模型的规则中。更改其中一个元素将会影响地形模型。在 DGN 中找到的其他元素将添加到地形模型中，但不会添加到规则中。更改其中一个元素不会影响地形模型。如果达到限制，土木消息中心将显示一条警告。
编辑过滤器 | 打开“编辑过滤器”对话框，您可在其中设置过滤器参数，即级别、颜色、土木特征等。 单击左侧的类别，然后选择参数，可以设置这些参数。定义选择集，选择类别，然后单击“通过选择”。软件将基于选择集中的元素自动填充字段。支持多选（选择六种颜色或五个级别等）。要查看与过滤器匹配的元素数量，请单击“预览”。视图中适合过滤器的所有元素将高亮显示。设置完参数后，单击“完成”关闭编辑器，并返回“过滤器管理器”对话框。
过滤依据 | “过滤依据”部分将快速显示当前过滤器中指定的类别。例如，如果使用级别和颜色来定义过滤器，则过滤完成后，级别和颜色项将会打开。 有关级别、颜色、线宽、线型和其他元素属性的详细信息，请参考 MicroStation 帮助主题。
父主题: 从图形过滤器创建


显示设置

选项 | 描述
廊道 - 元素模板 | 元素模板用于在“创建廊道”工具中绘制廊道边界。作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
廊道手柄长度系数 三维路面手柄长度系数 单桩号手柄长度系数 缓和手柄长度系数 | 长度系数是指手柄长度与廊道宽度的比率。因此，1.0 将使手柄与该点处的廊道宽度一样长。
廊道手柄间距 | 手柄间距可设置为如图所示的物理距离，或设置为零。如果设置为零，则每个廊道将获得 11 个手柄，无论其长度如何。任何非零值都用作沿纵面路线在主单位中测量的手柄之间的距离。
三维???面 - 元素模板 | 用于在“创建三维路面”工具中绘制三维路面边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
缓和 - 元素模板 | 用于在“创建过渡段”工具中绘制过渡边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
父主题: 操纵器设置


视域分析工作流

  1. 对于“路径”方法，使用选择工具来标识线性元素。
  2. 标识所选元素的哪一端为起始点。 这很重要，因为沿线测量从选定端开始，获得的结果可能略有不同，这取决于选择哪一端。
  3. 在设置相应参数并选择视域范围后，选择“运行”。
  4. 标识应用于计算视域的视图。
生成的分析将在指定栅格文件中产生。此文件可连接任何光栅文件进行可视化。
如果路径或元素已移动或更改，确保使用相应的工具再次对其进行选择。当选中每个元素后，会使用该元素图形的副本进行处理，而不是原始元素。
父主题: 视域分析


视域分析

视域分析确定可从指定位置或路径看见 STM 的哪个部分。输出为光栅网格文件。这有助于定位砾石坑或森林采伐等，使其从视点或路径中不可见或可见性最低。

视域分析工具设置
视域分析工作流
父主题: 可缩放的地形模型


线性

参数 | 描述
创建模板中定义的几何元素 | True - 创建模板几何图形。False - 不创建模板几何图形。 False - 不创建模板几何图形。
线性特征符号 | 用于绘制线性特征的线符。
父主题: 特征定义


应用组件名称覆盖

使用此对话框在一组组件上设置“组件名称覆盖”属性。请谨慎使用此对话框，以确保仅为在任何给定桩号与解决方案相互排斥的组件分配相同的组件名称。可以使用测试末端条件对话框上的“验证特征 (Verify Features)”按钮测试组件名称覆盖。

“组件名称覆盖”不适用于组件显示规则、“激活模板”列表或“父/子”下拉菜单。

遇到的第一个组件的样式用于具有该覆盖的所有组件。

组件名称覆盖

指定要应用于所选组件的组件名称。

应用于组件

列出要应用组件名称的可用组件。已经具有覆盖的组件显示为红色，覆盖名称也会显示。

父主题: 工具命令（创建模板）


缩放到项

  1. 打开“资源管理器”对话框的其中一个选项卡并展开“项类型 (Item Type)”节点。
  2. 执行以下操作之一：

    选择一个项。

    或

    右键单击该项并选择“缩放”。

  3. 单击“缩放”图标 [image] 。

    应用程序会将绘图中的项放大。项的放大倍数由“资源管理器设置”对话框中的“缩放因子”设置控制。

父主题: 常用工具


按图形过滤器创建的相关工作流

工作流

  1. 启动命令。

  2. 选择过滤器组。

已在 dgnlib 库中定义以备使用。

或

  1. 单击“图形组”按钮，以启动“图形过滤器管理器”并构造自定义过滤器组。

  2. 输入数据点以从 DGN 和参考中的所有可见元素构造地形。

父主题: 从图形过滤器创建


视距分析报告

显示“移动目标以实现可视性”关闭时剖面运行期间所用的全部设置。

绿色指示已实现目标状态。

红色指示未实现目标距离。

高亮显示的行项显示在图形视图中。选择要显示的一个或多个项。

报告 | 显示“视距分析”报告。
已实现 |
已放宽 |
未实现 |
显示已选定 | 开启可在三维图形视图中显示行项。 白线指示为实现目标需延伸的距离。

使用浏览器工具查找 OpenRoads Designer 模型内容将显示按特征定义排序的树。选择要查看的特征定义将在三维图形视图中显示结果视图和弹出框显示。

父主题: 视距分析


创建挖方和填方土方量

  1. 选择该工具并按照警告提示操作。

    提示

    用户操作

    选择现有表面

    以图形方式选择任何地形模型，通常是现有地形。

    选择设计表面

    以图形方式选择任何网格，通常是设计曲面。

    挖方特征定义

    注意：使用键盘箭头键导航特征层次。用于挖方土方量的线符的特征定义。

    填方特征定义

    注意：使用键盘箭头键导航特征层次。用于填方土方量的线符的特征定义。

    点击确认以接受选择

    点击确认屏幕上的任何位置以开始处理。

  2. 选择其中一个挖方或填方土方量对象，然后使用“属性”或“元素信息”查看土方量。
父主题: 创建挖方和填方土方量


工具命令（创建模板）

这些命令用于组织模板以及管理当前模板的各种设置。

选项

模板库管理器
应用特征名称覆盖
应用组件名称覆盖
模板选项
命名设置
动态设置
父主题: 创建模板


层管理器

功能区：“主页”>“基本”

层管理器

用于控制打开的 DGN/DWG 文件和连接的参考的层显示和层线符。

父主题: 基本


添加新的末端条件组件

向模板添加末端条件组件。有关末端条件的详细信息，请参阅创建模板概述。

当前组件

名称

指定新约束的名称。

样式

指定新组件的特征样式。此选项用于显示以及定义组件的材质。

目标类型

指定末端条件将查找的目标类型。目标包括：

  • 曲面 - 查找曲面。

  • 高程 - 查找特定高程。

  • 特征 XY - 查找特定曲面特征的水平位置。

  • 特征高程 - 查找特定曲面特征的垂直位置。

  • 特征 XYZ - 查找特定曲面特征的位置。覆盖末端条件分段的坡度约束以查找特征。

  • 路线 XY - 查找特定路线的水平位置。

  • 路线高程 - 查找特定路线的垂直位置。

  • 路线 XYZ - 查找特定路线的位置。覆盖末端条件分段的坡度约束以查找特征。

优先级

确定末端条件尝试求解的顺序。先尝试较小的数字。如果有多个末端条件从同一点开始，则使用此值。

定边坡

启用即指定重复末端条件分段的集合，直至找到解。

计数（字段）

指定应该定边坡的最大次数。如果此值为 0，则重复次数无限制，定边坡末端条件必须找到其目标才会有效。大于 0 时，如果重复定边坡指定次数但未达到目标，并且连接到定边坡末端条件终点的末端条件成功，则定边坡末端条件仍视为成功。

自数据

启用即指定定边坡使用基准高程和步长高程设置定边坡，而非使用定义的末端条件分段。

基准（字段）

指定构成步长高程基础的高程。基准 + 当前工作台高程 = n * 步长高程。

步长高程

指定使用基准时的定边坡增量。每个工作台高程始终位于定边坡末端条件的第一段末尾（或第二点）。

水平偏移

指定相对目标的水平偏移。仅当目标为水平目标或具有水平长宽比时，这些值才适用。

竖向偏移

指定相对目标的竖向偏移。仅当目标为垂直目标或具有垂直长宽比时，这些值才适用。对于高程目标，请在此处指定高程。

长度取整

指定用于对末端条件进行取整的长度。当此值不为 0.0 时，利用抛物线公式在末端条件末尾添加 4 个额外的点，以平滑末端条件与曲面相交处的过渡。仅当目标为曲面或高程时，此取整效应才适用。连接到此目标终点的其他末端条件连接到圆形剖面终点。

测试

显示“测试末端条件”对话框。有关测试末端条件的详细信息，请参阅测试末端条件。

父主题: 添加（组件）命令


向导和过滤器

在使用“文本导入向导”导入文件之前，请定义一般格式（称为向导），可以重复使用该格式导入任意数量的相同类型的文件。向导描述 1) 每列数据的内容，2) 列是固定宽度还是由分隔符分隔，3) 要导入的行。

向导由一个或多个过滤器组成。过滤器是一组描述要导入的文件内不同行组的参数。在许多情况下，向导包含一个过滤器。统一的数据文件便是如此。在统一的数据文件中，要读取的所有数据行均具有相同的格式。由于格式的一致性，因此向导仅需一个过滤器即可描述统一的数据文件。为导入统一数据文件定义向导时，向导和过滤器完全相同。

另一方面，非统一的数据文件在单个数据文件中包含不同格式的行（不同的行表现出不同的格式）。要适应多种行格式，向导必须包含多个过滤器。具体地说，向导需要为每种类型的行格式提供一个过滤器。在为导入非统一数据文件定义向导的过程中，可以定义多个过滤器，这些过滤器组合在一起构成向导。

  1. 从 ASCII 工具中选择“创建 TM”。

    将显示“创建文本导入向导 (Create Text Import Wizard)”对话框。

  2. 将“向导名称”设置为 <New>，指定相应的数据类型以及要导入的文件名称。

  3. 单击“确定”。

    将显示“文本导入向导 - 第 1 步”对话框。

  4. 设置“范围内的行 (Lines within Range)”以指定文件中的哪些行包含实际数据。

  5. 单击“下一步”。

    将显示“文本导入向导 - 第 2 步”对话框。

  6. 定义如何应用过滤器、定义原始数据类型和查看已定义的过滤器。

  7. 单击“下一步”。

    将显示“文本导入向导 - 第 3 步(固定宽度)”对话框。

    或

    将显示“文本导入向导 - 第 3 步(分隔符)”对话框。

    显示的对话框取决于您在“文本导入向导 - 第 2 步”对话框中定义的原始数据类型。

  8. 提供定义的数据类型所需的信息。

    将显示“文本导入向导 - 第 4 步”对话框。

  9. 定义要导入的文件中每列数据的内容。

  10. 单击“完成”。

父主题: 从 ASCII 文件创建地形模型


视距分析工作流

定位廊道或路线

选择廊道将会使用廊道路线作为命令的控制路线。所有桩号设置均相对于此控制路线。这还会导致分析使用廊道的顶网格作为设计曲面，而且以后不会出现“定位设计曲面”的提示。

选择路线会导致选定的路线用作工具的控制路线。在这种情况下，用户以后将收到“定位设计曲面”的提示。

定位视线控制路线 - 重置以使用主路线

如果选择路线来控制视点位置，则会通过将桩号平行和垂直主控制参考方向投影到选定的视点控制路线来计算视点位置的 XY 位置。系统将相对于选定的视点控制路线应用偏移。

如果重置以使用主路线来控制视点位置，则会直接从主控制路线计算视点位置的 XY 位置。此时将相对于主控制路线应用偏移。

定位对象控件对齐-重置为主对齐

如果选择路线来控制对象位置，则会通过将桩号平行和垂直主控制参考方向投影到选定的对象控制路线来计算对象位置的 XY 位置。系统之后将相对于选定的对象控制路线应用偏移。

如果重置以使用主路线来控制对象位置，则会直接从主控制路线计算对象位置的 XY 位置。此时将相对于主控制路线应用偏移。

起点桩号 <Alt> 锁定到起点

选择要分析的第一个视点位置的位置。选择起点桩号位置将会向用户显示临时视线。此临时视线仅用于帮助用户在分析视线时可视化视点和对象位置的目标位置。它并不动态分析视线距离。

注释: 将终点桩号设置为小于起点桩号可按行进的相反方向进行分析。当终点桩号小于起点桩号时，偏移相对于行进方向。因此，无需因行进方向改变而更改偏移的符号（负或正）。

<Alt> 锁定到起点

将起点桩号锁定到控制路线的起点。

终点桩号 <Alt> 锁定到终点

选择要分析的最后一个视点位置的位置。

<Alt> 锁定到终点

将终点桩号锁定到控制路线的终点。

定位设计曲面

选择要用作设计曲面的曲面。稍后，命令的提示序列中将显示定位现有曲面的提示。在分析视线过程中，如果未指定任何现有曲面，将仅使用设计曲面来确定视线是否实现所需的视线距离。如果最初选择了廊道，则不会出现“定位设计曲面”的提示。

定位已有表面 - 重置以忽略

选择要用作现有曲面的曲面。如果选择了现有曲面且其与设计曲面不同，则分析将忽略与现有曲面的交点（如果其在选定设计曲面的边界内）。如果重置以跳过现有曲面，分析将仅检查与选定设计曲面的交点。类似地，如果选择了现有曲面但未选择任何设计曲面，则分析将仅检查与选定现有曲面的交点。

确保“移动目标”复选框设置为所需的分析类型。切记，当“移动目标”为“打开”时，将针对每个对象位置间隔分析视线，直至该视点位置实现规定距离或者找到与设计或现有地形或网格的交点。如果找到了交点但未实现所需的视线距离，分析将显示该视点位置的最后一个成功的视线。当“移动目标”为“关闭”时，将仅分析给定视点位置的一个对象位置，而且对象位置将从视点位置开始沿对象位置的参考路线下降，下降距离等于沿主控制路线测得的规定距离。

点击确认以接受“设置文件”。

点击确认以接受“可视性类型”。

点击确认以接受“速度”。

点击确认以接受“规定距离”。

点击确认以接受“松弛距离”。

将显示“结果”对话框，分析的视线出现在三维模型中。如果三维模型已连接到二维模型，则视线在二维模型中也可见。它们不是单独的路线，而是一组临时线，其显示受“结果”对话框上的复选框（“已实现”、“已放宽”和“未实现”）控制。

“结果”对话框的右侧有一个用于显示或隐藏扩展属性的箭头。

此外，“报告”图标还显示报告浏览器以及包含“结果”对话框中未显示的额外信息的缺省报告。

可通过浏览器或在三维模型中选择视线时显示的弹出菜单来访问给定视距分析剖面的“结果”对话框。

“显示已选定”复选框仅显示选定行的视线。使用向上/向下箭头可显示在“结果”对话框中选择的行。如果为“关闭”，将恢复“已实现”、“已放宽”和“未实现”复选框的先前状态。

父主题: 视距分析


圆弧延长

用于根据控制一端相切的选定基准元素来构造弧。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“圆弧延长”根据控制一端相切的选定基准元素来构造弧。构造可能还包括可选缓和曲线过渡或弧过渡（双心圆曲线）。

选择要确定相切的基准元素，然后定义弧参数以便用各种方法定义弧。

工作流

对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  1. 选择基准元素。

  2. 使用以下方法之一“输入偏移”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入“弧长”值，然后按 Enter 键并点击确认。

  3. 选择起始点。这是与基准元素或其偏移相切的点。

  4. 使用以下方法之一设置“通过点”或“半径”（通过单击向左或向右箭头键来导航选项）：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入“半径”值，然后按 Enter 键并点击确认。

    • 输入“通过点”值，然后按 Enter 键并点击确认。

  5. 使用以下方法之一“定义弧长”：

    • 移动光标时，会在提示框中显示值。在所需值处点击确认。

    • 输入“弧长”值，然后按 Enter 键并点击确认。

  6. 要将基准元素修剪或延长到与弧的交点处，请单击向上或向下箭头键选择“修剪/延长”选项。

对话框自定义

右键单击对话框可针对特定任务或用户首选项自定义对话框。

曲线过渡

基于此工具进行的曲线构造可以包括选定参考元素与曲线之间的过渡。可用的过渡选项有：

  • 无 - 无过渡（仅构造中心简单曲线）

  • 缓和曲线。一条缓和曲线（创建曲线构造）

此处列出了可用于创建缓和曲线的值。

  • 双缓和曲线。使用此工具可以创建两条缓和曲线；第一条缓和曲线的过渡与参考元素在同一侧，从参考元素半径开始，过渡到无穷远。第二条缓和曲线从无穷远过渡到新曲线的半径，在相对一侧。尽管此弯曲参考元素为最常见的用例，但可以在任何所需的位置使用双缓和曲线。

注释: 最常使用的情况是参考元素本身是曲线，并在相对一侧。

  • 曲线 - 构造双中心曲线（过渡曲线由半径和长度定义）

  • 弧比率 - 构造双中心曲线（过渡长度由中心曲线的比率定义）

操控器

使用“功率选择器”选择已创建的直线可显示编辑操控器。

在无捕捉且无土木精确绘图约束的情况下放置直线时，屏幕上将显示操控器，如上所示。这些操控器可用于编辑直线，如下所述：

  • 过渡参数文本操控器

  • 偏移文本操控器和拖曳图柄

  • 半径文本操控器

  • 终点方向文本操控器和拖曳图柄

  • 弧长拖曳图柄

属性

此外，也可以在弧的属性中访问规则数据。选择弧并单击“元素”>“信息”，或者打开“项”浏览器。您可以编辑属性窗格中的大部分数据来更改弧定义。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“圆弧延长”图标，然后从元素工具中选择“显示/隐藏圆弧 (Show/Hide Arc)”以访问下列选项：

  • 简单圆弧切向延长 - 创建到另一元素无任何过渡的简单半径弧，并且偏移锁定为零

  • 双圆弧组合延长 - 创建弧过渡始于另一元素的弧，并且偏移锁定为零

  • 圆+缓和曲线延长 - 创建缓和曲线过渡始于另一元素的弧，并且偏移锁定为零

  • 圆+双缓和曲线延长 - 创建到另一元素为反向缓和曲线过渡的弧（仅在“从”元素是反手侧曲线时适用），并且偏移锁定为零

父主题: 圆弧延长工具


管理点列表

  1. 执行以下操作之一：

    在“细节”对话框中右键单击“线性特征”名称，然后选择“管理点列表”。

    或

    在屏幕上选择“线性特征”，右键单击工具菜单并选择“管理点列表”。

    将显示“线性特征”点列表。

  2. 如果“图形线性特征 (Graphic Linear Feature)”尚未转换为“点列表线性特征 (Point List Linear Feature)”，则“添加”、“插入”、“替换”、“删除”、“向上”、“向下”、“转置”按钮不可用。
  3. 如果“图形线性特征 (Graphic Linear Feature)”已转换为“点列表线性特征 (Point List Linear Feature)”，则“添加”、“插入”、“替换”、“删除”、“向上”、“向下”、“转置”按钮可用。
父主题: 管理点列表


点选择

使用此命令可从点选择列表中选择点。缺省情况下，一次只列出 4 个点。可选择 ESC 键滚动到下一组点。

父主题: 创建模板


三角形

将 STM 显示为 TIN（三角形化不规则网络）。随着视图缩放比例的更改，TIN 的显示也会动态更改。线符和视图着色模式可以设置为如下图所示。材料也可以连接到 STM 以增强真实感。

主题显示是三角形显示的一部分。“从视图”选项与视图的显示样式匹配。其他选项与可用于视图着色的选项相同。STM 着色功能适用于选定的 STM，且是一种全局设置。它可能与视图设置不同，允许更自定义的显示。您可能需要在对话框中取消选择 STM 文件才能正确查看选定的着色。

父主题: 显示可扩展地形模型


插入直-缓-圆-缓-直曲线

用于在先前放置的两个元素之间构造弧。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“插入直-缓-圆-缓-直曲线”用于在先前放置的两个元素之间构造弧。此工具能够选择在元素和构造的弧之间应用后过渡段和/或前过渡段。

工作流

注释: 在“插入直-缓-圆-缓-直曲线”对话框中，可随时锁定任何输入。锁定某些值可能会限制或影响其他值。

  1. 选择用于构造线起点的元素。点击确认，例如单击鼠标左键接受。

  2. 设置与第一个元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  3. 选择弧将延伸到的第二个元素。要接受的数据点。

  4. 设置与第二个元素的偏移距离。可以使用鼠标以图形方式选择此距离，也可以键入数值。

  5. 您也可以填写“后渐变”信息。此信息可以采用三种格式：

    • 长度 - 比率（如下所示）

    • 长度 - 偏移

    • 比率 - 偏移

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    注释: 如果对话框中的“后渐变”选项设置为“无”，系统将不会提示您输入此信息。

  6. 您也可以填写“前渐变”信息。此信息可以采用三种格式：

    • 长度 - 比率（如下所示）

    • 长度 - 偏移

    • 比率 - 偏移

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    注释: 如果对话框中的“前渐变”选项设置为“无”，系统将不会提示您输入此信息。

  7. 您也可以填写“后过渡段”信息。此信息可以采用八种可能的格式组合：

    • 缓和曲线 - 长度（如下所示）

    • 缓和曲线 - A 值

    • 缓和曲线 - 偏转

    • 缓和曲线 - 增量 R

    • 缓和曲线 - RL

    • 曲线 - 长度

    • 曲线 - 偏转

    • 曲线 - 增量 R

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    注释: 如果对话框中的“后过渡段”选项设置为“无”，系统将不会提示您输入此信息。

    缓和曲线的定义：

    • 长度 = 缓和曲线长度

    • A 值 = RL 的平方根

    • RL 值 = 半径乘以长度

    • 偏转 = 缓和曲线 PI 的偏转（在美国，有时称为缓和曲线角度）

    • 增量 R = 从简单曲线没有缓和曲线的位置到具有缓和曲线的曲线的偏移（在美国，称之为投射或偏移）

  8. 可以选择填写“前过渡段”信息。此信息可以采用八种可能的格式组合：

    • 缓和曲线 - 长度（如下所示）

    • 缓和曲线 - A 值

    • 缓和曲线 - 偏转

    • 缓和曲线 - 增量 R

    • 缓和曲线 - RL

    • 曲线 - 长度

    • 曲线 - 偏转

    • 曲线 - 增量 R

    使用向左或向右箭头键在各个字段间切换，键入所需的值，然后按 Enter 键接受。

    注释: 如果对话框中的“前过渡段”设置为“无”，系统将不会提示您输入此信息。
  9. 选择弧的半径。可以用图形方式选择该值，也可直接键入数值。

  10. 选择截断方法。从以下选项中进行选择：

    • 无

    • 上一步

    • 前

    • 两者

    这将截断或修剪用于构造弧的元素。

使用 ALT 键

在操作该命令期间，按住 ALT 键可以在备选解决方案之间切换。对于此命令，该键有两种功能：

  • 拾取基准元素时，按 ALT 键可以拾取复合元素的组件，而不是复合元素本身。

  • 放置弧时，按 ALT 键可以在最短弧与最长弧之间切换（循环显示）。

曲线过渡

基于此工具进行的曲线构造可以包括选定参考元素与曲线之间的过渡。可用的过渡选项有：

  • 无 - 无过渡（仅构造中间简单曲线）

  • 缓和曲线 - 一条缓和曲线（创建曲线构造）

此处列出了可用于创建缓和曲线的值。

  • 双缓和曲线 - 使用此工具可以创建两条缓和曲线；第一条缓和曲线的过渡与参考元素在同一侧，从参考元素半径开始，过渡到无穷远。第二条缓和曲线从无穷远过渡到新曲线的半径，在相对一侧。尽管此弯曲参考元素为最常见的用例，但可以在任何所需的位置使用双缓和曲线。

注释: 最常使用的情况是参考元素本身是曲线，并在相对一侧。

  • 曲线 - 构造双中心曲线（过渡曲线由半径和长度定义）

  • 弧比率 - 构造双中心曲线（过渡长度由中心曲线的比率定义）

对话框自定义

右键单击对话框可以针对特定任务或用户首选项自定义对话框。

操控器

操控器可用于：

  • 偏移

  • 后渐变

  • 前渐变

  • 后过渡段

  • 前过渡段

  • 半径

  • 拖动图柄可以动态调整与两段弧的可选偏移距离

属性

“插入直-缓-圆-缓-直曲线”规则数据也会显示在“元素信息”对话框的属性中。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“插入直-缓-圆-缓-直曲线”图标，然后选择“显示/隐藏圆弧延长工具”可以访问以下选项：

  • 插入简单切向圆弧 - 创建一个两端没有缓和曲线或渐变的半径弧，“偏移”锁定为零

  • 插入缓-圆-缓曲线 - 创建一个两端有缓和曲线过渡但没有渐变的半径弧，“偏移”锁定为零

  • 插入直-圆-直曲线 - 创建一个两端有渐变但没有过渡的半径弧，“偏移”锁定为零

  • 插入三心圆曲线 - 创建一个两端有半径过渡的半径弧，结果是一条三心曲线，“偏移”锁定为零

  • 插入两心圆曲线 - 创建一个一端有半径过渡的半径弧，结果是一条两心曲线，“偏移”锁定为零

父主题: 插入直-缓-圆-缓-直曲线工具


创建剪切的地形模型

用于通过剪切先前创建的地形模型来创建新的地形模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮

“创建剪切的地形模型”可通过剪切先前创建的地形模型来创建新的地形模型。请注意，将创建原始地形的副本。原始地形中的数据不会发生更改。

剪切元素必须在开始剪切之前绘制，并且可以是任何类型的闭合区域。

设置 | 描述
参考地形模型 | 要剪切的地形模型或网格。
剪切方法 | 内部 - 在剪切模型的副本中放置空区。 外部 - 对剪切元素之外的任何地形数据进行剪切。
水平偏移 | “水平偏移”影响剪切限制。如果关闭“水平偏移”，则将把闭合多边形用作剪切限制。如果打开“水平偏移”，则将把该多边形移出，这类似于根据偏移值执行平行复制。
竖向偏移 | “竖向偏移”将生成的地形模型上移（正值）或下移（负值）偏移距离（用主单位表示）。它不会更改剪切限制。
剪切限制 | 下面的第一个图形描述了原始 TM。在该模型中间放置了一个闭合区域，用黑色粗线表示。 内部 - 将在生成的 TM 中创建空区。 外部 - 使用剪切多边形（生成的 TM 的边界）剪切超出剪切限制的所有数据。

工作流

  1. 放置一个 Microstation 闭合区域用于剪切。
  2. 选择工具。
  3. 为要创建的剪切 TM 设置特征定义和名称。
  4. 按照危险警告提示操作。
提示 | 用户操作
定位参考地形模型元素 | 以图形方式选择要剪切的地形模型。
定位剪切元素 | 选择先前绘制的闭合区域。如果该区域未闭合，则会显示警告提示。
水平偏移 | 打开开关并输入偏移。如果不使用，请确保关闭开关。
竖向偏移 | 打开开关并输入偏移。如果不使用，请确保关闭开关。
剪切方法 | 选择“内部”或“外部”。

另请参阅

特征定义

父主题: 其他方法


地形导入

功能区：主页 > 模型导入/导出

地形导入

地形创建
父主题: 模型导入/导出


打开向导

此命令用于在向导创建过程中选择现有向导。

对话框选项

打开

打开所选向导。系统将使用所选向导的设置更新“文本导入向导”对话框。

取消

关闭对话框，且不执行任何操作。不会打开任何所选向导。

帮助

显示帮助。

父主题: 从 ASCII 文件创建地形模型


编辑过渡组件

根据需要连接点之后，该命令就会尝试根据开始和结束模板为过渡创建组件。窗口中将显示“最佳猜测”的结果。您可以根据需要修改过渡模板，方法是单击“取消”并返回到“编辑过渡段”对话框。

上图显示定义过渡的三维路面之间的过渡半途的横截面。您可以通过右键单击视图中的任意位置来添加新组件；然后，系统会提示您选择定义组件的点。选择点时，仅限于选择现有点，不能创建新点。可以通过右键单击并选择“删除”来删除组件。

父主题: 编辑过渡段


添加约束（完全约束）

完全约束模板中的一个点。完全约束的点包含 2 个约束，影响该点的偏移和高程。该点由视图中的 [image] 表示。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


等高线

可以使用“元素信息”启用等高线并为等高线间隔设置值，如下所示。选择顶层等高线选项以设置间隔和其他设置。选择各个项的主等高线和次等高线。如果未启用等高线显示，则节点的显示将暗显。

控件 | 描述
最大斜率选项 | 无： 忽略最大斜率：允许根据最大斜率值过滤等高线
最大斜率值 | 此十进制值表示要显示的最大斜率。在非常陡峭的区域防止非常密集的等高线
等高线标签精度 | 小数位数
光滑因子 | 1 – 10 表示平滑因子。10 表示最平滑。仅在下面选择平滑选项时才有效。
平滑 | 无： 样条：平滑因子 无重叠的样条：平滑且不太可能重叠。处理速度较慢。 顶点
主间距 | 主间隔之间主单位的距离
次间隔 | 次间隔之间主单位的距离
父主题: 显示可扩展地形模型


模板选项

为当前模板指定命名和步长选项。

命名选项

组件

种子名称 (Seed name)/来源样式 (From Style)

如果选中，则指示组件名称派生自创建组件时所指定的样式。

种子名称 (Seed Name)/指定 (Specify)

如果选中，则指示在字段中指定组件名称。

点

种子名称

支持您为当前模板中的点指定种子名称。因为点名称必须唯一，所以每次创建点时要为种子名称附加不同的编号。

应用词缀

如果打开，则指示应用词缀。

左前缀/后缀 (Left Prefix/Suffix)

指定当值处于 0.0 (绝对值) 左侧时应向点或组件添加的前缀/后缀。

右前缀/后缀 (Right Prefix/Suffix)

指定当值处于 0.0 (绝对值) 右侧时应向点或组件添加的前缀/后缀。

步长选项

为组件和点指定精度步长输入。此外，还可以从动态设置对话框中访问这些值。

X 步长

为与动态原点的 X 轴距离指定步长增量。如果此值不为零，则光标将从动态原点移动到测量得出的指定值的平面增量值。

Y 步长

为与动态原点的 Y 轴距离指定步长增量。如果此值不为零，则光标将从动态原点移动到测量得出的指定值的垂直增量值。

斜率

为相对于动态原点的坡度指定步长增量。如果此值不为 0，则光标会移动到动态原点的坡度增量。仅当动态设置处于平面/坡度模式下时，坡度才适用。

首选项

打开“首选项”对话框。

父主题: 工具命令（创建模板）


添加约束（纵面最大值）

使用此命令部分约束模板中的一个点。纵面最大值约束可确保子点具有两个父点并与最高的父点保持给定的垂直距离。有关约束的详细信息，请参阅创建模板概述主题。

父主题: 添加约束


工作流: 放置点

  1. 选择“点”工具。

  2. 在工具设置中输入“特征定义”和“名称”。

  3. 如果希望点具有纵面值，请选中“三维点”框并在提供的字段中输入高程。

  4. 在危险警告提示“输入数据点”之后，将光标依次移动到所需位置和数据点以放置该点。

父主题: 插入点


移动点

在点未完全受约束的情况下移动点。一个例外情况是如果点包含到曲面的投影或到设计约束的投影，则点仍会移动，尽管其看起来已完全约束。

父主题: 创建模板


占用、后视和观测

在“数据树”中选择相应分支时，详情面板将显示占用点、后视点信息或与观测关联的数据。

注释: 此处介绍的观测分支是指作为设置子分支而存在的分支。

顶级观测分支显示整个项目中的所有观测，而不考虑任何特定设置。

父主题: 显示细节


圆弧连接

用于根据控制一端相切的选定基准元素来构造弧。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 弧拆分按钮

“圆弧连接”根据控制一端相切的选定基准元素来构造弧。构造可能还包括可选缓和曲线过渡或弧过渡（双心圆曲线）。

选择用于确定相切的基准元素，然后定义弧参数以便用各种方法定义弧。

工作流

  1. 选择未与元素重合的弧终点。

  2. 定位与待构造的弧相切的元素。

  3. 输入与主元素的偏移距离。若要与主元素重合，可使用零偏移来构造。

  4. 输入半径值。

    请注意提示最右侧的箭头。许多工具中均显示此箭头，可用于在各种参数之间切换输入。在这种情况下，按键盘上的向左或向右箭头将切换提示参数，以便输入过渡参数。本例中为缓和曲线过渡，所用参数为缓和曲线长度。有关各种缓和曲线以及可用的弧过渡选项，请参阅“偏移过渡”。

    放置新弧时，请注意半径和弧长的动态反馈。

  5. 截断基准元素，仅在与基准元素的偏移为零时可用。

SHIFT 键的用途

在命令操作期间，可以使用 SHIFT 键在顺时针和逆时针解决方案之间切换。

曲线过渡

基于此工具进行的曲线构造可以包括选定参考元素与曲线之间的过渡。可用的过渡选项有：

  • 无 - 无过渡（仅构造中心简单曲线）

  • 缓和曲线。一条缓和曲线（创建曲线构造）

此处列出了可用于创建缓和曲线的值。

  • 双缓和曲线。使用此工具可以创建两条缓和曲线；第一条缓和曲线的过渡与参考元素在同一侧，从参考元素半径开始，过渡到无穷远。第二条缓和曲线从无穷远过渡到新曲线的半径，在相对一侧。尽管此弯曲参考元素为最常见的用例，但可以在任何所需的位置使用双缓和曲线。

注释: 最常使用的情况是参考元素本身是曲线，并在相对一侧。

  • 曲线 - 构造双中心曲线（过渡曲线由半径和长度定义）

  • 弧比率 - 构造双中心曲线（过渡长度由中心曲线的比率定义）

对话框自定义

右键单击对话框可针对特定任务或用户首选项自定义对话框。

操控器

使用“功率选择器”选择已创建的直线可显示编辑操控器。

在无任何捕捉且无任何土木精确绘图的情况下放置直线时，屏幕上将显示操控器，如上所示。这些操控器可用于编辑直线，如下所述：

  • 过渡参数文本操控器

  • 偏移文本操控器和拖曳图柄

  • 半径文本操控器

  • 终点方向文本操控器和拖曳图柄

  • 弧长拖曳图柄

属性

规则数据也可在弧的属性中进行访问。选择弧并转到“元素”>“信息”，或者打开“项”浏览器。您可以编辑属性窗格中的大部分数据来更改弧定义。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“圆弧连接”图标，然后从元素工具中选择“显示/隐藏弧 (Show/Hide Arc)”以访问下列选项：

  • 简单圆弧切向连接 - 创建到另一元素无任何过渡的简单半径弧，并且偏移锁定为零

  • 双圆弧曲线连接 - 创建到另一元素为弧过渡的弧，并且偏移锁定为零

  • 圆+缓和曲线连接 - 创建到另一元素为缓和曲线过渡的弧，并且偏移锁定为零

  • 圆+双缓和曲线连接 - 创建到另一元素为反向缓和曲线过渡的弧（仅在“到”元素是反手侧曲线时适用），并且偏移锁定为零

父主题: 圆弧连接工具


文本导入向导 - 第 3 步（分隔符）

本部分介绍了“文本导入向导 - 第 3 步”对话框中的参数。有两个名为“文本导入向导 - 第 3 步”的对话框。本主题讨论在“文本导入向导 - 第 2 步”对话框中选定“分隔符”后显示的对话框。

有关详细信息，请参考文本导入向导。

对话框选项

分隔符 |
选项卡 | 将制表符识别为要导入的文件中的分隔符。
分号 | 将分号 (;) 识别为要导入的文件中的分隔符。
空格 | 将空格识别为要导入的文件中的分隔符。
逗号 | 将逗号 (,) 识别为要导入的文件中的分隔符。
其他 | 允许将任何单个字符指定为要导入的文件中的已识别分隔符。
忽略连续分隔符 | 忽略要导入的文件中连续出现的任何已识别分隔符。例如，如果已将空格定义为分隔符，则向导将忽略要导入的文件中的连续空格，使两个或多个连续空格被视为单个空格。选择“忽略连续分隔符”之后，向导实质上会将连续分隔符视为单个分隔符。
文本限定符 | 忽略在定义为“文本限定符”的字符对内出现的分隔符。例如，假设您已将空格定义为分隔符。字符串 |Point Number 1| 将作为三个值 |Point、Number 和 1| 导入（空格识别为分隔符），如果竖线字符 (|) 被定义为文本限定符，则该字符串将作为 Point Number 1 导入。 “文本导入向导”应用“文本限定符”选项（如果已定义），然后选择“开始行列”选项，然后选择“开始字段列”选项。
开始行列 | 指定向导应从（文件中每行）哪一个字符开始读取数据。例如，如果指定值 6，则向导将从该行的第六个字符开始查询数据。在此示例中，将忽略该行的前五个字符。 “文本导入向导”应用“文本限定符”选项（如果已定义），然后选择“开始行列”选项，然后选择“开始字段列”选项。
开始字段列 | 指定向导应从（文件中每行中每个字段）哪一个字符开始读取数据。例如，如果指定值 4，则向导将从每行中每个字段的第四个字符开始查询数据。在此示例中，将忽略每行中每个字段的前三个字符。 此上下文中的字段是指由分隔符指定的单个值。单行数据包含多个字段。 “文本导入向导”应用“文本限定符”选项（如果已定义），然后选择“开始行列”选项，然后选择“开始字段列”选项。
(文件名) | 显示正在导入的文件的名称。
(文件预览) | 显示正在导入的文件的预览。预览将会更新，以反映您定义的当前过滤器设置。 此对话框上的预览最多显示 1000 行。但是，1000 行限制仅适用于预览，而不适用于实际导入。整个文件将在使用“文本导入向导”导入文件时进行处理。 如果要导入非统一文件（请参考“文本导入向导 - 第 1 步”对话框中的“记录格式”选项），预览仅显示满足“文本导入向导 - 非统一记录信息”对话框中“包含 (Include)”设置的行。 如果要导入统一文件（请参考“记录格式”选项），预览将从“文本导入向导 - 第 1 步”对话框中“自此行开始导入 (Start Import at Row)”选项中指定的行开始，显示文件的 1000 个连续行。
父主题: 从 ASCII 文件创建地形模型


覆盖光栅

如果光栅图像连接到 STM 的区域中，则可以将其覆盖到 STM 上。从“STM 管理器 (STM Manager)”中，选择“编辑”–>“设置覆盖…”

左侧显示连接的光栅图像。右侧显示可用的 STM 文件。从左侧选择应覆盖到右侧 STM 文件的光栅。移动图像会将其从 Raster Manager 中卸载。复制图像意味着它将覆盖到选定的 STM 上，但仍可在 Raster Manager 中使用。

注释: 注意：如果光栅没有显示“光栅覆盖”对话框的“光栅连接”面板，请检查以下内容：

  1. 光栅连接与顶视图平行

  2. 光栅连接与 STM 重叠

  3. 光栅连接在激活视图中已显示

可以使用左侧面板顶部的图标连接光栅。此图标的行为与选择“文件”->“连接” ->“Raster Manager 中的光栅 (Raster in Raster Manager)”相同。

要查看实际覆盖到地形上的图像，请务必使用下面显示的开关启用“地形覆盖 (Terrain Draping)”。

为了正确显示 STM，在“显示样式”对话框中，选择平滑显示样式，然后选择“着色”渲染模式显示，但请确保关闭“显示阴影”选项，否则 STM 无法正确显示。

STM_DEFAULT_MINIMUM_PIXEL_SIZE_FOR_DRAPING
STM_RASTER_DRAPING_TRANSPARENCY
父主题: 显示可扩展地形模型


文本导入向导 - 第 4 步

本部分介绍了“文本导入向导 - 第 4 步”对话框中的参数。

“文本导入向导 - 第 4 步”对话框用于定义要导入的文件中每列数据的内容。通过选择列标题、然后从“列数据格式 (Column Data Format)”参数指定值或右键单击列标题并从菜单中进行选择，您可以定义列内容。

您不必定义每个列。应忽略的列（因为它们不包含相关数据）可以保持标记为“跳过”。以下列表为各种类型的数据定义了至少所需定义的列：

  • 表面 - 纵坐标和横坐标；
  • 平面路线 - 纵坐标和横坐标；
  • 平面事件点 - 纵坐标和横坐标，或者桩号；
  • 平面回归点 - 纵坐标和横坐标，或者桩号；
  • 纵面路线 - 纵坐标和横坐标，或者桩号和高程；
  • 纵面事件点 - 纵坐标和横坐标，或者桩号；
  • 坐标几何点 - 纵坐标和横坐标，或者桩号。

最多不超过 15 列，并且不存在两列可能具有相同的标题（标记为“跳过”的列除外）。

有关详细信息，请参考文本导入向导。

“选项卡”选项

列数据格式

定义数据列的内容。列数据格式的选择取决于要导入的文件类型。文件类型在“文本导入向导”对话框中定义，该对话框在选择“文件”>“导入”>“文本导入向导”命令时将会显示。

“表面”选项

特征样式 | 用于指定过滤器的特征样式。
点类型 | 用于指定过滤器的点类型。
钢笔顺序 | 用于指定过滤器的钢笔顺序。
从三角网中排除 | 从三角网中排除每个单独的过滤器。为此，请先关闭“导入时指定 (Specify at Import)”开关。
导入时指定 | 如果为任何过滤器启用此选项，则该过滤器将使用每次导入时“表面选项 (Surface Options)”对话框中提供的任何参数。如果关闭该开关，则每个过滤器必须在创建时指定相应的参数。
(文件名) | 显示正在导入的文件的名称。
(文件预览) | 显示正在导入的文件的预览。预览将会更新，以反映您定义的当前过滤器设置。 此对话框上的预览最多显示 1000 行。但是，1000 行限制仅适用于预览，而不适用于实际导入。整个文件将在使用“文本导入向导”导入文件时进行处理。
打开 | 显示“打开向导 (Open Wizard)”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。
保存 | 保存打开的向导。如果为先前未保存为 XIN 文件的向导选择“保存”按钮，则会遵循“另存为”工作流。
另存为 | 显示“名称向导 (Name Wizard)”对话框，用于提供名称和描述，并保存向导，以便您可以使用它来导入其他类似格式的文件。
上一步 | 移动到向导中的上一步。
下一个 | 移动到向导中的下一步。
完成 | 使用当前定义的向导导入文件。如果选择多个文件进行导入，则使用此向导导入所有选定文件。打开的向导不会保存到 XIN 文件中。
取消 | 关闭对话框，且不执行任何操作。您所做的选择和键入命令均不会保存。
帮助 | 显示帮助。
父主题: 从 ASCII 文件创建地形模型


按元素垂直反向点

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“垂直”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    垂直

    垂直模式

    按元素

    选择元素

    在将投影的点上选择先前绘制的 MicroStation 或土木元素。

    输入终点垂直点（可在下方提示字段查看，而不是警告提示）

    点击确认或输入第二个点测量点名称，以完成基线。

    输入要投影的点

    点击确认或输入每个要投影回至基准元素的点的测量点名称。继续选择数据点直到完成。任何超出基准元素限制绘制的点均不会投影，仅会连接到最近的基线端点。

    重置

    如果已打开选项，结束工具并打开土木工程报告浏览器。

父主题: 反转点


文本导入向导 - 第 3 步（固定宽度）

本部分介绍了“文本导入向导 - 第 3 步”对话框中的参数。有两个名为“文本导入向导 - 第 3 步”的对话框。本主题讨论在“文本导入向导 - 第 2 步”对话框中选定“固定宽度”后显示的对话框。

此对话框可用于设置字段宽度（分栏符）。要创建分栏符，在所需位置进行单击。要删除分栏符，单击现有行。

有关详细信息，请参考文本导入向导。

对话框选项

文件名 | 显示正在导入的文件的名称。
文件预览 | 显示正在导入的文件的预览，并用于指定分栏符在数据文件中的位置。

通过单击预览窗格来设置字段宽度，以指示分栏符的位置。当您在预览中的各个位置单击时，将显示垂直线，它表示分栏符。要移除分栏符，请单击表示分栏符的垂直线。单击垂直线时，它们会消失。

预览窗格顶部的轴网表示文件中的字符数。文件预览使用单倍间距字体。

此对话框上的预览最多显示 9 行。但是，9 行限制仅适用于预览，而不适用于实际导入。整个文件将在使用“文本导入向导”导入文件时进行处理。

如果要导入非统一文件（请参考“文本导入向导 - 第 1 步”对话框中的“记录格式”选项），预览仅显示满足“文本导入向导 - 非统一记录信息”对话框中“包含 (Include)”设置的行。

如果要导入统一文件（请参考“记录格式”选项），预览将从“文本导入向导 - 第 1 步”对话框中“自此行开始导入 (Start Import at Row)”选项中指定的行开始，显示文件的 9 个连续行。

父主题: 从 ASCII 文件创建地形模型


提取光栅网格

STM 的一部分可以提取到光栅网格格式。此格式可以通过“光栅管理器”工具的“连接光栅网格”来显示。

从 STM 对话框的“编辑”菜单中，选择“提取光栅网格”。

设置 | 描述
面积类型 | 定义区域选择方法：“块”、“定向块”、“元素”、“形状”、“视图”
使用围栅 | 如果围栅激活，则可以使用它来定义区域。
使用所有 STM | 在处理期间使用所有连接的可扩展地形模型。
像素大小 | 输出光栅文件的像素大小。该测量工具可用于直接从视图中选择像素大小。

根据区域类型选择点以定义要提取的区域。必须在顶视图中选择这些点。任何围栅或形状均应位于顶视图的平面内。

系统将计算所选点数，并在区域太大时显示一条消息。在这种情况下，请选择一个较小的区域。

将显示一个带有光栅网格文件选项的对话框。

设置 | 描述
文件类型 | 定义输出文件格式。支持的类型为：Erdas IMG、GeoTIFF、Internet TIFF、Internet TIFF 64、TIF（标记图像文件）
颜色模式 | 颜色模式为：整数 - 16 位和浮点 - 32 位。
压缩模式 | 如果所选文件类型支持，则进行文件压缩。

选择“确定”将提示输入保存的文件位置。

键入: STM STMMANAGERDLG EXTRACTRASTERGRID

变量 STM_EXTRACTGRID_USESUBRES 控制所使用的 STM 的分辨率。设置为 0 时，使用全分辨率。设置为 1 时，使用子分辨率。

父主题: 可缩放的地形模型


更改放置点

向模板添加新的简单组件时，使用此命令更改动态拖曳的点。每次选择此命令时，拖曳点都将顺时针移动到简单组件上的下一个点。简单组件的放置点不是拖曳点。拖曳点是所拖曳模板的原点。

在添加过程中右键单击可访问此选项。放置组件后，此选项不再可用。

父主题: 添加（组件）命令


地形

参数 | 描述
体积选项 | 无 设计 现有 底土 路基
表面特征符号 | 用于绘制地形的线符定义。从激活文件或 DGNlibs 中的所有“地形特征线符”选择列表中选择。
父主题: 特征定义


添加新的空点组件

向模板添加空点。有关空点的详细信息，请参阅创建模板概述。

名称

指定新约束的名称。

样式

指定新组件的特征样式。此选项用于显示以及定义组件的材质。

父主题: 添加（组件）命令


添加新的简单组件

此命令可用于向模板添加简单组件。有关简单组件的详细信息，请参阅创建模板概述主题。

当前组件

名称

指定新约束的名称。

样式

指定新组件的特征样式。此选项用于显示以及定义组件的材质。有关详细信息，请参阅“样式管理器”主题。

斜率

指定组件的斜率。

厚度

指定组件的厚度。

宽度

指定组件的宽度。

测试

显示“测试末端条件”对话框。有关测试末端条件的详细信息，请参阅测试末端条件主题。

父主题: 添加（组件）命令


操控过渡段

过渡段具有可操控的编辑图柄。您可以动态移动开始和结束桩号，也可以在编辑字段中键入值。切记，如果移动与某个三维路面相邻的过渡段，则需逐个移动它们。例如，如果一个过渡段在 14+00 处结束，而某个三维路面在该处开始，且您要将桩点更改为 13+50，则需逐个移动过渡段和三维路面。

要操控过渡段，右键单击过渡段并从上下文相关菜单中选择“编辑过渡段”。

父主题: 创建过渡段


控制点

在“数据树”中选择“控制点”分支时，“显示面板”将显示指定用于控制查看或编辑的点。控制点是点列表的子集。

父主题: 显示细节


反射

向模板中添加新的简单组件时，使用此命令可在水平方向上反射该组件。

在添加过程中右键单击可访问此选项。放置组件后，此选项不再可用。

父主题: 添加（组件）命令


提示 3：外业簿可视化

考虑到 InRoads、GEOPAK 和 MX 的样式文件中包含的设置和选项不同，导入这些设置和选项来填充特征样式本质上会导致测量样式受损。测量样式中包含了 InRoads、GEOPAK 和 MX 样式文件之间的主要样式特征重叠，但每种格式中包含的部分更加细微的注释选项尚不受支持。

使用“测量”导入并操作字段数据，如果可视化与预期输出不够接近，可将完成的数据导出到相应 COGO 文件，并重新可视化本地产品中的数据。

此方法将提供新软件带来的所有优势以及您已适应的可视化效果。

父主题: 提示和技巧


报告

功能区：分析与报告

报告

  • 平面曲线数据表
  • 纵断面报表
  • 合规报表
  • 地图检查报表
  • 桩号偏移报表
  • 点特征桩号偏移高程报表
  • 桩号基准报表
  • 超高报表

从所选土木平面几何元素生成报告。

创建包括有关所选纵面路线的信息的 XML 报告数据文件。

根据一组闭合土木平面元素和参考元素生成报告。

根据绘制的数据（而不是软件存储的内部精度）生成包含精度信息的报告。

创建包含所选平面几何元素的桩号偏移数据的报告。

创建包含点名称、点特征、桩号以及从所选点到基线 MicroStation 或土木平面几何或测量元素的偏移的报告。

创建包含所选平面几何元素的桩号偏移数据的报告。

可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。

父主题: 模型分析与报表


模板库管理器

将模板从一个模板库移动（拖放）到另一个模板库。此命令还可用于将模板从 (*.ird) 路面设计复制到模板库。

要复制或移动模板或整个文件夹，请单击模板或文件夹并按住鼠标左键，然后将所选项拖动到其他库或同一库中的新位置。缺省操作过程为复制项。要移动项，请在按住 Shift 键的同时松开鼠标左键。按 Delete 键也可以删除所选文件夹或模板。

可用于/可用于

左侧面板中的树视图显示激活的模板库。右侧面板中的树视图显示您通过“浏览”按钮定位的另一个库或路面设计。

浏览

激活“打开”对话框。如果您查找并选择模板库，它会在右侧面板树视图中显示。

预览/预览

显示从左侧/右侧树视图中选择的模板的预览。

父主题: 工具命令（创建模板）


翻转点属性

添加坡度约束时定义翻转值当您在点属性对话框中选择翻转值按钮时，将激活此功能。

高侧偏差

指定当参考坡度矢量为正数时，从参考点到父点的矢量与从父点到受约束点的矢量之间的最大允许坡度偏差。

低侧偏差

指定当参考坡度矢量为负数时，从参考点到父点的矢量与从父点到受约束点的矢量之间的最大允许坡度偏差。

参考点

指定用于定义参考坡度的点。

父主题: 添加约束


末端条件异常替代

“替代”可用于替换或替代主结构左侧或右侧的三维路面末端条件。选中此选项后，必须编辑替代以设置新的末端条件。编辑替代异常时，将显示“创建模板”对话框，用于编辑末端条件。

以下示例显示了已执行编辑的横截面窗口。淡蓝色线表示异常起点桩号的原始末端条件解。

父主题: 创建末端条件异常


应用水平段翻转锁定

使用此对话框根据高低侧代数差为肩点创建控制线。此命令使用输入值创建控制线；然后，将控制线分配给指定点。

肩点 (Shoulder Point)

指定由翻转控制的肩点。从列表中选择该点或使用定位按钮标识该点。

控制线名称 (Control Line Name)

指定控制线的名称。

高侧

偏差

指定路肩坡度与路面坡度之间的绝对差。此值始终为正。

最大坡度

选中即表示使用路肩坡度的绝对上限。在字段中指定此值，包括正确的正负号。

“瞬时水平段向上滚动过渡 (Instantaneous Shoulder Rollup Transition)”选项

仅当指定的高侧偏差小于路肩和路面边缘之间的当前差值。例如，如果道路上的普通路拱为 2%，路肩为 4%，则差值为 2%。在开始旋转高侧路面时，任何小于 2% 的高侧偏差都将需要瞬间变化才能满足高侧偏差要求。

指定长度

确定路面开始超高之前路肩超高的过渡段长度。请指定大于 0 的值。

匹配过渡边坡

选中时，计算得出的水平段向上滚动过渡段的长度使路肩过渡段超高控制线的坡度与路面控制线的边缘坡度匹配。

低侧

偏差

指定路肩坡度与路面坡度之间的绝对差。此值始终为正。

最小边坡

选中即表示使用路肩坡度的绝对下限。在字段中指定此值，包括正确的正负号。

限制

桩号

选中即指定使用桩号范围限制。

起点

标识起点桩号。键入此值或使用定位按钮标识桩号。

停止

标识终点桩号。键入此值或使用定位按钮标识桩号。

应用

应用值、创建控制线并分配点控制。

父主题: 创建模板概述
相关概念
创建模板概述


检查点的连接性

使用此对话框验证与合并指定公差内的点。

公差

指定公差值。如果两点之间的距离在公差内，则使用“合并点”命令对其进行处理。

确定

接受公差并应用命令。对于在彼此的指定公差范围内找到的每一组点，屏幕将滚动，使这些点可见。“删除点”对话框位于相应点的下方，您有机会标识要删除的点。此时按 Esc 按钮可跳过这两个点的合并，如果需要，移动到下一组要处理的点。选择要删除的点时，该点的所有对应子项都将成为保留点的子项。

如果在彼此的指定公差范围内未找到点，则会显示以下消息框：未找到能够接受公差的两个点。

父主题: 创建模板


工作流

  1. 创建为 ASCII 数据格式配置的 TIW 文件。有关详细信息，请参考“地形建模”。

    必须将此 TIW 文件复制到存储 TIW 文件的文件夹中。通常（在 32 位操作系统上）该文件夹为：

    ...\Program Files\Common Files\Bentley Shared\Civil Platform\08.11.07\Data

  2. 激活土木测量。导航“项目浏览器”>“土木标准”选项卡，然后导航到“项目设置”>“测量”>“设置”。

  3. 右键单击并选择“属性”。

  4. 导航到“数据分析 (Data Parsing)”>“数据导入项”。

  5. 使用“浏览”按钮打开“数据导入项”对话框。

  6. 添加新项（使用“添加”按钮）。

  7. 填充字段：

    使用：True

    供应商：<使用供应商名称>

    标题: <此处使用自己的标题>

    过滤器: <此处使用自己的标题>，例如 *.txt

    FileTypeIn：中性

    可执行路径：<保留空白>

    可执行文件：survey.exe

    格式文件：<TIW 文件>，例如 *.tiw

  8. 接受新行。

父主题: 数据文件解析


任意线连接

构造到参考元素的一条偏斜线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 直线拆分按钮
  • 功能区：几何图形 > 纵断面 > 直线拆分按钮

工作流

  1. 单击“任意线连接”。将显示“任意线连接”对话框。对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  2. 标识要绘制的直线的起点位置。

  3. 定位要绘制到的元素，方法是通过点击确认（例如左键单击）选择该元素。

  4. 选择相对要绘制到的元素的偏移。可以键入或以图形方式选择此值。

  5. 在上一步中选择偏移后，需要选择斜交角。如果需要直角，只需在键入命令中输入 90 度即可。

  6. 指定起点距离。此距离沿相对偏移元素的偏斜测量。

  7. 选择调整选项：“无”或“后”。这将修剪要绘制到的元素。

使用 ALT 键

在操作该命令期间，可以使用键盘上的 ALT 键在备选解决方案之间切换。当斜交角被锁定时，按 ALT 键在两个备选项之间切换。

对话框自定义

右键单击对话框可针对特定任务或用户首选项自定义对话框。

操控器

操控器可用于：

  • 相对绘制到的基准元素的偏移

  • 倾斜角度

  • 起点距离

  • 拖曳图柄以动态调整起点和终点距离

属性

还可以在属性中访问“任意线连接”规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意线连接”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • 切线连接 - 在零度斜交角从另一个元素创建不带任何过渡段的直线，仅当“连接 (To element)”为曲线且偏移锁定在零时，此选项才适用

  • 缓和曲线连接 - 在零度斜交角从另一个元素创建具有缓和曲线过渡段的直线，仅当“连接 (To element)”为曲线且偏移锁定在零时，此选项才适用

  • “曲线连接”- 在零度斜交角从另一个元素创建具有弧过渡段的直线，仅当“连接 (To element)”为曲线且偏移锁定在零时，此选项才适用

  • 定角度连接 - 在用户定义的斜交角创建不带任何过渡段的直线，偏移锁定在零

父主题: 任意线连接工具


XYZ 文件

二进制 XYZ 文件是可识别的格式，无需特殊配置。但是，必须正确配置 ASCII XYZ 文件才能确保其正确导入。

父主题: 导入文件


应用特征名称覆盖

在一组点上设置“特征名称覆盖”属性。请谨慎使用此特征，以确保仅为在任何给定桩号与解决方案相互排斥的点分配相同的特征名称。可以使用测试末端条件对话框上的“验证特征 (Verify Features)”按钮测试特征名称覆盖。

特征名称覆盖

指定要应用于所选点的特征名称。

应用于点

列出要应用特征名称的可用点。已经具有覆盖的点显示为红色，覆盖名称也会显示。

父主题: 工具命令（创建模板）


点名称列表

管理缺省点名称列表中的条目。可以添加或修改点名称，也可以为点指定预定义样式。

名称

显示点名称。

样式

为点指定所选样式。

点

列出名称列表中的所有可用点。

添加

向名称列表添加新点。

删除

从列表中移除名称。可以选择多个要删除的点名称。

更改

可用于编辑点名称。

应用

保存对当前点名称的更改。

父主题: 创建模板


通行车道的工作流

最佳实践：要在多个区间内创建车道而无需分别创建它们，在选择工具之前创建区间的选择集。拖曳光标对角穿过所有所需的区间。您对角定义一个正方形，其中必须包含整个区间，以将其包括在选择集中。如果除区间之外，选择集中还包括元素，无需担心，在处理期间，系统会将它们过滤掉

  1. 选择“创建超高车道”工具。

  2. 按照危险警告提示操作。

提示 | 用户操作
定位第一个超高断面 | 选择第一个剖面。要在多个区间内创建车道而无需分别创建它们，创建区间的选择集。此操作可在选择工具之前完成，或者，通过拖曳光标对角穿过所有所需的区间，以交互的方式完成。
定位下一个超高剖面 - 或重置可完成 | 继续选择区间直到所有区间均高亮显示，然后重置以移至下一个提示。
输入车道名称 | 为每个车道命名，建议命名为 RT 或 LT 等，对于具有多个车道的项目，可附加 -1、2 等。请注意，如果您的项目有多个廊道，则这些名称应该唯一。
类型 | 选择“基本”。选中后，对话框/警告提示更改以反映该选择。
选择中心线侧 | 右侧或左侧。
内边缘偏移 | 输入相对于基线参考的偏移（以主单位计）。如果车道边缘为基线参考，输入 0。
宽度 | 输入车道的宽度（以主单位计）。
标准段横坡 | 输入用于计算的默认横坡（以百分比格式）。无需添加百分号。
名称 | 提示再次循环，因此您可以使用工具的单个选择集来定义多个车道。您可能需要稍微移动光标才能显示提示。无需定义其他车道时，重置以退出此工具。
父主题: 创建超高车道


命名设置

定义组件和点在通过组件创建最初添加到模板中时如何命名。您也可以定义在拖放操作期间如何修改点名称。点名称在模板内必须唯一，创建的任何已存在的名称均带有索引编号（1、2、3 等）。

组件

种子名称

从特征样式

如果选定，则指定组件名称最初为特征样式名称。

指定

如果选定，则指定组件名称以后续组件附加索引（1、2、3 等）的形式表示。

点

标识如何确定初始点名称。

种子名称

从模板名称

如果选定，则指示点名称为模板名称附加相应的前缀、后缀和索引。

从组件名称

如果选定，则指示点名称为组件名称附加相应的前缀、后缀和索引。

指定

指定点名称附加相应的前缀、后缀和索引。

应用词缀

如果打开，则指示应用词缀。

前缀/后缀（左/右）

指定值在 0.0 的左侧/右侧（即为绝对值）时应如何向点或组件中添加前缀和/或后缀。

父主题: 工具命令（创建模板）


STM_RASTER_DRAPING_TRANSPARENCY

可以通过定义以下变量来调整覆盖到 STM 上的光栅的透明度。

指定全局应用于所有连接的 STM 上覆盖的光栅数据的透明度。提供了从 0 到 100 的十进制值，其中 0 表示不透明，100 表示完全透明。默认值为 0。

父主题: 覆盖光栅


合并组件

删除两个重叠组件的所有共用点线段并将其合并到选定组件中。第二个组件会被删除。右键单击两个重叠部件的线段上方的某个位置可访问此命令。仅当 2 个或更多组件共用一条公共边时，该对话框才出现。

组件 1

用于标识第一个组件。

组件

用于选择第二个（合并）组件。

确定

接受所做的选择并关闭对话框。

取消

关闭对话框。所做的选择不会保存。

父主题: 创建模板


组件显示条件表达式

使用此对话框，可根据外部影响（例如，平面和纵面控件和末端条件）创建模板的变化。使用此功能，可应用一个能够根据特定桩号处发生的情况而加以变化的模板。利用此功能，您无需了条件何处发生了变化而导致可能需要不同的模板，且可允许模板内的规则做出更改。

此功能具有两个主要特征。首先，模板中已存储独立规则。支持以下类型：“水平”、“水平绝对值”、“垂直”、“垂直绝对值”、“坡度”、“坡度绝对值”和“已显示组件”。除最后一个类型外，其余所有类型均为两点之间使用 <、<=、=、>=、> 的条件表达式，可将两点之间的指定偏差与特定值进行比较。

例如：

Rule1 - 点 1 和点 2 之间的平面偏差小于 10。

“中线组件”的规则为“NOTRule1”

Median Component Rule1 = False

Median Component Rule1 = True

Rule2 - 从点 1 到点 2 的坡度大于 -10%

Rule3 - 从点 1 到点 2 的坡度小于 10%

在此示例中，规则通常具有 5 个组件。

  1. 名称

  2. 类型，例如，“绝对平面偏差 (Absolute Horizontal Difference)”

  3. 计算值（例如，Point1.x - Point2.x）

  4. 测试（<、<=、=、>、>=）

  5. 测试值（例如 10）

此功能的第二部分是组件中存储的条件表达式。条件表达式的示例为：Rule1 OR Rule2 AND Rule3.

中线组件的条件表达式

显示当前组件的条件显示表达式。表达式按从左到右的顺序进行求值，括号用于控制表达式的优先级。

计算当前表达式。如果出现错误，会显示一条消息，且错误的位置会高亮显示。

AND OR NOT ( )

将特定文本置于当前光标位置的编辑字段内，然后在末端添加一个空格。

“选定的规则”按钮

将选定的规则名称置于当前光标位置的“模板显示规则”内，后跟一个空格。

模板显示规则

列出当前模板显示规则。

添加规则

激活显示规则对话框。

编辑规则

如果选定单个规则，激活“编辑显示规则 (Edit Display Rule)”对话框。

删除规则

从列表中移除所选规则。

显示规则
父主题: 创建模板


添加约束（平面最大值）

部分约束模板中的一个点。平面最大值约束可确保子点具有两个父点并与最右边的父点保持给定的水平距离。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


点属性

指定与路面模板点关联的属性。

名称

显示点名称。下拉列表包含点名称列表中的项。

特征名称覆盖

显示将在表面中创建的与点对应的特征的名称。此字段为可选字段。如果此字段为空，将使用点名称作为特征名称。

注释: 虽然点名称对于模板必须唯一，但特征名称不必唯一。但是，如果给定桩号处解决方案的多个点上存在相同的特征名称，则会发生不良结果。

该选项主要用于末端条件组件，可以在模板末端条件发生变化时创建从一个桩号到下一个桩号的连接。例如，如果您希望所有表面接头点都属于一个特征，则将模板每侧的所有末端条件点的特征名称设置为相同的名称（即，为右侧所有挖方和填方终点指定特征名称 Tie_R，并为左侧所有挖方和填方终点指定特征名称 Tie_L）。

表面特征样式

显示点的特征样式。如果未指定任何样式，则采用该点所属的第一个组件。

备选表面

用于为点指定备选表面的名称。可以选择多个备选表面名称。从激活模板的可用表面列表中进行选择。

末端条件属性

用于在点属于末端条件时指定其他属性。

检查拦截

指定在求解末端条件时将检查前一个线段是否存在目标拦截。如果关闭此选项，则在检查拦截时将忽略该线段。

在拦截处放置点

指定当沿前一个线段发现拦截时，线段将被绘制到拦截中。否则，如果找到拦截，则线段将被绘制到其最大宽度中。

末端条件为无穷大

指定在尝试拦截目标时，最后一个段将被视为无限长度。此选项仅适用于末端条件的最后一个点。

不构造

指定将像末端条件中的所有其他点一样对点求解，但在绘制组件段时将跳过该点。

成员属于

指示包含该点的组件。

约束

用于检查/编辑点上的约束。

类型

指定约束类型：无、平面、纵面、坡度、矢量-偏移、对表面进行投影、对设计进行投影、平面最大值、平面最小值、纵面最大值、纵面最小值、角度距离。

父项 1

指定约束父点。

父项 2

显示第二个父点（仅在适用时显示）。适用于“平面最大值”、“纵面最大值”、“平面最小值”、“纵面最小值”约束以及“矢量偏移”约束。

翻转值（复选框和按钮）

仅针对坡度约束显示。这些值显示在“父项 2”字段中，因为翻转参考点是坡度约束的第二个父点。选中该复选框将激活“翻转值”按钮。选中该按钮将显示翻转点属性对话框。

值

指定平面类型约束的平面偏移。负值在左侧；正值在右侧。

对于“纵面”类型约束，这是竖向偏移。负值在下方；正值在上方。

对于“坡度”约束，该值是坡度。负值表示从左上到右下的坡度；正值表示从右下到左上的坡度。

对于“矢量偏移”约束，负值是从第一个父项到第二个父项的矢量左侧的偏移；正值是该矢量右侧的偏移。

对于“对表面进行投影”约束，该值是表面的名称（请注意，名称为空白将会转换为激活表面）。

对于“对设计进行投影”约束，该值是尝试投影到的最大距离。负值意味着向左投影；正值意味着向右投影。

对于变量约束，该值是两点之间的差值。

标签

显示约束的可选标签。对于带标签的约束，可以在设计处理期间更改其值。可以将相同的标签名称分配给多个约束和多个点。

对表面进行投影

用于限制点到表面的投影：任何方向（无限制）、“向下”（点仅从其原始位置向下投射）、“向左”（点仅从其原始位置向左投射）、“向右”（点仅从其原始位置向右投射）和“向上”（点仅从其原始位置向上投射）。当另一个约束为“纵面”时，将忽略“向上”和“向下”选项。同样，当另一个约束为“平面”时，将忽略“向左”和“向右”选项。

样式约束

选中时，如果在指定的平面范围内找到具有匹配样式的特征或线形，点的样式约束将替代点约束。激活可用于确定样式的“样式”字段。

样式约束（类型）

用于选择约束类型：“平面”、“纵面”或“两者”。

范围

指定从点的当前位置搜索到具有指定样式的任何特征或线形的最大平面距离。仅搜索激活表面和激活几何项目。负值会向左搜索；正值会向右搜索。值为零会导致搜索查找样式的最近实例。

应用

保存对当前点的更改。

父主题: 创建模板


表面模板

参数 | 描述
三维线性特征显示 | True - 显示三维线性特征。 False - 不显示三维线性特征。
父主题: 特征定义


显示规则

使用此对话框添加或编辑模板显示规则。
注释: 过渡中不应用显示规则。过渡仅查看创建过渡时过渡开始和结束时显示的内容，并使用该信息创建过渡。只有显示的组件才会包括在过渡中。

名称

显示规则名称。在编辑模式下，此字段处于只读状态。但是，可以从“创建模板”>“激活模板”选项卡中重命名规则。

注释: 显示规则不能包含左括号、右括号、“(”、“)”或规则名称中的以下任何短语：AND、OR、NOT。

描述

指定显示规则的描述。

类型

显示规则类型。

水平

指定点的 x 值之差 (pt1.x - pt2.x)。

水平绝对值

指定 ABS (pt1.x - pt2.x)。

垂直

指定 pt1.y - pt2.y。

竖向绝对值

指定 ABS (pt1.y - pt2.y)。

斜率

指定 pt1 到 pt2 的斜率。

坡度绝对值

指定 pt1 到 pt2 的斜率绝对值。

已显示组件

列出现有组件。如果显示指示的组件，则规则计算结果为 True。

Between（第一点）

指定条件测试的第一个点。不适用于“已显示组件”类型。

And（第二个点）

指定条件测试的第二个点。不适用于“已显示组件”类型。

（表达式）

指定条件表达式（<、<=、=、>=、>）。

（值字段）

指定计算表达式的值。

父主题: 组件显示条件表达式


创建增量地形模型

用于创建曲面和平面或两个曲面间的增量 TM，然后可以将其用于绘制等厚线轮廓。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮

“增量曲面 (Delta Surface)”工具创建曲面和平面或两个曲面间的增量 TM，然后可以将其用于绘制等厚线轮廓。增量 TM 中的 Z 值是两个指定模型或模型和曲面之差，而非实际高程。所有地形模型中的任何空区均会在增量模型中生成相应的空区（因为软件无法计算这些区域中的差值）。

注意：比较谨慎的做法是使用不同于原始 TM 的特征定义，这样可以相互区分开来，因为在顶视图中查看时，增量 TM 位于原始 TM 之上。

设置 | 描述
增量方法 | 地形模型到地形模型：指定两个文件。 地形模型到平面：指定一个文件和高程。
竖向偏移 1 | “竖向偏移 1”在处理增量命令之前，将第一地形模型上移（正值）或下移（负值）偏移距离（用主单位表示）。
竖向偏移 2 | “竖向偏移 2”在处理增量命令之前，将第二地形模型上移（正值）或下移（负值）偏移距离（用主单位表示）。
到平面 | 平面的高程，用主单位（英尺或米）指定。

工作流

  1. 选择工具。
  2. 设置增量地形模型的特征和名称。
  3. 按照危险警告提示操作：
提示 | 用户操作
选择增量方法。 | 以图形方式选择 TM。
定位第一地形模型。 | 以图形方式选择 TM。
定位第二地形模型或输入平面。 | 以图形方式选择 TM 或输入高程（以主单位表示）。

另请参阅

特征定义

父主题: 其他方法


廊道

特征定义

支持“名称”、“描述”和“名称种子”的公共字段。

处理剖面与临界剖面

选项 | 描述
三维路面间距乘数 | “三维路面间距乘数”与创建三维路面时指定的“路面间距”一起使用。其目的在于使设计人员能够使用更大的间距完成初步工作，并在细化设计时轻松缩短间距。为了确定用于处理的间距，路面间距需乘以三维路面间距乘数，且系统将使用该结果。
平面基点 | 设置为 True 时，激活水平路线的基点（PC、PT、CS 等）位置将用于计算点或三维路面间距位置。
纵面基点 | 设置为 True 时，激活纵面路线的基点（VPC、VPT、VPI 等）位置将用于计算点或三维路面间距位置。
外部控制点 | 设置为 True 时，将使用平面和/或纵面点控件的位置来计算点或三维路面间距位置。
增加平面密度 |
增加平面值密度 |
增加纵面密度 |
增加纵面值密度 |
启用剪切 |
启用通道布尔 |
选项 | 描述
平面基点 | 设置为 True 时，激活水平路线的基点（PC、PT、CS 等）位置将用于计算点或三维路面间距位置。
纵面基点 | 设置为 True 时，激活纵面路线的基点（VPC、VPT、VPI 等）位置将用于计算点或三维路面间距位置。
外部控制点 | 设置为 True 时，将使用平面和/或纵面点控件的位置来计算点或三维路面间距位置。
增加平曲线密度 | 设置为 True 时，将以更近的间距沿平曲线进行处理。此选项使用 CIVIL_DEFAULT_CURVE_STROKING 配置变量值，并根据与平曲线的弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置配置变量或“增加平曲线密度”设置为 False，则默认值为 0.01。
增加竖曲线密度 | 设置为 True 时，将以更近的间距沿竖曲线进行处理。此选项使用 CIVIL_DEFAULT_PROFILE_STROKING 设置，并根据与纵断面的和弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置配置变量或“增加竖曲线密度”设置为 False，则默认值为 0.1。

显示设置

操纵器设置

选项 | 描述
廊道 - 元素模板 | 元素模板用于在“创建廊道”工具中绘制廊道边界。作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
廊道手柄长度系数 | 长度系数是指手柄长度与廊道宽度的比率。因此，1.0 将使手柄与该点处的廊道宽度一样长。
廊道手柄间距 | 手柄间距可设置为如图所示的物理距离，或设置为零。如果设置为零，则每个廊道将获得 11 个手柄，无论其长度如何。任何非零值都用作沿纵面路线在主单位中测量的手柄之间的距离。
三维路面元素模板 | 用于在“创建三维路面”工具中绘制三维路面边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
三维路面手柄长度系数 |
单桩号点元素模板 |
单桩号点手柄长度系数 |
过渡段元素模板 | 用于在“创建过渡段”工具中绘制过渡边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
缓和手柄长度系数 |
父主题: 特征定义


添加边界

用于从地形中提取隐含或存储的边界，并能够编辑/规则化边界。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑 > 边界选项拆分按钮

“添加边界”选项用于从地形中提取隐含或存储的边界，并能够编辑/规则化边界。一旦边界作为边缘方法添加到地形，最大边长和裂片的其他方法都不可用，因为显式边界将使它们无效。通过使用“删除地形模型边界”工具，可以删除使用此新工具添加的边界。

“创建地形边界”包括 3 种方法

  1. 提取图形 - 将三角网的当前边界提取为可编辑的 3D 线串。
  2. 添加边界 - 将三角网的当前边界提取为地形元素中的显式边界（即锁定边界）
  3. 添加规则边界 - 将当前三角网的当前边界提取到可编辑的规则覆盖边界
父主题: 边界选项


删除边界

用于从无规则的地形模型中移除边界元素。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑 > 边界选项拆分按钮

“删除边界”工具从无规则的地形模型中移除边界元素。当边界在合并或操纵地形模型时或在创建合并的竣工地形模型时导致出现问题时，这非常有用。

使用该工具时只有一个选项，即创建切断线。如果原始边界元素具有有效高程且用户需要保留该数据以维持原始数据（即测量数据）的完整性，则使用切断线选项。如果没有高程或与地形模型无关，则不要作为切断线包括在内。

该工具只能在包含地形模型的活动文件中使用，因为需要写入访问权限来修改地形模型。如果使用刚才参考地形模型的文件，则该工具无法支行。

父主题: 边界选项


地形过滤器

“地形过滤器”类别显示地形过滤器管理器中定义的所有地形过滤器和过滤器组。这些数据可以位于当前文件或参考的文件中。过滤器组的弹出菜单包含地形过滤器管理器的快捷方式。

弹出菜单中的另一个选项是“属性”，具体取决于选定的项。例如，在过滤器组上选择“属性”将会显示组信息：

请注意，您可以在“属性”对话框中遍历层级结构。例如，选择“遮挡区域 (Obscure areas)”将显示“常规”和“过滤依据”信息。

可以通过右键单击弹出菜单在“属性”中进行编辑。

或者，单击多个字段右侧的向下箭头，也可以编辑选定字段。
父主题: OpenRoads Designer 标准


合并点

将重叠的多个点合并为一个点。仅当光标之下有多个点时，此命令才可用。系统会提示您选择要删除的点。重置以退出该命令。

父主题: 创建模板


创建廊道备选表面

用于根据廊道模型中的用户指定点沿任何给定路径创建地形模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮
  • 功能区：主页 > 模型导入/导出 > 地形导入拆分按钮

“创建廊道备选表面”工具可根据廊道模型中的用户指定点沿任何给定路径创建地形模型。例如，可能需要在铺装层结构中为骨料层底部获取一个表面。在此示例中，骨料路径底部的每个点已设置用于该特定表面的名称。务必对属于骨料表面路径的每个点使用相同的名称。指定了备选表面名称的所有点都将添加到备选表面。在“廊道模型”>“创建模板”>“编辑点”>“点属性”对话框中指定备选表面名称。选项包括键入新名称或从先前键入的名称中选择。

可以在激活模板的列表中查看指定模板的所有备选表面（和对应点）。

软件将扫描备选表面的模板点。如果找到一个这样的点，就会创建一个地形模型。它将所有断点、边界等复制到备选表面并从模板中的对应点分配模板点特征定义。生成的地形模型使用以廊道名称为前缀的备选表面名称命名。

项目浏览器

创建的备选表面在项目浏览器中的“地形模型”下列出。

右键单击任何地形模型以打开上下文相关菜单，选择“属性”以查看属性，并更改显示设置等。

元素信息

工作流: 创建备选表面

  1. 选择“创建备选表面”工具并按照警告提示选择廊道。处理进度条显示在屏幕底部。

  2. 打开项目管理器以查看创建的地形模型。使用“属性”查看特性或更改显示设置。还可以通过以图形方式选择任何地形模型，右键单击并选择“属性”（元素信息），对属性进行访问。

父主题: 其他方法


动画和渲染

STM 显示已针对交互式操作进行优化。但在录制动画项目时，生成的质量可能并非最佳，特别是在有许多切断线的情况下更是如此。要提高生成的动画质量，请按如下所示定义变量。交互式操作速度较慢，但渲染效果会大幅提高。

STM_Presentation_Quality=1

父主题: 显示可扩展地形模型


词汇表

上次更新时间： 2019 年 1 月 30 日
三维几何图形 | 三维几何图形在三维模型中创建，即：以数学方式组合平面几何与纵面几何，从而创建三维元素。这些三维几何图形元素进而定义设计模型。
三维模型 | 三维模型由系统自动创建和管理。用户可以与之交互，但通常不需要这样做。平面几何与纵面几何的数学组合存储在三维模型中。
三维点特征 | 可以在平面模型或三维模型中定义三维点。这些点存储在三维模型中，但可通过平面和三维方式表示。
激活对象 | 将创建的所有几何图形添加到其中的当前对象。
激活纵断面 | 在一个元素的多个可能纵断面中，激活纵断面用于设计。激活纵断面与平面几何相结合，可构建用于三维模型的三维元素。
激活地形模型 | 可将一个地形模型指定为“激活”。激活地形模型用于显示“现有地面”；换言之，打开时自动显示在纵断面模型中的模型。除非模板按名称定义了不同的目标，否则边坡也以激活地形模型为目标。
ALG | 原有（专有）InRoads 文件，包含特定几何项目的坐标几何信息、超高和路线信息。
对齐 | 专用于定义路面中心线或基线的线性特征。
应用线性模板 | 沿特征应用廊道模板，同时在一定程度上简化廊道创建。
应用表面模板 | 将廊道模板应用于地形模型，以便在地形模型下创建组件（如铺装层）。
弧定义 | 通常用于路面应用的曲线定义方法。半径 R 用于定义曲线，由公式 R=5729.58/D 定义，其中曲率 D 是由 100 英尺的弧正对的圆心角。在“设计文件设置”>“半径设置”下的“土木格式设置”中设置。另请参阅“弦定义”。
长宽比 | 对曲面的面朝向的角度测量。该值的格式取决于 DGN 文件中的角度设置。
基本几何图形 | 在许多情况下，几何元素将被修剪。原始（或基本）未修剪元素用于存储规则，因此始终都会保留。
边界（地形模型） | 用于约束地形模型的外部边界。边界外不创建三角形。此外，边界外的任何点数据都将被忽略。
切断线 | 由具有隐含线性关系的空间坐标集合组成的曲面特征。三角形边（在三角形化曲面中）不能越过切断线。
断裂空区 | 缺失或被模糊化的数据的闭合区域，该数据使用每个顶点的高程，而连续空区坐标之间的孔隙线插入为切断线。因此，断裂空区更改 TIN 曲面的斜率和高程。
基点 | 用于定义路线几何的点之一。方位基点包括 PC、PT、PI 和 CC（对于平面几何）；VPC、VPI 和 VPT（对于纵面几何）。
质心（三角形） | 地形模型中三角形的几何中心。
弦定义 | 通常用于铁路应用的曲线定义方法。半径 R 用于定义曲线，由公式 R=50/SIN(0.5*D) 定义，其中曲率 D 是由 100 英尺的弦正对的圆心角。另请参阅“弧定义”。
土木单元 | 用作预先配置常用的复杂几何布局的机制。这些布局通常存储在 DGNLIB 文件中，以便跨多个项目重用，但也可以将其直接存储在激活 DGN 文件中，以便在该位置使用，这在某些情况下非常有用。土木单元将包含平面几何，也可以包含纵面几何。
土木消息中心 | 用于显示 Civil 消息的连续更新日志，包括警告和错误。当错误和警告得到解决时，它们将从列表中移除。只要条件允许，就会添加新消息。大多数信息都与土木几何、超高和廊道模型有关。
土木模板 | 最常用于廊道模型、但也有其他应用的土木设计概念。土木模板定义建模对象的横截面形状。然后，此横截面沿三维几何图形元素拉伸，形成最终的模型。廊道模板可以创建或锁定道路边缘等特征。其结果是创建廊道。
剪切参考 | 剪切允许您在单个曲面中使用多个廊道时移除重叠区域。例如，在与交叉路面相交的廊道中，剪切将用于移除交集内的所有重叠特征。
复合地形模型 | 通过合并或附加两个或多个地形模型创建的地形模型。
上下文工具箱 | 选定元素时，将鼠标悬停在元素上方会在光标处弹出一个危险警告和上下文相关工具栏。此工具栏提供一些最常用的工具，可对所选元素类型进行操作。此工具栏中的第一个工具始终为“快速属性”。
等高线 | 表示相对于给定基准的等高点的线性符号。
等高线、等厚线 | 增量地形模型的等高线，将挖方量和填方量值表示为等高线，而非高程。正等高线表示填方量，负等高线为挖方量
等高线、计曲线 | 主要高程线，指示表面模型中的特定高程。计曲线通常以更粗的线宽或用不同的颜色绘制。高程文本标签通常与计曲线联合绘制。
等高线、间曲线 | 次要高程线，指示表面模型中的特定高程。绘制间曲线时通常不使用特殊的颜色或线宽索引，也没有高程文本标签。
廊道 | 用于路面建模的土木对象，由廊道模型工具自动管理。
横截面模型 | 定义了特殊桩号高程坐标并具有其他专用功能（如视图放大）的 DGN 模型（垂直于定义的平面几何提取）。将廊道用作基础时，横截面桩号与三维路面间距匹配。使用平面几何时，左/右偏移和间隔由用户定义。
曲线线型 | 描边是通过从数据的曲线段内插新快照向地形模型或廊道自动添加快照的过程。此距离用于在处理廊道和应用线性模板时沿曲线元素内插新快照。此值用作到沿弧生成的弦的最小垂直距离。沿弧绘制弦，垂直距离从每条弦的中间测量到弧。如果此距离大于“曲线采样弦长”，则使用较短的弦长重复该过程。一直重复该过程，直至达到曲线的端点。曲线越平坦，计算的点数就越少。曲线越陡峭，计算的点数就越多。
增量地形模型 | 包含从两个地形模型或一个地形模型和平面之间的高差派生的数据的曲面。
对话框 | 激活命令的工具设置框。该对话框显示命令的所有可用选项。对于大部分土木命令，在大多数情况下，可以隐藏和忽略该对话框，因为用户通过光标提示获得所有必要的指令和输入。配置命令自定义设置需要该对话框。
投影 | 将元素垂直投影到曲面的过程，使元素的高程由曲面定义。
垂投空区 | 缺少或被模糊化的数据的闭合区域，空区坐标不包含在三角网中。空区插在三角网后面。空区坐标和线覆盖在 TIN 曲面上。即使用户必须为垂投空区顶点提供高程，但用户高程也会更改为 TIN 曲面在 XY 垂投空区坐标位置的高程。
元素模板 | MicroStation 概念，允许为 MicroStation 元素和土木工程特征的线符和其他杂项显示预先配置定义。
末端条件 | 廊道模板的专用组件，提供连接到激活表面的信息。
末端条件异常 | 用于修改末端条件解的行为，而无需使用其他三维路面。添加末端条件异常时，必须对其进行编辑以更改其行为。
导出到本地 | 用于自动或手动将平面几何与纵面几何推送到本地产品的选项（InRoads - ALG、MX - PSS 和 GEOPAK - GPK）。
特征 | 特征是可以看到或定位的事物，它是设计的物理部分，代表现实世界的东西。特征的定义是其属性之一。在设计过程中的任意给定时间，特征都将使用平面几何、纵面几何、三维几何图形或组合来定义其位置。
特征定义 | 用于在创建特征时定义选项。这些是预先创建的项，通常跨多个项目使用，可定义线符、注释和数量。特征定义（通常）在平面模型中分配，接下来是纵断面/三维特征定义。
特征名称 | 每个特征均可有一个名称。
间隙 | 修剪特征时，在基本几何图形上不可见的部分。
GPK | 原有（专有）GEOPAK 数据库，包含坐标几何信息。
图形过滤器 | 用于开发地形模型，可在使用三维元素创建地形模型时自动存储图形元素的搜索设置。可以为每个特征（例如，点、切断线、空区）创建图形过滤器，然后可以将过滤器定义为图形过滤器组。
危险警告提示 | 在光标处浮动的动态危险警告提示中提供命令指令。
平面几何 | 定义设计水平布局的元素。即使 DGN 模型为三维，这些元素也是二维元素。平面几何可能是点、线、弧、缓和曲线、样条或复合元素中的任意组合。
间隔 | 修剪特征时，在基本几何图形上可见的部分。
岛 | 用于放置在空区中的闭合区域，例如，河流、湖泊等中间的岛屿。
关键桩号 | 添加到廊道以强制在特定位置进行处理的其他桩号。
LIDAR | （激光雷达）是一种光学扫描技术，它通过扫描地面等物理特征来生成三维模型。
线性特征 | 在平面模型中，由线、弧、缓和曲线、样条或其组合构成。在纵断面模型中，由线、抛物线、样条或其组合构成。
线性线型 | 描边是通过从数据的直线段内插新快照向地形模型或廊道自动添加快照的过程。线性采样间距沿元素测量。只要顶点之间的距离大于线性采样间距值（以主单位表示），就会添加内插顶点。
操控器 | 屏幕危险警告编辑界面。操纵器中仅显示最常用的属性。操纵器有两种类型：图形和文本。
调整竖向覆盖关系 | 在廊道模型中，用于开发纵面几何（基于压碾和重叠参数）的工具，应用于廊道。
参数化约束 | 用于为指定的桩号范围设置约束值替代。
平面模型 | 常用的 DGN 模型，用于布置平面几何。最佳实践将规定这是二维 DGN 模型，但可以使用三维 DGN 模型。可在其中保存几何布局和廊道定义。几何布局不仅仅是路线，还有边缘、停车场、分段、人行道等
点特征 | 由 X, Y（Z 为可选）位置定义。点不一定是特征。它可以通过精确绘图、土木精确绘图、捕捉或数据点定义为非特征点。非特征点用于控制线性特征的结构。
点云 | 三维坐标系中的一组顶点，这些顶点由 X、Y 和 Z 坐标定义。点云通常通过三维扫描仪创建。这些设备可测量对象曲面上的大量点并将点云输出为数据文件。点云代表已扫描或数字化的对象的可见曲面。
点控制 | 用于修改模板中点的行为。这些控制优先于（替代）点上的现有约束。
项目浏览器 | MicroStation 的界面，用于浏览 DGN 文件中的元素。由土木工程扩展以适应专门的土木工程需求。
PSS 文件 | MX 文件（平面样式集），提供 MX 线串特征的图形表示。
参考元素 | 某些几何图形的规则从另一个元素进行计算。这里所说的另一个元素是参考元素。
次要路线 | 用于修改横截面的处理方向。默认情况下，在任何给定桩号，创建的横截面与主路线/特征正交。如果存在次要路线，则位于次要路线之外的那部分横截面将与次要路线（而非主路线）正交。
高程标注 | 一组 X、Y、Z 坐标，表示地形模型曲面上的点。正则点之间不存在隐含关系。
超高车道 | 由用于过渡段计算和旋转位置限制的超高工具定义的闭合区域。
超高断面 | 沿平面几何元素的区域，将计算其超高。
目标别名 | 用于在使用多个曲面时创建所需的结果，而无需从模板库中编辑模板。还可以使用目标别名，这样一个廊道便可锁定另一个廊道的解。
三维路面 | 沿廊道的区域（通常由桩号限制定义），将对其应用特定模板。
模板库 | 存储模板定义的文件，通常带有 ITL 文件扩展名。
模板过渡 | 过渡指示符出现在不同名称的模板之间的廊道中。
地形模型 | 由点、切断线、空区、孔、等高线定义的三维 DGN 元素，用于对地球表面建模。
工具提示 | 将光标悬停在元素或控制柄上方时，将显示工具提示，提供说明性信息。
跟踪边坡 | 上游 所示路径遵循从经过地形模型的点到地形模型的低点或边缘的最陡上升。 下游 所示路径遵循从经过地形模型的用户定义点到地形模型的低点或边缘的最陡下降。
纵面路线 | 纵断面模型中专用于定义路线高程的线性特征。
纵面几何 | 定义相应平面几何元素的垂直布局的元素。这些纵断面元素为二维，存储在纵断面模型中。
排空 | 标出缺失数据区域或模糊区域的闭合形状。不使用空区范围中的点或打断数据，也不会在空区范围内创建三角形。空区坐标包含在三角网中，连续空区坐标之间的孔隙线作为投影线插入表面中。因此，它们不会更改表面的坡度或高程。
流域 | 由地形模型中的低点或沿地形模型边缘的低边缘点定义，这是所有水都会排到低点的闭合区域。
XIN 文件 | 包含特征定义、关联样式、注释和其他设置的 InRoads 文件。

三维几何图形 | 三维几何图形在三维模型中创建，即：以数学方式组合平面几何与纵面几何，从而创建三维元素。这些三维几何图形元素进而定义设计模型。
三维模型 | 三维模型由系统自动创建和管理。用户可以与之交互，但通常不需要这样做。平面几何与纵面几何的数学组合存储在三维模型中。
三维点特征 | 可以在平面模型或三维模型中定义三维点。这些点存储在三维模型中，但可通过平面和三维方式表示。
激活对象 | 将创建的所有几何图形添加到其中的当前对象。
激活纵断面 | 在一个元素的多个可能纵断面中，激活纵断面用于设计。激活纵断面与平面几何相结合，可构建用于三维模型的三维元素。
激活地形模型 | 可将一个地形模型指定为“激活”。激活地形模型用于显示“现有地面”；换言之，打开时自动显示在纵断面模型中的模型。除非模板按名称定义了不同的目标，否则边坡也以激活地形模型为目标。
ALG | 原有（专有）InRoads 文件，包含特定几何项目的坐标几何信息、超高和路线信息。
对齐 | 专用于定义路面中心线或基线的线性特征。
应用线性模板 | 沿特征应用廊道模板，同时在一定程度上简化廊道创建。
应用表面模板 | 将廊道模板应用于地形模型，以便在地形模型下创建组件（如铺装层）。
弧定义 | 通常用于路面应用的曲线定义方法。半径 R 用于定义曲线，由公式 R=5729.58/D 定义，其中曲率 D 是由 100 英尺的弧正对的圆心角。在“设计文件设置”>“半径设置”下的“土木格式设置”中设置。另请参阅“弦定义”。
长宽比 | 对曲面的面朝向的角度测量。该值的格式取决于 DGN 文件中的角度设置。
基本几何图形 | 在许多情况下，几何元素将被修剪。原始（或基本）未修剪元素用于存储规则，因此始终都会保留。
边界（地形模型） | 用于约束地形模型的外部边界。边界外不创建三角形。此外，边界外的任何点数据都将被忽略。
切断线 | 由具有隐含线性关系的空间坐标集合组成的曲面特征。三角形边（在三角形化曲面中）不能越过切断线。
断裂空区 | 缺失或被模糊化的数据的闭合区域，该数据使用每个顶点的高程，而连续空区坐标之间的孔隙线插入为切断线。因此，断裂空区更改 TIN 曲面的斜率和高程。
基点 | 用于定义路线几何的点之一。方位基点包括 PC、PT、PI 和 CC（对于平面几何）；VPC、VPI 和 VPT（对于纵面几何）。
质心（三角形） | 地形模型中三角形的几何中心。
弦定义 | 通常用于铁路应用的曲线定义方法。半径 R 用于定义曲线，由公式 R=50/SIN(0.5*D) 定义，其中曲率 D 是由 100 英尺的弦正对的圆心角。另请参阅“弧定义”。
土木单元 | 用作预先配置常用的复杂几何布局的机制。这些布局通常存储在 DGNLIB 文件中，以便跨多个项目重用，但也可以将其直接存储在激活 DGN 文件中，以便在该位置使用，这在某些情况下非常有用。土木单元将包含平面几何，也可以包含纵面几何。
土木消息中心 | 用于显示 Civil 消息的连续更新日志，包括警告和错误。当错误和警告得到解决时，它们将从列表中移除。只要条件允许，就会添加新消息。大多数信息都与土木几何、超高和廊道模型有关。
土木模板 | 最常用于廊道模型、但也有其他应用的土木设计概念。土木模板定义建模对象的横截面形状。然后，此横截面沿三维几何图形元素拉伸，形成最终的模型。廊道模板可以创建或锁定道路边缘等特征。其结果是创建廊道。
剪切参考 | 剪切允许您在单个曲面中使用多个廊道时移除重叠区域。例如，在与交叉路面相交的廊道中，剪切将用于移除交集内的所有重叠特征。
复合地形模型 | 通过合并或附加两个或多个地形模型创建的地形模型。
上下文工具箱 | 选定元素时，将鼠标悬停在元素上方会在光标处弹出一个危险警告和上下文相关工具栏。此工具栏提供一些最常用的工具，可对所选元素类型进行操作。此工具栏中的第一个工具始终为“快速属性”。
等高线 | 表示相对于给定基准的等高点的线性符号。
等高线、等厚线 | 增量地形模型的等高线，将挖方量和填方量值表示为等高线，而非高程。正等高线表示填方量，负等高线为挖方量
等高线、计曲线 | 主要高程线，指示表面模型中的特定高程。计曲线通常以更粗的线宽或用不同的颜色绘制。高程文本标签通常与计曲线联合绘制。
等高线、间曲线 | 次要高程线，指示表面模型中的特定高程。绘制间曲线时通常不使用特殊的颜色或线宽索引，也没有高程文本标签。
廊道 | 用于路面建模的土木对象，由廊道模型工具自动管理。
横截面模型 | 定义了特殊桩号高程坐标并具有其他专用功能（如视图放大）的 DGN 模型（垂直于定义的平面几何提取）。将廊道用作基础时，横截面桩号与三维路面间距匹配。使用平面几何时，左/右偏移和间隔由用户定义。
曲线线型 | 描边是通过从数据的曲线段内插新快照向地形模型或廊道自动添加快照的过程。此距离用于在处理廊道和应用线性模板时沿曲线元素内插新快照。此值用作到沿弧生成的弦的最小垂直距离。沿弧绘制弦，垂直距离从每条弦的中间测量到弧。如果此距离大于“曲线采样弦长”，则使用较短的弦长重复该过程。一直重复该过程，直至达到曲线的端点。曲线越平坦，计算的点数就越少。曲线越陡峭，计算的点数就越多。
DDB 文件 | 包含特征定义、关联线符和注释设置的 GEOPAK 文件（设计数据库）。
增量地形模型 | 包含从两个地形模型或一个地形模型和平面之间的高差派生的数据的曲面。
对话框 | 激活命令的工具设置框。该对话框显示命令的所有可用选项。对于大部分土木命令，在大多数情况下，可以隐藏和忽略该对话框，因为用户通过光标提示获得所有必要的指令和输入。配置命令自定义设置需要该对话框。
投影 | 将元素垂直投影到曲面的过程，使元素的高程由曲面定义。
垂投空区 | 缺少或被模糊化的数据的闭合区域，空区坐标不包含在三角网中。空区插在三角网后面。空区坐标和线覆盖在 TIN 曲面上。即使用户必须为垂投空区顶点提供高程，但用户高程也会更改为 TIN 曲面在 XY 垂投空区坐标位置的高程。
元素模板 | MicroStation 概念，允许为 MicroStation 元素和土木工程特征的线符和其他杂项显示预先配置定义。
末端条件 | 廊道模板的专用组件，提供连接到激活表面的信息。
末端条件异常 | 用于修改末端条件解的行为，而无需使用其他三维路面。添加末端条件异常时，必须对其进行编辑以更改其行为。
导出到本地 | 用于自动或手动将平面几何与纵面几何推送到本地产品的选项（InRoads - ALG、MX - PSS 和 GEOPAK - GPK）。
特征 | 特征是可以看到或定位的事物，它是设计的物理部分，代表现实世界的东西。特征的定义是其属性之一。在设计过程中的任意给定时间，特征都将使用平面几何、纵面几何、三维几何图形或组合来定义其位置。
特征定义 | 用于在创建特征时定义选项。这些是预先创建的项，通常跨多个项目使用，可定义线符、注释和数量。特征定义（通常）在平面模型中分配，接下来是纵断面/三维特征定义。
特征名称 | 每个特征均可有一个名称。
间隙 | 修剪特征时，在基本几何图形上不可见的部分。
GPK | 原有（专有）GEOPAK 数据库，包含坐标几何信息。
图形过滤器 | 用于开发地形模型，可在使用三维元素创建地形模型时自动存储图形元素的搜索设置。可以为每个特征（例如，点、切断线、空区）创建图形过滤器，然后可以将过滤器定义为图形过滤器组。
危险警告提示 | 在光标处浮动的动态危险警告提示中提供命令指令。
平面几何 | 定义设计水平布局的元素。即使 DGN 模型为三维，这些元素也是二维元素。平面几何可能是点、线、弧、缓和曲线、样条或复合元素中的任意组合。
间隔 | 修剪特征时，在基本几何图形上可见的部分。
岛 | 用于放置在空区中的闭合区域，例如，河流、湖泊等中间的岛屿。
关键桩号 | 添加到廊道以强制在特定位置进行处理的其他桩号。
LIDAR | （激光雷达）是一种光学扫描技术，它通过扫描地面等物理特征来生成三维模型。
线性特征 | 在平面模型中，由线、弧、缓和曲线、样条或其组合构成。在纵断面模型中，由线、抛物线、样条或其组合构成。
线性线型 | 描边是通过从数据的直线段内插新快照向地形模型或廊道自动添加快照的过程。线性采样间距沿元素测量。只要顶点之间的距离大于线性采样间距值（以主单位表示），就会添加内插顶点。
操控器 | 屏幕危险警告编辑界面。操纵器中仅显示最常用的属性。操纵器有两种类型：图形和文本。
调整竖向覆盖关系 | 在廊道模型中，用于开发纵面几何（基于压碾和重叠参数）的工具，应用于廊道。
参数化约束 | 用于为指定的桩号范围设置约束值替代。
平面模型 | 常用的 DGN 模型，用于布置平面几何。最佳实践将规定这是二维 DGN 模型，但可以使用三维 DGN 模型。可在其中保存几何布局和廊道定义。几何布局不仅仅是路线，还有边缘、停车场、分段、人行道等
点特征 | 由 X, Y（Z 为可选）位置定义。点不一定是特征。它可以通过精确绘图、土木精确绘图、捕捉或数据点定义为非特征点。非特征点用于控制线性特征的结构。
点云 | 三维坐标系中的一组顶点，这些顶点由 X、Y 和 Z 坐标定义。点云通常通过三维扫描仪创建。这些设备可测量对象曲面上的大量点并将点云输出为数据文件。点云代表已扫描或数字化的对象的可见曲面。
点控制 | 用于修改模板中点的行为。这些控制优先于（替代）点上的现有约束。
项目浏览器 | MicroStation 的界面，用于浏览 DGN 文件中的元素。由土木工程扩展以适应专门的土木工程需求。
PSS 文件 | MX 文件（平面样式集），提供 MX 线串特征的图形表示。
参考元素 | 某些几何图形的规则从另一个元素进行计算。这里所说的另一个元素是参考元素。
次要路线 | 用于修改横截面的处理方向。默认情况下，在任何给定桩号，创建的横截面与主路线/特征正交。如果存在次要路线，则位于次要路线之外的那部分横截面将与次要路线（而非主路线）正交。
高程标注 | 一组 X、Y、Z 坐标，表示地形模型曲面上的点。正则点之间不存在隐含关系。
超高车道 | 由用于过渡段计算和旋转位置限制的超高工具定义的闭合区域。
超高断面 | 沿平面几何元素的区域，将计算其超高。
目标别名 | 用于在使用多个曲面时创建所需的结果，而无需从模板库中编辑模板。还可以使用目标别名，这样一个廊道便可锁定另一个廊道的解。
三维路面 | 沿廊道的区域（通常由桩号限制定义），将对其应用特定模板。
模板库 | 存储模板定义的文件，通常带有 ITL 文件扩展名。
模板过渡 | 过渡指示符出现在不同名称的模板之间的廊道中。
地形模型 | 由点、切断线、空区、孔、等高线定义的三维 DGN 元素，用于对地球表面建模。
工具提示 | 将光标悬停在元素或控制柄上方时，将显示工具提示，提供说明性信息。
跟踪边坡 | 上游 所示路径遵循从经过地形模型的点到地形模型的低点或边缘的最陡上升。 下游 所示路径遵循从经过地形模型的用户定义点到地形模型的低点或边缘的最陡下降。
纵面路线 | 纵断面模型中专用于定义路线高程的线性特征。
纵面几何 | 定义相应平面几何元素的垂直布局的元素。这些纵断面元素为二维，存储在纵断面模型中。
排空 | 标出缺失数据区域或模糊区域的闭合形状。不使用空区范围中的点或打断数据，也不会在空区范围内创建三角形。空区坐标包含在三角网中，连续空区坐标之间的孔隙线作为投影线插入表面中。因此，它们不会更改表面的坡度或高程。
流域 | 由地形模型中的低点或沿地形模型边缘的低边缘点定义，这是所有水都会排到低点的闭合区域。
XIN 文件 | 包含特征定义、关联样式、注释和其他设置的 InRoads 文件。


完成

添加新组件时，使用此命令完成组件并退出该过程。

父主题: 添加（组件）命令


添加约束（纵面）

部分约束模板中的一个点。部分约束的点仅包含 1 个约束，影响该点的移动。该点由视图中的 [image] 表示。纵面约束可确保子点与父点保持给定的垂直距离。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


导入几何

功能区：主页 > 模型导入/导出

导入几何

  • 导入几何
  • 从 ASCII 文件导入平面几何
  • 从 ASCII 文件导入纵面几何

导入几何 - 导入存储在坐标几何数据库中的几何元素（如果是 MX (FIL)、InRoads（ALG 或 FIL）或 GEOPAK (GPK) 元素）。

从 ASCII 文件导入平面几何 - 用于通过文本向导从 ASCII 文件导入平面几何元素。

从 ASCII 文件导入纵面几何 - 用于通过文本向导从 ASCII 文件导入纵面几何元素。

父主题: 模型导入/导出


创建水膜效应特征定义

创建水膜效应的特征定义，可控制两种不同实体（线性和曲面）的线符，这两种实体是通过在 OpenRoads Designer 中运行“创建水膜效应”命令生成的。

如果在 DGNLIB 中执行以下步骤，则特征定义可以重用且在删除 DGN 时不会丢失。

水膜效应特征定义是指 2 个特征符号。其中一个线符（通过元素模板）指示显示样式。首先设置显示样式。

创建显示样式

  • 打开“视图属性”对话框。
  • 单击显示样式旁边的省略号。

    将出现“显示样式”对话框。

  • 在左侧列表中查找并单击“主题: 高度”，然后使用工具栏上的按钮复制样式。右键单击新名称以重命名新样式。

    这是一个很好的初始基线。

  • 通过双击激活新的显示样式。
  • 在上述面板上，选中“忽略光照”框以确保显示的颜色块未着色，然后选择“主题显示”旁边的按钮。

    此时将显示以下对话框：（请注意，按 <ESCAPE> 时该对话框会消失，或者以其他方式失去焦点）

  • 单击“图例”选项卡可查看以下内容：

    接下来，对于水膜效应，定义特定的水膜深度范围。

  • 将“计数”从 10 更改为 3
  • 更改面板上的值以匹配以下内容。

    请注意，不可将数字更改为导致与另一个最小/最大块重叠的值，因此需要考虑更改值的顺序。

    另请注意，边距颜色已更改为与最高块相同的值。这可确保指定范围之外的任何内容看起来与较高的块匹配。

    保存创建的设置以供将来使用。

  • 关闭“显示样式”面板

    现在设置“特征符号”和“元素模板”。

创建元素模板（和初始特征线符）

  • 显示“项目浏览器”和“属性”面板。
  • 在“OpenRoads 标准”面板中展开“特征符号”。
  • 右键单击“曲面”并创建新分类（水膜效应）。
  • 右键单击新的水膜效应分类，然后选择“新建特征符号”。将其重命名为 AquaThematic 或类似名称。
  • 在“属性”窗口中，找到“默认元素模板”并展开下拉列表，如图所示。
  • 选择“管理模板...”

    现在创建一个模板来控制曲面的显示方式。

  • 在显示的对话框中，展开树节点并右键单击“地形”。
  • 选择“新建模板”并将其重命名为水膜效应主题。
  • 右键单击水膜效应主题，然后选择“添加”->“地形模型”->“计算的特征”。
  • 重复上述步骤，但选择“添加”->“地形模型”->“显示”。

    面板右侧会显示几组额外的选项。

  • 在 CalculatedFeaturesDisplay 组中查找“等高线”并确保它已关闭。确保在同一组中打开“三角网”。

  • 使用下拉列表在 CalculatedFeatureSettings 组中查找“三角网”->“主题显示样式”，查找并选择刚才创建的显示样式。（主题：水膜效应）。

  • 要节省一点时间，请在此面板中设置线性元素模板。线性模板是用于绘制流线的模板。
  • 右键单击树中的“线性”节点，然后选择“新建模板组”。将新组的名称更改为“aqua”或类似名称。
  • 右键单击新组并选择“新建模板”。将新模板重命名为 aqua_flowlines 或类似名称。
  • 右侧显示模板的一些基本显示选项。将颜色更改为“红色”。（更改为您认为合适的其他颜色）。
  • 关闭“元素模板”面板。

    现在，返回“项目浏览器”，继续设置特征符号。

完成创建特征符号

  • 展开“默认元素模板”旁边的下拉列表框，然后滚动以查找水膜效应主题或您称为“地形模板”的任何内容。
  • 选择它。

    现在已完成地形组件的线符。接下来完成线性组件。

  • 返回“项目浏览器”，右键单击“线性”（在“特征符号”下）并选择新分类。
  • 将新分类重命名为“水膜效应”。
  • 通过右键单击新的水膜效应分类，添加新的特征线符。将其重命名为 aqua_thematic（或类似名称）。

    在“属性”窗口中，您应当会看到“默认元素模板”。

  • 在元素模板的下拉列表下，查找并选择新的线性元素模板：
  • 现在已设置 2 个特征符号。接下来创建参考它们的特征定义。

创建特征定义

  • 返回“项目浏览器”，展开“特征定义”。您应当会在树中看到“水膜效应”条目。
  • 右键单击“水膜效应”并选择“新建特征定义”。将新 FD 重命名为 Aquaplaning1（或类似名称）。
  • 选择新 FD 以查看“属性”窗口中的项。在“水膜效应”面板下，为每个字段选择适当的特征线符。

    现在，新特征定义已设置完毕。

  • 如果正在使用 DGNLIB，现在请关闭 DGNLIB 并开始将其参考到新的 DGN 中。
父主题: 水膜效应


组件选择

从组件选择列表中选择一个组件。默认情况下，一次只列出 4 个组件。选择 ESC 键以滚动到下一组组件。

父主题: 创建模板


“从文件创建”工作流

地理坐标系

有关“地理坐标系”设置的详细信息，请参阅“地理坐标系”对话框。

工作流

  1. 启动命令。
  2. 选择要导入的文件。
  3. 填写过滤和过渡信息。
  4. 导入。

“选择要导入的文件”对话框

  1. 键入要导入的文件名，或从“文件“类型下拉列表中选择可用文件类型，然后选择要导入的文件类型。将显示与指定文件类型匹配的文件名。
  2. 双击文件名。
  3. 添加以指定要导入的文件的路径。还可用于选择要导入的多个文件。
  4. 单击“完成”导入文件。
父主题: 从文件创建


LandXML

LandXML 文件可能包含许多地形模型。使用“导入选项层 (Import Options Layers)”部分来选择要导入的“地形”模型。

父主题: 导入文件


创建点特征桩号偏移高程报告

  1. 创建要用于报告的点的选择集。
  2. 选择“点特征桩号偏移高程报表”工具。
  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    选择基线元素

    选择任何非点 MicroStation、土木平面几何图形或测量元素。

    点击确认以接受选定元素的数据点（在选择工具之前创建选择集时）

    点击确认以打开土木工程报告浏览器（包含生成的报告）。请注意，根据所选的默认报告，您的报告可能会有所不同。

    选择第一个偏移元素（当在选择工具之后创建选择集时）

    选择要包括在报告中的第一个点。

    选择下一个偏移元素 - 重置可完成（在选择工具之后创建选择集时）

    继续选择点，直到所有点均已标识为止。选择最后一个点之后进行重置。此时，将打开土木工程报告浏览器，其中包含生成的报告。请注意，根据所选的默认报告，您的报告可能会有所不同。

父主题: 点特征桩号偏移高程报表


转换对话框选项

设置 | 描述
转换 | 选择转换。 选择“英尺到米”、“英尺到 USFoot”、“米到英尺”、“米到 USFoot”、“USFoot 到英尺”或“USFoot 到米”。
浏览转换 |
重置所有转换 |
启用以转换元素。 | 选择下列一项或多项：“启用以旋转元素”、“启用以缩放元素”或“将转换应用于 Z 或高程值”。
旋转 | 选择“光标点”、“角度”、“激活角度”、“方向”。 选择要进行角度旋转和缩放的 4 个点。
比例 | 选择“比例”或“激活比例”。 选择要设置比例值的 4 个点。
将转换应用于 Z 或高程值 |
转换。选择转换选项。 | 选择“光标点”、“增量”或“点”。 如果启用了“启用以转换元素”，该设置将激活。
关于 | 选择“零原点”、“拾取点”、“固定点”、“零原点”、“元素中心点”。
复制 | 启用以进行复制。
保存转换 |
重复转换 |
删除转换 |
父主题: 转换


反向弧上的点

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“弧”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    点击确认（已在工具设置中设置）。

    弧模式

    选择定义弧的方法，半径点或曲线上的点。

    方向（向）

    选择弧的方向，顺时针或逆时针。

    输入弧起点

    点击确认或输入测量点名称。移动指针时，将显示动态圆及其半径/长度。

    输入中心点（仅限“半径点”方法）

    点击确认或输入测量点名称。请注意，动态信息随条目调整。

    输入弧终点

    点击确认或输入第二个点的测量点名称。

    输入通过弧点（仅限“曲线”方法上的“点”）

    点击确认或输入测量点名称。请注意，动态信息随条目调整

    重置

    如果已打开该选项，则结束工具、显示弧数据并打开土木工程报告浏览器。

父主题: 反转点


为元素设置桩号

  1. 检查首选项以确保所需的设置（加号、等式类型）。
  2. 选择“起点桩号”工具并按照警告提示操作。

    危险警告提示

    用户操作

    定位元素

    以图形方式选择要进行桩号设置的元素。如果元素已经进行了桩号设置，将显示一条消息，且不会发生额外的桩号设置。

    起点距离

    以图形方式定义（基于垂直于元素的虚线）要进行桩号设置的起点。也可以键入和锁定距离。使用非图形选项时，点击确认并移至下一提示。

    起点桩号

    输入桩号以在标识的位置处分配，然后点击确认并完成桩号设置。请注意，加号是可选的。

父主题: 起点桩号


更改模板原点

使用此命令更改模板原点的位置。在编辑过程中右键单击可访问此选项。执行此命令时，整个模板将移位，使所选点位于原点 (0,0)。

父主题: 创建模板


输入类型

选项

描述

线性

在二维或三维视图中以图形方式放置数据点。该工具将这些点链接起来，因此可以选择多个点。注释和报告在每对点之间生成信息。例如，如果放置了 4 个数据点，则显示点 1 和 2、点 2 和 3 以及点 3 和 4 的结果。连接到光标上的是最后一个距离和方向，本例中在点 4。

弧

弧选项需要 3 个点，这可通过以下项完成：

  • 曲线上的点 - 起点、终点、通过点
  • 半径点模式 - 起点、中心点（半径点）、终点

必须定义弧的方向。绘制弧后，设置光标以绘制第二个弧。重置以退出该工具。完成后，将显示详尽的弧数据。

径向

第一个点是半径的基点，通常称为后视点，而所有后续的点均从该点绘制回基点。重置将退出该工具。大圆点是基点。

在径向的情况下，每个点重新投影到基点，距离和方向沿投影计算，而不是从一点到另一点进行线性计算。

垂直

在垂直的情况下，点投影到元素，距离和方向沿投影计算，而不是从一点到另一点进行线性计算。支持两种模式：点间垂直 - 前两个点定义投影所有后续点的线（垂直）。至少需要 3 个点，其中 2 个点形成这条线，至少一个点进行投影。可以投影更多点，完成时重置以退出该工具。在此示例中，点 1 和 2 定义这条线，而点 3、4 和 5 进行投影。光标数据反映所投影的最后一个点。

按元素垂直 - 为基准元素选择现有 MicroStation 或土木元素，任何数据点将投影到（垂直于）选定元素。在此示例中，选择了先前绘制的弧并放置 3 个数据点。

按元素

反转现有 MicroStation 或土木元素。如果选择了线，则显示距离和方向。如果选择了弧，则显示弧数据。如果选择了复合元素、形状等，则标注每个组件。
父主题: 反转点


添加（组件）命令

使用以下命令向模板添加各种类型的组件。

选项

添加新的简单组件
添加新的约束组件
添加新的无约束组件
添加新的空点组件
添加新的末端条件组件
添加新的重叠/剥离组件
镜像
反射
闭合形状
更改放置点
完成
取消
父主题: 创建模板


编辑工具

使用这些命令可以修改激活或当前选定的模板或文件夹。

选项

父主题: 创建模板

编辑（撤消）

撤消（取消）当前模板的上次编辑。

编辑（恢复）

恢复（返回）当前模板的上次编辑。

编辑（剪切）

从模板库中删除所选模板或文件夹并将其放置在粘贴缓冲区中。

编辑（复制）

将选定模板或文件夹复制到粘贴缓冲区中。

编辑（粘贴）

将粘贴缓冲区的内容粘贴到模板库中的当前位置。

编辑（删除）

从模板库中删除所选模板或文件夹。

编辑（重命名）

重命名选定模板或文件夹。

编辑（清除）

擦除当前模板中的所有点和组件。


从组件中删除(清空)

将组件点更改为空点。该组件不会被删除。通过右键单击组件点来访问此命令。

父主题: 创建模板


输出设置

选项 | 描述
创建顶网格 顶网格特征定义 | 设置为 True 时，将为廊道中已禁用“从顶部/底部网格排除”的每个组件（基于其模板）创建一个网格。该网格使用指定的“特征定义”进行绘制。 如果“创建顶网格”设置为 False，则不能选择“顶网格特征定义”。
创建底网格 底网格特征定义 | 设置为 True 时，将为廊道中已禁用“从顶部/底部网格排除”的每个组件（基于其模板）创建一个网格。该网格使用指定的“特征定义”进行绘制。如果“创建底网格”设置为 False，则不能选择“底网格特征定义”。
创建线性特征 | 设置为 True 时，将根据“特征定义”绘制三维线性特征。首先，查看模板中的“点属性”： 然后，查看相应的“特征定义”。 如果“创建模板中定义的几何元素”设置为 True，则根据三维设置绘制线性特征。
创建组件网格 | 设置为 True 时，将为廊道中已启用“从顶部/底部网格排除”的每个组件（基于其模板）创建一个网格。该网格使用“组件属性”中指定的“特征定义”进行绘制。
包括空点线性特征 | 设置为 True 时，将根据与“创建线性特征”相同的条件为空点绘制线性特征。
父主题: 显示设置


资源管理器

功能区：“主页”>“基本”

使用资源管理器对话框管理项目数据。

父主题: 基本


添加特征

用于将三维图形元素（作为地形模型特征）添加到先前创建的地形模型中。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑 > 特征管理拆分按钮

此“地形模型编辑”工具用于将三维图形元素（作为地形模型特征）添加到先前创建的地形模型中。一个例子是在根据元素创建工具中从断裂线创建地形，然后使用“添加特征”工具添加点。另一个例子是在开发原始地形模型之后添加更多外业收集的断裂线。

包含预定义选择集的工作流

  1. 创建包含待添加元素的选择集。

  2. 启动工具。

  3. 指定要为其添加其他元素的地形模型。

  4. 设置“特征类型”并点击确认以接受。地形将更新以反映新元素。

不包含预定义选择集的工作流

  1. 启动命令。

  2. 指定要为其添加其他元素的地形模型。

  3. 选择要添加的元素。支持多个选择，仅在选择所有元素后重置。

  4. 设置“特征类型”并点击确认以接受。地形将更新以反映新元素。

另请参阅

特征类型

父主题: 特征管理


设置动态原点

设置动态原点的位置。动态原点用紫色框指示，用作步长锁定值的参考，以及动态设置对话框上的 OL= 和 OS= 键入命令。可通过在添加或编辑过程中单击鼠标右键来访问此选项。

父主题: 创建模板


选项

选项: 将缓和曲线定义为长度在上。或者，也可以按半径和下列项之一定义缓和曲线，具体操作是在对话框上更改方法。

  • 长度 -（如上所示）缓和曲线的长度

  • RL 值 - 通过参数（等于半径与长度的乘积）定义缓和曲线。

  • A-值 - RL 值相当大，因此在某些管辖范围使用 A-值；A-值等于 RL 的平方根。

  • 偏转 - 有时称为螺旋角或 θ 角；这是缓和曲线交点处的偏转。

  • 增量 R - 也称为覆盖偏移或螺旋偏移；这是简单曲线在引入缓和曲线后所发生的偏移

限制

  • 如果基准元素已曲线化，则下列内容适用：

如果在曲线的内部构造缓和曲线，则缓和曲线的起始半径将等于基准元素的半径而非无穷大，而且缓和曲线的旋向与基准曲线的旋向相同。

如果在曲线的外部构造缓和曲线，则缓和曲线的起始半径将无穷大。这可能无法满足所有需要。常用做法是构造双缓和曲线。第一条缓和曲线将从曲线半径到无穷大，并且与基准曲线的旋向相同。第二条缓和曲线的旋向相反，且半径从无穷大到工具中所定义的值。此工具不支持该双缓和曲线构造。使用多个工具可能会产生合适的构造。

  • 此工具仅支持回旋缓和曲线。

对话框自定义

右键单击对话框可针对特定任务或用户首选项来自定义对话框。

操控器

操控器可用于：

  • 偏移

  • 缓和曲线长度

属性

在属性中还可访问“插入直-缓-圆-缓-直曲线”规则数据。以下属性可供编辑。

以下属性为只读，但对检查非常有用。

父主题: 缓和曲线延长


特征符号

特征线符下支持四个分类。这些包括：

  • 线性
  • 点
  • 纵断面
  • 曲面

线性

参数 | 描述
默认/默认元素模板 | 用于绘制线性特征的默认元素模板。
平面/标注组 | 用于定义任何已放置标注的标注组
平面/元素模板 |
平面/弧元素模板 |
平面/缓和曲线元素模板 |
三维/元素模板 | 此元素模板用于绘制三维视图中的线性特征。
动态横截面/横断面点元素模板 | 此元素模板用于将线性特征绘制到交叉点处的动态横截面上。

点

纵断面

曲面

父主题: OpenRoads Designer 标准


属性

功能区：“主页”>“基本”

检查或修改有关元素的信息，如元素的类型、特性和几何图形。

父主题: 基本


外业簿

可以查看或编辑项目中外业簿的信息。如果选择单个外业簿，则仅显示该外业簿。

注释: 根据外业数据类型，仅某些外业可供编辑，以保持数据完整性。

父主题: 显示细节


对话框选项

“文本导入向导”由一系列对话框组成。以下主题介绍了“文本导入向导”中每个对话框的参数：

  • 文本导入向导（初始对话框）

  • 文本导入向导 - 第 1 步

  • 文本导入向导 - 第 2 步

  • 文本导入向导 - 第 3 步（固定宽度）

  • 文本导入向导 - 第 3 步（分隔符）

  • 文本导入向导 - 第 4 步

父主题: 从 ASCII 文件创建地形模型


提示 1：测量种子文件

测量将几乎所有可用的设置均存储在“设计文件设置”中。创建种子测量 DGN 文件将会提供一致、简化的工作流。

当然，组织可以具有多个测量种子文件。这些文件可能会因符号化要求、不同外业工作人员的编码技术或其他场景而异。不管原因如何，创建测量种子文件都很有意义。

父主题: 提示和技巧


添加新的约束组件

此命令可用于向模板添加约束组件。有关约束组件的详细信息，请参阅创建模板概述主题。

当前组件

名称

指定新约束的名称。

样式

指定新组件的特征样式。此选项用于显示以及定义组件的材质。有关详细信息，请参阅“样式管理器”主题。

测试

显示“测试末端条件”对话框。有关测试末端条件的详细信息，请参阅测试末端条件主题。

父主题: 添加（组件）命令


在两点之间反向

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“线性”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    点击确认（已在工具设置中设置）。

    输入起点段点

    点击确认或输入测量点名称。移动光标时会将动态距离/方向数据连接到光标。

    输入终点段点（可在下方提示字段、而不是警告提示处查看）

    点击确认或输入第二个点的测量点名称。

    重置

    如果已打开选项，结束工具并打开土木工程报告浏览器。

父主题: 反转点


末端条件优先级

使用此对话框可以查看/修复点上的末端条件优先级。

（点列表）

列出具有末端条件优先级的点。选定的点在测试窗口中高亮显示。

编辑

激活选定点的“修复优先级”对话框。

关闭

关闭对话框。

父主题: 创建模板


导入 IRD

功能区：主页 > 模型导入/导出

导入 IRD

导入（SELECTseries 2）以及 Roadway Designer (IRD) 文件中包含的以前版本的廊道。

父主题: 模型导入/导出


“标注地形位置”工作流

工作流

  1. 从地形建模杂项工具组中选择“标注地形位置”。
  2. 选择要标注的地形模型。
  3. 选择需要的工具设置。

  4. 选择地形位置。

将根据文本和尺寸标注样式设置来放置包含标高的标签。

父主题: 标注地形位置


创建新的可扩展地形模型

要创建新的 STM，请选择可扩展地形模型管理器中的“文件”>“新建”。使用“新建 STM”对话框选择新 STM 文件的位置。提供文件名并单击“保存”。将显示“新建 STM 设置”对话框，用于指定新 STM 的设置。

父主题: 可缩放的地形模型


点云概述

利用“MicroStation 点云”工具可以导入、控制、可视化和操作点云图像。可将点云导入 DGN 并将其用作可视参考。使用“点云”对话框（“文件”>“点云”）以及“点云”工具箱（“工具”>“点云”）可以控制用于附加和操作点云图像文件的所有设置。点云被视作任意标准元素，并且可以成为模型或层的一部分。

“点云”对话框可用于控制一个或多个图像文件在 DGN 文件视图中的显示。每个视图都可用于显示图像文件。（所有视图的）所有已附加图像文件的名称均会显示在“点云”对话框中。图像文件的相关信息将与 DGN 文件一起存储。“元素信息”对话框显示与点云相关的信息。“视图属性”对话框的“点云演示”部分可控制点云的样式。

支持多种点云文件格式，例如 POD、BIN、CL3、FLS、FWS、LAS、PTG、PTS、PTX、3DD、RXP、RSP、XYZ、IXF、E57 和 TXT。但是，只有 POD 文件可以附加到设计文件，因为它是点云引擎可在本地使用的唯一点云格式。此引擎是 Pointools 开发的库。POD 格式支持用户以出色的性能使用大型点云。其他所有格式的文件都必须转换为 POD 格式。

可同时打开多个点云文件。还可以将多个点云文件批量转换为一个 POD 文件或多个单独的 POD 文件。

另请参阅

MicroStation 点云工具

父主题: 从点云创建


添加新的无约束组件

向模板添加无约束组件。有关无约束组件的详细信息，请参阅创建模板概述。

当前组件

名称

指定新约束的名称。

样式

指定新组件的特征样式。此选项用于显示以及定义组件的材质。有关详细信息，请参阅“样式管理器”主题。

测试

显示“测试末端条件”对话框。有关测试末端条件的详细信息，请参阅测试末端条件。

父主题: 添加（组件）命令


按元素反向点

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“按元素”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    点击确认以继续。（已在“工具设置”中设置）

    选择元素

    选择先前绘制的 MicroStation 或土木元素。继续选择元素。

    重置

    如果已打开选项，结束工具并打开土木工程报告浏览器。

父主题: 反转点


线性模板

处理剖面与临界剖面

选项 | 描述
三维路面间距乘数 | “三维路面间距乘数”与创建三维路面时指定的“路面间距”一起使用。其目的在于使设计人员能够使用更大的间距完成初步工作，并在细化设计时轻松缩短间距。为了确定用于处理的间距，路面间距需乘以三维路面间距乘数，且系统将使用该结果。
平面基点 | 设置为 True 时，激活水平路线的基点（PC、PT、CS 等）位置将用于计算点或三维路面间距位置。
纵面基点 | 设置为 True 时，激活纵面路线的基点（VPC、VPT、VPI 等）位置将用于计算点或三维路面间距位置。
外部控制点 | 设置为 True 时，将使用平面和/或纵面点控件的位置来计算点或三维路面间距位置。
增加平面密度 |
增加平面值密度 |
增加纵面密度 |
增加纵面值密度 |
启用剪切 |
启用通道布尔 |
选项 | 描述
平面基点 | 设置为 True 时，激活水平路线的基点（PC、PT、CS 等）位置将用于计算点或三维路面间距位置。
纵面基点 | 设置为 True 时，激活纵面路线的基点（VPC、VPT、VPI 等）位置将用于计算点或三维路面间距位置。
外部控制点 | 设置为 True 时，将使用平面和/或纵面点控件的位置来计算点或三维路面间距位置。
增加平曲线密度 | 设置为 True 时，将以更近的间距沿平曲线进行处理。此选项使用 CIVIL_DEFAULT_CURVE_STROKING 配置变量值，并根据与平曲线的弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置配置变量或“增加平曲线密度”设置为 False，则默认值为 0.01。
增加竖曲线密度 | 设置为 True 时，将以更近的间距沿竖曲线进行处理。此选项使用 CIVIL_DEFAULT_PROFILE_STROKING 设置，并根据与纵断面的和弦偏移计算额外的点。该值定义用于计算额外点的弦高。如果未设置配置变量或“增加竖曲线密度”设置为 False，则默认值为 0.1。

显示设置

操纵器设置

选项 | 描述
廊道 - 元素模板 | 元素模板用于在“创建廊道”工具中绘制廊道边界。作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
廊道手柄长度系数 | 长度系数是指手柄长度与廊道宽度的比率。因此，1.0 将使手柄与该点处的廊道宽度一样长。
廊道手柄间距 | 手柄间距可设置为如图所示的物理距离，或设置为零。如果设置为零，则每个廊道将获得 11 个手柄，无论其长度如何。任何非零值都用作沿纵面路线在主单位中测量的手柄之间的距离。
三维路面元素模板 | 用于在“创建三维路面”工具中绘制三维路面边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
三维路面手柄长度系数 |
单桩号点元素模板 |
单桩号点手柄长度系数 |
过渡段元素模板 | 用于在“创建过渡段”工具中绘制过渡边界的元素模板。 作为最佳实践，将边界的图形放置在构造类中，以便根据需要轻松关闭/打开它们。
缓和手柄长度系数 |
父主题: 特征定义


文本导入向导（初始对话框）

工作流
  1. 启动命令。
  2. 配置“文本导入向导”文件或选择“文本导入向导”文件。
  3. 选择要导入的文件。
  4. 填写过滤和过渡信息。

“选择要导入的文件”对话框

  1. 键入要导入的文件名或选择要导入的文件。
  2. 添加以指定要导入的文件的路径。还可用于选择要导入的多个文件。
  3. 单击“完成”。

“从 ASCII 文件创建地形模型”对话框

选择“导入”。

设置 | 描述
选择要导入的文件 | 显示“选择要导入的文件”对话框
重命名地形模型 | 选择要重命名的地形模型，键入新名称并输入。
新建文本 | 显示“创建文本导入向导设置文件 (Create Text Import Wizard Settings File)”。
编辑当前选定的文本导入设置文件 | 显示“编辑文本导入向导设置文件 (Edit Text Import Wizard Settings File)”。
删除地形模型 | 从项目中移除指定的地形模型。

选项

特征定义

设置 | 描述
特征定义 | “无特征定义”是默认值。从下拉菜单中选择特征定义。
创建特征 | 根据源文件中定义的样式创建设计文件元素。

文本导入向导

设置 | 描述
向导设置文件 | 完成设置向导设置之后，文件将保存到 XML 文件中，可在后续会话中加载。这有助于部署适用于标准和历史文件格式的预定义设置文件。

地理坐标系

设置 | 描述
来源 | 未指定引入的地理坐标系。显示图像投影对话框以从可搜索库中选择。
目标 | 未指定传出的地理坐标系。显示图像投影对话框以从可搜索库中选择。
父主题: 从 ASCII 文件创建地形模型


曲线加宽工作流

  1. 选择“曲线加宽”工具。

  2. 定位廊道 - 已动态定义。

  3. 选择起点桩号 - 可以动态定义或通过键入值来定义。

  4. 选择终点桩号 - 可以动态定义或通过键入值来定义。

    在桩号范围内具有完整长度的任何曲线均会应用加宽。

  5. 输入描述 - 即在“廊道对象项目浏览器 (Corridor Objects Project Explorer)”和报告中使用的可选描述。

  6. 输入点 - 标识应用加宽的点。从可用模板点的点列表中选择点。

  7. 输入“切线曲线缓和百分比”- 指定加宽曲线前后的直线部分（切线）上的曲线过渡大小。

  8. 切换“是/否”以将缓和曲线长度用于缓和段 - 当设置为是且曲线具有缓和曲线组件时，则缓和曲线长度用于确定过渡的开始和停止位置。忽略从表中读取的“切线”百分比过渡和过渡长度。如果设置为“否”，则使用该表。

  9. 选择重叠方法 - 仅在一条曲线的结束过渡控制与下一条曲线的开始过渡控制重叠时适用。

    缩短过渡长度 - 指定重叠过渡长度缩短相等的量，使其不重叠。

    将最大加宽点移到曲线上 - 指定保持过渡长度；但整个过渡均会移动，以便更多过渡位于曲线上。重叠过渡按相等的量移动。

  10. 定义优先级 - 确定点上的控制顺序。仅当点上的控制存在冲突时，此值才适用。如果存在冲突，则应用具有较低优先级的控制（即，首先应用较低的数字）。

  11. 选择加宽表 (* .wid) 文件 - 包含加宽信息的 ASCII 表的位置。

系统将应用曲线加宽并重新处理廊道。可以在廊道图形、“项目浏览器”和“廊道对象”对话框中看到结果。

父主题: 创建曲线加宽


STM_DEFAULT_MINIMUM_PIXEL_SIZE_FOR_DRAPING

将图像覆盖到 STM 上时， OpenRoads Designer 将在覆盖区域上创建块状图像。此图像的像素大小定义为所有覆盖光栅的最小像素大小。但是，WMS 和 Bing Maps 没有定义像素大小。在这些情况下，STM_DEFAULT_MINIMUM_PIXEL_SIZE_FOR_DRAPING 的值用于确定合适的像素大小。默认情况下将其设置为 0.5 米。

父主题: 覆盖光栅


设计标准

设计标准分类用于创建、查看和编辑平面和纵面几何图形设计标准信息。

设计标准用于监视所需的曲率和其他路线检查（在平面土木几何元素上）以及坡度和 K 值（在纵面几何元素上）。

这些标准存储在设计库 (DGNLIB) 中，该库可以为只读并存储在一个中央位置供所有用户使用，并由配置变量 MS_DGNLIBLIST 引用。DGNLIB 是一个类似于种子文件的空文件，可在其中设置各种 MicroStation 和 Civil 资源。组织可以使用许多 DGNLIB，建议将水平和垂直标准存储在一个 DGNLIB 中，但与其他 DGNLIB 类型的数据分开。如果同时使用公制和英制单位，您可能需要为每种单位提供一个 DGNLIB。

这些标准在浏览器中设置。请注意，浏览器中的层次结构将镜像到“设计标准工具栏”选取列表中。可以根据组织的标准自定义该层次结构。

弹出式菜单包含许多实用工具以及属性（存储单个标准的位置）。请注意，水平标准与垂直标准的设置不同。

“属性”面板是每个标准的仓库。

垂直标准使用相同的弹出菜单选项。属性包括每个垂直标准。

可通过“主页”>“基本”访问项目浏览器。首先完成垂直标准更有效，因为在构建水平标准时将参考垂直标准。

右键单击单个条目并从弹出菜单中选择“属性”以查看设置。

水平设计标准属性

竖向设计标准属性

创建新的水平和垂直标准

注释: 如果已有 SELECTseries 2 水平标准，则可以升级到 SELECTseries 3 并添加垂直标准。

常规程序为：

  1. 确定水平和垂直标准的层次结构。这也决定了从头开始创建多少内容以及复制和粘贴多少内容。请记住，用户可以看到您构建的层次结构，因此请保持名称直观。

  2. 使用 Civil 产品之一打开 DGNLIB 文件。仅加载 MicroStation 无法访问这些工具。从主菜单中选择“文件”>“项目浏览器”。

  3. 在项目浏览器中，单击“土木标准”选项卡。

    注释: 用户选项卡的配置可能与图解不同。可以在主菜单上的“设置”>“项目浏览器”下更改选项卡。
  4. 将层次结构导航到“水平”和“垂直”。这是从头开始构建的起点。

  5. 创建层次结构的第一个部分。在开始时，避免倾向于构建整个层次结构。构建第一个标准，然后复制并粘贴到下一个标准中要更容易，因为许多字段值都相同。例如，双车道与四车道的条目相同，值略有不同。设置双车道文件夹，然后将完成的文件夹复制和粘贴到四车道并根据需要更改值，而不是所有内容都键入两次。

  6. 选择要开始的位置，右键单击并从弹出菜单中选择“新建”。将在标题为“竖向设计标准”的表中生成一个新条目。要重命名，请右键单击并选择“重命名”，然后更改名称。层次结构可以嵌套。

  7. 要设置每个条目的值，请高亮显示相应条目，右键单击并从弹出菜单中选择“属性”。
  8. 单击每个字段并调整值。要设置 K 值，请将“竖向表类型”设置为“K 表”，然后单击“表”以显示图标（三点）。单击以打开弹出的表编辑器。

  9. 向表编辑器添加信息（每个设计速度对应一行）并关闭。

  10. 继续添加其他垂直标准，方法是复制第一个条目并根据需要调整“最小坡度”和“最大坡度”以及“坡度偏差”。通过复制已经获得 K 值表信息，因此不必重新输入该信息。使用标准时，选择水平输入项 50 kph 或 mph 将使用垂直列表中的默认值 50 kph 或 mph。

  11. 完成垂直标准后，转到水平标准。添加新条目和填充标准的过程完全相同。过渡表通过表编辑器完成。

  12. 过渡表 - 请注意，绿皮书具有默认过渡段，但没有最小过渡段。

  13. 为某个超高值（如 4%）完成一组条目后，将整个分组复制并粘贴到标准中最为容易。重命名（例如，将 4% 重命名为 6%），然后调整 6% 分组中的值。这将维护每个条目中的值，因此您只需调整过渡表即可。

“设计标准”分支列出激活设计模型或 DGN 库中可用的设计标准，并启动命令在激活设计模型中为平面和纵面几何创建新的设计标准。“设计标准”定义用于帮助设计师在执行几何布局时保持所需的曲率和其他检查，这些标准通常基于地理区域或权威机构的公认标准，因此建议在 DGN 库中创建和存储这些标准。

要创建新的设计标准，请选择“水平”或“垂直”，然后右键单击以选择“新建”命令。单击“新建”之后，输入设计标准的名称并填充“属性”面板，如下所示。

每个水平标准的属性如下：

  • 设计值

    • 速度 - 这是标准的设计速度。
    • 默认半径 - 这是在命令启动时用来填充命令的半径。
    • 最小半径 - 这是相应设计速度的最小半径。使用小于此半径的值将导致显示警告。
    • 过渡段类型 - 可以是“表”或“公式”。
    • 表 - 如果“过渡段类型”为“表”，则此属性用于填充表。
    • 包括过渡段
    • 检查相切

  • 弧

    • 最大弧长
    • 最小弧长

  • 切线

    • 最大切线长度
    • 最小切线长度
    • 最大偏差 - 两条切线在无曲线的情况下连接时线间的最大角度。

  • 竖向设计标准

每个垂直标准的属性如下：

  • 最小坡度

  • 最大坡度

  • 最大坡度偏差

  • 竖向表类型

  • 表

父主题: OpenRoads Designer 标准


廊道报表

功能区：分析与报告

廊道报表

  • 组件数量
  • 设计输入报表
  • 结果报表
  • 清表报表
  • 超高报表

报告包括组件（混凝土、表层土、路肩、挖方和填方土方量）表面积、体积、计量单位、单位成本以及组件和总成本。

打开带有默认路面设置报告的 Civil 报告浏览器，其中包括廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡段、末端条件异常和超高区间信息。

打开带有默认路面设置报告的 Civil 报告浏览器，其中包括详细的廊道桩号范围、关键桩号、三维路面信息、约束、点控制、过渡段、末端条件异常和超高区间信息。

打开带有压碾/剥离组件报告的 Civil 报告浏览器。

可以为单个或多个区间生成超高报告。这些报告显示在 Civil 报告浏览器中。

父主题: 模型分析与报表


路线

参数 | 描述
廊道模板 | （可选）待附加到路线上的模板。
线性特征符号 | 此线符定义用于绘制水平路线。
纵断面特征符号 | 此线符定义用于绘制与路线相关的任何纵面路线元素（如果未使用替代）。
父主题: 特征定义


价值公式

通过设置方向和倍增系数以及选择点来构建公式。选择平面偏差、纵面偏差或坡度偏差以及不同的点时，等式中显示的值会进行更新以反映您的选择。

以下列表说明了等式中使用的方向符号。

  • _（下划线）- 平面偏差

  • | （竖线）- 纵面偏差

  • /（正斜杠）- 两点间的坡度

以下表述展示了语法示例并提供了结果说明。

  • =_$(Pt2)-$(Pt1) - 计算结果为 Pt2 和 Pt1 之间的平面偏差，即 (Pt2.x - Pt1.x)

  • =|$(Pt2)-$(Pt1)*0.5 - 计算结果为 Pt2 和 Pt1 之间纵面偏差的 Â?，即 (Pt2.y - Pt1.y) * 0.5

  • =/$(Pt2)-$(Pt1) - 计算结果为 Pt2 和 Pt1 之间的坡度，即 (Pt2.y - Pt1.y)/(Pt2.x - Pt1.x)

仅当选择坡度约束时，两点之间的坡度才适用。

以“-”开头的参数化值被解释为参数化值的负值。例如，如果在特定桩号上将 LaneWidth 参数化值设置为 15.0，则将为标签为 -LaneWidth 的约束指定值 -15.0。

等式中使用的点名称不能使用“$()”或“％”。

拖放带有标签的镜像约束将会生成一个影响模板两侧的标签。

工作流

  1. 从下拉列表中选择“平面偏差”、“纵面偏差”或“两点之间的坡度 (Slope Between Points)”。仅当选择坡度约束时，“两点之间的坡度 (Slope Between Points)”才可用。
  2. 从下拉列表中选择第一个点或使用“定位”按钮。
  3. 从下拉列表中选择第二个点或使用“定位”按钮。
  4. 输入“倍增系数”值。缺省值为 1。
  5. 单击“确定”以使用选定值执行命令。
父主题: 创建模板


添加约束（矢量偏移）

部分约束模板中的一个点。矢量偏移规定子点具有两个父点并投影到由两个父点定义的矢量。如果偏移量不是 0，则子点在指定的偏移值与父矢量保持垂直偏移。负值表示偏移到由父点定义的矢量左侧。正值表示偏移到右侧。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


概述

可缩放的地形模型 (STM) 是一种新的对象类型，旨在使巨大的数字地形模型实现高速显示。STM 从多种高程数据源中创建，其中包括 XYZ 文件、DEM、断线和其他数据源。STM 系统将跟踪构成 STM 的文件。如果源文件被更改，运行“检查是否为最新”功能会通知用户需要更新 STM。

父主题: 可缩放的地形模型


连接点

连接点时需要注意几点。连接创建方式如下：单击一个模板上的未连接点，将鼠标移动到另一个模板上的某个点，然后再次单击。连接线将动态显示。要中止连接，请按鼠标右键。

点的选择顺序十分重要，因为在曲面中创建此特定线时使用的特征样式将是选定第一个点的特征样式。

通过右键单击连接并从弹出式菜单中选择“删除”命令，可以删除连接。

通过右键单击模板其中的一个点、选择“移动模板”并将模板拖到屏幕上的新位置，可以更改模板的位置。这与窗口命令一起有助于更好地查看连接。这对于复杂模板特别有用。

模板点可以连接到另一个模板上的多个点。

父主题: 编辑过渡段


提取等高线

一部分 STM 可以作为矢量元素保存到 DGN。

从 STM 对话框的“编辑”菜单中，选择“提取等高线”。

设置 | 描述
面积类型 | 定义区域选择方法：“块”、“定向块”、“元素”、“形状”、“视图”
使用围栅 | 如果围栅激活，则可以使用它来定义区域。
使用所有 STM | 在处理期间使用所有连接的可扩展地形模型。

根据区域类型选择点以定义要提取的区域。必须在顶视图中选择这些点。任何围栅或形状均应位于顶视图的平面内。

处理后，将使用 STM 中所定义的线符将等高线写入至缺省层。

变量 STM_ EXTRACTCONTOURS_USESUBRES 控制所用 STM 的分辨率。设置为 0 时，使用全分辨率。设置为 1 时，使用子分辨率。

父主题: 可缩放的地形模型


导出到 TM

MicroStation 现在支持本地“地形”数据类型。通过选择“文件”- >“将 STM 导出到 TM”，可以将 STM 导出到此地形类型。导出后，STM 将被分离，且系统将创建一个新地形元素。有关地形元素和相关工具的详细信息，请参阅 MicroStation 文档。

地形模型元素的大小由控制导出到 i-model 的变量控制。

变量 STM_DOWNSAMPLING_PREFSIZE 控制导出的地形元素大小（以 MB 为单位）。默认值为 5。

父主题: 可缩放的地形模型


删除点

删除模板中的选定点。通过右键单击主视图中的点来访问此命令。当选定点是两个或多个形状的成员时，将显示该对话框。

选择要从中删除点的形状

列出当前点。可以选择单个或多个点。

全部

选择所有要删除的点。

无

取消选择所有点。

确定

从选定形状中删除该点。

父主题: 创建模板


辅助项的工作流

工作流: 添加辅助车道

可以使用“创建超高车道”工具来添加辅助车道（那些带有用户指定的横坡和桩号范围的车道），但是必须在单个区间内。选中单个区间后，提示会更改以反映正在添加单个车道。要移动区间限制以适应辅助车道，以图形的方式选择区间，然后动态移动到所需的桩号。要获得准确的桩号，使用区间操控器，然后键入值。如果有相邻的区间，它也需要移动，以避免区间之间重叠或存在间隙。

此工作流的结果是图形辅助车道。此车道需要与廊道关联，类似于通行车道。如果车道带线形，则包含该车道的区间需要重新处理（计算超高）。

辅助车道的工作流

  1. 查看区间，以确保辅助车道在单个区间内。根据需要调整区间限制。

  2. 选择“创建超高车道”工具。

  3. 按照危险警告提示操作：

提示 | 用户操作
定位第一个超高断面 | 选择第一个剖面。
定位下一个超高剖面 - 或重置可完成 | 重置以移动到下一个提示。请注意，对于辅助车道，仅可以选择一个区间。
输入车道名称 | 为每个车道命名，建议命名为 RT 或 LT 等，对于具有多个车道的项目，可附加 -1、2 等。请注意，如果您的项目有多个廊道，则这些名称应该唯一。
类型 | 选择“辅助”。选中后，对话框/警告提示更改以反映该选择。
应用程序类型（仅限辅助车道） | 定义横坡： 无 - 未分配横坡。 常数 - 指定值的固定坡度。如果车道为过渡，使用此选项，然后在编辑器中修改一端或创建后以图形方式修改。 跟随临近 - 从临近车道投影横坡到此车道。
选择中心线侧 | 右侧或左侧。
内边缘偏移 | 输入相对于基线参考的偏移（以主单位计）。如果车道边缘为基线参考，输入 0。
宽度 | 输入车道的宽度（以主单位计）。如果车道有多种宽度，您可以使用最宽的宽度，或稍窄的宽度。在这两种情况下，模板可以按参数约束或几何特征来控制宽度。
起点桩号 | 以图形方式定义（基于垂直于参考元素的虚线）车道的起点。可以键入和锁定桩号。
终点桩号 | 以图形方式定义（基于垂直于参考元素的虚线）车道的终点。可以键入和锁定桩号。
标准段横坡 | 输入用于计算的默认横坡（以百分比格式）。无需添加百分号。
父主题: 创建超高车道


在两点之间垂直反向点

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“垂直”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    点击确认（已在工具设置中设置）。

    垂直模式

    两点间。点击确认以继续。

    输入起点垂直点

    点击确认或输入测量点名称，以定义基线的第一个点。移动光标时会将动态距离/方向数据连接到光标。

    输入终点垂直点（可在下方提示字段查看，而不是警告提示）

    点击确认或输入第二个点测量点名称，以完成基线。

    输入要投影的点

    点击确认或输入每个要投影回至基线的点的测量点名称。继续选择数据点直到完成。任何超出基线限制绘制的点均不会投影，仅会连接到最近的基线端点。

    重置

    如果已打开选项，结束工具并打开土木工程报告浏览器。

父主题: 反转点


添加约束（平面）

部分约束模板中的一个点。部分约束的点仅包含 1 个约束，影响该点的移动。该点由视图中的 [image] 表示。平面约束可确保子点与父点保持给定的水平距离。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


创建复合地形模型

用于将多个地形模型合并或附加成一个模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮
  • 功能区：主页 > 模型导入/导出 > 地形导入拆分按钮

“创建复合地形模型”工具用于将多个地形模型合并或附加成一个模型。顺序非常重要，因为模型按列出的顺序进行处理。为项目指定对应的附加或合并也很重要，因为结果可能会大不相同。

任意两个地形模型均可合并在一起，前提是其中一个地形模型至少在一点上与另一个模型重叠。如果无重叠，将显示一条警告消息，不执行任何处理。

工作流

1.启动命令。

2.激活 DGN 及其参考中的所有可用地形模型在左侧的面板中列出。

3.在左侧选择基本（主要）地形，然后单击对话框中间的“添加”将其添加到右侧的合并列表。

4.在左侧逐一选择其他地形模型，在中间选择“合并”或“附加”，然后单击“添加”。

5.当合并列表完成后，设置要分配给新地形模型的特征定义。

6.单击“完成”。

更改合并或附加顺序

设置 | 描述
 | 在曲面列表中将所选曲面上移。
 | 在曲面列表中将该曲面下移。

当前操作：合并或附加地形模型

合并和附加操作均会合并多个（两个或多个）模型中包含的数据。但它们不是同一个过程，会产生不同的结果。

进行附加时，软件会在使用两个地形模型中的所有数据，而不忽略任何数据的情况下，将来自两个模型的合并数据三角形化。这两个模型可能会重叠或彼此相邻。如果两个模型的公共区域中存在数据，则会利用所有这些数据进行三角形化。

进行合并时，软件将三角形化两个地形模型的不重叠区域中的合并数据。这两个模型必须至少在一点上重叠。如果两个模型在公共区域（重叠）中均有数据，则会丢弃主模型中的数据，仅使用合并模型中的数据。因此，顺序至关重要。

在上述示例中，TM1 是主模型，TM2 则正在合并（在顺序列表中的下方）。在（两个地形模型共有的）阴影区域中，利用来自 TM2 的数据并围绕公共边重新三角形化。将丢弃阴影区域中来自 TM1 的数据。将显示新的合并地形模型的外壳。

父主题: 其他方法


添加点

使用此命令在组件末端动态放置（添加）点。仅当光标位于开放组件上时才会显示此命令。重置以退出该命令。

父主题: 创建模板


在资源管理器中查询数据

在“资源管理器”对话框的“文件”、“项”和“资源”选项卡中，您可以搜索对象，并指定搜索条件来缩小搜索结果的范围。您可以根据具体要求执行“简单”搜索、“标准”搜索或“高级”搜索。“简单”搜索可以根据搜索文本执行搜索。“标准”搜索可以创建简单查询。“高级”搜索可以构造复杂的搜索条件，您可以保存这些条件以供日后使用。搜索结果会存储在一个以搜索条件命名的文件夹中。通过搜索结果文件夹的右键菜单，您可以将结果保存为报告定义（仅适用于“标准”和“高级”搜索），编辑搜索标准，删除搜索标准，或查看属性。

父主题: 常用工具


从点云创建

用于从一个或多个点云创建地形模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮
  • 功能区：主页 > 模型导入/导出 > 地形导入拆分按钮

“从点云创建”工具利用一个或多个点云创建地形模型。

点云是一种可以包含对象曲面上的大量点的数据文件。点云是三维坐标系中的一组顶点，这些顶点由 X、Y 和 Z 坐标定义。点云通常通过三维扫描仪创建。这些设备可测量对象曲面上的大量点并将点云输出为数据文件。点云代表已扫描或数字化的对象的可见曲面。点云可用于许多目的，尤其是确认 DGN 模型和现实世界之间的测量值。

点云概述
创建地形模型
父主题: 其他方法


测试末端条件

测试末端条件解决方案，测试重叠/剥离组件，并测试组件显示规则的 true 或 false 标记。

（显示）

显示当前模板。未解决的末端条件及其子组件以虚线显示。常规组件和已解决的末端条件以实线显示。该显示包含所有标准窗口命令和滚动条。

可用目标

列出适用于当前模板的所有目标。可以选择所需目标并在显示中绘制。

使用表面坡度

指定要放置的表面的坡度。在末端条件与表面相交多次的某些实例（例如沟渠纵断面）中，此选项很有用。

绘制

绘制选定目标。表面和高程绘制为水平线。特征和线形绘制为 + 标记。绘制目标时，显示将动态更新以显示解决方案。

重置

清除绘制的所有目标。

显示规则

列出当前模板的显示规则。在值上单击鼠标左键可在 True 和 False 之间切换。按“重置”按钮可恢复“显示规则”的原始值。

失败报表

激活“结果”对话框。无法获得一侧或两侧的解决方案时，结果将显示失败的组件，以及未得到解决的末端条件起点。

检查优先级

测试优先级冲突的模板。存在冲突时，将显示一条消息，指出存在从相同点开始且优先级相同的末端条件。将显示末端条件优先级冲突 (End Condition Priority Conflicts) 对话框。如果不存在冲突，将显示一个消息框，指出没有任何冲突。

检查重复项

检查给定解决方案中是否存在重复的特征和组件名称。如果找到重复的特征或组件名称，将显示“重复特征名称列表 (Duplicate Feature Name List)”对话框。如果未找到任何重复项，将显示有关此结果的消息。

（视图窗口）

可以执行标准放大/缩小；沿 X 方向放大/缩小；沿 Y 方向放大/缩小；显示窗口区域，以及适合视图。

父主题: 创建模板


动态设置

使用此对话框指定精确输入。捕捉到现有点或组件时会覆盖步长锁。

X:Y/X:斜率

在 X、Y 步长锁和 X/斜率步长锁之间切换。

X 值

显示与动态原点的当前 X 距离。

X 步长

指定步长增量。如果此值不为零，则光标将从动态原点移动到测量得出的指定值的平面增量值。

Y 值

显示与动态原点的当前 Y 距离。

Y 步长

指定步长增量。如果此值不为零，则光标将从动态原点移动到测量得出的指定值的垂直增量值。

检查拦截

仅适用于末端条件点。启用此项后，指定在对末端条件求解时检查前一段是否拦截目标。关闭后，检查拦截时将忽略该段。

在拦截处放置点

仅适用于末端条件点。指定当沿前一个线段发现拦截时，线段将被绘制到拦截中。否则，如果找到拦截，则线段将被绘制到其最大宽度中。

末端条件为无穷大

仅适用于末端条件点。指定在尝试拦截目标时，最后一个段将被视为无限长度。此选项仅适用于末端条件的最后一个点。

不构造

仅适用于末端条件点。指定将像末端条件中的所有其他点一样对点求解，但在绘制组件段时将跳过该点。

点名称

指定要放置的点的名称。

点样式

用于设置要放置的点的样式。

应用词缀

选定时，指定在放置点时应用词缀。

（键入命令）

指定要执行的键入命令的类型。

  • XY= 键入绝对坐标

  • DL= 键入放置最后一个点的增量坐标（如果它是组件的第一个点，则默认为动态原点）。

  • HS= 键入水平增量距离和放置的最后一点的斜率。

  • VS= 键入垂直增量距离和放置的最后一点的斜率。

  • OL= 键入动态原点的增量坐标。

  • OS= 键入水平增量距离和动态原点的斜率。

（键入命令）

指定精度值。如果键入命令值以键入命令类型（例如 &rdquor;DL="）开头，则键入的类型将替代当前的组合框设置。按 Tab 键或 Enter 键接受字段中的值并将其应用于当前操作；然后，该字段将会清除且焦点保留在该字段中。您还可以使用向上和向下箭头键来获取先前键入的值。使用相对键入命令（类型 DL、HS、VS）创建刚性组件和末端条件时，点上的约束将与选定的键入命令匹配。这些约束将持续存在，直到键入命令类型更改为另一个值为止。有关约束的详细信息，请参阅创建模板概述主题。

设置动态原点

设置动态原点的位置。对此选项使用以下快捷方式：Crtl+D。

父主题: 工具命令（创建模板）


从 ASCII 文件创建地形模型

用于以各种 ASCII 格式导入曲面数据，并允许您在导入文件之前灵活地描述文件格式。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮

“从 ASCII 文件创建地形模型”工具以各种 ASCII 格式导入曲面数据，并允许您在导入文件之前灵活地描述文件格式。

表面数据

表面数据文件可以仅包含随机点、切断线、内部、外部或轮廓特征信息，并且一个文件可以不包含多于一种类型的特征数据。每行表示一个点。处理每行时，将计算该行中所述的点。接下来，该向导将处理“表面选项 (Surface Options)”对话框中指定的围栅选项和特征类型。如果存在围栅且选择模式不是“忽略”，如果点采用围栅边界，则该点将添加到数组中。如果选择的特征类型为“随机”，则所有点在导入过程结束时插入，否则将处理笔代码。（如果已选择需要笔代码的特征类型，并且向导未将列定义为包含笔代码数据，则会显示错误消息并中止导入。）如果读取的点是第一个点，或者如果笔代码指示应开始新特征，则特征名称将通过提供的名称或种子名称进行更新。读取一个特征的数据之后，该特征将添加到指定的表面，且该过程将会继续，直到添加完所有特征为止。

数据示例 - 横坐标、纵坐标、高程、笔代码

47 417919.93 25.00 1

57 417912.36 27.97 0

67 417904.80 30.95 0

77 417897.23 33.92 0

87 417889.67 36.89 0

96 417882.11 39.87 0

06 417874.54 42.84 0

16 417866.98 45.81 0

文本导入向导（初始对话框）
修改现有文本导入向导
向导和过滤器
工作流: 使用向导导入文件
保存向导
多个过滤器的运行方式
对话框选项
文本导入向导 - 第 1 步
文本导入向导 - 第 2 步
文本导入向导 - 第 3 步（固定宽度）
文本导入向导 - 第 3 步（分隔符）
文本导入向导 - 第 4 步
“表面”选项
打开向导
父主题: 其他方法


取消

向模板添加新组件时，使用此命令完成添加过程而不进行任何更改。在添加过程中右键单击可访问此选项。放置组件后，此选项不再可用。

父主题: 添加（组件）命令


删除特征

用于从“添加特征”或“从元素创建”添加的地形中移除 3D 元素。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑 > 特征管理拆分按钮

此工具可从“添加特征”或“从元素创建”添加的地形中移除 3D 元素。元素可以在启动工具之前放置在选择集中，也可以在工具内分别选择。

  1. 使用要移除的元素创建选择集。

  2. 启动工具。

  3. 指定要移除其元素的地形模型。

  4. 接受以移除元素。地形将会更新，以反映已移除的元素。

工作流 - 没有预定义的选择集

  1. 启动命令。

  2. 指定要移除其元素的地形模型。

  3. 选择要移除的元素。支持多种选择，选中所有元素后可重置。

  4. 接受以移除元素。地形将会更新，以反映已移除的元素。

父主题: 特征管理


土木分析

功能区：分析与报告

土木分析

  • 测点分析
  • 测点间分析
  • 分析土方量
  • 反转点
  • 分析轨迹边坡
  • 分析水塘
  • 组件数量
  • 三维漫游

动态查看有关所选二维或三维设计元素、地形模型或网格的信息。

查看地形模型或网格的两个所选点之间的高程、斜率、距离和增量信息。

计算两个模型或一个模型和一个平面之间的土方量并（可选）将结果放在文件中用户定义的位置。

计算并显示每对指定点之间的距离和方向。支持几种类型：线性、弧、径向、垂直和按元素。

动态追踪地形模型或网格曲面上的路径。

沿着下游追踪一个点到低点，然后填充它，得出土方量、最大深度和最大高程。此外，以图形方式显示水塘描述。

报告包括组件（混凝土、表层土、路肩、挖方和填方土方量）表面积、体积、计量单位、单位成本以及组件和总成本。

使用户能够以更逼真的可视化方式查看三维模型。

父主题: 模型分析与报表


超高

超高断面

参数 | 描述
线性特征符号 | 创建超高区间时使用的线符定义。
显示填充 | True - 为区间打开填充。 False - 不显示填充。

超高车道

参数 | 描述
左侧元素模板 | 用于道路左侧候选超级点控件的模板。
右侧元素模板 | 用于道路右侧候选超级点控件的模板。
启用距离渐变 | True - 根据横坡值显示车道的主题阴影。请参阅超高设置。 False - 车道充满了底纹，与未计算的车道相同。
父主题: 特征定义


更改特征类型

用于更改地形模型内选定元素的特征类型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 编辑> 特征管理拆分按钮

工作流

  1. 启动命令。
  2. 选择作为地形一部分的元素。
  3. 将元素类型更改为点、切断线、空区等。
父主题: 特征管理


提示 2：点重命名

当前，没有规定要在将测量数据导入测量时处理自动点重命名。要处理点重命名，可以使用两个选项。

选项 1：

  • 具有相同点字段命名的数据文件可以导入不同外业簿中。

  • 创建外业簿，并导入第一个文件。

  • 创建另一个外业簿，并导入第二个文件。

  • 等等。

选项 2：

将第一个数据文件导入外业簿。在详情面板中选择该数据文件中的所有点，并附加前缀或后缀。选择“编辑选定项”>“名称”（或任何属性），并使用以下运算符：

如果属性为“数字”（“向东”、“角度”、“高程”等），可使用：

+ - / *

如果属性基于“字符串”，则可使用：

+ 和 -

要向字符串中添加前缀，请使用：

<前缀字符串> +

要添加后缀，请使用：

+ <后缀字符串>

父主题: 提示和技巧


添加约束

仅当点尚未完全受到约束时，使用以下命令向点添加约束。

选项

添加约束（完全约束）
添加约束（平面）
添加约束（纵面）
添加约束（坡度）
翻转点属性
添加约束（矢量偏移）
添加约束（角度距离）
添加约束（平面最大值）
添加约束（平面最小值）
添加约束（纵面最大值）
添加约束（纵面最小值）
父主题: 创建模板


添加断链

  1. 检查首选项以确保所需的设置（加号、等式类型）。
  2. 选择“添加断链”工具并按照警告提示操作。

    危险警告提示

    用户操作

    定位元素

    以图形方式选择要添加断链的元素。

    定位后桩号

            以图形方式定义（基于垂直于元素的虚线）断链的起点。也可以键入后桩号（然后按 Enter 以锁定并继续下一提示）。使用非图形选项时，点击确认并移至下一提示。

    前桩号

    输入桩号以分配给等式的前桩号，点击确认并完成断链。当使用“按名称”(InRoads) 等式类型（如“设计文件”设置中所定义）后，条目的格式为 A 10+00，其中 A 是每个等式的用户定义的唯一标识符。当使用“按索引”(GEOPAK) 后，区域将自动分配，因此用户仅需输入桩号值。两种类型均无需加号。

父主题: 添加断链


点

另请参阅“功能定义”。

参数 | 描述
点特征符号 | 用于绘制点特征的线符。
父主题: 特征定义


标注定义

父主题: OpenRoads Designer 标准


按文本内插创建

用于从二维“标记”等高线和内插二维线性元素与文本点创建地形模型。

您可以通过以下方式访问此工具：

  • 功能区：地形 > 创建 > 其他方法拆分按钮

“按文本层内插创建地形模型”工具使用二维文件。通过在纵向 MicroStation 元素上定位高程标注以及通过内插来派生线性数据。必须使用高程“标记”等高线，而断裂线和空区则使用每个顶点处的文本来确定高程。因此，必须定义两组过滤器：一组用于“线性特征”，另一组用于高程信息。

常规

设置 | 描述
文本过滤器 | 允许为所需文本选择“图形过滤器”。要细化过滤器，请使用“图形过滤器管理器”。
线性特征过滤器 | 允许为表示文本插入点的元素选择“图形过滤器”。系统提供缺省文本过滤器，用于查看绘图中的所有文本，以尝试并提取所提供的高程标注。要细化过滤器，请使用“图形过滤器管理器”。
搜索公差（以主单位计） | 仅用于线性特征 - 如果文本对齐在指定的顶点搜索公差范围内，则将该高程包含到线性特征的 TM 创建中。如果文本未在任何线性特征图形的搜索公差范围内，则忽略高程，不将其包含在任何线性特征中。但是，也可以将其作为通用高程标注包含在内，具体取决于它是否与高程标注的图形过滤器相匹配。
包括文本作为高程标记 | 开启可查看绘图中利用对齐点作为 X,Y 坐标的所有文本和作为高程的文本值，并用作高程标注。
地形过滤器管理器 | 打开“地形过滤器管理器”。
预览 | 预览当前过滤器选择。

另请参阅

三角网选项

特征定义

“按文本内插创建”工作流
父主题: 其他方法


文本导入向导 - 第 1 步

本部分介绍了“文本导入向导 - 第 1 步”对话框，该对话框是创建新向导系列中的第一个对话框。

对话框选项 | 描述
定义导入范围: (Define Import Range:) |
范围内的行 | 指定应导入的第一行和最后一行。
自此行开始导入 | 指定向导应从（已导入文件）哪一行开始读取数据。例如，如果指定值 3，则向导将从数据文件的第三行开始查找数据。在此示例中，将忽略文件的前两行。您可以从可用选项中指定“提示”。如果指定“提示”，则每次使用向导导入文件时都会提示您定义导入的起始行。单击第 4 步中的“完成”按钮时会提示您。
至此行结束导入 | 指定向导在（已导入文件）哪一行停止读取数据。例如，如果指定值 500，则向导将搜索数据文件前 500 行的数据，并忽略第 500 行之后的所有行。您可以从可用选项中指定“提示”。如果指定“提示”，则系统会提示您定义每次使用向导导入文件时向导停止读取数据的行。单击第 4 步中的“完成”按钮时会提示您。
相对范围内的行 (Lines within Relative Range) | 指定相对于文件开头的导入起始行以及相对于文件末尾的导入结束行。如果您有两个不同长度的文件，且这两个文件都以“START”开头并以“END”结尾，则此选项十分有用。由于文件长度不同，因此仅定义导入的确切起始行和确切结束行是不够的。
在文件开头开始导入 (+) (Start Import at Start of File +) | 指定导入应从每个文件的开头开始指定的行数。
在文件末尾开始导入 (-) (Start Import at End of File -) | 指定导入应从每个文件的末尾结束指定的行数。
文件名 | 显示正在导入的文件的名称。
文件预览 | 显示正在导入的文件的预览。“文本导入向导 - 第 1 步”对话框中的文件预览最多显示 1000 行。但是，1000 行限制仅适用于预览，而不适用于实际导入。整个文件将在使用“文本导入向导”导入文件时进行处理。如果要导入非统一文件（请参考“文本导入向导 - 第 1 步”对话框中的“记录格式”选项），预览仅显示满足“文本导入向导 - 非统一记录信息”对话框中“包含 (Include)”设置的行。尽管这些设置出现在向导的后续对话框中，但确实可以应用于“文本导入向导 - 第 1 步”对话框中的预览，因为您可以使用“下一步”和“上一步”按钮定义这些设置并返回“第 1 步”对话框。如果要导入统一文件（请参考“记录格式”选项），预览将从“文本导入向导 - 第 1 步”对话框中“自此行开始导入 (Start Import at Row)”选项中指定的行开始，显示文件的 1000 个连续行。

文件选项

选项 | 描述
打开 | 显示“打开向导 (Open Wizard)”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。
保存 | 保存打开的向导。如果为先前未保存为 xin 文件的向导选择“保存”按钮，则会遵循“另存为”工作流。
另存为 | 保存向导，以便您可以使用它导入其他类似格式的文件。向导保存之后，下次调用“文本导入向导”命令时可以使用向导。
上一步 | 移动到向导中的上一步。
下一个 | 移动到向导中的下一步。
完成 | 使用当前定义的向导导入文件。
父主题: 从 ASCII 文件创建地形模型


导入文件

选择要导入的文件之后，将显示“导入选项”对话框。此对话框提供单位和地理坐标系的配置选项。

XYZ 文件
点云文件 (.POD)
LandXML
父主题: 可缩放的地形模型


组件特性

使用此对话框指定与模板组件关联的属性。

名称

指定当前组件的名称。使用“定位”按钮选择其他组件。

使用名称覆盖

指定选定组件的新名称。使用模板放置三维路面时，将使用新的组件名称。

描述

指定组件的描述。

样式

指定组件的特征样式。此选项用于显示以及定义组件的材质。有关详细信息，请参阅“样式管理器”主题。

闭合形状

此选项仅适用于非末端条件组件。只有闭合形状才能计算组件数量。

父组件

指定父组件。如果组件具有父组件，则仅在显示父组件时才显示该组件。父组件可以是非末端条件组件，也可以是末端条件组件。指定组件或使用“定位”按钮标识它。

显示规则

显示确定是否应显示组件的条件表达式。

编辑（显示规则）

激活显示规则对话框。

从三角网中排除

指定从三角网中排除从组件中的点创建的特征。但是，与未指定为从三角网中排除的组件共享的点将会三角形化。

末端条件属性

指定仅对末端条件组件可见的属性。

目标类型

指定末端条件将查找的目标类型。目标包括：

  • 曲面 - 查找曲面

  • 高程 - 查找特定高程

  • 特征 XY - 查找特定曲面特征的水平位置。

  • 特征高程 - 查找特定曲面特征的垂直位置。

  • 特征 XYZ - 查找特定曲面特征的位置。覆盖末端条件分段的坡度约束以查找特征。

  • 路线 XY - 查找特定路线的水平位置。

  • 路线高程 - 查找特定纵面路线的垂直位置，或者在没有纵面路线的情况下，使用平面几何高程。

  • 路线 XYZ - 查找特定路线的位置。覆盖末端条件分段的坡度约束以查找特征。

曲面/特征/路线

指定与目标类型关联的曲面。根据目标类型，可以使用“曲面”、“路线”或“曲面和特征 (Surface and Feature)”选项来设置目标信息。如果目标类型是“高程”，则此处不显示任何字段。

注释: 如果目标类型是“曲面”或其中一个“特征”目标类型，且您没有指定曲面名称，则 Roadway Designer 会话期间的曲面将成为激活曲面。有关目标别名的详细信息，请参阅 Roadway Designer 命令。

水平偏移

指定相对目标的水平偏移。仅当目标为水平目标或具有水平长宽比时，此选项才适用。

竖向偏移

指定相对目标的竖向偏移。仅当目标为垂直目标或具有垂直长宽比时，此选项才适用。对于高程目标，请在此处指定高程。

优先级

指定末端条件尝试求解的顺序。如果多个末端条件在同一点开始，则此值确定末端条件尝试求解的顺序。先尝试较小的数字。

工作台复选框

启用即指示重复末端条件分段的集合，直至找到解。

工作台计数

指示应该定边坡的最大次数。如果此值为 0，则重复次数无限制，定边坡末端条件必须找到其目标才会有效。在输入任何其他数字时，如果重复定边坡指定次数但未达到目标，并且连接到定边坡末端条件终点的末端条件成功，则定边坡末端条件仍视为成功。

自数据

启用即指示定边坡将使用基准高程和步长高程来设置定边坡，而非在定义时使用末端条件分段。

基准高程

指定构成步长高程基础的高程。基准 + 当前工作台高程 = n * 步长高程。

步长高程

指定使用基准时的定边坡增量。每个工作台高程始终位于定边坡末端条件的第一段末尾（或第二点）。

长度取整

指定用于对末端条件进行取整的长度。当此值不为 0.0 时，利用抛物线公式在末端条件末尾添加 4 个额外的点，以平滑末端条件与曲面相交处的过渡。仅当目标为曲面或高程时，此取整效应才适用。连接到此目标终点的任何其他末端条件连接到圆形剖面终点。

重叠/剥离属性

指定对重叠/剥离组件可见的属性。

顶部选项

指定如何定义组件顶部。

按照组件

指定组件顶部将跟随定义的组件顶部。

跟随曲面

指定组件顶部将跟随曲面。

按照最高

指定组件顶部将跟随组件或曲面中的最高者。

底部选项

指定如何定义组件底部。这些选项的行为可能不同，具体取决于所选的顶部选项。

按照组件

指定组件底部将跟随组件在定义深度的定义顶部，但不会超出组件顶部。

跟随曲面

指定组件底部将跟随定义深度的曲面，但不会越过组件顶部。

按照最低

指定组件底部将跟随定义深度的组件或曲面中的最低者。

按照最高

指定组件底部将跟随定义深度的组件或曲面中的最高者。

组件深度

设置位于定义的组件线下方的底部深度。此值不能为负。

曲面

定义要跟随的曲面。不支持混叠。

表面深度

设置位于表面下方的底部深度。此值不能为负。

备选底部表面

如果填充了此字段，当从 Roadway Designer 的“创建表面”命令创建备选表面时，此组件的底部将生成指定名称的备选表面。

标签（组件深度/表面深度）

用于从 Roadway Designer 中更改默认深度的参数化标签。

剥离组件

定义此组件用于移除材质还是添加材质。用于端部区域土方量。

应用

保存对组件所做的更改。

下一个

继续进行模板中的下一个组件（根据左上角范围点从左到右，从上到下排列）。

上一个

返回模板中的上一个组件。

父主题: 创建模板


设置

“设置”分支显示在“数据树”中的各个“数据文件”下，用于编辑设置信息。选择任何数据文件下的顶级“设置”分支将在详情面板中提供所有设置的详细信息。选择单个“设置”分支将仅显示该特定设置的详细信息。

父主题: 显示细节


项目设置

“项目设置”只有一个类别：“测量设置”。此类别在当前版本中不使用。

父主题: OpenRoads Designer 标准


文本导入向导 - 第 2 步

本部分介绍了“文本导入向导 - 第 2 步”对话框中的参数。

有关详细信息，请参考文本导入向导。

所有行 (All Lines) | 指定要读取的所有数据行均具有相同的格式。
起始行 (Lines that Start With) | 定义要导入的文件中的一系列行。一系列行仅包含以关联键入命令字段中指定的文本字符串开头的行。键入命令字段与“起始行 (Lines that Start With)”一起位于对话框的“包含”区域中。 键入文本字符串并按 Tab 键之后，键入命令的结果将显示在对话框底部的预览窗格中。预览仅显示满足“包含”设置（“起始行 (Lines that Start With)”或“包含的行 (Lines that Include)”的行，以及关联的键入命令）。
包含的行 (Lines that Include) | 定义要导入的文件中的一系列行。一系列行仅包含那些包括在关联键入命令字段中指定的文本字符串的行。键入命令字段与“包含的行 (Lines that Include)”一起位于对话框的“包含”区域中。 键入文本字符串并按 Tab 键之后，键入命令的结果将显示在对话框底部的预览窗格中。预览仅显示满足“包含”设置（“起始行 (Lines that Start With)”或“包含的行 (Lines that Include)”的行，以及关联的键入命令）。
文本段 (Segments of Text) | 对在指定的起始段文本之后、但在指定的末段文本之前出现的行应用过滤器。 通过“包含在导入中 (Include in Import)”开关，您可以选择导入时包含或排除起始段和末段文本行。
从导入中排除过滤的行 (Exclude Filtered Lines from Import) | 定义导入时要忽略的行或段。选择“起始行 (Lines that Start With)”、“包含的行 (Lines that Include)”或“文本段 (Segments of Text)”，并提供所需的文本。选中“从导入中排除过滤的行 (Exclude Filtered Lines from Import)”选项，并将过滤器添加到向导中。导入过程将忽略使用过滤器的每一行（无论它们出现在文件中的何处均是如此）。它可能出现在另一个文件内或过滤器之外，但仍会被忽略。启用此选项时，无需指定分隔符、列宽或列标题。因此在您定义另一个过滤器之前，“下一步”和“上一步”按钮均会禁用。
已定义的过滤器: (Defined Filters:) | 显示已添加到向导的过滤器列表。过滤器按其应用顺序列出。（有关详细信息，请参考文本导入向导中的“多个过滤器的运行方式”。） 单击列表中的项时，将使用选定过滤器的设置替换当前定义的过滤器的设置。
原始数据类型 (Original Data Type) |
固定宽度 | 指定将文件中的数据组织为列格式。
分隔 | 指定每行数据上的值由分隔符分隔。常见分隔符的示例包括逗号、空格、制表符和分号。
添加 | 将过滤器添加到向导，并将过滤器放入对话框的“包含”区域中的列表中。在完全定义过滤器之前，您无法将过滤器添加到列表中。这意味着您必须继续执行“文本导入向导”的工作流，定义过滤器的所有必需参数，然后再返回以单击“添加”按钮。
删除 | 从列表和您定义的向导中删除选定的过滤器。
更新 | 将当前设置应用于选定过滤器。 更新过滤器的工作流如下：1) 在对话框的“包含”区域的列表中选择过滤器，2) 更新“文本导入向导”的各种对话框上的设置，3) 单击“文本导入向导 - 非统一记录信息 (Non-Uniform Record Information)”对话框上的“更新”。
(文件名) | 显示正在导入的文件的名称。
(文件预览) | 在对话框的“包含”区域中应用过滤参数之后，显示正在导入的文件的预览。预览仅显示满足“包含”设置（“起始行 (Lines that Start With)”或“包含的行 (Lines that Include)”的行，以及关联的键入命令）。“文本导入向导 - 非统一记录信息 (Non-Uniform Record Information)”对话框中的文件预览最多显示 1000 行。但是，1000 行限制仅适用于预览，而不适用于实际导入。整个文件将在使用“文本导入向导”导入文件时进行处理。
打开 | 显示“打开向导 (Open Wizard)”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。
保存 | 保存打开的向导。如果为先前未保存为 xin 文件的向导选择“保存”按钮，则会遵循“另存为”工作流。
另存为 | 保存向导，以便您可以使用它导入其他类似格式的文件。
上一步 | 移动到向导中的上一步。
下一个 | 移动到向导中的下一步。
完成 | 使用当前定义的向导导入文件。
取消 | 关闭对话框，且不执行任何操作。您所做的选择和键入命令均不会保存。
帮助 | 显示帮助。
父主题: 从 ASCII 文件创建地形模型


添加约束（角度距离）

完全约束模板中的一个点。此约束需要两个父点、一个距离和一个角度。该点约束到由到第一个父点的距离以及与第一个父点所成的角度（相对于由两个父点定义的矢量）定义的位置。此约束产生刚体旋转。选中后，没有其他约束类型可用。有关约束的详细信息，请参阅创建模板概述。

角度

您可以修改约束角度。

距离

您可以修改约束距离。

确定

创建约束。

父主题: 添加约束


提取 TM 元素

通过选择“编辑”>“提取 TM 元素”，可以将 STM 的某些部分导出到 TM。此操作的分辨率为 1:1。

要确定待导出的区域，请从“区域”列表中选择选项，或单击“使用围栅”选项，然后从“边界”列表中选择选项。选项如下：

  • 区域：如果形状呈现凹形截面，则修剪形状轮廓以提取 TM。
  • 凸包：如果形状呈现凹形截面，则提取的 TM 将填充凹形区域以生成凸形。

确定区域时，如果达到最大点数，将显示警告。提取操作将应用于选定区域中的所有 STM，但只生成一个 TM。原始 STM 的属性用于生成 TM。如果在提取操作中使用了多个 STM，则会显示一个对话框，允许选择要使用的 STM 属性。

变量 STM_EXTRACTTM_USESUBRES 控制所使用的 STM 的分辨率。设置为 0 时，使用全分辨率。设置为 1 时，使用子分辨率。

父主题: 可缩放的地形模型


详细

功能区：“主页”>“基本”

详细

  • 键入命令
  • 保存的视图
  • 单元
  • 标记
  • 窗口列表

键入命令 - 打开“键入命令”窗口。

保存的视图 - 使用“保存的视图”对话框管理保存的视图。

单元 - 在单元库中创建和管理单元。

标记 - 通过“标记”对话框检查设计中所做的标注和备注。

窗口列表 - 显示与在资源管理器对话框的任何一个选项卡中选择的内容有关的信息

父主题: 基本


删除组件

删除多个组件。通过右键单击主视图来访问此命令。系统提示您单击并拖动要删除的组件。

父主题: 创建模板


任意线延长

用于从基准元素构造一条偏斜线。

您可以通过以下方式访问此工具：

  • 功能区：几何图形 > 平面 > 直线拆分按钮
  • 功能区：几何图形 > 纵断面 > 直线拆分按钮

工作流

  1. 单击“任意线延长”。将显示“任意线延长”对话框。对话框中的任何输入均可随时锁定。锁定某些值可能会限制或影响其他值。

  2. 选择基准元素。

  3. 指定用于计算的偏移。该偏移是相对基准元素的平行偏移。

  4. 指定起点。起点是新线与偏移线交叉的位置。

  5. 指定倾斜角度。请注意此提示右侧的开关。通过使用向左/向右箭头，还可以指定起点距离。起点距离沿相对偏移元素的偏斜测量。

  6. 指定终点距离。此距离沿相对偏移元素的偏斜测量。

工作流（偏斜为零时的特殊情况）

当偏斜锁定在零时，可以使用过渡选项。当起点距离和偏移也锁定在零时，这将特别有用。

  1. 单击“任意线延长”。将显示“任意线延长”对话框。

  2. 将偏移和偏斜设置并锁定为零。

  3. 选择基准元素。

  4. 指定用于计算的偏移（锁定在零）。

  5. 指定起点。起点是新线与偏移线交叉的位置。

  6. 由于倾斜角度和起点距离锁定在零，因此系统会提示您指定终点距离。

  7. 由于偏斜和偏移锁定在零，因此系统会提示您截断基准元素。

  8. 由于在对话框中指定了缓和曲线过渡段，因此生成的元素是缓和曲线复合元素。

对话框自定义

右键单击对话框可针对特定任务或用户首选项自定义对话框。

操控器

操控器可用于：

  • 相对基准元素的偏移

  • 倾斜角度

  • 起点距离

  • 终点距离

  • 拖曳图柄以动态调整起点和终点距离

属性

还可以在属性中访问“任意线延长”规则数据。

自定义工具

这些预先自定义的版本为许多常见的构造工具提供简化的提示序列。右键单击“任意线延长”图标，然后选择“在元素工具中显示/隐藏弧 (Show/Hide Arc from Element Tools)”以访问下列选项：

  • “切线延长”在零度倾斜角度从另一个元素创建不带任何过渡段的直线，仅当“延长 (From element)”为曲线且偏移锁定在零时，此选项才适用

  • “缓和曲线延长”在零度倾斜角度从另一个元素创建具有缓和曲线过渡段的直线，仅当“延长 (From element)”为曲线且偏移锁定在零时，此选项才适用

  • “曲线延长”在零度倾斜角度从另一个元素创建具有弧过渡段的直线，仅当“延长 (From element)”为曲线且偏移锁定在零时，此选项才适用。

  • “定角度延长”在定义的倾斜角度从另一个元素创建不带任何过渡段的直线，偏移锁定在零

父主题: 任意线延长工具


创建地形模型

在操作或编辑点云（根据需要）之后，下一步是创建地形模型。可以使用整个点云，也可以使用点云演示来限制对某些分类的导入，或者可以将围栅放置在相关区域中。围栅应在启动该工具之前放置。

该对话框的左上角支持两个工具：

设置 | 描述
重命名地形模型 | 重命名指定的地形模型。
移除地形模型 | 从列表中移除指定的地形模型。

该对话框的右窗格中支持以下选项：

  • 地形模型 - 此类选项指示激活 *.dgn 文件中是否已存在地形模型以及如何与要导入的数据组合。

  • 过滤器 - 对于大型数据集，过滤可能是一个十分有用的选项。

  • 特征定义 - 用于导入地形的特征定义。如果未选择任何选项，则使用激活线符绘制地形模型。

  • 地理坐标系 (GCS) - 如果软件可以确定要导入的文件的地理坐标系，则填充字段。如果设置为“未知”，则该软件将使用 MicroStation 设计单位。如果生成的地形模型需要位于不同的 GCS 中，则使用本部分。

按平铺 TIN 过滤

此工具支持两种过滤算法。一种基于平铺，另一种基于其他 TIN 或三角网。从经验研究来看，平铺算法更快，通常可以使文件大小减少 30% 到 50%。TIN 算法通常可以减少 70% 到 90%。

平铺算法是一种递归分治算法，它将 LIDAR 数据集划分为分块。为每个分块计算最佳拟合平面，如果 LIDAR 点落在用户设置的平面 Z 公差范围内，则将其移除。

如果 LIDAR 点落在三角形平面的用户设置 Z 公差范围内，则 TIN 算法会对其进行过滤。TIN 算法首先将 LIDAR 点平铺到具有最多 200 万个点的分块中，然后重复对每个分块进行三角形化以过滤点。此算法在具有 1 GB 内存的 1.67 GHz 计算机上运行，通常需要大约 12 分钟来过滤 3000 万个 LIDAR 点。

设置 | 描述
文件选项 | 平铺或 TIN 过滤器
Z 公差 | “Z 公差”对于两种算法都是通用的，基本上是在过滤过程中允许曲面在 Z 坐标中移动的变化。通常在第一次调用过滤函数时，对于英制数据集，Z 公差应设置为 0.5 到 1.0，对于公制数据集，应设置为 0.25 到 0.5。根据效果和所需结果，Z 公差可以上下变化。
最小平铺点（平铺） | 如果平铺的点数少于此数，则平铺不会细分。通常，此数量设置为 5。
最大平铺分界线（平铺） | 是指允许的递归级别，且是指初始平铺集可以细分的次数。通常，此数量设置为 5。
起始平铺长度（平铺） | 在递归到最小平铺点之前，LIDAR 数据集最初被分为该大小的分块。此参数的设置需要了解 LIDAR 点之间的距离，这需要检查 MicroStation 中的 LIDAR 点进行确定。通常将其设置为 LIDAR 点之间距离的 10 倍。
粗滤器 (TIN) | 过滤更多的点，且脊和山谷较模糊。
精滤器 (TIN) | 过滤更少的点，且脊和山谷较清晰。
重新插入点 (TIN) | 如果地形上的迭代过滤移除公差范围内的点，则重新插入点会再次添加点。例如，此过程可以移除山顶的点，第二次迭代可以移除高点周围的点，使得该点超出细化公差。迭代过程最多可发生五次。

工作流

  1. 打开或参考包含点云的 DGN 文件。
  2. 设置云的视图属性以显示地形模型中所需的所有点
  3. 可选择围绕点进行围栅提取。
  4. 从点云命令启动地形。
  5. 根据需要进行过滤。
  6. 设置“定义”和“三角网选项”特征。
  7. 数据点接受并构建地形模型，默认情况下命名为 Point Cloud Surface_1。
  8. 根据需要重命名地形模型。
父主题: 从点云创建


尺寸标注样式

有关详细信息，请参考 MicroStation 帮助的“绘图合成”>“注释”>“尺寸标注”>“尺寸标注样式”。

父主题: 尺寸标注样式
Relateds
https://docs.bentley.com


文件工具

使用这些命令可在模板设计会话期间管理数据文件。

选项

父主题: 创建模板

新建（文件夹）

使用此命令可在模板库的当前位置在库中创建一个新文件夹。

新建（模板）

使用此命令可在模板库的当前位置创建新模板。

新建（模板库）

使用此命令可创建新的模板库，然后打开该库。

文件（保存）

保存当前模板库。

文件（另存为）

将当前模板库保存为其他名称。

文件（关闭）（创建模板）

关闭创建模板对话框。如果已修改模板库，系统将提示您在退出之前保存所做的更改。


修复优先级

列出附加到某一特定点和每个对应优先级的末端条件。

优先权/末端条件组件

标识要修复的组件。选择优先级输入字段时，对应的末端条件组件将在测试窗口中高亮显示。

确定

接受所做的选择并关闭对话框。

取消

关闭对话框。所做的选择不会保存。

父主题: 创建模板


数据文件

选择“数据文件”分支时，所选数据文件的信息显示在详情面板中。可通过单击“名称”单元来编辑数据文件的名称。如果选择单个数据文件，将仅显示这一个数据文件。

父主题: 显示细节


添加新的重叠/剥离组件

向模板添加重叠/剥离组件。压碾由“重叠/剥离”组件处理。使用此命令处理所有压碾/剥离操作。此命令还可用于处理找平（重叠）操作。有关重叠/剥离的详细信息，请参阅创建模板概述。

当前组件

名称

指定新约束的名称。

特征

指定新组件的特征样式。此选项用于显示以及定义组件的材质。

顶部选项

指定如何定义组件顶部。

按照组件

指定组件顶部将跟随定义的组件顶部。

跟随曲面

指定组件顶部将跟随曲面。

按照最高

指定组件顶部将跟随定义段或曲面中的较高者。

底部选项

指定如何定义组件底部。这些选项的行为可能不同，具体取决于所选的顶部选项。

按照组件

指定组件底部将跟随组件在定义深度的定义顶部，但不会超出组件顶部。

跟随曲面

指定组件底部将跟随定义深度的曲面，但不会越过组件顶部。

按照最低

指定组件底部将跟随定义深度的组件/曲面中的较低者。

按照最高

指定组件底部将跟随定义深度的组件/曲面中的较高者。

组件深度

设置位于定义的组件线下方的底部深度。此值不能为负。

曲面

定义要跟随的曲面。不支持混叠。

表面深度

设置位于表面下方的底部深度。此值不能为负。

备选底部表面

如果填充了此字段，当从 Roadway Designer 的“创建表面”命令创建备选表面时，此组件的底部将生成指定名称的备选表面。

标签（组件深度/表面深度）

用于从“Roadway Designer”>“工具”>“参数化约束”中更改默认深度的参数化标签。

剥离组件

定义此组件用于移除材质还是添加材质。用于端部区域土方量。

父主题: 添加（组件）命令


多个过滤器的运行方式

本部分介绍了如何使用多个过滤器处理非统一数据文件，这些文件的各行显示不同的数据格式。

您定义的每个过滤器均可通过“文本导入向导 - 第 2 步”对话框中的“添加”按钮添加到向导中。添加过滤器的顺序非常重要，因为当该行满足多个过滤器时，该顺序将确定将哪个过滤器应用于特定行。

数据文件中的单行可以满足多个过滤器的条件。

该向导一次传输数据文件，一次读取一行。对于每一行，向导按照“文本导入向导 - 第 2 步”对话框中添加到列表的顺序应用过滤器。过滤器一次应用一个，直到其中一个过滤器成功匹配特定的数据行，或直到所有过滤器全部失败为止。当数据行满足在“文本导入向导 - 第 2 步”对话框中定义的过滤器的“包含”参数时，会发生匹配。

在数据行和过滤器之间发生匹配之后，将根据相应过滤器中指定的所有参数导入数据行。导入数据行之后，该向导将移到数据文件中的下一行。如果在尝试所有过滤器之后仍未发生匹配，则忽略数据行，向导将移到数据文件中的下一行

父主题: 从 ASCII 文件创建地形模型


编辑过渡段工作流

  1. 选择“编辑过渡段”工具。

  2. 选择要编辑的过渡段，将打开“编辑过渡段”对话框。

  3. 根据需要连接点。单击“确定”，将打开“编辑过渡段中点”对话框。

  4. 编辑组件。要返回“点连接 (Point Connection)”对话框，请单击“取消”。要完成过渡，请单击“确定”。

父主题: 编辑过渡段


添加约束（平面最小值）

部分约束模板中的一个点。平面最小值约束可确保子点具有两个父点并与最左边的父点保持给定的水平距离。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


创建模板概述

“创建模板”命令生成横向几何图形，这是路面设计的核心。模板由一系列点和组件组成，这些点和组件表示稍后使用 Roadway Designer 命令处理的切断线特征。已处理的路面特征将保存到设计曲面。模板存储在模板库 (*.itl) 中。

注释: 编辑“末端条件异常”时，只有模板以及所含模板具有末端条件的文件夹才会显示，并在模板库视图中可用。
注释: 在“激活模板”选项卡上，将某个组件拖到另一个组件的顶部以使其成为该组件的子组件，或将其拖到“组件”文件夹以移除其父组件。

模板点

模板的点表示使用 Roadway Designer 命令处理模板时将创建的切断线特征。点具有名称和特征样式；模板中的点数没有限制。在 Roadway Designer 中作为特征处理之后，它们将保存到设计曲面中。

注释: 选择“点”文件夹之后，文件夹/树视图下方将显示所有点的列表。可以使用 Shift 和 Ctrl 键功能选择多个点。右键菜单可用于编辑或删除点，更改样式和显示状态，以及设置“特征名称覆盖”。

模板组件

组件是一组定义开放或闭合形状的点。每个组件（无论是开放还是闭合）均可表示不同的材料或相关区域。组件已命名并具有分配的特征样式。在 InRoads 中已创建 6 种类型的组件：“简单”、“受约束”、“无约束”、“空点”、“末端条件”和“重叠/剥离”。

简单组件通常表示路面的剖面。它是一个由坡度和厚度定义的闭合平行四边形（4 个约束点）。受约束的组件由全部限制于第一点移动的点组成。约束点通常用于管理模板中其他点的行为。移动点（父项）时，任何约束点（子项）也会移动。此限制仅影响约束点的偏移和高程 (x,y)，且这种关系是单向的（子点的移动不会移动父点）。无约束的组件是开放或闭合形状，没有移动限制。空点是刻意与任何特定组件无关的模板点。它经常用作控制其他点的参考。末端条件是一个特殊的开放形状组件，它用于瞄准曲面、曲面特征、高程或路线（它替换以前的“剪切/填充”、“材料”和“决定”表）。现在，可以在创建路面模板时定期测试末端条件的完整性。重叠/剥离组件用于处理所有压碾/剥离类型操作，并且可用于处理调平（重叠）操作。

创建之后，可以根据需要修改组件。模板中的点或组件数量没有限制。当模板与平面和纵面路线以及超高配对时，它们将定义廊道的表面。模板是灵活的设计组件，既可用于对简单的构造（如沟渠和人行道）进行建模，也可对更为复杂的具有超高曲线和可变边坡的多车道高速公路进行建模。

在上述示例中，简单模板包含 20 个点和 15 个组件。

点约束

点约束用于管理模板中点的行为。使用点约束之后，如果在模板中移动点（无论是通过用户编辑模板移动点，还是通过在设计处理期间应用水平或垂直控制来移动点），则与移动点相关的所有点均会采取合理且可预测的行为。

点约束是二维和单向的约束。二维意味着约束只能影响点偏移和高程（横截面视图中的 x 和 y 坐标）。单向意味着点之间存在子-父关系。换句话说，如果点 B 受点 A 约束，则点 A 称为点 B 的父项，移动点 A 将影响点 B，但是移动点 B 无法影响点 A。在以下示例中，淡蓝色箭头表示从点 A 到点 B 的父/子关系：

一个点最多可以有 2 个约束。在该点处，它称为“完全约束”。完全约束的点由红色加号表示：

一个部分受约束的点，意味着它只有一个约束，显示为黄色加号：

无约束点显示为绿色加号：

也可以标记约束，以便在处理期间可以更改标记约束的值。例如，模板可以具有称为“厚度”的约束标签，用于控制沥青磨损表面的厚度。稍后，可以在设计过程中在一个或多个桩号范围内更改此厚度。

约束类型

InRoads 为路面模板设计（“平面”、“平面最大值”、“平面最小值”、“纵面”、“纵面最大值”、“纵面最小值”、“坡度”、“矢量偏移”、“对表面进行投影”、“对设计进行投影”、“角度距离”）提供了各种约束类型，如下所述：

平面

子点与父点保持给定的水平距离。

平面最大值

子点具有两个父点并与最右边的父点（具有平面最大值或 X 值）保持给定的水平距离。

平面最小值

子点具有两个父点，并且保持在距离最左侧的父点（具有平面最小值或 X 值）的给定水平距离处。

纵面

子点保持在距父点的给定垂直距离处。

纵面最大值

子点具有两个父点，保持在距最高的父点（具有纵面最大值或 Y 值）的给定垂直距离处。

纵面最小值

子点具有两个父点并与最右边的父点（具有纵面最小值或 Y 值）保持给定的水平距离。

坡度

子点与父点保持给定的坡度。此外，可以为坡度约束分配翻转值。翻转值用于根据高侧坡差和低侧坡差设置坡度约束，并设置用于定义父点控制坡度的参考点。有关翻转控制的更多详细信息，请参阅应用水平段翻转锁定主题。坡度约束是绝对值。无论子点位于父点的左侧还是右侧，从左下角到右上角的斜率均为正。

矢量偏移

该子点具有两个父点并投影到由两个父点定义的矢量。如果偏移量不是零，则子点在指定的偏移值与父矢量保持垂直偏移。负值表示偏移到由父点定义的矢量左侧。正值表示偏移到右侧。

对表面进行投影

此约束必须与先前定义的约束之一结合使用。另一个约束将定义投影方向。稍后，在处理设计时，将使用给定的名称或参数标签将子点投影到表面。如果表面不存在，或者找不到解决方案，则该点将保留在模板中放置的位置。

对设计进行投影

此约束类似于“对设计进行投影”，但该点投影到模板的设计曲面。给出投影值以指示投影是向左还是向右。该点还必须受先前约束之一的约束（不包括“对表面进行投影”），以便可以确定投影的方向。负值将投影限制在 0 的左侧；正值将投影限制在右侧。值 0 将在 0 的左侧和右侧查找以投影该点。如果找不到解决方案，则该点将保留在模板中放置的位置。

角度距离

此约束具有两个父点、一个距离和角度。稍后，选定的点完全约束到由第一个父点定义的位置，以及与第一个父点所成的角度（相对于由两个父点定义的矢量）定义的位置。此约束产生刚体旋转。选中后，没有其他约束类型可用。

应用水平段翻转锁定
父主题: 创建模板
相关概念
应用水平段翻转锁定


土木单元

此分支列出了所有已创建的、在激活设计模型或 DGN 库文件中可用的标准土木单元。土木单元是先前存储的土木对象的集合，这些对象使用灵活但明确定义的规则创建，可在许多项目中重复使用。

土木单元通常存储在一个或多个 DGNLIB 文件中，访问方式类似于 MicroStation 单元或环形交叉口。对于列出的任何土木单元，可以通过右键单击来放置所选土木单元。该命令提示根据需要在所选土木单元的定义中选择外部组件。

父主题: OpenRoads Designer 标准


径向反向点

  1. 选择“反转点”工具。
  2. 在工具设置窗口中，进行以下设置。

    将“输入类型”设置为“径向”。

    或

    如果高程可用且需要增量高程，请打开三维。

    或

    （可选）在工具设置中设置注释和保存选项。

    或

    如果需要在土木工程报告浏览器中显示反向报告，请打开“发送选项 (Send Option)”。

    或

    如果使用现有测量数据，请打开“使用点名称”。

  3. 按照危险警告提示操作：

    危险警告提示

    用户响应

    输入类型

    点击确认（已在“工具设置”中设置）。

    输入径向起点

    点击确认或输入测量点名称。移动光标时会将动态距离/方向数据连接到光标。

    输入半径点（可在下方提示字段查看，而不是警告提示）

    点击确认或输入第二个点的测量点名称。继续根据需要输入点。支持数据点和测量点混合输入。

    重置

    如果已打开选项，结束工具并打开土木工程报告浏览器。

父主题: 反转点


工作流: 使用向导导入文件

本部分介绍了使用向导导入文件的步骤。此工作流假设您已创建可用于导入特定文件类型的向导。

  1. 调用“文本导入向导”命令。

  2. 指定文件包含的数据类型（数据类型）。

  3. 选择用于导入文件的向导（向导名称）。

  4. 单击“确定”导入文件。

  1. 选择“文件”>“文本导入向导”命令。

    将显示“文本导入向导”对话框。

  2. 将“向导名称”设置为 <New>，指定相应的数据类型以及要导入的文件名称。

  3. 单击“确定”。

    将显示“文本导入向导 - 第 1 步”对话框。

  4. 设置“范围内的行 (Lines within Range)”或“相对范围内的行 (Lines within Relative Range)”以指定文件中的哪些行包含实际数据。

  5. 单击“下一步”。

    将显示“文本导入向导 - 第 2 步”对话框。

  6. 定义如何应用过滤器、定义原始数据类型和查看已定义的过滤器。

  7. 单击“下一步”。

    将显示“文本导入向导 - 第 3 步(固定宽度)”对话框。

    或

    将显示“文本导入向导 - 第 3 步(分隔符)”对话框。

    显示的对话框取决于您在“文本导入向导 - 第 2 步”对话框中定义的原始数据类型。

  8. 提供定义的数据类型所需的信息。

    将显示“文本导入向导 - 第 4 步”对话框。

  9. 定义要导入的文件中每列数据的内容。

  10. 单击“完成”。

父主题: 从 ASCII 文件创建地形模型


标注组

父主题: OpenRoads Designer 标准


闭合形状

当添加新组件时，使用此命令以将组件绘制为闭合形状。此选项对末端条件组件不起作用。

父主题: 添加（组件）命令


“按文本内插创建”工作流

工作流

  1. 打开一个二维 DGN 文件，其中包含表示地形特征的高程文本元素和线性元素。
  2. 通过“文本级内插”工具选择“地形模型”。
  3. 设置要创建的地形模型的“特征定义”和“名称”。
  4. 设置“边方法”。
  5. 如果需要创建过滤器或过滤器组，请单击“地形过滤器管理器”。
  6. 创建过滤器以表示点文本和所需线条的线性特征。
  7. 单击“完成”以关闭“地形过滤器管理器”对话框，该对话框将自动返回到“地形模型”工具。
  8. 打开“附加到地形”（如果需要）并选择要附加的地形。
  9. 为点选择过滤器或过滤器组。
  10. 为切断线选择过滤器或过滤器组。
  11. 设置“搜索公差”。
  12. 打开“包括文本作为高程标注 (Include Text as Spot Elevations)”。
  13. 用于创建地形模型的数据点。
父主题: 按文本内插创建


创建过渡段上下文相关菜单

创建过渡段之后，可以通过上下文相关菜单访问常用工具。

工具 | 描述
属性 | 弹出显示包括间距、构成过渡段的两个模板名称和桩号范围。
编辑过渡段 | 启动“编辑过渡段”工具，打开“编辑过渡段”对话框，其中显示当前过渡段。
删除 | 删除三维路面。
父主题: 创建过渡段


添加约束（纵面最小值）

使用此命令部分约束模板中的一个点。纵面最小值约束可确保子点具有两个父点并与最低的父点保持给定的垂直距离。有关约束的详细信息，请参阅创建模板概述主题。

父主题: 添加约束


视距分析对话框选项

您可以通过以下方式访问此工具：

功能区：地形 > 分析

参数 | 描述
锁定到起点 |
起点 | 指定第一个视线分析的起点桩号。 注释: 将终点桩号设置为小于起点桩号可按相反方向进行分析。当终点桩号小于起点桩号时，偏移相对于行进方向。因此，无需因行进方向改变而更改偏移的符号（负或正）。
锁定到终点 |
停止 | 指定最后一个视线分析的桩号。 注释: 将终点桩号设置为小于起点桩号可按相反方向进行分析。当终点桩号小于起点桩号时，偏移相对于行进方向。因此，无需因行进方向改变而更改偏移的符号（负或正）。
设置文件名 | 指定用于预填充对话框上各设置的文件。执行工具时，将使用对话框上的实际设置。使用设置文件只是为了快速预填充对话框。
可视性类型 | 列出在设置文件中找到的所有速度表。更改可视性类型将更改可用速度表条目的列表。此外，当更改可视性类型时，还会更改“移动目标”、“间隔”、“偏移”和“高度”的“视点位置”和“对象位置”设置。
速度 | 列出在设置文件中找到的对应于选定可视性类型的所有速度表条目。更改速度将根据选定的可视性类型和速度更改“规定距离”和“松弛距离”。
规定距离 | 指定必须实现的视线距离。
松弛距离 | 指定当实现的视线距离大于或等于“已放宽的视线距离”且小于所需的视线距离时，视为松弛距离的视线距离。
视点位置 | 视点位置的 XY 位置的计算方法为：将桩号沿控制参考方向投影到视点参考路线，然后应用偏移。视点位置所用的高程由指定设计曲面在视点位置的 XY 位置处的高程确定。
间隔 | 指定计算视线所使用的沿控制路线的间隔。
偏移 | 指定距视点参考路线的偏移。相对于行进方向而言，负偏移在视点参考路线的左侧。
高度 | 指定视点位置高程距选定的最高曲面的偏移值。
对象位置 |
移动目标以实现可视性 | 对象位置的 XY 位置计算方法与视点位置类似。但是，对于对象位置，位置将从视点位置开始沿参考路线下降，下降距离等于“规定距离”。 注释: 当“移动目标”为“打开”时，将针对每个对象位置间隔分析视线，直至该视点位置实现规定距离或者找到与设计或现有地形或网格的交点。如果找到了交点但未实现所需的视线距离，分析将显示该视点位置的最后一个成功的视线。
间隔 | 指定计算视线所使用的沿控制路线的间隔。 注释: 仅在“移动目标”为“关闭”时使用。
偏移 | 指定距对象参考路线的偏移。相对于行进方向而言，负偏移在对象参考路线的左侧。
高度 | 指定对象位置高程距选定的最高曲面的偏移值。
特征 |
特征定义 | 选择描述所创建元素的特征定义。 用作所创建元素的符号的基础。
名称 | 所创建元素的名称，缺省值基于“特征定义”设置。根据需要使用新名称覆盖此值。

工作流

定位廊道或路线

廊道

可以使用廊道中心线作为参考线。使用廊道顶网格作为设计曲面。

定位视线控制路线

指定中心线或其他特征。

重置以使用主路线

指定视点位置距中心线的偏移。

定位现有曲面

重置以跳过

验证可视性类型。

输入速度值

规定距离

松弛距离

将显示“视距分析报告”。

父主题: 视距分析


点特征

当在“数据树”中选择“点特征”分支时，“显示面板”将列出项目中的所有点以供查看/编辑。

注释: 此为点信息；如果需要观测原始数据，则必须选择观测分支。

展开“点特征”分支，然后选择单个特征样式以便仅显示该类型的点。例如，当选择特征 BLDS 时，列表中仅显示具有特征 BLDS 的点，如下所示。

父主题: 显示细节


网格

参数 | 描述
体积选项 | 选项包括“无”、“设计”、“现有”、“底土”和“路基”。
表面特征符号 | 用于绘制网格的线符。
父主题: 特征定义


删除组件

删除选定的组件。通过右键单击主视图中的组件来访问此命令。

父主题: 创建模板


从所有点删除约束

删除模板中所有点的约束。通过右键单击主视图来访问此命令。

父主题: 创建模板


添加约束（坡度）

部分约束模板中的一个点。坡度约束可确保子点保持父点的给定坡度。有关约束的详细信息，请参阅创建模板概述。

父主题: 添加约束


点云文件 (.POD)

点云文件可以处理为 STM 文件，但文件中的数据应来自卫星源，因为地面 LIDAR 数据通常不表示地形，因此该数据无法提供理想的结果。当 POD 文件已嵌入分类信息时，仅考虑与地形分类对应的点。

父主题: 导入文件


特征定义

特征定义可用于在所有可能的查看场景中定义特征线符和显示、元素命名、自动选择模板、区域数量计算属性以及其他属性。

“特征定义”部分

由于每种元素类型都有不同的参数，因此“属性”对话框各不相同。但是，“特征定义”部分是所有元素共有的。

参数 | 描述
名称 | 特征定义的名称
描述 | 描述
名称种子 | 用于默认命名。如果文件中有多个元素，则名称种子将会递增。
路线
地形
廊道
超高
线性模板
表面模板
线性
点
网格
父主题: OpenRoads Designer 标准


层显示

功能区：“主页”>“基本”

层显示

使用“层显示”对话框打开和关闭层。

父主题: 基本


修改现有文本导入向导

有两种编辑向导方法。

  • “文本导入向导”初始对话框中的“编辑”按钮显示文本导入向导，其中已打开选定向导。可以对此向导进行任意数量的编辑。您可以保存向导，可以使用其他名称保存向导，或者只需完成导入过程以及对向导的修改，而无需永久修改向导。

  • 向导创建对话框的“打开”按钮显示“打开向导 (Open Wizard)”对话框，用于在向导创建过程中打开现有向导。系统将提示您保存对当前向导的任何更改。

父主题: 从 ASCII 文件创建地形模型


向 STM 文件添加高程数据

完成新的 STM 设置后，将附加一个新文件，创建一个新的空 STM 文件，然后打开 STM 高程源编辑器对话框。

父主题: 可缩放的地形模型


Key-in Index

ARRAY ICON

ARRAY PATH

ARRAY POLAR

ARRAY RECTANGULAR

COPY ICON

DIALOG PROPERTIES < OPEN | CLOSE | TOGGLE >

DROP COMPLEX

DROP FENCE

FENCE ARRAY PATH

FENCE ARRAY POLAR

FENCE ARRAY RECTANGULAR

FENCE DELETE

FENCE ICON

[ FENCE ] MOVE [ ELEMENT ]

[ FENCE ] [ ROTATE | SPIN ] [ COPY | ORIGINAL | POINTS ] [ COPY | ORIGINAL ]

[ FENCE ] SCALE [ POINTS ] [ COPY | ORIGINAL ]

GEOCOORDINATE DIALOG

GOOGLEEARTH PLACEMARK DELETE

MIRROR ICON

MOVE ICON

< MOVE | MODIFY > FENCE

ROTATE ICON

SCALE ICON

[FENCE] COPY [ELEMENT]

[FENCE] MIRROR [ COPY | ORIGINAL ] [ HORIZONTAL | LINE | VERTICAL ]


查找：


“首选项”对话框：“输入”分类

上次更新时间： 2019 年 1 月 30 日

由用于设置键控输入和指针拖曳操作首选项的控件组成。

设置 | 描述
禁止拖曳操作 | 如果打开，当指针位于视图中时，本产品将放弃数据按钮操作。按数据按钮时在指针位置输入一个数据点，但在松开数据按钮时不输入第二个数据点。缺省值为关闭。
ESC 退出命令 | 如果打开，按 <ESC> 将停用选定工具并激活在“外观”分类中选择的“缺省工具”。缺省值为关闭。
定位公差 设置在搜索元素时指针周围的搜索区域大小。缺省值为 10 像素。
SET LOCATE TOLERANCE
按 Enter 键显示键入命令浏览器 | 如果打开，按 <Enter> 将显示键入命令窗口。缺省设置为“打开”。
指针大小 设置指针十字光标的大小。可以设置为“普通”或“充满视图”。缺省值为“普通”。
SET CURSOR [ SMALL | FULL ]
指针类型 控制指针十字光标的对齐方式：
  • 正交 — 传统十字 (+) 指针（缺省）。
  • 轴测视图 — 十字光标与轴测绘图平面对齐（顶部、左侧、右侧或全部）。
SET CURSOR [ ISOMETRIC | ORTHOGONAL ]
单击灵敏度 调整如何将主动单击解释为对数据点的拖曳操作。
  • 普通（缺省）
  • 快速
  • 慢速 — 这是用于数字化板设备的最佳选择。对于数字化板设备，有时会将单击解释为单击并拖曳，该操作将导致放置额外的数据点。使用此设置可消除这个问题。
  • 笔 — 这是用于笔输入设备的最佳选择，因为本产品会极为主动地随拖曳移动而解释输入。
重置弹出菜单 设置用于显示“重置”弹出菜单的“重置”按钮操作。
  • 按住 — 在指定的“按住延迟”持续时间内按住“重置”按钮即会显示该菜单。单击“重置”按钮将进入重置操作。这是缺省值。
  • 单击 — 单击“重置”按钮将显示该菜单。
按住延迟 设置时间间隔（以滴答数计，每秒钟滴答 60 次），在此间隔内必须按住“重置”按钮才会显示“重置”弹出菜单。缺省值为滴答 10 次（0.17 秒）。

将“重置弹出菜单”设置为“单击”时，“按住延迟”首选项不会影响该菜单的操作，且“按住延迟”滑块控件处于禁用状态。


“属性”对话框

键入: DIALOG PROPERTIES < OPEN | CLOSE | TOGGLE >

注释: 如果元素具有关联，关联将在对话框顶部窗格中按关联类型列出并分组。

注释: 如果字段及其设置以灰色文本显示，则表示该值为只读，无法修改。

设置 描述
常规 显示所选元素、激活模型或打开的 DGN 文件的常规属性。
  • 注释目的
  • 注释比例
  • 单元名
  • 创建日期
  • 出图日期
  • 保存日期
  • 描述
  • 设计修订数
  • 设计修订
  • 编辑器
  • 文件名 - DGN 文件的文件名和路径。
  • 文件大小 - DGN 文件的大小。
  • 格式
  • 已激活
  • 是注释
  • 标注
  • 已保存的视图
  • 上次保存者
  • 名称
  • 元素数
  • 修订号 - DGN 文件已编辑和保存的次数。
  • 类型 — 元素或模型类型。
几何图形 显示所选元素的几何属性。
  • 仿射
  • 角度
  • 面积 — 确定闭合元素是实体还是。
  • 激活 Z 深度
  • 长宽比
  • 轴比率
  • 后部裁剪
  • 向后深度
  • 背景色
  • 底部裁剪
  • 底部高度
  • 边界数据
  • 边界边数
  • 相机位置
  • 中心
  • 圆心 1
  • 圆心 2
  • 剪切原点
  • 剪切宽度
  • 闭合
  • 控制网
  • 控制点数据
  • 控制点数据 > 实际已闭合
  • 控制点数据 > 行数
  • 控制点数据 > 列数
  • 控制点数据 > 行索引
  • 控制点数据 > 列索引
  • 控制点数据 > 控制点数
  • 控制点数据 > 行大小
  • 控制点数据 > 列大小
  • 控制点数据 > 控制点
  • 控制点数据 > 控制点 > 点
  • 控制点数据 > 控制点 > 线宽
  • 控制点数据 > 线宽
  • 控制点数据 > 线宽 > 点
  • 控制点数据 > 线宽 > 线宽
  • 控制多边形
  • 计数
  • 增量 X
  • 增量 Y
  • 增量 Z
  • 尺寸
  • 方向
  • 有向矢量
  • DPI
  • 边数
  • 高度
  • 高度角
  • 终点
  • 结束角
  • 结束点数据
  • 结束点数据 > 点
  • 结束点数据 > 相切方法
  • 结束点数据 > 相切源
  • 结束点数据 > 相切
  • 终点
  • 范围
  • 面数
  • 面数据
  • 填充点数据
  • 填充点数据 > 实际已闭合
  • 填充点数据 > 填充点数
  • 填充点数据 > 填充点
  • 前部裁剪
  • 前部深度
  • 地理编码
  • 地理优先级
  • 隐藏边数
  • 内部边数
  • 结点数据
  • 结点数据 > 统一
  • 结点数据 > 结点数
  • 结点数据 > 结点
  • 结点数据 > 结点，重数 > 值
  • 结点数据 > 结点，重数 > 重数
  • 左侧裁剪
  • 长度
  • 法线
  • 像素数
  • 阶数
  • 方位
  • 原点
  • 周长
  • 定时
  • 像素大小
  • 平面的
  • 平面距离
  • 点云 > 公差
  • 点云 > 投影到剖切面
  • 保留
  • 长轴
  • 主矢量
  • 半径 1
  • 半径 2
  • 有理
  • 右侧裁剪
  • 旋转
  • 绕 X 轴旋转
  • 绕 Y 轴旋转
  • 绕 Z 轴旋转
  • 缩放
  • 缩放 X 轴
  • 缩放 Y 轴
  • 缩放 Z 轴
  • 短轴
  • 辅矢量
  • 线段
  • 起点
  • 起始角
  • 起始点数据
  • 起始点数据 > 点
  • 起始点数据 > 相切方法
  • 起始点数据 > 相切源
  • 起始点数据 > 相切
  • 起点
  • 表面积
  • 扫角
  • 顶部高度
  • 总高程
  • 总长度
  • 顶部裁剪
  • U 数据
  • 用户原点
  • V 数据
  • 视图索引
  • 顶点数
  • 顶点数据
  • 体积块
材质 显示所选元素的材质属性。

  • 面连接
  • 已分配材质
  • 连接材质
扩展 显示所选元素的扩展属性。
  • 终端端帽
  • 节点
  • 上次修改时间
  • 线型参数
  • 线型参数 > 比例
  • 线型参数 > 宽度模式
  • 线型参数 > 起始宽度
  • 线型参数 > 结尾宽度
  • 线型参数 > 恒定宽度
  • 线型参数 > 真实宽度
  • 线型参数 > 移位模式
  • 线型参数 > 移位
  • 线型参数 > 分数相
  • 线型参数 > 角模式
  • 已锁定
  • 模型
  • 已修改
  • 新建
  • 轮廓数
  • 轮廓
  • 可捕捉
  • 实体
  • 始端端帽
  • 厚度 — 为平面元素提供厚度。如果值为正数，则在正 Z（全局）方向上应用厚度；如果值为负数，则在负 Z 方向上应用厚度。缺省情况下，厚度值为零。即使在应用厚度后，本机元素类型仍保持不变。通过提供非零厚度值，可以使用厚度属性在除用于绘制平面元素的视图窗口以外的视图窗口中可视化该平面元素。
  • 视图相关
原始数据 显示所选元素的原始数据属性。
  • 元素 ID
  • 文件位置
  • 范围是否动态显示
  • 为范围下限
  • 链接
  • 范围上限
  • 大小
  • XAttribute
格式设置 显示所选元素的文本格式特定属性。
  • 是注释
  • 原点
  • 用户原点
内容 显示所选元素的文本特定属性。
  • 文本串
  • 文本样式
  • 垂直
组 显示与所选元素关联的分组属性。
  • 图形组
工作单位 显示所选模型的工作单位属性。
  • 精度
  • 格式
  • 主单位
  • 主单位标签
  • 子单位
  • 子单位标签
单元 显示所选模型的单元属性。
图纸 显示的属性。
  • 显示边界
  • 图纸编号
  • 序号
  • 边框连接
  • 图纸大小
  • 宽度
  • 高度
  • 原点
  • 旋转
  • 图纸索引
绘图属性 显示所选绘图模型的属性。
  • 参考 - 在绘图模型中连接的参考的详细信息，如逻辑名称、文件名和描述。
  • 视图类型 - 保存的视图的类型。
  • 视图名称 - 保存的视图的名称。
  • 领域 - 绘图的领域。
  • 用途 - 保存的视图的用途。
断点 显示用于向表应用断点的属性。
  • 中断类型
文本样式 显示表中文本的文本样式的属性。
  • 物体
  • 缺省文本线宽
父主题: “地理坐标系”对话框


“重投影设置”对话框

用于指定重投影设置。您可以通过此选项卡以不同方式为参考和激活模型设置重投影设置。

您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框：选择编辑重投影设置图标

设置 | 描述
笔划公差 | 指定表示曲线元素的线串近似的弦与精确曲线之间的最大允许间隔。单位采用激活模型的主单位。数值越小，近似就越精细，但算法也会越慢。“笔划公差”用于所有笔划选项。
逐个重投影单元组件 | 确定是否应逐个重投影各单元组件。始终重投影每个单元中的每个元素。从不将所有元素视为单个图元。缺省值“所占空间较大时”将重投影在 X-Y 平面内所占的面积超过 0.2 平方千米的单元的每个组件，并将较小的单元视为单个图元。 对于表示人造单位（例如变压器箱或停车场光线）的单元，最好逐个重投影每个组件元素。对于出于方便而分组为一个单元的地理要素，最好在单元原点计算最佳线性转换，然后将转换应用于所有组件，并将此单元视为单个图元。
逐个重投影多行文本组件 | 确定是否应逐个重投影多行文本组件（文本节点）。始终重投影多行文本中的每个文本元素。从不将所有文本元素视为单个图元。缺省值“所占空间较大时”将重投影在 X-Y 平面内所占的面积超过 0.2 平方千米的多行文本的每个文本组件，并将较小的单元视为单个图元。
旋转单元 | 按在单元原点算出的地理坐标系会聚角旋转单元。缺省设置为“是”。
缩放单元 | 按在单元原点算出的地理坐标系比例因子缩放单元。缺省设置为“是”。
旋转文本元素 | 按在单元原点算出的地理坐标系会聚角旋转文本元素。缺省设置为“是”。
缩放文本元素 | 按在单元原点算出的地理坐标系比例因子缩放文本元素。缺省设置为“是”。
在行字符串下划弧 | 在线串近似下划弧（近似的精度取决于“笔划公差”设置），然后重投影线串中的各点；弧将失去其作为弧的标识。在许多重投影过程中，弧的路径并不保持弧的形状。该设置可以设为“始终”、“从不”和“所占空间较大时”（缺省值）。 如果不划弧，系统将计算最佳拟合重投影弧。
在行字符串下划椭圆 | 在线串近似下划椭圆（近似的精度取决于“笔划公差”设置），然后重投影线串中的各点；椭圆将失去其作为椭圆的标识。在许多重投影过程中，椭圆的路径并不保持椭圆的形状。该设置可以设为“始终”、“从不”和“所占空间较大时”（缺省值）。 如果不划椭圆，系统将计算最佳拟合重投影椭圆。
在行字符串下划曲线 | 在线串近似下划 Akima 曲线元素（元素类型 11）（近似的精度取决于“笔划公差”设置），然后重投影线串中的各点；Akima 曲线元素将失去其作为 Akima 曲线元素的标识。在许多重投影过程中，Akima 曲线元素的路径并不保持 Akima 曲线元素的形状。该设置可以设为“始终”、“从不”和“所占空间较大时”（缺省值）。 如果不划 Akima 曲线元素，系统将计算最佳拟合重投影 Akima 曲线元素。
重投影仰角 | 如果打开并且使用三维坐标系，则当源地理坐标系与目标地理坐标系的基准或大地水准面标高不同时， OpenRoads Designer 会更正坐标 Z 值。如果关闭，则 Z 值将保持不变。缺省设置是保持 Z 值不变。
需要时添加点 | 沿线插入点，使该线在“笔划公差”设置范围内保持在正确的路径上。这样做不但可提高质量，还可控制线段在一个投影中显示为直线而在另一个投影中显示为曲线的情况，但这会延长处理器的处理时间。例如，对于等纬度线，其在“等距圆柱”投影中为水平直线，但在“兰勃特等角圆锥”投影中则为半径可变的圆弧。如果在使用“等距圆柱”投影的设计中由一条长线来表示完全沿平行线绘制的特定边界，则当重投影到“兰勃特等角圆锥”投影时，端点将重投影，但仍显示为直线。
父主题: 从文件创建


选择地理坐标系

打开“地理坐标系”对话框，您可以在其中从预定义的地理坐标系库中选择一个地理坐标系 (GCS)。

键入: GEOCOORDINATE DIALOG
父主题: 从文件创建


“选择地理坐标系”对话框

用于从 OpenRoads Designer 随附的预定义库中选择一个地理坐标系 (GCS)。这在以下情况下非常有用：

  • 现有数据采用地理坐标系进行了绘制（例如，省/自治区/直辖市平面或国家/地区网格坐标系），并且您希望 OpenRoads Designer 注意到该 GCS。
  • 数据已采用指定的 GCS 正确绘制，但您想将该数据重投影到其他 GCS。
  • 您希望为新设计文件指定 GCS。
您可以通过以下方式访问此对话框：
  • “地理坐标系”对话框：选择从库图标

设置 | 描述
“库”选项卡 | 库选项卡中包含分类的地理坐标系。
“搜索”选项卡 | 搜索选项卡中包含用于搜索地理坐标系的控制选项。
父主题: 从文件创建

“选择地理坐标系”话框：“库”选项卡

包含用于从显示地理坐标系组的树中选择地理坐标系 (GCS) 的控件。

选择地理坐标系：“库”选项卡

设置 | 描述
收藏夹 | 包含您或管理员预留用于快速访问的地理坐标系。您可以在“收藏夹”文件夹中添加和移除地理坐标系。
库 | 将地理坐标系分为两组：地理（使用经纬度坐标）和投影。GCS 按地理进一步分为若干个子组。选定 GCS 的属性在右侧窗格中显示为只读。这些属性与“地理坐标系属性”对话框中的属性相同。 您还可以使用包含用户定义的基准和椭圆体的用户定义 GCS。您可以成功打开使用包含用户定义椭圆体或基准的 GCS 的设计文件，而无需访问包含 GCS 的 GCS 库。唯一的限制是，某些椭圆体和/或基准参数（例如“源”）的值需要能够访问库。因此，当库不可用时，这些参数的值在“地理坐标系属性”对话框中将为空值。但是，这并不会引起任何操作问题。

从库中选择地理坐标系

  1. 在“地理坐标系”对话框中，选择从库图标。

    将打开选择地理坐标系对话框。

  2. 执行以下操作之一：

    展开库并双击一个 GCS。

    或

    选择一个 GCS 并单击确定。

向收藏夹文件夹添加地理坐标系

执行以下操作之一：

从“库”文件夹中选择一个地理坐标系，然后将其拖曳到“收藏夹”文件夹中。

或

右键单击 GCS，然后从弹出菜单中选择添加到收藏夹。

“选择地理坐标系”对话框：“搜索”选项卡

包含的控件可用于输入预计在名称、说明、源、基准或椭圆体名称中包含的字符串，从而在库中快速找到地理坐标系 (GCS)。如果字符串包含多个单词，会根据匹配单词的数量确定结果的优先顺序。搜索字符串不区分大小写，但包含精确的输入字符串的匹配项排序更高。

  • 要将结果排序，可单击列标题。结果将根据列内容按升序或降序排序。再次单击列标题将按相反顺序排序。
  • 要重新对列进行排列，可单击列标题并将其拖曳到新位置。
  • 要选择 GCS，可双击其名称，或将其选中然后单击确定。

选择地理坐标系：“搜索”选项卡

设置 | 描述
搜索文本 | 定义搜索字符串。
任何单词 | 指定结果可包含字符串中的任何单词。
所有单词 | 指定结果必须包含字符串中的所有单词。
立即查找 | 开始搜索。
停止 | 停止搜索。
结果 | 按关键字名称和说明、单位、投影、EPSG 代码、基准和椭圆体名称显示所有地理坐标系。 由于某些 GCS 参数是线性度量或笛卡尔坐标（例如“东移假定值”和“北移假定值”），并且因为投影数学需要使用笛卡尔坐标单位作为计算的输入项或输出项，因此将显示线性单位（例如米）。 OpenRoads Designer 的单位系统能够将模型中的线性单位转换为任何投影地理坐标系的单位，因此 GCS 的单位不需要与模型的单位匹配。如果两个地理坐标系只有单位不同（例如，两个宾夕法尼亚州北区平面图条目，一个单位为米，另一个为测量英尺），则可以选择任一个，给出的结果相同。如果要在 Bentley Map V8 XM Edition 或更早版本中使用该文件，则选择线性单位与模型相匹配的 GCS。
添加到收藏夹 | 将选定 GCS 添加到库选项卡上的“收藏夹”文件夹中。
属性 | 在“地理坐标系属性”对话框中显示选定 GCS 的属性。


拉伸元素

上次更新时间： 2019 年 1 月 30 日

用于拉伸围栅内容（其由围栅定义）。围栅可以是现有围栅，您也可以使用此工具定义新的矩形（仅限矩形）围栅。

“拉伸元素”工具按如下所述对元素进行操作：

  • 移动位于围栅内部的直线、线串、多线或形状的顶点。位于围栅外部的顶点并不移动。
  • 移动位于围栅内部的弧的端点。位于围栅外部的弧的端点并不移动。
  • 移动完全位于围栅内部的椭圆、圆或单元。
  • B 样条曲面位于围栅内部的一个或多个孔（控制点）移动。

可使用“拉伸元素”工具操作断点（例如多线中的断点，当多线本身为墙壁时通常用于表示窗户或门口）。例如，可以放置一个围栅以包括窗口，并沿着墙面移动窗口。也可以通过仅在围栅中包括断点的起点和终点来更改窗口的大小。这意味着，在大多数情况下，不必将多线拖放到其组件元素中即可执行此类操作。

无法将某个断点从包含它的多线线段中移出。如果您因移动围栅而使断点的起点或终点从线段中移出，断点位置只不过会投影到线段上的最近点处。如果将某个断点从线段末端移出，它仅仅会被删除。

如果只有弧的一个端点位于围栅中，则会有效地旋转和缩放弧，以便该点移动到新位置。这意味着，弧不会改变其长宽比（例如，圆弧不会变成椭圆形）或扫角。弧的新端点位置与围栅的移动方式保持一致，而不像“围栅拉伸”那样只是在 x 或 y 方向缩放弧。

设置 | 描述
使用围栅 | （仅限有围栅时）如果打开，将使用当前激活围栅。
拉伸单元 | 如果打开，将拉伸与围栅重叠的内容。 LOCK CELLSTRETCH [OFF | ON | TOGGLE] 键入命令还可用于关闭或打开“拉伸单元”。
键入: STRETCH ICON


Tool Index

三维漫游

两弧切线连接

两弧间弧

两点间弧

交点法创建路线

从 ASCII 文件创建地形模型

从 ASCII 文件导入平面几何

从 ASCII 文件导入纵面几何

从元素创建

从图形过滤器创建

从文件创建

从点云创建

任意元素与弧间的复杂过渡

任意坡延长

任意坡连接

任意竖曲线延长

任意竖曲线连接

任意线延长

任意线连接

修改围栅

倒角

冲突点报表

分析土方量

分析水塘

分析轨迹边坡

创建三维路面

创建关键桩号

创建剪切的地形模型

创建参数化约束

创建土木单元

创建土木规则特征

创建增量地形模型

创建复合地形模型

创建廊道

创建廊道备选表面

创建挖方和填方土方量

创建曲线加宽

创建末端条件异常

创建模板

创建次要路线

创建点控制

创建超高车道

创建过渡段

删除临时标注

删除剪切参考

删除围栅内容

删除廊道参考

删除特征

删除规则

删除边界

剖切地面线

匹配特征定义

反转点

取消激活参考规则

合规报表

同步模板

图形过滤器管理器

圆

圆弧延长

圆弧连接

土木消息中心

地图检查报表

基于元素按竖向偏移绘制纵断面

基于参照纵坡按可变坡度绘制纵断面

基于参照纵坡按固定坡度绘制纵断面

基于固定点按指定坡度定义纵断面

处理土木单元

复制三维路面

复制元素

复制元素

复合重新定义

定义地标界碑

定义目标别名

导入 IRD

导入超高

导出几何图形

导出到文件

平面曲线数据表

应用线性模板

应用表面模板

廊道对象

打开横断面视图

打开纵断面模型

打散围栅内容

打散复杂状态

指定给廊道

按三维元素绘制纵断面

按元素复合

按固定高程绘制纵断面

按定角度反向曲线连接

按平面图纵断面的附加三维体

按文本内插创建

按最佳拟合定义

按最佳拟合定义纵断面

按模板创建三维几何模型

按点创建竖曲线

按竖交点创建纵断面

按竖曲线单元创建纵断面

插入交点及复合曲线

插入任意竖曲线

插入切线坡

插入反向曲线坡

插入变坡点及竖曲线

插入桩号横坡

插入点

插入直-缓-圆-缓-直曲线

插入缓和曲线

插入过渡纵断面

操作围栅内容

放置 - 平面交叉点投影至其它剖面 (Place Profile Intersection Point)

放置围栅

放置土木单元

放置点

整路段等距偏移

旋转

显示模板

显示横断面标注

更改特征类型

更新廊道

构造阵列

标注地形位置

标注地形等高线

桩号偏移报表

桩号基准报表

比例

测点分析

测点间分析

添加剪切参考

添加廊道参考

添加断链

添加特征

添加竖曲线单元至纵断面

添加边界

清表报表

激活土木精确绘图工具栏

点特征桩号偏移高程报表

特征定义工具栏

特征集交叉报表

直线

直线坡

移动元素

移除土木单元

纵断面偏移

纵断面单元投影至其它剖面

纵断面投影至其它剖面

纵断面报表

组件数量

结果报表

缓和曲线延长

编辑三维路面

编辑复合模型

编辑桩号

编辑模型

编辑超高规则文件

编辑过渡段

自由反向曲线连接

设置元素信息

设置激活

设置激活纵断面

设置特征定义

设置设计标准

设计标准工具栏

设计输入报表

起点桩号

超高报表

超高编辑器

选择地理坐标系

通过三维元素创建平面元素

通过图形过滤器选择

通过土方量创建三维元素

通过放坡将三维元素应用到目标

通过桩号定位横断面

镜像

附加元素