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What is Multi-Batch

Multi-Batch is the fastest way to perform the same selected routines on all files that you have selected.

Features:

· Works with AutoCAD Full and AutoCAD LT.

· Dialog box control for creating popular script routines. (Plot – Detailed Setup, Plot - Page Setup, Purge, Import Page setup, Saveas Drawing/DXF)

· Ease of selecting and modifying scripts within Multi-Batch from a Database.

· Combine routines at runtime, allowing smaller routines to be created.

· It will not save the drawing unless requested to do so.

· Automatically handle read only files.

· Routine database can be accessed from network so the whole office can use the one set.

· Favorites & Non Favourites routine lists. This means the most commonly used routines are at your fingertips.

· On line help.

· Friendly support.

· Timer, so you can start the process within 24 hours. Allows you to process drawings overnight

· The ability to save and retrieve drawing lists including assigned routines.

· Recover drawings.
· Set AutoCAD default window size.

· The ability to easily sort and manipulate the drawings in the list.

· Works with multiple files across multiple directories and networks.

· Apply different routines to different files in the one session. E.g. Plot 300 drawings files and Purge another 500 drawing files.

· Run in the background.

· Add profile switches

Multi-Batch works by generating a detailed script file and then uses AutoCAD to run this script file.

For example, "applying" a command string such as _PURGE _A * _N , a script file will be created that tells AutoCAD to open the first file, apply the PURGE command, select ALL, and save it (or save back to a previous version), open the next file and do the same, so on, and so on.  The demo is limited to creating a Script file with no more than 3 drawings. It is intended to allow the user to experience the power of Multi-Batch scripting capabilities.  The full version of Multi-batch will allow access to the full features of Multi-Batch and only requires a registration number to unlock them.

Quick Start
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Main Screen Interface

· Start Multi-Batch.

· The main screen will appear

· Click on the “Add Files to List” Button

· Locate and select the Files you want to work on.

· Click the “Add Selected Files" or click on "Add All Files" button to add all the files in the highlighted folder. You can also double click on any file.

· When you are finished adding files click the “<< Back to Main” button.

· To add more files repeat the previous three steps.

· Next select a routine description from the routines list. There are two different sets of routines, Favourites and Non Favourites

· Click the “Assign Routine to Files” Button or if you are applying different routines to different files first select the files and then click “Assign Routine to Files”, or double click on the routine selected.

· You now have a list of files with a Routine assigned to each one.

· Before you begin the operation make sure that the script you have selected behaves as you expect. This is a powerful program and processes a lot of drawings very quickly. So make sure you have proper backups of all your files.

· Click the “Start” button to begin the operation. This will automatically start up AutoCAD and proceed to process the drawings in the list.

· After it is finished AutoCAD will close.

Using The Wizard Create Your First Plot Routine 2000 to 2014
This will demonstrate the ease with which you can create a routine to plot thousands of drawings.
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· If you have not done so already, we would recommend you firstly use AutoCAD to successfully plot a single drawing. Once you have done this record the important information needed for batch plotting, which is Plot Device, Plot style name, Paper size and Plot area. Please make sure that the Paper size matches the description shown in AutoCAD

· Start Multi-Batch

· The main screen will appear

· Click on the "Edit Routines / Wizards" Button

· Click on the "Plot - Detailed Setup" tab.

· Select the current tab of the drawings. If you are using AutoCAD LT you will be need to create a routine for plotting drawings in Modelspace and another routine for drawings in Paperspace. Select the appropriate option for the drawings you wish to plot. If you are using AutoCAD full the "Model/Layout Automatic" option will automatically detect the drawings setup and plot accordingly. This is recommended for AutoCAD full users.

· In this dialog box, working through the sections 1-6 select the features you require. To get the same results time after time select the Plot Device, Paper size, Plot Style name including file extension and Plot area.

· To select a Plot Device, you can select from the drop down list or browse to select a PC3 file from a different location. You can set up the default PC3 location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a PC3 file in the folder you wish to have as default. The PC3 files in this folder will now appear in the Plot Device list.

· To select a papersize: If you have selected a network printer then you can select from the dropdown list. If you select a PC3 file you can enter it manually or select a Paper Standard then select from the Standard sizes. You can also add your custom sizes to the custom list.

· To select a plot style you can select from the drop down list or browse to select from a different location. You can set up the default plot style location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a plot style file in the folder you wish to have as default. The Plot Style files in this folder will now appear in the Plot Style list.

· Next click the "Misc Plot Options" tab and select from the options here.

· For more information about the plot options please read the section under Automatic Script Creation Wizards.
· Click on "Save Routine" and give the new routine a name.

· Select it you want the routine to appear in your favourites routines list.

· Click on "<< Back to Main" to return to the main screen.

· Select the drawings to plot.

· Assign your new routine

· Click on "Start" This will automatically start up AutoCAD and proceed to plot the drawings you have selected.

· After it is finished AutoCAD will close.
Manually Writing Your First Script Routine:
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As a simple example, say you get in 200 drawings that need to be purged and you would also like your own snap settings set.

· Start AutoCAD

· Work out what the series of commands you need to achieve these results.

· Work through the commands in AutoCAD then press F2 to see the results.

· You therefore need purge, enter, a, enter, enter, n

· Since the Enter corresponds to a space or a blank line the routine is written as purge space a space space n

· For setting the snap settings you require  (setvar "osmode" 37)
· Then to save your changes you need a Qsave
· The finished script routine is purge a  n (setvar "osmode" 37)
Qsave 

· Next start Multi-Batch

· The main screen will appear

· Click on the “Edit Routines / Wizards” Button

· In the Routine Description box add a unique description.

· In the Script Routine box add the script routine purge a  n (setvar "osmode" 37) Qsave
· Click on "Add New Routine"

· Your new routine is now in the script routines list.

· Click on "<< Back to Main" to return to the main screen.

· Select the drawings to process.

· Assign your new routine

· Click on "Start" This will automatically start up AutoCAD and proceed to process the drawings in the list.

· After it is finished AutoCAD will close.

· If AutoCAD stops during your routine, press F2 to see the list of commands AutoCAD has used and where it has stopped. It usually just means you require a space or something simple added to your script routine.

Interface Screens:
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Main Screen:

Assign Routines to Files in the List 

Add Files to List

· Click the "Add Files to List” button.

· Select the files you want and return to the main screen.

· See Files Interface section for more information

Combine

· Click the "Combine” button to combine routines at runtime
· Select the routines you want to combine at run time.

· See Combine Routines section for more information

Assign Routine to all Files

· After you have added drawings to the list

· Select a routine description from the Favourites or Non Favourites Routines list.

· Click the “Assign Routine to Files” Button or double click on the required routine.

· You now have a list of files with a Routine assigned to each one.

Assign Routine to Selected Files

· Select the files you wish to apply the routine to.

· Select a routine description from the Favourites or Non Favourites Routines list.

· Click the “Assign Routine to Files” button or double click on the required routine.

· You now have a list of files with a routine assigned to each one selected.

· Do this until all files have a routine assigned to them.
Sort Drawing List

· When you have drawings listed in the Files to be processed window.

· Click on any of the three headings to sort by that heading. E.g. Click on Drawing File to sort by drawing name click again to reverse the sort order.
· Ideal for reversing the order of drawings for plotting on some machines. 
Remove Entries from the List

· From the main screen select the entries you want to delete.

· To select multiple files hold down the CTRL key, and then click each item you want to select or to select a group of files first select the first file then hold down the SHIFT key and select the last file.

· Click on “Remove From List”.

· Your selection will be removed from the list

Save Script File

· Click on the dropdown menu "File"

· Select “Save Script File”

· Select the location and name that you wish to save the file

· The script file will be saved in that location.

· You can then use this to manually start the script routine in AutoCAD.

Save Drawing List

· Click on the dropdown menu “Save/Retrieve List".

· Select Save Drawing List

· Multi-Batch displays the Save Drawing List dialog box.

· Enter a file name

· Click on “Save”

· The drawing list and assigned actions will now be saved with the file extension .mbl

Retrieve Drawing List

· In the main screen click on “Save/Retrieve List".

· Select Retrieve Drawing List

· Multi-Batch displays the Select Drawing List dialog box.

· Double-click the file name in the list of files or select a file name and click on “Open”

· The drawing list and assigned actions will now be retrieved to the Files To Be Processed list.

Number of sets

· Select the number of times you want to repeat the whole process.

· Ideal for batch plotting sets of drawings.

Runs from the command line
· Send the address of the mbl file to Multi-batch for processing.
Files Interface:
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Add Files to the List

· From the main screen Click on the “Add Files to List” Button

· Locate and select the Files you require. 

· Click the “Add Selected Files" or click on "Add All Files" button to add all the files in the highlighted folder.

· You can also Double click on the selected file.

· Your selected files will now appear in the Drawings To Be Processed list

· When you are finished selecting files click “<< Back to Main” button.

· You will then exit back to the main screen

To add more files repeat the previous steps. The file folder will default back to your previous location. You can also assign your favourite folders to the history for quick selection next time.

Add Path to History

· From the files window Click on the “Add Path to History” button

· The folder you are currently in is now added to the history list for quick selection later.

· You can access this list from the File pull down menu

Map a missing Network Drive

· If you are looking for a file on the network and the file does not appear in the Look in box, you will need to Map the network drive.

· From the files window click on the “…” button next to the "Look in:" box.

· Click the OK button.

· The Map Network Drive window will appear.

· In the Drive box, click the drive letter you want to use to connect to the network.

· In the Path box, enter the path where the file is located on the network.

· You can now access this drive in the Look in Box

File Type

Select the type of file to process and also narrow your selection by using the custom filter.
Combine Routines:
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Select routines to combine at runtime

· This allows you to combine existing routines to run in order at runtime.

· From the Favourites and Non Favourites list select one or multiple routines
· Click the >> button to copy them across into the Routines to Combine list
· Once you have selected the routines click the Assign Combination to assign this set of routines to your drawings.
· Click the << Back to Main button to return to the main menu
Sort you selection

· Select the routine in the Routines to Combine list.

· Click the Up or Down button to place the routines in the order you want.
Script Routines Interface
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Add New Routines to Database

· From the main screen click the “Edit Routines / Wizards” button.

· The Script Generator screen will appear

· Enter a description for your new routine

· Write your script in the Scriptwindow.

· You can also use the routine wizards to automatically create the routine for you. These are explained later in this manual.

· Click the “Add New Routine” Button

· Select whether to add it to your Favourites list or not (by default it will be added).

· If you are plotting using a R14 PC2 file you will need to set the Cmddia and Filedia settings to off. This is usually not required for Rel 2000 and above.

· Click “Exit” to return to the main menu.

· The easiest way to add a new routine is to Firstly select an existing routine and alter this. Then click the “Add New Routine” button.

Update Routines in Database

· From the main screen click the “Edit Routines / Wizards” button.

· The Script Generator screen will appear

· Select routine from the list.

· After selecting a routine the Description and Script will appear in the Description and Script Windows

· Make any alterations that you require.

· Click the “Update Routine” Button

· Click “<< Back to Main” to return to the main screen.

Delete Routines from Database

· From the main screen click the “Edit Routines / Wizards” button.

· The Script Generator screen will appear.

· Select an routine from the list.

· Click the "Delete Routine" Button.

· Confirm delete

· The routine will now be deleted form the database.

· Click “<< Back to Main” to return to the main screen.

Favourite & Non Favourite Routines

The "Add to Favourites" option means that you can have two lists of routines. One list of routines that you use frequently called Favourites and one list of routines that you use occasionally called Non Favourites.

This means that your most frequently used routines are always at hand and easily located.

· To change the listing of routines:

· Click the " Edit Routines / Wizards " button.

· Select a routine you want to change.

· Select either the "Favourites" or "Non Favourites" option.

· Click the "Update Routine" button

Automatic Script Creation Wizards

Plot - Detailed Setup
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This will demonstrate the ease with which you can create a routine to plot thousands of drawings.
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· If you have not done so already, we would recommend you firstly use AutoCAD to successfully plot a single drawing. Once you have done this record the important information needed for batch plotting, which is Plot Device, Plot style name, Paper size and Plot area. Please make sure that the Paper size matches the description shown in AutoCAD

· Start Multi-Batch

· The main screen will appear

· Click on the "Edit Routines / Wizards" Button

· Click on the "Plot - Detailed Setup" tab.

· Select the current tab of the drawings. If you are using AutoCAD LT you will be need to create a routine for plotting drawings in Modelspace and another routine for drawings in Paperspace. Select the appropriate option for the drawings you wish to plot. If you are using AutoCAD full the "Model/Layout Automatic" option will automatically detect the drawings setup and plot accordingly. This is recommended for AutoCAD full users.

· In this dialog box, working through the sections 1-6 select the features you require. To get the same results time after time select the Plot Device, Paper size, Plot Style name including file extension and Plot area.

· To select a Plot Device, you can select from the drop down list or browse to select a PC3 file from a different location. You can set up the default PC3 location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a PC3 file in the folder you wish to have as default. The PC3 files in this folder will now appear in the Plot Device list.

· To select a papersize: If you have selected a network printer then you can select from the dropdown list. If you select a PC3 file you can enter it manually or select a Paper Standard then select from the Standard sizes. You can also add your custom sizes to the custom list.

· To select a plot style you can select from the drop down list or browse to select from a different location. You can set up the default plot style location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a plot style file in the folder you wish to have as default. The Plot Style files in this folder will now appear in the Plot Style list.

· Next click the "Misc Plot Options" tab and select from the options here.

· Click on "Save Routine" and give the new routine a name.

· Select it you want the routine to appear in your favourites routines list.

· Click on "<< Back to Main" to return to the main screen.

· Select the drawings to plot.

· Assign your new routine

· Click on "Start" This will automatically start up AutoCAD and proceed to plot the drawings you have selected.

· After it is finished AutoCAD will close.
Plot options Available:

Select Tab:
There is a difference between printing Model and Layouts. Therefore you need to select whichever the drawings are set at. 

Model/Layout Automatic: AutoCAD Full.

If you are using the full version of AutoCAD you can select this option. This uses Lisp (AutoCAD’s programming language) to automatically select the correct plotting routine required to plot Model or Layout depending on which tab is active when the drawing is opened. This option is ideal for batch plotting all drawings. You don’t have to worry about page setups or if the drawing default tab is in model space or paper space. Recommended for AutoCAD full version users.

Layout: AutoCAD LT.

Use this option to create a routine to print drawings when the default tab of the drawing is Layout.

Model: AutoCAD LT.

Use this option to create a routine to print drawings when the default tab of the drawing is Model.

Plot Device:

You can select a PC3 file or system printer. You can also browse to select a PC3 file in a different location. 

You can set up the default PC3 location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a PC3 file in the folder you wish to have as default. The PC3 files in this folder will now appear in the Plot Device list.

Paper Size:

You can leave this as the default paper size or if the plot device is a network printer you can select a paper size from the paper size drop down list.

If the plot device is a PC3 file and you wish to enter a paper size, then you can enter it manually or select a standard size. To select a standard size, firstly select a paper standard from the paper standard drop down list and then select a paper size from the paper size drop down list. If your paper size is not listed then you can enter it manually.
It is important if you are entering a paper size that it matches exactly, one of the available sizes listed for that plot device. If you are not sure of the paper size, open AutoCAD and check the availability of the paper size for that plot device through the plot command in AutoCAD. 

If you have custom paper sizes, you can add these to a custom paper list. These will then be available for later reuse. Click on the button “Add Custom Size” and add your paper size to the list. This list will be saved in the file NewPaper.txt located in the Multi-Batch folder.
Units:
Specifies the plotting units either Inches or mm. This is important when plotting to scale.

Plot Style Table:

Contains the information on color, dithering, gray scale, pen assignments, screening, linetype, lineweight, endstyles, joinstyles, and fill styles. Plot styles are applied to each drawing at plot time. Since it is important to give the full file name including file extension, the easiest way is to select from the drop down list or Browse to locate a file from a different folder.

You can set up the default plot style location by going to the Options menu, clicking the "PC3 and Plot Style Location" tab and selecting a plot style file in the folder you wish to have as default. The Plot Style files in this folder will now appear in the Plot Style list.

Plot Area:

Specifies the portion of the drawing to be plotted.

Plot Scale:

Controls the plot area. The default scale setting Scaled to Fit. When you select a standard scale, the scale is displayed in Custom.

Custom:

Creates a user-defined scale. You can create a custom scale by entering the number of inches/mm equal to the number of drawing units.

Scale Lineweights:
Scales lineweights in proportion to the plot scale. Lineweights normally specify the linewidth of printed objects and are plotted with the linewidth size regardless of the plot scale.

What to Plot:
Plot all tabs:

This is used in conjunction with the Model/Layout Automatic option. Depending on the status of the tabs when the drawing is opened it will print accordingly. If the drawing is opened with the Model tab active it will print the model view. If the drawing is opened with the Layout tab active it will print all of the layout tabs in that drawing. This requires Lisp, which is only available with the AutoCAD full version.

Copies:
Sets the number of copies for each drawing you want printed 
Drawing Orientation:

Specifies the orientation of the drawing on the paper for plotters that support landscape or portrait orientation. You can change the drawing orientation to achieve a 0-, 90-, 180-, or 270-degree plot rotation by selecting Portrait, Landscape, or Plot Upside-Down. 

Plot Offset:

Specifies an offset of the plotting area from the lower-left corner of the paper. In a layout, the lower-left corner of a specified plot area is positioned at the lower-left margin of the paper. You can offset the origin by entering a positive or negative value. The plotter unit values are in inches or millimeters on the paper.

Center the Plot:

Automatically calculates the X and Y offset values to center the plot on the paper.

Layout Name:

This will print only this layout. If the layout is not on the drawing then the routine will stop.

Shaded Options:

Specifies how you plot shaded objects in Modelspace. You have the option to specify As Displayed, Wireframe, and Hidden. For AutoCAD full users there is also the option to print Rendered. If you select rendered you also get the further options for render quality. These are Draft, Preview, Normal, Presentation and Maximum.

If you are using Paperspace these options are set in the viewport.

Plot Options:

Plot with Plot Styles:

Plots using the plot styles applied to objects and defined in the plot style table. All style definitions with different property characteristics are stored in the plot style tables and can be easily attached to the geometry. This setting can replace pen mapping in earlier versions of AutoCAD.

Plot Paperspace Last:

Plots model space geometry first. Paper space geometry is usually plotted before model space geometry.

Hide Objects:

Plots layouts with hidden lines removed for objects in the layout environment (paper space). Hidden line removal for model space objects in viewports is controlled by the Viewports Hide property in the Object Property Manager. This is displayed in the plot preview, but not in the layout.

Plot with Lineweights:

Plots lineweights. 

Plot to File:

The resulting plot is sent to file.

Save changes to Tab:

This saves the current changes to the layout. If you select this option, the current settings will be used in the Page Setup dialog box. The drawing will need to be saved after plotting.

[image: image14.png]Sel

gs
Licence Location
i Losaiion

File Location

Frogram Excutable
eg Acadere,
Ackere

Routine Database.
Balch Cadmdb

Batch.sor Location

| StotupSeiches | PC3 nd Pt S Locatn

[CProgram FlestAutoCAD LT 2004\Ack exe

[€:Program FestMuliBatch_5 5\Batch_CAD.md

[C\Progam FlestMulBatch_55

BoCaDVesin | Advarced

Browse.

Browse.

Browse.

|
|

o Cooa

Apply




Plot - Page Setup

· Start Multi-Batch

· The main screen will appear

· Click on the “Edit Routines / Wizards” Button

· Click on the “Plot - Page Setup” tab

· In this dialog box select the features you require. 

· Click on “Save Routine”

· In the Save Routine box add a unique description, or select one from the list to update.

· Select whether you want the routine to appear in the Favourites or not. Click save

· This routine will be saved to the database

· Back in the main screen your new routine can now be assigned to any drawings you wish to process.

Options Available:

Page setup location:

Select "Use page setup already in drawing" option if you know that the drawings you want to batch plot already contain the correct page setup.

Select "Load page setup from a different drawing" option if you want to use a page setup from another drawing. This will also update the existing page setup if it already exists in the host drawing.

Select Page Setup:
Browse to select the drawing that contains the page setup you want to use.

Enter the page setup name in the box indicated.

Options:

Number of copies.

Set the number of copies, of each drawing you want printed.

Plot to file:

Select if you want to print to file.

Plot all tabs:

This option uses lisp and requires the full version of AutoCAD. Depending on the status of the tabs when the drawing is opened it will print accordingly. If the drawing is opened with the Model tab active it will print the model view. If the drawing is opened with the Layout tab active it will print all of the layout tabs in that drawing.
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Save As Drawing/DXF 

Save As Drawing 
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Save As DXF

· Start Multi-Batch

· The main screen will appear

· Click on the “Edit Routines / Wizards” Button

· Click on the “Save As Drawing/DXF” tab

· Select options. 

· Click on “Save Routine”

· In the Save Routine box add a unique description, or select one from the list to update.

· Select whether you want the routine to appear in the Favourites or not. Click save

· This routine will be saved in the routine database

· Back in the main screen your new routine can now be assigned to any drawings listed.
Options Available:

Save Drawing Type: Drawing
Select Drawing option to save the drawing as a previous release.

Save as Type:
Select the previous release of AutoCAD you want to save to.

Select Folder to Save to:

If you are using the full version of AutoCAD you can select to save the drawing to a different folder. By doing this you won’t overwrite the original drawing.

Save Drawing Type: DXF
Select DXF option to save the drawing as a DXF file.

Save as Type:
Select the version of DXF you want to save to. 

Select Folder to Save to:

If you are using the full version of AutoCAD you can select to save the DXF to a different folder. This way you can process drawings in different folders and have all the DXF files in the one.
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Purge

· Start Multi-Batch

· The main screen will appear

· Click on the “Edit Routines / Wizards” Button

· Click on the “Purge” tab

· Select the objects you want to purge from the drawings.

· Select the number of passes (number of times the purge command is initiated)

· Click on “Save Routine”

· In the Save Routine box add a unique description, or select one from the list to update.

· Select whether you want the routine to appear in the Favourites or not. Click save

· The routine will be saved in the routine database

· Back in the main screen your new routine can now be assigned to any drawings you wish to process.

Import Page Setup
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· Start Multi-Batch

· The main screen will appear

· Click on the “Edit Routines / Wizards” Button

· Click on the “Import Page Setup” tab

· Browse to select the drawing that contains the page setups you want to load.

· Enter a page setup name making sure that the drawing actually contains the page setup. If the host drawing already has this page setup the new one will redefine it.

· To load more than one Page Setup from the host drawing separate the setup names by a comma.

· To load all of the Page Setups from the host drawing select “Load All”.

· Click on “Save Routine”

· In the Save Routine box add a unique description, or select one from the list to update.

· Select whether you want the routine to appear in the Favourites or not. Click save

· Back in the main screen your new routine can now be assigned to any drawings you wish to process. 

Properties Interface

· From the Main Screen click on the Options menu

· Click on Properties

In this section you set the location of files needed by Multi-Batch the version of AutoCAD used and start-up options, licence location and default plot file location. You may have to restart Multi-Batch for the changes to take effect.
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File Location

Locate CAD Program File

· Click the Browse button next to the Program Executable address text window.

· Locate your CAD package executable file.  e.g. C:\Program Files\AutoCAD 2002\Acad.exe or for AutoCAD LT e.g. C:\Program Files\AutoCAD 2002 LT\Aclt.exe

· Click on the Program File

· Click Open This also returns you to the Properties screen

· Click Apply

· Click Okay to return to the Main Menu

Locate Database File

· Click the Browse button next to the Database address text window.

· Locate the database file "Batch_CAD.mdb"

· Click on Batch_CAD.mdb

· You can also have a different file name.

· Click Open. This also returns you to the Properties screen

· Click Apply

· Click Okay to return to the Main Menu

Locate Batch File

· Click the Browse button next to the Batch.scr address text window.

· Locate the Folder that "Batch.scr" will be located in.

· Click OK. This also returns you to the Properties screen

· Click Apply

· Click Okay to return to the Main Menu

AutoCAD Version
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· From the Main Screen click on the Options menu

· Click on Properties

· Click on the AutoCAD Version tab. It is important to make the correct selection.

· Click Apply

· Click Okay to return to the Main Menu

Select the version of AutoCAD you are using. There are sets of routines to go with each version of AutoCAD. These can be downloaded from our web site www.multi-batch.com

Advanced Options
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Set Start Command

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Advanced tab

· In the Default Start Command section select the start command you wish to use.

· You can choose the default command Open or the Recover command.

· This option gives you the opportunity to recover a series of drawings if you wish.

· Click Apply

· Click Okay to return to the Main Menu
Set AutoCAD Window State

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Advanced tab

· In the AutoCAD Window Style select the size of the window you wish for AutoCAD to start up in.

· You can choose Normal, Minimized or Maximized. The default is Normal.

· Click Apply

· Click Okay to return to the Main Menu
Sort by Field

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Advanced tab

· In the Sort By Field select to switch on the field sort option.

· There is now a “Sort by Field” button on the main screen.

·  Select the field number and the name delimiter. For example you wish to sort the file name 350-150-STM-5896-VP-65 by the field 5896 then you would set the Field Delimiter to - and the Field Number to 4

· Once you have the files listed and a routine assigned press the “Sort by Field” button. This creates another list with the selected fields which you can sort by clicking on the header.
Set AutoCAD SDI Option During Operation

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Advanced tab

· Select to set the AutoCAD variable SDI to 1 or leave it at 0. It will default to 0 but if you are experiencing problems with your script routine then set SDI to 1 as this will show the AutoCAD history and you will be able to see where the problem is.
· With SDI set to 1 you will also be able to set the default SDI option to return AutoCAD to afterwards.

Set Default SDI Option

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Advanced tab

· In the Default SDI section select whether you want the SDI variable turned back on or not.

· This controls whether AutoCAD runs in single- or multiple-drawing interface, if you leave it off then this turns off multiple-drawing interface. The default is Turn SDI Back On

· Click Apply

· Click Okay to return to the Main Menu
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Licence Location

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Licence Location tab.

· Click Apply

· Click Okay to return to the Main Menu

If you have multiple licences and wish to process them all from the one file then select the Network / Central option and select a location for the central file (Multi-Reg.txt).

Now when you start Multi-batch it will access this file to retrieve the registration number. It will also record the serial number for the various Multi-Batch installations. This will save all of the serial numbers in the one file, which you then send to us and we will process it for you. When you receive the processed file just overwrite the existing Multi-Reg.txt file.

This file can be updated in stages if you wish.

Once registered you can change between Local and Network/Central option. Your registration number will transfer automatically each time.
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Startup Switches

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the Startup Switches tab.

· To add extra switches select that option.

· Enter the switches

· Click Apply

· Click Okay to return to the Main Menu

Enter in the startup switches you wish to access when starting AutoCAD. The example /p "Test Profile" starts AutoCAD with the profile Test Profile.

If there are spaces in the file name surround the name in quotation marks. E.g. /p "Test Profile". For more information look up the AutoCAD help.
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PC3 & Plot Style Default Location

· From the Main Screen click on the Options menu

· Click on Properties

· Click on the PC3 and Plot Styles Location tab.

· Browse to select the default location for your PC3 files, select a PC3 file and click enter.

· Browse to select the default location for your Plot Style files, select a CTB or STB file and click enter.

· Click Apply

· Click Okay to return to the Main Menu

· Next time when you use the plot wizards these files will be listed in the Plot Device and Plot Style drop down lists.

Registration Interface

Local Registration:

· Under the Registration pull down menu click on Registration

· Record the serial number (select and right click copy and paste the Registration number into an email then) or click on the “Email Serial Number” button.

· Email this serial number to sales@multi-batch.com
· If payment has been received a return Registration number will be sent within 24 hours. This will allow you to access the full features of Multi-Batch.

· From the email returned copy/paste the Registration number into the Registration Number text box

· Click Ok. This will return you to the main menu.

· Your registration will be recorded.

Network Registration:

· Start up Multi-Batch on each machine that it is installed on.

· Each serial number will be recorded in a central file.

· Email this file (Multi-Reg.txt) to sales@multi-batch.com
· If payment has been received you will receive back the file with the registration numbers recorded against the serial numbers. This will be sent within 24 hours. This will allow you to access the full features of Multi-Batch.

· From the email returned copy the attached file overwriting the existing file.

· Your registration numbers are now recorded.

You can now swap between Network and Local registration and your number will be recorded on each. This is useful if you have to take your machine off the network.

Set Timer Interface


· Click on the dropdown menu “Timer”

· The set Timer dialog box will be displayed

· Click on “Set Start Time”

· Set the time you want the process to begin

· Click “OK”

· The timer is now set

· You can minimize the timer, but if you exit out of the timer your settings will be lost.

· Multi-Batch will now start at the time set.

AutoCAD Variables

Some functions are available both on the command line and in a dialog box. In many cases, you can enter a hyphen before the command to suppress the dialog box and display prompts on the command line instead. For example, entering layer at the command line displays the Layer & Linetype dialog box, in which you can define layer and linetype properties. Entering –layer at the command line displays the equivalent command line options for defining layer and linetype properties.

The CMDDIA system variable controls the display of dialog boxes used for plotting. If CMDDIA is set to 1, dialog boxes are displayed when you use the PLOT command. If CMDDIA is set to 0, you use the command line. Cmddia is not used in AutoCAD Release 2000, use –PLOT instead.

The FILEDIA system variable controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1, SAVEAS displays the Save Drawing As dialog box. If FILEDIA is set to 0, SAVEAS is displayed as prompts on the command line. 

If you exit out of AutoCAD prematurely and you have set FILEDIA and CMDDIA to 0. You will have to reset the variables.

In Release 2000 and above to open multiple files and close them down you have to set the variable SDI to 1. If this is not set to 1 the drawings will not close down and you can have a lot of drawings open at once. Multi-Batch handles this automatically, but if you exit out of AutoCAD before the script routine has finished this will not have been reset. 

Reset AutoCAD Variables

If you exit out of AutoCAD prematurely, you may have to reset FILEDIA and CMDDIA to 0 and in Release 2000 and above set SDI  to 0.

You can do this in two ways.

Manually:

In AutoCAD Rel 14

· Type “Filedia” at the command prompt and set it to 1.

· Type “Cmddia” at the command prompt and set it to 1.

In AutoCAD Rel 2000 and above

· In Rel 2000 and above type in “SDI” at the command prompt and set it to 0.

Automatically:

In Multi-Batch

· Go to the File dropdown menu.

· Select “Reset AutoCAD Variables”

· Follow the prompts.

Writing Script Routines

What is a script file?

A script is a series of AutoCAD commands in a text file that can be used to carry out a task. With scripts, you can run several commands in succession. For example, you can script a series of AutoCAD commands for overnight batch processing.

Multi-Batch comes with dialog box control for a lot of the popular routines. These include Plotting in 2000 to 2010, Saveas and Purge with more to follow.

AutoCAD provides a script facility that reads commands from a text file. This facility is useful for executing a sequence of commands; you can invoke these commands when you start AutoCAD (using a special form of the Acad command), or you can run a script from within AutoCAD using the SCRIPT command. The script facility provides an easy way to create continuously running displays for product demonstrations and trade shows.

Script files can contain comments. Any line that begins with a semicolon (;) is considered a comment, and AutoCAD ignores it while processing the script file.

A space is considered a Return (Enter Key pressed). A new line is also considered a Return and has to be used in some cases.

All references to long file names that contain embedded spaces must be enclosed in double quotes. For example, to locate the pc2 file C:\My_Acad\Custom\HP Design 430_10.pc2 you must use the following syntax:

"C:\My_Acad\Custom\HP Design 430_10.pc2"

The underscore before the commands is required only as an English Command equivalent (under normal use you do not need to put it in). This means that no matter what language AutoCAD is using “_Purge” will always purge etc. 

The underscore is only required for the English version of the command. By doing it this way Multi-Batch will work with International versions of AutoCAD.

The best way to figure out what to write is to disable the dialog boxes in AutoCAD by typing at the command prompt Cmddia and setting it to 0 and by typing in Filedia and setting it to 0. This gives you command line access with no dialog boxes. Type in the commands you want and write them into the Script Window of Multi Batch. After you have finished set Cmddia and Filedia back to 1.

As in everything TEST, TEST, & TEST AGAIN. Set up a test folder with a few drawings and try out your routines on these drawings to make sure that it does as you expect it to. This is especially important if you are doing an operation that is saved over the original drawing like Binding xref's.

It is a good idea to work on copies of the original files, that way if you make a mistake you can revert to the original files.

NEVER OPERATE WITHOUT PROPER BACK UPS OF YOUR FILES. This is good practice.
Sample Script Routines

Save as R13

_saveas _r13  _y

Saveas Return R13 Return Return Yes

Plot using PC2 file (Release 14 only. For Release 2000 see sample 6)

_Zoom _E _Plot _E 2 "C:\My_Acad\Custom\HP Design 430_20.pc2" _E 0 _Delay 32760 _Regen

Zoom Extents Return Plot Extents Return 2 (gets a PC2 file)

File name and address (enclosed in double quotes because of the spaces in the address name)

Extents 0 (to continue plotting) Delay 32760 milliseconds (max of 32760) Regen to finish off

We also set the button Cmddia and Filedia to off. Otherwise the dialog boxes appear to get the PC2 file.

Change Text
Cht All  T G

;Next line contains text you want to change

JULY 1st, 1999

;Next line contains text you want to change it to

JUNE 27, 1999

_Qsave _Redraw
Change all text globally, text to be changed, text to change it to return Qsave and Redraw to finish off.

Export DXF Files

_Dxfout

6 _Redraw

DXF export return 6 (decimal places of accuracy) Redraw to finish off

Plot and Purge Drawings (Rel 14)
_Zoom _E _Plot _E 0 _Purge _A * _N _Qsave _Redraw

Zoom Extents Return Plot Extents Return 0 (continues plotting) Purge All Qsave and Redraw to finish it off.

Plot_2000
Plot Scripts in Release 2000 to 2013
By working through the sequence of commands in AutoCAD you can see exactly what response is required. For example see the AutoCAD sequences below and the resulting script files. The dialog box control takes care of all this but it is useful to understand how the routines are written.

Plot Model space without using detailed configuration:

Command: -plot

Detailed plot configuration? [Yes/No] <No>:

Enter a layout name or [?] <Model>:

Enter a page setup name <>:

Enter an output device name or [?] <Dataproducts A3>: 
change to suit you
Write the plot to a file [Yes/No] <N>:

Save changes to model tab [Yes/No]? <N>

Proceed with plot [Yes/No] <Y>:

So your resulting script routine would be:

_-plot

_n

model

Dataproducts A3
change to suit you
_n

_n

_y

Plot Layout using detailed configuration to plot extents:

Command: -plot

Detailed plot configuration? [Yes/No] <No>: y

Enter a layout name or [?] <Model>:

Enter an output device name or [?] <Dataproducts A3.pc3>:  change to suit you
Enter paper size or [?] <ANSI A (11.00 x 8.50 Inches)>:

Enter paper units [Inches/Millimeters] <Inches>:

Enter drawing orientation [Portrait/Landscape] <Landscape>:

Plot upside down? [Yes/No] <No>:

Enter plot area [Display/Extents/Limits/View/Window] <Display>: E

Enter plot scale (Plotted Inches=Drawing Units) or [Fit] <Fit>:

Enter plot offset (x,y) or [Center] <0.00,0.00>:

Plot with plot styles? [Yes/No] <Yes>:

Enter plot style table name or [?] (enter . for none) <>:

Plot with lineweights? [Yes/No] <Yes>:

Remove hidden lines? [Yes/No] <No>:

Write the plot to a file [Yes/No] <N>:

Save changes to model tab [Yes/No]? <N>

Proceed with plot [Yes/No] <Y>:

So your resulting script routine would be:

_-plot

_y

model

Dataproducts A3.pc3
change to suit you
inches

landscape

_n

_E

_fit

_y

_yes

_no

_n

_n

_y _redraw

;;You can change any of these settings to get the required plot you want.

Tip The redraw command at the end lets you know how many returns have been used at the end of the script.
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