U.S. Coordinate Systems in MicroStation V8i & Bentley Map V8i
Common Coordinate System Problems or Questions Encountered in Bentley Software Support

Jim McCoy P.E.
11/6/2013

How to assess and solve geospatial coordinate system problems in MicroStation V8i & Bentley Map V8i for design files, ESRI shape files, raster images, Google Earth KML/KMZ files, and geospatial databases.
# Table of Contents

Introduction ................................................................................................................................. 3

What is a Coordinate System in MicroStation ............................................................................. 5

US Survey Feet vs. International Feet .......................................................................................... 10

Which Definition of a Foot should be used in the United States for the State Plane Coordinate Systems? ........................................................................................................................................ 11

Linear Measurement Units in MicroStation .................................................................................. 13

  Master Units .................................................................................................................................. 13

  Storage Units .................................................................................................................................. 14

Correcting Storage Units and/or Master Units .............................................................................. 15

Units for External Sources of Data ................................................................................................. 16

  Referencing Design Files or .SHP Files with a Different Definition of a Foot ............................... 16

  Referencing Design Files or .SHP Files with Different Coordinate Systems ............................... 18

Units for ESRI Shape Files ............................................................................................................ 19

Coordinate Systems for Raster Images ......................................................................................... 20

Units for Raster Files with Sister/World Files .............................................................................. 21

Using Bentley Map to Import 3D Contours from Shape Files with Mixed Units .......................... 22

How to Assign a Coordinate System ............................................................................................. 25

  Assigning a Known Coordinate System ..................................................................................... 25

  Determining an Unknown Coordinate System ............................................................................. 29

  Testing the Selected Coordinate System using Google Earth ..................................................... 36

Geographic Coordinate Readout and Input in a Projected Coordinate System ............................... 38

  Geographic Coordinate Readout .................................................................................................... 38

  Geographic Coordinate Input ......................................................................................................... 41

Capturing Google Earth Images in a 3D Design File .................................................................... 43

Coordinate Systems for Geospatial Databases ............................................................................. 45

  Coordinate System Considerations in an Oracle Spatial Database ............................................ 47

  Coordinate System Considerations in Microsoft SQL Server ...................................................... 51

Additional Information .................................................................................................................. 54
Introduction

As a Bentley software support analyst, I want to explain processes to resolve many coordinate system problems and answer questions that involve design files, ESRI shape files, raster images, Google Earth KML/KMZ files and geospatial databases. It has been my experience that many Bentley customers and Bentley employees alike are confused by coordinate system issues. The most common problems or questions that I encounter as a support analyst can be categorized as:

- How to assign a coordinate system and possibly how to determine the correct coordinate system.
- Data from multiple sources (design files, shape files, raster images, or graphics from geospatial databases with a defined Spatial Reference Identifier, SRID) are not located in the right geographic location within a design file.

This technical note is concentrated on coordinate systems used in the United States. Coordinate system confusion arises in the United States because of the many zones of the State Plane Coordinate System and the multiple choices of these zones, also because two datums are used (NAD27 and NAD83) with multiple realizations of the NAD83 datum (NAD83, HARN(HPGN), and a future NAD83(2011)), and the fact that linear measurement units can be in meters, U.S. survey feet, or international feet.
NAD83 State Plane Coordinate Zones

Figure 1

States are divided into multiple zones to minimize the distortion from mathematically projecting features on a round earth to a flat map. With the exception of zone 1 in Alaska, two mathematical techniques are used for the map projection process for the SPCS zones: Lambert Conformal Conic and Transverse Mercator. The Universal Transverse Mercator coordinate system is also used frequently in the United States, and it of course uses the Transverse Mercator map projection method.
What is a Coordinate System in MicroStation

A MicroStation design plane itself is a Cartesian coordinate system with the XY origin at the center of the design plane, except when the global origin has been shifted. The coordinate system zones, available from the Geographic Coordinate System library, make use of the design plane coordinate system. XY coordinates in the SPCS and UTM zones are always positive. So three fourths of the design plane is not used. The coordinate system zone itself further restricts where the map can be drawn on the design plane. The center of a zone has the coordinate value of the False Easting. The baseline of the zone is the False Northing.
The unit of the coordinate system needs to be known for the False Easting and False Northing.

Because the zones cover large areas of the state, a map may be many miles from the False Easting and Northing. The figure below shows a 7.5 minute quadrangle map relative to the Longitude of Origin (False Easting/Central Meridian) for the East Zone of the Alabama SPCS.
All UTM zones in the northern hemisphere have a False Easting of 500,000 meters (1,640,416.667 US survey feet or 1,640,419.948 international feet) and a False Northing of 0 meters at the Equator. The False Easting and Northing are therefore not reported in the Coordinate System parameters.

The dimensions of the zone are further restricted by the minimum and maximum longitude and latitude values. These geographic restrictions are to minimize distortion as a result of the map projection technique. While graphics for map features can be drawn outside of the minimum and maximum longitude and latitude ranges, it is not recommended.
When a map is based on horizontal survey control points of a SPCS zone, the map will be drawn in the correct location on the design plane whether it has a coordinate system defined or not.

Defining the coordinate system is the magic key to opening a treasure chest of tools that were previously unavailable. Once the coordinate system is defined, additional capabilities become available.

- The design file can now interact with Google Earth using the available tools.
- External sources of data such as raster images and shape files with a different coordinate system can be attached and reprojected to the design file coordinate system.
- Other design files with different coordinate systems can be referenced and reprojected.
- The design file itself can be reprojected to another coordinate system simply by changing the coordinate system and selecting the option to reproject.

![Figure 6](image1.png)

![Figure 7](image2.png)
• Geographic coordinates can be displayed and used as coordinate input for MicroStation key-ins.
• Using Bentley Map, design file graphics in one coordinate system can be posted to and queried from a geospatial database with a different coordinate system.
• Using Bentley Map, longitude and latitude lines can be drawn as graticule lines in the design file.
• Custom coordinate systems, datums, and ellipsoids can be created using Bentley Map.

If the map is placed on the design plane without any reference to known horizontal control points, assigning a coordinate system accomplishes nothing. The map will have to be moved and possibly scaled and rotated to the correct location on the design plane. See 2D Conformal Transformation.pdf for a possible workflow.
US Survey Feet vs. International Feet

A big source of confusion with MicroStation is due to a lack of understanding of the difference between a US survey foot and an international foot. In MicroStation “Feet” are international feet. The two linear measurement units have different definitions and slightly different lengths.

| 39.37 US survey inches = 1 meter (by definition) |
| 39.37/12 US survey feet = 3.2808333333333333333333333333333 US survey feet = 1 meter |
| 1 US survey foot = 0.30480060960121920243840487680975 meters |
| 1 international foot = 0.3048 meters (by definition) |
| 1/0.3048 international feet = 3.2808398950131233595800524934383 international feet = 1 meter |

It can be seen that an international foot is slightly shorter than a US survey foot. Therefore the coordinates of a point in international feet will be slightly larger than the same point in US survey feet. This can be observed by switching the Master Unit in a design between the two unit definitions while checking the coordinate readouts of a point using a tentative snap.

| Ratio of XY coordinates in US survey feet to XY coordinates in international feet |
| (39.27/12) / (1/0.3048) = 0.999998 |
| Ratio of XY coordinates in international feet to XY coordinates in US survey feet |
| (1/0.3048) / (39.27/12) = 1.000002 |

When MicroStation graphics are shifted slightly relative to other graphics, raster images, or in Google Earth, suspect that the problem may be related to US survey feet versus international feet. Multiply the X and Y coordinates of a point by 0.000002 to see if the computed XY offsets agree with the shift that is observed.

The difference in the lengths of the two foot definitions will usually not be significant for measurements made with present day surveying equipment. The lengths of the measurements will probably not be long enough or precise enough to detect a difference between international feet or US survey feet. The problem occurs when using the large coordinate values of the SPCS zones. For example, the Nevada East zone of the NAD83 datum has a False Northing of 8,000,000 meters (26,246,666.667 US survey feet). Multiplying the False Northing by 0.000002 gives an offset of over 50 feet, and that does not take into account the additional offset in the east-west direction.
Which Definition of a Foot should be used in the United States for the State Plane Coordinate Systems?

When starting a project from the beginning, it is best to choose the correct foot definition from the start. However, if hundreds or thousands of design files exist with the wrong definition of a foot, it probably would not be wise to change procedures that have worked satisfactorily.

What is the significance of using the wrong definition for feet? When working totally within a closed environment where no external data such as design files, ESRI shape files, raster images or geospatial databases from external sources are used and no interaction with other software such as geospatial databases or Google Earth is required, there will be no adverse affect to using “Feet” when “US Survey Feet” should have been used. If there is a need to interface with external data or produce design files or shape files (using Bentley Map), for consumption by groups outside of a company, corrections may need to be made. But first determine which foot definition should be used.

For the State Plane Coordinate Systems that use the NAD27 datum, the measurement unit is US survey foot. National survey control monuments had their positions recorded as X and Y coordinates in US survey feet. So surveys that tied into survey control points would have coordinate values in US survey feet.

The unit for the SPCS zone is documented in the coordinate system parameters in MicroStation.

Figure 8
For SPCS zones with the NAD83 datum, most states use US survey feet, while six use international feet. Arizona, Michigan, Montana, Oregon, South Carolina, and Utah use international feet. MicroStation offers choices of “US Survey Foot” or “Meter” for all SPCS zones. For the six states that use international feet, there is the additional choice of “International Foot.”

So what are the ramifications of choosing a SPCS zone with the wrong unit? As far as projection calculations are concerned, it doesn’t really matter which unit is chosen. For clarity a SPCS zone with the unit used for horizontal survey control points should be chosen. The only difference that will be seen for the same coordinate system with differing units will be the values displayed in the False Easting and False Northing fields. Most False Easting and False Northing parameters were originally defined in meters. A linear conversion takes place when a SPCS zone unit other than meters is selected. See Figure 8 above.

When the SPCS zone unit does not match the design file storage unit, there will be an option to change the design file storage unit to match the SPCS zone unit when the coordinate system is defined.

![Geographic Coordinate System Changed](image)

Changing the design file storage unit should be done with caution for design files with existing graphics. Changing the storage units has the effect of scaling the graphics in the design file, although the graphics do not move on the design plane. The relationship of linear units in MicroStation is discussed in Correcting Storage Units and/or Master Units.
Linear Measurement Units in MicroStation

The two main areas concerning linear units are the Master Units and the Storage Units.

**Master Units**
In MicroStation select Settings > Design File > Working Units > select the appropriate Master Unit from the dropdown list.

![Design File Settings](image)

**Figure 10**
This Master Unit is used when interacting with the graphics of the design file, such as the XY coordinate input/readout, dimensions, measurements, and calculations of perimeter, area, or volume. It is not often that multiple linear units are required for data input and readouts. Set the unit to the appropriate unit that will be used for data input and readout.
**Storage Units**

Click the Edit button in the Design File Settings dialog and click OK to dismiss the Alert warning about saving design files to version 7 MicroStation if it does not apply to your workflow.

![Advanced Unit Settings](image)

Figure 11

The storage unit specifies the linear unit in which the design file graphics are stored. This unit can be totally transparent to the user and does not have to agree with the Master Unit or the SPCS zone unit. If the storage unit is “Foot” and the Master Unit is “US Survey Feet,” graphics entered into a drawing will be converted from US survey feet to international feet when they are stored internally. If the storage unit is “Meter” and the Master Unit is “US Survey Feet,” the graphics will be converted to meters when they are stored in the design file. If the Master Unit is “Feet” and the storage unit is “Meter,” international feet will be converted to meters. This presents a problem if the intent was to actually input US survey feet. The conversion of international feet to meters is not the same as the conversion of US survey feet to meters.
Correcting Storage Units and/or Master Units

Changing the storage unit after graphics have been placed in the design file will in effect scale the map even though the graphics do not move on the design plane. Coordinate readouts and distance measurements will change by the ratio of the old storage units per meter to the new units per meter. When the Master Unit “Feet” has been used for data input, where “US Survey Feet” should have been used, an additional scale factor correction will be needed. Correcting the Master Unit will change readouts and measurements by the ratio of the new units per meter to the old units per meter. When the Master Unit is corrected and the storage unit is changed, the two ratios are multiplied together. Take the reciprocal of the combined factors to derive the scale factor correction. See Table 1 below for scale factor corrections about the origin point when one or the other or both the Master Unit and the storage unit are changed /corrected. The new Master Unit in the table is “US Survey Feet.”

Change the Master Unit to US Survey Feet and the storage unit to US Survey Foot and manually scale the graphics using Scale or Fence Scale about the origin point “xy=0,0.”

<table>
<thead>
<tr>
<th>Original Master Unit</th>
<th>Original Storage Unit</th>
<th>New Storage Unit</th>
<th>Scale Factor Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feet*</td>
<td>Meter</td>
<td>US Survey Foot</td>
<td>1/0.3048**</td>
</tr>
<tr>
<td>US Survey Feet</td>
<td>Meter</td>
<td>US Survey Foot</td>
<td>39.37/12**</td>
</tr>
<tr>
<td>Feet *</td>
<td>US Survey Foot</td>
<td>No change</td>
<td>1.000002</td>
</tr>
<tr>
<td>US Survey Feet</td>
<td>Foot</td>
<td>US Survey Foot</td>
<td>0.999998**</td>
</tr>
<tr>
<td>Feet*</td>
<td>Foot</td>
<td>US Survey Foot</td>
<td>No correction required</td>
</tr>
</tbody>
</table>

Table 1

Note:

- **”Feet” was used for data input when “US Survey Feet” should have been used.
- ** Apply the scale factor correction after changing the storage unit to “US Survey Foot.”

Record the coordinates of a point in the design file using a tentative snap before making the unit changes and applying the scale factor and after making the unit changes and applying the scale factor. The coordinates of the point should be the same after the change as they were before the change.
Units for External Sources of Data

Referencing Design Files or .SHP Files with a Different Definition of a Foot

When a design file or .SHP file with one definition of a foot is referenced to a design file with the other definition of a foot, a warning will be issued. While it is possible that two different definitions of a foot are actually being used, a more common situation is that the two should both be US Survey Feet.

Figure 12
A scale factor can be applied in the Reference dialog without modifying the storage units or Master Units of either of the master design file or the reference design file.

If the reference design file needs to be shifted in a northeast direction, insert 1.000002 in the left hand field of the scale ratio. If it needs to be shifted in a southwest direction, insert 1.000002 in the right hand field. This rule applies to referenced ESRI shape files also.

Figure 13
Referencing Design Files or .SHP Files with Different Coordinate Systems
Design files or .SHP files with different coordinate systems can be referenced to the master design file. Select “Geographic – Reprojected” when attaching the reference design or .SHP file. The coordinate system must be defined in both the master and reference design files. A .PRJ file must exist with the .SHP files in order for a reprojection to take place.

Figure 14
**Units for ESRI Shape Files**

ESRI shape (.SHP) files can be referenced in MicroStation or imported using Bentley Map. Shape files have their coordinate system and distance unit and the relationship of the unit to a meter specified in a text file with a .PRJ extension.

```plaintext
PROJCS["UTM83-14F",GEOGCS["UTM83-14F",DATUM["D_NAD83",SPHEROID["GRS1980",6378137,298.257222100887]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295],PROJECTION["Transverse_Mercator"],PARAMETER["False_Easting",1640416.6666667],PARAMETER["False_Northing",0],PARAMETER["Central_Meridian",-99],PARAMETER["Scale_Factor",0.9996],PARAMETER["Latitude_Of_Origin",0],UNIT["Foot_US",0.30480060960121924])
```

If the shape file unit does not agree with the design file Master Unit, the .SHP file graphics will be scaled. This may not be the desired result if .SHP file graphics are scaled from US survey feet to international feet as a result of the Master Unit being set as “Feet.” Shape files, like design files, can also be scaled in the Reference dialog. See Figure 13. The units for .SHP files in the U.S. are usually US survey feet, meters, or degrees.

When the .PRJ file does not exist, the coordinate system and unit is assumed to be the same as that of the design file. If no .PRJ file exists and it is known that the coordinate system is different from the design file, the .SHP file can be attached to a design file with a coordinate system that matches the .SHP file. The design file with the attached .SHP file can then be referenced to other design files and reprojected.
Coordinate Systems for Raster Images

When the coordinate system of a raster image differs from that of the design file, a reprojection of the image will take place if the coordinate system is defined for both the design file and the raster image. To define the coordinate system of a raster image, in the Raster Manager dialog select Utilities > Coordinate System > Select From Library > select the coordinate system. The raster image will automatically reproject to the coordinate system of the design file.
Units for Raster Files with Sister/World Files
Another linear unit in MicroStation where the unit needs to be considered is in the Preferences for the Workspace. Select Workspace > Preferences > select Raster Manager from the Category in the left hand panel > select the Georeference tab from the right hand panel > select the units for the Sister file and the Raster file from the dropdown lists.

![Preferences Diagram](image)

A “sister” file, also called a “world” file, is a text file containing information about where and how the raster image will be placed geographically. It, however, doesn’t contain information about the unit of measurement. The unit can be specified in the workspace Preferences.

Some raster files contain information about where and how to display the raster image in the header of the raster but don’t contain information about the unit of measurement. The unit can be specified in the workspace Preferences. If the wrong definition of a US survey foot is used (i.e. “Feet”) as the design file Master Unit, also use “Feet” as the unit for the raster files. Otherwise the raster image will be scaled relative to graphics. Raster images in the U.S. are usually in units of US survey feet, meters, or degrees.
Using Bentley Map to Import 3D Contours from Shape Files with Mixed Units

Bentley Map has the ability to import contour .SHP files into a MicroStation 3D design file with the contours at the correct elevation. The elevation value is retrieved from the attributes of the .SHP files (in the .DBF file which can be viewed with Microsoft Excel) and is selected from the dropdown list of the Elevation field.

A common problem is when there are mixed units. The coordinate system of the .SHP files, which can be determined by examining the .PRJ file with Microsoft’s Notepad or WordPad software, will often be a UTM coordinate system with units of meters while the elevation attribute is in US survey feet. The
The elevation attribute must be converted to meters during the import process in order for Z values to be scaled correctly relative to XY values. This is accomplished by multiplying the elevation by the conversion factor of 12/39.37 to convert the elevation US survey feet to meters to agree with the coordinate system unit of meters in the .PRJ file. See the figure below.

Figure 18
If the coordinate system of the design file has a unit of “US Survey Feet,” the contours will be displayed at the correct elevation in US survey feet. The conversion of the elevations will have made a roundtrip from US Survey feet to meters and back to US survey feet during the import process.
How to Assign a Coordinate System

Most civil engineering maps are *georeferenced*. That is they are based on field survey data that were tied to one or more SPCS zone control points. To perform a quick test, tentative snap to a graphic element in the design file and observe the XY coordinate values. If the values of the XY coordinates are not in the hundred thousands, millions, or tens of millions range, the coordinate system is not a SPCS zone. Often the X coordinate will vary from the Y coordinate by an order of magnitude either greater or smaller in a SPCS zone. Coordinates of the SPCS zones will also never be negative. If the X coordinate is a small (-70 to -180) negative value and the Y coordinate is a small (less than 90) positive value, investigate the possibility that the coordinate system is geographic rather than a projected coordinate system. Longitude values are negative in the western hemisphere and latitude values are positive in the northern hemisphere for a geographic coordinate system.

Assigning a Known Coordinate System
To assign a SPCS zone to a design file, select Tools > Geographic > Select Geographic Coordinate System.

![Geographic Coordinate System dialog]

Select the 2\textsuperscript{nd} icon from the left “From Library” in the Geographic Coordinate System dialog.
Navigate to the “United States of America” node in the “Projected (northing, easting)” section of the Library.
Expand the node for the appropriate state and select the correct coordinate system.

Figure 21

States with multiple zones will usually have their zones named according to the geographic position in the state, such as East or West, Central, North or South. California, Alaska, Hawaii, and Puerto Rico and Virgin Islands use a numeric naming convention for the zones. Wisconsin and Minnesota also have coordinate systems for each county. After selecting the coordinate system, click OK to dismiss the dialog to complete the operation.
Often the next dialog to display is the “Geographic Coordinate System Changed” dialog.

![Geographic Coordinate System Changed dialog]

The ramifications of changing the storage units were discussed previously. See Correcting Storage Units and/or Master Units. If graphics already exist in the design file when the coordinate system is chosen, the storage units should probably not be changed unless an immediate scale correction will be made to the graphics.
**Determining an Unknown Coordinate System**

Often a design file or other data have been acquired where the graphics are based on a coordinate system, but it is unknown. Usually the seemingly daunting task of determining the unknown coordinate system can be determined relatively quickly using a systematic approach. In the U.S., coordinate systems are usually State Plane Coordinate Systems or Universal Transverse Mercator.

The approach can be summarized as:

1. When external data are being brought into a design file such as raster images or shape files, try to find a feature where the dimensions can be measured to see if the right Master Unit is being used. For example, a 2-lane highway is usually about 24 feet wide. If dimensions are off by an approximate factor of 3 either too large or too small, there probably is a problem where meters are assumed to be feet or vice versa. Also measurements in MicroStation can be compared to measurements in Google Earth.

2. Try different SPCS zones if multiple state zones are available for the NAD83 datum. Choose a SPCS zone with a unit of US Survey Feet, except for the states of Arizona, Michigan, Montana, Oregon, South Carolina, and Utah which use international feet. Do not change storage units if prompted. Test to see if the coordinate system is correct.

3. Switch to the NAD27 datum if the correct coordinate system is not found and test multiple zones if necessary. Again, do not change storage units. Test to see if the coordinate system is correct.

4. Lastly test the UTM zone for the map with a datum of NAD83 and then NAD27. Do not change the storage units. Test to see if the coordinate system is correct.

A more detailed description of the SPCS zone selection workflow is listed below.

1. Without information or experience to indicate otherwise, initially assume that the coordinate system is a SPCS zone. For states with multiple zones, determine the geographic location of a town that includes the mapped area of the design file or nearby town using a tool such as Google Earth. Because many states use geographical names for their zones such as North, South, East, West, and Central, the appropriate zone for the map can be determined or narrowed down. A few states have differing zones for the NAD27 and NAD83 datums. For states which use numerical names for the zones, try to find a map of the state’s zones on the World Wide Web. When trying different coordinate systems by trial and error, do not reproject the graphics. Specify that the coordinate system is being corrected.
2. The next decision is to choose the datum either NAD27 or NAD83. Choose the NAD83 datum as the first guess. There are multiple realizations of the NAD83 datum – NAD83, HARN/HPGN, or NAD83 (2011). A realization is an adjustment of horizontal survey control points used to define the ellipsoid
of the datum. There is very little difference between the different realizations of the NAD83 datum and without direct knowledge about the survey control points used in the field to produce the map, the NAD83 datum can be assumed and corrected later if it is determined that the wrong realization was assumed. When correcting, specify that the coordinate system is being corrected and not reprojected when prompted. See Figure 23 above.

Note: The zones whose names begin with EPSG (European Petroleum Survey Group) are often duplicates of the other zones with a different naming convention.

3. In addition to the multiple zones and the two datums, there is a choice of the distance unit used by the SPCS. For the NAD27 datum, US Survey Feet is the only choice. For the NAD83 datum, there will be a choice of US Survey Feet, Meters and for six states international feet (Arizona, Michigan, Montana, Oregon, South Carolina, and Utah). It really doesn’t make any difference which unit is chosen unless the storage unit is changed to match the SPCS zone unit. See Correcting Storage Units and/or Master Units. During the trial and error process of finding the correct coordinate system, do not change the storage units. Select a SPCS zone with a unit of US Survey Feet unless the zone is known to use international feet.

4. If there is no success testing the SPCS zones, test the UTM zone(s) for the region. The UTM zones for the United States are under the “Others” node in the “United States of America” section. Zone numbers increase traveling from the west coast at 10 to 19 on the east coast. The units for UTM zones for the United States can be in meters, US survey feet, or international feet. The east coast states are in zones 17, 18 or 19. The west coast states are in zones 10 and 11.
**Select Geographic Coordinate System**

**Library**
- Washington
- West Virginia
- Wisconsin
- Wyoming
- Others

**Coordinate System**
- Name
- Description
- Projection
- Source
- Units
- Central Meridian
- Origin Latitude
- Scale Reduction
- False Easting
- False Northing
- Quadrant
- Minimum Longitude
- Maximum Longitude
- Minimum Latitude
- Maximum Latitude

**Datum**

**Ellipsoid**
- Name
- Description
- Equatorial Radius
- Polar Radius
- Eccentricity
- Source

---

**Figure 25**
Most states will fall within one or two UTM zones. A few states will fall within three zones. Alaska will fall within nine UTM zones. Be aware also that a small part of the Aleutian Islands of Alaska is in the eastern hemisphere and longitudes will be positive for that area. To determine the appropriate UTM zone, observe the minimum and maximum longitude of the UTM coordinate system. If the geographic location of the mapped area is known in Google Earth, examine the longitude readout in Google Earth and compare it to the UTM zone. The longitude will fall between the minimum and maximum longitude of the UTM zone.

The False Easting for UTM zones is 500,000 meters, or the equivalent distance in US survey feet or international feet, for both the NAD83 datum and the NAD27 datum. Whereas the False Easting for most SPCS zones was changed significantly to distinguish between NAD27 and NAD83 coordinates, the change in position on the design plane for UTM maps is due only to the datum shift between NAD27 and NAD83, which is not as easily detected. Graphics need to be carefully compared to determine the right coordinate system.
UTM zones can be displayed in Google Earth by changing the Google Earth options. Select the 3D View tab after selecting Tools > Options. Select the Universal Transverse Mercator system and select the Grid option under the View menu.

![Google Earth Options](image)

Figure 27
Select Grid from the View menu in Google Earth.
Testing the Selected Coordinate System using Google Earth

To test whether the selected coordinate system is correct, there are at least four different methods – all of which require the presence of Google Earth software.

1. Export the graphics to Google Earth. Select Tools > Geographic > Export Google Earth (KML) file and observe whether features line up with the Google Earth image. For 3D design files it may be necessary to change the Altitude Mode to “Flatten to Ground” (Tools > Geographic > Google Earth Settings), if the graphics have an elevation that is lower than the Google Earth Terrain.

![Google Earth Tools Settings](image)

2. Place the MicroStation view at a zoom level to display features such as roads, buildings, or water that can be identified in Google Earth. Select Tools > Geographic > Synchronize Google Earth View. The Google Earth image should pan to the same geographical region displayed in the design file view.
3. Place the Google Earth view in a known area of the map at an appropriate zoom level and in MicroStation select Tools > Geographic > Follow Google Earth View. The graphics in the design file should pan to match the geographical location of the image displayed in Google Earth.

4. Compare Google Earth geographic readouts with those in MicroStation. The geographic coordinates and elevation can be read below the Google Earth image. In Google Earth select Tools > Options > select the 3D View tab > select the appropriate format for the coordinate readout under “Show Lat/Long.” If the Google Earth Tour Guide is displayed, it will need to be minimized. See Geographic Coordinate Readout and Input in a Projected Coordinate System for instructions on displaying geographic coordinates in MicroStation.
Geographic Coordinate Readout and Input in a Projected Coordinate System
In MicroStation select Utilities > Auxiliary Coordinates > double click the assigned coordinate system to make it the active ACS (Auxiliary Coordinate System) and dismiss the Auxiliary Coordinates dialog.

![Figure 31](image1.png)

**Geographic Coordinate Readout**
At the lower right of the MicroStation window, right click to enable Running Coordinates on the popup menu.

![Figure 32](image2.png)
Left click on the coordinate readout display at the bottom right of the MicroStation window and select ACS Position from the popup menu. The coordinates will change to geographic coordinate readouts when the cursor is clicked in the view and moved over the MicroStation view. To change the format of the geographic coordinate readout, perhaps to agree with that of Google Earth, select Settings > Design Files > Angle Readout. The geographic coordinates can be displayed in decimal degrees (DD.DDDD) or degrees, minutes, and seconds (DD MM SS) or degrees with decimal minutes (DD MM). Set the Accuracy to specify the precision of the readout.

Click in the MicroStation view and move the cursor to see the geographic coordinates after selecting the ACS Position.
Set the format of the angle readout and the precision of the readout (Accuracy).

Figure 35
**Geographic Coordinate Input**

After setting the projected coordinate system to be the active ACS as described above, coordinate key-ins can be entered using “ax=<longitude>, <latitude>” rather than using “xy=” The key-in would be in response to a prompt from a MicroStation command such as “place point.”

For example, to enter coordinates using degrees, minutes and seconds:

\[
ax=-86:41:55.85, 34:44:13.08
\]

or

\[
ax=86:41:55.85w, 34:44:13.08
\]

Note: Longitude values are entered first, followed by the latitude. Longitude values in the western hemisphere can be specified using a negative sign or by appending a “w” to the longitude. A colon “:” is used as the separator between the degrees, minutes, and seconds.

To enter coordinates for the same point using decimal degrees:

\[
ax=-86.69884722, 34.73696667
\]

To enter coordinates for the same point using degrees and decimal minutes:

\[
ax=-86:41.93083320, 34:44.2180002
\]

Additional geographic data input syntax can be found in the MicroStation help. See Working with Complete Designs > Geo-Coordination > Geographic Coordinate Systems > Using Longitude and Latitude Coordinates.
Figure 36
Capturing Google Earth Images in a 3D Design File

In 3D design files a georeferenced terrain model can be captured from Google Earth and displayed with a draped raster (.JPG) image. The coordinate system of the design file must be set, and the design file must be 3D. A 2D design file can be exported to a 3D design file (File > Export > 3D).

1. Position the Google Earth image to the area of interest.
2. In MicroStation select or create a level for the captured terrain model.
3. Select Tools > Geographic > Capture Google Earth Image > datapoint the screen.
4. Select Fit View if the terrain model doesn’t display in the MicroStation view.
5. Select Settings > View Attributes > change the display style to Smooth. A grayscale image will be displayed draped over the terrain. The .JPG file will be stored in the same folder as the design file and named “<DGN file name>TerrainCapture1.jpg.”
6. To get a color image, in Google Earth select File > Save > Save Image > overwrite the grayscale JPG image.

7. To see the color image, close MicroStation and reopen it.

If the graphics have a lower elevation than the terrain model, they can be moved above the terrain using the Front View in MicroStation.

Multiple overlapping draped images can be captured to improve the image resolution. Zoom into a smaller part of the area of interest and capture the terrain model. Pan to an adjacent area in Google Earth without zooming in or out and capture the adjacent/overlapping terrain model. Remember to save the color image if needed. Repeat the process until the entire area of interest has been covered.

Parts of the terrain model can be masked out by attaching the 3D design file to another design file as a reference file and using the “Clip Boundary” tool with a defined Fence.

![Figure 38](image-url)
Coordinate Systems for Geospatial Databases

A geospatial database is a database that contains both geometry and business data of map features (for example, roads, rivers, buildings, boundaries, fire hydrants, utilities, etc.). Bentley Map is a GIS software application that can utilize either an Oracle relational database that is spatially enabled or the Microsoft SQL Server relational database. See “Working with Spatial Databases” in the Bentley Map help.

The geospatial database is queried to dynamically display features in a MicroStation design file and the business data associated with each feature. The symbology of the displayed features is defined by Bentley Map using the Geospatial Administrator utility. Modifications, additions or deletions to the geometry and/or the business data can be made in Bentley Map, and the changes can then be posted back to the database. Each feature type is usually stored in a single table. In Oracle each table can optionally have a particular coordinate system associated with it. The association is made in the Oracle system table MDSYS.SDO_GEOM_METADATA table and can also be viewed in the MDSYS.USER_SDO_GEOM_METADATA view. In SQL Server each record in a table can have a coordinate system assigned to it.

A numeric code is used to represent the coordinate system and is called a SRID (Spatial Reference Identifier). SRID numbers from 0 to 32768 have the same numeric code used by EPSG (European Petroleum Survey Group) to identify coordinate systems around the world. Numbers greater than 32768 are SRIDs instituted by Oracle prior to the adoption of the EPSG coding system.

In MicroStation the EPSG codes for many coordinate systems are listed in the Select Geographic Coordinate System dialog. The EPSG coordinate systems are often duplicates of other coordinate systems in the same list. For example, in the figure below the code “EPSG: 26729” is the same as “AL-E-NAD27.”
The EPSG code can be searched by selecting the Search tab in the Select Geographic Coordinate System dialog.
Coordinate System Considerations in an Oracle Spatial Database

Valid coordinate systems in Oracle are stored in the system table SDO_COORD_REF_SYS owned by the MDSYS user.

For Oracle the SRID for feature tables can be found in the USER_SDO_GEOM_METADATA view as displayed using Oracle’s SQL Developer application in the figure below.
The USER_SDO_GEOM_METADATA view can be found in Oracle’s SQL Developer application by connecting to the database > selecting “MDSYS” under the “Other Users” node > expand the “Views” node > select the view “USER_SDO_GEOM_METADATA” > select the “Data” tab to view the data.

To be spatially enabled a feature table must have an entry in the USER_SDO_GEOM_METADATA view and have a column to contain the geometry with a data type of MDSYS.SDO_GEOMETRY. The USER_SDO_GEOM_METADATA entries for each feature table are entered manually.

```
INSERT INTO USER_SDO_GEOM_METADATA (TABLE_NAME, COLUMN_NAME, DIMINFO, SRID)
VALUES ('table_name', 'geometry_column',
        MDSYS.SDO_DIM_ARRAY
         (MDSYS.SDO_DIM_ELEMENT ('X', x_min, x_max, x_tolerance),
          (MDSYS.SDO_DIM_ELEMENT ('Y', y_min, y_max, y_tolerance)),
         srid);
```

Note:

1. The geometry_column must have a data type of MDSYS.SDO_GEOMETRY when the feature table is created.
2. The x_min, x_max, y_min, and y_max coordinates define a minimum bounding rectangle using the coordinate system of the srid. If the srid is “NULL” the coordinate system will be considered to be the same as the coordinate system of the design files during a database query. Because
there will not be the capability of reprojecting data from the database to the design file or vice versa, multiple design file coordinate systems cannot be used in this case.

3. The \texttt{x\_tolerance} and \texttt{y\_tolerance} specify the positional tolerance of when two points are considered to be the same point.

If the design file coordinate system differs from the SRID for the feature table, the geometry of the design file will be reprojected to the coordinate system of the feature table when posting to the database. The reverse will be done when querying features from the database.

This is useful technology when the mapped area covers more than one coordinate system, for example, two or more SPCS zones. Different SPCS zones can be used in design files while the feature SRID is for a larger coordinate system that covers multiple SPCS zones such as a UTM zone. Examples of creating spatial feature tables, inserting records into the USER\_SDO\_GEOM\_METADATA view, and creating spatial indexes can be found in the \texttt{Bentley Map help} by selecting “Working with Spatial Databases” > “Working with Oracle Spatial” > “Setting Up Oracle” > “Oracle Objects and XFM Objects” > expand the several nodes about creating the various types of features.
Coordinate systems in MicroStation must be recognized as a valid coordinate system in the MDSYS.SDO_COORD_REF_SYS table. Otherwise an error message will be issued when posting to the database.

Error Inserting Feature (class: TEST_BOX, id: 24)

Invalid geometry for table TEST.BOX, column GEOMETRY.

Oracle details: A specified dimension value is outside the range defined for that dimension. Make sure that all values to be encoded are within the defined dimension range. This error is often caused by a mismatch between the bounds stored in ALL_SDO_GEOM_METADATA and the geometry to be posted.

ORA-13011: value is out of range

Irreparably invalid geometry.

The MicroStation coordinate system will need to be reprojected to a coordinate system that is valid in Oracle before posting to the database.
Coordinate System Considerations in Microsoft SQL Server

Valid coordinate systems are stored in the sys.spatial_references_systems view in SQL Server. Using Microsoft SQL Server Management Studio, connect to the server > select the database in Object Explorer > select Views > select System Views > right click on the sys.spatial_reference_systems view and select “Select Top 1000 Rows” from the popup menu.

SQL Server also uses the EPSG (European Petroleum Survey Group) codes for the SRID (Spatial Reference ID).
SQL Server does not include the coordinate systems of the SPCS zones or UTM zones.

Spatial feature tables created in SQL Server must have a column with a data type of “GEOGRAPHY” or “GEOMETRY.” The SRID is part of the information stored in the geography/geometry column of a table record when the record is inserted. Because there are no SRID values for the SPCS zones and UTM zones in SQL Server, enter a “NULL” value for the SRID when creating a feature table which has a “GEOMETRY” data type. There will therefore be no reprojection that takes place for “GEOMETRY” tables. See Bentley Map help. Select Working with Spatial Databases > Working with SQL Server Spatial > Spatial Type Matching > Creating a Spatial Table.

**Example of Creating a Geographic Table for Points**

Longitude and latitude values are inserted for the point locations of the “places” table. They are separated by spaces. The SRID for each record is 4326 (WGS84) and the data type of the “shape” column is GEOGRAPHY.

```sql
CREATE TABLE places
(gid INT IDENTITY (1,1) CONSTRAINT PLC_PK PRIMARY KEY,
 name VARCHAR(32),
 shape GEOGRAPHY);

-- Sample insert statements
INSERT INTO places (name, shape) VALUES('Edinburgh', GEOGRAPHY::STPointFromText('POINT(-3.19 55.95)', 4326));

INSERT INTO places (name, shape) VALUES('Sydney Harbour Bridge', GEOGRAPHY::STPointFromText('POINT(151.209 -33.855)', 4326));

INSERT INTO places (name, shape) VALUES('Statue of Liberty', GEOGRAPHY::STPointFromText('POINT(-74.045 40.69)', 4326));
```
Example of Creating a Geometric Table for Linestrings

Coordinates can be inserted for the vertices of the “linestring” of the “street” table. The vertices are the X and Y values of a point. The points are separated by commas. The SRID is NULL and the data type of the “geom” column is GEOMETRY.

```
CREATE TABLE street
(gid INT IDENTITY (1,1) NOT NULL CONSTRAINT PK_STREET_GID PRIMARY KEY,
name VARCHAR(50) NULL,
street_cat VARCHAR(50) NULL,
geom GEOMETRY NULL);

-- Sample insert statement
INSERT INTO street (name, street_cat, geom) VALUES ('HIGHWAY 101', 'HIGHWAY',
GEOMETRY::STLineFromText('LINESTRING(398857.58 1539307.39,
402594.05 1539840.70)', 0));
```
Additional Information

For a more general understanding of the concepts and terminology of 3D and 2D US coordinate systems and geodesy from a civil engineering point of view, see:


For a detailed explanation of a process of using Bentley Map to transform arbitrary coordinate systems or project coordinate systems to State Plane Coordinate Systems, see: