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课程概述 
 
 
课程说明 

本课程旨在指导项目管理员如何创建及自定义项目以满足公司标准。您将使
用 OpenPlant 产品系列中的多个工具来支持这些功能。通常情况下，公司需
对符号、菜单或元件定义进行修改，才能使用软件应用程序。 

 
您将学习如何创建新项目元件，对设计元件添加类和属性。您还将学习如何
修改标识，创建并维护管道等级。您将创建并修改报告，以将其置于绘图中
或导出至其他应用程序。 

 
 
 
授课对象 

本课程适用于以下人员： 

• 负责自定义 OpenPlant Modeler 软件以满足公司需求的工程师、设计人员
和制图人员。 

 
 
 
先决条件 

• 学习此课程的学员应具备 CAD 系统操作方面的知识并了解 3D 建模的相关
概念。 

• 学员应已完成 OpenPlant Modeler 用户基础课程。 
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课程目标 

学完本课程后，您将能够： 

• 了解 OpenPlant Modeler 文件夹结构。 

• 了解 Configuration Manager 

• 在 Class Editor 中打开附加 Schema，并编辑 Schema。 

• 元件添加元件属性 

• 修改 Engineering Content Browser 中的显示方式 

• 修改元件标示名称 

• 设置 OpenPlant Modeler dgnlib 

• 修改和创建报告 

• 创建和维护管道等级 
 
 
 
包含的模块 

本课程包含以下模块： 

• OpenPlant Modeler/ModelServer 概念 

• 项目管理 

• Class Editor 

• 配置管理器 

• 元件配置 

• 添加设备 

• 管件 Catalog 和 SPEC 

• 配置管理出图文件 

• 自定义报告 
 



系统要求 
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系统要求 

配有 CD 驱动器，或者通过访问 Internet 来安装产品。如果要运行 
OpenPlant Modeler (SELECTseries 5) 中所包含的模块，需要符合以下条件： 

处理器：Intel ® Pentium ® 4 或 AMD ® 处理器（3.0 GHz 或更高），或者 
Intel ® 或 AMD ® 双核处理器（2.0 GHz 或更高） 

内存：建议 RAM 最少为 4 GB。通常内存越大性能越好，在处理大型模型
时更是如此 

硬盘：1500 MB 可用磁盘空间（其中进行完整安装需要占用 1200 MB 的
空间） 

显卡：DirectX 9.0c 支持的显卡。有关 DirectX 驱动程序的最新信息，请咨
询显卡制造商。建议使用 256 MB 或更大的视频 RAM。当视频 RAM 不足
或者没有 DirectX 支持的显卡时，OpenPlant Modeler 将尝试使用软件仿真。
要获得最佳性能，图形显示的颜色深度应设置为 24 位或更高。当使用 
16 位的颜色深度设置时，会出现一些不一致的情况。对于 Windows 7 系
统，需要使用 128 MB 或具有更大显存的 Direct3D 工作站级显卡 

操作系统：Microsoft® Windows XP Professional（SP2 或更高版本）、
Microsoft® Windows 7（32 位）、Microsoft® Windows 7（64 位） 

Microsoft Office：Professional Edition 2000 (SR1a)、XP、2003、2007 或 
2010。 

Microsoft Office：ProjectWise 客户端 

输入设备：Windows 支持的任何行业标准输入设备。 
 

输出设备：Windows 支持的任何行业标准输出设备。 
 
 
 
软件要求 

ProjectWise Explorer V8i（SELECTseries 3 或 4）、Bentley OpenPlant Modeler 
V8i (SELECTseries 5)、OpenPlant ModelServer V8i (Select Series 5) 的网络访问
权限。 
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注意事项： 

OpenPlant (SELECTseries 5) 在 Windows XP、Windows 7 或 Windows Server 2008 
中的安装目录略有不同。下表提供了软件文件的路径。 

 
Windows XP： 

 
 

网络路径： 程序： 
C:\Program Files\Bentley\OpenPlantModeler 
V8i\ 

 
本地路径： C:\Documents and Settings\All 

Users\Application 
Data\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects 

 
默认项目路径： C:\Bentley Plant V8i Projects\ 

 
 

注意：文档中提到的“网络路径”、“本地路径”和“项目路径”均指以上路径。 
 

Windows 7（32 位）或 Windows Server 2008： 
 
 

网络路径： C:\Program Files\Bentley\OpenPlantModeler 
V8i\ 

 
本地路径： C:\ProgramData\Bentley\OpenPlantModeler 

V8i\WorkSpace\Projects 
 

默认项目路径： C:\ProgramData\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects\ 

 
 

注意：文档中提到的“网络路径”、“本地路径”和“项目路径”均指以上路径。 
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Windows 7（64 位）或 Windows Server 2008： 
 
 

网络路径： C:\Program Files 
(x86)\Bentley\OpenPlantModeler V8i\ 

 
本地路径： C:\ProgramData\Bentley\OpenPlantModeler 

V8i\WorkSpace\Projects 
 

默认项目根目录： C:\ProgramData\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects 

 
 

本培训手册使用 Windows XP（32 位）系统编写而成，因此练习中所使用的
快照和步骤的位置与 Windows XP（32 位）系统一致。如果您使用的是其他
操作系统，则请参阅上面的表格。 
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安装数据集 

为方便起见，已为您提供了操作文件。请将文件解压到适当位置。 
 

 练习 1：安装培训项目。 

1 确保已关闭了所有 OpenPlant 应用程序。 

2 下载数据集文件 
OpenPlant_Modeler_Admin_V8i_SS5_Dataset.zip。 

3 将 Workspace.exe 文件解压到桌面。 

4 双击 Workspace.exe 文件。 

5 单击“Unzip”。 

开始解压缩。 

6 单击“Close”。 
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OpenPlant Modeler/Model 
Server 概念 

模块概述 

OpenPlant Modeler 是三维工厂设计软件系列中的一部分。了解这些模块之间
是如何运作的，对于一个合格的管理员来说是至关重要的。 

 
 
 
模块先决条件 

• 学员应已完成 OpenPlant Modeler 用户基础课程。 
 
 
 
模块目标 

学完本模块后，您将能够： 

• 更深入地了解 OpenPlant 产品套件如何进行交互并相互配合。 
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OpenPlant 设计技术 

本章对 OpenPlant Model Server 进行了概述。OpenPlant Modeler 将工厂元件
存储在中心数据库中。OpenPlant Model Server 可对这些元件进行管理，从
而为用户提供以下功能：检入、检出并参考输出组成完整 3D 工厂模型的
元件。 

 
除了可以存储 OpenPlant Modeler 创建的模型数据，Model Server 还可以导
入任何基于 ISO15926 软件所创建的模型。元件一旦通过服务器导入，可以
像 OpenPlant 自身模型一样可以被编辑。 

 
使用随 OpenPlant Administrator 应用程序一同安装的 Bentley Class Editor，
用户可添加新类（元件类型）和属性（数据库字段）。Class Editor 可以修改
OpenPlant Schema，即一些 Xml 格式的文件。这些概念将在培训手册的其他
部分中进行讨论。 

 
如下所示为 OpenPlant Modeler 系统的基本配置。 
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ProjectWise 

ProjectWise 是 Bentley 的内容管理环境。OpenPlant Modeler 及 ModelServer 
与 ProjectWise 完全集成。除传统的文档管理功能之外，ProjectWise 还具有
强大的安全机制和工作流机制，OpenPlant 可利用这些机制提供稳固的项目
平台。 

 
ProjectWise 可存储所有项目文档和元件 (ModelServer)。这样，用户即可在
分布式环境中充分利用 ProjectWise 的全部优势。 

 
OpenPlant ModelServer 运行在 ProjectWise Integration Server 上。其首要功能
是用作主机，便于用户对 OpenPlant 三维元件进行查询。 

 
Model Server 用户界面已集成至 OpenPlant Modeler 中，进而提供下列功能： 

• 检入 

• 检出 

• 更新全部内容 

• 刷新 

• 参考输出 
 

OpenPlant Modeler Administrator 界面恰好内置在 ProjectWise Administrator 
之中。它可提供用于管理项目的管理员工具。其中一些可用的工具包括： 

• 导入 Schema。 

• 数据库设置。 

• 锁定元件浏览器 - 允许管理员查看哪些人员检出了哪些元件，以
及释放元件。 

• Schema 管理工具 - 允许管理员更新数据库 Schema。 

• 状态 - 允许管理员创建状态。 

• 工作流 - 允许将不同的状态集用于不同类型的文档。 

• 用户 - ProjectWise 用户。 
• 工作组 - ProjectWise 工作组用于在指定工作流内的不同状态上设置

安全性。 

• 工作空间托管- 在分布式环境中，托管工作空间可以让管理员管理
那些控制项目的一系列文件。 
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安全性 

OpenPlant Modeler 使用 ProjectWise 安全和登录功能。这样，即可通过绑定
用户名或单点登录的方式登录到 Windows 域。管理员可利用此功能，基于
设计阶段管理对文件和数据的访问权限或者将访问权限限制于特定成员或组。 

 
例如：您可以让所有配管工程师在设计阶段都有权限访问管道模型，但是
在施工图阶段，某些人会受限。 

 
 
 
OpenPlant ModelServer 

OpenPlant ModelServer 集成于 ProjectWise 管理员端。它可提供用于管理项
目的管理员工具。其中一些可用工具包括： 

• 导入 Schema。 

• 数据库设置。 

• 锁定元件浏览器 - 允许管理员查看哪些人员检出了哪些元件，并
释放元件。 

• Schema 管理工具 - 允许管理员更新数据库 Schema。 

• 状态 - 允许管理员创建状态。 

• 工作流 - 允许将不同的状态集用于不同类型的文档。 

• 用户 - ProjectWise 用户。 

• 工作组 - ProjectWise 工作组用于在指定工作流内的不同状态上设置
安全性。 

• 工作空间托管- 在分布式环境中，托管工作空间可以让管理员管理
那些控制项目的一系列文件。 
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OpenPlant Modeler 

OpenPlant Modeler 是一种桌面建模应用程序，也是进入 ModelServer 数据库
的用户界面。它以最新的 MicroStation 和 ProjectWise 应用程序技术为基础。 

 
您可以利用最新的技术，包括“动态视图”和“托管工作空间”。 

 
OpenPlant Modeler 旨在支持单机、离线及分布式工作等多种工作模式。用户
仅需在定期连接到项目数据库，以生产可交付图纸和报告。 

 
下图所示为 OpenPlant Modeler 的基本工作流。 
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项目管理 
 
 
模块概述 

本模块将向用户介绍 OpenPlant Modeler 的项目管理知识。其中将包括创建项
目的必要步骤，如编辑 DGNLIB 和托管工作空间等。 

 
 
 
模块先决条件 

• 必须事先安装所有软件，其中包括： 

• ProjectWise Integration Server 

• ProjectWise Administrator 

• ProjectWise Explorer 

• SQL Server 2005 或 2008 

• OpenPlant Model Server 

• OpenPlant Administrator 

• OpenPlant Modeler 

• OpenPlant Isometrics Manager 

• OpenPlant Reporting 

• 用户必须具有 SQL Server 和 ProjectWise 的管理员权限 
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模块目标 

学完本模块后，您将能够： 

• 创建 OpenPlant Modeler 项目 

• 加载 OpenPlant Schema。 

• 使用命名表达式编辑 DGNLIB 以配置层 

• 将工作空间托管到 ProjectWise 
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创建 OpenPlant Modeler 项目 

设置工作项目需要以下步骤：复制现有项目以用作种子、复制现有的控制
文件路径的 pcf 文件、将项目 Schema 加载至 ProjectWise 数据库，以及将项
目工作空间导入至 ProjectWise。最后一步会让管理员从 ProjectWise 上控制
整个项目，这样的好处是，所有用户，在任何地方都可以从工作空间中获
得项目配置文件以及更新的模型文件。 

 
 练习：复制现有项目： 

1 打开 Windows 资源管理器，然后浏览至 OpenPlant Modeler 
Workspace\Projects 文件夹。 

 
注意： 有关操作系统的网络路径，请参阅“课程概述”。 

2 展开“Workflows”，然后单击“Isometric Workflow”。 

3 右键单击“Projects”文件夹，然后选择“New > Folder”。 

4 以项目名称命名新建文件夹。针对此练习，请使用名称
“OP_AdminTraining”。 

5 将“Dataset”和“Workfiles”文件夹从 PModeler_metric 项目文件夹
复制到新项目位置。 

 
注意：为了打开 OpenPlant Modeler 项目，您需要项目配置文件 PCF 文件。

这个文件位于项目文件夹中。随后，我们将创建该项目的 pcf 文件。 

6 创建“OPModeler_Metric.pcf”文件的副本，并将其重命名为
“OP_AdminTraining.pcf”。 
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7 使用任意文本编辑器（Notepad、Wordpad 等）打开
“OP_AdminTraining.pcf”。 

 

8 从变量“_USTN_PROJECTNAME”开始，将“OPModeler_Metric”更改
为“OP_AdminTraining”。 

 
 
 

注意： 必须将此变量设置为与项目文件夹同名。您还可以根据需要更改
“_USTN_PROJECTDESCR”变量，该变量即为所显示的项目描述。 
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9 最后，将“OPMS_REPOSITORY_NAME”的名称更改为
“OP_AdminTraining”。 

 
 

 
以上为成功启动项目的所有必要编辑操作，在后续步骤中，您可能还需要更
改很多其他内容。 

 
 
 
导入 OpenPlant 样式 

数据源设置完成后，需要导入 OpenPlant Schema。管理员需要通过
OpenPlant 项目管理员端进行以下两步操作。OpenPlant 项目管理员端在安装
完 OpenPlant ModelServer 管理员端模块后，会在 ProjectWise 管理员端界面
中找到。 

 
 练习：导入 OpenPlant Schema 

1 登录到 PW Administrator，然后展开“OpenPlant Project Administrator”
选项。 

2 单击“Populate Database”。 
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提示： 可能需要等待几秒钟样式状态窗口才能打开。 

3 在“Populate Database”窗口中，单击“Schema Import”。 

4 需要导入的第一个 Schema 为“OpenPlant_3D.01.04.ecshema.xml”。 
 

注意： 公制项目路径（操作系统本地路径）\Bentley\OpentPlant 
Modeler\Workspace\Projects\ OP_AdminTraining\DataSet\Schemas 
文件夹。 

5 选择该文件，然后单击“Open”。 

 

6 随后，需要找到“BentleyBase01.00.ecschema.xml”。此文件应位于 
OPM 工作空间的 … WorkSpace\OPModeler\schemas 文件夹下。 
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7 选择此文件，然后单击“Open”。 

 
 

 
注意： 通常，10 分钟以内便可完成该流程。 

 
注意： 该流程需要您为 OpenPlant 选择一个本地工作目录。此目录与 

ProjectWise 本地工作目录无关。如果不选择工作目录，则无法成
功完成导入。另外，非常重要的是，不同版本的 OPM 可能有新的 
Schema，要确保选择到正确的 Schema！ 
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完成后，您将看到一则消息，提示您重新启动 Project Administrator。要
实现我们此时的目的，仅需关闭 Project Administrator，然后转至 
ProjectWise Explorer 来完成工作。 

 
 

 
 
 

在 ProjectWise Explorer 中创建 OpenPlant 项目 

 练习：创建项目 

1 启动 ProjectWise Explorer，然后使用管理员用户名和密码登录：
admin/admin。 
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2 右键单击“Documents”，然后从菜单中选择“New Project...”。 

 

3 “Project Creation Wizard”窗口打开时，单击“Next”。 

 

4 单击“Browse”。 

选择一个模板项目。 
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5 选取“OP Standard”项目，然后单击“OK”。 

 

6 单击“Next”。 

7 将“Name”更改为“OP_AdminTraining”。 

 

8 单击“Next”。 

9 将“Project Type”更改为“OpenPlant_Template”，然后将“Project 
Name”更改为“OP_AdminTraining”。 
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10 确保 UOR 设置与项目设置匹配，且“Workflow”和“Global Origin”
设置均正确。满足条件后，单击“Next”。 

 

11 单击“Resource Type”对话框中的“Next”，接受所有应用程序。也
可使该列表仅包括将在项目中使用的应用程序。 

 

12 同样，单击“Project Participants”窗口中的“Next”。 
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可在此窗口中设置所有项目团队成员的项目角色。跳过此步骤将导致项
目用户不具有项目权限。 

 

13 要完成项目设置，单击“Review project creation options”对话框中的
“Finish”。 
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创建第二个项目 

要在同一个数据源中再创建一个项目，必须遵守几个特定步骤。这些步骤
如下； 

 
 练习：创建新项目 

1 打开 ProjectWise Administrator，然后登录到培训用数据源。 

2 向下浏览至“Managed Workspaces”节点下的“Project”区域。 

 

3 右键单击“OP_AdminTraining”，然后选择“Copy”。 

 

4 在窗口中右键单击，然后选择“Paste”。在打开的“Copy”对话框
中，接受默认设置并单击“OK”。 
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5 右键单击新的配置块，转至其“properties”，然后将其重命名为
“OP_AdminTraining2”。 

 

6 双击“OP_AdminTraining2”，然后单击“Configuration”选项卡。 

7 从顶部开始，更改“_USTN_PROJECTNAME”的值以匹配新项目。 

 

8 在文件的底部，同样相应更改“OPMS_PROJECT_REPOSITORY_NAME”
的值。 

 

最后，遵循上述步骤在文件系统中复制现有项目并在 ProjectWise 内创建
新项目。唯一的不同之处在于将新项目配置应用于该文件夹。 

 
 
 
配置 DGNLIB 

OpenPlant Modeler 使用 MicroStation 基本配置文件来设置图层、颜色、层和视
图等。 

 
 

先决条件： 
 

对 MicroStation 管理员有一定的了解。特别应了解 DGNlib、“元素模板”、
“命名表达式”和 MicroStation 基本操作。 
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目标： 
 

完成这些练习之后，您应牢牢掌握 OpenPlant Modeler 工作环境的基本配置。
这包括：在 MicroStation 中打开 DGNlib 文件的最佳做法，以及应用符合特
定制图标准的“层”、“颜色”、“元素模板”和“命名表达式”等制图
标准。 

 
 练习：创建 MicroStation 快捷方式 

在这些练习中，您需要在桌面上创建一个专用于打开 MicroStation 的快
捷方式。执行此流程的原因是，无论是否登录到数据源，OpenPlant 属
性都将保存到加载 OpenPlant Modeler 时进行编辑的任何文件。这将导
致所有文件和元件的所有权问题。但是，如果在 OpenPlant Modeler 中
打开 DGNlib 文件，则可使用下面的键入命令将 DSN 信息从 DGNlib 文件
中移除： 

opms remove_signature 

            1 在桌面上或开始菜单中找到“OpenPlant Modeler”快捷方式。 

2 右键单击该图标。 

3 选择“Copy”。 

4 将该快捷方式复制到桌面上，并将其重命名为“OPM_No_OPMS”。 
 

 

 
 
 

5 右键单击新快捷方式。 
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6 选择“Properties”。 

 

7 在“Target:”行末尾添加以下文本，并确保在键入前输入一个空格。 
-wc"C:\Program Files (x86)\Bentley\OpenPlantModeler 
V8i\OpenPlantModeler\config\OPModelerNoOPM.cfg"。 

 

 
注意： 请注意路径问题，以上路径适用于 Windows 7 或 Vista，对于 

Windows XP，该路径仅为 Program Files。此条目会通知 OpenPlant 
Modeler 开始使用 OPModelerNoOPM.cfg 文件。该配置文件会断
开 Modeler 和 Model Server 的连接。 
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 练习：创建 DGNLIB 的副本 

编辑配置文件时，最好在对文件进行任何更改前创建文件的副本。 

1 浏览至“DGNlib”文件。默认位置为：..\OpenPlantModeler 
v8i\workspaces\Projects\OP_Training\DataSet\Dgnlibs\OPModeler.dgnlib 

2 右键单击“OPModeler.dgnlib”文件。 

3 选择“Copy”，然后在同一文件夹中选择“Paste”。 

4 将新副本重命名为“OPModeler.dgnlib.orig”。 

 
 

 
注意： 由于项目配置文件 (pcf) 会指示软件使用该文件夹中的所有 dgnlib 

名称，因此我们通过更改文件扩展名来重命名 dgnlib，而不是直接
更改文件名。通过更改扩展名，我们可以确保不会误用旧文件。 

 
 练习：编辑 DGNLIB 

对项目应用设置标准对设计公司来说至关重要。通常情况下，能够控制
层与颜色以及元件与这些属性的关联方式是项目成功的必要条件。 

在此练习中，我们将编辑 DGNlib 文件以整合制图标准。这将包括创建适
当的“元素模板”和“命名表达式”，这两项标准用于控制 OpenPlant 
Modeler 中元件的“层”、“颜色”、“线型”和“线宽”。 

            1 使用我们在练习 1 中创建的快捷方式打开 MicroStation。 
2 导航至“OPModeler.dgnlib”。 
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3 选择“OPEN”。 

4 从按钮菜单中选择“Level Manager”。 

5 按照如下表所示创建新层。 
 

名称 颜色 样式 线宽 

Pipe 0 0 0 

Equipment 0 0 0 

Centerline 0 0 0 

Insulation 0 0 0 

Supports 0 0 0 

Plant Area 0 0 0 

Tray 0 0 0 

Reserved Areas 0 0 0 

 
 
 

 

              6 退出 Level Manager。 
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7 选择“Element > Element Templates”。 

 

8 展开左侧窗格中的“OPmodeler.dgnlib”。 

9 展开“OpenPlant”。 

10 展开“Piping”。 

 

11 选择“Piping”下的第一项，然后按下 Shift 键的同时选择“Piping”下
的最后一项。 

所有“Piping”下的现有元素模板都应突出显示。 
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12 在“Element Templates”对话框的工具栏中单击“Delete”。 

 
 
 
 
 
 
 
 
 
 
 

13 单击“New Template”。 

14 输入“Model”。 

 

15 选择新模板“Model”。 

16 从“Levels”列表中选择“Pipe”。 
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17 从“Colors”列表中选择“7”。 

 

18 按照如下表所示创建其余模板。完成后，关闭元素模板窗口。 
 

模板组 模板名称 层 颜色 

Piping Model Pipe 7 

Piping Centerline Centerline 3 

Piping Insulation Insulation 4 

Equipment Model Equipment 2 

Equipment Insulation Insulation 4 

Areas Model Plant Area 127 

Tray Model Tray 141 

Tray Centerline Centerline 3 

Reserved Areas Model Reserved Areas 175 

Support Model Supports 250 

Support Insulation Insulation 4 
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 练习：命名表达式 

1 选择“Utilities > Named Expressions”。 

 
 

注意： 这些命名表达式的名称已硬编码。有关所有可用命名表达式的列
表，请参阅附录 A。 
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命名表达式的语法： 
"BY_TEMPLATE:TemplateGroupName:TemplateName" 

 

 
注意： 需要加引号。 

 

2 选择“OP_SYMBOLOGY_AREA”。 

3 将“External Name”更改为“Areas”，并修改表达式： 
"BY_TEMPLATE:OpenPlant\Areas\" & ":Model" 

4 使用下表作为指南来更改其余的“命名表达式”。请注意，以下语
句区分大小写。 

 
命名表达式 外部名称 表达式 

OP_SYMBOLOGY_AREA Area "BY_TEMPLATE:OpenPlant\Areas\" & ":Model" 

OP_SYMBOLOGY_EQUIPMENT Equipment "BY_TEMPLATE:OpenPlant\Equipment\" & ":Model" 

OP_SYMBOLOGY_EQUIPMENT_ 
INSULATION 

EquipmentIns "BY_TEMPLATE:OpenPlant\Equipment\" & ":Model" 

OP_SYMBOLOGY_PIPING Piping "BY_TEMPLATE:OpenPlant\Piping\" & ":Model" 

OP_SYMBOLOGY_PIPING_CENT 
ERLINE 

PipingCenteline "BY_TEMPLATE:OpenPlant\Piping\" & ":Centerline" 
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命名表达式 外部名称 表达式 

OP_SYMBOLOGY_PIPING_INSU 
LATION 

PipingIns "BY_TEMPLATE:OpenPlant\Piping\" & ":Insulation" 

OP_SYMBOLOGY_SUPPORT Support "BY_TEMPLATE:OpenPlant\Support\" & ":Model" 

OP_SYMBOLOGY_SUPPORT_IN 
SULATION 

SupportIns "BY_TEMPLATE:OpenPlant\Support\" & ":Insulation" 

OP_SYMBOLOGY_TRAY Tray "BY_TEMPLATE:OpenPlant\Tray\" & ":Model" 

OP_SYMBOLOGY_TRAY_CENTE 
RLINE 

TrayCenterline "BY_TEMPLATE:OpenPlant\Tray\" & ":Centerline" 

 
 
 

托管工作空间 

在分布式环境中，管理员可通过托管工作空间来管理项目工作环境，进而
确保所有用户，无论何地，均可获得相同的工作空间的文件。以下练习将
向您展示如何在您的培训项目上设置托管的工作空间。 

 
步骤概述： 

1 将 OpenPlant Modeler 工作空间文件导入到 ProjectWise 中一个名为
“OpenPlant Workspace”的文件夹（使用托管工作空间向导）。 

2 将 OpenPlant Modeler 配置文件导入到 ProjectWise 配置设置模块（使
用托管工作空间向导）。 

3 为 OpenPlant Modeler 编辑/添加 ProjectWise CSB。 

4 将 CSB 链接至 OpenPlant Modeler 的项目。 
 

 练习：将 OpenPlant Modeler 工作空间文件导入到 ProjectWise 

1 在 ProjectWise Administrator 中，登录到名为“OP_AdminTraining”的
培训数据源。 

2 在“User Name”字段中键入“admin”。 

3 在“Password”字段中键入“admin”。 
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4 单击鼠标右键，然后选择“Workspace Profiles > Managed”。 

 

随即将打开“Import Managed Workspace Wizard”。 

5 在“Welcome”对话框中，单击“Next”。 

 
6 单击“Next”。 
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选中“Import MicroStation Configuration Files to ProjectWise 
Configuration Settings Blocks”(CSB)。 

 
7 浏览至 OpenPlant Modeler 的正确安装位置，然后验证工作空间位置是

否正确，此位置应自动更新。 

8 满足条件后，单击“Next”。 

 
9 单击“Scan Workspace”。 
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扫描整个工作空间的配置文件，此后无需再逐一添加配置文件。 

 
10 完成后，单击“Next”。 
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在结果对话框中，我们需要移除所有与项目不相关的配置文件。因此，
基于路径移除所有与 OP_AdminTraining 项目不相关的文件。由于 IsoProj 
和 style.cfg 文件无需以这种方式导入，因此我们也可将这些文件全部移
除。您还需要 OP_AdminTraining.pcf 文件和 OPModeler 及 Untitled.ucf 文
件。完成后，将看到如下所示的对话框。 

 

11 单击“Next”。 

继续。 

12 处理完成后，单击“Next”。 
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13 在“Configuration Settings Blocks”页面上，查看即将创建的 
ProjectWise 配置设置块。“Configuration Settings Block”名称可更改
和/或重新分配至不同的 ProjectWise 等级，如果不需要也可将其移除。
根据需要更改名称后，单击“Next”。 

 

14 请检查配置文件设置，如果发现任何错误或更改，请按“back”按钮
返回到“Workspace Import Wizard”；如果配置文件设置满足要求，
请单击“Import”。 

随即开始将配置文件转换为 ProjectWise 配置设置块（缩写为 CSB 或 
CSBs）。 

15 单击“Import”。 
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导入配置。 

 
16 出现“***IMPORT SUCCESSFUL***”消息时，单击“Next”。 

 
这样将返回到“Workspace Import Wizard”主对话框。此时可关闭会话，
稍后继续。现在我们将继续。 

17 选中“Import Data to ProjectWise, from the File System”。 
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18 单击“Continue”。 

 
19 在结果对话框中，右键单击窗口右上角的“dmsSystem”。 

20 选择“New Folder”。 

21 将文件夹命名为“OPM_Workspace”。 

22 在窗口左上方，浏览至 Workspace 文件夹，其路径
为 ..\Bentley\OpenPlantModeler V8i\WorkSpace。 

23 高亮显示此文件夹和刚刚在 ProjectWise 中创建的新文件夹。 

24 单击“Map”。 
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25 单击“Validate”。 

 
26 在“Validate”对话框中，展开“Projects”树。 

27 取消选中所有不需要的项目，然后单击“Remove Unchecked Items”。 

28 完成后，单击“Resolve”。 
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29 出现“***IMPORT SUCCESSFUL***”消息时，单击“Next”。 

 
30 选中“Update ProjectWise Configuration Settings Blocks to Refer to 

ProjectWise Data”。 

31 单击“Continue”。 

此操作会将配置文件中的所有路径重新映射到 ProjectWise 位置。 
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32 验证 OpenPlant Modeler 可执行文件和 Workspace 的路径是否正确，
然后单击“Next”。 

 
33 单击“Next”。 

更新所列配置块。如有需要，可移除所有不希望映射到 ProjectWise 的
配置，方法是将其高亮显示后单击“Remove”。 

34 我们会将所有项目配置均映射到 ProjectWise，因此单击“Next”。 
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35 出现“***Done***”消息时，单击“Next”。 

 
“Remap Paths and Variables”对话框随即打开，需要将窗口左上方的变
量映射至其在 ProjectWise 工作空间中的相应位置。无需重新映射所有
变量，但如果现在进行重新映射，将节省以后的查找时间。 

36 从窗口左上方的“$(USTN_PROJECTDATA)”开始，选中工作区中
“Projects”下的“OP_AdminTraining”文件夹，然后单击“Map”。 
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37 如下所示，沿着列表继续映射每个变量。完成后，单击“Next”。 

 
 

变量 映射位置 

$(PROJECTDATASET) ..\Projects\OP_Training\DataSet 

$(PROJECTWORKFILES) ..\Projects\OP_Training\Workfiles 
$(USTN_SITE) OPM_Workspace\Standards 
$(USTN_WORKSPACEROOT) OPM_Workspace 
$(OPM_ISOMETRIC_DATASET_ROOT) ..\OP_Training\DataSet\Isometrics 
$(OPM_REPORT_DATASET_ROOT) ..\OP_Training\DataSet\Reports 

 
38 单击“Update”。 
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更新修改后的路径。 

 
39 完成后，单击“Close”。 

完成导入过程。 
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 练习：将托管工作空间应用于项目文件夹 

要将托管工作空间设置应用于文件夹，我们首先需要在 ProjectWise 中创
建文件夹，然后才能为其分配工作空间设置。 

1 从“Programs > Bentley > ProjectWise V8i > ProjectWise Explorer”启动 
ProjectWise Explorer。 

 
2 使用“Admin”帐户登录到 OP_AdminTraining 数据源。 

 

3 在 OP_AdminTraining 项目中，右键单击“OP Working Model”。 
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4 选择“Properties”。 

 
5 选择“Workspace”选项卡。 

 
6 双击“Predefined”。 

7 选择“WorkspaceRoot”。 
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8 单击“OK”。 

 
9 双击“Site”。 

10 选择“Standards”。 

11 单击“OK”。 

 
12 双击“Project”。 

13 选择“OP_AdminTraining”。 

14 单击“OK”。 

 
15 双击“User”。 

16 选择这两个“User files”。 
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17 单击“OK”。 

 

18 完成后，单击“Apply”。 

19 单击“OK”。 

将工作空间分配至该文件夹。 

 

现在，在该文件夹中创建或放置的任何文件都将使用我们定义的工作空
间设置。因此，管理员只需管理一组文件，而非多组文件。 
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Schemas 和 Class Editor 
 
 
 
 
 

本章概要 
 

为了控制软件的表示方式，管理员需要修改控制这些表示方式的 schema。
本章将介绍 OpenPlant Modeler Schema 和 Class Editor 功能。 

 
 
 
 

先决条件 
 

• 学员需要完成 OpenPlant Modeler 基础用户课程。 

• 学员需要完成 PW 基础课程。 
 
 
 

本章目标 
 

学完本章，您将能够： 

• 了解不同的 schema 文件及其目录结构； 

• 了解 OpenPlant 的 Class 结构； 

• 使用 Class Editor 编辑 schema。 
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OpenPlant Modeler Schemas 
 

Schema 的作用是描述数据的类的定义、结构等等信息。它是示例数据的元数
据。示例数据由数据行、工作对象，以及其他作为补充的数据信息组成。 

 
元数据简单来说就是用来描述其他数据的数据。描述其他元数据的元数据
叫做元-元数据。 

 
OpenPlant Schema（OpenPlant.08.11），是从 ISO 15926 RDS/WIP 衍生出来，
定义了每个元件的全生命周期数据，并且被所有 OpenPlant Modeler 的
schema 参考。 

 
OpenPlant_3D schema 包含模型属性数据，也被所有 OpenPlant Modeler 
schema 参考。在这个 schema 中，一个控制阀的系统数据和表现属性将在基
本阀门类里面定义。 

 
OPModeler_Imperial、OPModeler_Metric 和 OPModeler_MMetric 项目的附加
schema 里会对这个控制阀做更进一步的定义。这些 schema 将把控制阀归
为仪表类元素，并且带有阀门的定义（比如球阀或者闸阀）。流速、操作
机构类型、端面形式等属性都是附加 schema 中属性的例子。 

 
每个 schema 都被分成几个部分，分别是参考、类、关系类。 

 

• 参考：表示当前 schema 参考了哪些 schema。 
• 类：类是元素范畴的定义。以前面提到的控制阀为例，在 3D schema 中，

控制阀属于基本阀门类型。 
• 关系类：关系类显示了类与类之间的关系。比如 EQUIPMENT_HAS_NOZZLE 

和 UNIT_HAS_NAMED_ITEM。他们之间的关系用来提取某一项目的相关
信息，或者从其父项中获取部分标签的命名。 
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了解各个 schema 文件、目录以及他们之间的关系 
 

 
注意： OpenPlant Modeler 有很多不同的 schema，分别保存在几个不同的目录

中。了解这些 schema 是非常有价值的任务，知道哪个 schema 存储哪些
信息，你才可以编辑正确的 schema，来找到相应的信息。 
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Schema 目录 操作对象 保存路径 

项目级 schemas 对某一项目进行
特定的用户定义-
多数 schema 的
编辑都在此 

..\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_Training\DataSet\Schemas 

工作空间级
（Workspace）
schemas 

对该工作空间下
的所有项目产生
影响-可进行适当
的修改 

..\OpenPlantModeler V8i\WorkSpace\OPModeler\schemas 

基础 OPM 
产品 schemas 

影响整个 OPM
的使用-很少修改 

C:\Program Files (x86)\Bentley\OpenPlantModeler 
V8i\OpenPlantModeler\schemas (Windows 7 or Vista), 
C:\Program Files\Bentley\OpenPlantModeler 
V8i\OpenPlantModeler\schemas (Windows XP) 

 
 
 

Schema 目录 内容 

OpenPlant_3D 项目级 
schemas 

主要的 OpenPlant Modeler schema 

OpenPlant_3D_Pr 
ojectProperties 

项目级 
schemas 

空白 schema，用来进行项目的用户化定义 

OpenPlant_3D_S 
upplemental_Mo 
deling 

项目级 
schemas 

用于绘制元素的建模系统的补充属性 

Openplant_suppl 
emental_tagging 

项目级 
schemas 

定义 Tag 命名 

OpenPlant_3D_S 
upplemental_Mo 
delingViews 

项目级 
schemas 

用来定义在 OPM 中的元素信息和放置元素对话框里显示的属性
分类 

OpenPlant_3D_S 
upplemental_Imp 
erial_DefaultValu 
es 

项目级 
schemas 

定义属性默认值的 schema，比如设备类型或阀门类型 

OpenPlant Workspace 
schemas 

OpenPlant ISO15926 class 结构定义 

BentleyBase Workspace 
schemas 

定义所有元素共有的基本属性，比如 

 
Schema 分为固定 schema 和附加 schema，固定 schema 会参考其他 schema。 
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附加 schema 创建的时候依附于固定 schema，或者作为固定 schema 的子

schema。在附加 schema 中，不能添加新的类、属性和关系，只能添加用

户自定义信息。 
 
 

项目级 schemas 
 
 
 
 
 
 
 
 
 
 
 
 
 

工作空间级 schemas 
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ISO15926 schema 的 class 结构 
 

我们来看一下 Openplant schema 的 class 结构，这是 Bentley 执行
ISO15926schema 定义的表现。在这里，Class（类）也可被称为元件类型。 

 
 练习：浏览 OP class 结构 

 

1 从开始菜单>所有程序>Bentley> Bentley(R) OpenPlant Administrator 
V8i (SELECTseries 5) > Class Editor V8i 启动 Class Editor。 

 

 
 

2 选择 文件 > 打开 > OpenPlant schema。 
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找到前面提到的工作空间 schema 的位置。 

 
3 展开 Classes。 

 
注意： Device class 是基本的物理元素，其他 class，比如 System、Unit、

Pipelint、Segment 是类的组合方式，Named Item 包含所有带有
Tag 名称的类。 

 

4 展开 Device。 
 

5 选择 Piping Component 类。 
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右侧区域 Class 选项卡显示这个类的基本信息。Properties 选项卡显示为
这个类定义的所有属性。 

 
 

6 在 properties 中选择 Tag Number (NAME 属性)。 
 

下面将显示 Tag Number 属性的信息，包括帮助定义和控制这个属性
的用户自定义信息。 

 

 
 

7 选择 Relationships 选项卡。 
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Relationships 选项卡中可以看到与这个类相关的其他类，比如
SEGMENT_HAS_PIPING_COMPONENT, 这里面定义了 Piping Component 和 
Piping Segment 之间的关系。 

 
 
在 Class Editor 左侧，Relationship Class 下面，也列出了所有关系类的详细
信息和列表。 

 

Plant 列表里面是一些典型的类，比如 Area、Unit、Plant 和 System，这些
包括对工厂结构很重要的关系。 

 

Port 类用来定义连接点。 
 

类通常具有继承父类，或者他们的基类属性的功能。 
 

当然，为了给某一类定义其特有的属性，你也可以对这个类的属性进行
修改。 
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Class Editor 
 

工程行业有若干潜在的分散的系统需要整合，所以我们需要一个贯穿流程
工厂全生命周期的通用信息模型。这样一个模型应该能够为所有项目参与
人员提供一个统一的信息环境，包括工艺工程师、设备工程师、运营商、
维护工程师及与项目相关的其他专业人员。 

 
这个应用可以帮助完成数据集成任务，将多个不同应用程序特定的信息模
型转换成一个基于行业标准的信息模型。这样，您的单位可以定义和管理
您的项目或设施的全生命周期信息。 

 

Bentley Class Editor 具有以下功能： 

• 添加从不同系统转换成通用格式的映射功能，使你能够持续维护
企业范围内的数据。 

• 提供一个始终如一的方式，定义贯穿企业所有应用程序的商业
schema。 

• 提供叫做 ECXML 的标准 XML 格式，来定义类和关系。 

• 定义元数据和 schema。 

• 使用 Bentley ECOM（工程内容对象模型 Engineering Content Object 
Model）这一可扩展的软件开发框架。 
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• 支持未来需要开发的插件，包括把 ECXML 类和规则加载进
eWarehouse 的插件。 

 

 
 
 

Class Editor 对话框由两个主要的工具条组成，主工具条和编辑工具条。主工
具条包括常用的菜单选项，比如 File、Edit、View、Tools 等等。编辑工具条
包含编辑菜单里面的工具。下表列出了相应的图标及其功能。 

 
主工具条: 

 
 

图标: 说明: 
 

新建 打开新建 Schema 对话框，创建新的 schema。 
 
 
 
打开 打开 Open Schema 对话框。 
 
 

 
保存 保存新建或修改的 schema 

 
 
 

保存所有 当同时打开多个 schema，并对其中的 schema
进行修改后，点击保存所有，可以打开 Save 
Schema 对话框 
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图标: 说明: 

 
复制 复制类或者属性，可以同时复制多个属性。 
 

粘贴 粘贴已复制的数据（类或属性）。 

Option 打开 Options 对话框，设置参考路径。 

 

平铺显示 平铺的方式列出所有的 schema。 

分层显示 以分层列表的方式显示所有的 schema。 
 

单层显示 以单层列表的方式显示 schema，所有 schema 和
所有的类都在一个文件夹下显示，类与 schema
之间的归属关系 

 
查找类 打开查找类对话框，来搜索类、关系、用户

自定义属性等等 
 
 

编辑工具条: 
 
 

图标: 说明: 

    添加类 
在 schema 中添加新的类 

    删除类 
从 schema 中删除类 

    添加属性 
给类添加新的属性 

    删除属性 
删除某个类的属性 

    添加关系 
在 schema 中添加新的关系类 

    删除关系 
从 schema 中删除关系类 

    自定义属性 
打开自定义属性对话框 

 

 
 

选项卡: 
 

在 Class Editor 中一旦选择了一个类，在右侧的对话框中将有三个选项卡，分
别是 Class、Properties 和 Relationships。 
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Class 选项卡: 
 

Class 选项卡显示类的名称及其显示标签。这个选项卡中列出的方法和过程将
应用到该元件类型上。这里面会显示这个类是否带有自定义属性，这个类
属于哪个基类。 

 
Properties 选项卡: 

 
Properties 选项卡显示的是给这个类定义的属性，以及这个属性归属的原始
schema 是哪个。 

 
Relationships 选项卡: 

 
Relationships 选项卡显示的是元件与其他元件类型之间的关系，比如管嘴和
设备以及管道元素之间的关系定义就在这里。 
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配置管理器 
 
 
 
 
 

本章概要 
 

本章主要介绍 OpenPlant 配置管理器工具，告诉您如何对 Associations, 
Standard Preferences, Model Server 和 Property Categorization 进行监督的
配置。 

 
 
 
 

先决条件 
 

• 学员必须完全掌握 OpenPlant Modeler 基本用户课程。 
 
 
 
 

本章目标 
 

完成本章节学习，您将能够: 
 

• 更好的理解 Associations； 
 

• 控制哪些属性在 Standard Preferences 对话框里显示； 
 

• 自定义属性是如何表示的； 
 

• 在元素信息对话框中对属性进行逻辑分组来显示； 
 

• 修改属性状态，比如允许编辑或者不允许编辑； 
 

• 修改 SPEC 列表的组织方式。 
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OpenPlant 配置管理器 
 

OpenPlant 配置管理器工具为 Associations, Standard Preferences, Model Server 
和 Property Categorization 提供了简洁明了的编辑界面。 

 
 
 

Associations 
 

Associations 定义用来创建管道的相关项。在 Association 选项卡中列出了默认
的关联类及其层次结构，用户可以从 schema 中选择已有的类添加到
Association 中，并按照自己的需要对它们进行关联。 

 
 练习 1: Associations – 操作界面 

 

本练习的目的是熟悉 OpenPlant 配置管理器中的 Associations 操作界面，
不用对当前设置进行任何修改。 

 

1 选择开始菜单 > 所有程序 > Bentley > Bentley OpenPlant Modeler V8i 
(SELECTseries 5) > Bentley OpenPlant 配置管理器。 

 

2 选择 OP_AdminTraining 项目。 
 

3 点击 Select Project。 
 

4 点击 Associations 选项卡。 

 
5 展开 Unit, Service 和 Segment. 
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能看到像 Pipeline、Piping Component 等这些类是灰色的，那是因为它
们被程序使用，用户不能修改它们。 

 

6 在 Existing Hierarchy 中选择到设备。 
 

可以看到对设备类支持的关系定义与对 Unit 支持的关系定义是不同的。 
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7 展开 Pipeline，比较 Pipeline 的属性和 Piping Component 属性有什么
不同。 

 
 
 
 

 

8 你可以使用添加一个新类来指定一个新类在目录树中。 
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Standard Preferences 
 

Standard Preference 中显示了不同操作对象需要的默认信息，下面是管道类

元素的 Standard Preferences. 

 
 

用户通过 OpenPlant 配置管理器中的 Standard Preferences 选项卡，可以自
己设置这些默认信息。用户可以在 Standard Preferences 中添加新的属性，
也可以更新现有的属性。 

 
 练习 1: 添加新属性 

 

本练习将在 Standard Preferences 中添加 Schedule 属性。 
 

1 选择 Standard Preferences 选项卡。 
 

2 在定义 Standard Preferences 列表中选择 Piping Component。 
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注意:  可以通过点击 Add a new for Standard Preferences 来指定一个新
的 Standard Preferences。 

 
 

3 点击右侧的 Add a standard preference property。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4 选择 Schedule。 
 

5 点击 Select Property。 
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Schedule 会显示在 PropertyName 列表中。 

 
 

Box Order 的编号用来控制每个属性在管道元素的 Standard Preferences 对
话框中的显示顺序，Schedule 将显示在最后一行。 

 

6 在 Group Name 中输入 2.Component，如下图所示 

 
 

在 Standard Preferences 中属性值的显示有几种方法，默认是 KEYIN 方式，
需要手动输入数值。 

 

7 选择 Input Method 区域。 
 

8 从列表中选择 Query。
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使用 Query，系统会从当前的等级表中查找相应的属性值，并在菜单中
列出所有可用的唯一值。 

 
 

9 点击 Save。 

 
 

10 点击 OK。 
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 练习 2: 修改已有的属性 
 

在这个练习中，将修改 Insulation Thickness 属性。 
 

使用“VALUE”这种取值方式，可以输入几个用逗号分开的数值，这些
值将会显示在 Standard Preferences for Piping Component 对话框中。 

 
 

1 对 INSULATION_THICKNESS 属性，在 Input Method 区域选择 VALUES。 
 

 
 

2 在 Input Method Arguments 字段中输入需要的保温厚度值，用逗号
分开。 

 

 
 

3 点击 Save。 
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Model Server 
 

在 model server 选项卡里，用户可以通过简洁的用户界面来控制服务器的设
置，而不用在 Class Editor 中编辑这些属性。 

 
 练习 1: Model Server – 界面 

 

本练习的目的是熟悉 OpenPlant 配置管理器中的 Model Server 界面，不用
对当前设置进行修改。 

 

1 选择 Model Server 选项卡。 
 

2 注意当前的设置。 

 
 

Property Categorization 
 

在 Property Categorization 选项卡中，所有 schema 的类和它们的属性都
按照组别来显示，本小节的目的是修改部分属性组别。 
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 练习 1: 修改分组名称 
 

本练习将把分组名称 Design Values 改成 Demo Design Values。 
 

1 选择 Property Categorization 选项卡。 

对话框左侧列出了所有 OpenPlant schema 的类，右侧显示了对每个类
定义的属性。 

 
 

2 找到 Plant Base Object > Named Item > Device > Piping Component。 

3 点击 Edit Category(s)图标对分组名称进行编辑。 
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4 选择 Design from Categories。 
5 把 Display name 改成 Demo Design Values。 

 
 

优先级指的是这个分组在 Place Component 或者 Edit Component 对话框中
的位置，优先级越高越靠前。 

 
 

6 点击 OK. 
 

关闭 Edit Category 对话框，分组名称已经更新。 
 

 
 

7 点击 Save。 
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 练习 2: 把一个属性从一个分组转移到另一个分组 
 

本练习将把 Shop Field 属性从 Operating Conditions 移到 Design Conditions
分组中。 

 

1 选择 Shop Field 属性。 

2 点击 Move property to other category。 

3 在 Categories 中选择 DESIGN_CONDITIONS。 

 

4 点击 OK。 

5 检查 Shop Field 的新位置。 

 
 

6 点击 Save。 
 

 练习 3: 添加一个新的分组 
 

本练习将创建一个新的分组 New Category，并把属性 Short Description 移
到该组。 

1 点击 Edit Category。 

2 选择 Add a new category。 

3 输入新分组的名称 New Category 。 
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4 点击 OK。 

 
 

5 在 Edit Category 对话框中点击 OK。 

 
 

注意:  如果一个分组是空的（没有属性），这个分组将不显示。 
 

6 选择 Short Description。 

7 点击 Move property to other category。 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8 从 Categories 列表中选择 New Category 。 
 

9 点击 OK。 
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新的分组 New Category 现在显示出来了。 

 
10 点击 Save。 

 
 练习 4: 更改属性状态 

 

在 Property Categorization 选项卡中还可以对属性状态进行编辑，比如属
性是否隐藏，可编辑还是只读。本练习将把 Schedule 属性状态从只读改
成可编辑。 

 

1 选择 Property Categorization 选项卡。 
 

2 在 Demo Design Values 中展开 Schedule 属性。 
 

有三种属性状态可进行编辑，分别    是： 
• GeneralStatus– 放置元素时属性在属性对话框里的显示状态。 

 

• ElementInfoStatus – 在 MicroStation 元素信息对话框中属性的状态。
默认情况下通常是只读。对外形属性的修改不会影响元素的属性
状态。 

  



OpenPlant 配置管理器 
 

配置管理器 92 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

• SpecGridPosition (将在后面的练习中讨论)。 

 
3 把 ElementInfoStatus 和 GeneralStatus 都改成 Editable。 

 
 

4 点击 Save。 
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 练习 5: 修改属性在等级列表中的位置 
 

Property Categorization 也能让用户设置属性在等级列表中的位置，这个等
级列表是在使用 OpenPlant Modeler 放置元素的时候自动弹出来的。本练
习将把 Specification 的位置调整到 Rating 和 Schedule 后面。 

 
1 选择 Property Categorization 选项卡。 

 

2 在 Demo Design Values 分组中展开 Schedule, Specification 和 Rating。 
 

SpecGridPosition 的值，Rating 是 30，Schedule 在 rating 的右边，是
31，从这里你可以看出数值越大，属性显示的位置就越靠右，0 表示
不显示。 
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3 修改 Specification 的 SpecGridPosition 值为 32。 

 
 

4 点击 Save。 
 

 练习 6: 在 OpenPlant Modeler 中查看结果 
 

本练习将在 OpenPlant Modeler 中检验之前练习的结果。 
 

检验 Standard Preferences 修改结果 
 

 练习 1 结果: 添加新的属性 
 

目标: 在 Standard preferences 中添加 Schedule。 
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 练习 2 结果: 修改已有属性 
 

目标：给保温厚度预定义数值。 

 
 

检验属性分组的修改结果 
 

 练习 1 结果:修改组别名称  
 

目标：把 Design Values 组别名称改成 Demo Design Values. 

 
 

 练习 2 结果: 把一个属性从一个分组转移到另一分组 
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目标：把 Shop Field 属性从 Operating Conditions 分组转移到 Design 
Conditions 分组。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  



OpenPlant 配置管理器 
 

2013 年 3 月 97 配置管理器 
版权所有 © 2012 Bentley Systems, Incorporated 

 练习 3 结果: 添加新的分组 
 

目标：添加新的分组，并把 Short Description 属性移至该组。 
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定制元件标签 
 

 
 
 

模块概述 
 

本章节提供涵盖大众化的客户定制练习。 
 
 
 

模块前提条件 
 

• 学生应该已经完成了 OpenPlant Modeler 的基础培训课程。 
 
 
 

模块目标 
 

在完成这个模块的学习后，您将能够达到： 
 

• 定制一个元件标记。 
 

• 定制默认的管线号标记。 
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定制管线号的默认标记 
 

在这个练习你将为一根管线（Piping Network System）修改已有的管号编
码格式。然后这个编码将由“介质”“-”“管道等级”“-”“用户能够
键入序列号”组成。在 OpenPlant Modeler 默认的管线号标记是“单元-介
质-管号-管道等级”（HTF-W-001-Training）。新的管线标记将会显示成“介
质-单元-管道等级-管号”（W-HTF-Training-001）。 

 
你将修改“Piping Network System Class Property Tag Number”和修改已存在
的“Custom Attribute CalculatedECPropertySpecification”和 EC 表达变量。 

 
 练习 1：定制管线号标记 
 

1 在“Programs > Bentley > Bentley(R) OpenPlant Administrator”启动

“Class Editor V8i”。 
 

 
 

2 选择“File > Open”。 

我们将打开 OpenPlant schema。 
 

3 打开“..\Bentley\OpenPlantModeler 
V8i\WorkSpace\OPModeler\schemas\OpenPlant.01.04.ecschema.xml” 

 

4 如果必要的话，当出现提示时，导航到为 referenced schemas 的上一

个位置。 
 

5 单击“OK” 
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6 在这个 schema 右键单击，选择“Supplement Schema”。 
 

 
 

7 单击“Add”。 
 

 
 

8 在“..\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining\DataSet\Schemas”目录下浏

览到“OpenPlant_Supplemental_Tagging.01.04.ecschema.xml” 
 

9 单击“Open”。 
 

10 在“Specify Supplemental Schemas”对话框，单击“OK”。 
 

注意： 这个 schema 为这个项目保留的是默认的名称编码定义。 
 

11 展开“Classes”。 
 

列出 classes。 
 

暗示： 你可能不得不在 EC Class Editor 中调整视图“Separate Hierarchy 
View”。 

 

12 展开“Plant Base Object > Named Item”。 
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13 选择“Piping Network System”类。 
 

 
 
 

注意： Piping Network System 是所有管线的父类。Piping Network Segment
是一个独立的管道走向。 

 

14 选择“Properties”选项卡。 
 

15 从“Properties”选项卡中选择“Name”属性。 

 
 

16 在右边向下滚动，找到“CalculatedECPropertySpecification”。 
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17 修改“ECExpression”字段如下： 
“this.SERVICE_NAME & "-" & this.UNIT_NAME & “-” & 

this.SPECIFICATION& “-” & this.NUMBER” 
 

18 修改这个正则表达式如下： 
“^[?\w]*-[?\w]*-(?<SPECIFICATION>[?\w]*)- 

(?<NUMBER>.*)|(?<NUMBER>.*)” 
 

 
 

19 单击“Piping Network System”类。 
 

20 单击“File > Save”。 
 

保存变化了的 schema。 
 

注意： 这个变化是定制属性定义，存储在

“OpenPlant_Supplemental_Tagging.01.04.ecschema.xml”文件中，所以原

始的 OpenPlant schema 不要被修改。 
 

21 启动“OpenPlant Modeler”。 
 

22 创建一个新的模型文件命名为“OPM_Admin”。 
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23 从“Piping Tasks”菜单中打开一个新文件。 
 

24 单击“Create Pipeline”。 
 

 
 

25 如果你没有一个“Unit”或“Service”，通过点击加号边上的下拉列

表来创建它们 
 

注意： 针对这些练习，里面的值并不重要。但为了保证一致性，我们最
好使用“HTF (Heat Transfer Facility)”作为 Unit“W (Water)”作
为 Service 

 

 
 

26 选择“Properties”选项卡 

27 在“Number”字段中键入“001” 
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28 从“Specification”字段中选择“Training” 
 

 
 

注意到现在的名字字段格式就匹配了我们在 schema 文件中记录的样式 
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改变命名的显示方式 
 

这个练习中，您将修改阀门已有的标记样式。闸阀的默认样式是 Type–
Number (HV-100).这个练习将会改变闸阀的样式显示为 Unit-Type-Number 
(50-GV-100)。注意到 Unit 将会被添加，默认的阀门前缀也将会被修改成为 GV 

 
 练习 1：改变标记的显示 
 

1 启动“OpenPlant Modeler”。 

2 打开“OPM_Admin.dgn”。 

3 在上一个练习中画一根管线，好对这根管线来使用 

4 在这根管线上放置一个闸阀 
 

注意在“Device Type Code”和“Number”的标记显示 
 

 
 

5 打开“Class Editor”。 
 

6 关闭掉已经打开了的 Schema 文件。 
 

7 再一次打开“OpenPlant.01.04.ecschema.xml”，附加

“OpenPlant_Supplemental_Tagging.01.04.ecschema.xml”， 
另外从“..\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining\DataSet\Schemas.”打开

“OpenPlant_3D_Supplemental_Modeling.01.04.ecschema.xml”。 
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注意： 这次打开的 supplemental schema 没有连接它的父类的 schema。
任一有效的编辑选项都能够完成编辑。通过 supplemental schemas
你可能看不到全部的树形结构也看不到所有的类，只能看到已经
预定义了自定义属性的那些类。 

 
注意： 类都是在父类/子类的层级关系中被设置。这是一个从基础类的继

承关系。它的意思是，如果一个父类保存了一个特殊的属性，但是
子类没有，这个子类将继承父类的属性，可是，如果子类有一个
属性，不管父类是否有该属性，子类里的属性将会来控制。例如，
如果我们为阀门（父类）设置命名为“AREA-TYPE- NUMBER”，
然后设置闸阀（子类）命名规则为“TYPE-NUMBER”，闸阀会
以“TYPE-NUMBER”命名。与此同时，其他阀门（假设其他阀门
都没有改他们自己的自定义属性）将会标记为 
“AREA-TYPE-NUMBER” 

 

8 导航到“OpenPlant > Classes > Named Item > Device > Piping 
Component > Fluid Regulator > Valve > Inline Valve > Gate Valve”。 

 

 
 
 

9 单击在属性选项卡，下拉到 Tag Number。 
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10 单击“Override”。 
 

使该属性变成可编辑。 

 
 

11 单击“Custom Attributes...”。 
 

12 选择“Add/Remove” 
 

13 在“CalculatedEDPropertySepcification”位置设置到

“OpenPlant_Supplemental_Tagging”schema 
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14 修改这个“Calculated ECExpression”如下： 
“this.UNIT & "-" & this.DEVICE_TYPE_CODE & "-" & this.NUMBER。” 

 
注意： 这个标记名称的定义，它将包含的属性有“NAME (unit)”

“DEVICE_TYPE_CODE (type)”和“NUMBER”通过“-”分隔开 
 

15 在“Failure value”字段中键入“Invalid Tag” 
 

16 在“Parser regular expression”字段，键入“^[?\w]*-
(?<DEVICE_TYPE_CODE>.*)- (?<NUMBER>.*)|(?<NUMBER>.*)”。 

 
 

 
注意： 这个定义也可以反过来分析，当一个用户直接编辑标记，然后软件

能够分析这个变化返回到各自对应的属性，作为标记名称的构成。 

然后，我们将改变默认的前缀，它存储在
“OpenPlant_3D_Supplemental_Metric_DefaultValues”。 

 

17 展开“Classes”。 
 

18 导航到“Gate Valve”类。 
 

19 选择“Properties”选项卡。 
 

20 选择“Device Type Code”属性。 
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21 为 Gate Valves 改变“Default Value”为“GV”。 

 
 

22 点击“Gate Valve”类。 
 

23 点击“Save All”。 
 

24 关掉两个 schemas。 
 

25 从同样的文件夹中打开“OpenPlant_3D.01.04.ecschema.xml”。 
 

26 为 OpenPlant_3D 附加

OpenPlant_3D_Supplemental_Modeling.01.04.ecschema.xml。 
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27 导航至“Plant Base Object > Named Item > Device > Piping 
Component > Fluid Regulator > Valve > Inline Valve > Gate Valve。” 

 

 
 

28 高亮“Gate Valve”。 
 

29 在“Properties”选项卡点击。 
 

30 下拉到“Device Type Code”。 
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注意现在“Default Value”就是“GV”。 

 
 

31 高亮“Globe Valve”。 
 

32 在“Properties”选项卡点击。 
 
  



改变命名的显示方式 
 

2013 年 3 月 113 定制元件标签 
版权所有 © 2012 Bentley Systems, Incorporated 

注意到 Globe Valve 的“Default Value”仍然是阀门类给分配的
“HV”，这个属性是灰色的因为被分在了更高的一层，你可以通过
点击“Override”重置这个值。 

 
 

33 关闭然后重启“OpenPlant Modeler”。 
 

34 重新打开“OPM_Admin.dgn”。 
 

35 在上一个练习中已经放置的阀门右侧放置第二个闸阀。在“Tag 
Format”“Device Type”中注意两个的不同。 

 

 
 
 

注意： 你可以在任何类的层次上灵活的更改这些设置。这些修改会影响到它

的子类的设置，除非你在其子类中覆盖了不同的设置 
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创建一个新的设备类 
 
 
 
 
 

模块概述 
 

这个模块包含的内容是在 OpenPlant Modeler 添加一个设备类，使得用户可以
用“Existing Graphic Elements”命令“Create Component”的过程。 

 
 
 
 

模块前提条件 
 

• 学生应该已经完成 OpenPlant Modeler 基础课程的学习。 
 
 
 
 

模块目标 
 

在完成这个模块后，您将能够实现： 
 

• 创建自定义设备类。 
 

• 更新 Model Server Schemas。 
 

。 
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创建一个新的设备类“BLOB” 
 

 练习：创建一个新的设备类“BLOB” 
 

1 启动“Class Editor”。 
 

2 打开“OpenPlant_3D.01.04.ecschema.xml”
“OpenPlant_Model_Server.01.00.ecschema.xml”和

“OpenPlant_CustomAttributes.08.11.ecschema.xml”。 
 

注意： “OpenPlant_3D.01.04.ecschema.xml”是项目级 schemas，
“OpenPlant_CustomAttributes.08.11.ecschema.xml”和
“OpenPlant_Model_Server.01.00.ecschema.xml”是系统级
schemas 在 OPModeler 下 

 

3 在“OpenPlant_3D.01.02.ecschema.xml”，“Equipment”类右键

单击、 
 

4 选择“Add Derived Class”。 
 

 
 
 

注意： 这个新的类不能是任何一个设备类的父类。 
 

5 输入这个新的类名称“ELECEQP”。 
 

6 改变“Display Label”为“Electrical Equipment”。 
7 在“Electrical Equipment”右键单击。 
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8 选择“Base Classes....”。 
 

 
 

9 在过滤器中：键入“OPMS_BLOBDATA”。 
 

10 单击“Apply”。 
 

 
11 高亮“OPMS_BLOBDATA”然后点击向下箭头按钮。 

12 去把它加入到 Base Classes 列表当中。 
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13 点击“OK”。 
 

 
 

14 在“Electrical Equipment”右键单击。 
 

15 选择“Custom Attributes > Add/Remove”。 
 

 
 

16 在“Available Custom Attributes”窗口导航至

“CUSTOM_GEOMETRY_TYPE”并高亮。 
 

17 点击向下箭头 
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添加自定义属性至“Applied Custom Attributes”窗口。 

 
18 点击“OK”。 

 

19 在“Group ID”字段输入“ELEC”。 
20 在“Group name”字段键入“Elec”。 

 

当用户创建设备时，将会选择“Group name”，然后新的类才能够
被选择。 
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21 保存这个 schema。 
 

22 退出“Class Editor”。 
 

23 选择“ProjectWise Administrator > Open Plant Administrator > 
Schema Management.”。 

 
24 选择“Update Server Schema”选项卡。 

 

25 点击“Select Schema”。 
 

26 在项目 schemas 文件夹浏览至“OP3D schema”。 
 

27 在位于系统 schemas 文件夹导航至“Bentley Base schema”。 
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系统会对拷贝的 schema 和原始的 schema 在数据库中进行比较。 

 
28 在“OpenPlant_3D”下展开这些变化。 

 

29 更改“Display”至“Differences”。 
 

然后在 schemas 就只能看到有变化的内容。 
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注意到你的新的类“ELECEQP”是唯一的改变。 
 

 
 

30 点击“Check All”。 
 

31 单击“Commit”。 
 

32 当弹出“Warning dialog”对话框时点击“Yes”。 
 

 
 
 

请注意这个消息会告诉您数据库将会被修改。 
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33 点击“Continue”。 
 

 
 

34 当进程完成时，关闭 ProjectWise Administrator 

35 选择“Control Panel > Administrator Tools > Services”。 
 

 
 
 

36 在“OpenPlant ModelServer - Server”右键单击。 
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37 选择“Restart”，重启 OpenPlant ModelServer 服务。 

 
 

 练习：测试“ELECEQP”类 
 

1 启动“OpenPlant Modeler”。 
 

2 登录你的数据源。 
 

3 在打开的“ProjectWise”点击“Cancel”。 
 

4 在“OP_Training”项目中打开“OPM_Admin.dgn”。 
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5 在“Equipment Task”窗口，使用“Slab Solid”工具，创建一个任意

大小的立方体“XXmmxXXmmxXXmm”。 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6 在模型中放置一个立方体。 
 

 
 

7 用“Existing Graphic Elements”工具，选择“Create Component” 

8 在设置对话框，“Type”选择“Elect”。 
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9 选择立方体，然后点击“Create”。 
 

 
 

10 在“Name”字段键入“MCC-1”。 
11 点击绿色的对勾， 

保存这个修改。 
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高级 Schema 自定义 
 
 
 

模块概述 

要在真实环境中执行 OpenPlant，管理员需要对 Schema 理念有很好的理解。
本模块包含多个示例，阐释如何自定义 OpenPlant 以满足特定的客户需求。 

 
 
 
模块先决条件 

• 学员应完成对 OpenPlant Modeler 基础用户课程的学习。 
 
 
 
模块目标 

学完本模块后，您将能够： 

• 向特定类添加新属性。 

• 将属性值链接至等级库字段。 

• 创建新类。 

• 自定义元件浏览器。 
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添加新属性 
在下面三个练习中，您将为设备添加新的属性 WBS Number，该属性将
显示在通用类别中，并将该属性的默认值设为 01.01.01。 

 
 练习：新建附加 Schema 

 
我们需要新建一个附加 Schema，来存储为任意属性添加的自定义功能。 

1 从“Programs > Bentley > Bentley(R) OpenPlant Administrator”启动 
Class Editor。 

2 打开位于项目文件夹（即 ..\OpenPlantModeler V8i\WorkSpace\Projects\ 
OP_AdminTraining\DataSet\Schemas）中的 OpenPlant_3D.01.04 Schema。 

3 右键单击“OpenPlant3D.01.04”Schema 并选择“Add New 
Supplement Schema...”。 

 

4 每个 Schema 都会获得一个“Namespace Prefix”，以帮助标识每个 
Schema。在“NameSpace Prefix”行中，为此 Schema 输入“cs”。
保留默认版本号。 
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5 在“Display Label”和“Description”字段中分别输入“Custom Schema”
和“Schema Customizations”。 

 

6 每个 Schema 都会有一个目的，或是“Units”或是“Localization”，
选择“Localization”以实现我们的目的。 

7 对于“Name Descriptor”：可输入您想用于标识 Schema 的任意文本，
可在此字段中输入“OPAdmin”。 

 

优先级别非常重要，因为它们可以在两个不同位置存在同一属性值时决
定使用哪个 Schema 值。这些级别的设置方式与 MicroStation 优先级别的
设置方式相同，数值越大，优先级别就越高。 

8 从“Precedence Level”列表中选择“Project (400-499)”。 
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9 在“Precedence Value”字段中为 Schema 赋值为“401”，然后单击
“OK”。 

 

现在，我们将保存新 Schema，随后将其附加到三维 Schema 中。 

10 右键单击新 Schema 并选择“Save Schema”。 
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11 接受默认文件名并单击“Save”。 

 

12 同样接受“Save As”对话框中的默认值，并单击“OK”。 
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13 最后，右键单击新 Schema 并选择“Close Schema”。 

 
 

 练习：添加新属性 

1 右键单击“OpenPlant3D.01.04”Schema 并选择“Supplement 
Schema...”。 
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2 单击“Add”。 

 

3 选择“OpenPlant_3D_Supplemental_Metric_DefaultValues”，和我们
刚刚新建的 Schema。 

4 单击“Open”。 
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5 单击“OK”。 

 

6 导航至“OpenPlant_3D.01.04\Equipment”类。 

 

7 选择“Properties”选项卡。 

8 已选择“Equipment”类。 

9 单击“Add > New”。 
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添加新属性。 

 

10 更改“Property”的“Name”和“Display Label”，如图所示： 

 
 

 
注意： 单击对话框上方部分，将会刷新更改并显示更改： 

 

11 选择“File > Save All”或单击“Save All”图标。 

保存更改。 
 

注意： 继承按照从“父类”直至“子类”的方式运作，因此，
“Equipment”类的所有子类均会继承此新属性。 
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12 在“DISCONNECTED”模式下启动 OpenPlant Modeler 并检查更改。将
会在“Place Equipment”对话框的“Miscellaneous”部分显示“WBS 
Number”。 

 

13 关闭 OpenPlant Modeler。 
 

 练习：更改属性显示组别并分配默认值 

在本练习中，我们将更改“WBS_Number”的显示分组，使其处于更合
理的位置。此外，我们还将为该属性分配默认值，使其始终具有某值。 

1 打开 Bentley Class Editor。 

现在，我们需要为 OpenPlant3D Schema 附加可定义“用户界面”的 
Schema。 

2 高亮显示“OpenPlant 3D”Schema，然后单击鼠标右键并选择
“Supplement Schema”。 
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3 选择“Add”并添加位于 (..\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining \DataSet\Schemas) 项目文件
夹中的“OpenPlant_3D_Supplemental_Modeling.01.01”Schema 和
“OpenPlant_3D_Supplemental_ModelingViews.01.01”Schema： 

 

4 单击“Open”。 

5 单击“OK”。 

添加已附加的 Schema。 

 

现在，OpenPlant3D Schema 在 Bentley Class Editor 中显示为
“Supplemented”： 

 
注意： 现在已附加了 Schema，这样，附加信息即可用于类和属性。如有

需要，可导航回到“OpenPlant_3D.01.04\Equipment”类，并检
查“Elevation”属性以查看新信息。 
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注意： 现在仍有可用的附加属性 - 它们被称为“Custom Attributes”： 
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6 使用“Elevation”属性，单击鼠标右键并选择“Custom Attributes > 
Copy”。 
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7 高亮显示自定义属性“Category”，并单击向下键，将其添加至对话
框中的“Copied Custom Attributes”： 

 

8 单击“Copy”。 

9 在“Project Properties”Schema 中，针对“Equipment”类查找
“WBS Number”属性。 

10 单击“Custom Attributes > Paste”粘贴这两个新的自定义属性。 

11 单击属性窗格的顶部以刷新更改，且新的“Custom Attributes”现已
添加至“WBS Number”属性。将“Priority”更改为“88”。 
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 练习：分配默认值 

在本练习中，我们将为之前练习中添加的“WBS Number”属性分配默
认值。 

为向“WBS Number”属性分配默认值，需要我们从应用程序 Schema 位
置（即 ..\OpenPlantModeler v8i\Workspace\OPModeler\Schemas）处打开
“OpenPlant_CustomAttributes.08.11”Schema。顾名思义，自定义属性 
Schema 会精确地保留可应用于任何属性的自定义特性。只要 Schema 处
于打开状态，即可查看上述内容。 

1 在“Equipment”类下，高亮显示“WBS Number”属性。 

2 选择“Custom Attributes > Add/Remove…”。 

3 向“Applied Custom Attributes”添加“DEFAULT_VALUE”和
“PROPERTY_DISPLAY_STATUS”。将“Default Values”和“Property 
Display Status”的“Location”下拉菜单分别更改为“Default Value”
Schema 和先前创建的新 Schema。 

4 单击“OK”。 
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5 在“Property Display Status”部分，将“Element Info Status”和
“General Status”更改为“Show:editable”。 

 
 

这样就可以使用“Element Info”工具在“General Info”详细信息窗格
中编辑“WBS Number”。 

6 向“Default Value”自定义属性中的“Value”属性添加默认值
“01.01.01”： 

 
 

7 选择“Save All”并以“DISCONNECTED”模式检查 OpenPlant Modeler 
中的更改。 
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将属性值链接至等级库字段 

交付后，OpenPlant Modeler 并不会使用管道等级中的所有可用信息。在本练
习中，我们会将 Outside Diameter 链接至管道等级字段，以便发布值。 

 
 练习：将属性值链接至等级字段 

1 启动 Bentley Class Editor，并打开位于项目 
Schema ..\OpenPlantModeler V8i\WorkSpace\Projects\ 
OP_TRAINING\DataSet\Schemas 文件夹的 OpenPlant3D Schema。 

2 为此 Schema 附加位于同一文件夹的 
OpenPlant_3D_Supplemental_Modeling.01.01 附加 Schema。 

3 从应用程序 Schema 位置（即 ..\OpenPlantModeler 
v8i\Workspace\OPModeler\Schemas）处打开
“OpenPlant_CustomAttributes.08.11”。 

4 导航至“OpenPlant_3D.01.04\Piping Component”类。该类位于
“Classes > Plant Base Object > Named Item > Device > Piping 
Component”下。 

5 高亮显示“Outside Diameter”属性。 

6 单击“Add”。 

添加新的自定义属性。 

7 选择“OpenPlant_3D_Catalog_AttributeProperties”和
“PROPERTY_DISPLAY_STATUS”自定义属性。 
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8 单击“OK”。 

 

9 修改“Property Display Status”自定义属性的“Element Info Status”
和“General Status”。 
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10 将必填的“Specification”字段名称“PIPE_OD_M”添加至
“OpenPlant_Physical_Catalogue_property_Map”的“PropertyName”
中，如图所示： 

 

11 检查新的自定义属性是否已保存到如下所示的
“OpenPlant_3D_Supplemental_Modeling.01.04”Schema 中。 

12 单击“OK”。 
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13 全部保存，并在 OpenPlant Modeler 中测试更改。现在，“Outside 
Diameter”属性应已填有管道等级表中存储的值。 
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创建新类 Work Package 

下列两个练习将解释如何创建名为“Work Package”的新类和如何重新定义
“元件浏览器”结构以便更好地查看设备信息。 

 
 练习：创建新类 Work Package 

1 启动 Bentley Class Editor 并打开位于项目 Schema 文件
夹 .\OpenPlantModeler V8i\WorkSpace\Projects\OP_AdminTraining 
\DataSet\Schemas 中的“OpenPlant3D”Schema。 

2 导航至“OpenPlant 3D\Named Item Class”。该类位于“Classes > Plant 
Base Object”下。 
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3 右键单击“Named Item”类，并选择“Add Derived Class”。 

 

4 修改新类的“Name”和“DisplayLabel”，如图所示： 

 
 

5 选择“Relationships”选项卡。 

6 单击“Add > Add Source Relationship”添加新关系。 
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7 高亮显示新关系并选择“Go to class”。 

 

8 修改“Relationship”，如图所示： 

 

9 选择“Constraints”选项卡。 
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10 单击“Classes…” 

 

11 将“NAMED_ITEM”从“Project Properties”添加到“Target Constraint 
Classes”。 

12 单击“OK”。 

 
 



创建新类 Work Package 
 

2013 年 3 月 151 高级 Schema 自定义 
版权所有 © 2012 Bentley Systems, Incorporated 

13 将“Target”的“Cardinality”从“(0,1)”更改为表示一对多的“(0,N)”： 

 

接下来，我们需要将新关系类移到“Containment of Individual”关系类
之下。 

14 选择“WORKPACK_HAS_NAMED_ITEM”类上的“Relationship”选项
卡，然后在“BaseClasses”下， 

15 单击“Add Element”。 

 

16 将“Containment of Individual”的实际名称
“CONTAINMENT_OF_INDIVIDUAL”添加到新的“BaseClasses[0]”中： 
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接下来，我们需要将 WorkPack 放入“Associated Item List for Equipment”
中。由于我们希望“Workpack”功能与“Unit”功能类似，因此，可以
复制 Unit 属性进行修改。 

17 导航至“Associated Item List for Equipment”。 

18 选择“Properties”选项卡。 

19 高亮显示“Unit”。 

20 单击鼠标右键并选择“Copy”。 

 

21 导航至“Associated Item List for Equipment”，然后单击鼠标右键并
选择“Paste”。 
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22 可以看到，在“Property”列表中存在两条具有相同“Display Label”
的记录。选择刚刚创建的且“Display Label”为“UNIT1”的条目。 

 

23 如图所示，对值进行修改。 
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24 保存更改并在 OpenPlant Modeler 中检查结果。放置新设备时，您可以
在详细信息对话框的“Associations“部分中查看“Workpack”。 

 
 

 练习：自定义元件浏览器 

在本练习中，我们将自定义元件浏览器，以便“Workpack”在树中处于
可见状态。 

1 在 Bentley Class Editor 中，为“OpenPlant_3D.01.04”Schema 
附加位于 ..\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining\DataSet\Schemas 目录下的
“OpenPlant_3D_Supplemental_Model_Server.01.04”Schema。 
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2 导航至树中的“UNIT”类，并检查附加的类映射。 

 
3 右键单击“Unit”类，并选择“Custom Attributes > Copy…” 
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4 将“MODELSERVER_CLASS_MAP”属性移动到“Copied Custom 
Attributes”窗口，并将“Location”设置为相应的
“OpenPlant_3D_Supplemental_Model_Server.01.04”Schema。 

 

5 单击“Copy”。 

6 右键单击“Workpack”类，并选择“Custom Attributes > Paste”。 
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7 在“ModelServer Class Map”中修改“Abstracted Class Name”，如图
所示： 

 

8 导航至“System Has Named Item”关系类并进行检查。 

 

9 从“System Has Named Item”复制自定义属性
“ModelServerRelationshipMap”，并将其粘贴到 
“Workpack Has Named Item”关系类。 

10 转至“Custom Attributes”并将 Schema 位置修改为
“OpenPlant_3D_Supplemental_Model_Server.01.04”Schema。 
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11 将“Supported”属性修改为“True”并进行全部保存。 
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更新服务器 Schema 

由于我们已经在本地系统上对 Model Server Schema 进行了修改，现在需要
将这些更改输入到数据库中，以便在 OpenPlant Modeler 中查看它们。 

 
 练习：向数据库中加载 Schema 更改 

1 登录到 ProjectWise 数据源，并展开“OpenPlant Administrator”节点。 

2 选择“Schema Management”，然后选择“Update Server Schema”
选项卡。 

 

3 单击“Select Schema”。 

4 导航至位于项目目录（即 .\OpenPlantModeler V8i\WorkSpace\Projects\ 
OP_AdminTraining\DataSet\Schemas ）下的“ OpenPlant_3D.01.04 ”
Schema 并将其选中。 
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随后系统会提示您选择“BentleyBase”Schema。导航至应用程序 Schema 
目录（即 ..\OpenPlantModeler V8i\WorkSpace\OPModeler\schemas），并
选择“BentleyBase.01.00”Schema。然后，系统会检查 Schema 更改，
并显示不同之处。 

 

5 展开“OpenPlant_3D”节点并对其进行切换。将“Display”更改为
“Differences”，然后单击“Check All”按钮。现在，您可以检查更
改，如果对所有更改都很满意，请单击“Commit”。 

将这些修改提交给项目数据库。 
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最终，会显示下列消息：Schema commit completed。注意事项：请立即
重启 ModelServer 服务。 

6 导航至“Services”，并重启 OpenPlant ModelServer 服务。 
 

注意： 您可能需要在项目中删除 PROCESSED Schema 文件，因为这些文
件可能非常大，我们不打算将其加载到管理工作区。 

7 启动 OpenPlant Modeler，检查结果。您将看到“Workpack”位于
“Components”树中。 

 
 

 
 
 

使用系统变量 

 练习：为“Designer”属性指定系统用户名 

1 在 Bentley Class Editor 中，为“OpenPlant_3D.01.04”Schema  
附加位于 ..\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining\DataSet\Schemas 目录下的
“OpenPlant_3D_Supplemental_ ModelingViews”Schema。 

2 选择“Classes > Plant Base Object > Named Item”。 

3 导航至“OpenPlant_3D.01.04\Device Class”。 

4 导航至“Designer”属性，并添加新的
“CalculatedECPropertySpecification”自定义属性。 

5 在“ECExpression”字段中键入
“System.Environment.GetEnvironmentVariable("USERNAME")”。 
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6 输入一个可将系统用户名自动输入到值中的表达式。将“Is calculated 
as default only”属性设置为“True”，可指定创建时所指定的值。 

 
 

 
注意： 鉴于您正在调用系统环境值，您需要将“System.Environment”表

达式包含到“Require ECExpression SymbolSets”中。 

7 选择“Require ECExpression SymbolSets”，然后单击鼠标右键并选择
“Add element”。 

 

8 键入“System.Environment”。 
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9 保存更改并在 OpenPlant Modeler 中检查结果。 
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创建碰撞检查规则 
 
 
模块概述 

OpenPlant Modeler 内置碰撞检查功能。已对它进行规则配置，以便在使用过
程中消除众多典型的冲突（法兰和垫片）。 

 
然而，我们预计大多数用户仍需要附加规则，以便适应他们各自的工作流程。
下面的练习将展示一个创建新规则的示例。 

 
注意： 本练习仅用于演示创建规则的示例。不建议将该示例用于生产。 

 
 
 
模块先决条件 

• 学员应完成 OpenPlant PowerPID 基础用户课程的学习。 
 
 
 
模块目标 

学完本模块后，您将能够： 

• 创建规则以消除不必要的碰撞。 
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创建新规则 

本练习将演示创建新规则的方法。 
 

 练习：创建碰撞检查规则 

1 启动 OpenPlant Modeler。 

2 在“ProjectWise Login”对话框中，单击“Cancel”。 

 
 
 

3 在“File Open”对话框中，确保将“Project”设置为
“OP_AdminTraining”。 

4 打开文件“Example_Piping.dgn”。 

 
5 在“OpenPlant ModelServer Login”对话框中，单击“Cancel”。 
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对于本练习，我们在练习时将断开与数据库的连接。 

 

6 选择“OpenPlant Modeler > Tools -> Clash Detection...”。 

 
 

随即打开“Clash Detection”工具栏。本课程并不讨论所有的“Clash 
Detection”命令，它们会在 OpenPlant Modeler 用户基础课程中涉及到。 

 

7 单击“Clash Detection”。 
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打开“Clash Detection”对话框。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8 单击“New”。 

9 将新的“Clash”项目命名为“Example_1”。 

 
10 将“Example_Piping.dgn”拖放到“Set A”中，而将

“Structure.DWG.i.dgn”拖放到“Set B”中。 
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11 本练习中，“Self Check”复选框保持为清除状态。 
 

注意： 通常，您可能至少需要“自检”主模型。 

12 单击“Process”。 

 
13 在结果窗口中高亮显示“Clash02”。 

14 展开“Element Info”窗口。 

 



创建新规则 
 

创建碰撞检查规则 170 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

注意到，碰撞位于“电缆桥架”和某段钢梁之间。 

 

15 检查“Model”窗口，可以看到电缆桥架和钢梁实际上呈覆盖状态。
而事实上，电缆桥架正好位于钢梁的顶部。我们的目标就是消除此
碰撞。 

 

16 导航回到“Clash Detection”主对话框。 

17 单击“Rules”选项卡。 

18 单击“New”。 
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19 在“Rules Template”对话框中，将“Rule Set”设置为“Suppress 
Clashes (Generic)”。 

20 选择“Suppress clashes with elements that have a specific property 
value”。 

21 单击“Create”。 

 

22 将规则的名称更改为“Suppress clashes with elements that have a 
specific property value.(Tray/Steel)”。 
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23 在底部窗口中，单击蓝色的“<Property>”链接。 

 

24 单击“Change Class”。 

 

25 选择“Shapes”。 

26 单击“OK”。 

 

27 选择“Name”。 
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28 单击“OK”。 

 

29 单击“Results”选项卡。 

30 从“Element Info B”窗口中复制“Name”属性值。 

 
 

 
注意： 确保所复制的内容为值而非属性名。 

31  选择“Rules”选项卡。 

32 高亮显示新规则，然后单击“<Value>”链接。 
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33 将已复制的“Name”值粘贴到键入行中。 

34 单击“OK”。 

 

35 设置规则旁的复选框。 

36 单击“Process”。 
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完成后，注意到 Clash02 当前在“Status”列中显示为“Resolved”，表
示该碰撞已被清除。您还将注意到其他一些碰撞也被清除。 

 
 
  



创建新规则 
 

创建碰撞检查规则 176 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

 



 
 
 
 
 
 
 

2013 年 3 月 177 OP Specification Generator 概述 
版权所有 © 2012 Bentley Systems, Incorporated 

 
 
 

OP Specification Generator 
概述 

模块概述 

谈及管道设计时，术语“等级”是指将管道元件根据压力、材质、公称直径、
壁厚等要素进行分组的常见方法。这就免得各位管道设计者针对每个单独的
元件执行这种繁琐且容易出错的排查任务。这样，符合特定等级的系统相关
信息只需参考等级中所述的指南即可。 

 
从管道元件库（Catalog）构建将要在项目期间使用的等级，这样便于简化建
模流程。元件选择会变得更为有效，同时又能消除所有项目组成员之间共享
一致性时出现的错误。Bentley OpenPlant Modeler V8i Specification Generator 
应用程序不仅可以提供准确报告，而且可用于创建和管理等级与 Catalog 数据。 

 
尽管 Bentley OpenPlant Modeler V8i 为创建等级提供了一种很好的工具，但是，
如果您已经以不同格式创建了多种等级并对其进行了检查，那么您可能需要
尽己所能发挥作用。鉴于此，Bentley OpenPlant Modeler V8i 提供了多种可将
旧 Catalog 和/或等级转换至 OP Catalog 和等级的工具。 

 
Bentley OpenPlant Modeler V8i 提供成千上万个管道元件 Catalog 库。学员可
以使用 Bentley OpenPlant Modeler V8i Specification Generator 实用工具来定义
将要在特定项目中使用的元件。这些特定元件被称为“等级”，其中包含建
模与制造流程所需的所有相关信息（与行业通用等级表相同）。建模和报告
功能的速度变得更快，且由不正确的元件选择所引起的错误更少。 

 
样品等级包含在软件出厂版本中。这些等级适用于英制、公制和混合公制版
本。尽管工厂设备等级可能包含大量的印刷材料，但使用 Bentley OpenPlant 
Modeler V8i Specification Generator 构建的稳固“等级”不仅能够使用户正确
组装管道配置，而且能够在整个项目期间提供可靠的材料报告。借助此模块
可以基本了解如何针对某项目创建等级。 
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模块先决条件 
• 学员必须掌握 Microsoft Access 和 Microsoft Excel 操作方面的知识。 

 
 
 
模块目标 

学完本模块后，您将能够： 

• 了解 Catalog 及其不同类型的表。 

• 了解等级及其不同类型的表。 

• 了解 Bentley OpenPlant Modeler V8i Specification Generator 界面。 

• 从软件提供的 Calalog 创建 OPM 等级。 

• 了解如何添加和修改未包括在 Catalog 中的自定义等级字段。 

• 构建自定义说明。 

• 了解 Catalog 与等级之间的不同。 

• 学习以下 OpenPlant 用户选项： 

• 旧等级（PDS®、PlantSpace、AutoPLANT）。 

• 将旧等级转换为 OpenPlant 格式。 

• 将旧等级转换为用于创建新 OpenPlant 等级的 OpenPlant Catalog。 

• 开发和使用新的 OpenPlant 等级。 

• 开发和使用 OpenPlant Catalog。 
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生成等级 
 
 

行业标准 
 
 

管道行业规范和等级表 
 

为了确保施工质量和人员安全，工艺设施需要按照预定义的规范和等级来
建立。行业规范来源广泛，如政府机构（OSHA、EPA）和诸如美国国家标
准协会 (ANSI)（用于开发控制炼油厂管道操作程序的炼油厂管道代码 B31.1）
之类的组织。在其他国家/地区，可能会应用其他标准，如 DIN、EN 或 
NORSOK。 

 
通常，遵守规范是强制性的，并由监管机构强制执行。针对工厂设施发布
的规范包括诸如压力等级、温度限制、材料组成、工人安全、疏散程序等
行业法规。保险代理机构要求设施的所有者必须遵守这些要求。 

 
 

等级表 
 

等级表（通常被称为行业内等级表）包括设施物理构造的详细信息。对于
一台复杂的工厂设施而言，这些等级表是大量的印刷材料。工程师和设计
师使用等级表来确定管道和设备的大小、材料、等级和尺寸。 

 
计算应力时使用等级表中的信息，以确保元件能够承受施于其上的载荷和
力。采购部门需要使用等级表以确保订购了适当的材料和设备。制造商使
用等级表来确定他们以正确的管道尺寸安装了结构和支撑件。同样，控制
流程的仪器也遵照等级表进行安装，以确保其温度和压力设置正确。 

 
注意： 可在附录 A 中找到样品等级表。 
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类 
 

行业常见等级表也包含用于标识特定用途（根据包含在管道内的商品加以分
类）的元件类信息。这些类除了指定设计与工作温度、压力和腐蚀性，还指
定介质是气体还是液体。类的参数不仅可以建立要在元件之间使用的连接类
型，而且可以建立法兰等级、管道壁厚、压力和温度限制。 

 
示例：ASME/ANSI B16.9 - 2001 - 工厂制锻钢对焊配件。 

 
此标准涵盖了工厂制锻钢对焊配件的整体尺寸、公差、等级、测试和标记
（尺寸为 NPS1/2 ~ 48（DN 15 ~ 1200））。 

 
 

OpenPlant 等级 
 

在本课程中，在提及 Catalog 数据子集的创建时会用到术语“等级”。若创
建和使用得当，这些等级可以确保整个项目所有阶段（从最初的概念设计，
到详细设计，再到施工阶段）的一致性和统一性。 
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OpenPlant Catalog 

Bentley OpenPlant Modeler V8i 包括数据库格式的元件 Catalog，从中可生成
等级。可在项目中自始至终选择和应用这些等级，这意味着建模流程会变
得更加有效率，且制成品将符合已建立的行业规范。整个设计流程中的一
致性也为大型项目提供了其所需的多个领域的可靠材料报告。 

 
安装 Bentley OpenPlant Modeler V8i 时，会将元件 Catalog 安装为 Microsoft 
Access (*.MDB) 文件。此文件格式支持包含多个表的单个文件。 

 
让我们进行简短的浏览。 

 
 练习：使用 Windows 资源管理器查看 Catalog 列表 

1 从资源管理器中选择“(Operating_System 
Local_Root)\OPModeler_Metric > DataSet > Catalogs Databases”。 

将出现随 OpenPlant 应用程序一同安装的公制单位项目 Catalog 列表
（如图所示）。 

 

2 双击“ANSI-ASME”Catalog。 
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以显示可用表。 

 

Catalog 有两种类型的表，即元件表和特殊表。 
 
 

Catalog 管件表 
 

元件表包含元件详细信息。ANSI-ASME Catalog 的元件表包括 BOLT、BRANCH、
CROSSES、ELBOW、FLANGE、GASKET、MISC_FIT、ORIFICE、PIPE、REDUCER、
SPACER、TEE、TOPWORKS、VALVBW 和 VALVFL。元件详细信息将包含元件
类名称（此字段很重要，它控制着 OpenPlant Modeler 如何处理特定元件的
放置）、几何值和端面处理信息。 

 
注意： 不同 Catalog 的元件表不同。 
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例如，CRANE Catalog 的元件表包括 FLANGE、SPACER、VALVBW、VALVFL 和 
VALVESCSW。（由于 CRANE 并不生产其他管件，因此它没有这些管件的表）。 

 
 练习：打开一个表 

1 打开“ELBOW”表。 

请注意所示字段和详细信息。 

 
2 关闭“ELBOW”表。 
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特殊表 
 

特殊表包含 Catalog 特定详细信息。Catalog 可能包含不同的管件表，但应包
含 CatalogTables、DefaultDef 和 DefaultSysIDs。 

 
并非 Catalog 中的所有表均包含元件。一些被认为是“特殊表”的表用于其
他目的。ANSI-ASME Catalog 的特殊表包括： 

• CatalogColumns 

• CatalogTables 

• DefaultDef 

• FilterList 

• SpecGenFieldMap 
 

 练习：打开特殊表 

1 打开“CatalogTables”表。 

在此将看到一个列表，其中列有包含在 ANSI-ASME Catalog 中的所有表。 

 

2 关闭“CatalogTables”表。 
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其他特殊表 

CatalogTables 

可在某些 Catalog 中找到此表，此表包含对表中各列的定义。 
 

DefaultDef 

此表包括“Description Builder”所采用的默认设置。在进行任何自定义
前，它主要包括对 LONG_DESR 和 PIECE_MARK 说明字段的定义。 

 
FilterList & SpecGenFieldMap 

这些表被认为是在 AutoPLANT Specification Generator 应用程序的之前版
本中使用的旧表。Bentley OpenPlant Modeler V8i 无需这些表，因此可以
将它们删除。 

 
组 

 
对于我们的目的而言，术语“Catalog”指的是通常根据标准或制造商进行
分组的特定物理项的集合。示例： 

• 标准 

• ANSI/ASME：包含管件大小、尺寸等的美国标准 

• EN/DIN：欧洲标准 

• JIS：日本标准 

• AWWA：针对管件大小、尺寸等的美国水务工程标准 

• 制造商 

• Taylor Forged：锻钢制配件 

• Crane、Powell、Rockwell、Vogt：阀 

• Sulzer：泵 
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OpenPlant 等级 

在本课程中，术语等级指的是与预定义设计规范相匹配的管件数据库。等
级是单个 Catalog 或多个 Catalog 中提供的元件的子集。 

 
为帮助您入门，一些应用程序（如 ANSI 扩展、DIN、JIS）以及其他行业标准
元件和知名供应商的独特元件中会包含样品等级。 

• A1-OPM：样品碳钢等级，基于 150 磅美国标准协会 

• Ductile：样品球墨铸铁等级（英制：Ductile，公制：MDUCT，混合公制：
MMDUCT。） 

• Victaulic：样品 Victaulic 等级（英制：Victaulic，公制：MVICT，混合公制：
MMVICT。） 

• TriClove：样品 TriClove 等级（英制：Triclove，公制：MTric，混合公制：
MMTric）。 
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创建您自己的等级 

学习如何为特定项目创建等级，这是个不错的主意。例如，A1-OPM 
(CS300.MDB) 是一个包含 300LB 额定管件的样品等级。它是通过滤符合此
条件的管件 Catalog ANSI-ASME、BONNEY FORGED、CRANE、LADISH、GEN 
COMP 和 NON STANDARD 而创建的。 

 
包含在应用程序中的 Specification Generator 实用工具可帮助您根据样品轻松
构建新等级，并对数据库进行自定义以符合客户需求。 

 
使用 Bentley OpenPlant Modeler V8i 建模时并不经常使用 Catalog。这些 Catalog 
用于创建等级。 

 
在本课程中，在提及 Catalog 数据子集的创建时会用到术语“等级”。若创
建和使用得当，这些等级可以确保自初始阶段起整个项目所有阶段的一致
性和统一性。让我们进行简短的浏览。 

 
 练习：使用 Windows 资源管理器查看等级列表 

1 通过资源管理器导航至“(Operating_System 
Local_Root)\OPModeler_Metric\DataSet\Specs Databases”。 

将出现随 Bentley OpenPlant Modeler V8i 应用程序一同安装的公制单位
等级列表（如图所示）。 

 

2 双击“A1-OPM”。 
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以显示可用表。 

 
这些等级也有两种类型的表，即元件表和特殊表。 

 
 

元件表 
 

跟 Catalog 中的元件表一样，等级中的元件表也包含元件详细信息。元件表
由等级的所有者确定。 

 
特殊表 

 
与 Cataog 中的特殊表一样，等级中也存在多个特殊表。最重要的几个特殊
表如下： 

• SpecBranchTable：Bentley OpenPlant Modeler V8i 可使用此表以基于应用
程序中的设置确定会自动放置的配件。例如，带有 100mm 分支中心线的 
250mm 的管段将会放置焊接支管台 (WOL) 

• SpecCatalogs：用于构建此等级的 Catalog 列表。 
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• SpecInfo：关于此等级的常规信息（头信息）。 
 

由于大多数操作都将通过界面来完成，因此，很少需要或无需通过访问来
修改这些表。 

 

  



了解等级菜单和图标 
 

OP Specification Generator 概述 190 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

了解等级菜单和图标 

现在，我们将花费少许时间来了解可用图标和菜单工具栏选项及其功能。 
 
 

“Main”工具栏 

  File > New 

如果当前已加载等级，则在关闭其之前系统将提示您保存这些更改。 
 

注意： 激活此命令后，起初不会发生任何变化。您需要添加能够在等级中生成
内容的 Catalog。 

 

   File > Open 

激活此命令后将显示“Open Spec”对话框，该对话框会提示您导航至
“Open Exchange Spec…”并将其选中，以导航并选择“Open Spec”。 

 
File > Open Exchange Spec 

 
出厂等级和通过“Exchange”选项生成/输出的等级将缺失后端 Catalog。
“Open Exchange Spec”可用于使用和编辑 SpecGen 中的这些等级。此功能
将使用当前等级文件内容为您创建缺失的后端 Catalog。 

 
该选项也可用于打开缺失 Catalog 的 AutoPLANT 等级，但是，首先需要使用
“Tools”菜单中的“Tools > Upgrade to OPM”选项升级 PDW 等级。如果设
置了“Use PDW Data”选项，则无法打开升级的 PDW 等级。 

 
File > Close 

 
关闭激活的文件。在 Specgen 关闭文件前，将会显示以下“confirmation”对
话框对您进行提示： 

 
 
  



了解等级菜单和图标 
 

2013 年 3 月 191 OP Specification Generator 概述 
版权所有 © 2012 Bentley Systems, Incorporated 

单击下列选项之一： 

• Yes：保存更改并关闭等级。 

• No：关闭等级，但不保存更改。 

• Cancel：取消命令 
 

    File > Save 

将对等级/Catalog 的更改保存至打开的等级文件。 

    File > Save As 

用于以其他文件名保存等级/Catalog 副本，或将等级/Catalog 副本保存至其他 
Catalog。如果只是选择了其他文件名，那么在单击“Save”时将会激活副
本文件。 

 
File > Export Section 

 
借助“Export Sections”选项可以将等级部分另存为 XLS 工作表。随后，可
将此文件作为等级表打开并进行查看或打印。.XLS 文件将会在电子表格内
为每一个在等级中定义的等级部分创建新页面。 

 
File > Exchange 

 
“Exchange”对话框中的选项可用于在现有 Bentley 工厂设计应用程序之间
导入/导出等级或 Catalog 数据。当前支持以下工作流的交换： 

• 自 PDS 等级导入 

• 在 PDW 等级和 Catalog 中导入/导出 

• 在 PSD 等级和 Catalog 中导入/导出 

• 在 OPM 等级和 Catalog 中导入/导出 
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File > Exit 
 

退出 Specgen。在 Specgen 关闭文件前，将会显示以下“confirmation”对话
框对您进行提示： 

 
 

Edit > Add Spec Filter 
 

利用该选项可向等级中添加等级过滤器部分。借助等级过滤器可以为该等级
特定管径的管件指定壁厚系数 Schedule。只有在此过滤器中定义的壁厚系数 
Schedule（如果应用此等级）才能在等级部分中使用。可在等级范围的基础
上应用此过滤器，也可将此过滤器应用至各个等级部分。 

 
Edit > Add Spec Header 

 
为 SPEC 添加标题。该选项仅在创建新等级且新等级尚无标题时才可用。 

 

   Edit > Add Section 

在编辑等级过程中，从菜单中选择“Edit > Add Section”或单击主工具栏左
侧显示的“Add Section”，同样会显示“Add New Spec Section”对话框。当
您第一次创建新等级且选择了用于构建等级的 Catalog 时，此对话框会自
动显示。 

 

     Edit > Add Catalog 

可从工具栏或“Edit”菜单中找到“Add Catalogs”选项，激活该选项后会显
示“Open”对话框，借助此对话框可以导航型录存储到的 Catalog。可从此
处选择要用于构建激活等级的 Catalog。 

 
Edit > Remove Catalog(s)… 

 
显示一个对话框，可在此选择要从等级中移除的 Catalog。 
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Edit > PDW Settings > Use PDW Data 
 

启用该选项可以执行以下两个与使用 AutoPLANT PDW 等级有关的操作： 

• 在 OpenPlant Specgen 中创建新等级时使用 AutoPLANT PDW Catalog。与
“Add OPM Information”选项（仅在设置了“Use PDW Data”时该选项才
可用）一起使用时，构建的新等级将附有必要的 OpenPlant 信息，以使
新等级能够与 Specgen 和 OpenPlant Modeler 一起运行。 

• 只要有随附 Catalog，即可使用“Open”选项打开 AutoPLANT PDW 等级，
并对其进行编辑。如果您的机器上未存储 Catalog，那么在第一次打开 
PDW 等级时，需要使用“Open Exchange Spec”选项。这样就可以创建将
为等级所使用的后端 Catalog。 

 
Edit > PDW Settings > Add OPM Information 

 
OpenPlant SpecGen 支持从 PDW Catalog 直接生成等级。但是，直接从 PDW 
Catalog 生成的等级需包括特定的 OPM 数据，以便能够与 OpenPlant Modeler 
应用程序一起运行。如果在未设置“Add OPM Information”的情况下创建了
新等级，则需要运行“Upgrade to OPM”选项以添加必要信息。因此，在构
建等级之前启用该选项，省时又省力。 

 
在设置了“Add OPM Information”选项的情况下，以下信息将被添加至使
用 PDW Catalog 创建的等级中： 

• EC_CLASS_NAME：向所有有效的 OPM 元件记录中添加该字段。这意味着
将向等级中所有已映射到样式中的 OPM 类的 PDW 类添加 OPM 类名称。 

• OPERATOR 表：自 PDW 阀数据生成。OPM 需要使用此表在 Modeler 元
件插入工作流中添加与阀一起的/阀上的执行机构。 

 
注意： 只有在启用了“Use PDW Data”选项时，“Add OPM Information”

选项才可用。 
 

Tools > Branch Table Editor… 
 

等级分支表会填充 OpenPlant Modeler 中 AutoFit 功能所使用的等级 AUTO_TEE 
表。在铺设管件（具体方法是确定与交点相匹配的配件类型，随后放置正确
的分支管件）时，AutoFit 有助于实现配件放置任务的自动化。分支表用于选
择自动插入的三通、支管台等。 
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在 OpenPlant Modeler 中放置管道元件时，“Component Placement”对话框
中会显示“AutoFitting”选项卡，可利用该选项卡设置“Branch”选项，以
定义在使用 AutoFitting 放置元件时使用分支表的方式。 

 
以下选项可用： 

• Use Branch table：如果设置了该选项，那么只要 Modeler 中存在分支连
接，即会自动插入在分支表中定义的元件。如果在分支表中定义了多个
元件，那么将插入具有优先权设置的元件。 

• Show spec Selection Grid：只有在分支表中选择了多个元件，Modeler 才
会考虑该选项。随后将显示“Spec Record Selection”，可借此从列表中
选择元件。 

 
Tools > Branch Code Editor… 

 
“Branch Code Editor”提供了一个界面，用于编辑被分支表用作进一步过
滤等级的方式的分支规范。分支表栅格中的每一个单元都包含一个列表，
用户可从中选择进行管线尺寸组合时所要使用的元件类型。列表中的内容
不是类名称，而是代表一类或多类的分支规范。分支表栅格中的分支规范
列表是根据当前等级中具有此尺寸的有效元件进行过滤的。 

 
Tools > Upgrade to OPM 

 
“Upgrade to OPM”选项用于向现有 PDW 等级添加 OPM 信息，以使您能
够在 OpenPlant Modeler 中使用现有 PDW 等级。无需在 SpecGen 中打开这些
等级便可执行“Upgrade to OPM”选项（即可在 OpenPlant Modeler 中将这
些已升级的等级用作本地 OPM 等级，而无需使用 Specgen 进行任何进一步
的交互）。 

 
该选项的一个优点是可以同时升级多个 PDW 等级，而无需在 Specgen 中分
别打开每个等级。 

 
对 PDW 等级进行升级后，向等级中的管道表添加以下信息： 

• EC_CLASS_NAME：向所有有效的 OPM 元件记录中添加该字段。这意味着
将向等级中所有已映射到样式中的 OPM 类的 PDW 类添加 OPM 类名称。 
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• OPERATOR 表：自 PDW 阀数据生成。OPM 需要使用此表在 Modeler 元件
插入工作流中添加与阀一起的/阀上的执行机构。 

 
虽然“Upgrade to OPM”选项可将典型的 PDW 等级转换为可在 Modeler 中使
用的 OPM 等级，但是该选项不会将 SpecGen 特定表更新为 OPM 格式。因此，
用户仍需使用 OPM Catalog 重新构建等级，或使用“Open Exchange Spec”
选项以在 SpecGen 中使用此等级。 

 
Tools > Convert Spec to Catalog… 

 
用户可借助此功能将等级转换为 Catalog，而无需在 SPECGEN 中打开它们。 

 
Tools > Preview Spec 

 
用于预览等级的元件记录。 

 
Tools > Preferences… 

 
首选项可随时进行更改，且无需加载的任何特定等级或 Catalog。 

 
在自定义某个字段之前，必须首先在 Specgen 中加载一个有效的等级/Catalog，
并至少定义一个等级部分。 

   定义自定义字段（仅图标） 

 练习：定义自定义字段 

1 单击工具栏中的“Define Custom Fields”。 
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显示以下编辑器，在此可以为将应用于整个等级的说明字段创建自定
义定义。 

 
 

注意： 也可以在等级某类元件的 Section 的某一行信息上完成对其他说明字段的
自定义。在等级层上自定义的字段会被继承到该等级的每个 Section 上，
也可能会被覆盖。 

 
Define Custom Fields > Description Fields 

 
也可以在等级某类元件的 Section 的某一行信息上完成对其他说明字段的自
定义。在等级层上自定义的字段会被继承到该等级的每个 Section 上，也可
能会被覆盖。 

 
Define Custom Fields > Lookup Fields 

 
字段可与任何可用的查找表关联。将字段与查找表关联后，可从查找表提供
的值中选择该字段的值。 

 
Define Custom Fields > User Fields 

 
单击“User Fields”选项卡，在等级层创建新字段。在该选项卡中定义某个字
段后，可将该字段自定义为“Description”字段或“Lookup”字段。也可将
这些字段用作等级部分中的约束列。 

 
  



了解等级菜单和图标 
 

2013 年 3 月 197 OP Specification Generator 概述 
版权所有 © 2012 Bentley Systems, Incorporated 

Section Manager 
 

位于界面右上角的“Section Manager”按钮会显示一个控件，可用于管
理 Specgen 界面中不同部分的显示。 

 
Section Manager > Spec Header 

 
“Specification Header”区域可用于保存有关等级的描述性信息。执行等级上
的“Save”时，将保存详细信息。 

 
Section Manager > Spec Filter 

 
利用该选项可向等级中添加等级过滤器部分。借助等级过滤器可以为特定
管径的管件指定要 Schedule 壁厚系数。只有在此过滤器中定义的 Schedule 
壁厚系数（如果应用至等级）才能在等级部分中使用。可在等级范围的基
础上应用此过滤器，也可将此过滤器应用至各个等级部分。 

 
Section Manager > Sections 

 
用于显示为当前等级定义的所有等级部分的列表。 

 
 

Lookup Table Editor 
 

借助“Lookup Table Editor”可定义新查找表或编辑现有查找表，随后，可
以在自定义现有用户字段时使用这些查找表。SpecGen 会附带一些默认的
查找表，可根据需要对这些表进行修改。这些查找表分别存储在  
%Local_Install%\\WorkSpace\OPModeler\OPSpecGen\Lookup.mdb。 

 
Lookup Table Editor > Lookup Tables 

 
字段可与任何可用的查找表关联。将字段与查找表关联后，可从查找表提
供的值中选择该字段的值。 

 
Lookup Table Editor > Values of Components 

 
可用于添加、移除或编辑选定查找表的值。 
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“Spec Header”工具栏 

    Add Property 

用于定义要包括在标题中的新描述性属性。 
 

    Delete Property 

用于从标题中删除选定的属性字段。 
 
 

“Section”工具栏 

    Add Classes to Section 
用于修改与等级部分关联的类。要从“Selected Classes”中移除类，请选
择该类，然后单击“<”按钮。同样地，也可从“Available Classes”部分添
加类，方法是选择该类，然后单击“>”按钮。 

   Add Remove Constraints 

该控件可用于指定在此部分中可用的字段，以便定义约束。 
 

要向“Selected”部分添加字段，请从“Available”部分选中该字段，然后单
击“>”按钮。同样地，要从“Selected Fields”部分移除字段，请先选中该
字段，然后单击“<”按钮。单击该控件外部的区域时会应用这些更改。 

 

    Add New Row 

Specgen 将向当前部分添加新的空白行。 
 

    Expert Mode 

可随时清除每个等级部分中的“Expert Mode”复选框，以显示每个约束行
的“Count”字段中定义的过滤结果相匹配的激活 Catalog 的记录数量。对
“Expert Mode”进行设置后，计数标签的颜色将发生更改，以区别于其他
标签。 
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为了在每次修改约束行中的一个字段时使 SpecGen 不再重新生成元件计数，
应对此复选框进行设置以暂停生成计数。可随时更新计数，方法是清除
“Expert Mode”复选框或单击栅格中的计数字段标签。 

 
单击“Count”标签，将仅显示当前计数。如果继续修改约束，则直至再次
单击“Count”标签或清除“Expert Mode”复选框时才会重新生成计数。 

 

    Dynamic Filtering 

设置后，该选项会基于现有约束字段值过滤约束字段中的可用值。例如，
如果在约束行中定义了类名称，那么该行中的其余字段将仅存在与该类相
关的值。如果您指定了端面条件，则会以其他方式过滤可用值，以便仅包
括具有定义的端面条件的元件。 

   Preview Section 

单击该按钮以显示以下预览或选定等级部分中的元件。 
 

    Apply Spec Filtering 

设置此选项后，将会在当前等级部分应用过滤器。再次单击将从等级部分
移除过滤器。 

    Define Section Descriptions 

已为 SpecGen 创建了“Description Builder”，用户可借此创建说明字段的
定义。将“Define Custom Fields”对话框创建的定义应用于整个等级时，可
将特定的字段说明应用于每一行，以覆盖默认设置。 

 
  



Specification Generator 概述 
 

OP Specification Generator 概述 200 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

Specification Generator 概述 

Specification Generator 应用程序随 Bentley OpenPlant Modeler V8i 一同安装，
用于为 OpenPlant Modeler 创建等级。软件安装后将自带范例 SPEC，用于示
例项目的建模。 

 
等级建立后，将在项目中进行激活，以确保在整个项目中的一致性。在建模
过程中，CAD 设计师将使用预定义的等级。 

 
Specification Generator 还可用作 Catalog Editor，用于添加 Catalog，或者编
辑现有 Catalog 记录。您也可以定义某些字段中所允许的输入类型、向现有数
据库中添加新表、从现有表格中删除字段，还可以实现其他多种自定义功能。 

 
 

电子等级表 
 

Specification Generator 的体系结构以管道设计师所熟知的工作方法（即，
采用等级表）为基础。 

 
注意： 附录 A 中给出了相关示例。 

 
Specification Generator 使用此相同的方法基于管件 Catalog 来生成等级。通
过此体系结构可对每个管件的条目进行查看和修改，进而简化更新过程。您
只需修改所需条目的约束条件，然后重新建立等级。 

 
使用 Specification Generator 的基本步骤 

1 启动 Specification Generator。 

2 选择用于建立等级的 Catalog。 

3 添加等级标题并填充内容。 

4 向等级中添加条目。 

5 定义条目的过滤条件。 

6 继续为不同元件类型添加条目和过滤条件。 

7 保存等级。 
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创建新等级 

现在您将使用 Specification Generator 应用程序来构建包含所有搜索条件的新
等级。 

 
注意：构建等级时，不要忘记添加所需的管嘴、过滤器、控制阀、减压阀等，

这些不会在书面形式的管道等级中指定。 
 

 练习：使用 Specification Generator 

将创建一个名为 My_New_Spec 的新等级，定义描述性信息并加以保存。
将基于“附录 A”中的等级创建此等级。 

1 在 Windows 的“开始”菜单中选择“All Programs > Bentley > 
Bentley OpenPlant Modeler V8i (SELECTseries 5) > Bentley OpenPlant 
Specification Generator”。 

2 选择 OP_Training_M，然后单击“Select Project”。 

 

3 选择“Tools > Preferences...”。 

4 设置以下首选项。 

 

5 单击“OK”。 

6 关闭 Specification Generator，然后重新打开它。 
 

警告： 如未按此操作，当关闭并重新打开等级后某些信息会丢失。 

7 选择“Edit > Add Catalog...”，或单击“Add Catalog to Spec”。 
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随即出现一个对话框，显示可用的 Catalog。 

 
8 选择最上面的数据库，然后按下 Shift  键的同时选择最下面的数据库。 

9 单击“Open”。 
 

注意： 您的文件夹中可能会显示更多 Catalog。如果出现此情况，可单击
并按住 Ctrl 键，以选择此处显示的 Catalog。 

进度条指示正在加载 Catalog 数据。 

 
10 选择“Edit > Add Spec Header...”。 
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Header 部分将出现在等级顶部，如图所示。 

 
11 选择“Add Property”。 
12 在“Enter the name of Property”字段中键入“Temperature”。 

 

13 单击“OK”。 

14 填充对话框，如图所示。 

 
• 公司 =“Bentley Systems Inc”. 

• 部门 = 

• 地点 =“Exton, PA” 

• 等级编号 =“My_New_Spec” 

• 项目 =“Training” 

• 说明 =“150# Spec” 

• 温度 =“797°F (425°C)” 

15 选择“File > Save”，或单击“Save Spec”。 

注意： 还可以按下键盘上的 Ctrl S 键 

16 将新等级命名为 My_New_Spec。 
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 练习：添加管道条目，然后配置约束条件。 

1 选择“Edit > Add Section...”，或单击“Add New Section”。 

2 从“Select Section Name”对话框列表中选择“PIPE”。 

3 单击“OK”。 
 

 练习：向管道条目添加类 

1 单击“Add Classes to Section”。 

2 选择“PIPE”和“PIPE_NIPPLE”。 

3 单击“Add”。 

以将它们添加到右侧列中。 

4 选取对话框以外的点以关闭对话框。 

请注意，其他图标将不再显示为灰色。 

5 选择“Add New Row”。 

 练习：添加约束条件 

1 选择“Add/Remove Constraints”。 
2 选择“EC_CLASS_NAME”、“SCHEDULE”以及“COMP_LEN”。 

3 单击“Add”。 

以将选中项添加到右侧列中。 

4 选取对话框以外的点。 

5 设置以下约束条件 

• 类名称 =“PIPE” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“50mm” 

• Schedule = 80 
 

注意： 现在应有 11 种等级，但“附录 A”中仅列出了 6 个等级（15mm、
20mm、25mm、32mm、40mm 和 50mm）。 

6 右键单击管线。 

7 为选择集选择“Preview Row”。 
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随即会打开下面的对话框。 

 
 

注意： 此处显示的尺寸并非与“附录 A”中的等级相同。之后我们将对其
进行修改 

8 关闭对话框。 

9 选择“Add New Row”。 

10 设置以下约束条件 

• 类名称 =“PIPE” 

• 最小尺寸 =“80mm” 

• 最大尺寸 =“250mm” 

• Schedule = 40 

11 选择“Add New Row”。 

12 设置以下约束条件 

• 类名称 =“PIPE” 

• 最小尺寸 =“300mm” 

• 最大尺寸 =“500mm” 

• Schedule = STD 

13 选择“Add New Row”。 

14 设置以下约束条件 

• 类名称 =“PIPE_NIPPLE” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“50mm” 

• Schedule = 80 
 
  



创建新等级 
 

OP Specification Generator 概述 206 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

按 COMP LEN 选择列表，将显示共有 4 种管嘴长度（50.8mm、76.2mm、
101.6mm 和 152.4mm）。请注意，还有一个“...”选项 

 
注意： 注意，有 120 个短管满足条件。 

15 针对 COMP_LEN 从列表中选择“...”。 

会出现下面的对话框。 

 

16 选中“76.2”和“152.4”对应的复选框。 

17 单击“OK”。 
 

注意： 注意，现有 60 个短管满足条件 
 
  



创建新等级 
 

2013 年 3 月 207 OP Specification Generator 概述 
版权所有 © 2012 Bentley Systems, Incorporated 

 练习：为直管和短管添加说明 

1 选择“Define Section Descriptions”。 

2 选择“Add Description”。 

3 从“Column”列表中选择“LONG DESCRIPTION”。 

4 在“Value”列中右键单击。 

随即会打开下面的对话框。 

 

5 双击“SHORT_DESC”。 

将变量移至底部。 

6 键入 [, SMLS, SCH.]。 

7 双击“SCHEDULE”。 

文本现应显示为“<<SHORT_DESC>>[, SMLS, SCH.]<<SCHEDULE>>”。 

8 关闭对话框。 

9 右键单击其中一个直管并进行预览。 

注意长说明。 

10 关闭对话框。 
11 右键单击“PIPE_NIPPLE”管线。 

12 从列表中选择“Custom Description”。 

13 将值更改为“<<SHORT_DESC>>[, SMLS, 
SCH.]<<SCHEDULE>>[ x ]<<COMP_LEN>>[“]”。 

14 关闭对话框。 

15 预览修改后的管线。 
注意长说明的变化情况。 

 
  



创建新等级 
 

OP Specification Generator 概述 208 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

 练习：添加等级过滤器 

本章前面已提到，我们将缩小可供最终用户使用的选择集范围。此功能
通过等级过滤器实现。借助等级过滤器，可轻松过滤出与特定直径 
Schedule 匹配的壁厚系数的管件。这也有助于去除 Catalog 中并非在此特
定等级中使用的多余直径。 

但是请注意，等级过滤器只能过滤主直径。具有两个壁厚系数 Schedule 
的任何元件（例如，异径管和/或异径三通接头必须分开处理） 

对于未使用壁厚系数 Schedule 而使用壁厚的等级，应予以特殊考虑。注
意，等级过滤器仅对“SCHEDULE”字段进行过滤。Schedule 为将此功能用
于要求使用壁厚而不要求使用壁厚系数的等级，应将“WALLTHICKNESS_1”
字段复制到 Catalog 数据库中的“SCHEDULE”字段。 

1 选择“Edit > Add Spec Filter”。 

随即会打开下面的对话框。 

 

2 按以下方式填充字段： 

• 如使用介于 15mm 和 50mm 之间的尺寸（即 15mm、20mm 等），
请选择 Schedule 80。 

• 如使用介于 80mm 和 250mm 之间的尺寸（即 80mm、100mm 等），
请选择 Schedule 40。 

• 如使用介于 300mm 和 500mm 之间的尺寸（即 300mm、350mm 
等），请选择 Schedule STD。 

• 对于所有其他尺寸，请选择 N.A。 

 

3 选择“Filter Spec”。 
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4 注意管道 (15mm - 50mm) 计数的更改。 

5 请注意，在等级过滤器配有通用过滤器，并且每个独立的条目都配
有一个通用过滤器。因此，可开启或关闭整个等级的等级过滤器，
或仅打开或关闭某个条目的等级过滤器。 

 
 练习：添加弯头条目，然后配置约束条件。 

1 选择“Edit > Add Section...”或选择“Add New Section”。 
注意，列表中不包含“Elbows”的选择集 

2 在“Enter Sector Name”字段中键入“ELBOWS”。 

3 单击“OK”。 

 

注意，全部弯头图标已显示为灰色。这是因为没有与弯头相关联的类。 

4 选择“Add Classes to Section”。 

5 选择“LONG RADIUS_45_DEGREE_PIPE_ELBOW”和“LONG 
RADIUS_90_DEGREE_PIPE_ELBOW”。 

6 单击“Add”。 

7 选取对话框以外的点。 

请注意，其他图标将不再显示为灰色。 

8 选择“Add New Row”。 

9 选择“Add/Remove Constraints”。 

10 从列表中选择“EC_CLASS_NAME”、“RATING”、“CATALOG”、

“END_COND_1”和“SCHEDULE”。 

11 单击“Add”。 

12 选取对话框以外的点。 

13 设置以下约束条件： 

• 类名称 =“LONG RADIUS_90_DEGREE_PIPE_ELBOW” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“50mm” 

• 压力等级 =“3000LB” 

• Catalog =“ASME/ANSI B16.11” 
• 部件端面 1 连接形式 = SWF 
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14 选择“Add New Row”。 

15 设置以下约束条件： 

• 类名称 =“Pipe Elbow 45 Degree Long Radius” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“50mm” 

• 压力等级 =“3000LB” 

• Catalog =“ASME/ANSI B16.11” 

• 部件端面 1 连接形式 = SWF 

16 选择“Add New Row”。 

17 设置以下约束条件： 

• 类名称 =“LONG RADIUS_90_DEGREE_PIPE_ELBOW” 

• 最小尺寸 =“80mm” 

• 最大尺寸 =“250mm” 

• Schedule = 40 

• Catalog =“ASME/ANSI B16.9” 

18 选择“Add New Row”。 

19 设置以下约束条件： 

• 类名称 =“LONG RADIUS_45_DEGREE_PIPE_ELBOW” 

• 最小尺寸 =“80mm” 

• 最大尺寸 =“250mm” 

• Schedule = 40 

• Catalog =“ASME/ANSI B16.9” 

20 选择“Add New Row”。 

21 设置以下约束条件： 

• 类名称 =“LONG RADIUS_90_DEGREE_PIPE_ELBOW” 

• 最小尺寸 =“300mm” 

• 最大尺寸 =“500mm” 

• Schedule = STD 

• Catalog =“ASME/ANSI B16.9” 

22 选择“Add New Row”。 
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23 设置以下约束条件： 

• 类名称 =“LONG RADIUS_45_DEGREE_PIPE_ELBOW” 

• 最小尺寸 =“300mm” 

• 最大尺寸 =“500mm” 

• Schedule = STD 

• Catalog =“ASME/ANSI B16.9” 

24 选择“Define Section Descriptions”。 

25 选择“Add Description”。 

26 从“Column”列表选择“LONG_DESCR”。 

27 在“Value”列中右键单击。 

随即会打开下面的对话框。 

 
28 双击“SHORT_DESC”。 

将变量移至底部。 

29 关闭对话框。 

30 右键单击“Small Bore Line Sizes”。 

31 从列表中选择“Custom Description”。 

32 将值更改为“<<SHORT_DESC>>[, RATING ]<<RATING>>”。 

33 关闭对话框。 

34 右键单击“Large Bore Line Sizes”。 

35 从列表中选择“Custom Description”。 

36 将值更改为“<<SHORT_DESC>>[, SCH ]<<SCHEDULE>>”。 

37 关闭对话框。 
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 练习：添加大小头条目，然后设置约束条件。 

1 选择“Edit > Add Section...”或选择“Add New Section”。 
注意，列表中不包含“Reducers”的选择集。 

2 在“Enter Sector Name”字段中键入“REDUCERS”。 

3 单击“OK”。 

注意，全部大小头图标已显示为灰色。这是因为没有与异径管相关联
的类。 

 
 练习：将分类添加到异径管条目。 

1 选择“Add Classes to Section”。 

2 选择“CONCENTRIC_PIPE_REDUCER”和

“ECCENTRIC_PIPE_REDUCER”。 

3 单击“Add”。 

4 选取对话框以外的点。 

5 选择“Add New Row”。 

6 选择“Add/Remove Constraints”。 

7 从列表选择“CATALOG”、“EC_CLASS_NAME”、“RATING”、

“SCHEDULE”、“END_COND_1”和“RUN_SIZE”。 

8 单击“Add”。 

9 选取对话框以外的点。 

10 设置以下约束条件： 
• 类名称 =“CONCENTRIC_PIPE_REDUCER”和

“ECCENTRIC_PIPE_REDUCER” 

• 最小尺寸 =“20mm” 

• 最大尺寸 =“50mm” 

• 压力等级 =“3000LB” 

• 部件端面 1 连接形式 = SWF 

11 选择“Add New Row”。 

12 设置以下约束条件： 

• 类名称 =“CONCENTRIC_PIPE_REDUCER”和
“ECCENTRIC_PIPE_REDUCER”。 

• 最小尺寸 =“100mm” 

• 最大尺寸 =“250mm” 
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• Schedule = 40 

• 部件端面 1 连接形式 = BW 

• 运行尺寸 = 80、100、150 和 200 

13 选择“Add New Row”。 

14 设置以下约束条件： 

• 类名称 =“CONCENTRIC_PIPE_REDUCER”和
“ECCENTRIC_PIPE_REDUCER” 

• 最小尺寸 =“250mm” 

• 最大尺寸 =“500mm” 

• Schedule = STD 

• 部件端面 1 连接形式 = BW 

• 运行尺寸 = 300、350、400 和 450 

• Catalog =“ASME/ANSI B16.9” 
 

注意：由于 Schedule 在中管径和大管径尺寸之间变换，因而需要单独说明。 
15 选择“Add New Row”。 

16 设置以下约束条件： 

• 类名称 =“CONCENTRIC_PIPE_REDUCER”和
“ECCENTRIC_PIPE_REDUCER” 

• 最小尺寸 =“300mm” 

• 最大尺寸 =“500mm” 

• Schedule = STD 

• 运行尺寸 = 150、200 和 250 

• Catalog =“ASME/ANSI B16.9” 
 

注意： 如之前练习中所示，可在说明中使用变量“SCHEDULE”；但如此处所
示，有时说明中需要两个不同的 Schedule。下一练习将包括创建用于异
径管说明的新约束条件。 

 
  



创建新等级 
 

OP Specification Generator 概述 214 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

 练习：添加自定义约束条件 - 用于说明 

1 选择“Define Custom Fields”。 
2 选择“User Fields”选项卡。 

3 选择“Add User Field”。 
4 在“Field Name”字段中键入“SCHEDULE2”。 

5 将“Field Type”设置为“String”。 

6 选择“Lookup Fields”选项卡。 

7 选择“Add Lookup Field”。 
8 在“Column”列表中选择“SCHEDULE2”。 

9 在“Lookup Table”列表中选择“Schedules”。 

10 关闭对话框。 

 练习：为异径管添加说明 

1 选择“Define Section Descriptions”。 

2 选择“Add Description”。 

3 在“Column”列表中选择“LONG_DESCR”。 

4 在“Value”列中右键单击。 

随即会打开下面的对话框。 

 
5 双击“SHORT_DESC”。 

将变量移至底部。 

6 关闭对话框。 
7 右键单击“Small Bore Line Sizes”。 

8 从列表中选择“Custom Description”。 
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9 将值更改为“<<SHORT_DESC>>[, RATING ]<<RATING>>”。 

10 关闭对话框。 

11 右键单击“100mm to 250mm Large Bore Line Sizes”。 

12 从列表中选择“Custom Description”。 

13 将值更改为“<<SHORT_DESC>>[, SCH ]<<SCHEDULE>>”。 

14 关闭对话框。 

15 右键单击“350mm to 500mm Large Bore Line Sizes”。 

16 从列表中选择“Custom Description”。 

17 将值更改为“<<SHORT_DESC>>[, SCH ]<<SCHEDULE>>”。 

18 关闭对话框。 

19 右键单击“300mm to 500mm Large Bore Line Sizes”。 

20 从列表中选择“Custom Description”。 

21 将值更改为“<<SHORT_DESC>>[, SCH ]<<SCHEDULE>>[ x 
SCH.]<<SCHEDULE2>>”。 

22 关闭对话框 
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 练习： 

建立三通（包括等径三通和异径三通）、法兰（RF、FF、150# 和 300#）、
闸阀（SW、FLG 和 BW）、截止阀（SW、FLG 和 BW）、球阀（SW、
FLG 和 BW）以及止回阀（SW、FLG 和 BW）的条目。然后添加管帽和管
塞，运用以上课程所学知识来完成此练习。包括添加相关说明。 

 
 

三通 

类 

• EQUAL_PIPE_TEE 

• PIPE_TEE_REDUCING_BRANCH 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• SCHEDULE 

• END_COND_1 

• BRAN_SIZE 

• CATALOG 
 

特别考虑 

• 选择异径三通时，最小尺寸应比管道条目所选尺寸大一号。因为
此处使用的异径管尺寸是最大尺寸。即，小口径为 20mm - 50mm
（而不是 15mm - 50mm）或 100mm - 500mm（而不是 30mm - 
500mm）。 

• 需要为跨两个 Schedule 的异径管添加管线项。即“300mm - 
250mm”。处理方法为：为一端使用“SCHEDULE”变量，然后为
另一端键入 Schedule。 

示例：<<SHORT_DESC>>[, SCH.]<<SCHEDULE>>[ x SCH.40] 
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法兰 
 

（如果从列表中选择“FLANGE”，将会加载适当类和一些约束条件） 
 

类 

• BLIND_FLANGE 

• WELD_NECK_FLANGE 

• SOCKET_WELDED_FLANGE 
 

约束条件 

• EC_CLASS_NAME 

• FACING_1 

• CATALOG 
 

特别考虑 

• 应考虑添加 150# 和 300# 法兰，以及平面和凸面法兰 
 
 

闸阀 

类 

• GATE_VALVE 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• END_COND_1 

• CATALOG 

• LONG_DESC 
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截止阀 

类 

• GLOBE_VALVE 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• END_COND_1 

• CATALOG 

• LONG_DESC 
 
 

球阀 

类 

• BALL_VALVE 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• END_COND_1 

• CATALOG 

• LONG_DESC 
 
 

止回阀 

类 

• CHECK_VALVE 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• END_COND_1 
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• CATALOG 

• LONG_DESC 
 
 

管帽 

类 

• PIPE_CAP 
 

约束条件 

• EC_CLASS_NAME 

• RATING 

• END_COND_1 

• CATALOG 

• SCHEDULE 
 
 

管塞 

类 

• PIPE_PLUG 
 

约束条件 

• EC_CLASS_NAME 

• CATALOG 

• TYPE 
 

 练习：添加阀体的操作机构。 

1 选择“Edit > Add Section...”或选择“Add New Section”。 
2 从“Select Section Name”对话框列表选择“VALVE”。 

 
注意： 通常可创建与上述类似的特殊条目，但在此练习中，将仅使用

“VALVE”。 

3 单击“OK”。 

4 选择“Add Classes to Section”。 
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5 选择“Bar Handle”、“Cone Operator”、“Diaphram Gear 
Operator”、“Electric Valve Actuator”和“Hand Wheel”。 

6 单击“Add”。 

7 选取对话框以外的点。 

8 选择“Add/Remove Constraints”。 

9 选择“EC_CLASS_NAME”和“CATALOG”。 

10 单击“Add”。 

11 选取对话框以外的点以将其关闭  

12 选择“Add New Row”。 

13 设置以下约束条件： 

• 类名称 =“BAR_HANDLE” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

14 选择“Add New Row”。 

15 设置以下约束条件： 

• 类名称 =“CONE_OPERATOR” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

16 选择“Add New Row”。 

17 设置以下约束条件： 

• 类名称 =“DIAPHRAGM_GEAR_OPERATOR” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

18 选择“Add New Row”。 

19 设置以下约束条件： 

• 类名称 =“ELECTRIC_VALVE_ACTUATOR” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

20 选择“Add New Row”。 

21 设置以下约束条件： 

• 类名称 =“HAND_WHEEL” 
  



创建新等级 
 

2013 年 3 月 221 OP Specification Generator 概述 
版权所有 © 2012 Bentley Systems, Incorporated 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

• Catalog =“BONNEY FORGE” 
 

 练习：添加支管台条目。 

创建支管台条目时，需明确管头（岐管）尺寸即为主尺寸。实际支管台
尺寸为分支尺寸。 

1 选择“Edit > Add Section...”或选择“Add New Section”。 

2 从“Select Section Name”对话框列表选择“OLET”。 

3 单击“OK”。 

4 选择“Add Classes to Section”。 

5 选择“SOCKOLET”、“THREADOLET”以及“WELDOLET”。 

6 单击“Add”。 

7 选取对话框以外的点。 

8 选择“Add/Remove Constraints”。 

9 选择 EC_CLASS_NAME、RATING、BRAN_SIZE 和 SCHEDULE。 

10 单击“Add”。 

11 选取对话框以外的点。 

12 选择“Add New Row”。 

13 设置以下约束条件 

• 类名称 =“SOCKOLET” 

• 最小尺寸 =“80mm” 

• 最大尺寸 =“500mm” 

• 压力等级 =“3000LB” 

• 分支尺寸 = 15mm、20mm、25mm、32mm、40mm 和 50mm 

14 选取对话框以外的点。 

15 选择“Add New Row”。 
16 设置以下约束条件： 

• 类名称 =“THREADOLET” 

• 最小尺寸 =“80mm” 

• 最大尺寸 =“500mm” 
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• 压力等级 =“3000LB” 

• 分支尺寸 = 15mm、20mm、25mm、32mm、40mm 和 50mm 

• 简短说明 =“THREADOLET” 

17 选择“Add New Row”。 

18 设置以下约束条件： 

• 类名称 =“WELDOLET” 

• 最小尺寸 =“100mm” 

• 最大尺寸 =“100mm” 

• Schedule = STD 

• 分支尺寸 =“80mm” 
 

注意： 您将需要使用说明中的“[CONSTANT]”来提供 Schedule 尺寸。 
19 选择“Add New Row”。 

20 设置以下约束条件： 

• 类名称 =“WELDOLET” 

• 最小尺寸 =“150mm” 

• 最大尺寸 =“150mm” 

• Schedule = STD 

• 分支尺寸 = 80mm 和 100mm 
 

注意： 继续进行此过程，为每个管线的最小和最大尺寸增加一个值，并添加新
的分支尺寸。 

 
 练习：添加垫片和螺栓。 

 
注意： 无法在未配备垫片和螺栓的情况下插入法兰、阀或任何其他需要

垫片和/或螺栓的部件 
1 选择“Edit > Add Section...”或选择“Add New Section”。 

2 从“Select Section Name”对话框列表选择“FASTENER”。 

3 单击“OK”。 
 

提示： 可如图所示单独进行此操作，但在此练习中，会将所有部件置于
“FASTENER”部分下。关键在于缩小每个部件的选择集，以避免
放置法兰和阀等部件时始终仅能从列表进行选择。 
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4 单击“OK”。 

5 选择“Add Classes to Section”。 

6 选择“BOLT”和“GASKET”。 

7 单击“Add”。 

8 选取对话框以外的点。 

9 选择“Add/Remove Constraints”。 

10 选择“EC_CLASS_NAME”、“RATING”、“CATALOG”、

“COMP_LEN”、“FACING_1”和“SCHEDULE”。 

11 选取对话框以外的点。 

12 选择“Add New Row”。 

13 设置以下约束条件： 

• 类名称 =“GASKET” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

• 压力等级 = 150LB 和 300LB 

14 选取对话框以外的点。 

15 选择“Add New Row”。 

16 设置以下约束条件： 

• 类名称 =“STUD_BOLT” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 

• 压力等级 = 150LB 和 300LB 

• Catalog =“ASTM A307” 

• 法兰端面 =“FF”和“RF” 

17 选择“Add New Row” 

18 设置以下约束条件： 

• 类名称 =“BOLT” 

• 最小尺寸 =“15mm” 

• 最大尺寸 =“500mm” 
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• 压力等级 = 150LB 和 300LB 

• Catalog =“ASTM A307” 

• 法兰端面 =“FF”和“RF” 
 
 
 
配置自动放置表 

在以下的练习中，您将学习如何配置表格，以自动将所需管件放置在 OPM 模
型中。有分支表、自动弯头表和自动法兰表。所有这些表将作为等级上的附
加过滤器。“Branch Code Editor”和“Branch Table Editor”将一同用于此配
置，以确保分支放置正确。通过自动弯头表可以设置要放置的其他过滤器，
例如，特定直径的对焊的弯头、承插焊接弯头或螺纹弯头。自动法兰表规
范要定义以特定尺寸自动放置的法兰类型。可选择使用或不始使用这些表。
在“Preferences”对话框中，有启用或关闭这些附加表格的按钮。 

 
 
 

Branch Code Editor 
 

“Branch Code Editor”提供了一个界面，用于编辑被分支表用作进一步过滤
等级的方式的分支规范。因此分支表是用于等级的附加过滤器。分支表栅
格中的每一个单元都包含一个列表，用户可从中选择进行管线尺寸组合时
所要使用的元件类型。列表中的内容不是类名称，而是代表一类或多类的
分支规范。分支表栅格中的分支规范列表是根据当前等级中具有此尺寸的
有效元件进行过滤的。 

 
 练习：生成在分支编辑器中使用的规范 

1 选择“Tools > Branch Code Editor”。 

2 设置“Show All Classes”。 

3 设置以下分支规范： 

• PIPE = STR 

• SOCKOLET = SOL 
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• EQUAL_PIPE_TEE = T 

• PIPE_TEE_REDUCING_BRANCH = RT 

• WELDOLET = WOL 

4 设置“Show All Classes”。 

生成的分支规范现在可匹配以下所示的项。 

 

5 单击“OK”。 

关闭“Branch Code Editor”对话框。 
 

类名称 
 

显示元件类。默认情况下，仅会列出已在样式中定义了分支规范的类。 
 

分支规范 
 

输入元件类的分支规范。可为一个元件类分配多个分支规范。 
 

显示全部类 
 

此选项将列出参考 Catalog 中所有可用的类。 
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Branch Table Editor 
 

在 OpenPlant Modeler 中放置管道元件时，“Component Placement”对话框
中会显示“AutoFitting”选项卡，可利用该选项卡设置“Branch”选项，以
定义在使用 AutoFitting 放置元件时使用分支表的方式。 

 
以下选项可用： 

• Use Branch table：如果启用了该选项，那么只要 Modeler 中存在分支连
接，即会自动插入在分支表中定义的元件。如果在分支表中定义了多个
元件，那么将插入具有优先权设置的元件。 

• Show spec Selection Grid：只有在分支表中选择了多个元件，Modeler 才
会考虑该选项。随后将显示“Spec Record Selection”，可借此从列表中
选择元件。 

 
 练习 2：生成在分支编辑器中使用的规范 

1 选择“Tools > Branch Table Editor”。 

2 将表格与此处显示的项进行匹配。 

 

3 单击“OK”。 
 

提示： 同样可使用复制和粘贴执行此操作，以避免过多点击操作。 
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4 用鼠标选取一组单元，然后按下 Cntl C。 

5 选择一个单元，然后按下 Cntl V。 
 

警告： 请注意，此操作会粘贴已复制的确切单元数。此操作将覆盖现有
单元中的全部内容。注意，仅可在键盘上执行 Cntl C 与 Cntl V 操
作。单击鼠标右键无效。 

 
 
 
 
Auto Elbow Placement Editor 

在 OpenPlant Modeler 中铺设管道时，将在“User Preferences”对话框中看到
一个用于切换启用/关闭自动弯头表过滤的图标。此功能可规范以自动配件
放置模式放置的弯头类型。请注意，这只是附加的过滤器，仅可从等级中
选择要放置的弯头。可以定义弯头类型以及弯头可自动放置的角度范围。
注意，仅可选择具有针对此直径的有效弯头。 
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Auto Flange Placement Editor 
 

在 OpenPlant Modeler 中放置法兰时，将在“User Preferences”对话框中看
到一个用于切换启用/关闭自动法兰表过滤的图标。此功能规范自动放置的
法兰类型。请注意，这只是一个附加的过滤器。无论如何，只能从等级中
选择想要使用的法兰。 

 
 

注意： 仅可选择那些具有针对特定直径的有效法兰类型的单元。 
 
 
 
Catalog Editor 

Catalog Editor 是 SpecGen 的一个模块，可帮助用户创建新 Catalog 或编辑现
有 Catalog，这些 Catalog 可用于生成“等级”。用户可借助此应用程序将所
有零散的信息（excel 或数据库文件中的信息）整合到 Catalog 中。它还为使
用不同的工作流进行数据插入提供方便。 

 
要启动 Catalog Editor，请选择“File > Catalog Editor”： 
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这是 Catalog 创建过程中的基本数据流。 

 
 

 练习：创建新 Catalog 

1 选择“File > Catalog Editor”。 

可启动“Catalog Editor”。 

2 单击“Create New Catalog”，如下所示。 
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随即出现“Save File”对话框，可在此输入新 Catalog 的名称。 

 

3 输入 Catalog 的名称并单击“Save”。 

4 Catalog Editor 将创建新 Catalog，随后将帮助填充该 Catalog，并将打
开如下所示的“Edit Schema”对话框。 
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 练习：打开现有 Catalog 

1 单击“Open Catalog”，如下表所示。 
打开现有 Catalog。 

 

2 “Select Exiting Catalog”对话框随即打开。浏览至指定项目类型（例
如，OPModeler_Metric）的默认 Catalog。 

 

3 选择“Anderson Greenwood.mdb”。 
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4 Catalog Editor 将打开如下所示的 Catalog。 

 
 

 
 
 

导入数据 

 练习：导入现有 Catalog 

1 单击菜单栏中的“Edit Database Schema”，如下表所示。 
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2 “Edit Schema”对话框随即打开，其中显示有不同选项。在导入菜
单中，有两种导入方法。（即“Import Tables”和“Import From 
Excel”）。 

 

3 单击“Import Tables”将打开“Select Catalog”对话框，可在此选择
现有 Catalog。 

 

4 选择“ASME.mdb”Catalog。 

5 “Import Tables”对话框随即打开，其中带有关于 Catalog 中全部表
格的列表，然后选取要导入其中的表格并选择想要导入的类型。 
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6 单击“Import”。 

 

7 Catalog 编辑器会将选定的表格导入到当前 Catalog 中，在此情况下导
入到“Anderson Greenwood.mdb”中，如下表所示。 
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 练习：从 Excel 导入 
1 单击菜单栏中的“Edit Database Schema”，如下表所示。 

 

2 “Edit Schema”对话框随即打开，其中显示有不同选项。在导入菜
单中，有两种导入方法。（即“Import Tables”和“Import From 
Excel”）。 
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3 单击“Import From Excel”打开“Select Excel File”对话框，可在此选
择现有文件。 

 

4 选择“BCA2.XLS”。 

5 “Select Excel Sheets to import”对话框随即打开。选择要导入 Catalog 
的表，并单击“Import”，如下表所示。 
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6 “Fields Mapping”对话框随即打开，可在此创建映射。映射有助于将 
Excel 表列映射到“Catalog Table”列，这样就能够以自定义的方式导
入数据。 

 

7 如上表所示，可通过单击“Add New”创建映射。单击此按钮将添加
一个条目，随后用户可使用如下所示的下拉选项进行编辑。 
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 练习：导入映射 

1 创建映射后，用户可通过选择如下所示的“Export Mappings”保存供
日后重新使用的映射。 

 

2 用户可重新使用这些映射，这样便于导入/导出操作而不必每次创建
映射。 

3 要导入现有映射，请单击“Import”，如下所示。单击“Save”，将 
BCA2_Mappings.xml 文件中的映射保存到所提供的位置。 
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 练习：导出映射 

对于其他用例，如果想要导入已保存的映射，用户也可执行导入操作。 

1 单击“Import”。 

打开“Edit Schema”对话框。 

2 单击“Load Existing Mappings”。 

 

3 “Select Mapping file”对话框随即打开，可在此选择要导入的 XML 文
件，如下所示。选择映射文件。 
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4 Catalog Editor 将导入所有已定义的 XML 映射，如下表所示。 

 
 

 练习：预览映射 

1 在将映射导入到 Catalog 之前，用户可通过预览映射确认映射导入结果。 
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2 “Row Preview”对话框打开，其中显示有预览的映射结果，如下表
所示。 

 
 
 
 
 

添加基于元件的数据： 

“添加基于元件的数据”便于用户编辑 Catalog。利用该选项，用户可基于元
件类型将数据添加到 Catalog 中。 

1 加载 Catalog“Anderson Greenwood.mdb”。 

 

现在，如果想要以如下所示的指定元件类型在任一表格中添加新记录， 
 



添加基于元件的数据： 
 

OP Specification Generator 概述 242 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

2 请从 Catalog 表中选择任一想要插入新记录的表格，如下所示。 

 

3 单击“Add New Component”。 

可添加特定元件类型的新记录。 
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4 从选项列表中进行选择，如下所示。 

 

5 要插入元件的 PIPE_CROSS_REDUCING_ONE_RUN_AND_BOTH 类型的新
记录，请选中它并单击“Create”，如下所示。 

 

于是现在，根据“CROSSES”表格是否已存在于 Catalog 中，存在着两种
情形。在这种情况下，由于表格不存在，因此它将会执行下列操作，如
下所示。 

• 添加新的“CROSSES”表格。 

• 使用必需的字段结构对其进行填充。 
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• 添加新记录并使用默认值对其进行填充。 

 

现在，假设表格已存在，那么表格会根据新元件类型很容易地将新记录
添加到相应的表格中。 

6 要添加“BALL_CHECK_VALVE”元件，请从提供的列表中进行选择。 
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7 单击“Create”。 

 

8 选定的表格为“VALVE”类型的表格，因此可在选定的表格中添加新
记录，如下所示。 

 
 

 
 
 

添加新表格： 

如果用户想要添加新表格，则 Catalog 编辑器会通过必需字段创建默认结构
的表格。 
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1 要向 Catalog 中添加新表格，请单击工具栏中的“Edit Schema”。
“编辑模式”对话框随即打开，其中显示有 Catalog 的完整 Schema。 

 

2 现在，要将新表格添加至 Catalog，请单击“Add New Table”，
“Add New Table”对话框随即打开。 

3 在“Enter table name”字段中键入“TABLE_1”，然后单击“OK”。 
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单击“OK”之后，以默认结构的形式将新表格添加到 Catalog 中，如下表
所示。 

 

4 使用不同的导入选项填充以下空白结构。 
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Unit Conversion 工具 

 

 

Unit Conversion 工具可将等级数据库或 Catalog 数据库从英制单位转换为公
制单位，反之亦然。如果您按下“OK”，则会显示新对话框，您可在其中选
择想要转换的等级或 Catalog 以及输出目录。 
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Export Sections 

“Export Sections”选项可将等级部分另存为 XLS 工作表。随后，可将此文件
作为等级表打开并进行查看或打印。.XLS 文件将会在电子表格内为每一个在
等级中定义的等级部分创建新页面。 

 
单击此选项后，会显示一个标准的“Windows Save As”对话框，提示您为
文件命名并选择文件的保存位置。 

 
 练习：导出等级部分 

1 选择“File > Export Sections”。 

随即显示“Save As”对话框。 

2 输入 .XLS 文件的文件名。 

3 在“Save In”字段中，导航至文件所要存储到的目录。 

4 默认目录即等级存在的目录。 

5 单击“Save”。 

保存文件。 
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转换旧 Catalog 和等级 

OpenPlant Modeler 还可用于转换旧 Catalog 和等级，以便以 OPM 格式进行
使用。 

 
转换 PDS PCD 文件以创建 OpenPlant Catalog 

 
在本练习中，您需要获得一个 PDS pcd 文件和相应的 pmc 文件。 

 
 练习：将 PDS 等级转换为 OpenPlant 等级 

1 导航至 PCD 和 PMC 文件。 

2 使用 Exchange 将 PCD 文件转换为 MDB 文件。 

3 检查完整性和一致性。 

4 使用类编辑器中的映射来解决不一致性问题。 

5 生成最终的 *.mdb 文件。 
 

将 AutoPLANT 等级转换为 OpenPlant Catalog 和/或等级 
 

如果您已经拥有 AutoPLANT 等级，则使用上述的“AutoPLANT Plant Design 
(PDW)”将成为您建模的最佳选择；然而，有时您需要转换 AutoPLANT 等级，
以便能够在 OPM Specification Generator 中对其进行修改，或能够从这些等级
创建要用于新建等级的 Catalog。 

 
使用“AutoPLANT Plant Design (PDW)”可确保等级保持其写入状态。转换等
级后，某些变量仍未传送到 OPM 等级，其中包括滤出的尺寸和使用 
Description Builder 创建的详细说明。因此，该过程不会像仅打开等级并将其
保存到 OPM 等级生成器中那样简单。 

 
注意： 大多数 AutoPLANT 等级并不包括执行机构变量数据，因此在使用该方法

进行建模时，要预料到阀可能不具有执行机构。 
 

 练习：将 AutoPLANT 等级转换为 OpenPlant 等级 

1 对您希望修改的 AutoPLANT 等级进行复制。 
 

警告： 在 OPM 等级生成器中打开等级随即将其保存后，等级将在 
AutoPLANT 中不再可行。正因如此，首先进行复制很重要。 
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2 如果等级尚未打开，则打开 OPM 等级生成器。 

3 对位于“Edit > PDW Settings”中的“Use PDW Data”和“Add OPM 
Information”进行设置。 

4 选择“File > Open”。 

5 导航至 C:\Bentley Training Project\Training\Config\Specs 并打开 
Training.mdb 等级。 

Specgen 将尝试定位此等级的 Catalog。如果找不到相应的 Catalog，
则会显示类似如下的消息框： 

 

6 单击“Yes”。 

浏览至用于该等级的 Catalog 位置。 
 

注意： 您应持有硬拷贝的 AutoPLANT 等级，以便于查看差异。 
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建模模式 

OpenPlant Modeler V8i 拥有不同的建模模式，使设计师能够使用 OpenPlant 
Modeler V8i 生成的等级或使用旧等级。设计师在“Standard Preferences”对
话框显示的“Specification”字段中选取“Select Source”选项后，可以定义一
组不同的等级以便在模型/项目中进行使用。默认情况下，使用 OpenPlant 
Modeler (OPM) 等级。但是，下列任一等级均可供使用： 
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使用旧等级 
 

借助 OpenPlant Modeler 可以使用其他 Bentley 应用程序中的等级。您在
“Standard Preferences”对话框显示的“Specification”字段中选取“Select 
Source”选项后，可以定义一组不同的等级以便用于模型/项目。默认情况下，
使用 OpenPlant Modeler (OPM) 等级。但是，下列任一等级均可供使用： 

• OpenPlant Modeler (OPM) 

• AutoPLANT Plant Design (PDW) 

• PlantSpace Design Series (PSDS) 

• Plant Design System (PDX) 
 

OpenPlant Modeler (OPM) 
 

此为默认的建模模式 

 
 

AutoPLANT Plant Design (PDW) 
 

对于 AutoPLANT 等级，只需指定等级目录的路径。或者手动输入此路径，或
使用“Browse”按钮导航至相应的位置。 
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PlantSpace Design Series (PSDS) 
 

当选择 PlantSpace Design Series 作为源时，将显示下列选项： 

 

• Datasource：此即实际的项目数据库。 

• User Name/Password：在此输入项目管理员为您提供的信息，以登录到
数据源。 

• Dat Files Location：选择该选项后，用户可以指定所有 .DAT 文件的放置路

径，其中这些文件用于检索数据。 
 

 
注意： 您必须保证表（包括等级、Catalog 和同源表）的整套 .DAT 文件

位于定义的位置上。 

• Get data from catalogs：该选项可用于从 Catalog 表检索数据，且将会在
“Standard Preferences Specification”列表中列出所有 Catalog 而非等级。 

 
Plant Design System (PDX) 

 
对于 Plant Design System 等级，除了查阅映射表之外，OpenPlant Modeler 还
将使用 Schema 映射，以解密 PDX 等级并从 PDX 数据库（已导入 mdb 格式）
或等级文件（.PMC 和 .PCD）中直接获取数据。此外，还需要有 PDX 库，这
样才能从 PDX 存储库中获取未在等级定义中存储的尺寸数据。 

 
注意： 样品库随 Modeler 一起提供，但建议 Plant Design System 用户从

用于创建等级的版本中选择实际库的路径。 
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使用 Plant Design System 等级源时，下列选项可供使用： 

 
• Database：指定项目数据库的位置 

 
注意： 已导入 .MDB 格式。对于等级，仅需要表格 101 和 102。 

• Spec Files Location：指定 .PMC 和 .PCD 文件的路径。 

• Data Libraries Location：指定包含数据的 PDX 二进制文件的路径。 
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报表 
 
 
模块概述 

在 OpenPlant Modeler 中提供了可自定义的报表实用工具。可以三种格式使
用报表模板：水晶报表、DGN 报表和网格报表。本章将介绍对不同报表的
自定义。 

 
 
 
模块先决条件 

• 学员应完成对 OpenPlant Modeler 基础用户课程的学习。 
 
 
 
模块目标 

学完本模块后，您将能够： 

• 创建新报表。 

• 自定义现有报表。 

• 共享自定义的报表。 
 
 
 
报表 

OpenPlant Modeler 会随一些报表和报表模板一起提供，然而；大多数公司均
有标准化的报表格式。Modeler 已在软件中植入修改或创建新报表的功能。
可对报表进行修改，使其包含公司徽标，甚至使用公司软件编程语言（例如 
SQL）生成与公司标准类似的报表。自定义的报表格式被写入到 
reports.ecinstance.xml 文件中，且可以在卫星办公室与第三方之间共享。 
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注意： 需使用水晶报表 2008 (XI) 修改水晶报表模板。 
 

“Reports”对话框包含一个含不同报表类型的可停导航览树。 

 
 
 

图标 定义 

新类别 打开“Create New Category Report”对话框。在
导航树中右键单击类别并从上下文菜单中选择
“Edit”时，该对话框也将显示为“Edit 
category”对话框。 

 
 
• Category Name：必须有一个唯一的名称。 
• Display Label：“报表树”中显示的名称。 
 

新建报表 打开“Create New Report”对话框。在导航树中
右键单击报表并从上下文菜单中选择“Edit”
时，该对话框也将显示为“Edit report”对话框。 
 

剪切 将选定的报表类型或类别剪切到剪贴板上。 
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图标 定义 

复制 将选定的报表类型或类别复制到剪贴板上。 

粘帖 将报表类型或类别粘贴到导航树中的选定位置。 

删除 删除选定的报表类型或类别。 

 

“报表信息”用于显示选定报表类型的属性。在创建新报表或编辑现有报表
时对这些属性进行定义。右键单击“Equipment List”报表时，请选择“Edit”，
然后选择“Query”字段。单击“browse”时，“Search”对话框随即打开，
可在此修改报表查询。 

 
 

该对话框分为三部分： 

• Search For：此部分用于定义要查询的项或对象的类型。 
 

注意： 定义报表的查询时，通常需要将图标“Search for items and their 
sub-items”设置为“ON”。 

• Conditions：此部分显示用于定义查询条件的自定义“面板”。 

• Summary Description：此部分以用户界面友好的自然语言显示查询，且
可供您轻松控制查询条件。 

 



报表 
 

报表 260 2013 年 3 月 
版权所有 © 2012 Bentley Systems, Incorporated 

在创建新报表或编辑现有报表时，会打开下列对话框。 

 
 
 
 

值： 定义： 

Report Info Name：新报表的名称。 
Display Label：在“Reports”导航树中显示的 
名称 
Description：报表的简要描述 
Query：指定报表的查询定义。单击椭圆按钮时，

随即显示“Search”对话框，可在此编辑报表的

查询定义。 

 

Select Template Type 从以下可用的模板列表中为报表选择模板。 
Crystal Templates：显示已生成的且以水晶报表

格式显示的预定义模板的列表。 

DGN Templates：显示在生成时置于绘图上的预

定义模板的列表。 

Grid Templates：这是将栅格中的报表结果置于绘

图上的基本格式。 
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Set as Default 将“Report Template”类型和与之连接的选定报

表模板设置为默认。 

注意：如果创建新报表，则该按钮将被禁用，

直至选定“Template Type”且模板名称已与之

连接。 

 

Templates 列出可与选定的“Template Type”关联的可用模

板。列表中的模板可反映选定的“Template 
Type”。因此，如果使用 Crystal Report 模板类

型，则默认情况下有四种可供使用的报表模板：

Equipment、Instrument、Pipeline 和 Valve。 

 

Add Crystal Templates：如果在“Select Template Type”
字段中选择“Crystal Templates”选项，将随即

显示“Create New Template”对话框。 
输入新的“Template Name”，然后通过单击

“browse”按钮并导航至 new.RPT 文件所在的目

录来定义 Template Location。 
注意：New.RPT 文件只能使用许可的 Crystal 
Reports 应用程序进行创建。 

 
DGN Templates：如果在 Template Type 字段中选

择“DGN Templates”选项，将随即显示 DGN
“Create Template”对话框。通过此对话框可以

创建并修改置于绘图上的 DGN 模板。 

 
Grid Templates：“Grid”格式会生成单个列出绘

图中全部元件的报表类型。新报表模板不适用于

这种情况，因此，如果选中 Grid Template，则禁

用“Add”、“Remove”和“Edit”按钮。 
 

Remove 从 Templates 列表中移除选定模板。 

Edit 显示“Edit Template”对话框，可在此编辑现有

的水晶模板。 
在此对话框中，只能对 Template Name 和 Location 
进行编辑。 

如果正在编辑 DGN 模板，则会显示单独的对话

框，如同在绘图上显示字段那样，可在此定义/
编辑字段。 
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Attach/Detach 选择模板并单击“attach”后，该模板会与选定

的模板类型相关联。 
将模板连接到模板类型后，可将此按钮作为

“Detach”功能而移除关联。 
 

OK 单击此项可关闭对话框并应用更改。 

Cancel 单击此项可关闭对话框但不应用更改。 

 
 

创建新报表 
 

要创建新报表，可从现有报表入手，以便复制所有属性。 
 

 练习 1：从现有报表创建新报表 

1 启动“OpenPlant Modeler”。 

2 打开“OPM_AdminTraining.dgn”。 

3 选择“OpenPlant Modeler > Tools > Item Reports..”。 

 
 

4 展开“Reports”节点。 

5 展开“Piping”节点。 

6 展开“Piping Components”节点。 

7 右键单击“Valve List:Gate Globe and Check”。 
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8 选择“Copy”。 

 
9 将报表粘贴到“Piping Components”节点。 

10 右键单击“Copy of Valve List:Gate Globe and Check”。 

11 从上下文菜单中选择“Edit”。 

 

12 在“Name”字段中键入“Valve_List_Ball”。 
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13 在“Display Label”字段中键入“Valve List: Ball”。 

14 在“Description”字段中键入“Displays a list of Ball Valves”。 

 

15 选择“Query”字段。 

16 单击“ellipsis”。 

17 从“Search For”列表中选择“VALVE”。 

 
 

 
注意： 确保“Include Item Subtypes in Results”图标为高亮显示状态，否则

该列表将不起作用。您可能需要单击“OK”，然后再次在查询字

段中单击“browse”才能设置此项。 

18 对于“Where clause”，可从列表中选择“EC Class Name”。 

19 在“equal to”后的键入框中键入“BALL_VALVE”。 

 

20 单击“Add”。 
向查询添加“Where Clause”。 
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21 单击“(including these properties)”链接。 

 
 

22 在“Properties to Include”对话框中，单击“Clear All”。 

 

23 选择您希望在报表中查看的属性，确保“Line Number”为所选属性
之一。 

24 单击“OK”。 
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25 单击“(sorted)”。 

 
 

26 在“Select Sort Order”对话框中，选择“Sort items by”列表中的

“Line Number”。 

27 根据需要，选择其他条件。 

 

28 单击“OK”。 

29 在“Search”对话框中，单击“OK”。 

30 选择“Grid Templates”。 

31 单击“Set As Default”。 

这样会将 Ball Valve 列表置于栅格报表中，以供导出。 

 

32 单击“OK”。 

关闭“Edit Report”对话框。 

33 将“Ball Valve”放置在模型中。 

34 右键单击“Valve List:Ball”。 
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35 选择“Open in Grid”。 

 

36 将打开报表，现在可将报表保存为多种不同的格式。 
 

 练习 2：创建新报表 

1 选择“Utilities > Reports”。 

2 展开“Reports”节点。 

3 展开“Equipment Reports”节点。 

4 选择“Equipment Reports”。 

5 单击“New Category”。 

6 在“Category Name”字段中键入“Equipment_Exchanger_Reports”。 

7 在“Display Label”字段中键入“Equipment Exchanger Reports”。 

 

8 单击“OK”。 
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向导航树添加新类别。 

 

9 选择“Equipment Exchanger Reports”。 

10 单击“New Reports”。 

11  在“Name”和“Display Label”字段中键入“Exchanger List”。 

12  在“Description”字段中键入“Equipment Exchanger”。 

13 在“Query”字段内单击“ellipsis”。 

14 在“Search For”列表中，向下滚动以查找“Heat Exchangers”。 

15 设置“Search for Items”和“Sub Items”。 

提示： 要查找待添加到“搜索列表”的适用类，请打开 Class Editor 并查
找您希望报表的项的最高级别的基类。 

16 单击“OK”。 

17 选择“Crystal Template”。 

18 单击“Attach”。 

19 单击“OK”。 

20 单击“Yes”。 

打开“Report Templates Compatibility”对话框。 

21 展开“Equipment Exchanger Reports”节点。 

22 右键单击“Exchanger Report”。 
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23  从上下文菜单中选择“Open as Report”。 

 
 
 

自定义现有报表 
 

在先前练习中创建的报表将显示绘图内的所有交换器。如果您想要一个仅显
示 TEMA 交换器的报表，则需要对此报表加以修改。 

 
 练习 1：修改现有报表 

1 右键单击“Exchanger List”。 

2 选择“Edit”。 

            3 在“Query”字段中单击“ellipsis”。 

4 在“Where...”字段中选择“Number”。 

5 在运算符后的“blank”字段中选择“0107”。 

6 单击“Add”。 

7 单击“OK”。 

8 单击“OK”。 

关闭“Edit Report”对话框。 

9 右键单击“Exchanger List”。 
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10 选择“Open as Report”。 

 
 

 练习 2：共享热交换器报表 

1 在 Windows 资源管理器中，导航至 ..\Bentley\OpenPlantModeler 
V8i\WorkSpace\Projects\OP_AdminTraining\DataSet\Reports\ReportDef
inition 

2 查找“report.ecinstance.xml”文件的位置。 

3 在 Notepad 中打开“report.ecinstance.xml”。 

4 选择“Edit > Find”。 

5 在“Find What”字段中键入“Heat_Exchanger”。 

6 单击“Find”。 
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可将文件传送到早期生成的“热交换器”报表的节点位置。 

 

7 选择“File > Exit”。 

8 不保存已做出的任何更改。 

复制此文件，并将其发送到需要“热交换器”报表的办公室或第三方。 
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OpenPlant Manager 管理员

评估 
人们通常认为评估和测试是一回事，但事实上它们是完全不同的两个概念。
评估用于确定一个人的认知范围和能力范围。 

 
完成此评估，查看复习此模块或课程获得了哪些收获（需访问 
surveygizmo.com）。 

 
请注意，此评估仅用于课堂或虚拟课堂学习，不能用于按需学习。 

 
 

问题 

1 管理员在何处管理项目安全？ 

A. 从 ProjectWise 中 

B. 从 OpenPlant Modeler 中 

C. 从 OpenPlant Model Server 中 

D. 以上均可 

E. 以上皆非 

2 必须使用 DGNLIB。 

正确 

错误 

3 OPM 样式是一种可编辑的文件。 

正确 

错误 

4 Configuration Manager 中含有哪些选项卡？ 

A. Associations、Preferences、Properties 和 Model Server。 

B. Standard Preferences、Project Configuration、Manager 和 Classes。 

C. Associations、Standard Preferences、Model Server 和 Property 
Categorization。 

D. 以上皆非。 
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5 Class Editor 中的此图标代表什么含义？   

A. 添加属性 

B. 添加类 

C. 添加关系 

D. 添加 

6 “类”使用哪种格式？ 

A. 子/父层次结构 

B. 父/子层次结构 

C. 类/关系层次结构 

D. 关系/类层次结构 

E. 以上皆非 

7 与 Class Editor 相比，使用 Configuration Manager 的一项优势为用户无
需记住类与属性的查找位置。 

正确 

错误 

8 如何判断属性是否发生了更改？ 

A. 文本会以粗体显示。 

B. 文本会以红色显示。 

C. 文本会以蓝色显示。 

D. 文本会以斜体显示。 

9 组名称为创建用户设备时选定的类型。 

正确 

错误 

10 以下哪个实用工具用于检查模型中是否存在问题？ 

A. Configuration Manager 

B. 冲突检测 

C. Model Server 

D. 以上均可。 
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11 Spec Gen 中的此图标代表什么含义？   

A. 添加新属性 

B. 添加新行 

C. 添加新部分 

D. 添加用户字段 

12 要使用旧等级，首先需将其转换为 OP 等级。 

正确 

错误 

13 自定义报表将写入哪个文件？ 

A. Reports.ecinstance.pcd 

B. Reports.ecinstance.html 

C. Reports.ecinstance.xml 

D. Reports.ecinstance.pmc 
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答案 

1 A. 管理员从 ProjectWise 中管理项目安全。 

2 错误：并非必须使用 DGNLIB，但与种子文件类似，如果不使用 
DGNLIB，则几乎无法控制元素放入文件的方式。因此，强烈建议用户
使用 DGNLIB。 

3 错误：建议不要编辑 OPM 样式文件。 

4 C. Configuration Manager 中的选项卡包括 Associations、Standard 
Preferences、Model Server 和 Property Categorization。 

5 B. Class Editor 中的此图标是用于添加类的快捷方式。 

6 B.“类”使用父/子层次结构格式。 

7 正确：用户无需记住要编辑的样式，Configuration Manager 即可编辑
正确的样式。 

8 C. 属性发生更改时，文本会以蓝色显示。 

9 正确：组名称为选定类型，随后新类可供选择。 

10 B. 用于检查模型中是否存在问题的实用工具为“冲突检测”实用工具。 

11 B. Spec Gen 中的此图标是用于添加新行的快捷方式。 

12 错误：通过在“Standard Preferences”对话框的“Specification”字段
中选择“Select Source”选项，即可使用旧等级。 

13 C. 自定义报表将写入 Reports.ecinstance.xml 文件。 
 

进行评估 

http://www.bentley.com/
http://www.bentley.com/
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附录 A - 命名表达式 
 
 
 
OPM 使用层、模板和命名表达式的方式 

OPM 创建或更新元件时，需要配置元件符号。符号包括颜色、线型、线宽和
层。如果未执行任何操作，则将使用激活的符号设置来创建或更新所有元
件。每位用户都要负责制定新层并设置相应的颜色。由于元件可能由多个
子部分（如模型图形、中心线以及保温层）组成，因此用户必须分别设置
各个部分。 

 
因此，OPM 中提供了一种替代方法，即使用命名表达式、层和模板的组合来
控制元件符号。这样无需用户进行操作，即可根据一组规则进行自动分配。
具体来说，即对命名表达式进行求值，然后使用这些结果在层或模板中查找
符号。 

 
命名表达式的值应为以下两种格式之一的字符串： 

BY_LEVEL:LevelName 

或 

BY_TEMPLATE:TemplateGroupName:TemplateName 

在 BY_LEVEL 语法中，按照冒号后的字符所定义的层来设置符号。该名称必
须遵循完整的“MicroStation 层命名”标准。如果该层名称与层库中的某个
层名称相符，则将使用层库中的符号来创建层。如果层库中不存在相符的层
名称，则将使用默认符号在 DGN 文件中创建层。在这两种情况下，元素符
号均会“按层”进行颜色、线宽以及线型的设置。 
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在 BY_TEMPLATE 语法中，按照由模板路径和模板名称确定的模板中定义的值
来设置符号。模板可以设置任何符号属性的组合。任何未在模板中定义的符
号属性都会使用该激活设置。无法找到模板时，也会使用该激活符号。使用
模板定义符号最为灵活，但却比使用 BY_LEVEL 选项需要的设置时间更长。 

 
通过采用某个预定义 OPM 符号名称来命名“命名表达式”，可控制特定 
OPM 元件类型的符号。有效值列表如下所示： 

 
OP_SYMBOLOGY_PIPING 

OP_SYMBOLOGY_EQUIPMENT 

OP_SYMBOLOGY_TRAY 

OP_SYMBOLOGY_CONDUIT 

OP_SYMBOLOGY_HVAC 

OP_SYMBOLOGY_SUPPORT 

OP_SYMBOLOGY_STRUCTURAL 

OP_SYMBOLOGY_ARCH 

OP_SYMBOLOGY_AREA 

OP_SYMBOLOGY_RESERVED_AREA 

OP_SYMBOLOGY_PIPING_INSULATION 

OP_SYMBOLOGY_EQUIPMENT_INSULATION 

OP_SYMBOLOGY_TRAY_INSULATION 

OP_SYMBOLOGY_CONDUIT_INSULATION 

OP_SYMBOLOGY_HVAC_INSULATION 

OP_SYMBOLOGY_SUPPORT_INSULATION 
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OP_SYMBOLOGY_STRUCTURAL_INSULATION 

OP_SYMBOLOGY_ARCH_INSULATION 

OP_SYMBOLOGY_PIPING_CENTERLINE 

OP_SYMBOLOGY_EQUIPMENT_CENTERLINE 

OP_SYMBOLOGY_TRAY_CENTERLINE 

OP_SYMBOLOGY_CONDUIT_CENTERLINE 

OP_SYMBOLOGY_HVAC_CENTERLINE 

OP_SYMBOLOGY_SUPPORT_CENTERLINE 

OP_SYMBOLOGY_STRUCTURAL_CENTERLINE 

OP_SYMBOLOGY_ARCH_CENTERLINE 

因此，若要使用模板文件夹 OpenPlant\Piping 中名为 MODEL 的模板来控制管
道元件模型图形的符号，则需创建一个名为 OP_SYMBOLOGY_PIPING 的命名
表达式和一个值为 "BY_TEMPLATE:OpenPlant\Piping" & ":MODEL" 字符串的表
达式。最简便的方法是直接将该字符串键入为表达式。然而通常情况下，应
使用元件属性或其相关实例来设置表达式的格式。 

 
OPM 命名表达式的特殊扩展名 

 
为支持某些 OPM 概念，我们引入了命名表达式语法的一些扩展名。第一个
是符号 OPItem。如果将 OPItem.PropertyName 语法应用于当前要放置或编辑
的 OPM 元件，则该语法将会获得分配给该属性的值。此时，在表达式中使
用 NOMINAL_DIAMETER 属性时，语法将变为 OPItem.NOMINAL_DIAMETER。
请注意，表达式区分大小写。如果是管道元件，还需另行添加 PIPELINE 符号
这一项。通过此操作即可访问与管道元件相关联的管道实例属性。与 OPItem 
符号类似，PIPELINE 符号的格式为 PIPELINE.PropertyName。因此要从包含管
道元件的管道中获取 Service 属性，仅需在表达式中使用 
PIPELINE.SERVICE_NAME 符号 
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附录 B - 正则表达式分析程序 
 

Rad Software Regular Expression Designer 是一款可供免费下载的工具软件，
有助于程序员了解、开发和测试正则表达式。这是一款易于使用的交互式 
Windows 应用程序。 

 
http://www.radsoftware.com.au/?from=RegexDesigner 

 
 

位置匹配 
 

位置匹配可使用 ^ 和 $ 来搜索字符串的开头或结尾。将模式属性设置为
“^VBScript”时，只能与“VBScript is cool”成功匹配。而无法与“I like 
VBScript”匹配。 

 
 

符号 功能 

^ 仅匹配字符串的开头。 
“^A”匹配“An A+ for Anita”中的第一个“A”。 

$ 仅匹配字符串的结尾。 
“t$”匹配“A cat in the hat”中的最后一个“t” 

\b 匹配任一字边界 
“ly\b”匹配“possibly tomorrow”中的“ly”。 

\B 匹配任一非字边界 

 
 
  

http://www.radsoftware.com.au/?from=RegexDesigner
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文本 
 

“文本”用于表示字母数字字符、ACSII、八进制字符、十六进制字符、
UNICODE 或特殊转义字符。由于某些字符具有特殊含义，因此我们必须进行
转义。要匹配这些特殊字符，在正则表达式中我们需要在这些字符前加“\”。 

 
 

符号 功能 

字母数字 按字面匹配字母和数字字符。 

\n 匹配换行符 

\b 匹配任一字边界 
“ly\b”匹配“possibly tomorrow”中的“ly”。 
 

\B 匹配任一非字边界 

\f 匹配换页符 

\r 匹配回车符 

\t 匹配水平制表符 

\v 匹配垂直制表符 

\? 匹配 ? 

\* 匹配 * 

\+ 匹配 + 

\. 匹配 . 

\| 匹配 | 

\{ 匹配 { 

\} 匹配 } 

\\ 匹配 \ 

\[ 匹配 [ 

\] 匹配 ] 

\( 匹配 ( 

\) 匹配 ) 

\xxx 匹配由八进制数 xxx 表示的 ASCII 字符。“\50”与“(”或 chr 
(40) 匹配。 
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符号 功能 

\xdd 匹配由十六进制数 dd 表示的 ASCII 字符。“\x28”与“(”或 
chr (40) 匹配。 
 

\uxxxx 匹配由 UNICODE xxxx 表示的 ASCII 字符。“\u00A3”匹配
“£”。 
 

 
 

字符类 
 

字符类可通过将表达式置于 [] 括号中来自定义分组。例如，通过将 ^ 作为 [] 
内的第一个字符可创建反向字符类。同时，还可使用短划线将某个字符范围
联系在一起。例如，正则表达式“[^a-zA-Z0-9]”除不可匹配字母数字字符外，
可以匹配其他所有字符。此外，有些常见字符集被捆绑为转义字符加字母。 

 
 

符号 功能 

[xyz] 匹配字符集内包含的任一字符。“[a-e]”匹配“basketball”
中的“b”。 
 

[^xyz] 匹配字符集内未包含的任一字符。“[^a-e]”匹配
“basketball”中的“s”。 
 

. 匹配除 \n 之外的任一单个字符。 

\w 匹配任一字类字符。等效于 [a-zA-Z_0-9]。 

\W 匹配任一非字类字符。等效于 [^a-zA-Z_0-9]。 

\d 匹配任一数字。等效于 [0-9]。 

\D 匹配任一非数字。等效于 [^0-9]。 

\s 匹配任一空格字符。等效于 [ \t\r\n\v\f]。 

\S 匹配任一非空格字符。等效于 [^ \t\r\n\v\f]。 
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重复 
 

重复用于对正则表达式中的子句进行多次搜索。通过使用重复匹配，我们可
以指定元素在正则表达式中重复的次数。 

 
 

符号 功能 

{x} 正好匹配前面的正则表达式 x 次。“\d{5}”匹配 5 个数字。 

(x,} 至少匹配前面的正则表达式 x 次。“\s{2,}”匹配至少 2 个空格
字符。 
 

{x,y} 匹配前面的正则表达式 x 至 y 次。“\d{2,3}”匹配至少 2 个数
字，至多 3 个数字。 
 

? 匹配前面的字符或子表达式 0 次或 1 次。等效于 {0,1}。
“a\s?b”与“ab”或“a b”匹配。 
 

* 匹配前面的字符或子表达式 0 次或多次。相当于 {0,}。 

+ 匹配前面的字符或子表达式 1 次或多次。等效于 {1,}。 

 
 

替换和分组 
 

替换和分组用于开发更加复杂的正则表达式。使用替换和分组技术可在正
则表达式内创建复杂子句，进而提高灵活性与控制力。 

 
 

符号 功能 

() 对子句进行分组以创建子句。可采用嵌套的方式。
“(ab)?(c)”与“abc”或“c”匹配。 
 

| 替代会将多个子句组合为一个正则表达式，并将匹配其中任
一单独子句。 
“(ab)|(cd)|(ef)”与“ab”、“cd”或“ef”匹配。 
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反向引用 
 

程序员可通过反向引用来存储正则表达式的一部分，以供以后使用。此操作
可通过使用括号和反斜线 (\) 字符后加单个数字来实现。\1 引用第一个括号
子句，\2 引用第二个括号子句，以此类推。 

 
 

符号 功能 

()\n 匹配按照左括号的顺序进行编号的子句 “(\w+)\s+\1”匹配一
行中出现两次的任一单词，如“hubba hubba”。 
 

 
已给出示例！ 

 
此示例涵盖了本文中讨论过的一些内容。该应用程序简单易用，可利用正
则表达式来测试所执行的输入是否有效。它会反复提示用户进行输入，直
到输入有效为止。首先，我将详细介绍以下初始模式。 

"^\s*((\$\s?)|(£\s?))?((\d+(\.(\d\d)?)?)|(\.\d\d))\s*(UK|GBP|GB|US 
A|US|USD)?)\s*$" 

"^\s*…" and "…\s*$" 

表示可以存在任意数目的前导空格字符和结束空格字符，并且输入必
须自成一行 
"((\$\s?)|(£\s?))?" 

表示可选符号 $ 或 £ 后跟可选空格 
"((\d+(\.(\d\d)?)?)|(\.\d\d))" 

搜索后跟可选小数点和可选两位数或者后跟小数点和两位数的一位数
（或多位数）。这表示诸如 6.、23.33、.88 等输入有效，但 5.5 无效。 
"\s*(UK|GBP|GB|USA|US|USD)?" 

表示任意数目的空格字符后跟可选且可接受的参数对字符串有效。 
 

在此例中，正则表达式用于确定用户输入的是美元还是英镑。搜索字符串 £、
UK、GBP 或 GB。如果该正则表达式为 True，则用户输入的金额以英镑为单
位。否则，则是美元。 
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附录 C - ECExpression 
 
 

1 ECExpression 由 BE 开发。 

2 Is calc as default 仅当首次计算时为 True。 

3 Req SymbolSet 注册了其他 dll 文件，以创建更多功能强大的表达式。
其可以是 System.string 或 System.math 等标准 .net 函数或方法，也可
以是用于调用特殊程序的自定义公司 dll。 

4 可通过 () 分组技术执行标准计算，如 + - * /。 

5 | = 或。 

6 可执行 IF 子句： 

 

7 当前 getrelatedinstance 中不存在 where 子句。 

8 自定义计算属性表达式。 
 

下图即为用于创建标签的计算表达式。我们将其拆分为几个部分。 
 

如 Class Editor 中所示： 

 
 

 
结果 XML 代码为： 
<CalculatedECPropertySpecification 
xmlns="Bentley_Standard_CustomAttributes.01.01"> 

<ECExpression>this.GetRelatedInstance("PLANT_AREA_HAS_NAMED_ITEM:1 
:PLANT_AREA, NAME:?").NAME &amp; "-" &amp; this.DEVICE_TYPE_CODE 
&amp; "-" &amp; this.NUMBER</ECExpression> 

<FailureValue>Device</FailureValue> 
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<ParserRegularExpression>^[?\w]*-(?&lt;DEVICE_TYPE_CODE&gt;[\w]*)- 
(?&lt;NUMBER&gt;[\w]*)|(?&lt;NUMBER&gt;[\w]*)</ 
ParserRegularExpression> 

<IsDefaultValueOnly>False</IsDefaultValueOnly> 

<RequiredSymbolSets /> 

</CalculatedECPropertySpecification> 
 
 
 

ECExpression 
 

this.GetRelatedInstance("PLANT_AREA_HAS_NAMED_ITEM:1:PLANT_AREA, 
NAME:?").NAME & "-" & this.DEVICE_TYPE_CODE & "-" & this.NUMBER 

 
 

this.GetRelatedInstance("PLANT_AREA_HAS_N 
AMED_ITEM 
:1:PLANT_AREA, NAME:?").NAME 
 

表示基于“设备区域具有命名项”关系获
取与特定元件相关的区域名称 

& "-" 以 - 分隔表达式值 

& this.DEVICE_TYPE_CODE 在表达式值中包含该元件的 
DEVICE_TYPE_CODE 值 
 

& "-" 以 - 分隔表达式值 

& this.NUMBER 在表达式值中包含该元件的 NUMBER 值。 

 
 

语法 
 

要添加同一对象的某个属性值： 
this.[Object Property Name] 

 

 
要从相关对象添加某个属性值： 

this.GetRelatedInstance("[Relationship Name]:[1] :[Class type to 
retreived], [Pseudo Property Name for failure]:[Failure 
value]").[Target Property Name] 

 

 
注意： 值 1 或 0 表示关系的方向。1 表示检索源，而 0 表示检索目标。 

 
失败值 

 
失败值是一种可选功能。该值将被返回。 
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ParserRegularExpression 
^[?\w]*-(?<DEVICE_TYPE_CODE>[\w]*)- 
(?<NUMBER>[\w]*)|(?<NUMBER>[\w]*) 

 
 

^ 匹配解析表达式的开头 

[?\w]* 排空字符串中的所有第一个字符，直至出
现第一个短划线为止。 
 

- 查找文本 – 的值。 

(?<DEVICE_TYPE_CODE>[\w]*) 将第一个短划线与第二个短划线之间的所
有字符分配给 DEVICE_TYPE_CODE 属性 
 

- 查找文本 – 的值。 

(?<NUMBER>[\w]*) 将最后一个短划线后的所有字符分配给 
NUMBER 值。 
 

 
第二个 NUMBER 参数有何用途？ 

 
 

\w 字母数字字符 

\s 空格 

\d 数字 

| 或 

* 任意数目的字符 

? 文本 ? 标记值 

- 字符串中文本 - 的值 

 
“Is calculated as default”的值只能 

设置为 

[True] 或 [False] 
 

需要的 ECExpression 符号集 
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附录 D 
 
 
样品等级 
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附录 E 
 
 
OpenPlant_CustomAttributes.08.11 

 
 

1.1 Associated Component List 
 

类名称 OPENPLANT_ASSOCIATED_COMPONENT_LIST 

显示标签 Associated Component List 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.1.1 数据结构 
 

名称 显示标签 数据类型 
ASSOCIATED_COMPONENTS 
• EC_CLASS_NAME 

• X_OFFSET 

Associated Components 
• EC Class Name 

• X Offset 

opca:Associated Component Struct 
• string 

• string 
 

1.1.2 说明 
 

为在元件放置过程中应置于 OPM 中的关联元件指定列表及其相对位置，并在
该元件的 EC 类中定义此自定义属性 

 
1.1.3 属性 

 
1.1.3.1 Associated Components 

定义关联元件 EC 类的列表及其在父元件轴上的 X 偏移值。 

1.1.3.1.1 EC Class Name 

关联元件的 EC 类名称 
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1.1.3.1.2 X Offset 
ECExpression，其可以包含静态值或父元件的 EC 属性，其值应用于从
父元件的原点偏移关联元件。 

 
1.1.4 示例 

 
源活套法兰 

 
 
 
 

1.2 AutoPLANT_PDW_Catalogue_Property_Map 
 

类名称 AP_3D_Catalogue_AttributeProperties 

显示标签 AutoPLANT_PDW_Catalogue_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.2.1 数据结构 
 

名称 显示标签 数据类型 
PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

String 
Boolean 
String 
string 

 
1.2.2 说明 

 
指定 AutoPLANT Catalog/等级层属性映射 

 
1.2.3 属性 

 
1.2.3.1 PropertyName 

 
1.2.2 说明 

 
指定 AutoPLANT Catalog/等级层属性映射 
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1.2.3 属性 
 

1.2.3.1 PropertyName 
Catalog/等级表中的属性字段名称 

 
1.2.3.2 IsValueToBeMapped 

此属性是否需要值映射 
 

1.2.3.3 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.2.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.2.4 示例 
 

管道法兰 -> 长度 

 
 
 
 

1.3 AutoPLANT_PDW_Catalogue_Class_Map 
 

类名称 AP_3D_Catalogue_ClassProperties 

显示标签 AutoPLANT_PDW_Catalogue_Class_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.3.1 数据结构 
 

名称 显示标签 数据类型 
Table Table string 
ComponentType ComponentType string 
USE_ECCLASSNAME Use EC Class string 
Class Mapping ClassMapping opca:AutoPLANT_PDW_Catalogue_ 

Class_Map_Struct 
• ClassName • ClassName • string 
• ModuleName • ModuleName • string 
• GType • GType • string 
• SType • SType • string 
• SelectionCriteria • SelectionCriteria • string 
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1.3.2 说明 
指定 AutoPLANT Catalog/等级层元件类映射 

 
1.3.3 属性 

 
1.3.3.1 Table 

等级/Catalog 中的表名称 
 

1.3.3.2 ComponentType 

通用元件类型 
 

1.3.3.3 Use EC Class 

使用其他 EC 类映射信息来查询元件数据 
 

1.3.3.4 ClassMapping 

AutoPlant 类映射信息 

1.3.3.4.1 ClassName 

AutoPLANT 元件类名称 

1.3.3.4.2 ModuleName 

映射的 AutoPLANT 类所属的 AutoPLANT 模块名称 

1.3.3.4.3 Gtype 

已映射的类的 Gtype 

1.3.3.4.4 Stype 

已映射的类的 Stype 

1.3.3.4.5 SelectionCriteria 

在基于元件的 EC 属性执行导入操作期间定义 AutoPLANT 类选择的 
ECExpression 

 
1.3.4 示例 

 
 



OpenPlant_CustomAttributes.08.11 
 

2013 年 3 月 297 附录 E 
版权所有 © 2012 Bentley Systems, Incorporated 

1.4 AutoPLANT_PDW_Catalogue_Port_Property_Map 
 

类名称 AP_3D_Catalogue_PortAttributeProperties 

显示标签 AutoPLANT_PDW_Catalogue_Port_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.4.1 数据结构 
 

名称 显示标签 数据类型 
IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

Boolean 
String 
String 
string 

 
1.4.2 说明 

 
指定 AutoPLANT Catalog/等级层端口属性映射 
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1.4.3 属性 
 

1.4.3.1 IsValueToBeMapped 

此属性是否需要值映射 
 

1.4.3.2 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.4.3.3 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.4.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.4.4 示例 

 
 
 

1.5 AutoPLANT_PDW_Catalogue_Table_Map 
 

类名称 AP_3D_Catalogue_TableProperties 

显示标签 AutoPLANT_PDW_Catalogue_Table_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.5.1 数据结构 
 

名称 显示标签 数据类型 
IsValueToBeMapped 
ValueMapName 
AlwaysCreate 
ECExpression 

IsValueToBeMapped 
ValueMapName 
AlwaysCreate 
ECExpression 

Boolean 
String 
Boolean 
string 

 
1.5.2 说明 

 
指定在 Catalog/等级数据库中创建字段时所需的信息，以及导入期间所需的
任何附加值操作 
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1.5.3 属性 
 

1.5.3.1 IsValueToBeMapped 

此属性是否需要值映射 
 

1.5.3.2 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.5.3.3 AlwaysCreate 

即使此属性值为空也会创建此属性字段 
 

1.5.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.5.4 示例 

 
 
 

1.6 AutoPLANT_PDW_Catalogue_Value_Map 
 

类名称 AP_3D_Catalogue_ValueProperties 

显示标签 AutoPLANT_PDW_Catalogue_Value_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.6.1 数据结构 
 

名称 显示标签 数据类型 
ValueNameInAutoPLANT3D ValueNameInAutoPLANT3

D 
string 
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1.6.2 说明 
 

指定 AutoPLANT Catalog/等级层值映射 
 

1.6.3 属性 
 

1.6.3.1 ValueNameInAutoPLANT3D 

AutoPLANT 特定值 
 

1.6.4 示例 

 
 
 

1.7 Associated Task Panes 
 

类名称 AssociatedTaskPanes 

显示标签 Associated Task Panes 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 

1.7.1 数据结构 
 

名称 显示标签 数据类型 
TaskPaneLabels Task Pane Labels string 

 
1.7.2 说明 

 
定义任务窗格的名称，该任务窗格中的所有子类都将显示为可放置的选项。 

 
1.7.3 属性 

 
1.7.3.1 Task Pane Labels 

应显示在任务窗格上的标签字符串 
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1.7.4 示例 

 
 
 

1.8 Component Ports Information 
 

类名称 Component_Ports_Information 

显示标签 Component Ports Information 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.8.1 数据结构 
 

名称 显示标签 数据类型 
Port_Count 
Port_EC_Class_Name 
Port_Type 

No. of Ports 
Port EC Class Name 

Port Type 

Int 
String 
string 

 
1.8.2 说明 

 
定义 OPM 的元件端口信息 

 
1.8.3 属性 

 
1.8.3.1 No. of Ports 

元件端口数量 
 

1.8.3.2 Port EC Class Name 

端口用 EC 类名称 
 

1.8.3.3 Port Type 

端口类型 
 

1.8.4 示例 
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1.9 Creation Attribute 
 

类名称 CREATION_ATTRIBUTE 

显示标签 Creation Attribute 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.9.1 数据结构 
 

名称 显示标签 数据类型 
ASSEMBLY_NAME Assembly Name string 
CLASS_NAME Class Name string 
NAMESPACE Namespace string 
PLACEMENT_TOOL Placement tool string 
HANDLER_TYPE Handler Type string 
DIAGRAM_CELL_NAME Diagram Cell Name string 
CELL_LIBRARY Cell Library string 

 
1.9.2 说明 

 
定义 OPM 的元件绘图与放置信息 

 
1.9.3 属性 

 
1.9.3.1 Assembly Name 

脚本类所属的组合件名称 
 

1.9.3.2 Class Name 

脚本类的名称 
 

1.9.3.3 Namespace 

脚本类所属的名称空间 
 

1.9.3.4 Placement tool 

元件所用的放置工具 
 

1.9.3.5 Handler Type 

元件所用的处理器类型 
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1.9.3.6 Diagram Cell Name 

包含该图表的默认单元。 
 

1.9.3.7 Cell Library 

包含元件预览的单元库。 
 

1.9.4 示例 

 
 

 
 

1.10 Custom geometry 
 

类名称 CUSTOM_GEOMETRY_TYPE 

显示标签 Custom geometry 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 

1.10.1 数据结构 
 

名称 显示标签 数据类型 
GROUP_ID 
GROUP_NAME 

Group ID 
Group name 

String 
string 

 
1.10.2 说明 

 
在可用于自定义设备创建的选项列表中添加 EC 类。 

 
1.10.3 属性 

 
1.10.3.1 Group ID 

可用作设备类型代码的组 ID 
 

1.10.3.2 Group name 

该组的显示名称。 
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1.10.4 示例 

 
 
 

1.11 Default Value 
 

类名称 DEFAULT_VALUE 

显示标签 Default Value 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.11.1 数据结构 
 

名称 显示标签 数据类型 
VALUE Value string 

 
1.11.2 说明 

 
若其他源中不提供 EC 属性值，可使用默认值进行填充 

 
1.11.3 属性 

 
1.11.3.1 Value 

属性的默认值 
 

1.11.4 示例 

 
 
 

1.12 End Preparation Script Information 
 

类名称 END_PREPARATION_SCRIPT_INFORMATION 

显示标签 End Preparation Script Information 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.12.1 数据结构 
 

名称 显示标签 数据类型 
ASSEMBLY_NAME 
CLASS_NAME 
NAMESPACE 

Assembly Name 
Class Name 
Namespace 

String 
String 
string 

 
1.12.2 说明 

 
定义用于绘制端面处理图形的绘图例行程序 

 
1.12.3 属性 

 
1.12.3.1 Assembly Name 

脚本类所属的组合件名称 
 

1.12.3.2 Class Name 

脚本类的名称 
 

1.12.3.3 Namespace 

脚本类所属的名称空间 
 

1.12.4 示例 

 
 
 

1.13 End_Preparation_Type 
 

类名称 End_Preparation_Type 

显示标签 End_Preparation_Type 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.13.1 数据结构 
 

名称 显示标签 数据类型 
IS_FEMALE 
END_PREPARATION_TYPE 

Is Female 
End Preparation Type 

Boolean 
string 
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1.13.2 说明 
 

可根据端面在 OPM 中的含义对端面处理进行分类 
 

1.13.3 属性 
 

1.13.3.1 Is Female 

端面处理为凹面型还是其他类型 
 

1.13.3.2 End Preparation Type 

端面处理衍生类型 
 

1.13.4 示例 

 
 
 

1.14 End Preparation Type Information Map 
 

类名称 END_PREPARATION_TYPE_INFORMATION_MAP 

显示标签 End Preparation Type Information Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.14.1 数据结构 
 

名称 显示标签 数据类型 
END_PREPARATION_TYPE_C
LASS_NAME 

End Preparation Type 
Class Name 

string 

END_PREPARATION_TYPE_P
ROPERTY_MAP 

End Preparation Type 
Property Map 

opca:End Preparation Type Property 
Map Struct 
string 

• END_PREPARATION_TYPE
_PROPERTY 

• End Preparation Type 
Property 

string 

• PORT_PROPERTY • Port Property string 
 
 

1.14.2 说明 
 

可将端面处理命名映射到其对应的绘图例行程序类 
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1.14.3 属性 
 

1.14.3.1 End Preparation Type Class Name 

端面处理的绘图脚本类名称 
 

1.14.3.2 End Preparation Type Property Map 

端面处理尺寸信息的内部属性映射 

1.14.3.2.1 End Preparation Type Property 

脚本类中的端面条件尺寸属性，用于绘制端面条件图形 

1.14.3.2.2 Port Property 

端口 EC 类的相应 EC 属性 
 

1.14.4 示例 

 
 

 
 

1.15 Hvac Custom Geometry 
 

类名称 HVAC_CUSTOM_GEOMETRY_TYPE 

显示标签 Hvac Custom Geometry 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 

1.15.1 数据结构 
 

名称 显示标签 数据类型 
GROUP_ID 
GROUP_NAME 

Group ID 
Group name 

String 
string 

 
1.15.2 说明 

 
在用于创建自定义 HVAC 元件的选项中添加 EC 类 
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1.15.3 属性 
 

1.15.3.1 Group ID 

此类所属的组 ID 
 

1.15.3.2 Group name 

已分配的组的名称 
 

1.15.4 示例 

 
 
 

1.16 Lookup Value Map Pointer 
 

类名称 LOOKUP_VALUE_MAP_POINTER 

显示标签 Lookup Value Map Pointer 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:[none] 

1.16.1 数据结构 
 

名称 显示标签 数据类型 
ADD_BLANK_VALUE Add Blank Value boolean 
LOOKUP_VALUE_MAP_CL
ASS 

Lookup Value Map 
Class 

string 

PropertyName PropertyName string 
ECExpression ECExpression string 

 

1.16.2 说明 
 

可帮助用户指出属性被用作 EC 属性的有效值的 EC 类，此自定义属性在此
类中进行定义。 

 
1.16.3 属性 

 
1.16.3.1 Add Blank Value 

属性值列表中允许出现空值。 
 

1.16.3.2 Lookup Value Map Class Name 

查找值映射分类名称 
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1.16.4 示例 

 
 
 

1.17 ModelServer Class Map 
 

类名称 MODELSERVER_CLASS_MAP 

显示标签 ModelServer Class Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.17.1 数据结构 
 

名称 显示标签 数据类型 
IS_GRAPHICAL Is Graphical boolean 
PRIME_BASE_CLASS Prime Base Class string 
ABSTRACTED_CLASS_NAME Abstracted Class Name string 
DISPLAY_LABEL_PROP Display Label Property string 
ROOT_NODE Set As Root Node boolean 
MARKS_DISCIPLINE Set As Discipline Node boolean 
AUTO_REFERENCEOUT Auto ReferenceOut on 

Server connect 
boolean 

IS_NONLOCKABLE Is Non Lockable boolean 
IS_BROWSE_SUPPORTED IsBrowseSupported boolean 
GUI_VISIBILITY GUI Visibility boolean 
IS_PHYSICALGROUPINGNODE Is PhysicalGroupingNode boolean 
IS_CHECKOUTDISABLE IsCheckoutDisable boolean 
IS_DUPLICATE_CHECK Is Duplicate Check boolean 

 

1.17.2 说明 
 

用于定义 OPMS 中某一 EC 类行为的主自定义属性。 
 

1.17.3 属性 
 

1.17.3.1 Is Graphical 

判断类及其子类是否为图形 
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1.17.3.2 Prime Base Class 

存在多个基类时，其中可被视为主基类的类（展平逻辑） 
 

1.17.3.3 Abstracted Class Name 

经过 Schema 展平处理后，各类变得抽象起来。 
 

1.17.3.4 Display Label Property 

希望在 <ClassName> :<instanceID> :<DisplayProp> 之后的 TreeNode 中显示
的属性值 

 
1.17.3.5 Set As Root Node 

在浏览 PW 存储库时，将要显示为根节点的类设为 True 
 

1.17.3.6 Set As Discipline Node 

在浏览 PW 存储库时，将要显示为规则节点的类设为 True 
 

1.17.3.7 Auto ReferenceOut on Server connect 

将要从服务器自动引用的类设为 True 
 

1.17.3.8 Is Non Lockable 

是否无需锁定 
 

1.17.3.9 IsBrowseSupported 

指示是否支持 IsBrowseSupported。 
 

1.17.3.10 GUI Visibility 

显示 GUI 的可视性 
 

1.17.3.11 Is PhysicalGroupingNode 

判断该类是否具有分组节点 
 

1.17.3.12 IsCheckoutDisable 

是否禁用上下文菜单检出 
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1.17.3.13 Is Duplicate Check 

[none] 
 

1.17.4 示例 

 
 
 

1.18 ModelServer Relationship Map 
 

类名称 MODELSERVER_RELATIONSHIP_MAP 

显示标签 ModelServer Relationship Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.18.1 数据结构 
 

名称 显示标签 数据类型 
SUPPORTED 
DIRECTION 
TARGET_POLYMORPHIC 

Supported 
Direction 
Target Polymorphic 

Boolean 
String 
boolean 

 
1.18.2 说明 

 
定义 OPMS 所需的关系类属性。 

 
1.18.3 属性 

 
1.18.3.1 Supported 

说明 ModelServer 当前是否支持此关系 
 

1.18.3.2 Direction 

要在 ModelSrv 中使用此关系的方向 
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1.18.3.3 Target Polymorphic 

指示是否会将此关系的目标视为多形态 
 

1.18.4 示例 

 
 
 

1.19 Nozzle Property 
 

类名称 NOZZLE_PROPERTY 

显示标签 Nozzle Property 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 

1.19.1 数据结构 
 

名称 显示标签 数据类型 
COLUMN_ORDER Column number in grid int 

 
1.19.2 说明 

 
在喷嘴管理器中定义属性列的位置 

 
1.19.3 属性 

 
1.19.3.1 Column number in grid 

[none] 
 

1.19.4 示例 
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1.20 Nozzle Type Information 
 

类名称 NOZZLE_TYPE_INFO 

显示标签 Nozzle Type Information 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 

1.20.1 数据结构 
 

名称 显示标签 数据类型 
DIAGRAM_CELL Diagram cell string 
DIAGRAM_LIBRARY Library for diagram cell string 
ITEM_CLASS Item class string 
ASSEMBLY_NAME Assembly Name string 
NAMESPACE Namespace string 
SCRIPT Script for locations string 
SCRIPT_ASSEMBLY Point Script Assembly- 

name 
string 

SCRIPT_NAMESPACE Point script namespace string 
CLASS_NAME Script Name string 
PLACEMENT_TOOL Placement Tool string 
HANDLER_TYPE Handler Type string 
DYNAMIC_SCRIPT Dynamic script for 

computing parameters 
string 

SYSTEM System boolean 
SPECIFICATION Specification boolean 
NOMINAL_DIAMETER Nominal Diameter boolean 
INSULATION_THICKNESS Insulation Thickness boolean 
PARAM_A A boolean 
PARAM_B B boolean 
PARAM_C C boolean 
PARAM_D D boolean 
PARAM_E E boolean 
LENGTH L boolean 
PROJECTION P boolean 
PARAM_T T boolean 
PARAM_R R boolean 
LINENUMBER Line boolean 

 
1.20.2 说明 

 
指定喷嘴类元件的放置及操作方式 
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1.20.3 属性 
 

1.20.3.1 Diagram cell 

此类喷嘴中要显示为图表的单元名称 
 

1.20.3.2 Library for diagram cell 

图表单元在此单元库中 
 

1.20.3.3 Item class 

此喷嘴类型（直喷嘴、弯头喷嘴、人孔...）的项类型 
 

1.20.3.4 Assembly Name 

脚本类所属的组合件名称 
 

1.20.3.5 Namespace 

此类喷嘴中要显示为图表的单元名称 
 

1.20.3.6 Script for locations 

用于计算点位置的脚本 
 

1.20.3.7 Point Script Assembly- name 

点脚本在此组合件中 
 

1.20.3.8 Point script namespace 

点脚本在此名称空间中 
 

1.20.3.9 Script Name 

脚本类的名称 
 

1.20.3.10 Placement Tool 

元件所用的放置工具 
 

1.20.3.11 Handler Type 

元件所用的处理器类型 
 

1.20.3.12 Dynamic script for computing parameters 

用于计算参数的脚本 
 

1.20.3.13 System 

是否显示列“System” 
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1.20.3.14 Specification 

是否显示列“Specification” 
 

1.20.3.15 Nominal Diameter 

是否显示列“Nominal Diameter” 
 

1.20.3.16 Insulation Thickness 

是否显示列“Insulation Thickness” 
 

1.20.3.17 A 

是否显示列 A 
 

1.20.3.18 B 

是否显示列 B 
 

1.20.3.19 C 

是否显示列 C 
 

1.20.3.20 D 

是否显示列 D 
 

1.20.3.21 E 

是否显示列 E 
 

1.20.3.22 L 

是否显示列 L 
 

1.20.3.23 P 

是否显示列 P 
 

1.20.3.24 T 

是否显示列 T 
 

1.20.3.25 R 

是否显示列 R 
 

1.20.3.26 Line 

是否显示列“Line” 
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1.20.4 示例 

 
 
 

1.21 OpenPlant_Physical_AdditionalQuery 
 

类名称 OpenPlant_3D_AdditionalQuery 

显示标签 OpenPlant_Physical_AdditionalQuery 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.21.1 数据结构 
 

名称 显示标签 数据类型 
WHERE_CLAUSE Where Clause opca:OpenPlant_Physical_Additional 

Query_Struct 
• OPERATOR • Operator • string 
• RELATIONSHIP • Relationship • string 
• RELATED_CLASS • Related Class • string 
• CLAUSE • Clause • opca:OpenPlant_Physical_Additional 

Clause_Struct 
• PROPERTY_NAME • PropertyName • string 
• VALUE • Value • string 
• REL_OPERATOR • Relational 

Operator 
• string 

• LOG_OPERATOR_BEF
ORE 

• Logical Operator 
Before 

• string 
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1.21.2 说明 
 

指定要用于等级中元件查询的附加 where 子句 
 

1.21.3 属性 
 

1.21.3.1 Where Clause 

针对基于附加信息的查询的查询定义 

1.21.3.1.1 Operator 

用于连接已定义子句与原始 OPM 元件查询 where 子句的运算符 

1.21.3.1.2 Relationship 

已定义的 where 子句属性属于相关元件实例时的 EC 关系名称 

1.21.3.1.3 Related Class 

相关 EC 类的 EC 类名称 

1.21.3.1.4 Clause 

用户定义的 where 子句 

1.21.3.1.4.1 PropertyName 

要添加到 where 子句中的 EC 属性名称 

1.21.3.1.4.2 Value 

要查询的上述已定义 EC 属性的值 

1.21.3.1.4.3 Relational Operator 

对上述在 where 子句中定义的值进行运算 

1.21.3.1.4.4 Logical Operator Before 

用于上述已定义 where 子句的逻辑运算符 
 

1.21.4 示例 
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1.22 OpenPlant_Physical_Catalogue_Property_Map 
 

类名称 OpenPlant_3D_Catalogue_AttributeProperties 

显示标签 OpenPlant_Physical_Catalogue_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.22.1 数据结构 
 

名称 显示标签 数据类型 
PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

String 
Boolean 
string 
string 

 
1.22.2 说明 

 
指定 OpenPalnt Modeler Catalog/等级层属性映射 

 
1.22.3 属性 

 
1.22.3.1 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.22.3.2 IsValueToBeMapped 

此属性是否需要值映射 
 

1.22.3.3 ValueMapName 

端口用 EC 类名称 
 

1.22.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.22.4 示例 
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1.23 OpenPlant_Physical_Catalogue_BranchCode 
 

类名称 OpenPlant_3D_Catalogue_BranchCode 

显示标签 OpenPlant_Physical_Catalogue_BranchCode 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.23.1 数据结构 
 

名称 显示标签 数据类型 
BranchCode Branch Code string 
MaximumAngle Maximum Allowable 

Angle 
double 

MinimumAngle Minimum Allowable 
Angle 

double 

 
1.23.2 说明 

 
定义等级生成器的分支表中所用元件的分支规范 

 
1.23.3 属性 

 
1.23.3.1 Branch Code 

元件的分支规范 
 

1.23.3.2 Maximum Allowable Angle 

此分支元件可兼容的最大支管有效角度 
 

1.23.3.3 Minimum Allowable Angle 

此分支元件可兼容的最小支管有效角度 
 

1.23.4 示例 
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1.24 OpenPlant_Physical_Catalogue_Class_Map 
 

类名称 OpenPlant_3D_Catalogue_ClassProperties 

显示标签 OpenPlant_Physical_Catalogue_Class_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.24.1 数据结构 
 

名称 显示标签 数据类型 
Table Table string 
ComponentType ComponentType string 
USE_ECCLASSNAME Use EC Class string 
ClassMapping ClassMapping opca:OpenPlant_Physical_Catalogue

_Class_Map_Struct 
 

1.24.2 说明 
 

指定 OpenPalnt Modeler Catalog/等级层类映射 
 

1.24.3 属性 
 

1.24.3.1 Table 

等级/Catalog 中的表名称 
 

1.24.3.2 ComponentType 

元件类型 
 

1.24.3.3 Use EC Class 

使用其他 EC 类映射信息来查询元件数据 
 

1.24.3.4 ClassMapping 

OpenPlant 类映射信息（已过时，用户无需对此进行定义，日后将被移除） 
 

1.24.4 示例 
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1.25 OpenPlant_Physical_Catalogue_Port_Property_Map 
 

类名称 OpenPlant_3D_Catalogue_PortAttributeProperties 

显示标签 OpenPlant_Physical_Catalogue_Port_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.25.1 数据结构 
 

名称 显示标签 数据类型 
IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

Boolean 
string 
string 
string 

 
1.25.2 说明 

 
指定 OpenPalnt Modeler Catalog/等级层端口属性映射 

 
1.25.3 属性 

 
1.25.3.1 IsValueToBeMapped 

此属性是否需要值映射 
 

1.25.3.2 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.25.3.3 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.25.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.25.4 示例 
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1.26 OpenPlant_Physical_Catalogue_SpecSection 
 

类名称 OpenPlant_3D_Catalogue_SpecSection 

显示标签 OpenPlant_Physical_Catalogue_SpecSection 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.26.1 数据结构 
 

名称 显示标签 数据类型 
SectionName 
Constraints 

SectionName 
Constraints 

string 
string 

 
1.26.2 说明 

 
定义 Spec Generator 中“Section”的名称，在此应显示其所应用的 EC 类。 

 
1.26.3 属性 

 
1.26.3.1 SectionName 

Spec Generator 中 EC 类所属的“Section”的名称。 
 

1.26.3.2 Constraints 

应显示为默认选项的 EC 类的约束列表。 
 

1.26.4 示例 

 
 

 
 

1.27 OpenPlant_Physical_Catalogue_Table_Map 
 

类名称 OpenPlant_3D_Catalogue_TableProperties 

显示标签 OpenPlant_Physical_Catalogue_Table_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.27.1 数据结构 
 

名称 显示标签 数据类型 
IsValueToBeMapped 
ValueMapName 
AlwaysCreate 
ECExpression 

IsValueToBeMapped 
ValueMapName 
AlwaysCreate 
ECExpression 

boolean 
string 
boolean 
string 

 
1.27.2 说明 

 
指定导入期间所需的属性字段创建信息，以及将其写入 OPM Catalog/等级期
间所需的附加值操作 

 
1.27.3 属性 

 
1.27.3.1 IsValueToBeMapped 

此属性是否需要值映射 
 

1.27.3.2 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.27.3.3 AlwaysCreate 

无论等级/Catalog 数据库表中存在何种属性与否，都将此属性创建为此
表中的字段。 

 
1.27.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.27.4 示例 

 
 
 

1.28 OpenPlant_Physical_Catalogue_Value_Map 
 

类名称 OpenPlant_3D_Catalogue_ValueProperties 

显示标签 OpenPlant_Physical_Catalogue_Value_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.28.1 数据结构 
 

名称 显示标签 数据类型 

ValueNameInOpenPlant3D ValueNameInOpenPlant3D string 

 

1.28.2 说明 
 

指定 OpenPalnt Modeler Catalog/等级层属性值映射 
 

1.28.3 属性 
 

1.28.3.1 ValueNameInOpenPlant3D 

在 OpenPlant3D 等级/Catalog 中显示的值 
 

1.28.4 示例 

 
 
 

1.29 OpenPlant Physical Conversion 
 

类名称 OpenPlant_3D_Conversion 

显示标签 OpenPlant Physical Conversion 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.29.1 数据结构 
 

名称 显示标签 数据类型 
ELEMENT_TYPE Element Type int 

 
1.29.2 说明 

 
可用于定义从 PDS dgn 执行转换操作时所考虑的元素类型 

 
1.29.3 属性 

 
1.29.3.1 Element Type 

要转换的源 EC 实例图形的预期 DGN 元素类型 
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1.29.4 示例 

 
 
 

1.30 OpenPlant_Physical_JointType_Map 
 

类名称 OpenPlant_3D_JointTypeProperties_Map 

显示标签 OpenPlant_Physical_JointType_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.30.1 数据结构 
 

名称 显示标签 数据类型 
JOINT_TYPE Joint Name opca:OpenPlant_Physical_JointType

_Struct 
JOINT_NAME Joint Type string 
IS_SPEC_DRIVEN Is Fastener Spec Driven boolean 
SCRIPT_ASSEMBLY_NAME Script Assembly Name string 
SCRIPT_CLASS_NAME Script Class Name string 
SCRIPT_NAMESPACE Script Namespace string 
END_PREPARATION_1 End Preparation 1 string 
END_PREPARATION_2 End Preparation 2 string 
MATCH_PROPERTY Match Property string 
FASTENER Fastener string 

 
1.30.2 说明 

 
指定接头类型及其兼容性信息 

 
1.30.3 属性 

 
1.30.3.1 Joint Type 

定义 OPM 接头类型及其下列属性 

1.30.3.1.1 Joint Name 

接头名称，在列表中必须是唯一的。 

1.30.3.1.2 Is Fastener Spec Driven 

此接头所需的紧固件是否应从等级中查询。 
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1.30.3.1.3 Script Assembly Name 

接头脚本的类组合件名称 

1.30.3.1.4 Script Class Name 

接头脚本，其中包含创建接头时所需的附加信息或检查 

1.30.3.1.5 Script Namespace 

接头脚本类的名称空间 

1.30.3.1.6 End Preparation 1 

第一组兼容的端面处理 

1.30.3.1.7 End Preparation 2 

第二组端面处理，其应与第一组兼容以便获得有效接头 

1.30.3.1.8 Match Property 

流体端口属性，其应配合于两匹配元件之间，以便验证接头。 

1.30.3.1.9 Fastener 

创建接头时要插入的紧固件列表。 
 

1.30.4 示例 
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1.31 OpenPlant_Physical_Placeable_Child_Classes 
 

类名称 OpenPlant_3D_Placeable_Child_Classes 

显示标签 OpenPlant_Physical_Placeable_Child_Classes 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.31.1 数据结构 
 

名称 显示标签 数据类型 
EC_CLASS_NAME EC_CLASS_NAME string 

 
1.31.2 说明 

 
指定应立即用于放置父类的子选项的子类列表 

 
1.31.3 属性 

 
1.31.3.1 EC_CLASS_NAME 

子 EC 类的名称 
 

1.31.4 示例 

 
 

 
 

1.32 OpenPlant Physical Support Map 
 

类名称 OPENPLANT_PHYSICAL_SUPPORT_MAP 

显示标签 OpenPlant Physical Support Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.32.1 数据结构 
 

名称 显示标签 数据类型 
SUPPORT_CLASS_NAME 
IS_SUPPORT_TO_SUPPORT 
IS_ELBOW_SUPPORT 
IS_HEIGHT_BY_DATAPOINT 

Support Class Name 
IsSupportToSupport 
IsElbowSupport 
IsHeightByDataPoint 

string 
boolean 
boolean 
boolean 

 
1.32.2 说明 

 
定义支持类型类的不同属性。 

 
1.32.3 属性 

 
1.32.3.1 Support Class Name 

可应用于此 EC 支持类的支持 EC 类名称 
 

1.32.3.2 IsSupportToSupport 

此支持是否可以应用于另一支持上？ 
 

1.32.3.3 IsElbowSupport 

此支持是否可以应用于弯头上？ 
 

1.32.3.4 IsHeightByDataPoint 

可否从用户输入的数据点提取支持的高度？ 
 

1.32.4 示例 
 

 
 
 
 

1.33 Parametric Property Marker 
 

类名称 PARAMETRIC_PROPERTY_MARKER 

显示标签 Parametric Property Marker 
Schema OpenPlant_CustomAttributes.08.11 

基类 [none] 
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1.33.1 数据结构 
 

名称 显示标签 数据类型 
PARAMETRIC_STATUS 
DISPLAY_PREFIX 
DISPLAY_ORDER 

Parametric Status 
Prefix display-label with 
Override display order 

int 
string 
int 

 
1.33.2 说明 

 
此 CA 用于标记应由用户输入的参数属性。 

 
1.33.3 属性 

 
1.33.3.1 Parametric Status 

此属性由参数创建器保存到已保存的属性列表中时，参数化状态显示为 1 
 

1.33.3.2 Prefix display-label with 

将此内容添加到属性显示标签的开头 
 

1.33.3.3 Override display order 

覆盖显示顺序 
 

1.33.4 示例 
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1.34 PDS_Catalogue_Property_Map 
 

类名称 PDS_Catalogue_AttributeProperties 

显示标签 PDS_Catalogue_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.34.1 数据结构 
 

名称 显示标签 数据类型 
PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

string 
boolean 
string 
string 

 
1.34.2 说明 

 
指定 OpenPalnt Modeler Catalog/等级层属性映射 

 
1.34.3 属性 

 
1.34.3.1 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.34.3.2 IsValueToBeMapped 

此属性是否需要值映射 
 

1.34.3.3 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.34.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.34.4 示例 
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1.35 PDS_Catalogue_Class_Map 
 

类名称 PDS_Catalogue_ClassProperties 

显示标签 PDS_Catalogue_Class_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.35.1 数据结构 
 

名称 显示标签 数据类型 
USE_ECCLASSNAME 
ClassNames 

Use EC Class 
ClassNames 

string 
string 

 
1.35.2 说明 

 
指定 PDS Catalog/等级层类映射 

 
1.35.3 属性 

 
1.35.3.1 Use EC Class 

使用其他 EC 类映射信息来查询元件数据 
 

1.35.3.2 ClassNames 

要映射的元件的 PDS 类名称 
 

1.35.4 示例 

 
 

 
 

1.36 PDS_Catalogue_Value_Map 
 

类名称 PDS_Catalogue_ValueProperties 

显示标签 PDS_Catalogue_Value_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.36.1 数据结构 
 

名称 显示标签 数据类型 
ValueNameInPDS ValueNameInPDS string 

 
1.36.2 说明 

 
定义 PDS 属性值的值映射。 

 
1.36.3 属性 

 
1.36.3.1 ValueNameInPDS 

PDS 中的属性值 
 

1.36.4 示例 

 
 

 
 

1.37 Property Display Status 
 

类名称 PROPERTY_DISPLAY_STATUS 

显示标签 Property Display Status 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.37.1 数据结构 
 

名称 显示标签 数据类型 
ELEMENTINFO_STATUS 
GENERAL_STATUS 
SPECGRID_POISTION 

Element Info Status 
General Status Spec 
Grid Position 

int 
int 
int 

 
1.37.2 说明 

 
定义元素信息、总体状态计划和等级网格中 EC 属性的可视化标准。 
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1.37.3 属性 
 

1.37.3.1 Element Info Status 

定义属性在元素信息中的显示状态 
 

1.37.3.2 General Status 

定义属性在除元素信息之外的所有其他属性窗格中的显示状态。 
 

1.37.3.3 Spec Grid Position 

等级网格中的列位置，0 表示不显示 
 

1.37.4 示例 

 
 

 
 

1.38 Plant Area Definition Class 
 

类名称 VOLUMEDEFCLASS 

显示标签 Plant Area Definition Class 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.38.1 数据结构 
 

名称 显示标签 数据类型 
ICON 
CHILDREN 

IconID in DgnLib 
Children 

string 
string 

 
1.38.2 说明 

 
定义 EC 类被标记为“Area”类时的不同属性。 

 
1.38.3 属性 

 
1.38.3.1 IconID in DgnLib 

应用于代表区域的图标。 
 

1.38.3.2 Children 

子类（若已定义）的名称。 
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1.38.4 示例 

 
 
 

1.39 PlantSpace_DesignSeries_Catalogue_Property_Map 
 

类名称 PSDS_Catalogue_AttributeProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.39.1 数据结构 
 

名称 显示标签 数据类型 
PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

PropertyName 
IsValueToBeMapped 
ValueMapName 
ECExpression 

string 
boolean 
string 
string 

 
1.39.2 说明 

 
可将 PSDS Catalog/等级属性与 EC 属性一一对应。 

 
1.39.3 属性 

 
1.39.3.1 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.39.3.2 IsValueToBeMapped 

此属性是否需要值映射 
 

1.39.3.3 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.39.3.4 ECExpression 

用于处理属性值的 ECExpression 
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1.39.4 示例 

 
 
 

1.40 PlantSpace_DesignSeries_Catalogue_Class_Map 
 

类名称 PSDS_Catalogue_ClassProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Class_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.40.1 数据结构 
 

名称 显示标签 数据类型 
Table 
USE_ECCLASSNAME 
ClassName 

Table 
Use EC Class 
ClassName 

string 
string 
string 

 
1.40.2 说明 

 
指定 PSDS Catalog/等级层元件类映射 

 
1.40.3 属性 

 
1.40.3.1 Table 

等级/Catalog 中的表名称 
 

1.40.3.2 Use EC Class 

使用其他 EC 类映射信息来查询元件数据 
 

1.40.3.3 ClassName 

要映射的元件的 PSDS 类名称 
 

1.40.4 示例 
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1.41 PlantSpace_DesignSeries_Catalogue_Material_Value_Map 
 

类名称 PSDS_Catalogue_MaterialValueProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Material_Value_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.41.1 数据结构 
 

名称 显示标签 数据类型 
ValueNameInPSDS 
ValueDescriptionInPSDS 

ValueNameInPSDS 
ValueDescriptionInPSDS 

string 
string 

 
1.41.2 说明 

 
指定 PSDS 材料映射属性 

 
1.41.3 属性 

 
1.41.3.1 ValueNameInPSDS 

PSDS 中的属性值 
 

1.41.3.2 ValueDescriptionInPSDS 

PSDS 中属性值的描述性信息 
 

1.41.4 示例 

 
 
 

1.42 PlantSpace_DesignSeries_Catalogue_Port_Property_Map 
 

类名称 PSDS_Catalogue_PortAttributeProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Port_Property_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 
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1.42.1 数据结构 
 

名称 显示标签 数据类型 
IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

IsValueToBeMapped 
ValueMapName 
PropertyName 
ECExpression 

boolean 
string 
string 
string 

 
1.42.2 说明 

 
可在流体端口 EC 类中将 PSDS 接口属性与其 EC 端口属性一一对应 

 
1.42.3 属性 

 
1.42.3.1 IsValueToBeMapped 

此属性是否需要值映射 
 

1.42.3.2 ValueMapName 

包含值映射信息的 EC 类名称 
 

1.42.3.3 PropertyName 

Catalog/等级表中的属性字段名称 
 

1.42.3.4 ECExpression 

用于处理属性值的 ECExpression 
 

1.42.4 示例 
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1.43 PlantSpace_DesignSeries_Catalogue_Table_Map 
 

类名称 PSDS_Catalogue_TableProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Table_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.43.1 数据结构 
 

名称 显示标签 数据类型 
DefaultValue DefaultValue string 

FieldLength FieldLength string 
SpecField SpecField boolean 
IsValueToBeMapped IsValueToBeMapped boolean 
ValueMapName ValueMapName string 
SystemFieldName SystemFieldName string 
ECExpression ECExpression string 

 
1.43.2 说明 

 
指定导入期间所需 PSDS Catalog/等级字段的不同属性 

 
1.43.3 属性 

 
1.43.3.1 DefaultValue 

未找到此属性值时要设置的默认值 
 

1.43.3.2 FieldLength 

在等级/Catalog 导入期间，要在 PSDS 数据库中创建的字段长度 
 

1.43.3.3 SpecField 

此字段属于 PSDS 等级表时，将其设置为 True 
 

1.43.3.4 IsValueToBeMapped 

此属性是否需要值映射 
 

1.43.3.5 ValueMapName 

包含值映射信息的 EC 类名称 
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1.43.3.6 SystemFieldName 

[none] 
 

1.43.3.7 ECExpression 

用于处理属性值的 ECExpression 
 

1.43.4 示例 

 
 
 

1.44 PlantSpace_DesignSeries_Catalogue_Value_Map 
 

类名称 PSDS_Catalogue_ValueProperties 

显示标签 PlantSpace_DesignSeries_Catalogue_Value_Map 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.44.1 数据结构 
 

名称 显示标签 数据类型 
ValueNameInPSDS ValueNameInPSDS string 

 
1.44.2 说明 

 
指定 PSDS 的属性值映射 

 
1.44.3 属性 

 
1.44.3.1 ValueNameInPSDS 

PSDS 中的值 
 

1.44.4 示例 
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1.45 Replacement Options 
 

类名称 ReplacementOptions 

显示标签 Replacement Options 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.45.1 数据结构 
 

名称 显示标签 数据类型 
CLASSES Classes string 

 
1.45.2 说明 

 
可使用 Component Replace 选项定义能够替换该 EC 类的 EC 类列表。 

 
1.45.3 属性 

 
1.45.3.1 Classes 

允许被替换的 EC 类的名称。 
 

1.45.4 示例 

 
 

 
 

1.46 Standard Preference 
 

类名称 StandardPreference 

显示标签 Standard Preference 
Schema OpenPlant_CustomAttributes.08.11 

基类 opca:MappingBase 

1.46.1 数据结构 
 

名称 显示标签 数据类型 
BoxOrder 
DisplayTableName 
InputMethod 

Box Order 
Display Table Name 

Input Method 

int 
string 
string 
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名称 显示标签 数据类型 
Group  
IsSpecToBeQueried 

Group 
Is Spec To Be Queried 

string 
boolean 

 

1.46.2 说明 
 

用户能够控制要显示在标准首选项中的特定属性的行为。 
 

1.46.3 属性 
 

1.46.3.1 Box Order 

属性在标准首选项中的位置。 
 

1.46.3.2 Display Table Name 

[none] 
 

1.46.3.3 Input Method 

此属性定义标准首选项中属性值的填充方式。 
 

1.46.3.4 Group 

定义属性在标准首选项中应归属的组。 
 

1.46.3.5 Is Spec To Be Queried 

此属性是否需要等级查询？ 
 

1.46.4 示例 
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