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elLectures of this course available on the Bentley LEARN Server (learn.bentley.com).
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Description and Objectives

Course Description

This workbook contains exercises to customize a drawing border and control the level names, colors, styles and weights.

Skills Taught
= Customizing the Drawing Border
= Customize the Drawing Border Data in the Dashboard

= Customizing the Levels
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Getting Started

Each company has its own drawing border and style so supplying a standard drawing border is out of the question. We supply a drawing
border in the sample data set to get started. Creating and customizing the drawing border needs to be done with some tools in MicroStation,
OpenPlant Support Engineering (OPSE) in the user interface and OPSE Dashboard settings.

OPSE does not depend on the user to place components on the correct project level with the correct symbology. For OPSE elements the user
doesn't have to set the symbology or use Element templates. OPSE controls all of this through the project Dashboard in the Visual Manager.

A few rules to follow:

There are a few rules that must be followed for the program to work correctly. If these rules are not followed then then the drawing production
will not work correctly.

= The Design File Settings and Working Units of the sheet must be the same as the Design file.

Format
Master Unit
Sub Unit

Resolution (Note: If there is geometry in a design file the Resolution cannot be changed without scaling the geometry.) We will
show you how to deal with this issue.

= The Border Seed file must be a 3D sheet model. (Do not use a 2D sheet model.

Category
Active Angle
Active Scale
Angle Readout
Pads

Calor

Element Attributes
Fence

Grid

lsometric
Locks

Snaps

Stream

Views
Working Units

Linear Units
Format: | MU:SU

Master Unit: Feet
Sub Unit: |Inches

Accuracy |0.12

| Advanced Settings

Resolution:
Working Area:
Solids Area:
Solids Accuracy:

Focus ltem Description
Select category to view.

[ Modify Working Unit Settings

1000000 per Distance Meter
5.0072E+006 Kilometers

1 Kilometers

1E-008 Meters




Creating a Border Base File

Creating the base file to match the Design file units can be done with MicroStation tools. At this point OPSE will not be
adding anything to the design file. We will grab the graphics of a design file and get this in the correct scale and units
settings by referencing in the graphics into a known good file and coping the graphics into the file.

1. Start OpenPlant Support Engineering.

2. In the File Open dialog, set the following:
User: OPSE_Samples
Project: Sample 1

3. Navigate to the ..\\OPSESamples\Dataset\seed\ folder.

Lookin: | ] seed Jesrm N
T MName = Date modified Type
e [B#B-Border.dgn 2/9/201510:52 AM  Bentley M
Recent places |2 pESh_DrawingProduction.dgn 2/9/20159:36 AM  Bentley M
% BESM_seed.dgn 12/11/201410:10 ...  Bentley M
-__ BESM_seed.dwg 12/11/201410:10 ...  Autodesk
Desktop
;T:
Libraries
A
This PC
Metwork — — - —————————
File name: | B-Border2.dan hdl Open User: |O_P5E_§§l'_l'h'-{l€5__v!
Flesoftype: | CAD Fies ("dan;" dwg;".dd) v | cance | Project: | Sample v
[]Open as read-only Options Interfacs: | Defaut v/

4. Copy BESM_DrawingProduction.dgn.

5. Paste and rename to B-Border.dgn.
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So far we have been using the BESM_ DrawingProduction.dgn as the seed file for the earlier lessons so we know this file is set correctly
for this project.

6. Highlight B-Border.dgn and click Open.

In the Reference dialog, attach the B-border file Default model from \\Systems\Borders\ANSI\ folder.

&5
Tools Settings

B '|'—ﬁ§é_l DG AW KL B 0D G

Slet ¥ 4 File Name Model Description Logical

x

Presentatior
Coincident Wireframe

1 B-border.dgn Default Base model

£
Scale | 1.000000 : [ 1.000000 Rotation | 07
Offset X | 0.0000 | [0.0000 |Z | 0.0000

lE‘ =3 .. d} {" . B l:‘ .l__ 1 Nested Attachments: |No Nesting = | Display Overides: | Alloy

New Level Display: | Config \ \c’anable ¥ | Georeferenced:  MNo

The file should be attached coincident and the bottom left corner should be at 0,0,0.

8. Navigate to Edit > Select All. Delete everything in the design file. This will delete all the elements in the file except the referenced data.

9. With the MicroStation Copy tool select all the referenced elements through to the master file.

10. Detach the Reference file.

Note: The reface file attachment compensates for any difference in the resolution when attached. Note the Scale is set 1:1 but the
resolution was different in the reference file than the master. The graphics now has the correct settings from the master file.
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Setting up the Title Block:

Open the MicroStation Text Tools > Attach Tags tool.
Select the TitleBlockApprovals tag set and place the tags in the drawing.

Move the This is the Drawing Title text as shown.

o Dd =

Move the Pipe Support Number text as shown.
Note: For now the only Tag Set that can be used must be named TitleBlockApprovals. This will change in the future.

5. The Title Block should look like this:

et
This is the Drawing Title
mamus T
[5e5s Pipe Support Number
] T
t 2 I 1
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Creating Areas for Graphics, Bill of Material, and General Info

In this exercise the areas for different parts of the drawing will be created. This will involve using a few MicroStation
tools and some tools in OPSE that will be exposed to only the administrator in the final product.

1. Continue working on file B-Border.dgn. All levels should be on.

2. Create three rectangles with the Place block tool as shown. | set the color to Green and the weight to 2 to make it easy to see. These are
temporary shapes and will be deleted.

4 | 3 Lvi 2 | 1
Orthogonal *
Area: | Sold ~
8 FEill Type: | None 8
Fill Color: 1l 2 -
) -
A A
_uhis is the Drawing Title
WS ] =
Pipe Support Number
|B | |5—Enrﬂer.ﬂgn |
[ - 1 i i
4 I 3 [AY 2 I 1

3. Inthe Support Drawing drawer select the BOM tool.
4. Select the rectangle in the upper right.

5. Place the BOM rectangle over the green shape.
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6. Delete the green shape.

You should have something like this:

4 | - 7 Z | 1
%@ Delete Ele.. — H©
B8 -]
b ke
A A
_uhis is the Drawing Title
WPPADOAL S [ ] Ty
Pipe Support Number
|B | |E-Eurder.d9n |
I 1 =TT
4 | 3 fay 2 | 1
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7. Do the same to the smaller rectangle below.

3 I 3 v Z I 1
@ Delete Ele.. -
B
= ke
A
_uhis is the Drawing Title
WPPRDAL & [ ] .
Pipe Support Number
|B | |E-Eurder.dgn |
I |l | =TT
4 | 3 L 2 | 1
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Defining the Graphic Area

1. From the Support Drawing drawer select the Graphic Area icon.
2. Inthe Drawing Area dialog set the following:
View Type: System
Callout (On/Off): Checked
Y Drawing Area = &
“i¢ Area Parameters
Drawing ¥
= View Type System
Image Type
Frame {On/Off)
Callout (On/Off) E
¥
2/10/2015 11:36:57 AM
& Modification Time 2/10/2015 11:36:57 AM
Project Identification ¥
Item Tag Pipe 8 B1-OPM ACR-SI5-B1...
Project Identity ¥
i L D of each compor
(= ok ]| Ceresl |
3. Click OK.

4. Place graphic shape in the upper left corner.

5. Delete the green shape.
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Customize the Data in the Dashboard

Now that the three areas have been defined the next step is to set some parameters in the Dashboard. As you may

have noticed there are three cells in the seed file, Graphic Area, General Info and Bill Of Material.

1. Open the Project Dashboard from the Support Modeler menu.
2. Expand Settings > Project Parameters in the Navigation panel.

3. Inthe Category/Group tree expand the Project > SupportDrawing section.

n

el 2 | Category/Group
251 Administration bl |
55 Customization v ||
ol | +- Environment
[ Settings = - Placement
| | B Modeling
Project Parameters [l- Repository

Grid System
Seguence Manager

Expressions Manager

lezna Cron Edibar

We want to use the seed file that we have created so we need to tell OPSE what file we want to use.

4. Change the Template value to B-Border.dgn.

Category/Group Parameters
[=- Project

: - SupportDrawing Mame Description
[zl-Environment |

ExpandAsbyBOM Report assembly as single support or multiple

ShowCallout Show callout in the main araphics area

We want to define the Balloon size or Callout Radius.

i v Template Template drawing for production drawing

- Placement |

- Modeling | QutPrefix Prefix of the output file name

- Repository RevPrefix Revision Prefix of the output file name
COverwrite Whether to overwrite existing file or create re...

Value uom
B-Border.dgn
<??PRV.SupportMark =

.Rev

1

1

1
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5. Change the CalloutRadius value to 0.125.

Parameters

Name
Template
OutPrefix
RevPrefix
Overwrite
ExpandAsbyBOM
ShowCallout

GridMame

Description

Template drawing for production drawing

Prefix of the output file name

Revision Prefix of the output file name

Whether to overwrite existing file or create re...
Report assembly as single support or multiple
Show callout in the main graphics area

Callout Radius

Reference Grid name to identify support location

Value
B-Border.dgn
<??PRV.SupportMark =

Next we will set the text and display of grid lines in the BOM and Info area.

Set the BOMHasGridLines to Yes.

© ©® N o

Set the GNHasGridLines to yes.

10. Click Save.

GridMame

f Font
MinTxtHeight
MaxTxtHeight
BOMHasGridLines
GMHasGridLines
DisplayTextTags
TextTagsEditable

Set the MinTxtHeith and the MaxTextHeigt to 0.09375 (3/32").

Reference Grid name to identify support location
Font of the text on output drawing

Minimum Text Height in BOM

Maximum Text Height in BOM

Show grid lines in BOM

Show grid lines in General Motes

Display Tag Text in the Text Editor

Allow Tag Text editing in the Text Editor

[
0.09375
0.09375
Yes

yes

Mo

Mo

UoM

The fonts used in OPSE only support numbered fonts and not TTF fonts. Set the Font to 6.

For Reference: Before we close this panel notice at the bottom of the cells in the seed file match the value of the BOMArea, GNArea and

SO on.
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GraphicsArea
BOMArea

GMArea
SupportkeyPlan
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Mame of Main Graphics area name
Mame of Graphics area name
Mame of Bill Of Material area name
Mame of General Info area name

Mame of Support Key Plan area name

Main Graphic Area
Graphic Area

Bill Of Material
General Info

Support Key Plan
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11. Navigate back to the OPSE ToolCabinet.

12. Click on Refresh ToolCabinet.
13. Save the Settings.
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How the Tags are Populated

The Tag information can be filled in by OPSE and or ProjectWise. For the ProjectWise integration of tags and sign-off
please refer to ProjectWise documentation. ProjectWise will want to know some of the tag information that OPSE needs
to supply like the Project Name and Pipe support number.

Open the Project Dashboard from within the session from Support Modeler > Project Dashboard.
Navigate in the Dashboard to Settings > Expressions Manager.

Notice that there are three items that refer to Tags, Express ID 15, 16, and 17.

w0 N~

Notice that the Express Name is the Tag Name.

Navigation T
aﬂ Administration Y Express ID Context Category Class Name Express Name Reference ID  Ref Source . Expression
Z__# Customization v 3 1 TAG Support PipeaAttachment SupportID <??NXTD. PIPLIM=
X 2 TAG Support PipeaAttachment SupportMark <??PRV,PIPLIN>-H<??PRV.SupportlD>
SRS - 3 TAG Support SupportAssembly SupportlD <?7NXTD,PIPLIN=
Project Parameters 4 TAG Support SupportAssembly SupportMark <?7PRV.PIPLIN >-H<??PRV.5upportlD >
Grid System 5 BOM Support PipeaAttachment PipeAttachBOM [<??PRV PariType> <??PRY.CatalogTag
SR 6 BOM Support SupportDetal SupportDetailBOM [<??PRV. PariType> <??PRY.CatalogTag
7 BOM Support StructAttachment StructAttachBOM [<??PRV PariType> <??PRY.CatalogTag
Bty 8 BOM Support SteelFrame SteelFrameBOM [«??PRV.CatalogTag>] <??PRV.Descripti
Usage Group Editor 9 BOM General SupportCore BOMSuppho Support: <??PRV.SupportlD >
Ej PO— . 10 BOM General SupportCore BOMUNit Unit: <??PRV.Unit>
11 BOM General SupportCore BOMPipe Pipe: <??PRV.Fipeling >
[ Reporting Lt 12 BOM General SupportCore BOMEley Elevation: <??PRY.Elevation>
=] Reference Browser 3 13 BOM General SupportCore BOMIso Ref. Iso: <??PRV,IsolD>
14 BOM General SupportCore BOMDesing Design Temp: <??PRY.OperTemp>
15 BOM Tag SupportCore ProjectiMame <??P1V.Project.DGNStamp. ProjectMName:
16 BOM Tag SupportCore DrawingMumber <??P 1V Project. SupportDrawing, QutPref
17 BOM Tag SupportCore SupportMark <?7PRV. SupportMark >
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File File
Sets Tags Sets Tags
TitleBlock Approvals EngineeringDate ~ TitleBlock Approvals DesignActivity ~
ProjectName DrawingNLn"nBer
Revision Drawn
SheetNumber DrawnDate
SupportMarkc b Engineer 5
I Add... ||_ Remove _| |_ Add... Remove | Add... H Bemove l Add H Remove
L Rename... i_ELIJ)"CEﬂe..- i | Rename... | : Duplicate... : Edit.. :
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Note: Remember The Tag Set must be named TitleBlockApporvals for now.

For now we will change the name of the project to be populated in the drawing.

Note the Expression will tell you where to make this change. Expression: <??PJV.Project.DGNStamp.ProjectName>.
Navigate in the Dashboard to Settings > Project Parameters.

Expand Project > DGNStamp.

© N o O

Select ProjectName.

=

Category/Group Parameters
251 Administration o [~ Project
_ i -~ DGNstamp |
3 Customization ¥ .~ SupportDrawing Name Description Value
E_fl.r‘ Settings A I8} Eenrcrmet { ProjectName The offidial name of the project OpenPlant Support Engineering
odeling ProjectType The type of the projectin terms ...  Imperial
Project Parameters - Repository ProjectRevision The Project Revision 1.0
Grid System ProjectStatus The Project development Status Development
Seguence Manager
Expressions Manager
Usage Group Editor
B 4 Repository v

9. Change the Value to: OpenPlant Support Engineering.
10. In the Ribbon select Save.

!ﬁ

'k |
!&:f Main

| 2
=1 &F
Mew Category/Group  Mew Parameter Save Refresh

n

Note: The Save saves the changes to the Dashboard database.
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gat Category/Group
EE—I Administration v [EI-Project
=@ Customization ¥ : - SupportDrawing
rem—— [zl Environment
|57 Settings G [l Placement

Project Parameters

[zl-Modeling
[+ Repository
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A good habit to get into when making changes in the Dashboard is to refresh the ToolCabinet.

11. Click the Refresh icon in the ToolCabinet.
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ToolCabinet : Sample v 1 x

BR| Pipeata.. ~ & ] @ S ([ [FH
Support Drawing

B B o &
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Testing the Results

If you have followed everything correctly up to this point you should have good results. If not then more than likely you
have forgotten to do a Save in the Dashboard or a Refresh in the ToolCabinet.

1. Navigate to the Support Model.dgn file.
2. Select one of the supports that were created earlier.
3. Create a Drawing.

The results should look like this:

v z I i

LT Robmals

il
i ey THott Clorp 8 P20
7= Ep it [T

-
st el Lef tHerd Theead Aod 104 Fug 120
wnbuckls Forged | I, Fig 10

5 | d (Heldocd ] JH, Fag LD
5 [1 e Tens
Weldad Been itttachnent L K Fig. 28 B

2 I 3
Fppart
et it
e -0
N
g
@\-

OpenPlant Support Engineering
=

ACR-SIS--B81-OPM-H3

(- IE | |ﬁCR-SlS--B1-GFM-’13 Revdé dgn I
I 1 T
a | 3 fa 2 ] 1

Notice that the shapes are displayed. What we should have done is turned off the levels for the shapes. Note where the callout balloons
are located and the graphics are located in the Graphic Area. This will give you a feel how the program logic is setup. Notice that the BOM

grows from the Top Left so there is space to the right.
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Customizing the BOM & General Notes:

In this lesson we will customize the BOM and add some general notes. The BOM will be customized in the Dashboard
and the General Notes is just MicroStation text but may be a refresher on how to do this.

= General Notes: General notes are just MicroStation text. Many companies will put generic notes that will apply to all
supports and let the support designer append as needed. In the example there is a text style that will allow you
place text at 1/8 if you like.

= Modifying the BOM: We will make a change to the “Detail” area of the BOM. By default “Fig. 80” for example is in

brackets and at the front of the line. We will move this to the end of the line with a comma and remove the brackets.

Bill Of Materials Esme——memmme

No [Uty. |Detail / \l

| |(F1q.80 1 Heavy 3-Bolt Clamp 8 IN

! [F1g. 4 1 Weldless Eye Nut 1IN

! [F1g. 129 1 Right and Left-Hand Thread Rod 1IN
! [(F1g. 30 1 Turnbuckle (Forged) ! IN
!

!

!

[Fig. 11@ 1Eye Rod (Welded! | IN
[CC-A-71 7A-WBX1D
[F1g. 20 1 Welded Beam Attachment | IN

e e a1 I IS U N

1. Open the B-Border.dgn file.
2. Open the Project Dashboard.

3. Open the Settings > Expressions Manager.
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We will modify the /D 5, 6, & 7.

o
Eﬂ ST TEET Express ID Context Category Class Name Express Name
39 Customization w 1 TAG Support PipeAttachment SupportID
- 2 TAG Support PipeAttachment SupportMark.
Settings g
3 TAG Support SupportAssembly SupportID
Project Parameters 4 TAG Support SupportAssembly SupportMark.
Grid System 5 BOM Support PipeAttachment PipeAttachBOM
& BOM S i S tDetail S tDetailBOM
Seguence Manager | UPOaT DAL SOPORESIC
3 7 BOM Support StructAttachment StructAttachBOM
Expressions Manager I
3 BOM Support SteelFrame SteelFrameBOM
Seaue S Pl 9 BOM General SupportCore BOMSuppho

4. Inthe Expression column copy and paste the information in the brackets [ ] from the front of the line to the back.

. Expression C

<??NXTD.PIPLIN >
<??PRV.PIPLIN >-H<??PRV.5upportID >
<??NXTD.PIPLIN >
<??PRV.PIPLIN >-H<??PRV.5upportID >
[<??PRV.PartType> <??PRV.CatalogTag =] <??PRV.Description = <??PRV.Prim5ize = <??PRU.PrimSize >

[<??PRV.PartType> <??PRV.CatalogTag=] <??PRV.Description> <??PRV.PrimSize = <??PRLU.PrimSize =
[<??PRV.PartType> <??PRV.CatalogTag=] <??PRV.Description> <??PRV.PrimSize = <??PRLU.PrimSize =
[<??PRV.CatalogTag>] <??PRV.Description =

Support: <??PRV.SupportID>

Unit: <??PRV.Unit>

Pipe: <??PRV.Pipeline >

5. Delete the Brackets [ ] and add a comma.

The line should look like this:

6. Repeat for the next two lines.
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<7?PRV.Description= <??PRV.PrimSize > <??PRU.PrimSize >, <??PRV.PartType>= <??PRV.CatalogTag>
[<??PRV.PartType> <??PRV.CatalogTag=] <??PRV.Description> <??PRV.PrimSize = <??PRLU.PrimSize =
[<??PRV.PartType> <??PRV.CatalogTag=] <??PRV.Description> <??PRV.PrimSize = <??PRLU.PrimSize =

L T e PR,
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7. Next we will modify /D 8 and add some text to explain what this item is.

<??PRV,Description> <??PRV.PrimSize > <??PRU.PrimSize =,
<??PRV,Description> <??PRV.PrimSize > <??PRU.PrimSize =,
<??PRV.Description> <??PRV.PrimSize > <??PRLU.PrimSize =,
[<??PRV.CatalogTag>] <??PRV.Description=

Support: <??PRV.SupportID=

Unit: <??PRV.Unit>

8. Delete the two Brackets and replace the right bracket with a comma.
9. At the front of the line add the following text: Standard Detail:.
The line should look like this:

</PRV.Desaiption > <//PRV.Primsize> <//FHU.Frimsize>, <//PRV.Partlype> </
Standard Detail: <??PRV.CatalogTag=, <??PRV.Description =
Support: <??PRV.SupportID=

10. Click Save.

Note: To get around a bug you will have to close the Dashboard. In the ToolCabinet do a Refresh ToolCabinet. Exit OPSE and restart.
11. Open the Support Model.dgn file.
12. Test your changes by creating a support drawing.

13. If all has gone well this is what you should see:

Bill Of Materials

No |Oty. |Detail

Heavy 3-Bolt Clamp 8 IN; Fig. 8/

Weldless Euye Nut 1IN, Fig. 40

Right and Left-Hand Thread Rod 1IN, Fig. 129
Turnbuckle (Forged) 1 IN, Fig. 30

Eye Rod (Welded) 1IN, F1g. 110

Standard Detail: CC-A-7, /6-WeX1b

Welded Beam Attachment 1IN, Fig. 20

U 6o T I v [ R AV O N I B
— (= — | — | — | — | —
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Controlling the Levels

In OPSE the Level Name, Color, Style, and Weight are controlled by the Visual Manager in the Project Dashboard. In
this lesson we will make a few changes in the level names used.

1. Start OpenPlant Support Engineering.
2. Inthe File Open dialog, set the following:
User. OPSE_Samples
Project: Sample 1
File: Support Model.dgn
From the Support Modeler menu open the Project Dashboard.

4. Navigate to Customization > Visual Manager.

E’E‘I Administration

Yl sl Context Class ID C

| = Customization P 130 1000 E
I 2 1000 &

Modify ToolCabinet | 3 1000 B
Companent Builder i 430 20390 5

Visual Manager 53D 20390 5

53 1000 &
||/ Setmgs sl 73 1000 E

Locate Visual ID 16 and 17.

In Visual ID line 16 change the Level name to Support Frame.
In Visual ID line 17 change the Level name to Catalog Item.
Click Save.

Exit OPSE and restart.

= © © N o v

0. Place a Support Frame like a Cantilever.
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11. Check the Level name.
12. Place a Pipe Clamp.
13. Check the level.

Note: Refresh ToolCabinet does not work with the Visuals so a full restart of OPSE is required.
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