
Getting Started Guide – Print Organizer 

Print Organizer is a batch print utility designed for printing and reprinting sets of files, models, 

and Project Explorer links. The individual files and models within a print set file (.pset) are 

referred to as print definitions and can be hierarchically grouped in folders and sub-folders. 

Each print definition consists of a reference to a DGN/DWG file to be published, like a sheet 

model in a DGN/DWG file, along with properties, such as size, scale and form name that 

determine how the DGN/DWG file will be published within the print set.  Note: The fundamental 

architecture of print definitions and print styles comes from ProjectWise InterPlot, where they 

are called IPARM files and settings files respectively.  

The focus of Print Organizer is on printing multiple files, models, and Project Explorer links 
versus printing the active DGN/DWG file like the Print dialog.  Print Organizer was first delivered 
in MicroStation V8i and is the replacement for Batch plot. 

Since Print Organizer uses the same printer drivers as the Print dialog, you can create printed 
output either directly to the default system printer or to a file saved to disk for later submission to 
a printer. 

Using Print Organizer, you can set print definition properties per item. This allows you to specify 
different pen tables or use multiple workspaces in the same print set. For example, suppose you 
have print definitions in two separate folders: Electrical and Mechanical. You can specify a 
different pen table or workspace for the print definitions in each folder. 

The Print Organizer command is located in the File pull down menu in MicroStation.  Once Print 

Organizer is invoked, the following dialog displays: 

 



To create folders in the plot set, select File – Add Folder to Set.  To add print definitions, select 
File – Add Files to Set.  The Create Print Definitions dialog will display. 

 

Select Add to select the DGN/DWG files. 



 

Before adding the DGN/DWG files to the print set, you can define specific attributes about the 
print definitions by selecting Manually Specified Options.  The following dialog will display: 



 

In the Main tab, you can define the layout of the plot such as plot size, scale, rotation, and paper 

size among other settings.  Note the paper size list presented is a direct reflection of the printer 

selected under File – Printer Setup and can change based on the printer selection.  You can 

also attach the pen table to be applied to the print definitions.   

 

 

 

 



 

In the Advanced tab, you can define the MicroStation workspace/project, set the color mode, 

and define raster settings.   

In addition, you can set the print definition to automatically update from the design file.  A print 

definition does contain detailed information about the master models and views defined within a 

DGN/DWG file. This information, referred to as ―design state", provides context for print layout 

parameters stored in the print definition. If the model and/or view properties are changed in the 

DGN/DWG, and you wish for those changes to be reflected inside the print definition, then you 

must use the print definition's 'Update from design file' feature. 

Information stored in the design state includes: 

 List of master models 

 List of view groups 

 List of saved views 

 Active view group 

 Information about each numbered and saved view, including: 

o View origin and size 

o View flags, including level symbology, area fill, custom line styles on/off, etc 



o Maximum render mode, used in determining whether rasterized mode is 

enforced 

o Per-view level on/off flags 

o Information about the master model pointed to by the view, including: 

 2D/3D flag 

 Design/Drawing/Sheet model type 

 Model name 

 Global origin 

 Working units 

 Sheet definition parameters 

 

The 'Update print definition name' should be ignored when initially adding print definitions to the 

print set.  After the print definition exists, if you select ‗Update print definition name‘ in the 

Advanced tab of the print definition, the Name field gets updated to the current value of the 

Default Print Definition Name defined under the File menu. 

 



In the Fence tab, you can specify the area to be printed.  The first section allows you to create 

the plot areas using Models.  The pull down under ―Create Print Definitions from Models‖ has 

the following options: 

 

 Additional fence creation methods include: 

 Define from shape  

Opens the Define from shape dialog which is used to specify the plot area indirectly by 

describing shapes whose actual coordinates define the print area. 

 

 Define from cell  

Opens the Define from cell dialog which is used to specify the plot area indirectly by 

describing a cell whose actual coordinates define the print area. 

 

 Fit to master model  

The print area is automatically calculated to include every element in the master model. 

The fence points are displayed in the Fence points list box.  

 

 Fit to master model and all reference files  

The print area is automatically calculated to include every element in the master model 

and all references. The fence points are displayed in the Fence points list box.  

 

 Fit to element range  

Opens the Fit to element range dialog which is used to specify the plot area indirectly by 

describing a fence whose coordinates are based on the range of specified elements. 

The fence points are displayed in the Fence points list box.  

 

 Enter fence points  

Opens the Enter fence points dialog which is used to specify the fence points that define 

the print area. 
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The Display tab can be used to set print output options.  A check mark means the attribute will 

be turned on regardless of the DGN/DWG file setting.  A blue box means the attribute setting 

will be read from the DGN/DWG file.  An empty box indicates the attribute will be turned off 

regardless of the DGN/DWG file setting. 

Select OK to accept the manually specified options for the print definitions.  Then select OK to 

add the files to the print set.  A typical print set may look as follows: 

 

 

 



 

Print Styles 

Assigning the proper values to print definition properties is an essential part of creating a print 
set, therefore, Print Organizer provides several methods to assign print definition properties and 
each method is used in a different context. The most useful method is Print Styles. 

Print Styles allow you to define and reuse named collections of print definition properties that 
are stored in a DGN library. You can apply a print style when creating print definitions or you 
can reference them on demand.  

To create a print style, select Print Organizer's Tools > Define Print Styles menu item.  

In the Create Print Definitions dialog, select the magnifying glass icon to the left of the Print 
Style Name field.  The following dialog will display showing a list of available Print Styles: 



 

Once you choose the appropriate print style, select OK.  The print style will be listed as follows: 

 

As the print definitions are added to the print set, the selected print style will be used to define 
the properties of the print definitions in the print set.   



Print styles are stored in the DGN file.  In order to make the print styles available to all users, 
you should create the print styles in a dgnlib.  By defining MS_DGNLIBLIST to reference the 
dgnlib containing the print styles in the users workspace, all DGN/DWG files will have access to 
the pre defined print styles. 

To create a print style, open the .dgnlib that will contain the print styles.  Open Print Organizer, 
and create the print styles by selecting Tools > Define Print Styles.  The following dialog will 
appear: 

 

Select the first icon  to create a new print style. 



 

You can rename the print style by right clicking on the new print style.  Using the tabs to the 
right, define the specific settings desired for the print style.  Once you have made your 

modifications, save the print style by selecting the second icon . 

 

Apply the print style as discussed earlier when creating the print definitions. 



Print Organizer’s Single/Multi-edit Properties Dialog 
 

Single or multi-edit properties dialogs allow you to edit a group of print definition properties for 
one or more print definitions. To edit a single print definition, double-click the print definition to 
open the Properties dialog or right-click it and select Properties from the pop-up menu.  
 
When editing a single sheet, the Properties dialog displays the specific property settings for the 

selected sheet as below: 

 

 
 

To edit a group of print definition properties, select the print definitions from the Print Organizer 
dialog and select Edit > Properties.  

 

When editing the Properties for multiple sheets, the Modify Properties dialog is more generic 

and does not list specific sheet settings as below: 



 
 

Printing 

Once the .pset has been configured with the desired print definitions, you can print the sheets 

using the Print dialog by selecting File > Print from Print Organizer. 



 

On this dialog, select the pltcfg to be used.  Depending on the pltcfg, the options will change 

specific to the printer driver configuration file. 

Print Definition and Output File Names 

Print Organizer supports named expressions for print definition and output file names.  

Print Organizer uses MicroStation named expressions to generate print definition and output file 
names.  Named expressions are created using the product's Define Named Expression dialog 
and are stored in the configured DGN libraries. Once a named expression is defined, it is visible 
in the appropriate Print Organizer dialogs. 

Print definitions are created when you add files to Print Organizer and the print definition name 
expression is used to determine the print definition names. The print definition name expression 
can also be used to rename print definitions. If you are using Print Organizer to print a set of 
files to disk, you can use the output file name expression to generate the output file names. 

An expression is composed of a series of components, where a component may be a symbol, a 
number, a string, or an operator. The symbols available for use in expressions are published by 
various symbol providers, and are grouped by symbol sets such as System.String, 
System.Path, PrintSet, and PrintDefinition. You can generate an HTML report showing all 
available symbol sets and the symbols available in each by selecting Utilities > Report Symbols 
from the Named Expressions dialog. 

See the MicroStation Help for more information on named expressions. 



Plot Area by Shape 
 
When creating a print definition, you can define the plot area to search for a specific shape.   
 

 

In the Search section, turn off the master model or Reference files to limit the search for the 
boundary-defining shape. By default, Print Organizer searches each master model and all of its 
references to find the boundary-defining shape. You can restrict the search to specific 
references by typing their logical names (for example: ―Border*‖) or filenames (without drives or 
folders, for example, ―border.dgn‖) into the References list box.  

In the Shape properties section, you can restrict the search to specific levels by typing the level 
names into the Levels list box. As with references, level names can be regular expressions. The 
Colors (0–255), Weights (0–31), and Styles (0–7) fields limit the search to a specific color, 
weight, or style. Each field accepts single integer values, dash-separated ranges of integer 
values, and comma-separated lists of values and ranges. Example: 1, 2, 3, 5-7. 

The ―Create one print definition from first matching shape‖ specifies that the first matching 
shape be used to define the print area, and the ―Create one print definition for each matching 
shape‖ specifies that one print be created from each shape. The configuration variable 
MS_PLT_AUTOAREA_RESULT_LIMIT defines the maximum number of print definitions to be 

created when searching for multiple shapes or cells. The default limit is 500. 



Plotting Models 
 
There are several ways to add models as the print area when adding print definitions to a plot 
set.   
 
You can drag and drop the models directly from the Models dialog into Print Organizer.  Open 
the Print Organizer dialog.  Open the Models dialog.  In the Models dialog, select the models.  
Hold down the data button and drag the selected models to Print Organizer, releasing the button 
to drop the models.  The Create Print Definitions dialog opens. 

 
You can add models from Project Explorer by dragging and dropping models from Project 
Explorer into Print Organizer or you can right-click model in Project Explorer and select Print 
Organizer.  Both methods will open the Create Print Definitions dialog. 
 
When adding print definitions to Print Organizer using File > Add Files to Set, you can specify 
which models to use as the plot area by using a print style or manually specifying the model 
preference.  In the Fence tab, the Create Print Definitions from Models provides a choice of 
model preference: 
 

 

Note this option is visible only when the Print Definition Creation Options dialog or Define Print 
Styles dialog is selected. 

There are five model selection methods: Prefer sheet models, All models, All sheet models, All 
design models, and Listed models. The default model selection method is Prefer sheet models, 
which creates a print definition for each sheet model. If there are no sheet models present, a 
print definition is created for each design model. This behavior may, however, be overridden by 
specifying a different model selection method in a print style, on the Print Definition Creation 
Options dialog's Fence tab, or in Print Organizer's Preferences dialog. 

Print Configuration Variables 
 
The following MicroStation variables should be noted when using Print Organizer. 
 
MS_PLT_ENGINE_CMDLINE_ARGS 

Specifies custom command line arguments used by Print Organizer when invoking its 

background MicroStation process. If this variable is undefined and MS_CONFIG is defined, then 

the background process is invoked with the command line argument -wc"$(MS_CONFIG)" 



(MS_PLT_ENGINE_CMDLINE_ARGS).  It is common to make modifications to this variable 

when the font/line resource files do not plot properly when printing from Print Organizer.  

Typically this is because MicroStation is started with additional command line arguments that 

the worker MicroStation does not know about. 

MS_PLT_DEFAULT_PRINTDEF_NAME_EXPRESSION/ 
MS_PLT_DEFAULT_OUTPUT_FILENAME_EXPRESSION  

Print Organizer stores a default print definition name expression and a default output file name 
expression in each new print set file. You can change these default expressions using the 
Default Print Definition Name Expression and Output File Name Expression dialogs. Changes 
made to the default print definition name and output file name expressions only affect newly 
created print definitions and output file names; however, you can use the Update Print Definition 
Name button on the single- and multi-edit properties dialogs to update existing print definition 
names using the new expression. 

You can define configuration variables to override the software's default print definition name 
expression and the output file name expression. These configuration variables may contain 
either the name of an expression in a DGN library or an explicit expression string. It is important 
to note that these configuration variables do not override the default print definition name 
expression and output file name expression in existing print set files, they only affect new print 
set files. 

MS_PLT_DEFAULT_PRINTDEF_NAME_EXPRESSION – overrides the software's default print 

definition name expression. 

 

MS_PLT_DEFAULT_OUTPUT_FILENAME_EXPRESSION – overrides the software's default 

output file name expression 

 

MS_DGNLIBLIST  

List of DGN files which are used as resource for your current session.  The Print Styles should 

be defined in the dgnlib. 

 

MS_PRINTDEF_PATH 

This variable specifies the search path for saved MicroStation print  definition (.pset and .ini) 

files. 

 

Print Organizer > Edit > Preferences 

 
Some of the print settings have associated configuration variables. These configuration 
variables are honored and those defined override the corresponding preferences. Preferences 
for which an override is in effect are disabled in the Preferences dialog. 
 
Open design file in read-only mode 

If set, Print Organizer opens all design files in read-only mode to prevent any inadvertent 
modifications to the files.  This is controlled by the 
MS_PRINTORGANIZER_OPEN_DGN_READWRITE configuration variable. 



 

Models used when creating print definitions 

List box that lets you choose the models to print. 
 Prefer sheet models — a print definition is created for each sheet model. If there are no 

sheet models present, a print definition is created for each design model. 
 All sheet models — a print definition is created for each sheet model.  
 All design models — a print definition is created for each design model. 
 All models — a print definition is created for each model. 

 

 


