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WHAT’S A TAG?

A Tag is like a shopping list stuck on the front of your fridge. Your

shopping list (tag) identifies food (an attribute) that you place in

your fridge (an element). In geek speak a tag is a “non-graphical

element that is attached to an element”.

In CAD speak, a Tag called Door could identify the type, size, and

location etc of the door drawn in your drawing.

Tags are a good way of attaching sets of data to many elements

within a file e.g. you may have multiple doors in your file, but each

one may have unique characteristics that need to be identified.

These attributes can be extracted from the file in order to make a

door schedule.

Many people use Tags in the titleblock of the drawing frame. The

titleblock attributes (drawing number, revision, date etc) can then

be exported out of the file.

WORKFLOWS

It helps to think about your approach to creating and attaching

your Tag before you start – there can be several workflows

including;

1. Open drawing which contains the element on which to attach Tag

2. Create your Tag Set

3. Add Tag to element

4. Edit Tag

or

1. Create Tag Set

2. Export Tag to Tag Library

3. Open drawing containing element on which to attach Tag

4. Import Tag Set from library

5. Attach Tag to element

6. Edit Tag

or

1. Create Cell

2. Edit cell (open the .cel)

3. Attach Tag to cell

4. Place cell in drawing

5. Edit Tag in cell

And

6. Create Template

7. Generate Report

Tags can be part of Tag libraries or more often defined as part of a

cell. This allows editing to be controlled from one location only.
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CREATING A TAG SET

Go to the pull down menu: Element > Tags > Define. This is where

we first create our “group” of Tags, or Tag Set.

Click the Add button in the dialog. The Tag Set Name dialog opens.

We’ll make a Tag Set called Titleblock.

Now click the Add tool on the right hand side of the dialog to create

your tag list.

Here you define your first “attribute”. Let’s look at the Job number.

Create a Tag for each attribute you want to include. You will be

able to choose whether each Tag is visible or not when you attach

them.

The Tags will be created in the list in alphabetical order, though

when you attach the tag it will list them in the order you create

them.

Tag

Name is the name of your tag “Job No”. The maximum number of

characters is 32.

Prompt You may wish to “prompt” the person editing the tag with

instructions such as “Enter Job No”. This should be descriptive of

the tag and also indicate the tag data Type. The maximum number

of characters is 30. The default prompt is “Value”.

Type can be one of three; Character – text with a limit of 1024

characters; Integer (e.g. 1, 2, 3, 1000, 1001, etc), or Real (e.g.

1.2345). Do not change a tag's data type after having attached

any instances of the tag.

So far so good?

VariableThis toggle forces you to enter the tag data during the

Attach Tag process.

Variable on: the Default Tag Value “XXX” can change. The Attach

Tags dialog box opens when you use the Attach Tags tool for

keying in the value for the tag (unless Default is also ticked on –

see below).

By default Variable is on.
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So, so far we have given a default value which we want the user to

change when attaching the tag.

Variable off: The Default Tag Value “XXX” is used when you attach

the tag and it cannot be changed at the time of placement, unless

you edit the default value and apply it to subsequent instances of

the tag.

Default

If the Default toggle is on, the tag attaches automatically with the

default value. If the Default Tag Value is not set, the value for

character type tags will be NULL (that would be nothing, nada, nil,

blank) and 0 for the numeric types.

Confirm toggle

If the Confirm toggle is on it causes the Attach Tags dialog box to

open, for confirming the default tag value upon attachment of the

tag.

Display Tag toggle

The Display Tag toggle is on by default causing the tag to display

when you place it. You should turn the display off when associating

the tag with elements that won’t be shown, or for fast display.

So, all with Display Tag on:

Variable on + Default Tag Value set = input tag value on placement.

(Attach Tags dialog box).

Variable on + Default on + Confirm on + no Default Tag Value =

input tag value on placement (Attach Tags dialog box).

Variable on + Default on + Default Tag Value set = no change of

tag value on placement (straight placement, no dialog)

Variable off + Default Tag Value set = no change of tag on

placement. (Attach Tag dialog box but inability to edit the value

which is greyed out (well, actually it’s so white I can hardly see it).

Have a cup of tea.

Define all your tags for inclusion into your Tag Set.

EXPORTING YOUR TAG SET TO A TAG LIBRARY (OPTIONAL)

Now your tag is ready to attach to your drawing element. What you

may have done is defined your tag set in one drawing and now

want to place it in another. A Tag Set is only present in the

drawing you create it in – so order to get it out, we’ll place it in a

Tag Set Library, along with other Tags. This may be a way for the

CAD Manager to keep a library of all the tags used in a company, or

within a project.

In the Tag Sets dialog box go to File > Export > Create tag Library.

A tag library is appended .tbl. You can now File >Import > From Tag

Library to pick up the tag from any drawing.

Don’t forget – this only added the single tag you had highlighted.

Your need to File > Append to Tag Library... to add further tags

(arrgh!).

ATTACHING YOUR TAG TO AN ELEMENT

Check your active text settings as the placed tag will pick up these

for placement. This will save formatting later.

The Tag tools are located in the Drawing Task list. Type T to bring

up the tools at your cursor.
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Type in T1 to bring up the Attach Tags dialog box.

I have chosen a line on the A-Z900-G-NonPlt level to attach my tag

too. This line I have drawn at the corner of my titleblock.

When Association is ticked the tag must be attached to an element

in the file. Place the tag and the tag VALUE is displayed in the

dialog box for editing:

(Note: When Association is not ticked, the tag is placed directly in

the file and places in your file the tag NAME (not the Value). This

method is typically used for tags in a cell.)

You’ll notice that if you hover your cursor over the Value the

Prompt will display.
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Click OK, and then data click (left click) on your screen to accept

(or right click to reject) changes.

Your Values will now appear floating on your cursor ready for

placement. You will see the text has picked up your active text

settings.

Place the text – of course it won’t be formatted yet to fit your

titleblock yet.

FORMATTING YOUR TAG

Now move the text to the correct location in your file. If you have

Graphic group on, all the text will move as one element, if graphic

Group is off you can move each individual piece of text.

Format your text using the Change Text Attributes tool (A7).

You will find that if you double click on the text (how you would

usually edit the text) then the Edit Tags dialog box will appear. Here

you can edit the VALUES of the Tag and control whether it will be

displayed or not, but you cannot format any of the text properties.
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Note: There is an alternative method to creating a cell. The tag

above is attached to the element; my line at the corner of my

titleblock. However if I placed my tag without association I can

place it in my file without the need to attach it to an element. I will

then see the tag Names, rather than the Values, but in the same

way I move them to the correct location and then create the cell.

EDITING AND DELETING TAGS

Use the Edit tags tool (or double click the tag) to edit the tag

values or, as you have seen above, use the Change Text Attribute

tool to change the text appearance.

If you use the normal Delete tool with Graphic group on you will

delete the entire tag. If Graphic Group is off you will delete only the

value you choose within the tag. Deleting the element to which you

attached your tag will delete the entire tag.

Using the Delete Tag tool you should delete a value if Graphic Group

is off and the entire tag set if Graphic Group if on. There is a bug in

08090451 and above (noted in V8i 081107443) that deletes only

the individual value, regardless of Graphic Group being on or off.

Selecting the element to which the tag is attached deletes the Tag

Set but not the element.

GENERATING TAG REPORTS

If we now want to export the tag data into a report then we go to

Element>Tags>Generate Templates.

You’ll see the dialog has picked up my Tag Set from my drawing

already.
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To generate a template file (containing the settings on which to

report), you must first select, in turn, each tag on which you want

to report, and add it to the list of report columns. If you scroll down

your tag list you will also find extra reporting settings like $length

and $area.

The Report File Name (12 letters max) sets the name of the report

file that is generated when the template file is used. When the

template file is saved, this report filename is also saved with the

selected tag set in the design file. Make sure you hit Enter after

filling the Report File Name field or click somewhere else afterwards

otherwise MicroStation does not understand that you have entered

a name.

Make sure that you choose Report On > Tagged Elements and

Format > Text.

When you go to File>Save you are saving a .tmp file. I’ve called

mine titleblock.tmp.

Report On>Tagged Elements: If on, the generated template

specifies that only elements that have tags attached will be

reported. (This is just a setting, don’t expect the report to be

generated yet).

Report On>All Elements: If on, the generated template specifies

that elements will be reported regardless of whether they have tags

attached.

(Remember that you don’t have to attach a tag to an element with

association off.)

Format>Text: Generates the report in a text (ASCII) format.

Format>XML: Generates the report in a XML format.

Now close this dialog box. Don’t expect the report to be generated

yet – all you have done is create the template.

Now to go Element > Tags > GenerateReports. In the Generate

Reports dialog that appears you need to go and pick up your saved

templates (.tmp) file and either double-click the template file or

highlight it then click Add. You can use more than one template at

a time. This means you can generate several reports at the same

time. Click Done.

“Done Generating Reports” will be displayed in the Message Centre.

You will have created a .rpt file.

(Note: you may have to speak to your CAD department about

where your Tag Reports are saved to, or check these

configurations: MS_TAGOUTPUT, MS_TAGREPORTS,

MS_TAGTEMPLATES. Refer to final section of this PDF.)

TO IMPORT YOUR TAG REPORT INTO EXCEL

1. Open Excel

2. Choose Open All files *.*

3. Pick the .rpt (or pick ALL the .rpt’s)

Excel will then lead you through the Text Import Wizard. Pick

Delimited file and click Next.
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Tick Comma and set the Text qualifier to {none}. You will see in the

Data preview that each tag is now in its own cell. Hit Next and

Finish.

CONFIGURATIONS

The MS_TAGOUTPUT folder must already exist. It will not be

created and no error message will be displayed.

MS_TAGOUTPUT General tag data

MS_TAGTEMPLATES Directory containing tag data manager report

templates.

MS_TAGREPORTS Output directory for tag data manager reports

Make them all go to the same folder for ease of use.

If your report cannot be generated then MicroStation will not inform

you and will still say “Done Generating Reports”.
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