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1  REFERENCE DOCUMENTS 
[1] SAN03390 Data Type Names used in eB Layouts 
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2  WHAT THE LAYOUT EDITOR IS FOR 
The layout editor allows you to customise the display and editing screens that eB Web 
applications display.  The editor allows you to control the naming, ordering, and the 
types of controls used to display and edit the properties and relationships of objects in 
your eB system. 
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3  STARTING THE LAYOUT EDITOR 
In order to use the layout editor, you must have a valid username and password for 
your eB system.  In addition you must have the Classes > Class permission to save 
changes to the layouts. 

To start the editor: 

• Select the eB Layout Editor from the Spescom menu. 

 

Figure 1 - Log on Screen 

• A log on screen will appear, enter the User name and password.  In order to 
pick a community, you must first enter the name of the server you wish to 
connect to. When the community dialog enables itself you can use it to pick a 
community. The user name, server, and community that you enter will be 
remembered the next time that you log in.  

• Click on OK to log into the application. 

 



Eb Layout Editor User Guide
 

SAN03810 Rev 0.2 Restricted Page 4
 

4  THE LAYOUT EDITOR SCREEN 

 

Figure 2 - The layout editor screen 
The layout editor screen is divided into four sections: The menu bar, the tool bar, the 
class tree, and the work pane.  When you start the editor, the Change Requests object 
type will be selected and the class tree export display will be shown. 

4.1 THE CLASS TREE 
You navigate through the application using the 
class tree. This tree expands from the object type 
down through all of the classes that are defined 
for that type. At each level are two links: “Edit” and 
“View”.   These links allow you to reach the 
layouts that are defined for the class or object 
type. If you select one, the work pane will change 
to show the layout display. Selecting a class name 
or the name of an object type (for example “eB 
CA” or “Documents”) will show the class tree 
export display in the work pane. 

4.1.1 The class tree and inheritance 
When you define a layout for a class or object type, it will take effect for all of the 
classes that appear in the tree beneath it unless a different layout is specified at the 
lower level.  Classes which have custom layouts are shown in purple in the tree (as 
shown in the image above).  This allows you to see which classes have their own 
layouts and enables you to determine which layout will affect a particular class.  For 
example in the screenshot above, there is a default layout specified for Edit and View 
of the Document type, this will be inherited by all documents that are created, including 
the “Trend Codes”, “File Container”, and “Structure” classes.  However two sub classes 
have their own view layouts defined: “Supporting Documents” and “Questionnaires”. 
These classes and all of their sub classes will use their own layouts for displaying an 
object. 
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4.1.2 Adding a customised layout 
When you click on a layout name (either View or Edit) that is not shown in purple, you 
will receive the following prompt:  

 

Figure 3 - Undefined layout prompt 
This is not an error. Rather it is telling you that what you clicked on has no custom 
layout yet.  If you want to load the parent layout (this is recommended) click Yes. If you 
want to start with a blank layout and import properties and relationships from 
elsewhere, click “No”.  Once you have chosen a response, the layout display will be 
shown for the class, either pre-populated with the default layout, or devoid of content. 

When you add a customised layout, it is not saved to the database until you use either 
the File -> Save Menu option, or click on the save button. An asterisk will appear in the 
titlebar of the application when there is unsaved data. 

4.1.3 Editing a customised layout 
When you want to make changes to an existing customised layout, simply click on it’s 
link in the class tree and use the layout display to make the changes that you want. 
You can make any changes you want, but to make them permanent you must use 
either the File -> Save Menu option, or click on the Save button. An asterisk will appear 
in the titlebar of the application when there is unsaved data. 

4.1.4 Removing a customised layout 
To remove a custom layout for a class and its children, select the type of layout that 
you wish to remove (edit or view) and either: 

• Press “Delete” on your keyboard. 

• Select the “Delete” tool bar button( ). 

• Use the Edit > Remove menu option. 

4.1.5 Abandoning changes 
You can abandon changes you have made at any time by clicking on a different link in 
the class tree. For example if you have made edits to a view layout and do not wish to 
keep them (or you wish to revert back to the current layout and try again) simply click 
on the edit link. 

When you click on another link in the tree and you have unsaved data, you will be 
prompted to return to the link you were on: 

 

Figure 4 - Unsaved Changes Prompt 
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Clicking on “Yes” will cause any changes made to be abandoned, and the link that you 
highlighted will be selected. Click “No” to return to your edits. 

4.2 THE WORK PANE 

4.2.1 The Layout Display – an overview 
The layout display is shown when you click on an “Edit” or “View” link in the class tree. 

 

Figure 5 - The Layout Display 
The display shows four “tabs” which allow you to control different aspects of the layout: 

• Sections - Which allow you to group properties and relationships in categories 
for display. 

• Properties – The properties of the eB object. 

• Relationships – Relationships between the eB object and other objects. 

• Layout – General settings for the layout. 

By default, the Sections tab will be selected. 

4.2.2 The Sections Tab 
The section tab shows you the sections which are currently included in the layout. It 
also allows you to manipulate them as well as which properties and relationships are 
displayed within them. 

Each section that you define contains a set of properties and relationships which were 
defined in the other layout tabs. In the web application, sections appear as a set of 
links in the task area of the object display.  Clicking a section link shows the properties 
and relationships that were associated with the section in the section tab. 
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Figure 6 - Sections and the links they create 
Sections allow you to group the properties and relationships of an object in a 
meaningful way, for example in the case of Documents, it is used to organise the 
disparate types of relationships into convenient groups.  Sections can also be placed 
under permissions control by relating them to a permission controlled attribute.  This 
allows you to permission control properties and relationships that are not normally 
affected by permissions (for example Title, or Remarks) without having to deny users 
permission to the document as a whole. 

It is necessary to have at least one section, if you try to remove all sections, the display 
system will create a section with all of the properties and relationships of the object 
visible.  It is not however necessary to include all of the properties or relationships, if 
you have some that are of no interest to your users, or are for data collection only and 
are not intended to be displayed or manipulated, you do not have to include them in 
any section. In this way these unselected properties and relationships are invisible to 
the users of your eB system. 

Remember that any changes you make to the sections in a layout is not made 
permanent until you click on the save button. 

4.2.2.1 Creating a section 

To create a new section select the at the top of the sections frame.  
The right hand frame will contain the following fields: 

Name The section name, e.g. Initiator 

Description Explanation of what the section comprises 

Determine Visibility 
Based On Attribute 

If checked, the section’s visibility will depend on 
whether the user has view permissions on the 
attribute selected. 

Synchronize Attributes 
with an attribute group 

If you set up attribute groups, you can use this option 
to synchronise the properties selected in the section 
with the attributes in the selected group. 

Once you have filled in the name and description you can click on the Add Button, this 
will insert the new group. 
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Figure 7 - Editing a Section 

4.2.2.2 Editing a section 
To change the details of a section, simply select its name in the tree and change the 
properties that you want to change. The section will be changed as you enter the new 
details. 

4.2.2.3 Deleting a section 
To delete a section, select the section name in the tree and either: 

1. Click on the Delete button in the Section details.( ) 

2. Press “Delete” key on the keyboard. 

3. Select the “Delete” tool bar button( ). 

4. Use the Edit > Remove menu option. 

4.2.2.4 Controlling section visibility 
You can control whether or not sections are visible to the user by using the “Determine 
visibility based on attribute” checkbox in the Section details.  When checked, the user 
will only be presented with a section if they have view permission on the attribute 
named in the drop down list. For example, if the option is checked and the attribute 
selected has view permission for only the “Supervisors” group, users who are not 
members of that group will not see the section in the display of the object.  This feature 
is powerfully used to control access to aspects of the object that are not directly 
permission controlled in other ways (for example title and code fields).  Clearing the 
check box removes the permission restriction on the section. 

4.2.2.5 Synchronising Attribute groups 
Sections can be used to represent attribute groups, to make this easier, select the 
attribute group that you want the section to represent and click on the arrow button to 
the left of the drop down list. 
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4.2.2.6 Reordering Sections 
You can also change the order that sections appear in by clicking one and dragging it 
to the location that you want it to appear. Note that sections cannot be dragged into 
other sections. 

 

Figure 8 - Choosing properties 

4.2.2.7 Selecting Properties and Relationships 
Expanding the Properties or Relationships folders will display a list of the names of the 
information that the user will be able to see about the object. On the right of the tree a 
complete list of all of the properties or relationships will be shown, the ones that are 
selected are marked to make them easier to detect.  In the example above (Figure 8 - 
Choosing properties) the first selected property from the Properties folder is “Brief 
Description *” which you can also see has a mark next to it in the properties list. 

To add a property or relationship to a folder you can either mark it by clicking on the 
empty box, or drag its name onto the list in the position that you want it to appear. If 
you add a name by clicking on it, the name will automatically appear at the bottom of 
the list.  To re-order the names, drag them using the mouse pointer. 

You can remove a property or relationship in a similar way, by clearing the mark next to 
its name in the list. Or by selecting it in the tree and: 

• Pressing the delete key on the keyboard 

• Selecting “Remove” from the Edit menu 

• Clicking on the Delete button on the toolbar 
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4.2.2.8 The <Attributes> property 
The <Attributes> property is a special property that tells the layout system to include all 
of the available attribute properties.  You can use it to avoid having to manually include 
all of the properties for a class, and in cases where objects have properties associated 
with them that are not associated with the class.  If you want to include single attribute 
properties in the section, simply select them and clear the selection of the <Attributes> 
property. 

Note - It is an error to include the attributes property and any other individual attribute 
in the same section.  The error “Multiple controls with the id name were found on the 
page” will occur when an object is displayed to the user. 

 

Figure 9 - Relationship names 

4.2.2.9 Re-ordering Names 
When you place a name in a section list, it might not be in the right order with the other 
names. For example in the image above (Figure 9 - Relationship names) the 
relationship “Related Condition Reports” is between “Affected System” and “CAP 
Templates”. To re-order the names you can either drag and drop them within the list, or 
click on the sort button.  Dragging and dropping will allow you to order the names in the 
most appropriate way for your users (for example bringing critical information to the 
top), while the sort button will attempt to sort the names alphabetically. 

Note – In eB v14.3.2 Sort can only be applied to properties. 
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4.2.3 The Properties Tab 

 

Figure 10 - The properties tab 
Properties are the metadata associated with the eB object that the layout is displaying 
or editing.  You can select and configure the properties that the layout contains, and 
control which ones appear to the user.  The properties tab allows you to configure the 
Name, the description, the data type, and whether or not a property must be completed 
at edit type. To control whether a property actually appears in the output use the 
Sections tab. The table shown in the Properties tab is a list of all of the available 
properties for the layout, refer to “Figure 11 - Columns in the property display” for the 
meaning of each column. 

Name Purpose 

Property The short name of the property, to be used to represent 
the property in lists and tables. 

Required Indicates whether the field is a required to be completed 
when the object is edited. 

Description A longer description of the property, typically used as a 
tool tip or as explanatory text for the property. 

Data Type A short code indicating the type of data that is stored in 
the property (eg Date, String) Appendix A – Data Types 
for Columns and Properties contains more details about 
this value. 

Type The type of the property.  

Figure 11 - Columns in the property display 
There are three types of property: Intrinsic, Attribute, and Custom.  

• Intrinsic properties are those properties that are defined by the eB system for 
the object type. For example on an Event, there are the intrinsic properties: 
Name, Code, Start Date (and others). Intrinsic properties are aspects of the eB 
system and cannot be removed, but are available to be renamed.   
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• Attribute properties are the attributes (formerly known as the Characteristics) of 
the object type that were associated with the object class when the eB system 
was configured.  

• Finally there are Custom Properties, which are defined by applications running 
on the system and which represent calculated or advanced properties which 
may be stored in different ways to the regular attribute properties. 

The editor allows the following actions on each type of property: 

Action Intrinsic Attribute Custom 

Add No No1 Yes 

Delete No No1 Yes 

Rename / edit description Yes Yes Yes 

Make required Yes Yes Yes 

Make into a link Yes Yes Yes 

Choose data type Yes Yes Yes 

Figure 12 - Features and property types 

4.2.3.1 The <Attributes> property 
The <Attributes> property is a special property that tells the layout system to include all 
of the available attribute properties.  You can use it to avoid having to manually include 
all of the properties for a class, and in cases where objects have properties associated 
with them that are not associated with the class.   

Note - It is pointless to edit or rename the <Attributes> property as the name itself is 
not displayed - rather it is used as a placeholder in the Sections tab. 

4.2.3.2 Editing a property 
There are two ways to edit a property - if you want to 
quickly change one of the details shown in the 
properties tab, click once on it to highlight the row that 
contains it. Pause for a second and click again.  

The value that you clicked on the second time will 
become editable. You can now change it, either by changing the text (as shown) or by 
using the drop down list that appears.  When you have finished, either press the return 
key on your keyboard or click on another row in the property screen. 

The second way to edit the details of a property is to use the Property Editor screen. To 
activate the property editor double click (two clicks in quick succession) on the row in 
the table that you want to edit. Or highlight the row to edit and use the Edit > Properties 
menu action to bring up the editor. 

                                                 
1 Attribute properties are automatically synchronised with the class when the layout is loaded. 
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4.2.4 The Relationships Tab 

 

Figure 13 - The relationships tab 
The relationships tab contains definitions of how to display the relationships between 
an object and other objects in the eB system.  The display is split in two, with a table of 
the available relationships at the top, and a table of the columns displayed in the 
currently selected relationship at the bottom.  The bottom table always reflects the 
selected relationship in the top table. 

Name Purpose 

Relationship The short name of the relationship, used in lists when 
selecting relationships and shown as the title of the 
relationship when it is displayed to the user. 

Titles Only Determines whether the relationship will initially be 
displayed collapsed, so that only its title is visible. 

Required This field is not used in the current release. 

Description The longer description of the relationship which is used 
as descriptive text for the relationship, and as a tool tip 
where appropriate. 

Data Type A short code indicating the type of data that is stored in 
the relationship (for example Documents, Notes, Trends) 

Figure 14 - The Columns of the Relationship table 
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Name Purpose 

Title The short name of the Column, shown to the user at the 
head of the column when the relationship data is displayed. 

Hidden Determines whether this column is displayed to the user 

Required This field is not used in the current release. 

Description A longer description of the column, which is used for 
informative displays such as tool tips. 

Data Type A short code indicating the type of data that is stored in the 
column (eg Date, String) Appendix A – Data Types for 
Columns and Properties contains more details about this 
value. 

Figure 15 - The Columns of the Relationship Columns table 

4.2.4.1 Editing a relationship 
There are two ways to edit a property - if you want to 
quickly change one of the details shown in the 
properties tab, click once on it to highlight the row that 
contains it. Pause for a second and click again.  

The value that you clicked on the second time will 
become editable. You can now change it, either by changing the text (as shown) or by 
using the drop down list that appears.  When you have finished, either press the return 
key on your keyboard or click on another row in the property screen. 

The second way to edit the details of a property is to use the Property Editor screen. To 
activate the property editor double click (two clicks in quick succession) on the row in 
the table that you want to edit. Or highlight the row to edit and use the Edit > Properties 
menu action to bring up the editor. 

4.2.5 The Layout Tab 
The layout tab contains extra configuration information for the layout which is not 
specified in the other three tabs. 

 

Figure 16 - The Layout Tab 
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The tab is divided into two sections, the first contains configuration information for the 
layout engine, while the second defines the preferred title of the page which the layout 
generates. 

4.2.5.1 Configuring the Layout Engine 
There are two properties that you can specify for the program that generates the 
display or edit screen from a layout: The style of the properties layout and the style of 
the relationships layout.  It is recommended that you leave these values set to 
“Table1Column” and “Collapsible” respectively. Other layout types have not been 
extensively tested and may produce unexpected results. 

4.2.5.2 Choosing the object title 
Edit and Display screens can read their titles from the layout. The title is generated 
using the template specified in the edit field, and may contain your own text as well as 
values from the properties of the object that the layout is applied to. 

 

Figure 17 - Example Title for a Person 
In the example above, a person’s title is being specified.  The title will consist of the 
person object’s identifying code, followed by their surname and initials, for example: 

1234 – Clark, G 
When the title is generated, the layout will convert all of the values that appear in the 
braces (${}) into the values of the properties with the internal id specified within the 
brace (e.g. the values of the code, surname and initials properties in the example 
above).  To make it easier to create a title without having to look up the internal id of 
each property in The Property Editor, use the drop down list on the right of the arrow 
button, this list contains the human readable names of each of the properties in the 
layout. Once you have selected the property that you want, click on the arrow button to 
add it to the title. 

4.2.6 The Class Tree Export Display 

 

Figure 18 - The class tree export display 
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The class tree export display provides quick access to the ability to import and export 
the layouts associated to an object type or class, and all of it’s child classes.   

4.2.6.1 Exporting a layout structure 
The tree export option creates a .LayoutStructure file which contains all of the display 
and edit layouts for all of the classes below the item selected in the tree. In the 
example above, the layout structure would include the Edit and View layouts for “C100 
– Incident Reports” as well as those for “C001 – Condition Report”, and “C002 – 
Benchmarking”, but not “C200 – Corrective Action” or “L100 – Legacy Incident Forms”.  
To include those layouts, the user would have to select the “CA – eB CA” class and 
perform the export from there. 

When you click on the export button you will be prompted with a standard save dialog, 
pick a location to put the file, and click “Save”.  The file will be created and a notification 
will be displayed indicating how many classes have been written to the file. 

This feature can also be invoked by selecting a class or object type and using the File 
> Export menu option. 

4.2.6.2 Importing a layout structure 
Similarly Importing a class tree will overwrite the layouts at the level selected and at 
any level below it (providing that the LayoutStructure file imported contains layouts for 
those classes). Classes are matched to layouts stored in the LayoutStructure using 
their class code, this allows structures to be transferred between communities provided 
that the class codes in both communities are the same. 

Note - Layouts imported from a LayoutStructure file are automatically saved into the 
database with no prompting. When the process is complete, the number of layouts 
imported is displayed.  If you wish to import data with prompting, consider using the 
Edit > Merge Updated Layout menu option. 

When you click on the import button a standard file load dialog will appear which will 
allow you to select the LayoutStructure file for import. Locate the file you wish to import 
and click “Open”, the file will be imported and a notification will be displayed indicating 
how many layouts were added from the file 

This feature can also be invoked by selecting a class or object type and using the File 
> Import menu option. 

4.3 THE MENU BAR 
The menu bar provides access to most of the features of the editor. Actions that you 
see listed in a menu are often context-sensitive – that is the exact action that occurs 
when you select one depends on the type of object that you have selected in the class 
tree or work pane. The manual will list each of the possible actions that a menu option 
can activate, and give alternative ways to get to it. 

4.3.1 The File Menu 

4.3.1.1 New > Custom Property 
Custom Properties are used to create user specific fields that will be used to display or 
allow data entry for a property of an eB object. Custom fields are used when an 
application (such as Corrective Action) have property display needs that are not met by 
intrinsic or attribute properties of the object. 

When you select this option the “Custom Property Editor” will appear. This is another 
name for the Property Editor. 
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4.3.1.2 New > Responsibility Property 

 

Figure 19 - The Add Responsibility Property Dialog 
The New Responsibility Property dialog is a convenient way to create custom 
properties that allow the user to display and edit specific responsibilities for the eB 
object. The dialog creates a new custom property and configures it correctly for the 
responsibility that you select.  If you select the “Organisation only” box, the user will not 
be prompted to enter a person for the responsibility when they are editing. 

The property created is of the eBOrgResponsibility:<responsibility name> 

The eB Organisation Responsibility data type is a special type that allows an 
organisation responsibility relationship to be “promoted” to a property. This is the type 
of property that is created when you use the New > Responsibility Property menu 
option and select the “Organisation only” box. The value after the colon in the data type 
name is the name of the responsibility that the property relates to. 

eBOrgResponsibility responsibilities differs from eBResponsibility in that when editing, 
the user will only be allowed to specify an organisation. 

eBResponsibility:<responsibility name> data type. 

4.3.1.3 New > Custom Relationship 
This option provides you with the ability to make an empty relationship which is 
intended to be used by an external plug-in.  Custom relationships have their 
appearance and features dictated by the plug-in that renders them, for this reason they 
have no columns and little information that can be configured.   

Custom relationships are an advanced feature and are not recommended for general 
usage. 

4.3.1.4 New > Empty Layout 
This option will allow you to create a new layout file, which you can populate by 
copying relationships and columns from other layouts using the Edit > Copy from 
Layout option.  

This is an advanced feature and is not recommended for general usage. 

4.3.1.5 Save 
Selecting this option will save the current layout to the eB Database, it is identical in 
function to the Save toolbar button ( ), and can also be activated by pressing Ctrl+S. 

4.3.1.6 Import 
This option will import a layout file from your computer to overwrite the current selected 
layout.   

If you have a layout type (Edit or View) selected, a single layout file of type .Layout or 
.xml will be imported into the editor. It must be saved to become effective.   
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If you have a class or object type selected, a layout structure file of type 
.LayoutStructure will be imported. The class structure below the level that you select is 
searched, and layouts that are found in the LayoutStructure file are loaded into the eB 
database. See “Importing a layout structure” for more information about importing 
layout structures. 

If you have made changes to your current layout you will be prompted to save or 
abandon them before you can select a file. 

4.3.1.7 Export 
This option will export a layout file to your computer’s disk.   

If you have a layout type (Edit or View) selected, a single layout file of type .Layout or 
.xml will be created. This file can be imported into any community at any level beneath 
the same object type. For example you could export a document class layout for 
display from one system and import it into a completely different document class in 
another system.  

Note - .Layout files only contain a single edit or view layout. If you have defined both 
edit and view you will need to export at the class level in the tree and save as a Layout 
Structure. 

If you have a class or object type selected, a layout structure file of type 
.LayoutStructure will be created. The class structure below the level that you select is 
searched, and all customised layouts that are found beneath it are added to the file. 
This includes all of the edit and view layouts. For more information see “Exporting a 
layout structure”. 

4.3.1.8 Exit 
Exit the layout editor. If you have made changes to your current layout you will be 
prompted to save or abandon them before the application will exit. 

4.3.2 The Edit Menu 

4.3.2.1 Copy from Layout 
The “Copy from layout” option allows you to import properties and relationships that 
were defined in another layout into the current one. The layouts available for copying 
are those that are already saved in your eB database. If you wish to import a property 
or relationship from a layout file, use the Edit > Merge Updated Layout menu option. 

This option is equivalent to clicking the “Copy from Layout” tool bar button and invokes 
The Copy From Layout Dialog. 

4.3.2.2 Remove 
The remove option deletes the selected object. You can use it to delete 

• Custom Layouts on classes and object types 

• Sections 

• Custom and attribute properties 

• Custom relationships 

It is equivalent to the Delete button on the toolbar, and can also be triggered with the 
Delete key on your keyboard. 
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4.3.2.3 Properties 
The Properties option can be used to invoke an editor when certain types of information are 
selected. 

• In the properties tab, when a property is selected it invokes The Property Editor. 

• In the Relationships tab, when a relationship is selected it invokes The 
Relationship Editor. 

• In the Relationships tab, when a column is selected it invokes The Relationship 
Column Editor. 

4.3.2.4 Merge Updated Layout 
The “Merge Updated Layout” option allows you to import properties and relationships 
that were defined in a layout file into the current one. If you wish to import a property or 
relationship from another layout in your eB system, use the Edit > Copy from Layout 
menu option. 

When you select this option The Merge Layouts dialog is displayed. 

4.3.3 Window Menu Option 

4.3.3.1 Log Window… 
Provides a log of the activities performed in the layout for the current session.  This log 
is not saved, but can be copied and pasted into a text editor like notepad. 

4.3.4 Help Menu 

4.3.4.1 About 
This option provides information about the current version of the layout editor, 
Spescom Support may ask you for the version of the editor you are using, this screen 
will provide that information. 

4.4 THE TOOL BAR 
The tool bar provides quick access to some useful actions. The actions that you see 
listed here are often context-sensitive – that is, the exact action that occurs when you 
select a button depends on the type of object that you have selected in the class tree or 
work pane. The manual will list each of the possible actions that a toolbar button can 
activate, and give alternative ways to get to it. 

4.4.1 Save ( ) 
This button saves the current layout to the eB database. It is identical in function to the 
File > Save menu option, and can also be activated by pressing Ctrl+S. 

4.4.2 Copy From Layout ( ) 
The “Copy from layout” option allows you to import properties and relationships that 
were defined in another layout into the current one. The layouts available for copying 
are those that are already saved in your eB database. If you wish to import a property 
or relationship from a layout file, use the Edit > Merge Updated Layout menu option. 

This option is equivalent to clicking the Edit > Copy from Layout menu option and 
invokes The Copy From Layout Dialog. 
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4.4.3 Delete ( ) 
The delete button deletes the selected object. You can use it to delete 

• Custom Layouts on classes and object types 

• Sections 

• Properties and Relationship names in a section 

• Custom and attribute properties 

• Custom relationships 

It is equivalent to the Remove menu option, and can also be triggered with the Delete 
key on your keyboard. 
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5  EDITORS AND DIALOGS 

5.1 THE PROPERTY EDITOR 

 
The property editor is used to edit the details of a property within the layout, it can be 
invoked in the following ways: 

• Double Click on a property in The Properties Tab of the layout screen. 

• Select a property and choose the Edit > Properties menu option. 

• Select the File > New > Custom Property menu option (the dialog is then titled 
“Custom Property”). 

The editor dialog contains six fields: 

Name Purpose 

Display Name The short name of the property, to be used to represent 
the property in lists and tables. 

Description Indicates whether the field is a required to be completed 
or not. 

Data Type A short code indicating the type of data that is stored in 
the property (eg Date, String) Appendix A – Data Types 
for Columns and Properties contains more details about 
this value. 

Internal ID The internal name of the property. (see below) 

Link ID 
Column 

This field allows the property to be displayed as a link to 
another object. (see below) 

Required Indicates whether the field is a required to be completed 
when the object is edited. 
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a. Custom Properties are used to create user specific fields that will be used to 
display or allow data entry for a field in eB for that object. 

b. The Display Name is what will appear on the screen in the web interface. 

c. The Description contains the tool tip.   

d. The data type controls used for each property are generic eB controls. 

e. Application specific data type controls may have been created however these will 
not appear in the drop down of possible eB data types. 

f. The Internal ID refers to the eB field name, i.e. the column name or attribute 
name in the database. 

g. Link ID Column –  

h. Select the Required check box to make this a required field for data capture in 
the layout.  This required check box is NOT related to the Mandatory check box 
for attributes. 

i. A required field will appear in RED typeface and will contain a yellow warning 
icon: 

 

j. Once you have created the new property, remember to go to the section and 
select it to display in the edit and/or view mode. 
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5.2 THE RELATIONSHIP EDITOR 

 

a. When selecting one of the relationships, the columns that are available as part of 
this relationship are displayed in the window below. 

Title Column name 

Hidden Whether this column is viewable or not in the web 
interface 

Required This value is not used in eB 14.3.2 

Description Tool tip 

 

b. Selecting the column name allows the user to modify the display name for the 
column and determine whether the column is visible or not. 

 

c. It is recommended that the user does not modify the Data Type, Link ID Column 
and Element as this may cause an error with the control. 
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5.3 THE RELATIONSHIP COLUMN EDITOR 

5.4 THE COPY FROM LAYOUT DIALOG 

 
Copy a property or relationship from another layout to the current selected layout.   

 

5.5 THE MERGE LAYOUTS DIALOG 
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6  APPENDIX A – DATA TYPES FOR COLUMNS AND 
PROPERTIES 
Layout properties and relationship columns have a field named Data Type which 
defines the type of data that they display.  This information is used when the layout is 
converted into a display to determine what controls are used to display or edit the data. 

For some fields there is more than one possible data type, which you choose depends 
on what specific meaning the field has in your system.  For example, a date field can 
be an xs:Date, if the value can be any date, an eB:futureDateTime if the date must be 
today or in the future, or an eB:historicDateTime if the date must be today or in the 
past. When you edit a column or property in the layout editor the Data Type field is 
shown as a drop down list from which you can choose a pre-defined type, if you do not 
see the data type that you need you are free to enter one manually. 

6.1 DATES 
These types apply to date properties and columns. If you define a Date attribute in your 
class and use the <Attributes> element to include it, the system will automatically 
assign it the data type xs:Date. 

6.1.1 eB:futureDateTime 
This data type defines a date that is 
either today or any date in the future. 
During editing, the display will not allow 
a date earlier than today to be 
selected. 

 

6.1.2 eB:historicDateTime 
This data type defines a date that is 
either today or any date in the past. 
During editing, the display will not allow 
a date later than today to be selected. 

 

6.1.3 xs:date 
This data type describes a date that is at any point in the future or past 

6.1.4 xs:dateTime 
In 14.3.2 this has the same effect as xs:date. 

In 14.4 this data type is similar to xs:date, but when the object is displayed (not edited), 
the time is also shown. 

6.2 TEXT VALUES 

6.2.1 eB:memoField 
The eB memo field type is used for extremely long text, such as the contents of a note. 
When the value is edited, a larger text box will be used, and a special link provided 
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which allows more room for editing. Although it is titled memoField this type can be 
used for plain string attributes as well. 

6.2.2 eBRel:YesNoType  
YesNoType is used to represent columns 
and properties whose values are stored 
in the eB system as “Y” or “N” or “T” or 
“F”. When used in a display layout, this 
type converts the terse internal value into 
a more readable “Yes” or “No”.  In an edit 
layout a YesNoType property is 
displayed as a check box, which is 
selected for “Yes” and cleared for “No” 

6.2.3 xs:base64Binary 
This type has a specialised use within eB, it is used where the eB server stores a value 
in a specially encoded format within the database.  If you select xs:string for the type of 
a property or column, and the result is a gibberish string, use the xs:base64Binary data 
type to display it as plain text.  If you are unsure of the type of the data, always select 
xs:string or eB:memoField first and test the display before using xs:base64Binary. 

6.2.4 xs:string 
The string type is used for any text value that is not expected to be more than a 
sentence. For text values that can be very long, (more than 20 words for example) use 
eB:MemoField.  

6.3 NUMBERS 

6.3.1  xs:positiveInteger 
This type is used to display and edit 
plain numbers.  If the user tries to enter 
a non-number into a positiveInteger field 
during editing, the value is blanked and 
they are prompted to re-fill it.  

6.4 EB DATA TYPES 

6.4.1 eBRel:IdentifyingNumber 
The identifying number data type is used 
to indicate that a property or column 
contains the number or code of an 
object.  For example a person code, a 
physical item number, or a location 
number. 

Note - When eBRel:IdentifyingNumber is 
selected for a document number you 
should specify “prefix” as the internal ID 
field value. 
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6.4.2 eBOrgResponsibility:<responsibility name> 
The eB Organisation Responsibility data 
type is a special type that allows an 
organisation responsibility relationship to 
be “promoted” to a property. This is the 
type of property that is created when you 
use the New > Responsibility Property 
menu option and select the “Organisation 
only” box. The value after the colon in the 
data type name is the name of the 
responsibility that the property relates to. 

eBOrgResponsibility responsibilities differs from eBResponsibility in that when editing, 
the user will only be allowed to specify an organisation. 

6.4.3 eBResponsibility:<responsibility name>  
The eB Responsibility data type is a special 
type that allows a responsibility relationship to 
be “promoted” to a property. This is the type of 
property that is created when you use the New 
> Responsibility Property menu option and do 
not select the “Organisation Only” box. The 
value after the colon in the data type name is 
the name of the responsibility that the property 
relates to. 

eBResponsibility responsibilities differs from eBOrgResponsibility in that when editing, 
the user will be able to specify a person as well as an organisation. 

6.4.4 eBState:<state type>  
The eBState data type is used to convert 
status values that are stored in the eB 
system into human readable text. 

When an eBState property is displayed, 
the internal code (e.g. “A”) is converted 
to a more readable form (e.g. 
“Approved”). In editing mode, the 
property is displayed as a drop down list 
containing the possible values of the 

property (e.g. “Pending”, “Not Approved” “Approved”).  When you configure an 
eBState: property you must replace the name in angle brackets with the name of an 
eBState type, for a list of state types refer to SAN03390. 

6.5 CUSTOM AND SPECIALISED DATA TYPES 
Certain plug-ins for the eB system may define additional data types that are not listed 
in the editor but are useful for your specific application. For a list of the special data 
types in use by your system, consult your Spescom Software representative. 
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7  APPENDIX B – DATA TYPES FOR RELATIONSHIPS 
In the same way as properties and relationship columns, the relationships listed in a 
layout have a related data type. This data type is used by the user interface to choose 
an appropriate control to display the values in a relationship and to determine how 
those values should be edited. 
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