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 Overview 

1.1.  Why SYNCHRO Pro? 

At SYNCHRO, we are passionate about improving construction project performance because we understand the impact 

construction has on global resources and we recognize the importance of the industry to quality of life and economic 

prosperity. We have also experienced how significantly digital technology improves results over the tried and true methods 

that have been standard in the industry for generations. Imagine crystal clear communications and engaged team 

collaboration. Imagine the ability to easily create a shared vision of the project among your stakeholders, the ability to 

identify spatial and resource clashes in the planning phase rather than the costly construction phase, imagine a project 

schedule that gives you confidence to deliver according to plan! 

1.2.  Why 4D? 

Scheduling and planning is critical to safe, efficient, high quality construction. While using 4D, the computer becomes a 

practice field where sequences, safety, special relationships and more can be viewed and discussed continuously before and 

throughout the project lifetime. Because SYNCHRO links 3D Resources (human, material, equipment, and space) to the 

associated Schedule tasks, making changes and comparing baselines to alternatives is quick and easy. Testing sequencing and 

running “what if” scenarios is highly efficient and engaging. Communications are crystal clear, because you can see each step 

in the process. Cooperative knowledge sharing creates innovation and unique approaches that build competitive advantage. 

The result is an efficient, reliable and safe project delivery process that saves time and money. 

1.3.  Who uses SYNCHRO Pro? 

Contractors, Subcontractors, Specialty Supplies, Consultants and Owners use SYNCHRO for the construction of buildings, 

infrastructure, roads and bridges, healthcare facilities, Industrial, Oil and Gas, Power, Alternative Energy, Marine, as well as 

Mining projects. 

1.4.  How does SYNCHRO Pro apply to you? 

SYNCHRO Pro integrates with major scheduling softwares but it can also be used as a stand-alone scheduling tool. In this 

tutorial, you will learn how to integrate your schedule with 3D models from most CAD systems to produce a 4D schedule and 

visualization in virtual reality. Whether you like to see the schedule through the model or see the model through the 

schedule, the ability to visualize your plan while maintaining its integrity allows project delivery performance to consistently 

and reliably exceed today’s performance standards in an immediate and dramatic way.  

1.5.  Course Description 

This course will take you through the basics for SYNCHRO Pro. This course is appropriate for anyone involved in construction 

delivery - including planners and schedulers, virtual design coordinators, and project managers. The course will introduce you 

to 4D scheduling in SYNCHRO. It will cover everything you need to get started working in SYNCHRO, including importing 

schedules and models, linking 3D objects to tasks, inserting new tasks, subdividing geometry, animating equipment using 3D 

paths, and producing outputs. 
 
At the end of the course you will be able to import a model and schedule, fully link the model to the schedule using colour 

coding and growth simulation, review the construction sequence, and export a video to present to stakeholders.  
 
It is time to synchronise your projects. As always, we welcome your feedback at any time, we look forward to seeing your 

results and we hope you will share your experience with SYNCHRO with others to spread the word. Thank you for investing 

your time in learning SYNCHRO Pro. Together we will make a positive change in how projects are planned and delivered. 
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This section will present the various windows in SYNCHRO and how to reorganize and manage your workspace. 

2.1.  Windows in SYNCHRO Pro 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
• Quick Access Toolbar:  contains commonly used icons. The Quick Access toolbar can be customized by left clicking on the down arrow and 

selecting More Commands. 

• Ribbon: contains commands, sorted by category. In the top right corner of the Ribbon is the Help menu which can be used to find more 
information about a particular feature. 

• Toolbars: contain shortcuts and useful commands found in SYNCHRO. Right click in the empty space below the Ribbon to view and select 
available toolbars. Select Customise to create your own custom toolbar of commonly used commands. 

• Gantt Chart:  window displays the list of Tasks, which can be created, modified, linked, etc. 

• 3D Window:  displays the modelled resources at any defined point in time. 

• 3D Objects: contains the list of 3D Objects and Workspaces (including those imported and those created in SYNCHRO). 

• Resources: contains the list of Resources (including those imported and those created in SYNCHRO). 

• Resource Groups: contains the list of Resource Groups created in SYNCHRO 

• Task Properties: contains data related to the selected Task(s) including Task Status (in the General panel), assigned Resources, and Budgeted 
Costs. 

• Resource Properties: contains data related to the selected Resource(s) including Costs, assigned to Tasks, and User Fields. 

• 3D View Properties: contains properties that allow the user to set different view settings per view. Filters, View Indicators, Render modes, 
Cutting Planes etc.  
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2.2.  Workspace Management 

 Start SYNCHRO Pro by double clicking on the  icon on your desktop 

 
 

NOTE: To access the training files, select Synchro Training from the Support tab. The default location for tutorial files: 

C:\Users\Public\Documents\Shared SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training 

2.2.1. Resizing Windows 

 Place the cursor at the top of the 3D Window so the double arrow icon  appears.  
 Select it with a left mouse click, hold down and drag the 3D window up. All windows in SYNCHRO can be resized 

by this method. Windows can also be resized horizontally 

2.2.2. Undocking and Relocating Windows 

 To undock a window, double click in the window header.  

To undock a single tab, left click on the tab and keep holding the mouse button while moving the mouse. The tab 

will be undocked as a new window. 

 If you are using multiple monitors, you can then move the new window to another screen. 
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 To resize the undocked window, hover over a corner until a diagonal arrow appears, then left click and drag to the 

desired size. 

 

 To re-dock the window in the previous location, simply double click the window header. 

 To re-dock the window in a different location, left click and drag in the window header. Move the mouse over 

another window until the smart window placement icons appears. Hover over one of the icons – a blue preview of 

where the window will be place will be shown. Release the mouse button to place. 

 

 

2.2.3. Reset layout 

 If you close any of these windows, you can re-open them by selecting the appropriate icons in the Windows tab. 

 
 

 To reset the window layout to the default, select Windows tab → Windows Placement panel → select Reset 

Placement. 

 
This command is particularly useful if you cannot locate a particular window or the window placement is changed 

when switching from multiple monitors to only one. 
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 Importing Schedules/Plans 

This section will demonstrate how to import a schedule/plan from another source and manipulate the Gantt Chart display 

options. 

You can import a range of different schedule/plan files into SYNCHRO PRO. The types of plan/schedule files that can be 

imported: 

• SYNCHRO Pro and SYNCHRO Scheduler (.SP file extension) 

• Asta PowerProject 

• Microsoft Project XML 

• PMA NetPoint 

• Primavera P6 

• IFC 

NOTE: Asta PowerProject must be installed on the same computer as SYNCHRO in order to import schedules from this 

program.  

Importing from Primavera can be achieved via P6 XML or directly from the P6 database using the P6 API. Direct database 

access can be achieved for either PPM or EPPM (Standalone/Local or Server) versions of Primavera P6.  

SYNCHRO Pro and SYNCHRO Scheduler are both complete CPM scheduling tools for construction – users can create a schedule 
from scratch, calculate the critical path, manage resources and costs, create baselines, track progress, and compare schedules. 
SYNCHRO Scheduler is essentially SYNCHRO Pro without 3D/4D capability and is available at zero cost to anyone.   

For this training, we will import a schedule in Microsoft Project XML format.   

3.1.  Importing a schedule from Microsoft Project XML 

1. To import a schedule, select File tab → Import then select the source program. For Microsoft Project, select     

File tab → Import → Microsoft Project XML as shown below.  

 
2. Select Browse to locate and select the Training Project Schedule.xml file, then select Open. File Location 

C:\Users\Public\Public Documents\Shared SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\Schedule 

3. Select Next. 
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4. This screen allows the user to choose how to treat 

different attributes of the file on import. The Command 

for each Object can be individually set to Import or Skip. 

Keep the default settings.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Select Import. A Progress bar will display while 

importing and the Output panel will display what was 

imported and any relevant notifications. 

 

NOTE: This data can be copied and pasted into a text 

editor for future reference by using the Select All and 

Copy to clipboard buttons. 

 

6. Select Finish. 
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7. Select (left mouse click) the Gantt tab (at the bottom of the Support Panel) to display the Gantt Chart. The imported 
schedule should look like this. Note: In SYNCHRO, the left side of the Gantt window is called the Task List and the 
right side is referred to as the Gantt Chart. 
 

 

3.2.  Gantt Chart Navigation 

8. Move the mouse into the Gantt Chart area. 

9. To Pan, hold down the middle mouse button then move the mouse up, down, left and right. 

10. To Zoom, roll the middle mouse button wheel forward and back to zoom in and out respectively. 

11. This schedule is organized by Work Breakdown Structure (WBS). In the Plan ribbon → Gantt Display Options, ensure 
that it is set to WBS. Schedules may alternatively be Custom grouped by any attribute, including Activity Codes. 

 
12. In the Task List, click on the    or   icon next to any WBS summary to collapse the schedule to that level. When 

collapsed, click on the    or    icon to expand the summary task. 
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13. Right click in the Task List and choose Collapse → All to view only the top level Task. 

14. Right click in the Task List and use Collapse To → Level 3 to view the 3rd level of the WBS 

 

15. Right click again and choose Expand →All to see all the tasks again. 

3.2.1. Customise Columns 

SYNCHRO gives you the option to customise the columns shown in the Gantt chart by adding or removing columns, or 

changing the order or names of the columns displayed.  

16. Right click in the heading field of the Task List and select “Customise Columns” (below left) to open the “Customise 

Columns” window (right).  

 

17. To add a Column, in the “Customise Columns” window, select a Task Parameter on the left under “Available 

Columns” and press the Single Arrow (outlined above) to move the Task Parameter to the right under “Selected”. 

18. Conversely, to remove a Column, highlight a Task Parameter under “Selected” and press the single Left Arrow to 

move the parameter back to “Available Columns”. 

19. Once you have finished adding and removing Task Parameters, you can re-order the columns by highlighting a Task 

Parameter in the “Selected” Column and pressing “Up” or “Down” or Dragging and Dropping in the list. Similarly, 

you can rename the Columns titles by highlighting the parameter and pressing the “Rename” button. 

NOTE: The top Task Parameter in the “Selected” column is the farthest left column in the Task List. 
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3.3.  Date Display 

The time and date format can be changed to 

match the local convention. 

20. In the File tab, Navigator tab or Quick 

Access Toolbar, select the  Options icon. 

This will open the Options dialog which 

contains many settings related to all 

aspects of SYNCHRO including the 

customization of the Gantt Chart and 3D 

view, as well as scheduling and 

Synchronisation preferences. 

21. Expand the General tab, and select Time 

Display Format. 

22. From the first drop down menu, select 24H 

Clock for this training. This will set the date 

format to DD/MM/YY. There is also the 

option to hide the time of day, but we will 

leave it on for this training. 

 

You can leave the Options dialog open for the next section. 

 Auto Save 

This section will teach you how to use the Auto Save and Backup functions in the Options menu to ensure you will lose no 

data while working on your SYNCHRO Project.  

At this stage it is advisable to activate the Auto Save and Backup functions. 

1. In Options → General → Auto Save, enable Auto Save Project (if it is not already on) and designate 90 minutes 

(optional). 

NOTE: The time specified for the Auto Save will depend on the size on the file. Larger files take longer to save and the file 

will be un-editable during the auto save process, so you should pick a frequency that balances time waiting and amount 

of work you are willing to lose if the file or computer crashes. 

2. Enable Backup project file when opened and Browse to select a convenient location. If the location is left blank, the Auto 

Save, Backup and Dump files will be saved in the default windows Temp folder as defined by the %TEMP% environment 

variable. 

NOTE: You will need to empty this folder from time to time as a time-stamped backup file is created every time you open 

a project (up to the maximum Number of backup files per project). These automatically generated backups can be very 

useful to return to an older copy if you find a mistake later on or want to access work you’ve since deleted. The Auto 

Save file and any DMP (dump) files will also save in this folder. 

3. If Auto Save is enabled, it is recommended to enable Delete auto saved file on normal exit.  This command will delete 

the Auto Saved files (but not the Backup file) when you close SYNCHRO normally. Otherwise, the file will be available to 

the last Auto Save point if necessary.  
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 Importing Models 

In this section, you will learn how to import various external 3D model files and what settings to use to optimize the model 

within your SYNCHRO project. 

SYNCHRO Pro can import 58 file types for 3D models including DWF, DWG, DGN, SKP, 3D PDF, and IFC. Multiple file types can 

be imported into the same master SYNCHRO Project. 

NOTE: For a full list of importable file types, please see Appendix A: 3D File Formats. 

Additionally, there are SYNCHRO plugins available on the SYNCHRO website to convert Revit (RVT), Navisworks (NWF and 

NWC) and Bentley (i-Model and DGN) to SYNCHRO Project format (SPX). For more information on the Bentley and Revit 

workflows, please see Appendix B and Appendix C, respectively.  

NOTE: To work with Bentley iModels, use SYNCHRO 4D Pro to Open>SYNCHRO Control Project. iModels hosted in the cloud 

can contain Bentley model files as well as other file types (e.g. Revit) bridged into the iModel using iTwins Synchronizer. 

Hosting the iModel via SYNCHRO Control also allows for collaboration between multiple users. 

5.1.  Importing 3D Files 

This section will define and explain various 3D import settings and teach you how and when to use each. 

1. Select File tab → Import → 3D.   

http://www.synchroltd.com/downloads/
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2. Browse to locate the training models to Import. File location: C:\Users\Public\Public Documents\Shared 

SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\Models. By holding down the Ctrl key you can select 

multiple files for import. Select the following files: 

• Site.dwfx 

• Landscape.dwfx 

3. Select Open. 

4. Select Next to view the import settings. Ensure that your settings match those in the image below right. 

• Read Unit Information – when enabled, processes the 
unit information of the 3D Object (i.e. cm, inches) 

• Read 3D Text Annotations – when enabled, SYNCHRO will 
process any text assigned to the 3D Object in the CAD file 

• Process User Fields – when enabled, SYNCHRO will 
import system- and user-generated parameters (or tags) 
with the 3D geometry as User Fields 

• Ignore Hidden 3D Objects – when enabled, objects that 
are hidden by filters or other display controls in the 3D 
file will not be imported into the SP file 

• Ignore Wireframe 3D Objects – when enabled, polylines, 
lines, circular arcs, circles, elliptical arcs, ellipses, and 
nurbs curves objects will not be imported into the SP file 

• Load 3D Objects into memory - controls whether 
imported objects are automatically loaded into memory. 
If disabled, imported objects will not be loaded into 
memory and will not be visible in the 3D window. 
Disabling this option tends to reduce the time to import 
and is recommended especially for large files.  

NOTE: To load/unload an object from memory after 
importing, check the box next to the object name in the 
3D Objects tab. 

• Default Tessellation Accuracy – allows the modelling 
engine to determine its own Tessellation accuracy to 
control Tessellation. 

NOTE: “Tessellation” means the surface of the geometry 
is built using triangles. High tessellation will slowly render 
very detailed geometry surfaces. Low tessellation will 
quickly render less detailed geometry surfaces. 

• SKP Format (Process Layers as Filters) – when enabled, 
creates Filters for Sketchup Layers 

 

5. Select Next to view additional import settings related to the geometry location, scale and rotation. We do not need 
to edit any of these settings for this training. 

NOTE: The Rotate (DWF Format) option can be enabled to apply a 90º rotation about the X Axis specifically to 
Autodesk published DWF where the Y axis is set as vertically up. 

6. Select Import. A progress bar will display while the files are importing. 

7. When the import is finished the Resource Wizard will appear.  
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5.2.  Understanding Resources 

• When 3D Objects are imported into SYNCHRO, they are just 3D Representations / Geometry that can be 
viewed and manipulated in the 3D View.  

• In order for 3D geometry to be linked to the project schedule they must be assigned to Resources. These 
can be considered ‘3D Resources’ which can be in essence a copy of the object name or several objects 
grouped together as one ‘3D Resource’. 

• A Resource is anything utilised by a project schedule. In SYNCHRO, Resources are categorized as Equipment, 
Human, Location, or Material. Resources do not necessarily need to have a 3D representation. 

 

5.3.  Resource Wizard 

This section will show you how to properly use the Resource Wizard to create resources during your 3D model import. 

8. Choose Assign to a new Resource and select Next. 

 

 
 

NOTE: Selecting “No assignment “will finish the 3D import 

process without creating any Resources. These 3D objects 

would not be able to be assigned to Tasks until Resources 

were created. If you receive the warning shown to the 

right, it is likely because you chose No Assignment on 

import. You would then need to create Resources for the 

3D objects by activating the Resource Wizard manually.  
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9. Enter Site for the Name and make sure the Type is set to Material. 

 
10. Then select Next, the Resource Creation options will show next. This step merits further explanation in the next 

section. 

 

 

  

NOTE: Name will be the top node of the resource 

tree, so always pick something that will help you 

identify the contents.  
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5.4.  Resource Creation Options  

The Resource Creation options can be used to help filter or group the imported 3D objects. The easiest way to describe 

this is if we consider an example. 

This crane model is split into 5 CAD files called 1 to 5, each containing several items. The following sections will 

demonstrate the result of choosing each of the 4 Resource Creation options. 

 

5.4.1. Assign to this Resource, don’t build tree 

The first option, Assign to this Resource, 

don’t build tree, creates a single resource in 

which multiple objects are grouped when 

importing one or multiple 3D files.  

In the example of the crane, if you chose 

Assign to this Resource, don’t build a tree, all 

5 files will be imported and assigned to one 

Resource for the whole crane, which you 

could name Tower Crane. 

 

5.4.2. Add Resource underneath, don’t build a tree 

The second option, Add Resource 

underneath, don’t build a tree, creates one 

resource for each file, to which any parts are 

combined within each 3D file name. 

If you chose this option in the example of 

the crane, you will import files 1 to 5 and 

will have 5 resources named as the CAD file 

names (1, 2, 3, 4, 5 in this example) under 

the Resource heading Tower Crane so that 

the crane is split into 5 resources, one for 

each file. 
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5.4.3. Assign to this Resource, build tree 

The third option, Assign to this Resource, build tree, creates multiple resources with the same tree structure as exists in 

the corresponding 3D objects list when importing one 3D file. When importing multiple 3D files, the tree structures will 

be merged. 

If you chose this option in the example of the crane, SYNCHRO will import files 1 to 5 and create a resource for each of 

the individual items of the crane, as a list under the heading Tower Crane. 

 

5.4.4. Add Resources underneath, build tree 

The fourth option, Add Resources underneath, build tree, creates multiple resources with the same tree structure as 

exists in the corresponding 3D objects list when importing one OR multiple 3D files. 

If you chose this option in the example of the crane, you will import files 1 to 5 and will have a resource for each of the 

individual items of the crane with the same tree structure as the CAD data under the Resource heading Tower Crane. 

 

 



SYNCHRO Pro Basic Training: Importing Models 

   
 

 PRO|16
  

5.4.5. Which Option to Choose 

Which option you choose depends on whether you are importing one or multiple files and how you intend to use the 

models in SYNCHRO.  

Generally speaking: 

• Use the first or second “don’t build tree” option to group all the objects within a CAD file as one; for example, 

an equipment model with all its subparts (wheels, bolts, etc.) that does not need to be assembled in the 

animation, but will be assigned to tasks as a whole;  

• Use the third or fourth “build tree” option if you want to assign model objects separately to different tasks.  

• The bottom option “Add Resources underneath, build tree” gives you the largest object tree and the most 

options for filtering and assigning resources to tasks.   

In the crane example, we would pick the first option Assign to this Resource, don’t build a tree if we just want to assign 

the whole crane to the tasks that utilize it.  If, however, our schedule includes multiple tasks for the assembly of the 

crane part by part, we should choose the fourth option Add Resources underneath, build tree. 

5.4.6. Resource Tree structure 

For this training we will give each individual item a separate resource. 

11. Select the bottom option Add Resources underneath, build tree. 

12. Select Finish. 

 
At this point SYNCHRO will read-in the 3D files, analysing their content and creating associated material resources. 

13. In the Resources tab, under Material Resources expand the Site tab to see that both files have been given a separate 

branch in the Resource tree. 

  
 

14. Right click anywhere in the Resources window and select Expand → All 

to see the full Resource tree. You will notice that each object is its own 

resource (the bottom level of the tree)  
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15. Open the 3D Objects window.  

16. Right click in the 3D Objects window and choose Expand → All. Here you can see that the Resource tree is 

essentially a copy of the 3D objects tree. This is because we chose the Add Resources underneath, build tree 

Resource Creation option. 

 
 

5.5.  Load 3D Objects 

You will notice that although the 3D Objects and Resources are populated, there is no 3D geometry in the 3D Window. 

This is because we disabled Load 3D Objects into memory when importing the files. Objects that are not loaded into 

memory will not be displayed in the 3D window. Objects can be loaded into memory using the check boxes in the 3D 

Objects.  

17. In the 3D Objects, enable the check box beside Landscape.dwfx. The Landscape geometry will show in the 3D 

Window. 

 

 

  



SYNCHRO Pro Basic Training: Importing Models 

   
 

 PRO|18
  

18. Enable the check box beside Objects of scene to load all 3D Objects into memory. 
 
NOTE: The first click of the box may unload all objects if some objects are already loaded. A second click will then 

load all objects. 

 

NOTE: Objects and/or files can be selectively unloaded from memory to help increase the performance of large files. 

5.6.  Duplicate Names Warning 

This tutorial explains how to troubleshoot the Duplicate Names Warning that occasionally occurs when using the 

Resource Creation Wizard. If left unresolved, duplicate Resource names can lead to improper synchronisation. 

19. Select File tab → Import → 3D. 

20. Browse to locate the training models. File location: C:\Users\Public\Public Documents\Shared SYNCHRO 

Projects\Tutorial Files\SYNCHRO Pro Training\Models. By holding down the Ctrl key you can select multiple files 

for import. Select the following files: 

• Architecture.dwfx 

• Structure.dwfx 

21. Select Open. 

22. Select Next to view the import settings. Settings will be saved from the last import. 

23. Enable Load 3D Objects into memory. 

24. Select Import. 

25. When the import is finished the Resource Wizard will appear. Choose Assign to a new Resource and select Next. 

26. Enter Office Building for the Name and make sure the Type is set to Material. By importing the Architecture and 

Structure models separately from the Site and Landscape models, we are able to create separate nodes for Office 

Building and Site in the Resources tree to aid with selection and filtering. Select Next. 

27. For Resource Creation, again select the bottom option Add Resources underneath, build tree and  

28. Select Next. 
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You will be presented with the following Duplicate Names in 3D file Warning! 

 

 
 

This warning will sometimes appear when you import a file that had been exported from Revit. Within this Revit file, 

there are SubParts that appear at the bottom level of the 3D object tree, which is a result of copying and pasting in Revit. 

If you select Finish, 3D Objects with duplicate names will be assigned to Resources.  If you ignore this warning and begin 

assigning Resources to Tasks, and later synchronise from an updated 3D file, some Resource assignments may be lost 

because SYNCHRO cannot distinguish which 3D object is assigned to which Resource as they have the same name. 

It is therefore important to ensure all names for 3D objects are unique! In the case of SubParts this can be done by 

limiting the 3D tree depth on import. 

29. Select Back. Note that the 3D Object tree is 6 levels deep.  

30. At this point, you could select Cancel to undo the 3D import and start again. For the purposes of training, select Next 

and then Finish. 
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31. In the 3D Objects, right click and choose Expand→ All. 

32. Right click again and choose Find 3D Object. 

33. Type SubPart in the Find 3D Objects dialog and select Find Next 

 

 

You can see that the SubParts are at the bottom or 6th level of the 

tree. The unique object name is at the 5th level of the tree.  

 

 

 

34. From the Quick Access Menu at the top of the screen, use the drop-

down arrow to the right of the Undo icon to view the list of recent 

commands. Select the first item in the undo stack (import) to undo 

the import of the Office Building 3D files. 

 

 

 

We will now re-import the Architecture and Structure models, but this time, limit the 3D Object tree to a depth of 5 

to eliminate the SubPart duplicate names. 

  

NOTE: SubParts are always at the bottom level of the tree, but this is not always the 6th level. When the duplicate 

name warning is encountered, use the Back button in the Resource Creation dialog to see the current 3D Object 

tree depth (step 29 above), then limit the tree to 1 level less than the current depth. 

To re-import the models, repeat steps 19 through 21 above.  
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35. When you get to the import options (step 22), set the value for Limit 3D Object tree levels by: to 5. 

 

36. Continue importing and creating Resources by repeating steps 23 through 28. You will not receive the Duplicate 

Names warning this time and will be able to successfully synchronise the file later. 
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 3D View 

In this section, you will learn how to navigate and customize the 3D View window. 

6.1.  3D Window Navigation 

It is highly recommended to have a mouse with left click and right click buttons, as well as a scroll wheel (that has center 

click capabilities). 

• Zoom All - This will show all the objects from the front as the models have been created- it can be used if the view 

becomes disoriented. 

o Within the 3D window click the right mouse button and select Zoom All. 

o Or select the 3D tab → Zoom panel → Zoom All.  

• Rotate - Hold down the left mouse button at a point in the 3D View that you want to rotate about, then move the 

mouse. 

• Zoom - Scroll the middle mouse button forward to zoom in and back to zoom out. 

• Pan - Hold down the middle mouse button and move the mouse left, right, up and down. 

• View Cube - Left click on points or faces on the cube and the view will rotate to that viewpoint, or hold down the left 

mouse button on the circle to rotate. 

 

NOTE:  To enable the View Cube (if not already enabled), in the 3D tab → Display Settings panel. Check the box next to “View 

Cube Manipulator” 
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6.2.  Preferences 

This section will teach you which custom settings are available for the 3D Window.  

• In the 3D tab → Display Settings panel, Selected View Background 

or Other Views Background will change the colour of the 

background for the selected and other 3D views. 

• The 3D View Properties window contains many other settings 

which apply to the selected 3D Window. More information can be 

found on these settings by right clicking on the 3D View Properties 

window title and choosing Help from the context menu 
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 4D Linking Process – Assigning Resources to Tasks 

This section will outline how to attach your scheduled tasks to the resources created from your 3D import, to create a 4D 

project.  

The crux of 4D is creating links between 3D representations and schedule data. When the linking process is complete, the 

view of the model will be controlled by the schedule - the 3D view tells the story of the schedule.  The process for assigning 

Resources to Tasks follows a simple procedure, which will be explained further in the following sections: 

1. Left click on the Task to select/highlight. 
2. Choose the Appearance Profile (which dictates how the Resource is to behave before, during, and after the Task). 
3. Select the Resource. 
4. Assign the Resource to the Task. 

7.1.  Resource Selection 

This section explains the various methods to select a single (or multiple) resource. 

When you select a 3D Resource, it will be highlighted purple in the 3D window (or selection colour as defined in Options 

→ 3D View → Colours → Selection Highlighting). 

• Left Click -Single left click an object in the 3D window to select. Any object that 
you click twice will be deselected. 
 
NOTE: If a single left click does not select an object, press Esc in the 3D window 
to unselect all objects, then right click in the 3D window and enable Selection 
Tool → Select on Click. 

 

• Shift Select - When Select on Click is disabled, holding down the Shift button on the keyboard and single left clicking 

with the mouse will select objects in the 3D View. You can continue to select objects while holding Shift.  Objects that 

you select twice will not be deselected. 

• Ctrl Select - When Select on Click is disabled, holding down Ctrl on the keyboard will work like using the Shift selection, 

except that any selected object that is clicked will be deselected. 

• Navigator / Window tabs - You can highlight the name of the 3D Object or Resource in the 3D Objects window, 

Resources window, or 3D Filters window. 

• Window Box - By default,  Window Box will be selected in 3D → Selection Tool. 
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Hold down both the Shift button and the left mouse button then move the mouse so you can select by a window box. 

Selection depends upon the direction you draw the box: 

a.  Top Left to Bottom Right- All objects within the window box and all that it touches that are visible. 
Selection:                     Result: 

 

 

 

 

 

 

b.  Bottom Right to Top Left- All objects completely within the box that are visible. 
  Selection:                     Result: 

 

 

 

 

 

 

c.  Top Right to Bottom Left- All objects within the window box and all that it touches that are visible and non-visible.  
  Selection:                                                                  Result: 

 

 

 

 

 

 

NOTE-You can also hold Ctrl on your keyboard instead of Shift to select and deselect objects using the window selection 

methods shown above 

• Cancelling Selection - If you left click anywhere within the 3D Window then press Esc on your keyboard, the 

selection will be cancelled. 
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NOTE: There are two different context (right-click) menus in the 3D window depending on whether any 3D objects are selected: 

When one or more objects are selected, the context 
menu contains commands related to working with the 
selected objects 

When no objects are selected, the context menu 
contains commands related to the 3D View 
properties, navigation, and creating new items 
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7.2.  3D Filters 

3D Filters can help with the 3D Resource selection process by limiting the objects visible in the 3D window. The most 

commonly used filter (the built-in 3D Object Filter) is explained here. Users can also create their own custom filters, 

which will be demonstrated later in the training. For more information, please see Section 12.1 User Fields. 

 In the Navigator ribbon → 4D Visualization panel open the 3D Filters window. There are 3 built-in filters.  
 Right click on 3D Object Filter and select Activate in selected 3D View or select the Activate in selected 3D View 

button.  
 

  

 

 

 The 3D Object Filter will be added to the 3D View Properties→ Filters:  Active Filters list. 

 

   

  

NOTE: The 3D by Selection filter is automatically enabled when 
using the 3D →Filters →Isolate Selected or Hide Selected 
commands.  

 

The Same as Task Filter shows in the 3D view only the objects 
assigned to Tasks included in the current Task Filter. 

 

NOTE:  The Active Filters panel allows the user to 

apply multiple filters to each 3D window combined 

with AND or OR operation. Each filter may have a 

different color scheme. The order of the filters in 

the Active Filters list controls which color 

scheme(s) take precedence. 
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 With 3D Object Filter selected in the Navigator→3D Filters list, select the 
General tab and ensure that the box is activated next to 3D. 

                  
 

This filters the 3D View by the 3D Objects list. Initially everything will 

disappear in the 3D view since nothing is selected in the 3D tab. 

 

 

 

 

 
  In the 3D Filters → 3D tab, right click within the 3D list and select 

Collapse → All. Then click on the icon left of the Objects of scene 
node to expand it. 

If you expand each file, you will see that you then have the layer the 

items are on. 

Click to expand a layer and you will see the individual items which you 

can hide or unhide as you so wish. 

Enabling (checking) the box next to the File Name, Layer, or Object 

Name will show the objects associated with each in the 3D View 

(Disabling/un-checking will hide these objects the 3D View): 

 Select Mark All to enable all objects or Clear All to disable. 

NOTE: You can begin with all objects disabled and begin checking files, layers, or objects to add to the visible scene, or 
you may prefer to begin with all objects enabled and uncheck files, layers or objects to hide them from the scene. 

Use the Exclude Matches rather than Include Matches options to hide all objects checked in the filter – this inverts the 
visible and hidden objects. 

Filter via 3D Filters vs Load / Unload in 3D Objects window: The 3D Filters control the visibility of an object only. Un-
checking an object in 3D Filters → 3D tab, hides it in any 3D windows where that filter is active; un-checking an object in 
the 3D Objects tab unloads it from memory (RAM) and also hides it from all 3D windows. Unloading from memory will 
help improve performance on large files. When an object is unloaded in the 3D Objects tab, it will not be visible in the 3D 
view, regardless of whether it is included in a 3D Filters filter or not – it must be enabled (checked) in both the 3D Filters 
and 3D Objects tab to be visible. For visualisation purposes and ease of sorting/assigning, it is recommended to use the 
3D Filters rather than 3D Objects list. The benefits to using the 3D Filters include: can save multiple filters, can create 
colour schemes to affect filtered/non-filtered objects, can show the intersection (AND) or union (OR) of multiple filters, 
can filter by other attributes than just the 3D Objects list (eg. text or parameters), and can easily switch between 
multiple saved filters. For more information on 3D Filters, please see the Help Section in SYNCHRO. 

 
TIP: You can unload selected 3D Objects from the 3D View via Right Click→Edit→ Unload Selected Objects. 
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7.3.  Appearance Profiles 

The Appearance Profile selected when assigning a Resource to a task dictates how the Resource is to behave before, 
during, and after the Task. The Appearance Profile controls: 

• when the Resource is visible (before, during, and/or after) according to one of 5 Actions (Install, Maintain, 
Neutral, Remove, and Temporary). 

• the colour of the Resource in the 3D view before during and after the Task. 

• any growth simulation or transparency interpolation during the Task. 

In the Navigator tab → 4D Visualization panel → Appearance Profiles. In the Appearance Profiles tab, under System 
Profiles you will see 5 predefined options which will be used when assigning to tasks. The functions of these are shown in 
the table below. 

These are the predefined Appearance Profiles you can use. 

Later in this tutorial you will create your own Profiles where you can: 

a. Set the Action. 
b. Change the Colours. 
c. Add Transparency. 
d. Set Different Start & Finish Transparencies. 
e. Show Growth Simulation. 
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7.4.  Basic Linking Process 

This section will guide you through the steps to link a 3D Resource to a Task using the Training Project model. 

1. Single left click to select the task Temporary Hard Standing in the Task List. It will be highlighted yellow. 

2. In Navigator→3D Filters activate the 3D Object Filter; this will limit the displayed objects in the 3D view. 

3. In the 3D Filters → 3D tab, check the box to show only Site.dwfx. 

4. Rotate in the 3D view so that you are looking down on the site: 

 
 

5. Left click to select the hard standing beneath the site trailers (you may need to zoom in using the mouse scroll 

wheel). 
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6. From the Fast Options toolbar located beneath the ribbon, ensure that Install is selected for the Appearance 

Profiles. 

 
 

7.  Right click in the 3D window and select Assign to Selected Task(s) from the context menu 

 
8. You will notice that the 3D Resources column in the Task List turns blue for that task, indicating that a 3D Resource 

has been assigned. The column also indicates the number of 3D Resources assigned. For this task it should read “1” 
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In the Task Properties → Resources tab, you will see the 3D model resource that you have assigned to that task.  

 
The hard standing model object may have disappeared from the 3D view. Once an object is assigned to a task, its visibility 

is controlled by the red Focus Time bar in the Gantt Chart. In the Gantt Chart, The Focus Time is indicated by the red 

dashed line with a triangle symbol on top. 

 
NOTE: The Data Date is indicated by a vertical blue dashed line. This defines the project scheduling date for progress 

reporting and can be confirmed and edited in Navigator → Project → Scheduling tab. 

 

9. Left click and hold in the Timeline where the red triangle is and move the Focus Time bar left and right. This will 

move the Focus Time to any point in time in the schedule.  

 

TIP: You can also single left click anywhere in the Timeline and the Focus Time will jump to that point. 
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10. Move the Focus Time 

before the start of the 

Install Temporary Hard 

Standing task. When the 

Focus Time is before the 

start of the Task, the hard 

standing object is not 

visible in the 3D window 

because it has not yet been 

installed. 

 

 

 

 

 

11. Move the Focus Time 

during the Install 

Temporary Hard Standing 

task. The hard standing 

object is visible and 

highlighted green according 

to the Appearance Profile 

to indicate that it is 

currently being installed. 

 

 

 

12. Move the Focus Time after 

the Install Temporary Hard 

Standing task. The hard 

standing object is visible 

and shown in its original 

colour because it has 

already been installed. 
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7.5.  Correcting Resource Assignment Mistakes 

If you realize that you have assigned a Resource to the wrong task by mistake, you can make this correction by using one 

of the following options: 

1. In Task Properties → Resources, right click on the resources and select Unassign All to remove all the resources. 

2. If you want to remove just one resource, right click on each item’s lowest level (shown as Floor [854875]) and select 

Unassign 

3. Alternatively, you can select the object in the 3D View, right click and Unassign from All Tasks, or use the Ctrl+U 

keyboard shortcut 
 

 

4. If you have assigned an object using the wrong 

Profile you can change it by selecting the lowest tree 

level of the resource in Task Properties → Resources 

and select the correct Appearance Profile from the 

dropdown box below. 

  

NOTE: After selecting and editing an object in the 

Task Properties → Resources, make sure you click in 

the open space in this window or the 3D window and 

press Esc on your keyboard to deselect it and avoid 

accidentally assigning it to another task later 
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7.6.  Linking Options 

There are 5 different ways to link the 3D models to the schedule that can be utilised at the user’s discretion. They are 

listed and explained below. 

1. Assigned from 3D Window via right click 

i. Select the desired task(s). 

ii. Select item(s) within the 3D window so they are highlighted. 

iii. Right click in the 3D window and select Assign to Selected Task(s). 

 

2. Assigned from 3D Window via drag and drop 

i. Select item(s) within the 3D window so they are highlighted. 

ii. Hold down the Alt key on your keyboard and the left mouse button then drag the cursor over the desired 

task, letting go to assign it. 

NOTE: With this method, you do not need to pre-select the desired task so that it is highlighted.  

3. Assigned using ‘Ctrl + Shift + A’ quick key 

I. Select the desired task(s). 

II. Select item(s) so they are highlighted. 

III. Click in the 3D window, then simultaneously hold down the Ctrl, Shift and A keys on the keyboard.  

 

4. Assigned from Resources or 3D Objects window via right click 

i. Select the desired task(s). 

ii. Select the Resources or 3D Objects window.  

iii. Select item(s) so they are highlighted. 

iv. Right click on the 3D Object/Resource name and select Assign to Selected Task(s). 

 

5. Assigned from Resources Window via drag and drop 

i. Select the Resources tab. 

ii. Select an individual item within the Resources list or an entire level of the Resource tree (eg. file or level) so 

they are highlighted. 

iii. Hold down the left mouse button and drag and drop over the required task. 

NOTE: With this method, you do not need to pre-select the desired task so that it is highlighted.  
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Using any of the above methods, practice assigning Resources to Tasks for the following items: 

Resource(s) Task Appearance 
Profile 

 

Double Wide Construction Trailer & Portable 
Restrooms. 
 
TIP: Select these items visually in the 3D 
Window 

Field Office Install 

 

Excavation1 [680854] 

TIP: You can search for Resources by name 
by right clicking in the Resources window 
and selecting Find…  
 

Foundation 
Excavation 

Remove 

 

 
All 13 “Basic Wall” Resources that make up 
the node “Site Perimeter Fence”. 
 
TIP: From the Resources window, you can 
select the parent node “Site Perimeter 
Fence” and drag and drop onto the task – 
this will assign all the Basic Wall Resources 
that make up the node. 

Perimeter 
Fence 

Install 
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 Review and Investigate Assignments 

In this section you will learn how to review resource assignments. After assigning resources to tasks, you can play the 

construction sequence in the 3D View, like a movie, to review. 

8.1.  Saving and Opening Projects 

1. Select File tab → Save. 
You will also see the option to Save As. 

2. Select File tab → Exit. 

3. Start SYNCHRO. 

4. Select File tab → Open → Private Project then locate and select Training Building.sp to Open. File Location: 

C:\Users\Public\Documents\Shared SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\ .sp Files 

8.2.  Review 

1. In 3D View right click and select Zoom → Zoom All. 
2. Rotate in the 3D window so you can see the whole site. 
3. Drag the Focus Time back to the start of the project and drag along to the right at your own discretion though time. 

8.3.  4D Review 

The 4D Review tab contains all the commands needed to control the Focus Time.  

1. From the 4D Review ribbon → Player panel, select   to Move to Start. 

2. From the 4D Review ribbon → Player panel, select  to Play. 
3. The speed can be adjusted by selecting from the 4D Review ribbon → Speed panel, then chose an option from the 

drop-down menu, for example  1 Week. Note that in this instance, the red Focus Timeline will move ahead in 
intervals of one week. 

4. From the 4D Review ribbon → Player panel, select  to Stop. 

8.4.  Select Assigned Tasks from an Object 

1. Select one of the Perimeter Fence items from the 3D Window. 

2. Right click in the 3D window and choose Select Assigned Task(s).  

This command will automatically find and highlight the task(s) that the object has been assigned to. If the Resource 

is assigned to multiple tasks, the Task list will automatically jump to the first task. You would need to scroll through 

the task list to see the other highlighted tasks, or use Plan ribbon → Find/Select panel → Down to next selected 

command 

3. You can also see a list of all tasks that a selected Resource is assigned in Resource Properties window → Tasks tab. 

Left clicking on a task in this list will select it in the Gantt Window. 
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4. Another way to quickly see which Tasks a Resource has been assigned to is to change the 3D selection mode in the 

Fast Options toolbar from Resource to Task 

5. As you select Resources in the 3D View, the Task(s) that the Resources are assigned to will be automatically selected 

in the Gantt Chart as well. Selecting additional Resources adds to the Task selection. 

6. Change the Task Selection Mode back to Resource 

7. Left click in the 3D Window then press Esc to cancel all selections. 

 

8.5.  Select Assigned Resources from a Task 

This section explains how to investigate which resources are assigned to a particular task. 

1. Select the task Field Office. 

2. Move the Focus Time after the end of the Field Office task.  

3. Right click on the task and choose Select Assigned Resources. 

This command selects and highlights all the object(s) assigned to the selected task.  

4. If you cannot find the objects in the 3D window, left click one of the top corners of the View Cube to zoom to the 

selected objects, or right click in the 3D window and select Zoom → Selected Objects 

 
You can also see all the Resources assigned to a task in the Task Properties → Resources tab. 

5. Another way to quickly see which Resources are assigned to a task is to change the Task Selection Mode in the Fast 

Options toolbar from Task to Task with Assignments. 

6. As you select a task or tasks, all the Resources assigned to those task(s) will be automatically selected as well. 

Selecting a new task updates the Resource selection. 

7. Change the Task Selection Mode back to Task  
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 Creating New Tasks 

This section will teach you how to create new tasks in the Project schedule. 

9.1.  Inserting New Tasks Manually 

Suppose that it has been decided to schedule the structural pile installation as three separate tasks.  The current 

schedule has only one task for all the structural piles – Structural Piles (20d). We can divide the current task into 3 new 

subtasks. 

1. Select the task Structural Piles in the Task List so that it is highlighted. 

2. From the Plan ribbon→Create panel, select As Child in the drop down menu.  

 

This will create a new task as a child task, or sub-task, of the selected task which has now been turned into a parent, or 

summary task. The new task will initially be given the duration of the parent task (20d in this case). 

 
3. With the New Task selected, select Plan → Create → Below, to insert a second new task below the first. Repeat this 

step once so that there is a total of three new tasks. Tasks inserted Below will automatically be given a duration of 1 

day. 

 

NOTE: The Plan ribbon → Create 

commands are also available by right 

clicking on a task and choosing from the 

Insert New Task→ commands. 

 

 

 
 

4. Rename the first new task to Piles 1 by double clicking on the name cell or right clicking and selecting Rename Task. 

5. With the Piles 1 task selected, you will see this symbol   within the bottom right of the Name cell. Move 

the cursor over this symbol until it becomes a crosshair. Select this with a left mouse click, hold and drag over 

the cells below until the tasks are named Piles 1, Piles 2, and Piles 3. 
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9.2.  Editing Durations 

Task durations for planned (not yet started) tasks can be edited by typing directly in the Duration cell in the Task List. 

6. Left click in the Duration cell of the Piles 1 task, type 8 and press Enter. If no unit is entered, the duration unit 

defaults to days (d).  

NOTE: Duration default units can be changed in Navigator → Options → General → Duration Display Format, for 

example if you typically schedule in hours. If you wish to enter a duration with a different unit use d for days, h for 

hours, or m for minutes. 

7. Tasks that are adjacent to each other in the Task List can quickly be given identical Durations using the same click 

and drag method as in step 5 above. Click on the crosshair at the bottom right of the Duration cell for the Piles 1 

task and drag down to change the Duration of the Piles 2 task to 8d as well. 

8. Change the Duration of the Piles 3 task to 4d. 

You will notice that the Duration of the Structural Piles task now reads 8d. This is because it is a summary task – 

summary tasks take their duration from the overall duration of all their subtasks.  The Structural Piles task should be 20d 

– we will correct this next by adding logic links to the subtasks. 

9.3.  Adding Logic Links 

Logic links between two tasks define a dependency between one task and another. Links are used to explicitly prevent 

tasks from being worked on out of sequence or to offset the start/finish of one versus another. If a Task is rescheduled, 

then any dependent tasks will also be re-sequenced. More than 2 tasks can be linked simultaneously. The order in which 

the tasks are selected will determine the order in which they are linked. 
 

9. Select Piles 1, hold Shift on the keyboard and select Piles 3.  
 
NOTE: Order matters - selecting Piles 3 followed by Piles 1 would link the tasks in reverse order. 
 

10. Choose the FS (Finish to Start) Link type from the Fast Options toolbar. A Finish to Start link will prevent a 

downstream task from being started before the Finish of the upstream task. 
 

 
11. From the Plan tab→Links panel → Link As Chain in the drop down menu. 
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The 3 tasks will be linked but not rescheduled. 
 

 
 

12. Select F9 on your keyboard to reschedule the project. The 

Reschedule command is also available in the Plan ribbon → Schedule 

panel → Reschedule.  

13. The Reschedule Options window will be raised. This window allows 

you to edit the various schedule related settings including Data Date.  

NOTE: The Parameters and Critical Path tabs contain further 

settings which may need to be updated on your own projects 

depending on the source of the schedule and your company’s 

default scheduling methods. 

For this training, leave the settings as shown and press Reschedule 

 

 

 

 

 

14. The result in the Gantt Chart is shown below (notice how the summary task Structural Piles is 20 days again). 

  
 

 

15. To assign the piles to the tasks, begin by showing them in the 3D 

window. In the 3D Filters window → 3D tab, select Clear All to 

hide all objects. 

 

16. Check the box next to Piles (205) to show them in the 3D view. 

 

TIP: Right click in the list and choose Find 3D Object to quickly 

locate “Piles”. 
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17. Click the TOP face of the Viewcube in the 3D window to view the piles from above. 

18. Right click in the 3D window and choose Isometric. This will make it easier to select the piles using window box 

selection. 

TIP: You may wish to change the Selected View Background colour in the 3D ribbon → Display Settings panel → 

select a colour for Selected View Background to provide more contrast between the piles and the background. 

19. Use window box selection from top right to bottom left (as described in section 7.1) to select the Piles in Group 1, 

then assign to the task Piles 1 using the Install Resource Appearance Profile. 

20. Repeat step 19 to assign the correct group of piles to the tasks Piles 2 and Piles 3. 

21. Right click in the 3D window and select Isometric to turn off this setting. 

 

9.4.  Model-Based Scheduling 

In this section, you will learn how to use Model Based Scheduling - creating tasks from 3D Objects. 

As an alternative to manually inserting new tasks as we did in section 9.1, SYNCHRO allows you to create tasks directly 

from 3D Resources. By default, SYNCHRO will generate the tasks in the order that you selected the objects, link the new 

tasks, and divide the durations of the selected task among the new tasks. 

Suppose we would like to create a task for each of 3 pours of the concrete slab 

on grade. Instead of inserting the tasks manually, we will select the objects in the 

order we want them installed and then create tasks directly from the objects. 

This is called Model Based Scheduling. 

1. In the 3D Filters → 3D tab, show the “Concrete Slab on Grade 200mm” type 

in the Floors family of the Structure file. 
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2. Select the objects in the 3D window in the following order: 

 
3. Select the task Slab on Grade in the Task List so it is highlighted. We will insert the new tasks as subtasks of this one. 

4. With the 3 slabs selected, right click in the 3D window and choose Create Task(s) → Under Selected Task  

 
NOTE: Selecting “Under selected Task” will create new task(s) as child task(s). If you select “At root level” the new 

task(s) will be created at the top (root) WBS level. Selecting “Below selected Task” will create new task(s) below the 

selected task at the same level; neither task will be parent or child to each other. 

 
 

5. The following dialog will appear. Select Yes to create a new task for each selected resources.  

  

 

NOTE: Selecting No will create a single 

task to which all selected resources will 

be assigned. 

 

 

 

 
 
You will notice that 3 tasks (titled the same as their Resource name) have been added as subtasks of Slab on Grade. 

The total duration of these tasks is automatically created to sum to the parent task and they are linked as a chain. 

6. Please rename the three Tasks created Floor [166617], Floor [821844], and Floor [693039] to Slab on Grade Area 1, 

Slab on Grade, Area 2, and Slab on Grade Area 3, respectively. 
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NOTE: See Options → Defaults for New Objects → Creating Tasks from Resources to change settings for how tasks 

are created in model-based scheduling. For example, you can choose not to link tasks when creating. 

7. Drag the Focus Time forward to see the slabs installed in the order that you selected. 
 

  Custom Appearance Profiles 

In this section, you will learn how to create custom Resource Appearance Profiles and how to apply a growth simulation. 

In addition to the default system Appearance Profiles (Install, Remove, Maintain, Temporary, and Neutral), SYNCHRO gives 

you the ability to create as many custom user-generated custom profiles as you would like. These custom profiles will appear 

underneath the default Appearance Profiles under the label Custom Profiles. 

You can vary the colour, the transparency, and/or add a growth simulation.  You can use custom Appearance Profiles to 

differentiate phases and processes or work crews, as well as show the intended direction of an installation or removal. 

10.1. Transparency Interpolation 

One way to indicate change over the duration of a task is Transparency Interpolation. For example, an object being 

installed could start completely transparent at the beginning of the task and become increasingly opaque until it is solid 

at the end of the task. 

1.  In Navigator → Appearance Profiles window, create a new user defined 

Profile by right clicking in the list panel then selecting Add. 

2. Rename the Profile Transparency Interpolation and ensure it is highlighted. 

3. In the General section, ensure the Action is set to Install. 

4. In Active Appearance, enable Original Colour by checking the box next to it 

(or change the colour if desired). 

5. Enable Transparency Interpolation (check the box next to it). 

6. Change the Start Transparency to 100 (%) and set Finish Transparency to 0 

(%). 

7. Ensure that the new Transparency Interpolation Appearance Profile is 

selected in Navigator → Appearance Profiles 

8. In 3D Filters →3D, show Roofs (2) within the Architecture file. 

9. Select Part [1084292] and assign to the task Thermal and Moisture 

Protection → Roofing, Low Roof under Construction in the Gantt Chart. 

10. Select the task, right click and select Focus Time on Task → Start to jump to 

the start of the task. 

11. Drag the Focus Time slowly through the task to see the Transparency 

Interpolation. (You may want to zoom in the Gantt Chart to make this easier to see). 
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10.2. Growth Simulation 

When a Growth Simulation is applied to a resource, the resource appears to grow incrementally in the specified 

direction (or shrink, in the case of Appearance Profiles with the Remove action selected) over the course of the task. 

Growth Simulations can be used to quickly and easily indicate the direction of construction.  

1. In the Appearance Profiles window, create a new user defined Profile by right 
clicking in the window then selecting Add. 

2. Rename the Profile R-L Growth and ensure it is highlighted. 
3. In the properties panel, ensure the Action is Install. 
4. In Active Appearance enable Original Colour by ticking the box next to it 
5. Select Right – Left from the Growth Simulation→Type dropdown  

Active Appearance should look as the picture to the right 
6. Select Part[1084295] and assign to the task Thermal and Moisture Protection 

→ Roofing, High Roof 

7. Move the Focus Time through the task- you will see the roof ‘grow’ as it is 

being installed 

10.3. Resource Groups 

Sometimes you may need to show multiple objects growing as a group using a growth simulation Appearance Profile, 

rather than growing individually. Using Resource Groups for growth allows you to show the general progression of 

construction for multiple objects without needing to create a task for each. For example, suppose you wish to show all of 

the pile caps being installed from right to left during a single task. If you assigned each pile cap to the task using a 

Resource Appearance Profile with a Right-Left Growth Simulation, they would each grow individually which is not the 

desired result. Instead, you should group all the pile caps into one Resource Group before assigning to the task. 

1. In 3D Filters →3D, select Clear All to hide all objects, then 

show Pile Cap-Rectangular (47) within the Structure file. 
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2. Select all the pile caps using window box selection. 

 

 

 

 

 

 

 

 

3. Right click in the 3D window and choose Resource Groups→ Create Resource Group from Selected

 

4. Name the Resource Group Pile Caps 

 
5. In the Fast Options toolbar, change Appearance Profile to R-L Growth. 

 
6. Open the Resource Groups window and select the newly created Pile Caps in the list. You will see the objects 

are all selected in the 3D View. 
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7. From the Resource Groups window, drag and drop the Pile Caps Resource Group onto the task Pile Caps 
under Construction → Concrete. 

8. Move the Focus Time forward over the task and you will see the pile caps growing as a group. 

 
 

NOTE: Resource Group assignments can be edited in Task Properties→Resource Groups. Select the top level Resource 

Group name to edit the Appearance Profile and/or 3D Path 

  

  3D Subdivision 

In this section you will learn how to use the 3D Subdivision tools: Slice, User Slice, and Freehand. 

The 3D Subdivision tool can be used to divide a model object into smaller sub-parts. The sub-parts can be selected 

individually and assigned to separate tasks. This may be used, for example, to divide a single concrete slab into individual 

concrete pours or split continuous columns and walls by level without having to ask the modeller or architect to make the 

changes in the original file.  

You will notice that the Slab on Deck, 1st Floor task is broken into 3 areas, each of which has multiple pours scheduled. There 

are only 3 slabs object on that level, however. The separate pours are not modelled – therefore, we will use the 3D 

Subdivision tool to create them in 

SYNCHRO. There are 3 options 

for Subdivision Type: Slice, User 

Slice and Freehand, which we will 

demonstrate in the following 

sections. 
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11.1. Subdivide by Slice 

In Slice mode, the subdivided object is split into orthogonal uniform planes (columns, rows and layers). You simply define 

how many rows, columns and layers you require. 

 In 3D Filters → 3D, select Clear All to hide all objects, then show 
Concrete Slab on Metal Deck 100mm under Floors in the Structure  
file. 

NOTE: We will only be using Floor [693311], Floor [693318], and 
Floor [693329] for this 3D Subdivision exercise. Please ensure Floor 
[829334] is deselected. 

 
 
 
 
 
 

 From the 3D ribbon → Edit panel → select Subdivide. If the 3D Subdivision window is docked on opening, 
double click the header to undock it as a floating window. 

 Select the “Area 1” slab -  Floor [693311] -  in the 3D Window. The selected item will be displayed in the 3D 
Subdivision window, as shown below. 
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 Enter 1 for Column cuts.  
 In Axes select World so that layers are facing up then enter 1 in the Row cuts. 

 Close the 3D Subdivision Window to finish by selecting the ‘X’ in the top right, then left click in the main 3D Window 

and press Esc on the keyboard.  

NOTE: Each Subdivision can now be selected and assigned separately.  
 

 Change the Appearance Profile to Install in the Fast Options toolbar. 
 Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 1 subtasks according to 

the diagram above. 

NOTE: You can rename the subdivided 3D Objects in the 3D Objects window by right clicking on them and 
selecting “Rename.” Try it now by renaming the subdivisions with their associated Task Areas (i.e. Subdivision 
1,1 will be Subdivision Area 1D). 

 
TIP: Try using the Ctrl + Alt shortcut to drag and drop the 3D object onto the appropriate task. 
 
 

11.2. Subdivide by User Slice 

In User Slice mode, the subdivided object is split into orthogonal non-uniform planes (columns, rows and layers). The size 

of each slice is defined as a proportion of the original geometry and the slices can be resized using the manipulators in 

the preview window. 

There are 2 subtasks for Slab on Deck, 1st Floor, Area 2 which requires a spilt that is at 75% of length of the slab rather 

than directly in the middle (50%). 

 Select “Area 2” - Floor [693329] - in the 3D window. 
 From the 3D Tab → Edit panel → select Subdivide. 
 In the Subdivision type box activate the User Slice option. 
 Enter 1 for Column Cuts. 
 Set Axes to World 
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 Select User Slice then either- 
a. Change the figure from 0.5 (50%) to 0.75 (75%) then Apply. 
b. Use the Arrow manipulator as shown below. 

 

 Close the 3D Subdivision Window to finish. Then left click in the Main 3D Window and press Esc on the 
keyboard. 

 Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 2 subtasks. 

 

 

NOTE: If you have several splits that you want to use the User 

Slice on you can toggle between the splits with the arrow keys 

as shown. 

 

 

 

 

 

 

 

11.3. Subdivide by Freehand 

In Free Hand mode, the subdivision planes are defined by user-drawn lines (polylines) that are then extended in a 

particular direction. This can be used to split objects into irregular shapes. 

1. From the 3D tab → Edit panel → select Subdivide. 

2. Select the final slab “Area 3” - Floor [693318] - in the 3D window. 

3. Select Free Hand. 

4. When using Free Hand slice, always make sure to select Snap to Face from the Axes box. Then in the 3D 

Subdivision Window, left click the face that you will be drawing the cut on (the top face in this case). 
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5. Right click in the 3D Subdivision window and select Visual Indicators>Axis Indicator 

 
6. Right click in the 3D Subdivision window and select Create Subdivision Polyline. 

7. Click the Top face on the view cube so you are looking down on the slab and scroll to zoom out a bit 

8. Left click at one edge to begin the polyline, and then continue left clicking within the slab to add vertices to the 

polyline. Finally left click on an edge to finish the polyline. Try creating the shape shown below. 

 
NOTE: Subdivision Polylines must extend from one edge of the object’s bounding box to another (even if the 
object is irregularly shaped so that its edge is not the same as the rectangular bounding box). 
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11.4. Troubleshooting 

If an object disappears or displays other unexpected behaviour upon subdivision, you may need to adjust your 

subdivision settings. 

 

1. Select the Navigator tab → Options. 

2. Expand 3D View and select 3D Subdivision. 

3. Within Toolkit for Subdivision Operations, change the Used Toolkit from Advanced to Simple and press OK. 

 
NOTE: For some files, the Advanced Toolkit may work better than the Simple and vice versa. You may also need to 

adjust the Triangulation Type setting and enable/disable Try sewing to solid. 
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4. Select the polyline from the list box in the 3D Subdivision window and choose the Remove Selected Polyline button. 

 
5. Right click in the 3D Subdivision window and select Create Subdivision Polyline, and then redraw the polyline as in 

step 8 of section 11.3 above. 

6. To add a second cut, right click in the 3D Subdivision window, select Create Subdivision Polyline again, and left 
click on one edge and across to the other as below: 

 

7. Close the 3D Subdivision window to finish. Then left click in the main 3D window and press Esc on the keyboard. 

8. Select and assign the subdivided floor slab to the matching Slab on Deck, 1st Floor, Area 3 subtasks as indicated 

above. 
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11.5. Editing Subdivisions 

It is possible to edit a subdivision if you decide that you need to after closing the 3D Subdivision. Suppose, for example, 

that it is decided that “Area 2” should be split at 60% rather than 75%. 

1. Move the Focus Time after the end of the Slab on Deck, 1st Floor, Area 2 task. 

2. From the 3D Tab → Edit panel → Subdivide. 
3. Select one of the “Area 2” subdivisions in the 3D window. You will see the object in the 3D Subdivision window, but 

the Subdivision commands will not be available.  

 
4. Click the Select Subdivided Object button to select the entire original object. You can now edit, add or remove splits. 

5. Change the Columns division to 0.6 and press Apply. 

NOTE: Selecting None for Subdivision Type will remove all splits if needed. If you select none, or decrease the number of 

rows, columns, or layers, you will be presented with a warning. If you meant to remove the subdivision, press Yes. Any 

existing subdivisions will be removed, and any associated 3D Resources will be deleted and unassigned from any tasks 

that may have utilised them.  The 3D Object and Resource trees will be updated accordingly. 

 

6. Close the 3D Subdivision window to finish. Then left click in the main 3D window and press Esc on the keyboard. 
7. If Subdivisions were added or removed you would need to assign the subdivisions to the appropriate tasks, 

but since we only changed the size of the existing subdivisions, they have remained assigned to the correct 
tasks. You can confirm this by selecting one of the subdivisions in the 3D window, right clicking and choosing 
Display Assigned to Task(s). 
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11.6. Subdivide Multiple Objects 

SYNCHRO also provides the ability to subdivide multiple objects simultaneously. This can be used to split many objects 

along the same plane; for example, splitting slabs on many floors into the same number of pours or splitting many 

columns in a building by level.  

In this tutorial, we will subdivide wall panels that span from the ground floor to the roof so that they have separate 3D 

Object representations for each floor (ground floor, first floor, and second floor). 

1. In the 3D Filters →3D  tab, select Clear All to hide all objects, then expand Walls → Basic Walls → Interior-

Blockwork 200 (11) under the Architecture.dwfx file. 

2. Show and select the Objects shown below in either the 3D Filters → 3D tab. 

 
3. In the 3D ribbon → Edit panel → select Subdivide. 

4. In the 3D Subdivision window enable Subdivide Multiple Objects. You will now see a purple bounding box that 

includes all selected 3D Objects for Subdivision. 

NOTE:  When Subdivide Multiple Objects is disabled, only the first object selected can be subdivided; the other 

objects selected will still be shown semi-transparent as a reference, which can be helpful to guide you when making 

user slices for example. When Subdivide Multiple Objects is enabled, all objects become opaque; in this mode you 

cannot show additional objects as reference. 

5. From the Subdivision Type panel, select Slice.  

6. Enter 2 for Layer Cuts. 

7. Select Layers Up from the Axes box. 

NOTE: If the flows are not evenly spaced, you 

could use the User Slice and adjust the slices 

accordingly. 

 Close the 3D Subdivision window to finish. Then 
left click in the Main 3D window and press Esc on 
the keyboard. 

 In the Task List of the Gantt Chart, find the tasks: 

“Blockwork / Elevator Shaft, Ground Floor”, 

“Blockwork/ Elevator  Shaft, 1st Floor”, and 

“Blockwork/  Elevator Shaft, 2nd Floor”, 
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 Assign the 3D Subdivisions to the associated Tasks as indicated below using the Install Appearance profile.  

 

 

 

 

 

 

 

 

 

 

 

 Each Task should now have four 3D Objects assigned to them: 

NOTE: When subdividing multiple objects, all selected objects will be split into the same number of subdivisions 

according to the settings specified. This may result in subdivisions listed in the 3D Objects list which do not have a 

physical geometry. This will happen, for example, when all the cutting planes in the 3D Subdivision window do not 

intersect each selected object. 
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 Auto-Matching with User Fields 

In this section, you will learn how to implement the Auto-Matching function using User Fields. 

The Auto-Matching feature in SYNCHRO provides a facility to automatically assign Resources to Tasks using custom filters and 

search rules. The match is based on Resource Names or User Fields as well as Task Names, ID, Comment, User Fields or 

Activity Codes. Using the Auto-Matching function greatly simplifies the task of linking resources to tasks. 

12.1. User Fields 

User Fields are custom fields created to track or filter information for Tasks, Resources, and 3D Objects that isn’t initially 

captured by SYNCHRO PRO’s default attributes. User Fields can be created when importing a schedule or 3D Model that 

has these assigned parameters in their source files. Additionally, you can create custom User Fields in SYNCHRO PRO.  

Previously when we imported the 3D Models (section 5.1), we selected “Process User Fields”.  In this tutorial, we will 

create User Fields for some Tasks to match the existing User Field values of certain Resources. 

1. In the 3D Filters → 3D tab, select Clear All to hide all objects, then show 

Structural Columns (63) and Structural Framing (791) under the 

Stucture.dwfx file. 

2. In the 3D View, select “Left” on the View Cube Manipulator. This will rotate 

the 3D View so that you are looking at the front of the building structure. 

There are over 850 3D Resources. Rather than assigning each Resource to its 

respective Task, we can instead create a custom field or User Field for each Task 

to match the User Fields already assigned to the 3D Resources.  

3. Select any 3D Object shown in the 3D View, then select the Resource Properties tab and expand the User Fields tab. 

For this tutorial, we want the value stored in “Task Location” (shown below). 

 
NOTE: The User Field values shown above are user defined Object Parameters in the BIM files. Upon 3D Import, 

these parameters are created as User Fields in SYNCHRO using the command “Process User Fields”. 
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4. In the Navigator ribbon →  Project Data panel → open the User Fields window. 

5. Right click in the User Fields window list panel and select Add. 

6. In the Add User Field dialog, set the Name to “Task Location”, the Category to 

“Task” and the Type to “String”. Leave Calculation Type as “Don’t calculate”. Then 

press OK 

 

 

 

 

 

7. You can create a custom column filter to only show all the tasks with the work “Area” within it. Right click in the 

Name column header →  Custom Filter. 

8. Select Operation as “contains” with the Value as “Area”. 

 

 

9. In the Task List, find Structural Framing, Area 1, Structural Framing, Area 2, Structural Framing Area 3, and Structural 

Framing, Area 4 under the Summary Task Metals.  

10. Right click in the Column Headers to Customise Columns and show the User Field →Task Location next to the tasks 

in the Task List. (If need be, please reference section 3.2.1: Customising Columns). Your Task List should look like 

this: 

11. Left click in the Task Location column cell of the Structural Framing, Area 1 task, type in “Area 1”.  

TIP: It is possible to create Formulas to calculate User Field 

values based on Task, Resource or 3D Properties and other 

User Fields. See SYNCHRO Help for directions and a full list 

of syntax. 
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12. Select the Task Location column cell for “Area 1”, hover over the bottom right corner until the crosshair appears, 

then drag down to increment the numeric value.  

NOTE: Holding Ctrl while dragging copies the value rather than incrementing. 

13. Task User Fields can also be defined in the Task Properties window 

under the User Field tab. Select the task Plumb/Bolt/Weld Area 1 and 

go to Task Properties → User Fields. 

14. Right click in the table and select Add Value or press the Insert key on 

your keyboard. A new row will be added to the table. 

15. Select “Task Location” from the drop-down in the User Field column. 

Type in the Value as “Area 1”. 

16. You can also use Calculated User Fields formulas to automatically 

extract the “Area” information from the Task Name. In the User Fields window, select “Task Location” and change 

the Calculation Type to “Calculate” and write the Formula – RIGHT(NAME,6) 

17. Select the Tasks Plumb/Bolt/Weld Area 2 - 4, and click Recalculate Values to run the formula. 

  

 

18. Your Task List should now look like this: 

In the next section, we will use these assigned User Field values to Auto Match 3D Resources to these eight tasks. 

12.2. Creating an Auto-Matching Rule 

We will now create an Auto-Matching rule to assign multiple 3D Resources to the appropriate Tasks by matching their 

User Field values.  
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1. Select all Resources shown in the 3D View: [Structural Columns (63) and Structural Framing (791)] 

2. Left click on Task Structural Framing, Area 1, hold down Shift and select Structural Framing, Area 4.  

NOTE: Please ensure you do not de-select the 4 Tasks and 854 Resources selected. You can see how many 

Task/Resources/3D are selected in the Status bar at the bottom of the window 

 

3. Open Assign Resources → Auto Matching →Resources to Tasks to display the Auto Matching Dialog. 

 

 

 

 

NOTE: Please see Appendix D: Auto-Matching for 

more information pertaining to this function not 

explicitly described in this tutorial. 

 

 

 

 

 

 

4. Select New to add a new Auto-Matching rule in the Add New Rule... dialog (shown below). 

5. Name: “Structural Framing & Columns”.   

6. Since we have purposely selected the 3D Resources and Tasks we want to link, enable Use only Selected Resources 

and Use only Selected Tasks under Summary Options.  

NOTE:  Selecting Use only Selected Tasks / Resources will limit the search criteria. If these options are not selected, 

all 3D Resources and Tasks in the project will be searched for a match.  

7. Under Relations, select Many-to-Many since we want to match and assign more than 800 3D Resources to four 

Tasks. 

8. Under Expression, press Add.  



SYNCHRO Pro Basic Training: Auto-Matching with User Fields 

   
 

 PRO|61
  

You can now define the matching criteria of your Auto-Matching Rule in the Add New Term… dialog. For the purposes of 

this tutorial, please set the following 

values: 

9. Under Resource Attribute: 

i. First Drop-Down= User Field. 

ii. User Field Drop-Down = Task 

Location. 

10. Under Task attribute: 

i. First Drop-Down= User Field. 

ii. User Field Drop-Down =Task 

Location. 

11. Please set Algorithm =Exact since we 

want an exact match between Task 

and 3D Resource User Fields.  

12. Operator = AND 

13. Press “Save”.  

14. You will now see your rule in 

“Expression”. 

15. Select OK at the bottom of the Add 

New Rule… Dialog.  
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12.3. Auto-Match Resources to Tasks 

We will now run our Auto-Matching rule “Structural Framing & Columns” in the Auto Matching window.  

16. Select “Structural Framing & Columns” from the Rules Drop-Down.  

17. Make sure Operations → Appearance Profile is set to Install.  

 

 

 

 

18. Select Search to display the Auto-Matching results. 

19. Select an item from both Resource and Task columns 

to populate the dialog windows beneath the search 

results. 

20. To confirm your Auto-Matching results, check one or 

two Resource/Task pairs to ensure the following values 

are equal: 

i. Resource Attributes→User Fields→ Task 

Location. 

ii. Task Attribute→User Fields→Task Location. 

21. Select Assign All to receive this window. Press OK. 

 
 
 
 

22. In the Task List the 3D Resources column should be 

populated for the tasks Structural Framing, Area 1-4.  

23. Select the tasks Plumb/Bold/Weld Area 1-4 and repeat steps 16-21 using the Maintain Resource Appearance Profile 

in Step 17. 

24. The 3D Resources columns for tasks Plumb/Bold/Weld Area 1-4 and Structural Framing Area 1-4 will have the same 

number of assigned Resources, respectively. (i.e. Structural Framing Area 1 and Plumb/Bolt/Weld Area 1 will have 

121 assigned 3D Resources). 
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  Adding Equipment 

In this section you will learn how to add Equipment to your SYNCHRO Project. 

One of the many benefits of 4D scheduling is the ability to visualize space allocation over time. In addition to construction 

models (buildings, sites, etc.), SYNCHRO gives you the ability to import equipment models such as concrete trucks, cranes, 

and excavators, and simulate their motion through and around the site. 

Before starting section 13, please save and close your projects and open Training Building Assigned.sp. File location: 

C:\Users\Public\Public Documents\Shared SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\ .sp Files  

The steps to do this are located in section 8.1.  

13.1. Importing Equipment Models 

SYNCHRO has a library of equipment model files that you can download for free by clicking the Equipment Library icon 

on the Support screen. The equipment models available in SYNCHRO’s Equipment Library have been optimized for use in 

SYNCHRO, but you are welcome to import your own models if desired. 

1. Select File tab → Import → 3D.  
2. Browse to locate the training models. File location: C:\Users\Public\Documents\Shared SYNCHRO Projects\Tutorial 

Files\SYNCHRO Pro Training\Models. By holding down the Ctrl key you can select multiple files for import. Select the 

following files:  

• Detailed Crawler Crane.dwf 

• Excavator.dwf 
3. Select Open, then Import. 
4. Activate Assign to a new Resource, then Next. 
5. Change the name to Equipment.  
6. Set the Resource Type to Equipment then Next. 
7. Activate Add Resources underneath, don’t build tree and select Finish.  

The equipment models will be imported to (0,0,0) and will need to be moved to the correct locations. 

13.2. Appearance Profiles for Equipment 

You can use any Resource Appearance Profile when assigning equipment models to tasks, but creating a few especially 

for equipment may improve the appearance of the 4D sequence. 

1. In Navigator → Appearance Profiles, create a new custom Profile by right clicking and select 

Add. 

2. Rename the Profile Equipment Install and ensure it is highlighted. 

3. In the General tab, ensure the Action is set to Install. 

4. In Active Appearance, enable Original Colour by checking the box next to it (or change the colour if desired) 

5. Create 2 more new Resource Appearance Profiles with these settings. 

Name Action Active Appearance 

Equipment Remove Remove Original Colour 

Equipment Temporary Temporary Original Colour 

 
These Resource Appearance Profiles may be used as follows: 

• Equipment Install: for the first task a piece of equipment is assigned to, plus any tasks where the 
equipment should remain on the site after the end of the task. 

• Equipment Remove: for tasks when the equipment should be removed from the site at the end of the task 
NOTE: Equipment Install & Equipment Remove are typically used in conjunction with each other. 

• Equipment Temporary: when the equipment is only on the site during the assigned to task – it will not be 
visible before the task starts or after the task ends. 
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  Editing 3D Objects 

In this section you will learn how to manipulate 3D objects by copying and pasting, translating, scaling, and rotating. 

SYNCHRO provides control over geometry by allowing you to move, rotate, and scale 3D objects using graphic manipulators. 

14.1. Move and Rotate (Simple Transform Manipulator) 

We need to move the Crawler Crane to the location where it will be used. To do this, we will use the Simple Manipulator, 

which gives us the ability to laterally, horizontally, and vertically move the object. We can also rotate the object around 

an axis (X, Y, or Z) using the Simple Manipulator. 

1. Unload the Excavator so that it’s not visible in the 3D View while working with the Crane. 

2. Select the Structural Framing, Area 1 task and select Plan → Focus → Center. 

3. Select the Crawler Crane in the 3D view so that it is highlighted. 

4. Right click in the 3D view and choose Edit → Transform. The simple manipulator appears on the selected item. If no 

manipulator shows up, then use M key shortcut to change between the 3 manipulators. 

NOTE: If the manipulator arrows are difficult to see or too close together, you can change the manipulator size in 

Options → 3D View → Manipulator. 

5. To use the manipulator, hover over the required arrow until it grows. Left click and drag to move the object along 

that axis. A semi-transparent preview of where the object will move to is shown. Release the mouse to place the 

object. 

6. Move the Crawler Crane to the new location as shown: 

  
7. Use the Manipulator to rotate the crane 180 degrees around the Z axis so that it is facing the building.  

 

TIP: Alternatively, the Windows ribbon→3D Properties 

window→Transform tab, can be used to rotate a selected object. For 

the crane, choose Z for the Axis to Rotate, 180° for the Angle to Rotate 

By, and Center for the Pivot Point then select the Rotate button. 

 

8. Press Esc on the keyboard to exit the manipulator and deselect the 

object. 
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14.2. Move, Rotate, and Scale (Advanced Transform Manipulator) 

In addition to the Simple Transform Manipulator, there is also the option within Edit to use the Advanced Transform 

Manipulator. This has all the features of the Simple Manipulator but has the additional options to:  

•   use plane axis movement. 

 or  

•   scale the selected object in a particular axis or overall. 

To use the Advanced Transform Manipulator, select the required icon with left mouse button, then hold and move 
mouse to either translate or scale. 

We will use the Advanced Transform Manipulator to move the Excavator to the correct location. 
1. Load the Excavator from 3D Object window. 
2. Select the Foundation Excavation task. In the Plan tab →Focus panel → Start, moves the Focus Time to the 

beginning of the excavation task. 
3. Select the Excavator in the 3D View. 
4. Right click in the 3D view and select Edit → Transform or 

use the Ctrl+M key shortcut to enable Transform mode, 
then Right click again and select Edit → Switch Transform 
Manipulator, or use M key shortcut. 
 

5. Use the Z axis translation icon (“A” in the image above) to 
move the excavator so it is sitting on top of the 
excavation surface. 

6. Use the Z axis rotation icon (“B” in the image above) or 
the 3D Properties tab → Rotate tab to rotate the 
excavator 90° clockwise. 

7. Use the XY plane manipulator (“C” in the image above) to 
move the excavator to the edge of the excavation. 
The excavator should be located as shown below: 
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14.3. Align 

Instead of manually moving the geometry to a rough location, we can use Align tab to 

precisely snap the Excavator to the top of the Excavation geometry.  

1. Select the Excavator and then select the Excavation geometry. The first selection 

defines which object will be moved to the last object selected.  

2. Go to Windows→3D Properties → Transform → Align. 

3. In the Align tab, specify the Axis to Align the Boxes (alignment is based upon the 

bounding box of the selected elements).  

4. Specify whether near side (Min) of the box or far side (Max) of the bounding box 

should be aligned.  

5. Select the Align button to align selection 

14.4. Select the Crawler Crane and assign Edit as Assigned 

The Edit manipulator must be applied to an object before it has been assigned to any 

tasks. After an object has been assigned to a task, it can be moved using the Edit as 

Assigned manipulator.  The Edit as Assigned manipulator allows you to vary the location, 

rotation, or scale of an object separately for each of the tasks it is assigned to. 

The same Crawler Crane is to be used on all four Metals → Structural Framing tasks. It 

will need to be located in a different location for each of these tasks, so we will use the 

Edit as Assigned command.  

6. Select the Crawler Crane and assign it to Structural Framing, Area 1; Structural 

Framing, Area 2; and Structural Framing, Area 3 using the Equipment Install Resource Appearance Profile. 

7. Select the Crawler Crane and assign it to Structural Framing, Area 4 using the Equipment Remove Resource 

Appearance Profile. 

8. Select the Crawler Crane and right click in the 3D window and hover over Edit as Assigned. You will see a list of the 

tasks the selected 3D Resource is assigned to. 

9. The Crawler Crane is already in the correct location for Structural Framing, Area 1, so select Edit as Assigned           

→ Task [Structural Framing, Area 2] → Transform Resource. 
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10. The Focus Time will snap to the centre 

of the task and the Manipulator will 

appear on the 3D resource. Use the M 

key to switch to the Advanced 

Manipulator, then use the XY plane 

manipulator and the Z axis rotation 

icon to move the crane to the centre of 

the active (green) section of framing 

and rotate it so it is facing the building 

as shown to the right. 

 

 

 

 

11. Repeat steps 9 and 10 for 

Structural Framing, Area 3 

(shown right): 

 

 

 

 

 

 

 

 

 

 

12. Again, repeat steps for 9 and 10 

for Structural Framing, Area 4 

(shown right): 

 

 

 

 

 

 

 

13. Beginning before the start of Structural Framing, Area 1, drag the Focus Time through all four Structural Framing 

tasks to see how the crane appears on site at the beginning of the first task, moves to a new location for each task, 

and then disappears from the site at the end of the last task.  
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  3D Paths 

In this section, you will learn how to create and edit a simple 3D path. 

3D Paths can be created to show the planned movement of a piece of equipment or other object. We will create a 3D Path to 

show the Excavator moving during the Foundation Excavation task. 

15.1. Create 3D Path 

1. Select the Foundation Excavation task. In Plan tab →Focus panel →Center. moves the Focus Time to the middle of 

the excavation task. 

2. In order to create a more accurate path, we can turn on 
Snapping. Right click in the Tool Bar under the Ribbon and 
enable the Snapping toolbar.  
 
NOTE: The Snapping toolbar can also be opened by selecting the 
Enable Snapping command in the 3D tab → Edit panel →Enable 
Snapping. 
 

3. Ensure that Enable Snapping and Snap to Face are the only 
options turned on. 

 
 
TIP: Before creating a 3D Path, click in the 3D window and press Esc on the keyboard to deselect all 3D objects. 
If an object is selected when a 3D Path is created, the first point on the path will be the center of the objects’ 
bounding box. 

 
4. Create a 3D Path, 3D tab → 3D Path panel → Create 3D Path or right click in the 3D view and select Create → 

3D Path from the context menu. 
5. As you move the cursor, object faces will be outlined in green and a green dot will preview where you can start 

the path. Move the cursor so that it is over the orange Excavation surface. Double left click to place the first 
point in front of the Excavator. 

6. Double left click at the opposite end of the Excavtation on the brown ground surface to place the second point. 
A blue line will indicate the path. 

 
NOTE: To continue adding points to a path, continue double clicking where each vertex should be 

7. Right click to finish the path. 

8. Enter Foundation Excavation for the Path Name, then select OK. 

9. The path will be listed in Navigator →3D Paths window and will be displayed in the 3D window. 
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15.2. Assign 3D Path to a Resource 

After a 3D Path is created, it must be associated with a particular Resource that is assigned to a particular task. When 

that association is made, the resource will move along the path over the duration of the assigned task. 

1. Select the Excavator in the 3D view and assign to the Foundation Excavation task using the Equipment 

Temporary  custom Appearance Profile since this is the only task the excavator will be used for 

2. Select the Foundation Excavation task, and expand Task Properties → Resources. You will see a list of the 

Resources assigned to the selected task. 

3. Expand Equipment and select Excavator.dwf at the bottom level of the Resource tree so that it is hightlighted in 

the list and in the 3D window 

4. Scroll down in the Task Properties → Resources tab to see the 3D Path panel.  

5. From the drop-down list which is currently set to <Empty>, choose the Foundation Excavation path  

6. Change the Alignment to Z Max so that the Excavator travels on top of the path. 

 

 
 

7. Click in the 3D window and press Esc on the keyboard to deselect the Excavator. 

8. Drag the Focus Time through the Foundation Excavation task to see the Excavator move along the path 

9. We can also apply a growth simulation to the Excavation so that the earth appears to be removed as the 

Excavator moves.  

10. In Navigator →Appearance Profiles, right click the Remove System Profile and select Add which will create a 

new Custom Profile with the same settings in the General tab (ie. Action=Remove and Active Appearance 

Colour=orange). Name the new Profile Excavation. 

11. In the General tab, set the Growth Simulation to Front – Back. 

12. Select the Excavation 3D object and with the Foundation Excavation task selected, in Task Properties tab → 

Resources, change the Appearance Profile to Excavation. 

13. Click in the 3D window and press Esc on the keyboard to deselect. 

14. Now as you drag the Focus Time through the Foundation Excavation task you will see the earth being excavated 

as the excavator moves. 

 



SYNCHRO Pro Basic Training: 3D Paths 

   
 

 PRO|70
  

 
Start Center End 

   
 

15.3. Edit 3D Path 

 When you create a 3D Path, each point along your path is stored as a “Keyframe”. You can edit the values of these 

Keyframe coordinates to modify your path. 

1. In Navigator 3D Paths, ensure that the Foundation Excavation path is 

selected 

2. Open 3D Path Properties from the 3D ribbon → 3D Paths panel 

3. In the 3D Path Properties → General tab, make sure the name is 

“Foundation Excavation”. 

 

4. In the 3D Path Properties → Keyframe tab, Keyframe 1 displays the starting point of the 3D Path and Keyframe 2 

displays the ending point. 
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For this tutorial, we want the excavator to travel along a straight path to follow the R-L growth for the task Foundation 

Excavation. 

 

5. Make sure your Axis Indicator is on if it is not already: In 3D View 

Properties→General→Visual Indicators enable Axis Indicator.  

6. In the 3D ribbon →Display Setting panel, uncheck the box next to 

View Cube Manipulator to ensure you are looking at the axes. As 

you can see, we want the excavator to travel along the Y-Axis.  

7. Check the box to show View Cube Manipulator again 

 

8. Below you can see the original 3D Path(left) which is at an angle to the axis vs. the desired 3D Path (right) which is 

parallel to the axis. 

 

 

 

 

 

 

We need to change the X and Z values of Keyframe 2 to equal the values in Keyframe 1 for our 3D Path to travel along a 

straight line in the Y-Axis; only the Y value should vary. 

 

9. Copy the X and Z values from Keyframe 1 and paste them over the X and Z values in Keyframe 2.  

10. Keyframe 2 should now have the same X and Z coordinates 

as Keyframe 1, but a different Y Coordinate. 

11. Move the Focus Time through the task to see the excavator 

move along the edited path. 

12. To hide the 3D Path indicators in the 3D window, disable 3D 

Paths in 3D View Properties→General→Visual Indicators. 

 

 

NOTE: You can also edit 3D Paths using the 3D Path Manipulator. In the 3D Paths tab right click 

on Foundation Excavation and select Modify 3D Path. You will see a Manipulator that you can 

drag, which will automatically update the coordinates of each Keyframe. Press the esc key in the 

3D View to get rid of the 3D Path Manipulator. 
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  Copy and Create 3D Objects 

In this section, you will learn how to copy existing 3D objects in your SYNCHRO Project, or create brand new objects within 

the 3D View window. 

16.1. Copy & Paste 

SYNCHRO gives you the ability to copy and paste any object regardless of whether it was created in SYNCHRO or 

imported. This can be useful if you decide to add duplicate objects such as site offices or equipment after the model has 

been imported. 

As an example, suppose it is decided that an extra site office is needed to accommodate the BIM team, but this office 

was not included in the original geometry file.  We can simply copy one of the existing offices and move it to the new 

location. 

1. In the 3D Filters → 3D tab, select Clear All to hide all objects, then show the Site file.  

2. Select the tasks Field Office & Temporary Hard Standing, then right click on one of the tasks to Select Assigned 

Resources:  

 
3. Right click in the 3D view and select Copy from the context menu. 

4. Right click again and select Paste. 

The copied site office & temporary hard standing will be created in the same location as the original site office 

and we will need to assign it a resource. 

5. The Resource Wizard is displayed. Select Assign to a new Resource, then select Next 

6. Rename BIM Office, change the Type to Material, and then select Next. 

7. Select Assign to this Resource, don’t build tree, and then select Finish. 

The copied site office will appear in the same position as the original one and we will need to move it to a new 

location. 

8. With the BIM Office still selected, right click in the 3D view and choose Edit → Transform 
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9. Move the new office to a new location as shown: 

 
10. Press Esc on the keyboard to exit the manipulator and deselect the object. 

11. Use the Install Appearance Profile to assign the BIM Office to the Field Office task. 

16.2. Creating Objects 

SYNCHRO is not a CAD authoring tool, but it does provide the ability to model a few simple objects (sphere, cylinder, box, 

and irregularly shaped extrusion). This can be useful to quickly model temporary site logistics such as material laydown 

areas. 

There is no 3D object for the Temporary Roof at Skylight task so we will create one in SYNCHRO. This will sit over the top 

of the opening on the high roof. 

1. In the 3D Filters → 3D tab, select Clear All to hide all objects, then show Roofs in the Architecture file. 

2. Move the Focus Time to the end of the project so all the objects are shown. 

3. We will ensure the correct snapping options are enabled. Snapping allows for precise input of object geometry. 

Disable all functions except for Enable snapping & Snap to vertex. 

 

NOTE: To see the uses of other Snapping Functions, please visit the 

SYNCHRO Help file. To access the help documentation, select Help in the 

upper right corner of the screen or Navigator tab → Options → Help. 

 

4. Right click in 3D View and select Create → Box. 

5. In the 3D window move the cursor to the corner until the red marker appears (as shown below) and left click to 

define the first corner. 

6. Then move the cursor to the opposite corner until the red marker appears and left click again to define 

width/length, then move the cursor up the define a height.  
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7. Enter 3D Object Name… appears - change New Box to Temporary Roof. Select OK 

8. At the Resource Wizard screen select Assigned to a New Resource, then Next. 

9. At the Enter Resource details screen, select Next. 

10. At the Resource Creation screen, select Assign to this Resource, don’t build tree, and select Finish. 

11. Select the Temporary Roof in the 3D View, right click and select Edit → Colour. 

a. On the Standard tab, you can simply change the colour or use Select to pick a colour from an object in 

the 3D window. 

b. On the Custom tab, you can change the colour and transparency by using the sliders to the right or 

the numeric entry. 

  
12. In the Standard tab, change the colour to a light blue 

13. In the Custom tab, disable Use original transparency and set the transparency to 50%, then select OK. 

14. Click in the 3D View then press Esc on the keyboard to deselect the box and see the colour 

15. Select the Temporary Roof object and assign to the Temporary Roof at Skylight task using the Install Resource 

Appearance Profile. 
 
NOTE: Even though the roof is temporary, we are using the Install Profile because the task is for the 
installation of the Temporary Roof. The Temporary Roof will be assigned using a Remove Profile to remove 
the Temporary Roof when the Skylight is installed. The Temporary Profile should be used only when an object 
is used exclusively for the duration of the task it is assigned to. 
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  Synchronising 3D Models 

In this section, you will learn how to synchronise from an updated 3D Model file, check for new objects and assign them to 

tasks after synchronising. 

When a design revision is made outside of SYNCHRO, it is possible to modify the 3D Models and still retain the assigned links 

between the tasks of the schedule and the objects of the model. This is called synchronising. 

17.1. Optimizing 3D Synchronisation 

In order to retain the previously established links between the current model and the project schedule inside of 

SYNCHRO upon synchronizing the updated model file with the current SYNCHRO Project, the updated model needs to be 

prepared to accommodate the design revisions. For optimal results, follow these four guidelines. 

1. Export – All the objects that were originally imported into SYNCHRO will need to be exported from the CAD system 

again. Any objects that are deleted in the updated CAD file will be deleted in SYNCHRO upon synchronisation. 

2. Import – All new objects will import into SYNCHRO when you synchronise, but they will need to be assigned to tasks. 

3. GUIDs – All modified 3D data needs to have the same name and Global Unique ID (GUID) number so SYNCHRO 

recognizes it as the same item and will retain its assignment. GUIDs are created automatically by the CAD authoring 

system (or SYNCHRO plugins). 

NOTE: You can change the geometry of an object as long as you don’t delete it and then recreate it, which would 

assign a new unique ID, making it impossible to synchronise with the original object using GUIDs. Splitting an object 

into parts in the CAD system creates separate objects with new ID numbers, which will need to be assigned after 

synchronisation. An alternate user-defined unique identifier (e.g. unique part number User Field assigned in CAD 

authoring tool) can be used to synchronise instead of GUID if desired – this may be useful if the 4D model is 

advancing from early concept stages to later detailed stages and much of the geometry is being recreated or split – 

see the Help in SYNCHRO Pro for more information. 

4. File Name – You can export the updated files from the CAD program with any file name, the original and revised 

models do not need to have the same file names for synchronisation. 

TIP: If an object has been subdivided in SYNCHRO, those subdivisions will remain as long as the object ID in the CAD 

file is unchanged. 

17.2. Synchronising 3D Models 

1. To begin synchronisation, select the Navigator tab → Project Data panel →External Data. 

NOTE: In the General panel, details about the original and last updated files can be checked.  

2. Right click on [Architecture.dwfx] [Import] [mm/dd/yyyy] and select Synchronise From. 

3. Browse to ArchitectureUpdated.dwfx, select Open and then Next.  File location: C:\Users\Public\Documents\Shared 

SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\Models 

4. When synchronising a 3D Model, you will be presented with the same import settings that were set when you first 

imported the file. These settings should match the initial import settings in Section 5.1. 

5. Select the synchronise button. 
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17.3. Identifying 3D Object Changes 

After Synchronization, a report will appear summarizing the changes 

made (shown right). From this Synchronisation Report, we can see: 

a. 3D Objects have been deleted, (Notice: there are more old 

3D Objects than new). 

NOTE: When a 3D Object is deleted upon Synchronisation, 

the Object is removed from any Tasks it was assigned to.  

b. 65 Resources have lost their (3D) representations. 

NOTE: This does not necessarily mean the associated 3D 

Objects were deleted; they may have been merged with 

other 3D Objects in the CAD file. 

c. No 3D Object Subdivisions were lost. 

d. 3D Objects that were deleted or merged in the CAD file are 

shown under Unmatched 3D Object names. 

6. Check to “Create Resources for new 3D Objects (as sub-tree)” to 

automatically create Resources for new 3D Objects and put those 

resources in the existing resource tree. (Located at the bottom of 

the dialog). Select OK. 

7. In Navigator tab → 4d Visualization panel → 3D Filters tab → 3D tab, select to only show ArchitectureUpdated.dwfx 

8. Drag the Focus Time back to the beginning of the project. 

9. Right click in the 3D window and select Zoom → Zoom All. 

10. You should see the below 3D Objects floating in mid-air. These 3D Objects were added during Synchronisation and 

have not yet been assigned to tasks. 

NOTE: Any 3D Objects that have been added during 

synchronisation will not automatically be assigned to tasks. 

The easiest way to locate these objects is to go to the 

beginning of the project before anything has been 

installed. 

For the purposes of this tutorial, please assign the exterior 

walls to the task Exterior Metal Siding/ Backup Framing 

(Right) and the exterior doors to the task Exterior Doors, 

Frames, Hardware. 

11. Select the windows and assign them to the task Punched Windows (Right). 
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12. Right select the Punched Windows (Right) task in the Gantt chart, select Focus Time on Task → Center. You should 

see the following: 

 

The new 3D Objects created during synchronisation have 

been correctly assigned, however this does not account for 

all 3D Object modifications that resulted from 

synchronisation. Remember, only 11 Objects were deleted, 

but 65 Objects lost their Resource assignments.  

 

 

 

 

 

 

 

Let’s compare the same section of the model before and after synchronisation. (For the purposes of this tutorial, 
please use the images below for this comparison). Notice below: 

 

i. In the Original Model (above left) there are 4 window pane sections (top & bottom) 
ii. In the Updated Model (above right), there are only 3 of these window pane sections (top & bottom). 

 
SUMMARY: The merging of the 2&3 window Pane sections accounts for the 3D Objects the recorded as deleted in the 
Synchronisation Report. If you select the individual Window Panes, as well as the metal borders, you will see that one 
window pane section is comprised of multiple 3D Objects. Ultimately, if the Synchronisation Report records deleted 3D 
Objects, this does not necessarily mean the Objects no longer exist.  
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  Baselines & Synchronising Schedules  

In this section, you will learn how to create a baseline of a current schedule and compare different schedules in side-by-side 

3D windows. You will also learn how to Synchronise from an updated schedule. 

One of the benefits of SYNCHRO is the ability to quickly and easily bring in updates from an external scheduling program and 

see those changes reflected in the 4D model. If changes or progress updates have been made to the original source schedule; 

e.g. in P6 or Microsoft Project, the updates can be brought into SYNCHRO using the Synchronise From command in Navigator 

ribbon → Project Data panel → External Data. This process is similar to Synchronising an updated 3D model file. 

Before synchronising from the updated schedule, a Baseline (or copy) of the current schedule can be made in SYNCHRO. A 

baseline can be used to compare planned against actual in SYNCHRO. The Baseline saves the dates and durations for all 

selected tasks. After creating a Baseline, it can be displayed in the Gantt Chart in a separate colour. Additionally, the Baseline 

Start and Baseline Finish dates can be viewed in the Task List. 

18.1. Creating a Baseline 

1. To create a baseline, you have the option to select certain tasks to be baselined – this allows you to create a 
baseline of only part of a schedule if desired. To baseline the entire schedule, right click in the Task List and choose 
Baseline Tasks from the context menu. 
 

2. When the following message appears, select Yes to calculate the Critical Path. 

 
3. The following dialog will appear. Choose Baseline all Tasks and then OK.  

NOTE: The second option would result in a selection that excludes tasks hidden by a filter or a collapsed summary 
task. 
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4. In the current schedule, the critical path tasks are white outlined in red, whereas tasks not on the critical path are 

solid green as shown below. The Baseline is directly over the current schedule, with critical tasks in solid blue, and 

non-critical tasks outlined in blue but hollow. 

 
 

5. To turn off the Baseline display in the Gantt Chart go to the Plan tab 

→ Display panel → Gantt Display Options →  

un-check Baselines and then OK 

   

6. To turn off the Critical Path display, toggle off Compute Critical Path in 

the Plan tab →Schedule panel → Compute Critical Path. 
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18.2. Synchronising Schedules (Programmes) 

 To begin Synchronisation, select the Navigator tab → Project Data panel →External Data.  
 
NOTE: All files imported or exported will be listed here. If you’ve imported multiple schedules, make sure you 

select the correct one. 
 

 Right click on [Training Project Schedule.xml] [Import] [dd/mm/yy] and select Synchronise From. 

 Browse to Training Project Schedule Updated.xml, select Open then Next.  File location: 

C:\Users\Public\Documents\Shared SYNCHRO Projects\Tutorial Files\SYNCHRO Pro Training\Schedule 

  When Synchronising a schedule, you will be asked to choose Synchronise, Consolidate, Integrate, or Skip for 

each of the different schedule attributes.  

 

 

NOTE: Schedule attributes are located in the Object 

column (shown left) and include: Tasks, Links, Task 

constraints, Costs, Calendars, Resources, Resource 

Assignments, Codes assignments, User Fields, and 

User Field values. 
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The Synchronisation options (Synchronise, Consolidate, Integrate or Skip) are explained in the chart below. 

 

SYNCHRONISE 

If you choose to Synchronise, the existing schedule in SYNCHRO will be completely replaced with the updated external schedule.  

Outcome: External schedule takes precedence over SYNCHRO schedule when synchronising according to the following rules: 

• Attributes ADDED externally → ADDED in SYNCHRO 

• Attributes DELETED externally →DELETED in SYNCHRO 

• Attributes MODIFIED externally → MODIFIED in SYNCHRO 

• Attributes ADDED or MODIFIED in SYNCHRO → OVERRIDDEN 

NOTE: The option to Synchronise is not available for P6 global objects (such as Calendars, Resources, Risks and Activity Codes) 

since these cannot be deleted.  

CONSOLIDATE 

If you choose to Consolidate, any schedule changes made externally or in SYNCHRO will still exist, NOTHING IS DELETED. 

Outcome: Merges the External and SYNCHRO Schedules when synchronising 

• Attributes ADDED externally → ADDED in SYNCHRO 

• Attributes MODIFIED externally → MODIFIED in SYNCHRO 

• Attributes ADDED or MODIFIED in SYNCHRO → MAINTAINED 

INTEGRATE 

If you choose to Integrate, any modifications made to the selected external schedule in SYNCHRO will be overridden. However, 

any additions to the schedule in SYNCHRO will be maintained.  

Outcome: External schedule takes precedence over SYNCHRO schedule for all Attributes not originally created in the external 

schedule. 

• Attributes ADDED externally → ADDED in SYNCHRO 

• Attributes DELETED externally → DELETED in SYNCHRO 

• Attributes MODIFIED externally → MODIFIED in SYNCHRO 

• Attributes ADDED in SYNCHRO → MAINTAINED 

• Attributes MODIFIED in SYNCHRO → OVERRIDDEN 

NOTE: Integrate only affects schedule attributes associated with the selected schedule being Synchronised.  Thus the option to 
Integrate is most commonly used when multiple schedules have been imported into SYNCHRO so no project data is lost upon 
Synchronisation. Integrate is the default choice for Resources and Resource Assignments. The option to Integrate is unavailable 
for Microsoft Project XML. 

SKIP 

If you choose to Skip, the associated attribute will not be modified or updated. 
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Use the following flowchart to determine whether to Skip, Synchronise, Consolidate, or Integrate each attribute. For each 
attribute (eg. Links, Calendars, etc.) substitute the attribute name wherever “[tasks]” appears in the flow chart. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

SUMMARY: Any attribute that you have added or modified in SYNCHRO since importing will need to be considered. For 

example, if you have not created any tasks, calendars etc. in SYNCHRO but have just created Resources and Resource 

Assignments, those are the only two options that you will be required to Consolidate or Integrate instead of Synchronise 

to ensure that Synchronisation works correctly and that all assignments are retained. 

See "Appendix F: Synchronisation Scenarios" for further information and to test your knowledge of these options. 

Do you wish for changes to 
[tasks] in the source 

Program to override the 
corresponding values in 

the SYNCHRO file? 

No 
Skip 

Yes 

Has more than one 
schedule been imported to 

the SYNCHRO file? 

Yes 

Integrate 

Have you added any new 
[tasks] in the SYNCHRO 

file? 

No No 
Synchronise 

Yes 

Were [tasks] deleted in the 
source Program? 

No 
Consolidate 

Yes 

Do you want the [tasks] 
that were deleted in the 

source Program to be 
deleted in the SYNCHRO 

file as well? 

No 

Yes 

Start 
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 Since we have added new tasks and links, created resources from 3D 

objects, and assigned resources to tasks, we should not use 

Synchronise for these options or else the changes made in SYNCHRO 

will be overridden with the changes in the Training Project Schedule 

Updated.xml. We can Skip attributes that are not contained in the 

schedule. Select Skip All, and then set your Synchronisation options as 

shown. Integrate will merge updates from the XML with new tasks 

created in SYNCHRO.  

 
 Select the Synchronise button. 

 The Synchronisation Report indicates what has been updated. You 

can save this report for future reference if desired by selecting Select 

All followed by Copy to Clipboard. 

 Select Finish to exit the report. 

 

 

 

 

The Data Date has been updated (as indicated in the Gantt Chart 

by the blue dotted line) 

 Select F9 on the keyboard to access Rescheduling Options. 

Ensure that Schedule From is set to Data Date. You can also view 

the new Data Date. 

 Press Reschedule to update the tasks that were created in 

SYNCHRO 
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 In Navigator → Baselines and Scenarios, select the Original Schedule to display it in the Gantt Chart and see how 

the schedule has changed.  You can see that the Notice to Proceed has been delayed about a month, lag has 

been added between Award Subcontractors and the Material Procurement tasks have been updated for actual 

Progress. 

 

18.3. Compare Baselines using 3D Views 

In addition to seeing the changes to the baseline in the Gantt Chart, it is possible to visually compare the baseline against 

the updated schedule in side-by-side 3D windows.  Each open 3D Window can independently be set to use either Best, 

Actual, Planned, Proposed, Baseline or Original dates. This allows for the comparison of different baselines, baseline vs. 

planned, baseline vs. actual, actual vs. planned, etc. 

 From the Windows ribbon→ Common panel select 3D to create another 3D View (which is typically 
positioned above the first 3D View). 

 Left click in the title bar of the new 3D window and drag the new 3D window over the first 3D window, 
and release the mouse button over the right side of the smart window placement icon. 

 A preview of where the window will be placed will be shown before you drop it in place. 

 Right click one of the 3D views and select Camera → Link All so that the camera angle in both windows is the same. 

 Modify one of the 3D views so that you can see the whole building. 
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 →Left-click in the first 3D View to select it. Then in 3D View Properties → General→Dates & Colours, set Dates to 

Use to Baseline. From the Baseline field below, select Original Schedule. This will display the geometry in the 

window according to the baseline dates. The other window should be set to Dates to use → Best Dates by default 

which will show the current schedule. 

 Move the Focus Time through the Project to review how the new schedule (below right) compares to the baseline 

(below left). The Dates to Use setting for each window is displayed in the window title bar. 

 
 Click the “X” in the top of the 3D window using Baseline dates to close it. 
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  Cutting Planes 

In this section you will learn how to create a cutting plane, which allows you to see a section or plane of your model in the 3D 

Window. 

Cutting planes may be used for example, to view inside of a building or underground when working in SYNCHRO, when 

playing the Focus Time, or when exporting an animation. 

 Ensure that the Focus Time is at the end of the Project and all objects are shown. 

 Right click in the 3D window and select Cutting Planes → Cutting Plane Z. 

 Left click to place the cutting plane on the roof which will appear as shown below.  

 

NOTE: To set a Cutting Plane, you must click on an object, not in empty space. 
 

 A simple manipulator appears. Move the cursor over the manipulator until the vertical icon ‘grows’ then hold 

down the left button and drag the cutting plane up and down in the Z direction, so that you can see into the 

Level 1 space. 
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 In the 3D View Properties window → Cutting Planes tab, notice the New Cutting Plane listed. 

 Left click on New Cutting Plane and rename it to Office Z. 
 The plane can be turned on/off by enabling/disabling the check box. 
 The Show Plane and Show Manipulator check boxes allow you to hide 

these visual indicators in the 3D view, while still applying the cutting plane. 

This may be useful when exporting an animation, for example.  

 Right click on Office Z and you will see the following options. 

         

 Select Invert Direction to change the direction of the cutting plane.        

 

 Invert Direction once again to revert back. 
 NOTE: X and Y cutting planes can also be created, cutting planes can be rotated off-axis, and multiple cutting 

planes can be applied simultaneously using a Cutting Box. Right click in the 3D window and select Cutting Planes 

→ Cutting Box.  Left click to draw the opposite corners of a square and then a third time to define the height. A 

cutting box is created which can be edited using the manipulator shown 
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  Viewpoints 

In this section, you will learn how to create and save a Viewpoint. 

Viewpoints can store Focus Time, Camera Angle, and 3D View Properties including applied 3D Filters, and Cutting Planes. A 

saved Viewpoint can be reactivated at any point in one or all 3D windows. This can be useful for returning to a particular time 

or view after updating a schedule or model to see what has changed, or to quickly jump to points of interest when presenting 

to stakeholders. 

 Adjust the camera angle to a desired view and move the Focus Time to a particular moment in time. 

 Right click in the 3D window and choose Viewpoints → Save Viewpoint 

 

 A dialog will be raised. Change the name to something descriptive 

 Press 3D View Property Details… to open a second dialog to choose which properties to save with the Viewpoint. 

For properties not saved with the Viewpoint, the current property will not be changed when the Viewpoint is 

applied. This can be useful for example if you want to save only a camera angle (e.g. the location of a webcam on 

the site) and return to it many times, or if you want to save only the 3D View Properties that you like to use for 

presenting review sessions.  

 When finished, press OK 

 This will create a new viewpoint in Navigator ribbon →Viewpoints window 

 To see how Viewpoints work, change the Focus Time in the Gantt Chart, and then edit camera angle and turn off 

the Cutting Plane in the 3D window. 
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 To return to the saved Viewpoint, in the Navigator ribbon →Viewpoints 

window simply double click on the Viewpoint name, or select the Viewpoint 

name and press the Activate in selected 3DView button located below the list 

of Viewpoints 

 

NOTE: If you update the Camera Angle, Focus Time, or any of the 3D View 

Properties and wish to resave with the new values, select the property you 

wish to update and then press the button as shown below - 

 

 You can turn on/off any of the features for a selected viewpoint under 

Controlled 3D View Properties. 
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  Animations 

In this section, you will learn how to create and edit an animation and export it to a video. 

Having created your 4D schedule within SYNCHRO it is also possible to create a scheduling animation that can be 

communicated to third parties or exported as a video and used as presentation material (without the need to install 

SYNCHRO). Animations can show an overview of the whole project, or you may prefer to create an animation that focuses on 

a few tasks or a few days of construction (e.g. a particularly complicated sequence). Animations can also be used to export a 

series of still images and tables over a period of time for inclusion in a report. 

21.1. Creating an Animation 

For practice, we will create a basic overview animation that spans the entire duration of the project with a camera that 

slowly spins around the outside of the building. 

 In order to avoid clipping the sides of the view when exporting the animation, set the 3D window to roughly the 

same aspect ratio as the desired output before creating the animation. To do this, undock the 3D window by double 

clicking in the header bar or left clicking and dragging. 

 In 3D View Properties → General, expand 3D Window Size and set the Width to 800 and Height to 450 (or 

approximately 16:9 ratio to suit the size of your screen). 

 From the 4D Review ribbon→ Animations panel open the Animations window. In the Animations window, right 

click and select Add to create a new animation. 

 Select the New animation, right click to rename it Site Tour and ensure that it is highlighted. 

 From the 4D Review ribbon → Animations panel, open the Animation Editor. 

 Move the cursor into the Animation Editor (do not left click!) and roll the mouse wheel to rescale to the 

required timescale, in this case 30 seconds.  

 

Animations are made of a series of Keyframes which define the viewpoint (camera-angle, position and zoom) and 

contents (Focus Time), and 3D View Properties of the 3D window at a given point in time within the Animation. 

A Keyframe is added by left-clicking in the Camera, Focus Time, or 3D View Properties channels in the Animation 

Editor. The added Keyframe records the current settings of the camera, Focus Time, or 3D View Properties. Camera 

Keyframes are marked by a blue diamond in the Camera animation channel. Focus Time Keyframes are marked by a 

yellow diamond. 3D View Properties Keyframes are marked by a brown diamond 

 To define the start of the animation; move the Focus Time in the Gantt Chart to just before the start of the project. 

 Left Click in the focus time channel of the animation editor at 0 sec. A yellow Keyframe marker  will appear. 

 To define the end of the animation move the focus time in the Gantt chart to just after the end of the project. 

 Left Click in the focus time channel in the animation editor at 30 sec. Another yellow Keyframe marker  will 

appear. 

 Select and drag the red Focus Time Marker in the animation editor to review the stored timeline. This can also be 

done with the options in the 4D Review ribbon →Play Mode panel→Play Animations. Then in the Player panel click 

Move to Start followed by Play. 
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 Modify the 3D window to show the entire site as shown. 

 

 To create a Camera viewpoint left click in the camera channel of the animation editor at 0 sec. This defines the 

view at a particular point in time. A blue Camera marker  will appear.

 
 Move the Focus Time Marker in the Animation Editor (not the Gantt Chart) forward to about 5 seconds. 
 Modify the 3D view by zooming into the work area as shown.  

 
 Left click in the camera channel of the animation editor at 5 seconds to set this view at this time.  

 

 Move the Focus Time Marker in the animation editor forward to 10 seconds. 
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 Modify the 3D view by orbiting around to the side of the building as shown. 

 
 Left click in the camera channel of the animation editor at 10 seconds to set a view at this time. 

 Repeat steps 17 – 19 four times in order to orbit around the entire building setting camera points every 5 

seconds. 

 Review the animation by dragging the Focus Time Marker in the animation editor or by going to the 4D Review 

ribbon →Play Mode panel →Play Animations. Then in the Player panel click Move to Start followed by Play. 

TIP: Click in the 3D window, then press the space bar on the keyboard to play and stop the Animation. 

 

TIP: The 3D View Properties channel can be used to change the 3D View Properties during an animation, for 

example, to turn off and on Cutting Planes, Legends, or 3D Filters. To learn more about using the 3D View 

Properties channel, refer to SYNCHRO Help (F1). 

21.2. Editing the Animation 

After reviewing the animation you may find that you need to edit some of the camera angles. 

 In the Animation Editor (not the Gantt Chart), move the red Focus Time line to the Camera keyframe you want 

to edit 

 Right click on the blue marker  in the camera channel and select Snap To Viewpoint. 

 Modify the 3D window to get the desired camera angle. 

 Right click on the blue marker  in the camera channel and select Use Current Viewpoint.  

NOTE: Snap to Focus Time and Use Current Focus Time work similarly. 

      You can also edit the animation by adding more points.  

 Drag the Focus Time line in the Animation Editor to 

a point in time in the middle of two of the camera 

nodes. 

 Modify the 3D window accordingly. 

 Left click in the camera channel of the Animation 

Editor where the Focus Time Marker intersects the camera channel. 

Sometimes long tasks or gaps in the work may want to be condensed to speed them up and short tasks expanded to 

slow them down. If this is the case then this can be done in the Focus Time channel.  

 Add additional Focus Time Keyframes at the beginning and end of a sequence you want to speed up or slow 

down. (i.e. add Keyframe 1 at the beginning of a task and Keyframe 2 at the end of a Task) 
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 To move a Keyframe, hover over it until a double arrow appears. Left click and hold while dragging to move.  

Move Focus Time Keyframes closer together to speed up the activities in between. Move them farther apart to 

slow down time in the animation.  

NOTE: If you move a Keyframe and want following Keyframes to move with it, hold down Shift when you are 

moving the Keyframe.  

TIP: If many Keyframes appear to be overlaid, scroll the mouse wheel forward to zoom in on the timeline. 

21.3. Interpolation 

At the end of the animation you may want to rotate the project for a final overview (or you can use this feature at 

any time in your animation). This is achieved using a Turntable camera interpolation. 

Interpolation defines how the Animation transitions between 

Keyframes. The term interpolation is used to describe the transition 

from one state to another, which for a Camera is from one position 

and angle to another, or for Focus Time is one point in time to 

another. The Interpolation Type dictates how the transition is 

achieved and includes Curve, Line, Step, Turntable, and 3D Path 

options. By default, Interpolation Type is set to Line. 

The different Interpolation Types are explained in this chart: 

 

 

 

Interpolation 
Type: 

Camera Behaviour: Focus Time Behaviour: 

Curve Linear interpolation along a calculated curve 
between the 2 points. 

N/A 

Line Linear interpolation along a calculated 
straight line between the 2 points. 

Linear interpolation 
between 2 focus time 
positions 

Step No interpolation; Jump from 1st to 2nd 
position. 

No interpolation; Jump 
from 1st to 2nd focus time 
position 

Turntable Camera rotation around the currently 
selected 3D object. When chosen, the 
Turntable Options dialog is displayed to 
configure the rotation. 

N/A 

3D Path 
Camera follows the selected 3D Path using the 
camera angle of the first Keyframe relative to the 
path. When this Interpolation type is chosen a 
dialog is displayed to choose the path to follow. 

N/A 

NOTE: Interpolations are always between two neighbouring Keyframes. The interpolation type assigned to the 
first (left) Keyframe defines the transition to the next(right) Keyframe. 
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1. To set up a Turntable interpolation, select an object in the 3D View that you want to rotate about. The camera will 
rotate about the centre of the selected object’s bounding box.  

TIP: If you want to spin around the entire 

model, select an object that is central to 

the model or spans the whole model 

(e.g. the Glass Skylight).  

 

 

 

 

2. Find the Glass Skylight task in the Task List, right click to Select Assigned Resources. 
3. Right click on the Camera node at 30 seconds and select Interpolation Type →Turntable. 
4. You will be presented with the Animation Turntable Options where you can decide on Rotation degrees, Direction 

and move the Preview bar to review. Keep the settings as default then select OK. 

5. Decide how long you want the rotation to last for- we will have this for 10 seconds so create another camera point 
at 40 seconds in the Animation Editor. 

 

6. Press Escape to cancel the 3D selection. 

7. Move the Focus Time to 30 seconds in the Animation Editor and press Play in the 4D Review tab →Player panel to 
see the effect of the Turntable. 
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21.4. Exporting an Animation 

Once an animation has been created, it can be exported as an AVI file which can be shared and played by a video player 

on any computer. 

TIP: Before the animation is exported it is recommended that a small duration of a few seconds is added to the end. 

Otherwise it will snap back to the beginning once it’s been exported. 

1. Drag the Focus Time Marker to the end of the animation and Left Click in the focus time or camera channel of the 

animation editor at about 45 Seconds. (This will add 5 seconds to the end of the animation). 

2. At this point it’s typical that the Axis Indicator, Grid, and 3D Path are switched off. In 3D View Properties → General 

→ Indicators and uncheck the box next each one to turn them off. 

3. If you wish to include a 3D Legend in the exported Animation, you may edit it in 3D View Properties → Legend. For 

this training: 

i. Enable Show Legend 

ii. Change Location to Top-Left 

iii. Next to Appearance Profiles to include in Legend, uncheck the box for 

All, then enable only Install and Remove in the list below 

4. Select the Animations window, right click on the “Site Tour” animation and select 

Export Animation. 

5. Create a new folder named Site Tour. Open the folder and press Save. 
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21.4.1.  AVI Resolution 

6. You will be presented with the Export Animation window with Resolution options shown: 

7. For the purposes of this tutorial, please use: 

i. Resolution – (1920x1080) 

ii. Frame Rate – 25 [the number of images per second], 

NOTE: The higher the frame rate, the better the 

quality of the video, but it does take longer to export. 

A good frame rate is 25. A frame rate of 15 is 

sufficient for a test export 

iii. Duration – Split every 0 Seconds  

NOTE:  The maximum AVI file size is 2 GB. For long 
animations, or those with high frame rate, splitting 
the video ensures that the files will not exceed this 
limit. Splitting the video (e.g. every 10 – 30 seconds) 
will also allow you to re-export sections of the AVI if 
you have changed your project. Sections will need to 
be stitched together in a video editing tool 

iv. Compression – Codec: x264vfw - H.264/MPEG-4 AVC codec (If it is not already set to this please select Change) 
 
NOTE: This Codec can optionally be installed using the SYNCHRO Pro installer 

NOTE: You also have the option to export the Animation in an image format (PNG, JPG, or BMP). Frame rate will 

determine how many image files are created per second. You can combine the images in an Animation software 

package if required. If you want to export to a series of image, enable the checkbox Export the animation as a series 

of images with given quality and choose what image quality you wish to use (for JPG only). 
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21.4.2. Animation Content 

In the Content tab, you can choose what to display in the animation.  

8. Select the Content tab. 

TIP: You can resize the size of the Export AVI window by moving the cursor to the edges, holding down the left 

mouse button, and dragging to suit. A larger window may make it easier to edit the window contents. 

9. Select 3D Using Dates, Focus Time, and Timeline then resize and move them in the preview window. If a window is 

hidden behind another window, select the hidden window in the list on the left and use the up arrow button to 

move it before the other window in the list – the windows are listed in order of precedence, front at the top to back 

at the bottom. 

NOTE: At the top of the screen is a Preview slider which you can move to check your animation before export. 

 

10. From the list, right click on Focus Time and choose Properties, then uncheck 

the box for Background and set the Border to 0, then press OK. The Focus Time 

background will look blue, but press the Preview button to see the final output.  

 

TIP: You can edit the format of the Focus Time window in the Export Animation 

→Focus Time tab  
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11. Select DirectX 11 from the Render with dropdown box. 

NOTE: The Driver options in the drop-down menu depend on which drivers you have installed on your computer. 

Software will use the SYNCHRO driver to export the AVI. Choose Direct X 11 if you plan to use effects like shadows or 

textures. 

12. Set Anti-Alias to 4x and check the box to Enable Software 

NOTE: Anti-aliasing increases the quality of the output, but increases the time it takes to export.  

13. Other Content options: 

i. Lock update of the window content – this enables you to modify the size of the windows without it trying to 

render every time. Unlock this to see the true view after movement, resizing etc. 

ii. Keep aspect ratio of 3D views - enables same aspect ratio as the main 3D windows you created earlier. (16:9 

aspect ratio in this case). 

iii. Iray Options – available with a separate Iray license, rendering with Iray will provide a much higher quality 

output. 

14. Select OK in the Export AVI window. 

15. After each AVI has completed exporting, double click the file to play the video  

16. Close the Animation Editor window by clicking the “x” in the upper right window corner. 

17. Double click on the 3D window title bar to re-dock the 3D window. 
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  Output 

In this section you will learn how to save a Viewpoint as an image, how to print from the Gantt Chart, and how to export the 

Gantt Chart to a PDF. 

22.1. Save as Image 

You can easily save an image of the 3D window to share with others. There are 2 ways to save an image. 

1. If you have a saved Viewpoint that you would like to export as an image, in the Viewpoints window, select the 

Viewpoint name, right click and choose Save as Image. 

2. Name the file and choose the file type (PNG, BMP, or JPEG) from the drop-down list. 

3. The Save as Image dialog will appear. There are options to change the image size (or keep it the same as the 3D 

window), set the graphics driver Type, Antialiasing (higher values improve quality), and apply Effects including 

Shadows. 

NOTE: The OpenGL driver does not support Effects. 

 
4. Set the options as desired and press OK to save the image. 

5. You can also save an image of the current 3D window without first creating a Viewpoint, by right clicking in the 3D 

window and choosing Save as Image from the context menu. 
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22.2. Printing the Gantt Chart 

The Gantt Chart can be printed from SYNCHRO to share with others without the need to share the SP file.  

1. When printing the Gantt Chart, what you see is what you get, 

so use Customise Columns in the Task List to choose which 

columns to include in the printout. 

2. Expand or Collapse the WBS and adjust the Gantt Zoom as 

desired before printing 

3. Before printing, set up the printer and page layout by 

selecting File tab → Print Setup. 

4. For printing the Gantt Chart, set the Orientation to 

Landscape. 

5. Set the Paper Size for printing as desired e.g. Tabloid     (11” x 

17”). 

6. Press OK to finish setup. 

7. Select File tab →Print. 

8. In the Print dialog, choose the Layout tab. 

9. Ensure that View to Print is set to Gantt. 

 

NOTE: From the View to Print drop-down you can also 

select other open windows to print including 3D. 

 

10. When printing the Gantt Chart, Fit to Exactly: 1 is a good 

choice for the Horizontal pagination and Fit to: Actual Size 

for Vertical pagination. 

11. A Date Range can be applied to the schedule if desired 

(eg. to export a 3 week look ahead). To print the whole 

schedule, leave this option disabled. 

12. Select Apply to save changes to this dialog before 

previewing or printing. 

13. If desired, a Header, Footer, and/or Legend can be added 

to the printout in the Legend tab. 

14. Select Preview to view the Gantt Chart before printing. 

15. From the preview window, select Print to return to the 

Print dialog. 

16. Select Print. 
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17. The printout will look similar to below: 

22.3. Export 3D PDF 

SYNCHRO gives you the ability to export a 3D View of the project as a 3D PDF, which can be manipulated in any PDF 

compatible programs, such as Adobe Reader. This can be used to share the 3D Model with others electronically without 

having to share the SYNCHRO Project file. 

1. Move the Focus Time in the Gantt Chart to show any view you would like to export. 

2. In File tab, select Export → 3D. 

3. In the Export 3D window, select Browse to choose where you would like to save your 3D PDF. 

i. Choose a file name. 

ii. Set “Save as Type” to 3D PDF(*.pdf). 

iii. Select “Save”. 

4. Select the following Options 

i. Export Mode: Export in accordance with the current Focus 

Time. 

ii. Dates to use: Best. 

iii. Check: Take into account global 3D Filter.  

NOTE:  By enabling Global 3D Filter, you will only export 3D Objects that 

are loaded in the project in the 3D Objects tab. 

5. Select Export. 

NOTE: You cannot export an animation in 3D PDF format. 

6. When the 3D PDF has finished exporting, open your file inside of a PDF 

compatible program to view the 3D Model. 
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22.4. Schedule Health Check Report 

SYNCHRO Pro has the ability to run a health check report on a Project. This runs a series of 11 tests and provides a 

schedule showing any Missing Resources, Missing Logic, Missed Tasks etc. The Schedule Health Check report is based on 

the first 11 points of the DCMA 14-point Assessment. 

1. To run a health check report on a project, in the Reports tab → Schedule panel → Schedule Health Check. 

2. The Report can be printed or exported in a variety of formats, either directly to a printer or to the screen to preview 

the results before they are printed. Choose the desired format from the Direct to... dropdown menu. Choices 

include: Printer, Preview, PDF, and Excel (among others) 

3. To generate a report select Start. 

 

 

4. The generated report includes:  

• The project file location. 

• A list of the 11 tests and results color coded for pass (green), fail (red), or not applicable (white).  

• A full list of all tasks or links that meet the criteria for each test. 

 

  

https://www.planacademy.com/dcma-14-point-schedule-assessment/
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  Appendix A: 3D File Formats 

SYNCHRO can import the following file formats into version 6.3: 

Product: File Extension(s): Version(s): Note(s): 

ACIS SAT, SAB up to 2019 
 

Alias Wavefront OBJ All Versions 
 

AutoCAD DWG, DXF R14 - 2018 
 

Autodesk DWF, DWFX up to 2012 
 

Autodesk FBX FBX 6.0 - 7.5 
 

Autodesk Inventor IPT, IAM Up to 2020 
 

Bentley I-Model I.DGN 1 
 

Bentley iModel 2.0 BIM  *With SYNCHRO 4D license 

Bentley Microstation DGN V7, V8, V8 XM, V8I, V8i 
(SELECTseries 2), V8i (SELECTseries 
3), V10 (CONNECT) 

Plug-in module is available for 
Microstation V8i (SELECTseries 2 and 
3) and V10 (CONNECT) 

CATIA V4 EXP, DLV, MODEL, SESSION up to 4.2.5 
 

CATIA V5/V6 CATProduct, CATPart, 
CATDrawing, CATShape, CGR 

R4 - V5-6 R2019 (R29) 
 

Collada DAE up to 1.5 
 

Dassault Interchange 
Format 

3DXML 2011 – 2013 
 

GL Transmission 
Format 

GLTF, GLB 2.0 only  

HOOPS stream file HSF 
  

I-deas MF1, ARC, UNV, PKG  up to 13.x (NX 5), NX I-deas 6 
 

IFC IFC 2x, 2x2, 2x3, 4 Geometry only for 4 (beta version) 

IGES part files IGES, IGS 5.1 - 5.3 
 

Navisworks NWF, NWC, [NWD]* 2017-2021 via plug-in module for Navisworks.  
*IMPORTANT: NWD can be exported 
to SPX, but does not support future 
model updates via Synchronise From 

Parasolid xmt_bin, x_b, x_t, xmt_txt up to v32 
 

ProE/Creo PRT, ASM, NEU, XAS, XPR,  Pro/Engineer 19.0 to Creo 6.0 
 

Revit RVT 2017-2021 via plug-in module for Revit 

Rhino 3DM 4, 5, 6 
 

SketchUp SKP v7, v8, 2013-2020 
 

Solid Edge ASM, PAR, PWD, PSM V19 - 20, ST - ST10, 2020 
 

SolidWorks SLDASM, SLDPRT up to 2020 
 

STEP part files STEP, STP AP203, AP214, AP242 Geometry ONLY 

Stereo Lithography STL All versions 
 

UGS JT JT up to 10.2 
 

Unigraphics NX PRT V11.0 to NX 12.0, and 1899 
 

Universal 3D U3D ECMA-363, 1st, 2nd & 3rd editions 
 

VDA-FS VDA 1.0 - 2.0 
 

VRML files VRML, WRL V1.0 and V2.0 (VRML'97) 
 

3D PDF, PRC PDF, PRC All Versions 
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  Appendix B: Bentley 3D Workflow 

24.1. Using the Bentley Microstation Plugin 

1. You can install the plugin from https://softwaredownloads.bentley.com/en/ 

2. Run and install the setup file (double click on the set up file and follow the on screen instructions). 

3. Once the Plugin has been installed, open up the DGN in Microstation. 

 
 

4. Go to File → Settings → Configuration → Configuration Variables. 

 
5. Find "MS_DGNAPPS" variable and press edit. 

  

https://softwaredownloads.bentley.com/en/
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6. Append "SynchroPlugin.dll" value. It will append "MS_DGNAPPS > SynchroPlugin.dll" to your configuration file ( 

C:\Users\...\AppData\Local\Bentley\MicroStation\10.0.0\prefs\Personal.ucf ). 

 
 

7. The next time you run MicroStation, the plugin will be loaded automatically. 

8. In MicroStation, go to Utilities Ribbon and select MDL Applications. 

 
 

9. Find "SYNCHROPLUGIN" in Loaded Applications list and press 

Key-ins button. You will have to Load it from the Available 

Applications section at the bottom, for the first time. 

 

 

10. Double click "open". 
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11. You will now see the SYNCHRO Plugin window. There are a number of export options available to you: 

Coordinate System - Can be used to export in world 
coordinate system or in local \"Global Origin\" coordinates 
system. 

 

Engineering Components 

Element Properties - Can be used to skip the export of 
Engineering Component properties as SYNCHRO User Fields.  

Element Classes - Can be used to export of Engineering 
Component classes as SYNCHRO 3D Sets.  

 

Hidden Objects 

Hidden Elements - Can be used to export hidden elements.  

Level Display - Can be used to skip levels that are not added 
to Level Display in selected 3D view.  

 

Object Tree 

Break By Levels - When enabled, 3D elements are grouped 
by levels.  

Break Cells - When enabled, creates separate node for each 
3D element under leaf cell.  

Limit 3D Object Tree Depth - Enable to limit the maximum 
depth of 3d object tree.  

Limit 3D Object Tree Levels By - This option determines the 
maximum depth of 3d object tree.  

 

Objects 

Construction Elements - Can be used to skip the export of 
construction elements.  

Dimension Elements  - Can be used to skip the export of 
dimension elements.  

Named Groups - Can be used to export Named Groups as 
Synchro 3D Sets  

Tags - Can be used to export Tags as Synchro User Fields.  

Text Elements - Can be used to skip the export of text 
objects.  

Wireframe Elements - Can be used to skip the export of polylines, lines, circular arcs, circular arcs, circles, elliptical 
arcs, ellipses, nurbs curves objects.  

 

Optimization 

Optimize 3D Model - Enable optimization of 3D model on export.  

Optimize Geometry - Enable optimization of geometric objects.  

Optimize Identical Geometry - Enable optimization of identical 3D objects  

Build Resources - Create resources by 3D entity tree on export 

Tessellation Accuracy - Tessellation accuracy ( 0 - 100 ). 
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12. Select the options you wish to export in SYNCHRO Plugin window (shown above)  Export SPX... 

13. In the Save As window, Select the location of where you wish to save, name the file and select Save. 

14. The progress bar will appear to give you the status of the export. 

15. When the export is complete, you will receive a message indicating the export finished successfully. Select OK. 

 

24.2. Importing .sp files generated from the Microstation plugin into SYNCHRO 

1. Open up SYNCHRO PRO, Select File tab → Import → SYNCHRO Project. 

2. In the Import SYNCHRO Project window, locate the .spx file. Select open. 

3. Select “Import” to import all available attributes. (If required, attributes can also be skipped) 

4. The progress bar will appear to display the status of the import. Upon completion, select Finish. 
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  Appendix C: Revit 3D Workflow 

SYNCHRO imports DWF, DWFx, and IFC files, all of which can be exported from Revit. Additionally, you can download the 

Revit Plugin for SYNCHRO, which exports the model as an .spx file. 

NOTE:  Whatever is visible in your Revit 3D view is what will be exported. 

25.1. Using the Revit Plugin 

The Revit Plugin enables native RVT files to be exported out of Revit as SYNCHRO Project files (.spx) that can be imported 
into an existing SYNCHRO Project (.sp) file. 

 
NOTE: The SYNCHRO Revit Plugin works with Revit 2017 and 2018, 2019 and 2020 

 
1. Download the appropriate Revit Plugin from 

https://softwaredownloads.bentley.com/en/ 

2. Run the installer  

3. Once the Plugin has been installed, open the RVT file in 

Revit. 

4. Select Add-Ins tab→ Synchro panel →Export Settings  

5. The Synchro Export Settings dialog will appear.  There 

are a number of options available to you: 
 

• Export Workspaces – If Checked, Revit Rooms are exported as SYNCHRO 

Workspaces; Otherwise no Workspaces will be exported. 

• Export nested families as separate elements – If checked, nested families will be 

broken down to individual families; Otherwise they will be grouped as one 

object 

• Use shared coordinates –  A Revit project stores internal coordinates for all the 
objects in a model, which are only known to that particular project. If the 
position of the project model is to be known to other linked models, users 
should use shared coordinates. 

• Create 3D Filters from Sheets – Plugin has the capability to create 3D Filters 
from Revit Sheets; for example: user created functional sheet in Revit, showing 
only floors on certain level of the building. By 
creating 3D Filter from that sheet, user will gain 
the possibility to filter the same objects in 
SYNCHRO PRO. 

• Create Resources from 3D – Plugin has the option to create Resources from 3D 

Objects and assign them to one of 4 Types – Equipment, Human, Location or 

Material. This can be done at this stage or later in SYNCHRO PRO. 

• Create Viewpoints for Each Level – If checked, creates Viewpoints in SYNCHRO 

for each Level in Revit. Each Viewpoint is defined by a cutting plane above and 

below that level. 

• Use Level Above – The viewpoint for a given Level is defined by a 

Cutting Plane at the elevation of the Level above 

• Distance from Level – Alternatively, the viewpoint for a given Level is defined by a Cutting Plane at the specified 

distance above the Level 

• Select Levels Manually – If checked, a dialog will be raised at the time of export to manually select which Levels to 

create Viewpoints for; Otherwise one Viewpoint will be created for each Level in the project 

• Export Matching User Fields Only – If checked, all User Field (Revit Parameter) names will be checked against strings presented in 

a list box (below this option): If the User Field name contains any of the strings from the list, that User Field will be exported; 

otherwise, it will be ignored. If unchecked, all User Fields will be exported. 

https://softwaredownloads.bentley.com/en/
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• Parameters to Export – Only available when “Export Matching Using Fields” is enabled. To enter a new String, Type it in the Text 

Box and select the “Add” button to the right of the Text Box. Conversely, to Remove a String, highlight the String and select the 

“Remove” button at the top right of the List Box. 

NOTE: The values in the List Box are CASE-SENSITIVE. Additionally, any strings added to the List Box will remain there 

until you manually remove them. 

6. Once you have selected your desired Export Settings, Select “Close” 

7. These Export Settings will be saved for future use. 

8. Please set up the 3D View in Revit according to how you wish to export your model – as you would with the 

DWF/DWFx export. 

9. When you are ready to export your model, Select Add-Ins tab → SYNCHRO panel → Export to SYNCHRO. 

 

NOTE: If you attempt to export from a 2D View you will 

receive the following message (right). Please make sure 

you are exporting from an active 3D View.  

 

 

10. The “Save AS” window will appear. 

11. In the File Name, type the required name and select “Save”. 

 

When the export is complete, you will have an .SPX file containing the 3D Geometry from Revit.  
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  Appendix D: Auto-Matching 

The Auto Matching feature in SYNCHRO provides a facility to automatically assign Resources to Tasks using custom filters and 

search rules. The match is based on the Resource Names, Task Names, Task ID, or Task Comment. 

Using the Auto Matching function greatly simplifies the task of linking resources to tasks to create a SYNCHRO Project 

suitable for scheduling and 4D Simulation. 

To match resources to task using the auto matching feature: 

Select the Assign Resources tab → Auto Matching panel → Resources to Task,  to display the Auto Matching Dialog. 
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26.1. Auto Matching Window dialog 

The dialog contains a number of control sections: 

1. Rules – defines a rule to match Resources and Tasks 

 

• Import – Can be used to read a previously Exported 

Auto-Match rules File, via the “Import Rules from File” 

window.  

i. Press the Browse button to select an XML file 

containing Auto Match Rules. 

ii. Press the Load File button to read the file and list 

its content. 

iii. Select the desired rules to import, and press the 

Import button. 

iv. Press Cancel to close the dialog. 

 

 

 

• Export - can be used to save a Rule-Set to an XML File, 

via the Export Rules dialog . 

i. Press the Browse  button to select an XML file to 

the Auto Match Rules. 

ii. Select the desired rules to export, and press the 

Export button. 

iii. Press Cancel to close the dialog.  

 

 

 

 

• The Add button is used to define a new rule – this will open the “Add New Rule…”window described below. 

• Edit can be used to modify an existing rule – this will open the Edit Rule window which is identical to the Add New 

Rule window (described below) except that it contains the saved rule. 

• The Remove button will delete the currently selected rule. 

• The Remove All will delete all currently defined rules. 
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2. Operations – applies the selected matching rule 

• Appearance Profile – the default 

Appearance Profile that will be 

applied to any matches 

• Search – search the SYNCHRO 

project using the currently defined 

rules. After running Search, if there 

are matches, the Group panel will 

be populated (outlined right). 

• Clear – clear any previous search 

results. 

• Assign All – to assign all the 

identified resources to tasks. 

• Close – exits the Auto Matching 

window without making any 

assignments. 

 

3. Groups – Review matching search 

results. Selecting a Resource (or Task) 

from the Groups panel will populate 

the Resource (or Task) Tree and 

Attributes panels. If more than one 

Resource matches a Task, the Task 

will be listed only once at the top of 

the group of the Resources. All 

Resources in the same group must be 

assigned using the same Appearance 

Profile. 

4. Resource Tree & Task – Displays the 

selected Resource or Task’s location in the Resource Tree or WBS, respectively. 

5. Resource Attributes – Displays the key attributes of matched Resources including Company Name, User Fields, 

Matched Resources and Assigned Resources. 

6. Task Attributes – Displays the key attributes of matched Tasks including Name, Activity Codes, User Fields, Matched 

Resources and Assigned Resources. 
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26.2. Add New Rule/ Edit a Rule 

To define a new rule: 

1. Press the New button in the Auto Matching window to bring up the Add New Rule window: 

2. Enter a Rule Name. 

3. The Summary Options, when applied can be used to set the range of your search. 

• Use only Selected Resources 

(and/or) Tasks  - applies the search 

rule only to Resources/Tasks that 

were selected in SYNCHRO before 

opening the Auto Matching 

window. Leave the options 

unchecked to search all Resources 

and Tasks in the project. 

• Ignore Assigned Resources – 

excludes Resources that have 

already been assigned to at least 

one task from search. 

• Ignored Tasks with Assignments – 

excludes Tasks that have at least one Resource assigned to them from search. 

• Merge Resources Groups – when enabled, groups all Resources that contain a common characteristic used for 

matching and assigns them to the same group of Tasks. 

NOTE: Resources in the group don’t match all grouped Tasks. 

• Ignore Summary Tasks – when enabled, excludes WBS level summary tasks from the search. No new Resource 

assignments will be made to those tasks. 

4. The Relations radio buttons can be used to set the default linkage when the search is applied a match is found. 

• None  - a linkage is not applied between matched Resources and Tasks. 

• One-To-One – Matches are linked on a one-to-one basis. One Resource can be assigned to one Task. 

• Many-To-Many – Matches are linked on a many-to-many basis. Multiple Resources can be matched to each Task 

and will be grouped together in the search results in the Auto Matching window. A Resource can also be matched 

to multiple Tasks. 

5. The Expression section allows you to define complex search criteria for the rule. 

NOTE: At least one search expression must be defined before you can close the dialog, or press Cancel to stop the 

Auto Matching rule creation. 

 

6. Select Add to define a new Expression. This will enable the Term, Algorithm, Operator, and Options panels below. 
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26.2.1. Defining Rule Search Expressions 

1. The Term section allows you to specify the Resource and Task attributes to use in the search, as well as the 

comparison operators to use: 

• The Resource Attribute section defines 

which Resource attribute will be 

searched (Name or User Field) 

i. User Field  - select desired User 

Field from the drop-down list. 

ii. Search Parent – allows the search to 

apply to the parent elements if the 

attribute does not exist in the 

current Resource (when the search 

is applied). 

iii. Type – allows you to select specific 

Resource Types to be included in the Auto-Matching operation: Equipment, Human, Material, or Location. 

• The Task Attribute section defines the which Task Attribute (Name, ID, Comment, User Field, or Activity Code) will 

be matched against the defined Resource Attribute. 

i. User Field  - Select the required value from the drop-down list. 

ii. Activity Code – select the required code from the drop-down list. 

iii. Search Parent – allows the search to apply to the parent elements if the attribute does not exist in the 

current Task. 

2. The Algorithm section defines how the Resource and Task attributes should be matched. 

• Exact – matches attributes exactly. 

• Substring – returns a match if the Resource attribute occurs within the Task attribute (i.e. “ana” is a substring of 

“banana” in two different places). 

• LCS – Matches the Longest Common Substring between the Resource and Task attributes. The minimum length of 

this substring is defined by the Min Length option. 

3. The Options section of the dialog defines additional search criteria: 

• Min Length – determines the minimum string length when the LCS matching is performed. 

• Min Digits – defines the minimum number of matching characters for a match. 

• Separator – If an attribute or field consists of multiple words or phrases, then the Separators option may be used to 

define the delimiters used between each word or phrase. During searches, the Auto-Matching function will test 

each word or phrase of the attribute, rather than the complete text defined for the attribute. 

4. The Operator radio buttons are used to logically define how multiple search expressions will be combined to 

determine whether or not a match exists. This allows complex search patterns to be defined for a single rule: 

• AND – this Expression must be true in order for a match to be found. 

• OR – a match will be found if this Expression is true even if the other(s) are not. 

• AND NOT – this Expression must be false in order for a match to be found. 

• True if Undef - controls whether the term should be evaluated as true if the matched attribute is undefined for a 

particular attribute. 

(Ex: If the Task Attribute is Activity Code, when True if Undef is checked, the Expression will automatically be true for 

any tasks that do not have an assigned Activity Code). 

5. Press Save to save the current Expressions. 

6. If you wish to continue adding more Expressions, press Add. 
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7. The Remove button can be used to delete the currently selected Expression. Remove All will delete all of the 

Expressions associated with the current rule. 

8. When the Rule is finished, press OK to close the dialog and return to the Auto Matching window to run a search. 

26.3. Auto-Matching Search 

Once an Auto Matching rule is defined, you can 

run the rule to search for matches in your 

SYNCHRO Project. 

1. Select the desired Rule from the drop down. 

2. Press the Search button. 

3. The groups list will display the matched 

Resources and Tasks. 

4. Right click in the list to select the proposed 

linking Options: 

• Group Relations – defines the proposed 

linkage (None, One-to-One, Many-to-Many) 

between the currently selected matched 

Resources and Tasks. 

• Overall Relations – defines the proposed 

linkage for all the matching resources and 

tasks. 

5. The Resources Tree displays a sub-tree 

containing the matched resource starting 

from the Resource Type. 

6. The Task Tree displays the matched Task and 

its hierarchy. 

7. You can change the assigned Appearance 

Profile for each matching group by clicking 

within the Appearance Profile column (which 

will display a drop-down list of the available 

Appearance Profiles).  

8. Press the Assign All button to apply your 

proposed Linkages (assigning all matched 

Resources to matched Tasks in the list) 

9. The Clear button will clear the list. You can 

then select another Rule in the dialog and 

repeat the Auto Matching operation again 

until you reach the desirable result. 
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  Appendix E: Synchronisation -Basic Rules for Scheduling Software 

P6 
GUID (Global Unique Identifier) is the primary information used to compare Tasks. If the Task is not found in the GUID map, 

and the option to Use Activity IDs on Synchronisation is set in Options → Synchronisation → Primavera P6, the IDs are 

compared. If not found, the Activity is considered a new one. If found; the Task and GUID map are updated. 

Therefore: 

• If the original schedule and P6 database are used to update, SYNCHRO will look for GUID’s when synchronising. 

• If the original schedule has been copied then updated, a different P6 database has been used, or if the GUIDs are 

not found, then Activity IDs will be compared, provided they have not been changed. 

• It is possible to change the IDs in both P6 and SYNCHRO, as long as GUIDs remain unchanged. 

• The schedules can be Synchronised using a different computer and can have a different file name 

Asta 
When making copies of the original schedules that are created in other systems; the global unique ID of each task will be 

changed in the process of copying.  

Therefore, when a copy is made and introduced into the Synchronisation workflow the change will be made to the original 

task’s own internal UID (unique identifier). 

This will result in SYNCHRO not recognising the task as the same, therefore all prior resource assignments will be lost. It is 

essential that the original import/export schedule is used throughout the workflow. If copies are introduced, it is important 

that they are only for side reference or saved as an archive as required, but at all times updates and changes are 

Synchronised between SYNCHRO and the original or original updated schedule. 

In essence, the original and updated schedules throughout the workflow process should be from the same source schedule 

and NOT copied versions.  

The programme can be Synchronised using a different computer and can have a different file name 

Microsoft Project XML 

MSP xml uses an attribute called Unique IDs (UID) that is used when synchronising. 

You can copy and update a project provided it is the same MSP Project resaved/exported in MSP then UIDs are retained. 

The projects can be Synchronised using a different computer and can have a different file name. 
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  Appendix F: Synchronisation Scenario (Skip, Synchronise, Consolidate, Integrate) 

Summary: 
This question looks at your knowledge of synchronisation options in an example scenario. 
Question: 
Consider the following scenario: 

1. Company XYZ employs both a professional P6 scheduler and a SYNCHRO specialist.  The scheduler creates a 
schedule in P6 named Schedule1.xer,  

2. The SYNCHRO specialist imports the P6 schedule into SYNCHRO after opening a new .sp file which he saves as 
Project1.sp.   

3. The SYNCHRO specialist then imports a 3D model into the same .sp file and begins linking the 3D resources to the 
tasks.  For the purpose of animation, he subdivides some of the tasks and creates entirely new tasks for equipment 
traveling on 3D paths.  

4. Meanwhile the scheduler has updated the durations of some of the tasks in P6, added a few more tasks, and 
deleted a few tasks as well. The updated schedule file is resaved as Schedule1.xer.   

5. When the SYNCHRO specialist goes to Synchronise Project1.sp with the updated schedule, he opens Navigator tab 
→Project Data panel →External Data. He right clicks on Primavera → [Schedule1][Import][Date] and selects 
Synchronise from.   

6.  
This scenario is illustrated graphically below: 
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Below are simplified example schedules, with durations in parentheses after the tasks. The left one was created in P6 and 

imported into SYNCHRO to begin. The middle one is the result of modifications made to the schedule in SYNCHRO by the 

SYNCHRO specialist, and the right one reflects the changes the scheduler has made in P6. 

Original Schedule Modified Schedule in SYNCHRO Modified Schedule in P6 

Project1 
Foundation (10d) 
Walls (10d) 
Landscaping (20d) 

Project1 
Foundation (10d) 
Walls (10d) 

Wall 1 (5d)  
Wall 2 (5d) 

Landscaping (10d) 
Truck Move (20d) 

Project1 
Foundation (15d) 
Walls (10d) 
Windows (5d) 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

a)  
 

b)  
 

c)  
 

d)  
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In which of the following windows has the SYNCHRO specialist selected the correct options to Synchronise without losing any 

of the work that he and the scheduler have conducted since the first version of the schedule was originally imported into 

Project1.sp? 

Answer: b) 

Explanation: 

The attributes of concern in this scenario are Tasks, Links, Resources, and Resource assignments. The original schedule has 

been modified in SYNCHRO, so choosing Synchronise for Tasks and Links will override and replace the modified schedule in 

SYNCHRO with the updated P6 schedule.  All the subtasks and equipment movement tasks created by the SYNCHRO specialist 

will be lost.  Therefore, a) is not the correct answer. 

The scheduler has deleted tasks. If the Tasks and Links are consolidated, the tasks that the scheduler has deleted will remain 

in the consolidated schedule because Consolidate keeps the greatest number of tasks compared to the other options: any 

tasks that are in either schedule (SYNCHRO or P6) will be in the new schedule – no tasks will be deleted from either schedule.  

You can think of it like a Venn diagram: 

Consolidate will keep all of the tasks in both ovals; 

SYNCHROnize would keep all of the tasks in the red oval 

(including the overlap.) Note: if a task is in both schedules 

(the overlap in the Venn diagram), the schedule that is being 

SYNCHROnized from will take precedence in determining the 

task duration and other attributes.  Because we do not want 

the Landscaping task in our final schedule, d) is not the 

correct answer. 

The same Venn diagram does not work to explain Integrate because the action Integrate takes depends on which program 

originated the change relative to the original schedule.  For example, even though just looking at the Venn diagram above, 

you wouldn’t guess that Landscaping and Truck Move would be treated differently when integrating, but the program 

remembers that Truck Move was created in SYNCHRO, whereas Landscaping was part of the original schedule that was then 

deleted in P6.  Tasks that were created in SYNCHRO will be retained when Integrate is chosen, but tasks that were part of the 

original schedule, then deleted in P6 (even though they are in the modified schedule in SYNCHRO) will be deleted in the new 

schedule as well after the SYNCHROnize from is carried out. Therefore Integrate is the correct option for Tasks and Links.  

If we now look at Resource Assignments, we see that b) has Integrate selected while c) has Synchronise.  Integrate will work 

the same way for Resource Assignments as for Tasks – any assignments made in either program will be retained, as long as a 

deletion hasn’t been made in the source program (in this case, P6).  Synchronise will override all of the 3D Resource 

assignments made in SYNCHRO (the term “Resource” in P6 refers primarily to human resources).  Therefore, c) is not the 

correct answer. 

The correct answer is b). 

The final schedule in SYNCHRO after Synchronise From has been performed will be: 

Final Schedule in SYNCHRO 

Project1 
Foundation (15d) 
Walls (10d) 

Wall 1 (5d)  
Wall 2 (5d) 

 Windows (5d) 
 Truck Move (20d) 
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 Contact Details 

Corporate Headquarters: 
Bentley Systems, Incorporated  

685 Stockton Drive 
Exton, PA 19341, United States 

  
Telephone: 1-800-BENTLEY (1 800 236 8539) 

Outside the United States: +1 610 458 5000 

Email: synchrosupport@bentley.com 
Bentley Website https://www.bentley.com/en/about-us/contact-us 

SYNCHRO Website: https://www.bentley.com/en/products/brands/synchro 

SYNCHRO Bentley Communities: 

https://communities.bentley.com/products/construction/w/construction__wiki 

FAQ: https://communities.bentley.com/products/construction/w/construction__wiki/41481/best-practices-

and-faq  

Submit an Idea for Improvements: https://communities.bentley.com/products/construction/i/synchro-

construction-solution-ideas 
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