关于设备图层设置的问题

三维设计中有时设备数量很多,设计者想通过自定义图层(自己在设计文件中新建图层)的方式在设计文件中对设备进行分组,以便于设计者可以通过开关图层排除无关内容的干扰。

OPM在dgnlib中的元素模板和命名表达式中对设备的图层进行了配置,例如放置一个泵,图层会自动分配为“E-PMP”,设计者在设计文件中新建一个图层且命名为“泵”,把之前的泵模型放到这个图层下,这样泵的图层就从“E-PMP”改为了“泵”,实现自定义图层的目的。

但是当对放置好的泵进行“Modify Component”操作并确认后,泵的图层又自动回到了原来的“E-PMP”,其它设备也都是同样的情况,以前V8i版时不会这样(自定义好图层以后再对设备进行修改图层不会改回去),查看了dgnlib的元素模板和命名表达式,并且把其中的相关内容改成跟V8i版一样也还是不行。请问该如何解决?谢谢

Parents
  • 补充一下:尝试将dgnlib中对图层的定义删掉之后,对设计文件中的设备进行“Modify Component”操作,设备图层不会改为原dgnlib中设定的图层了,但会改成软件的当前激活图层。也就是说我要修改哪个设备,就需要把当前激活图层调到该设备所在图层才可以。而以前V8i是设备确定了图层后,无论怎么修改,设备图层不会改变。

    中铝贵阳院吴道林

  • 您好,经过测试CE版本手动修改设备到自己创建的层后,修改设备会恢复到定义的层,暂无法实现需求。

    已经将这个问题提给外国同事,有回复后再给您答复。

  • 好的,谢谢回复

    中铝贵阳院吴道林

  • 吴工,您好!

    外国同事已经给了回复,需要确认几个问题

    首先需要您提供一下工作集,用于检查dgnlib,看一下命名表达式和元素模板。

    其次需要确认一下是否是按照原来的dgnlib移动到默认级别,那么在这个例子中,即使在元素模板中的设置不同,容器也会回到E-VSL
    还需要明确一下dgnlib是在项目开始时设置的,还是在项目进行中修改的?

    吴工我现在给您提供另一种思路来解决问题,您看是否可行

    通过新建过滤器,创建想要显示层组。再通过设置图层显示来显示想要的图层。具体操作如下:

    首先打开层管理器,新建一个过滤器,命名为“shebei”,右键该过滤器创建层组,在层组中选择想要显示的图层。

    过滤器创建好后,通过修改层级显示,达到显示目标层级的目的。操作如下:

    第一步:在层级显示下选择显示所有层级

    第二步:选择过滤器,选择创建好过滤器“shebei”,则“shebei”过滤器下的模型即可显示在视图中

  • 您好,感谢您的回复。

    关于要确认的问题,因为我的项目工作集做了些定制,怕不能说明问题,所以我后面用的软件自带的工作集“Metric”测试的,没有做任何更改,也存在同样的问题。根据您之前的回复,您测试了后证实确实存在我说的这个现象,所以我觉得跟工作集应该没有关系,而是软件内在的一个逻辑。

    我用软件默认的工作集“Metric”测试时,没有修改任何东西,比如放置一个泵模型,其按软件默认配置图层为“E-PMP”,我人为地在设计文件中新建一个图层叫“泵”,并把泵模型放置到改图层下,此时泵模型图层变为“泵”,当对模型进行“Modify Component”操作后,泵模型的图层又变回了“E-PMP”

    感谢您给的解决思路,不知道我有没有理解对。您提供的这个思路是将不同类型的设备进行自定义分组,以此来控制显示内容。我想实现的是“随心所欲”地对设备进行分组,比如对同种设备类型进行分组(因为有时候同一个车间相同设备类型的设备比较多)。

    中铝贵阳院吴道林

  • 吴工好,我在V8i版本中测试,也存在这个情况。自定义设备图层后,再修改设备组件,设备的图层会回到原图层。外国同事回复,这是个Bug, 暂时还没有解决结果。

    我提供给您的解决思路无法实现您说的"随心所欲"的对设备进行分组。只能对同类型的设备进行分组,如同为"Tank"或·"Pump"。

  • 了解了,谢谢回复

    中铝贵阳院吴道林

Reply Children
No Data