Connection Client 11.0.2.16 / Windows 10 / Running but not opening

Hi everyone,

I'm fairly new to Bentley products, but so far haven't had any issues that weren't resolved by following a KB article or forum post here.

However, this week I have a user on Connection Client 11.0.2.16 with Windows 10 Pro who can't log in to Connection Client. The program is running and is viewable in the task bar, but we cannot open it and right-clicking does not provide the usual context menu.

If we kill the process another one spawns but this has the same result. So far we've tried:

- uninstalling and re-installing

- deleting %localappdata%\Bentley\MySELECT.DB and %localappdata%\Bentley\Licensing\LicenseService.DB

- checking for available updates

- restarting all available Bentley services we could see

Does anyone have any thoughts on what might be happening? It may be worth noting that the user previously had v10.x of the Connect client (unfortunately I don't know which exactly, but it was early enough that it needed to be upgraded) - however there doesn't appear to be any traces of this left in the system.

Thanks!