FDOT Connect 10.10.01.00 and ORD 10.10.21.04 Issues

I installed the latest updates last week and have been having quite a few issues with slow performance.

The following hang-ups are occurring:

  • When opening a file, I can see everything has loaded, but the program continues to hang for 30 seconds or so before becoming usable. Even after, the first few things I try to do encounter hang-ups.
  • Switching between Views that show different models. For example, a 4 view setup with Default, Default 3D, a profile view, and an XS view. Every time I click to a new view, the program hangs for 5-10 seconds.
  • Using the Cross Section Navigator. Several minutes to actually get it loaded. About 30 seconds or more to flip to the next section.

 

I have tried compressing files to no avail. I work on local files, typically on my OneDrive files that are on my E Drive. I tried copying to my C drive and there was no improvement. Both of these drives are NVME drives. All of these issues are also occurring on my virtual machine, so it’s not just my home computer.

 

Then I decided to try to open my files without the workspace. I just right clicked one of my files and hit open. NONE of the issues above were occurring. However, the following was still an issue:

  • Slow undo in some files. Seems to mostly be related to files with Civil Labeler labels in them.

 I have posted a video to my YouTube page highlighting these issues: https://youtu.be/c_p2HTRADBU

 Has anyone encountered these issues?

Parents
  • I would like to jump on this thread (because this is also related to 10.10.01.00) and also express that the warning dialog about the missing Geotechnical file is very obtrusive for those firms that utilize ProjectWise. Could this check be moved elsewhere in the file opening process rather than the compiled DLL, so that as consultants we could opt to remove it? 

    Eddie Giese, PE
    Production Manager (licensed in FL & PA)

    Patel, Greene & Associates, LLC
    PowerGEOPAK V8i SS10 (08.11.09.918)
    OpenRoads Designer 2021 R2 (10.10.21.4)
    OpenRoads Designer 2020 R3 (10.9.0.91)
    ProjectWise Explorer CE 10.0.3.453
    LumenRT CE Update 14 (16.14.60.98)

  • Eddie, this is one of about 30 template files that are copied to a workset when a file is opened. It's complaining because the Geotechnical folder is missing in older worksets, and is part of the On File Open process. Bentley has not yet come up with a method to include this file when opening in ProjectWise and when it comes to quantities you will need the templates or build your quantities by hand.

  • Hello Bob,

    Yes sir, there is. It's Process Name is pwc.exe. The Process Description is ProjectWise Explorer.

    ProjectWise Explorer CONNECT Edition, Version 10.00.03.453

    ProjectWise Drive, Version 2022.1.328

    OpenRoads Designer CONNECT Edition, Version 10.09.00.91

    OpenRoads Designer CE 202 Release 2, Version 10.10.21.4

    Power GEOPAK V8i (SELECTseries 10), Version 08.11.09.918

  • i might be able to do something with that over the next few days if it's not too busy around here. want to volunteer as my tester?

  • Absolutely! Thank you so much for looking into this for us.

    ProjectWise Explorer CONNECT Edition, Version 10.00.03.453

    ProjectWise Drive, Version 2022.1.328

    OpenRoads Designer CONNECT Edition, Version 10.09.00.91

    OpenRoads Designer CE 202 Release 2, Version 10.10.21.4

    Power GEOPAK V8i (SELECTseries 10), Version 08.11.09.918

  • A better way might be to fetch a Configuration Variable for PW, is there a Main PW Variable. Like _ENGINENAME

  • This is where things can get a bit tricky. You can open Files in ProjectWise using a few methods:

    1. Launch the desired program using a Desktop Shortcut (ex. OpenRoads Designer), sign into the desired ProjectWise Datasource, select and open File.
    2. Double-click on the desired Document using ProjectWise Explorer.

    Based on different methods and configuration scenarios, this variable could work (the Bentley programs seem to know when to define this variable without intervention):

    _MCM_PWDISABLEINTEGRATION = 1 (Not working in ProjectWise; this is defined at the system level)

    _MCM_PWDISABLEINTEGRATION = undefined (Working in ProjectWise)

    If I open a File in ProjectWise (using any of the methods described above), the _MCM_PWDISABLEINTEGRATION variable is undefined. However, if I open a File outside of ProjectWise, the _MCM_PWDISABLEINTEGRATION variable is defined with a value of 1.

    ProjectWise Explorer CONNECT Edition, Version 10.00.03.453

    ProjectWise Drive, Version 2022.1.328

    OpenRoads Designer CONNECT Edition, Version 10.09.00.91

    OpenRoads Designer CE 202 Release 2, Version 10.10.21.4

    Power GEOPAK V8i (SELECTseries 10), Version 08.11.09.918

Reply
  • This is where things can get a bit tricky. You can open Files in ProjectWise using a few methods:

    1. Launch the desired program using a Desktop Shortcut (ex. OpenRoads Designer), sign into the desired ProjectWise Datasource, select and open File.
    2. Double-click on the desired Document using ProjectWise Explorer.

    Based on different methods and configuration scenarios, this variable could work (the Bentley programs seem to know when to define this variable without intervention):

    _MCM_PWDISABLEINTEGRATION = 1 (Not working in ProjectWise; this is defined at the system level)

    _MCM_PWDISABLEINTEGRATION = undefined (Working in ProjectWise)

    If I open a File in ProjectWise (using any of the methods described above), the _MCM_PWDISABLEINTEGRATION variable is undefined. However, if I open a File outside of ProjectWise, the _MCM_PWDISABLEINTEGRATION variable is defined with a value of 1.

    ProjectWise Explorer CONNECT Edition, Version 10.00.03.453

    ProjectWise Drive, Version 2022.1.328

    OpenRoads Designer CONNECT Edition, Version 10.09.00.91

    OpenRoads Designer CE 202 Release 2, Version 10.10.21.4

    Power GEOPAK V8i (SELECTseries 10), Version 08.11.09.918

Children
No Data