Corridor no longer processing, "object reference not set to an instance of an object"


I am working on updating our corridor for a project and in the process, I have started receiving the error in question, shown below.

This is occurring whenever I try to reprocess the corridor and no changes are actually made. I've tried changing the template drop frequency, removing corridor references, changing the Design Stage and none of these actually stick and still produce the same error. I have tried restoring to a previous version of the file and the error still occurs. Occasionally, it will start processing stations but doesn't actually make any progress and I am still free to manipulate the file (draw lines, attach references, etc.) which is not normally the case. I have had coworkers try on their machines and it results in the same error. Trying to apply a corridor and template in another file altogether still works however.

I have resolved to remaking the corridor but I was hoping someone might have some insight on what cause the issue so that an error like this can be prevented in the future.


Riley Parks