Bentley Learn is clumsy

I have been using LearnServer for a few weeks now, and I have tried with Internet Explorer, Chrome, and Firefox.  Sometimes when I can get what I need, and sometimes it just spins.  The OpenRoads Designer Feature Videos seems to never load.  Most load, but most are very slow.  The wait to load between videos in the same section is slow too.  (~30 seconds to ~3 minutes) Is there a way to load a whole section and watch instead of reloading a video every 1-10 minutes?

Thanks.

Dawn

Parents
  • Hi Dawn,

    We are aware of the issue with LEARNserver being slow. We are working on a long term solution to revamp the platform entirely.
    In the interim, if you have a specific course that you are having an issue with you can let us know.
    When you watch a video the remaining videos of that course are listed as related videos at the bottom of the screen, this may help you to easily navigate from one video to another.
    Also, you may find that it works better for you on Microsoft Edge.

    Thanks!

Reply
  • Hi Dawn,

    We are aware of the issue with LEARNserver being slow. We are working on a long term solution to revamp the platform entirely.
    In the interim, if you have a specific course that you are having an issue with you can let us know.
    When you watch a video the remaining videos of that course are listed as related videos at the bottom of the screen, this may help you to easily navigate from one video to another.
    Also, you may find that it works better for you on Microsoft Edge.

    Thanks!

Children
No Data