Welds. Why did it have to be Welds or Omitting Welds from AutoPLANT Reports

The Start of a Day 

Bill was running reports for his AutoPLANT models but when he ran his reports he got a nasty infestation of welds. Unable to remove the weld infestation from his reports he used the used the Bentley phone to place a service with Bentley Plant Support.

After receiving the service ticket I ran the standard set of complex plant support tests; which consisted of running a basic built in out of the box report to see if I get my own weld infestation. Having run the tests I did not receive any welds. Conclusion something was not set to an out of the box configuration.

Finding the Problem 

Now I needed to narrow down what was changed. I asked Bill to send me the .rpt report file he was using so I could test he had it changed to include welds. Upon examination of the .rpt file it looked exactly like a standard out of the box report with the heading was changed to include Wxyz & Co. logo and information. I ran the report to check for the inclusion of welds and not to my surprise it was a normal report a Wxyz & Co. logo at the top.

The .rpt was dry well I moved on to what I hoped was greener pastures built in report options. I opened the report dialog Piping>Reports>Generate Reports. And what did I see right there plane as an overcast day with a hint of fog but the "Omit Sort Codes > 99" in the options section of the dialog. Obviously the dialog is omitting sort code 99 and welds must therefore have a sort code of 99. Quickly I checked a weld in my drawing and its sort code was 100. Wait what was going on here. I checked the reports dialog again. It read "Omit Sort Codes > 99" well it says sort codes that means more then 1 but its pointing to 99 which is a singular value. After pondering "Omit Sort Codes > 99" section of the dialog it hit me. That's not an arrow ">" it's a greater then symbol. It's not omitting sort codes with a value of 99 its omitting sort codes over 99.

Problem Found! Or Is It?

I set the option to omit codes over 99999999999 (yes just a bit over kill) and run a report Bam Weld infestation. Immediately I send Bill an email stating that his "Omit Sort Codes > "must have been set to a higher value and instruct him to set the "Omit Sort Codes >" back to 99. Case closed.

Well not really shortly after sending the solution I received an email stating that the welds where gone but so was piping entries that where needed. This should not of a happened AutoPLANT normally doesn't label piping entries over 100. Time to call Bill.

From my conversion with Bill it turns out that the specs he is using is not his own. Wxyz & Co. was given a set of specs from Abcd Inc. to use for their project. And the specs had many custom components with a SORT_CODE value over 99. What Bill needed was to remove just the welds which had a SORT_CODE value of 100. Bill had to use the advanced component selection option in the repot generator. The advanced selection option would allow Bill to pick and chose what components he did or did not want to have included in the reports.

Below is the actual solution sent to Bill to have welds removed from a report. Advanced component selection can be used to add or remove any type of component based on values associated with that component. Using advanced component selection will take several run thoughts to learn the ins and outs of the tool but once mastered it can be a valuable tool to create reports.

Solution

Omitting Welds from AutoPLANT Reports

Omitting welds with out using Omit Sort Codes is possible. By using the Advanced in the Component Selection Modes welds or other components can be omitted form a report. Using the Advanced Component Selection Mode certain values that are only associated with welds can be flagged. Flagging the weld specific values allows the report generator to omit components with the flagged values. Use the following example steps to omit welds by using Component Selection Mode Advanced.


For this example create a blank piping drawing in Sample_Imperial project and save it.

1. Place a pipe
2. Place a second pipe connecting to the first
3. Open the report generator by going to Piping>Reports>Reports Generator
4. For this example change Omit Sort Codes to 150.


Note: All welds are placed with a SORT_CODE of 100. With this change welds will be included in the report with out using Component Selection Mode Advanced.


5. Hit O.K. to move to the AutoPLANT Selections Dialog.
6. Change the component Selection Mode to <>
7. In Define Query change the pull downs to the following selections


Data Type: 3D Piping Data
Attribute Field: SORT_CODE
Constraint: < >
Attribute Value: 100

8. Hit Add> in the Active Query section. This will add CONSTRAINT = (SORT_CODE < > 100).

NOTE: By adding this constraint query the report generator will search thought all 3d piping data for the field SORT_CODE. Then it will check that field for the value 100. If the value is not 100 then the component will be added to the report. If the value is 100 this indicates that the component is a weld and it will not be added to the report.


9. Hit O.K. to run the report. The resulting preview will not have any welds added to the report.

If other components have been added with a sort code of 100 then these components will be left out of the report. If this is the case then another attribute field will need to be used such as CLASS.

Please see the help file for more information about report generator and its options.