Zig-Zag Edges in Shaded Views

Updated February 2021: Default behaviour with the original sample model is better in CONNECT Edition, however the principals explained may still be relevant.

In my previous post on 'Setting Up in the Real World' I showed an example of zig-zag edges on my sample model located in the Shetland Islands incorrectly attributing this glitch to the model's distance from the Design File Origin:

On closer inspection it turns out that an excessive distance was involved, but not that between this part of the model and the file origin.

In addition to this trivial test model some other elements exist several hundred km away near the Design File Origin. The issue is with the display depths, when front/back clipping is off (which is typical) we try to dynamically compute the front/back planes based on the entire model extents. In this case the overlooked elements result in a huge display volume being calculated when the camera is off. The z-extents of the view in parallel projection are then too great affecting the resolution. The position of the viewpoint 276km away from the part of the model I'm actually looking at is determined by the computed view extents:

In Wireframe this could pass unnoticed, but as soon as a shaded mode is applied the zig-zags appeared.

CONNECT Edition has improved handling of this scenario, the artefacts did not appear when the original file from 2013 was opened in Update 15

If this behaviour occurs you may find that simply enabling 'Expand Clipping Planes' along with toggling On view attributes 'Clip Back' and ' Clip Front' when using 'Fit View' resolves it:

Using the Define Camera tool the unexpected coordinates of the viewpoint/camera can be seen both in the Tool Settings Dialog and graphically when Display View Cone is ticked On. In this screenshot the Clip Factor here has been set to 10 for front and back to reproduce the problem, the clip distance is thus excessive and artefacts are displayed.

Fitting the view with  'Expand Clipping Planes' enabled will reset these factors to the default of 1 resulting in an appropriate view frustum.

Cleaning up this model by removing the overlooked elements hundreds of kilometres away will reduce the overall z-extents effectively avoiding such problems. Setting the front and  back clipping planes to restrict the active Z extents is another solution but cleaning up your data is always the best option in the long term.

It may be useful in some operations to turn on the display depth tools in the view control toolbar, although AccuDraw has made these largely redundant:

Use the Display Active Depth tool to show the current Active Depth in the Status bar, note that despite the large numbers the actual display depth shown here is only about 37m.:

To change the Active Depth use the Set Display Depth tool.

Anonymous