MicroStation CONNECT - Remove example workspace.

When setting up a custom workspace by setting the _USTN_CONFIGURATION to the new location in the shortcut, I have noticed the example files are still visible from the original workspace install location.

How does one get rid of this from the startup dialog using configuration variables?

Parents Reply Children
  • Hi Brian,

    Please can you give some info about your configuration?

    Have you used ConfigurationSetup.cfg to redirect to your Custom Configuration?

    Have you tried using Bentley Configuration Explorer to examine your configuration?

    Are you starting the application(s) from configured shortcuts?



  • When I initially set-up the network workspace, I used the tutorial from the Learn Server "MicroStation CONNECT Edition Upgrade for CAD Managers: Configuration" which suggested using the WorkSpaceSetup.cfg and a Redirect.cfg in the Organization folder locally.  This worked great for MicroStation CONNECT, but, we want to use the same base standards for our OpenRoads configuration.  (I could not find a similar tutorial for OpenRoads networks set-up so I have been trying to figure it out using what I learned originally.) 

    Using ConfigurationSetup.cfg's _USTN_CUSTOM_CONFIGURATION combined  with WorkSpaceSetup.cfg's MY_WORKSPACE_LOCATION variables from the local workstation, everything seems to be working for both MicroStation CONNECT and OpenRoads Designer.  MicroStation is pulling standards from the correct network folder, Organization, and OpenRoads is using the network's Organization and Organization-Civil.  The only thing I want to do is disable the "Example Configuration" from appearing, minimizing the confusion for staff.

    To specifically answer your other questions: Yes, I have used the configuration Explorer and determined no errors and minimal warnings (hardcoded paths mostly) within my cfg files.  Startup is from the Application shortcut with no arguments in the shortcut.

  • I was able to "hide" the Example Configuration from the WorkSpace dropdown when I changed  _USTN_INSTALLED_CONFIGURATION to equal 0 in my /Organization/standards.cfg on my network.  According to the Configuration Explorer, this variable doesn't have any parents or children and initial testing does not appear to result in any other errors. 

  • _USTN_INSTALLED_CONFIGURATION is a variable that points to a path by default. By setting it to 0 you are making it not found. You could set it to Null and <blank> and do the same.