Windows 7 adding command in Micro-station

I know how to do a key-in to a file I want to load, I wanted to know was it save to run the following from within a Microstation session

 Command: C:\Windows\system32\SnippingTool.exe

it works as a desktop shortcut, but was going to make a Toolbar command where the key-in , runs the snipping tool

Command Opens my toolbox:

rd=C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace\Projects\Rjbp\dgnlib\RJBtoolbox.dgnlib
mdl keyin TEMPLATEMANAGER CUSTOMIZE DIALOG

Did not want to crash MicroStation so am asking this question first.

  • Richard,

    To execute a Windows keyin from within MicroStation use the %% prefix.

    In your case this is what the command will look like.

    %%C:\Windows\system32\SnippingTool.exe

    Rod Wing
    Senior Systems Analyst

  • So Appreciate your reply, did not work, locked up micro Station, copied your information. 

    Also checked path C:\Windows\System32 it is correct and the file name spelling again spot on

    SnippingTool.exe so I tried again %%C:\Windows\system32\snippingtool.exe and got the same fault message twice using the Key-in function.

    I have used the RD= command to open files that are .dgn or .dgnlib but was unsure in this on. Do thank you but failed for me twice. any additional suggestions ???

    Version: MicroStation V8i SS 10

    RJB Phillips III (Richard) Praise the Lord for His Mercy and grace in Christ Jesus

  • What I have tried and tested

    made a folder BatchFile inside Drew Bat if I used the key-in 

    %%C:\BatchFile\Drew and the file contains the commands below

    @ECHO OFF

    REM------------------------------------------------------------------------------
    Start " " "C:\Windows\System32\Notepad.exe"
    EXIT

    Notepad loads all works well, same file changed commands

    @ECHO OFF

    Start " " "C:\Windows\System32\SnippingTool.exe"
    EXIT

    Running the file while in windows it loads the Snipping Tool Fine

    same file using the same above command

    %%C:\BatchFile\Drew and the file contains the commands below

    fails to load the snippingtool.exe and give the following Micro-station fault

    now the batch file will load either program direct, Will load the Notepad from Micro-Station

    but errors out on the Snipping Tool and again it will work if I run from Windows direct ???

    RodWing any other ideas or can this be done in VBA ? I would have to start over to find that out I guess. Anyway much thanks RodWing

    Any really sharp folks with some help. Off to bed 2:00 am my time way to late

    Praise the Lord for His mercy and Grace ........ (c;

    Version: MicroStation V8i SS 10

    RJB Phillips III (Richard) Praise the Lord for His Mercy and grace in Christ Jesus

  • I just tried '%%C:\Windows\system32\SnippingTool.exe', works fine for me.

    I might suggest the batch file should be a straight call (no %%), then the command inside the batch file should have the %%. Stabbing in the dark.

    Connect r17 10.17.2.61 self-employed-Unpaid Beta tester for Bentley

  • Thank you Bob, the following is what I did and failed for me. I checked the file location to

    insure it was there. placed it there and the next picture it the error

     

    do not know how to explain. If I use the same commands and put  in Notepad

    It works perfect and loads the notepad on the screen

    as you see notepad loads perfectly . confusing appreciate the tip. I may have 

    a different version than yourself. Thanks again. If anyone else has a tip

    would love to hear it (see it) Ha

    I did even try loading the snippingtool without the .exe also. See below

    and the error above again.  )c;  )^8 

    Version: MicroStation V8i SS 10

    RJB Phillips III (Richard) Praise the Lord for His Mercy and grace in Christ Jesus