[CONNECT-12] Duplicate WorkSet Name

My company has a customized setup. All of the DGNWS files reside in one directory called ”_DGNWS” (without the quotes). The WorkSets are in a separate directory and not a sub of the WorkSpace directory. The design model and sheet dgn files are located on a separate project server.

 I was making a typical WorkSet gobye template for each of my WorkSpaces, so when I pick Create WorkSet, I could choose the gobye from the Template pulldown.

 I had made a WorkSet called “_Ameren_NCS-GoBye” (without the quotes).

Then when I made a new Workset called “_NCS-GoBye”, it initially looked OK in the pulldown listing.

I exited MicroStation CE. When I re-opened CE, the Workset pulldown displayed the name “_Ameren_NCS-GoBye” twice. When I looked in Windows Explorer at the WorkSet directory, everything appeared to be named correctly, including the dgnws files.

This seems to only happen when I use the “_” underscore and “-“ minus characters in the WorkSet name. Plus this only happens when part of the new WorkSet name has been utilized in a previous name.

I can successfully make simple WorkSet names like 19L0001.


Other examples of the name not working are:

_CSX_Struct-Gobye              I tried to make _Struct-Gobye it duplicated _CSX_Struct-Gobye

_ILTOLLWAY_ORD-Gobye    I tried to make _ORD-Gobye it duplicated  _ILTOLLWAY_ORD-Gobye

_MtDOT_Road-Gobye        I tried to make _Road-Gobye it duplicated _MtDOT_Road-Gobye

I have attached screenshots of the WorkSet pulldown showing the duplicate name, and a picture of the Windows Explorer WorkSet directory that show the cfg files NOT having duplicate names, plus the corresponding directories that were created.

 Is this a glitch in the DGNWS file??

Thanks in advance,