Cannot open v8i files from Projectwise. Getting lots of error 193's with .dll's.

I am trying to open a file on projectwise, but it is impossible with with a V8i program. I am trying to open it with SS10

I have stumped my IT department. I have gone through and deleted all Bentley software, reinstalled, as well as restoring both V8i and CE to defaults. 

I cannot even get Microstation to open the workspace configuration to see what happened, I have a hunch it has something to do with the MDLapps. I tried adding AutoTurn to Microstation Connect Edition by adding a line in the workspace configuration. It ended up not working and I removed it. Then this problem started with V8i

  • Other things, it does load into some sort of microstation, but has tons of errors. I get 123 lines of " Unable to load/create dialog item of type 'IconCmd', id = 6 from dialog "MGDSHOOK".

    I uninstalled CE and tried it again. This time I get the black window, but only two lines: does not contain MCM
    MDL Loader: Could not load application componentview

    This is acompanied by a Microsoft .Net Framework unhandled exception. Many come up if I hit continue. First one is "ustnvba"

  • Something is causing your ProjectWise v8i to try and load stuff from MicroStation connect. I suspect your v8i got the projectwise configuration file from Microstation Connect some how.

    Go to C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation\config\appl\

    and delete PW.CFG file there. Then reinstall projectwise.

    When you say you "deleted all bentley software" did you just do uninstalls then reinstalls, or did you uninstall, delete the bentley folders off your machine, then do reinstalls?

    When you just do an uninstall bentley products will leave behind files that it didn't install or have been modified. then when you reinstall those files are still there and it will reuse them. (that's why in my instructions i said to delete the pw.cfg before reinstalling).


  • Oh, this could also be a problem in one of the other config files in C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation\config\ too, so after deleting the pw.cfg see if Microstation opens normally outside of projectwise. if it does then just do the reinstall of ProjectWise. If it's still a problem, uninstall Microstaiton V8i, delete the folders:

    • C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\
    • C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace

    and reinstall Microstation


  • I noticed that. It's bizarre to me that V8i is trying to open Connect items.

    I did delete all Bentley products with the Windows remover/my companies software portal, then deleted the Bentley folders in Appdata and both Program Files and Program Files (x86). No dice.

  • if you remove just the pw.cfg file (or rename it, i usually rename to pw.cfg.disabled when testing this) does it work (you won't get projectwise integration and your references may be missing but should at least open)?