Upgrade from 15.4 to 16.7.25 on Oracle Database

Hello everyone!!

I´m having a lot of problems upgrading eB. While doing upgrade from 15.4 to 15.6 everything was OK, but during the execution of the scripts from 15.6 to 16.7.25 I´m getting a lot of errors. I managed to solve some of the errors but some not, and I´m stuck. Next I left to you some of the errors:

Problem 1

Using Oracle Console I was able to get the SQL script that was producing this error:

ALTER TABLE documents MODIFY( template NCHAR(1) DEFAULT(N'N') );

The problem was that Oracle automatically created and Index for performance on that column (Template), and when the script tried to change it the error appeard.

I solved this problem droppping the Index, but I had to restore the backup of the original 15.6 database make the fix discovered and run the upgrade again.


Problem 2

It seems that the scripts are trying to enable a constraint, but the column of that constraint has null values. This time I cannot get ths script runnig with Oracle Console, so I don´t know which table/column has null values. Then I clicked on “YES”.


Problem 3

After restoring the 15.6 database and applying all the fixes to solve many problems discovered durign the upgrade, I ran the upgrade again. The upgrade run for many hours, and I left it running on some scripts that verifies the files on the repository (I know this beacause I capture ths script running using Oracle Console), then I went to sleep. The next morning I found an error stating that wanted to create an Index and that Index already existed. So if the Index already exist there is no problem, so I clicked on "Yes" to continue the upgrade process, immediately I got this error: 

This error happend to me many times during various upgrade attempts.

It seems that this error occurs after a long period of time after an error window appears, and after some hours later a user click on “Yes” on that window to continue with the process. Opposite the other errors, this error is really complicated beacuse our database has more tan 1.8 million documents and many of the upgrade scripts take a lot of time to execute, so it is imposible to watch the progress of the upgrade all time and be pending of every error that shows to quickly press some button.

I need help with this last error most, because I cant´t upgrade in this conditions.

Thanks in advance.