Problem with the stair - AECOsim | speedikon Forum - AECOsim | speedikon - Bentley Communities

Problem with the stair

I see a problem with the stair. The drawing of the stairs disappears. See video.

Why this happens?.

AECOsim Dataset_US


13 Replies (Most Recent Reply)

  • I can't seem to reproduce that...   All I see when raising the cut plane above the stairs is that the break line symbol disappears.

  • In reply to Steve Cocchi:

    Hi Steve, this is the problem.

    If the section does not cut the stair, I do not see the stair . I only see the numbers of steps.

    The representation should be as indicated in the PDF.

    I tried it on another computer and windows xp and the problem is the same.

    You do not have the same result that the video?

  • In reply to Joaquin:

    Hi Joaquin, no I am not seeing the same results.   See the attached AVI.


    Stairs when moving SV cut
  • In reply to Steve Cocchi:

    Hello Steve, thanks for posting your video. Now I see the problem better.

    I installed AECOsim and pattern on the walls section disappeared when did zoom. (Video stair1). The first question: why lines disappear when zooming?

    I tried every Nvidia driver to resolve the problem. I did not find a good result. Only resolved  with  compatibility AECOsim =Windows XP. Now the section pattern is correct and not disappear when zooming , but this causes the problem that the stairs are not see in the plan.

    In the video stair2, you can see that appears the stair in the plan, but is blocked and therefore does not appear, but what can it be?

    This problem does not occur with BA, only occurs AECOsim (on the same computer with Windows 7 64).

    The big problem is: why some lines desaparecen con AECOsim?. Knowing this would solve all problems.

    Thank you for your help.


    Video stair1 AECOsim not compatibilty with Windows xp (default install)

    Video stair2 AECOsim compatibility with Windows xp

  • In reply to Joaquin:

    Hi Joaquin, what is the "compatibility AECOsim =Windows XP" that you're referring to?

    FWIW, I'm running an NVidea Quadro 1000M and haven't noticed any issues quite like this one.  If I understand correctly, using one setting results in the stair geometry missing when in the forward view, while the other setting results in intermittent hatch display on the cut plane?

  • In reply to Steve Cocchi:

    Hi Steve, I have not the English version of Windows, will be something like: right click of the mouse on the icon, properties - compatibility tab - run this program in compatibility mode - choose Windows XP (Service Pack 3).

    I have tried many drivers of Nvidia. I've found one of 2009 that solved the problem of patterns in section (video Stair1). This problem only affect to Aecosim not affect to BA

    But the problem of the stairs (video stair2) remains the same. Only la view top is the problem. If the stair is cut, the stair is correctly displayed. If the cut is above the stair, no longer seen, only I see the numbers of stair.

    I've tried on another computer with Windows XP and the problem is the same. The strange thing is that not happen to you. I've seen your video.

    Now I wonder: is there a setting or variable to adjust the graphics AECOsim?

    Thank you.

  • In reply to Joaquin:

    Ah, I see, you're using the Windows 7 compatibility mode option set to WinXP SP3.  If you use a different compatibility mode, or turn off the compatibility mode option altogether, then you have a display issue with the cut plane pattern instead?

    I've never had a need to use any Win7 compatibilty modes with Bentley apps, so I'm assuming it's something specific to the combination of your PC's chipset, graphics card and driver.   Unfortunately I probably won't be much help with that.  Unless your Nvidia card has a control application that allows you to fine-tune its settings (my current one does not) I don't know what you could try, outside of a different graphics card altogether.   What you're describing isn't normal behavior, which is why it would seem to be a system level issue.

  • In reply to Joaquin:

    We have the same problem in V8i, reported as ST 8001302237 and ST 8001359167.

    It has to do with a plane that is used in the stair symbol to cover things that otherwise would be seen thru the stairs from bellow.

    This plane is generated at the wrong height in regards to the generated 2D symbols of the stair when the cut is placed close to or above the stair, ending up covering the 2D symbol as well as things bellow.

    This obviously still hasn’t been fixed in V8i and as far as I can tell neither in AECOsim.

    My feeling is that it has something to do with language and unit settings. We use a Swedish version and one thing that comes to mind is that we use " , " instead of " . " when denoting fractions of millimetres.

    Here is an example, the black shape is the plane I am refering to.

  • In reply to Mikael S��w:

    Thanks Mikael, I think that you have found the source of the problem.

    I thought it was a problem of my computer.

    Thank you for your help.


  • In reply to Joaquin:

    Do you have the ability to try changing the decimal separator?

  • In reply to Steve Cocchi:

    Do you have the ability to try changing the decimal separator?

    Yes, but the problem is the same.

  • In reply to Joaquin:

    Mikael, it looks like the STs you had logged resulted in TR# 337999, but that was against Bentley Architecture Ss1.  Are you seeing the same results in the latest ABD with or without the SE dataset?

  • Hi Joaquin,

    I was able to test this on the latest Spanish version of AECOsim BD and same time the US_Dataset so far the issue can’t be reproduced on any of the versions I do recall this been an issue on earlier versions of the program but it is no longer a problem.

^ Go to first post