floor manager and z plane


I am puzzled and don't know how to solve this. I know this can be a bit tricky as it seems like a localised problem, but if anybody could help that would be a huge help.

I will try to explain

My work space is directed to a common location for the whole office users. We have not yet started doing projects in AECOsim  but we intend to start in the near future.

While started working on AECOsim I have noticed that my floor manager is not working as it should be. It is not placing elements at the selected floor. I have asked one of my colleagues to try and he also had the same problem. A third colleague who's  work space was still directed to the C drive had no issue at all. So it only affected two of us who used the workspace created for projects. Then by following the previous discussions here I figured out that there is a problem with the seed model of the project created for company users. Configuration was different to dgnlib. So my other colleague(who had the same problem) tried with a different seed file copied from GBdataset and it worked fine for him. I tried the same trick but it is not working for me and I don't know why? Even the file working fine for him when opened in my machine is not doing. There may be some wrong setting in my C drive but I don't know where to look. Help me please.