C# Feature SetProperty method problem

Hi Everyone,

I try to set property on feature like this

oFeature.SetProperty("PROPERTYNAME", Value);
oFeature.ApplyAttributeChanges();
oFeature.Write(true);

 everything is good but when i open Data Browser in Bentley the result is:

Unable to retrieve feature with id: 077a3eb5-53a7-44b7-9acd-06e4d54fd665

Thanks.

Parents
  • Greetings Nikolay,

    Not sure if you've resolved this or not but I offer the following comments for others which may experience the same.

    • Hovering over the red "!" icon in the Data Browser can often reveal additional information on why the feature instance can be displayed.
    • Any business properties that are marked as "required" in the schema which have null or missing value on the feature instance can cause this.
    • Any data type mismatch or data length violations can cause this (e.g. schema defines integer data type but feature instance has string value, schema defines 20 character max string value but feature instance has string value with length of 25).

    Regards,

    Jeff Bielefeld [Bentley]



    Answer Verified By: Nikolay Tsonev 

Reply
  • Greetings Nikolay,

    Not sure if you've resolved this or not but I offer the following comments for others which may experience the same.

    • Hovering over the red "!" icon in the Data Browser can often reveal additional information on why the feature instance can be displayed.
    • Any business properties that are marked as "required" in the schema which have null or missing value on the feature instance can cause this.
    • Any data type mismatch or data length violations can cause this (e.g. schema defines integer data type but feature instance has string value, schema defines 20 character max string value but feature instance has string value with length of 25).

    Regards,

    Jeff Bielefeld [Bentley]



    Answer Verified By: Nikolay Tsonev 

Children
No Data