Feature properties of newly created element are displayed only after relaunch of the application

Hello guys, there is a big possibility that you will redirect me to different forum with this kind of question, but here i am. 

Basically I have a .shp file containing contours generated by GDAL, and I´m importing it into OpenCities with keyins: 

gdi import storage[storage] options

gdi open name=[storage] file=[pathToShp]

In old V8I, after I imported the created elements i could see the feature properties in "Element information" window immediately. However, after using the CONNECT edition, I have to restart the entire application(OpenCities Map Advanced Update 7) to see the feature properties.

Before the restart it looks like this(properties are not visible even in Show/Hide menu):

After the restart (yes different feature name)

However, even though these properties are not visible at the start, I can access them via the VBA and its PropertyHandler. Do i need to call some UI event to see these data immediately? Thanks for help

Edit1: I don´t know if it helps, but the newly added elements also do not display any of the items attached to them (see the picture of how it should look)

The newly added elements contain only Linestring without any items. After i close and open the app again, the Items are displayed correctly.

Parents
  • Hi Lubo,

    Unfortunately, I was able to reproduce the behavior you observed and I submitted your case to development team.

    If you could provide you shapefile for investigation. That will be helpful.

    Thank you again for reporting. Sorry for the inconvenient.

    However, even though these properties are not visible at the start, I can access them via the VBA and its PropertyHandler. Do i need to call some UI event to see these data immediately? Thanks for help

    We are not aware of the event to call. File > Open would be the workaround.

    Best regards,

    Sebastien


    This is a test

Reply
  • Hi Lubo,

    Unfortunately, I was able to reproduce the behavior you observed and I submitted your case to development team.

    If you could provide you shapefile for investigation. That will be helpful.

    Thank you again for reporting. Sorry for the inconvenient.

    However, even though these properties are not visible at the start, I can access them via the VBA and its PropertyHandler. Do i need to call some UI event to see these data immediately? Thanks for help

    We are not aware of the event to call. File > Open would be the workaround.

    Best regards,

    Sebastien


    This is a test

Children
No Data