[CONNECT] Configuration Warning

Hi All!

When I open a desing file in Open Cities Map Powerview Update 16 the following dialog pops up.

"Active configuration (WorkSpace/WorkSet) does not include the latest changes to its associated schema.

Do you want to update the configuration?"

Is it possible to hide this warning?

If I can not hide it, how can I create a config file that is valid for U16 after a clean install? (clean install means that I copy the workspace/workset config files to the install dir and open the dgn)

It is offered by the program to update the config file automatically. I accepted the automatic update.

Under "<map powerview install dir>\Configuration\WorkSpaces\" I have a <worksapce name>.cfg that changed and a <worksapce name>.inc file is created. A schema file is also created in <install dir>\Configuration\WorkSpaces\Map_Schemas\<schema name>.xml.

I tired to use the updated/created filesbut the same dialog popped up.

Br,

Miklos

Parents
  • Hello Miklos,

    Beginning with OpenCities Map Update 16 the configuration (Workspace/Workset) needs to know if you are working with a Map Schema or not.  

    You can work in OpenCities Map without any schema by using No Workspace/No WorkSet.

    You can work in OpenCities Map by using a Workspace/Workset from MicroStation. Those do not require an OpenCities Map schema.

    All Map configurations (Workspace/WorkSet) require a schema. If one does not exist, the software will ask the to user to localize them.

    There are some additional alerts and settings that will help in this area

    Another Configuration Warning:

    and a Preferences setting for non-Map Workspaces:



  • Hi Dan!

    Thanks for the clarification. I got the above warning and chose 'Yes'.

    After that the automatic config update changed my config file so that there is the following include in the config file:

    #========================================================================================
    # Include GeoSpatial Administrator generated configuration data
    #========================================================================================
    %include mir6.inc

    In the above include file there are the following lines:

    #----------------------------------------------------------------------------------------
    #   Path to GSA schema.
    #----------------------------------------------------------------------------------------
    MS_GEOXFM_SRC_SCHEMA : C:\BentleyCE\MapPowerView\Configuration\WorkSpaces\Map_Schemas\mir6.xml

    To my understanding my workspace/workset (mir6) includes a schema. However the warning still appears.

    If I set the above preference the warning disappears.
    Is there a configuration varible that is equivalent with the above preference?

    Br,
    Miklos

  • This warning appears when the timecode between those two variables, defined in the .inc file, are different:

    _MS_GEOXFM_LAST_EXPORTED : 20220715182518

    MS_GEOXFM_SRC_SCHEMA : C:\BentleyCE\MapPowerView\Configuration\WorkSpaces\Map_Schemas\mir6.xml

     

    Clicking YES should synchronize the timecode.

    Or from the GSA, Save and Export the schema, this should synchronize the timecodes as-well.



    Answer Verified By: Miklos Bodi 

  • Hi Dan!

    Thanks for the hint. That solved my problem.

    I've already tried to clicked YES but the warning remained because my proprietary software installer replaced the modified schema xml with an older version (with older timestamp). From your response I understood the logic I changed the xml also and the warning disappeared.

    Br,

    Miklos

Reply Children
No Data