Encrypted connection to PostGIS in Private Azure Cloud


I'm trying to establish a connection to a PostGIS database in an Private Azure Cloud.
SSL encryption is enforced by my company. I'm using OC Map 10.17.

When I try to connect, I get an error message saying:
"Error Opening PostGIS Storage: A call to SSPI failed, see inner exception"

I checked with the Bentley helpdesk. They could not reproduce the issue on their side, but they suggested me to try again with a certificate.
Our database expert created a certificate file for me and in the meantime I found out about two MS-variables MS_SECURITY_LEVEL and MS_SECURITY_SPC.
MS_SECURITY_LEVEL was already set to NONE which indicates that OC Map was not doing any certificate check while trying to connect to PostGIS.
(So the issue is not related to the lack of a certificate???)
Still I tried to use the certificate, by setting MS_SECURITY_LEVEL to MEDIUM and by adding my certificate folder (and correct wildcard) to MS_SECURITY_SPC.
(The certificate file was named "DigiCertGlobalRootCA.crt.pem".)
But as a result, I got the same error message.

Any help on connecting to PostGIS in a Private Azure Cloud would be highly appreciated.