This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Import pipe and nodes from CAD data with ModelBuilder (inside SUDA)P. The conduit invert can't be change to be different from the bottom of node.

When importing from CAD data a model of nodes and pipes with ModelBuilder, I can't edit the invert level of one pipe at a node until I delete and recreate the conduit component (in fact done in SUDA). Any trick to avoid this?

Parents
  • In fact, I found that by default CAD import lock Start and End invert to node invert (Set Invert to Start? = True and Set Invert to Stop? = True by default), when it is false by default while placing a component. Replacing by value False in properties solves the problem.

    Thierry SAGE

    ProjectWise Consultant - Bentley Systems France

     

  • Hello Thierry,

     

    When importing data with ModelBuilder, if a property is not mapped in the field mapping step, the new element will take on the properties of the active prototype. The inverts and other hydraulic data are not included in the exported DXF. You’ll see there’s no invert elevation field to map to in ModelBuilder. The default conduit prototype has the set invert to start/stop set to True (create a new one to see this). So, the conduits will import like that unless you have a field in the data source to map them to, to set that to false. Unfortunately that setting can’t be changed in a new prototype.

     

    Please take a look at the following article.

    Conduit inverts not importing in ModelBuilder

     

    With that said, it is expected that when importing conduits with ModelBuilder the fields "set invert to start" and "set invert to stop" will be set to true. However it appears that these values are set to false only when placing new conduits only in SUDA, and new conduits are set to true in standalone. I will look into the reason for this difference and see if there is a way to change this default setting in SUDA.

     

    Regards,

    Craig Calvin

    Bentley Technical Support

Reply
  • Hello Thierry,

     

    When importing data with ModelBuilder, if a property is not mapped in the field mapping step, the new element will take on the properties of the active prototype. The inverts and other hydraulic data are not included in the exported DXF. You’ll see there’s no invert elevation field to map to in ModelBuilder. The default conduit prototype has the set invert to start/stop set to True (create a new one to see this). So, the conduits will import like that unless you have a field in the data source to map them to, to set that to false. Unfortunately that setting can’t be changed in a new prototype.

     

    Please take a look at the following article.

    Conduit inverts not importing in ModelBuilder

     

    With that said, it is expected that when importing conduits with ModelBuilder the fields "set invert to start" and "set invert to stop" will be set to true. However it appears that these values are set to false only when placing new conduits only in SUDA, and new conduits are set to true in standalone. I will look into the reason for this difference and see if there is a way to change this default setting in SUDA.

     

    Regards,

    Craig Calvin

    Bentley Technical Support

Children
No Data