This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Exporting to INP error


Every time I try and export my scenario to an inp I get the error "Object reference not set to an instance of an object." I downloaded the latest version of watergems today and tried again - same error. It only exports my junctions. Any help would be appreciated.


Parents Reply Children
  • Hello Taylor, 

    Thank you for uploading the model files, while exporting WaterGEMS model into EPANET format, if you choose No - use element ID's as reference and not use labels then model exports without any error. 

    The problem is with long labels of pipes, PRVs and patterns, apparently long labels are not supported by EPANET 2.XX.XX version, which can be seen in below screenshot. Once you export the model with option to choose export labels below user notifications are seen. 

    Workaround is to relabel the pipes, PRVs and pattern names and then export EPANET if you wish to use labels are reference, else you can choose to export IDs instead which would be a quick way. 


    Sushma Choure

    Bentley Technical Suppport

  • Hi Sushma, thanks for your reply! Unfortunately I get the same error even when I export IDs.

  • Could you please confirm what version of WaterGEMS you have now, is it  latest? A screenshot of user notifications you receive in WaterGEMS once you export INP file would be helpful. 

    I tried in both WaterGEMS and latest version, exporting IDs didn't give any error. 


    Sushma Choure

    Bentley Technical Suppport

  • Taylor,

    Unfortunately we're not able to reproduce this issue with that version, either before or after applying the latest related cumulative patch set. Most likely there is something different between your workflow or computer and ours. Please provide the following information to help troubleshoot:

    1) Are you certain that you sent us the correct model file? Maybe try re-sending, this time using the File > Save to Package option (sending us the resulting ZIP file) Please also identify the scenario you have active when exporting.

    2) In case one of the supporting files is somehow interfering, please try copying only the .WTG and .WTG.SQLITE files to a new folder on your local hard drive (such as your Desktop or My Documents), re-open it and try exporting again (with the ID option).

    3) Try opening WaterGEMS by right clicking on the shortcut and choosing "run as administrator", then try exporting again.

    4) Try choosing a different location to save the exported INP file, and choose a simple name to see if it makes a difference. For example "test.inp" on your desktop.


    Jesse Dringoli
    Technical Support Manager, OpenFlows
    Bentley Communities Site Administrator
    Bentley Systems, Inc.