Filtering a Flextable on Zone = "None"

Product(s): WaterGEMS, SewerGEMS, CivilStorm, StormCAD, PondPack, SewerCAD, HAMMER, WaterCAD
Version(s): 08.11.XX.XX, 10.XX.XX.XX
Area: Modeling

Problem

How can you filter a flextable on Zone = "None"?

Problem ID#: 46478

Solution - Option 1

In the query builder, type 'IS NULL' after the attribute name, and it will retrieve all elements with the attribute set to "<None>".

Solution - Option 2

(for CONNECT Edition and greater)

  1. In the query builder, type '>1' after the name of the attribute and click OK. This will select all elements of that current type that do have a zone set
  2. Click Options > Select in Drawing,
  3. Reset the flextable's filter, then close the flextable
  4. From the Home tab, click Select > Invert Selection
  5. Right click in the drawing > Edit Group > select the respective flextable > OK. The table should now be filtered on elements that have the Zone set to "None".

Solution - Option 3

  1. Create a selection set of all elements of interest. You can right click in the drawing and choose "create selection set" when the elements are selected.
  2. In the query builder, filter on 'Zone > 1', then select elements in the drawing.
  3. When the elements that have 'Zone' already set are highlighted in the drawing, right-click and select 'Remove from Selection', and choose the selection set from step 1
  4. Now, double-click on the selection set > right-click > edit group > select the respective flextable > OK. The table should now be filtered on elements that have the Zone set to "None".

See Also

Filter FlexTable to only show active elements

How do I filter a column in my flextable using a custom query that retrieves all records with a <None> attribute?

Anonymous
Recommended
Related