How can I reduce the number of pipes in my model?

  Product(s): WaterGEMS, WaterCAD
  Version(s): CONNECT Edition, V8i

Problem

How can the number of pipes be reduced in a WaterCAD or WaterGEMS model?

Solution - Skelebrator

To reduce the number of pipes in a model try to combine pipes that have equivalent diameters and roughness. The Skelebrator tool can help automate this and is available in WaterGEMS. If you have WaterCAD, you will need to upgrade to WaterGEMS to access Skelebrator.

Note: in the distant past, WaterCAD users could purchase Skelebrator separately, but this is no longer possible. Also, starting with CONNECT Edition Update 2 (10.02.00.43 and greater), the Skelebrator tool is no longer accessible from within the WaterCAD user interface. See more on Skelebrator in the articles linked to further below and in this video.

Note that when using Skelebrator, elements will be deleted in order to accomplish the skelebration. If you want to maintain separate scenarios in the same model for before-and-after skelebration, you'll need to first save separate models, and then use Submodel import. See this discussion and this article for more information.

Solution - Other Options

If you have hydrants, considering placing them on the main pipeline, and model the lateral losses using the embedded properties in the hydrant (rather than adding the extra lateral pipe.

You can also use Laterals and Customer elements to assign demands along the length of a pipe instead of creating extra nodes (which split the pipe). As of version 10.00.00.50, lateral link elements do not count toward your pipe limit.

Furthermore, you can also use isolation valves instead of valve node elements (like GPVs or TCVs) to model valves, as the isolation valves do not split the pipe. If you have already imported isolation valves as another valve type such as a GPV or TCV, you can convert them to isolation valves using the Inline Isolation Valve Replacement tool in Skelebrator (in WaterGEMS).

See Also

Series Pipe Merging in Skelebrator not working for pipes with zero diameter

Pipes not merging when using Skelebrator with series pipe merging

Customer Meter Elements and the External Customer Meter Data Manager
 

Recommended
Related