Drawing pane is blank or empty - no model elements appear

  Applies To 
  Product(s): WaterGEMS, WaterCAD, SewerGEMS, SewerCAD, StormCAD, HAMMER, CivilStorm
  Version(s): 08.11.XX.XX, 10.XX.XX.XX
  Area:  Data Input
  Original Author: Sushma Choure, Bentley Technical Support Group

Problem

No elements appear in the drawing (the drawing pane is blank) when the model is opened, or after importing data through ModelBuilder.

Solution

  1. Go to View > Zoom > Zoom Extents. This will pan and zoom to fit all elements in the drawing pane. 

  2. There may be some elements or parts of a background layer far off in the distance from each other. Try turning off the background files, then zoom extents per step 1 above.

  3. After using zoom extents, go to Edit > Select All (or press CTRL+A with the drawing pane active) and see if something highlights in the drawing pane.The default highlight color is red; look for a small red dot. If you see something, try changing your drawing style from CAD (which is the default) to GIS style, which will help you see the elements (and then you can zoom into them). This is done from the icon on the element symbology manager. If you do a search for "drawing style" in the help documentation there are step by step instructions for how to do this. You can also check the below article under See Also.

    If there are elements far off in the distance causing Zoom Extents to zoom too far out, this could be a problem with the spatial reference of the data that was imported (or a units issue) or possibly a color coding legend inserted far off in the distance. Try right clicking on any color coding definitions in Element Symbology and choose the "remove legend" option if present.

  4. Try going to File > Database Utilities > Synchronize Drawing. 

  5. Check all node flextables for "NaN" or "infinity" for the X/Y coordinates. Use the yellow Edit button to add the X and Y fields if not displayed, then sort on both fields and look at the top and bottom. Do this for the flextable corresponding to each element type in the model. If you see any with "NaN", "N/A" or "Infinity", fix the coordinates of these nodes (right click the row header > zoom to > change the X or Y in the properties) or delete the element (right click > zoom to > right click in the drawing pane > delete). If needed, you can export the flextable as a CSV file using the export button in the top left corner, then change the X and Y in Excel to the correct value or to something else like zero, then use Modelbuilder to only "update" changes, mapping the label as the key field and the X and Y fields. (or use the "Select column" option in the flextable, then use the Paste button to paste. If there are many elements with bad coordinates and you just imported them, correct the geometry in the source file first, then rebuild the model with Modelbuilder.

  6. Try deleting the model's .WTG.DWH file (with the same base file name as the model, in the same folder), or move only the .WTG and .WTG.SQLITE files to a new folder and re-open from there. The .DWH file contains information on how the drawing pane appears.

  7. If the problem is not model-specific and nothing is showing in the drawing pane (the screen is gray / grey), the problem could be related to your video drivers. See: Updating video drivers and troubleshooting video hardware issues

See Also

Building a model with Modelbuilder

Importing dxf as background

Updating video drivers and troubleshooting video hardware issues

Recommended
Related