Smooth contours are being overlapped

Product(s): WaterGEMS, WaterCAD, SewerGEMS, CivilStorm, SewerCAD, StormCAD
Version(s): 08.11.XX.XX and 10.00.00.XX
Area: Output and Reporting


When using the "Smooth Contours" feature, some of the lines overlap and loops are created. Is there a way to correct this?


The smooth contours are adjusted from the straight line contours and these issues are common when the straight lines they were created from are sharp (acute) angles. The smoothing algorithm used looks at each contour individually and doesn't consider adjacent contours.

Example with "Smooth Contours" disabled:

Example with "Smooth Contours" enabled:

The best way to avoid overlap is to simply use a wider contour interval.

Example with "Smooth Contours" enabled and increased interval:

Also note that the quality of any contour depends on the density of data points. For example, a model with 100,000 nodes will have a much better looking contour plot than one with 10 nodes.

Enhancement Request #641196 was submitted to implement an improved smoothing algorithm.

See Also

Forum Thread: WaterCAD contour smoothing