Animating in Profile or Time Browser Very Slow or Causes Hang (Not Responding)

Applies To
Product(s): WaterGEMS, WaterCAD,  SewerGEMS, SewerCAD, CivilStorm, HAMMER
Version(s): V8i, CONNECT Edition
Area: Modeling

Problem

In certain situations, animating a Profile or the Timestep Viewer is very slow and maybe even display "Not Responding" in the window's Title Bar.  The process is still running, just very slowly.

Solution

The default setting in a model is to have the Auto-refresh setting turned on.  Having a large number of color codes assigned to nodes in the model or anything else that the program has to refresh while it changes timesteps (like results in flextables, properties, etc.) has caused animating a Profile or the Timestep Viewer to run very slowly and even display "Not Responding" in the window's title bar.  The process is still running, just very slowly.  This could also possibly happen if there are a lot of annotations in the model.  Closing the Flextable and/or Properties dialogs can help performance and should speed things up.

If the model is too large or you cannot remove the symbology – you can temporarily turn off auto-refresh while you animate the profile. 

If that doesn't help, try going to File > Database Utilities > Synchronize Drawing. (or for V8i, Tools > Database Utilities > Synchronize Drawing)

You can also try deleting the model's associated .DWH file (which will be regenerated upon reopening the model), or try moving just the starter file (.WTG for WaterGEMS/WaterCAD, .STSW for the storm and sewer products) and the database file (.SQLITE) to a new folder location and re-compute the model.

See Also

How do you add color coding to an element?

  • Created by Bentley Colleague
  • When: Fri, Jan 17 2020 12:06 PM
  • Last revision by Bentley Colleague
  • When: Fri, Feb 7 2020 10:44 AM
  • Revisions: 3
  • Comments: 0
Recommended
Related