Print Preview > Fit to Page shows blank page or Reports will not print

Product(s): WaterCAD, WaterGEMS, SewerGEMS, SewerCAD, CivilStorm, StormCAD, HAMMER
Version(s): 10.XX.XX.XX, 08.11.XX.XX
Area:  Output and Presentation



When trying the print a model layout, the "Fit to Page" option of Print Preview shows a blank page with no model layout visible at all.


Print preview screen is blank when DXF attached as background

When a .DXF is attached as a background file, the Print Preview screen was appearing completely blank.

Without the .DXF attached, the model was shown in Print Preview as Normal.

You receive the message that No printers are installed

Problem ID#: 73627


This can be caused by a corruption in the model's .dwh file. This file can impact the appearance of the model in the drawing [pane and in functions like Print Preview.

To resolve this, go to Tools > Database Utilities > Update Database Cache. For the CONNECT Edition software go to File  > Database Utilities > Update Database Cache

If that doesn't help, try the following. Close the model and browse to the location that the model is stored. Find the .dwh file--it will be called something like "model.wtg.dwh"--and delete this. This file will be regenerated when you reopen and save the model.

With that file deleted, reopen the model and go to File > Print Preview > Fit to Page. For the CONNECT Edition reopen the Print Preview. The model layout should be visible in the Preview window.

If it still appears blank (no model displayed) then try this

  1. Go to the Element Symbology dialog and double-click on Junction
  2. In the Properties grid that displays for Junctions find “Zoom Dependent Visibility” 
  3. Set Enabled = True and Zoom Out Limit (%) = 10
  4. Click File - Print Preview and use the Fit to Page option

You should now see your model in the Print Preview window.  If the model seems too small with lots of "white space" around your model elements on the page, adjust the size of the WaterGEMS window to fit more closely around your model.  This should allow your model graphic to fill more of the paper space in the Print Preview window as well as the actual printed version. This Wiki article explains this in more detail.

Blank Print Preview with a .DXF background

To fix this issue, open the .DXF in AutoCAD and save down to an older version of DXF. For example, AutoCAD 2004, R12/LT2, 2010.

The DXF will now appear in Print Preview.

Reports will not print

You might also receive the message No printers are installed

Go to Control Panel > Devices and Printers and make sure one of the defined printers is set to be the "Default Printer".  It will have a check mark on it to designate that it is the "Default Printer".  If no device has been designated as the "Default Printer", right-click on one of the printers and check the option in the pop-up menu to Set as Default printer.  Then try printing your report again and see if you are prompted to select an output location.

See Also

Using the fit to page printing in the standalone platform

  • Created by Bentley Colleague
  • When:
  • Last revision by Bentley Colleague
  • When:
  • Revisions: 14
  • Comments: 0