Text, cells/blocks and line styles do not display correctly in a DXF background layer

Product(s): WaterGEMS, WaterCAD, HAMMER< SewerGEMS, SewerCAD, StormCAD, CivilStorm, PondPack
Version(s): 08.11.XX.XX and 10.00.00.XX
Area: Output and Reporting

Problem

When attaching a DXF as a background layer the text, labels and cells/blocks do not display correctly in the standalone platform.

Reason

The standalone platform's background layer display capabilities has minimal support for mtext (multi-line text) and cells. If it is mtext you will need to change it to either regular text or another type of text.

Steps to Resolve

In AutoCAD you can use the "explode" command 

  1. Open the DXF file in AutoCAD

  2. Select all the text and blocks by right clicking in the drawing and using the "quick select" option from the pop up menu.

  3. Set up your quick selection options to select all the mtext labels and blocks in your drawing file.

  4. After everything is selected use the "X" (explode) command on the command line. This will convert all your "mtext" to regular "text" and break the blocks into pieces.

  5. Save the file.

  6. Add the file as a background layer.

Note: It is a good practice to purge unused or nested blocks and attributes in the drawing. Often when multiple users work on a drawing, there are lot of vestigial blocks, line styles, hatches etc. which may cause exaggeration of text or make the DXF appear generally skewed. Purging these unwanted objects/blocks cleans up the DXF to make it more suitable for viewing.

Additionally it is also better to check if your DXF is referencing external drawings (XREF) which are not available for import. These drawings should be detached to ensure you work on the intended DXF.

In few cases it was seen that DXF elements "wobble" when zooming into the drawing pane and "move" from their original location. This proves difficult to layout elements based on the DXF background. In such cases, check the scale of the drawing by opening the DXF in an a CAD platform like AutoCAD or MicroStation. This can happen when the scale of the original drawing is too small. If the scale is too small try increasing it by a factor of 100 or 1000 and export to DXF. Doing this gets rid of the "wobbling" of DXF elements.

In Microstation use the "drop element" tool

  1. Select all the text the need to display in the background file

  2. For text and cells, use the "drop element" tool. Make sure the drop element settings has the "Complex", "Text" and "Linestring/Shapes" checkboxes selected.

  3. For line styles, go to Tools > Custom Linestyles > Drop Line Style. Then select the Line Style to be dropped and click to accept.

See Also

Attaching a DWG DXF or DGN as a background

Is it possible to change the font for text in DXF backgrounds and annotations?

After exporting a model to DXF, text appears shifted in the resulting DXF file

Recommended
Related