Element is visible in the flextables but not visible in the drawing

Product(s): Bentley WaterGEMS, WaterCAD, Hammer, SewerCAD, SewerGEMS, CivilStorm 
Version(s): CONNECT Edition, V8i
Area: Modeling

Problem Description

Information related to the elements are visible in the FlexTable however the element(s) itself is not visible in the drawing.

Steps to Resolve

First check if the model elements like junctions, manholes, hydrants etc. contains invalid X & Y coordinates such as ∞ (infinity), if yes then please change coordinates of those elements and then compact the database as mentioned below. 

If that is not the case then, follow below options.

Option 1

In order to synchronize the modeling data and the drawing, For V8i go to Tools > Database Utilities > Synchronize Drawing.

And for Connect Edition, go to File>Database Utilities>Synchronize Drawing.


When prompted, click Yes.

In AutoCAD integrated mode, this is located under the WaterGEMS ribbon > Hydraulic Model > Database Utilities:

Option 2

1) With all models closed and the program itself open, For V8i go to Tools > Database Utilities > Compact Database and for Connect Edition go to File>Database Utilities>Compact Database.

2) Choose the model's database file 

3)  Select the option to purge the database to save space

4)  Open the model and go to Tools/File > Database Utilities > Synchronize Drawing.

This should update the drawing so that any elements that should be in the model appear in the drawing.

Option 3

1) Close the model and make a copy of just the model starter file and the database file. For WaterGEMS, this would be the .WTG and .WTG.SQLITE (or .WTG.MDB for older versions).

2)  Move these to a new folder location and open the model from that new location.

This may help if there is an issue with one of the supporting files.

See Also

Changing drawing style for better viewing of element symbols and annotations 

Elements are not visible in the MicroStation platform but are visible in standalone