V8i, SS3 - AutoCAD drawings displaying rotated text callouts when opened in MicroStation

I have a drawing created in AutoCAD which contains Civil 3D notes (stations and offsets). The drawing looks fine when opened in AutoCAD. However, when I open the same drawing in MicroStation, I notice that some of these callouts are rotated and do not look like they should. When I open the draing in AutoCAD again, the callouts appear to be rotated correctly.

It seems like MicroStation is having trouble with certain elements created by Civil 3D in AutoCAD. When these elements are placed in model space and the model space is rotated in paper space, these elements (I believe they are AECC blocks or cells, they are not text elements) seem to want to line up with the unrotated view instead of following the desired rotation on each sheet. 

The figures below were captured from my screen, opening the same drawing in AutoCad and in MicroStation.



  • Hi,

    Unknown said:
    It seems like MicroStation is having trouble with certain elements created by Civil 3D in AutoCAD.

    I saw similar issue (not sure if completely the same) in the past in a plain AutoCAD drawing, so I guess it's a problem in DWG format support in MicroStation not specific to Civil3D only.

    Are you able to test the drawing with MicroStation CONNECT Edition (right now available for early access testing for SELECT customers)? Or to share the drawing (or its part) to be tested? Right now is a good time to report such issues, so they maybe solved in the next version (or they even are solved already).

    With regards,


  • Without seeing the actual file I can only make a guess: assuming your screen capture was from a viewport in a paperspace the C3D object enabler might be drawing its leader in the viewport differently than in modelspace. Currently in MicorStation, an element referenced in a model is always transformed with the reference attachment together, and itself does not have a branch display or transformation that is different than that of the ref attachment. If this is not your case, maybe you can upload a test file that shows the problem.