[V8i] DGN file created in V8 2004 does not look the same when opened in V8i.

Hi there, this is my first post on this forum.

I have a problem with some of the drawings/models created by our contractor in Microstation v8 2004 and TriForma. When I open them in v8i SS3 some elements are missing. 

The screenshots below show the same dgn file opened in v8 2004 (left) and v8i (right). As you can see the U-shape grey shading is not shown in v8i, although all the levels are turned on. According to file properties this drawing was created in Microstation v8.5.2.55, but the element information tools says the missing object is TriForma Solid.

My question: is there an option or variable in Microstation v8i I should change to make it displaying this drawing correctly?

  • Hello,
    Could you specify the version of MicroStation Select Series 3, you are using (xx.xx.xxx.xxx)?
    Is there any message in the Message Centre when the file is opened?
    Could you post the files for testing?
    Derval Canny.

  • Derval,

    I am using v08.11.09.459 but this problem also exists in SelectSeries4.

    The only messages in the Message Center are:

    MCM unloaded.
    MCMTB loaded.
    MCM loaded.

    I don't see an option to upload a file on this forum so I've put it on my google drive. Please follow the link: 


  •  In the older versions of MicroStation ( V8 2004 in this instance ) and Triforma a view had a render mode, not a display style.

    In the Settings > View Attributes dialog ( Ctrl+B) you will see the display style is set to "(Wireframe Display)". You could change the Display Style.

    For example: Take a copy of the Wireframe display style and rename as 'Example' and under Render Mode change the Display: to Shaded. Now in View Attributes select the new Display Style: Example. The shading will then be displayed in the view.

    If the element is selected with the Element Information Dialog open and Cell:TFFILL is selected it will also display the fill

    with it still selected you could also use the ' Drop Element ' tool with the tool Setting 'Application Elements' checked and drop the element ( You may need to repeat the operation depending on nesting ).

  • Changing render mode to SHADED does not help because it affects other objects. See the parallelogram just below the object I have problem with. It should not be filled with colour.

    So far dropping element is the only solution but it's not what I was looking for. I have over 5k dgn files and I don't want to drop every element that is not displayed properly. I tried it a few times and in some cases dropped TriForma object lost its geometry.

    SHADED ON                                                                                                                                   SHADED OFF

  • I apologies whilst reviewing I was zoomed in at the time and did not notice the adverse affect on other elements.

    I just opened your file directly without any changes in the latest version MicroStation CONNECT Update 2 and this appears to display correctly. This may have been the result of a fixed defect. TBC.