The snaps demon keeps turning my snaps off - Need an exorcist.

Hi,

I'm an experienced AutoCAD user, brand new to microstation.  Using V8i. 

First question:  Is there any good "If you know how to do it in AutoCAD, here is what you do in microstation" type guide for common tasks?   I find that microstation has a very non-intuitive user interface.  Things simply don't work the way you expect them to and even simple tasks are an exercise in frustration.

Second question:  Snaps not working.   I want to snap to end points, midpoints, intersections, and centers.   So I went Settings > Snaps > Multi-snap and I checked the appropriate boxes in the Multi-Snap 1 dialog.   I then selected Multi-Snap 1 as active and went to start drawing.   But it doesn't work.   It snaps only to end points, nothing else.   So I go back in the menu and I see that Multi-Snap 1 is not selected.  Keypoint is selected.  I figure that I'm a doofus who forgot to actually turn it on, so I select Multi-Snap 1.    Still not working.   Go back and see that Keypoint is once again selected.  So I select Multi-Snap 1 again.  This time I pull down the menu a second time and visually verify that there is a black dot right next to Multi-Snap 1.  Ok, its definitely selected this time.   Try to use it, still not working, go back to the menu and now keypoint is selected again!!

How to exorcise the demon in the machine that keeps turning my snap back to Keypoint after I select Multi-Snap 1?

Third question:  I want to do the microstation equivalent of exploding a polyline into line segments.   I have learned that the Microstation calls the explode function "Drop", and calls polylines "line strings". 

So I select the line string that I want to drop and I type DROP in the key in.  Nothing happens.  So then I try pulling down the menu and selecting the drop tool.   It displays a do not enter sign when I hover the cursor over the line string that I want to drop.  

How can I make it work to drop a line string into lines?

Thanks for your patience.