Need help working from home with your Bentley software? We're here to help - click here

Copy cell from one drawing to another and it disappears

Hi,

Is someone here pro in MicroStation can someone help please  when I go to copy a cell in microstation from one drawing to a different drawing it disappears after I accept the placement.

 

So for example I have a cell for a normally open relay contact.   I want to steal it from another drawing, so select it from that drawing, control-C to copy to clipboard, go to the new drawing, control V to paste it into the drawing.

So far so good, I can see it and it moves around as I decide where to insert the pasted object.   Then I make my selection and, Poof, its gone.    However I have discovered that if I first drop the cell to geometry before pasting it, then it always works fine.   But I really dont want to drop big complex cells to geometry, it effectively breaks them in my opinion.

I tried an experiment where I created a new blank drawing from the default 2D seed file.   I then tried pasting various blocks into that new blank drawing.   I discovered that certain ones will paste in fine and others will promptly disappear unless dropped to geometry first.

I have verified its not pasting into a level that is turned off. 

So what is causing this odd behavior?  How can I make paste work without dropping the object?  And why does it only disappear some times but not others?  

Parents Reply
  • Thanks for answering me i use MicroStation v8i

    That's vital information for anyone attempting to answer your question.

    Actually i have converted autoCAD files to MicroStation

    Also vital, because of your issues with shared cells.

    AutoCAD has blocks; MicroStation has shared cells as well as normal cells.  When you open a DWG file in MicroStation it will have a set of shared cells created from the DWG blocks.  A MicroStation shared cell may be placed multiple times.  Each shared cell instance references a shared cell definition.  A shared cell definition is a set of invisible elements stored in the DGN file.

    When you attempt to use copy-and-paste with a shared cell, it fails because the destination file doesn't have a shared cell definition.  You must have an existing shared cell definition in that destination file for the copy to work.

    Perhaps others can suggest better ways to achieve your goal.  What I would do is to save your DGN file, copied from DWG, as a cell library: that is...

    1. Do File|Save As and assign the new file a  .cel extension 
    2. Open that new cell library in MicroStation
    3. Open the Models dialog
    4. For each model that you want to use as a cell, set its Can be Placed as Cell property
    5. Close the cell library
    6. Open the destination file where you want to place those cells
    7. Use MicroStation's place cell tool to place cells from that library

     
    Regards, Jon Summers
    LA Solutions

Children