Change to the WorkSpace and WorkSet will not be remembered...

Hi,

I sometimes get this dialog box:

I have "No WorkSpace" and "No Workset".  What changes is Microstation trying to save?  Is there a particular user configuration file that can be updated?  (IE, What is the path to that file?)

Is there any issue with the "Do not display again" option?

--Thanks,
--Robert Arnold

  • This is most likely a permissions issue to the user configuration file. When changing workspaces/worksets the last used are saved to the UCF.

    Is there a particular user configuration file that can be updated?  (IE, What is the path to that file?)

    If you check the "About Configuration" dialog the path to the UCF will be shown.

    The message is just notifying you that the UCF could not be updated.

    Is there any issue with the "Do not display again" option?

    If you are getting no workspace/no workset when you open MS there should be no issue in enabling that option. I would suggest though that you make sure that you have read/write permissions to the location where the UCF is stored.

    You can refer to the following:

    Error - user configuration file could not be updated

  • Because I don’t know if you made an changes to your configuration, the easiest way to find what user configuration file you are using is to check the variable _USTN_USERCFG. Open any drawing and check the variable.

    The default file is : C:\Users\<YourLogin>\AppData\Local\Bentley\MicroStation\10.0.0\prefs\Personal.ucf

  • Hi Robert

    This error also occurs if the file "C: \ ProgramData \ Bentley \ MicroStation CONNECT Edition \ Configuration \ ConfigurationSetup.cfg" is write protected! You may check if you have write accesses to this file. If that's the case the error message is wrong because MicroStatin does not write the actual WorkSpace and WorkSet to ConfigurationSetup.cfg - as David and Pellet writes: MicroStation write this in the user configuration file.

    About the ConfigurationSetup.cfg
    This file tells where the $ (_ USTN_CONFIGURATION) folder is placed (line # 27) Unfortunately MicroStation wants to write the actual path to $ (_ USTN_CONFIGURATION) in this file.
    Until Update 15 the path was changed to a hard coded path instead of using the cfg.variabel $ (_ USTN_CUSTOM_CONFIGURATION). This was a bug which I have discussed with Marc Thomas who have created a change request to correct this. Because of this I normally write proctect the ConfigurationSetup.cfg! ...and sets a checkmark in "Do not display again".
    In Update 16 they have changed this so _USTN_CONFIGURATION = $ (_ USTN_INSTALLED_CONFIGURATION) ... this is in my humble opinion also wrong but I havn't yet investigated this change futher! In my opinion it should be _USTN_CONFIGURATION = $ (_ USTN_CUSTOM_CONFIGURATION)

    Best regards

    Anders