Max gap ratio


Where can I find the settings to change the gap ratio to numbers in microstation v8i ss3 version windows 10 when measuring the area using the flood option.

Appreciate your help.



  • Hi Steve,

    to change the gap ratio

    There is no "gap ratio" settings, only "gap" in a meaning of distance (gap size).

    As wrote, the format, how values are displayed, is defined by working units settings.

    when measuring the area using the flood option.

    It would be nice to share an example of geometry where the measuring does not work. It's not clear how you working units are set, but 0.00012 of sub unit looks like under standard resolution setting, so probably no gap is accepted.

    Please, do not use docx to share images. To open untrusted docx files is generally dangerous (because can be malicious). Why to not attach to the post jpg file directly?

    With regards,


  • I found the max gap on flood fill create region seemed to work better  in v8i  than in Connect 13 ... but it might just be my data..

    example would be I have 0.02m actual gap  in a line  ie they are not joined or single line, in V8i  I would set the max gap  trial and error  a few times and it would literally jump the gap and create a closed element  fill.. but in connect this is not working for me no matter what number I set.. I just have to go find gaps when it wont fill.. I suppose  I should use data clean up flag gaps  but the source file is a ref file and i want to create coloured filled shapes in the active file.....anybody else found this or figured it  out? My quick fix is to make smart line criss cross  over several places in my  line work then try and flood file in between until I find the little portion that  refuses to fill ie enclosed.. ( by the way arcs in complex lines are  particularly sensitive to this not working in Connect 13 for me..


    Now Retired 25 Nov 2022

    But was long time user V8iss10 ( dabbler CE  update 16 ( 

    MicroStation user since 1990 Melbourne Australia.
    click link to PM me 

  • We have noticed the same. The max gap on flood fill create region works better in v8i than in any versions of CE (currently CE16). That is one of many CE related problems that keeps our Microstation users using V8i SS10 instead of CE. We are using flood fill a lot  so this is a harmful bug.

  • I have reported it that Max(imum) Gap is not working as expected but got reply that it is WAD. Asked then to at least explain it in documentation but nothing has changed.

    The help is wrong, it has never worked in v8i or CE the way it is explained in help. Even when connected the end points it didn't connect by shortest distance but connected point before last point to first point. I no longer show max gap as an option to users as it is too complicated to explain what to expect just set it to 0:

    Max Gap:(Method set to Flood only) Sets the largest distance allowed between consecutive elements. If zero, the elements must connect to bind an area.

    Screenshot from year 2014:

  • Ok I built some new data then tried in both v8i and CE  and it still works as it always has even with arcs and  islands the trick is understanding what that max gap means so in my  new example I have complex line , arcs and straights but a deliberate GAP between an Arc and a  line of 0.00955 m  when I try flood   with max gap 0 or 0.01, or 0.1 or 0.2  it fails and spills out , 

    However in both versions if I set the max gap to 0.015 it jumps the gap and creates the filled region and locates the interior islands

    I tried 0.012 and it fails  even if rounded up my real gap 0.01m  so it works but the number of the max gap doesnt really relate to the true gap as it would be expected... previous results must have been the data itself was bad leading to false conclusion regarding Connect edition and this tool.. but I only tried a single set of line works...


    oops I thought I did .. went off line before I noticed .. now attached


    Now Retired 25 Nov 2022

    But was long time user V8iss10 ( dabbler CE  update 16 ( 

    MicroStation user since 1990 Melbourne Australia.
    click link to PM me 

  • so in my  new example

    Why you do not share your example? Just to talk about the data it quite useless...



  • ok posted  dgn so anybody got solution how to determine what  the right  number is  or  really means


    Now Retired 25 Nov 2022

    But was long time user V8iss10 ( dabbler CE  update 16 ( 

    MicroStation user since 1990 Melbourne Australia.
    click link to PM me 

Reply Children
  • I may have stumbled onto something and I don't like my findings one bit...

    Looking at your DGN file, there is actually another gap North of your annotated gap.

    I work in millimetres and my files always open in that unit so I will continue my post using those values.

    The true distance of the annotated gap is 9.55mm (to 2DP)

    The true distance of the additional gap is 15.27mm (to 2DP)

    When I set the max gap value to 15.27 the region works

    I manually tested different smaller values reducing by 0.1 and then 0.01 until I found that 14.79 works but 14.78 does not.

    Here comes the bad part...

    We all likely expect the gap value to the be the magnitude of the vector from 2No points (i.e. the true distance), however when I dimensioned the gap, I found the largest orthogonal dimension closely matched the value I had determined manually!

    Fearing the worst I decided to change the dimension accuracy and max the design file accuracy to 6DP:


    It seems my fear is unfortunately true (right click on the image and open in new tab/window for true size):

    In the above capture I measure the largest orthogonal distance using Distance between Points, copy the value and paste that in the the Create Region gap box. You can see the highlight shows the outer and inner boundaries are valid and that the region can be created. After cancelling, I reduce the gap by 0.000001mm (one millionth of a millimetre!!) and sure enough the region creation fails. 

    1 instance doesn't prove anything and could be a freak result, so I used modify element to align the above endpoints and tried the same proof with your original gap. The difference is its smaller and that the largest size is measured horizontally instead of vertically however I found the exact same result that reducing the gap size by 0.000001mm from its X dimension causes it to fail.

    Shoddy work Bentley, very Shoddy!

    Now my V8i SS10 feels somewhat tainted 

  • Excellent analysis!  You provide examples and show your working.  If only everyone would do the same!

    Regards, Jon Summers
    LA Solutions

  • Did you notice that it doesn't actually try to close the gap but just ignores it and connects to next point. This is what is not expected by users as for area measurements it introduces larger calculation error. Seems this max gap algorithm was introduced decades ago for some specific workflow and has not changed so that is why not possible if it is WAD or bug. Not to mention the tolerance setting which finally was removed in CE but even before that was not working.

  • I'll just have to use data clean up in a fence to find gaps and  overlaps and fix the line work which is what I feared was the problem...

    1 - 2 cm gaps  in a meters  world with road pavements  several hundred meters long and 2- 4 lanes wide  is tiny error  for jumping gaps and  creating filled coloured areas for measuring later by levels is not too bad  as your going to round up answers anyway.. but I agree this tool should be better and easier to predict ie  tolerance actually means something  relating to the gap distance permitted... for now the zig zag smart line helps find the gaps a but faster  when the source file is a reference file from modelers  and i just want to use active file for creating coloured filled regions 


    Now Retired 25 Nov 2022

    But was long time user V8iss10 ( dabbler CE  update 16 ( 

    MicroStation user since 1990 Melbourne Australia.
    click link to PM me