Bentley View and Microstation DGNLIB

I have recently installed Bentley View CE U15 using the same Configuration for View as for Microstation CE U16.1

However, upon opening ANY file, the program fails to open a DGN file
(after spinning its wheels for a while on "File Open Progress", Opening Mode, Reading Model, File: The DGNLIB, Model: --)
and ends with Bentley View has detected a problem and logged it to....
Abort, Retry, Ignore

Problem is, the exception log file is empty, so no clues there.
The Debug file shows no hints (understandable as this file is created before the program attempts to open a file)

The previous version of Bentley View opened the DGNLIB fine, however, I had made some changes recently (for MS U16) so cannot be sure of exactly if it would have failed.
If I change the Configuration file to not use the DGNLIB, it opens files fine. However, it is necessary as the DGNLIB controls the content for ITEMTYPES library.

Question is, what elements in the DGNLIB could be causing View to fail to open a file?

Parents
  • Update.

    I made a new DGNLIB file based on MS U16.1 Seed files, and populated it with ALL the elements from the original DGNLIB.

    i.e. LEVELS, MODELS, ITEMTYPES, TABLESEED, etc.

    No problems opening View now with this as the DGNLIB.

    I am sure, if we had the file repair tools promised by Bentley, that there would be issues found in the DGNLIB file that are causing this phenomena.

    Personal conclusion. As I have suspected for a long time now, and a few recent versions, MS/View CE seems to be highly sensitive to files with historical roots dating back to Version 5.0 days.

    If you can, I recommend updating your old SEED files and DGNLIBS with examples from the new files.

    I am happy to be found that this is all conjecture, and the issue is something innocuous, but I have spent hours trialling various ideas, and this is the only one that worked.

    Greg Smith

    Microstation 10.17.01.058

    Opinions expressed are my own and not necessarily those of my employer

Reply
  • Update.

    I made a new DGNLIB file based on MS U16.1 Seed files, and populated it with ALL the elements from the original DGNLIB.

    i.e. LEVELS, MODELS, ITEMTYPES, TABLESEED, etc.

    No problems opening View now with this as the DGNLIB.

    I am sure, if we had the file repair tools promised by Bentley, that there would be issues found in the DGNLIB file that are causing this phenomena.

    Personal conclusion. As I have suspected for a long time now, and a few recent versions, MS/View CE seems to be highly sensitive to files with historical roots dating back to Version 5.0 days.

    If you can, I recommend updating your old SEED files and DGNLIBS with examples from the new files.

    I am happy to be found that this is all conjecture, and the issue is something innocuous, but I have spent hours trialling various ideas, and this is the only one that worked.

    Greg Smith

    Microstation 10.17.01.058

    Opinions expressed are my own and not necessarily those of my employer

Children
  • if we had the file repair tools promised by Bentley

    Ah.... when did they do that?

    I still miss the  good old Edg  tool from way back when....somebody even made a gui for it  not long before we changed to V8i and then it didn't work anymore.. really disappointing that Bentley have not come up with something more robust than the  built in functions which hardly ever fix anything really bad .. ie can't open the file bad.

    Lorys

    Now Retired 25 Nov 2022

    But was long time user V8iss10 (8.11.09.919) dabbler CE  update 16 (10.16.00.80) 

    MicroStation user since 1990 Melbourne Australia.
    click link to PM me