Important Information - 3D PDF Performance & Display Problems in Acrobat Reader (please pass on)

I will preface this thread by stating that I have not posted this into the Printing and Plotting Forum as the discussion does not relate to the production of 3D PDF's from Bentley products (I don't want to read a single comment about best practices!). This thread's sole purpose is to serve as a source of information, and to advise my fellow MicroStation users (specifically those who use 3D PDF's) of a major issue, and how to solve it. Hopefully, Bentley Staff will also read this, test the findings for their own satisfaction, and relay the information to their support teams who may be asked about the issue by users.

Problem:
I recently noticed that when I opened up some of my existing 3D PDF files, which were created in MicroStation V8i, that the display in Acrobat Reader DC was terrible. Lines were not thin and sharp, but chunky and jagged, clearly no Anti-aliasing was being performed. The performance of Zoom, Pan and Rotation operations was also extremely slow.

What happened Next?:
I opened up the settings in Acrobat Reader, and ensured that the required settings were set correctly. For those of you not familiar with 3D PDF's, the default settings do not allow a 3D PDF to display as intended so you need to change a couple of things. The following screenshots are how the settings should look:

  

'Enable playing of Multimedia and 3D Content' is pretty self-explanatory, 'Enable Protected Mode at Startup', for whatever reason, causes Acrobat Reader to not use your GPU for the display, so disabling this is a must.

Sidenote:
There are discussions on Adobe forums (and elsewhere on the internet) where its written that disabling this one setting, solves all the problems with 3D PDF's not displaying correctly. I'm here to tell you that it doesn't, its simply one step which needs to be taken.

After confirming the above was set correctly, I found my display was still the same so the next step was to look at my Graphics Card drivers. I found I did have a recommended update so I downloaded them, performed a clean install and opened up a 3D PDF again, the result was still the same.

By this time, I already knew the problem:

For whatever reason, Acrobat Reader is not giving me the choice to choose DirectX and thus use my GPU.

Next thing I checked was the settings in my Nvidia Control Panel; I had seen images online of 'Manage 3D Settings/Program Settings' where you can specify an application to use integrated graphics or a GPU, but I didn't have that option visible. I did read that was for laptops only and not Desktops.

I also learned that Window's now gives the user the ability to do the same thing with 'Graphics Settings'. I enabled 'Hardware-accelerated GRP scheduling', rebooted, went back into Graphic's Settings, browsed to my Acrobat install, selected Acrobat.exe and choose High Power. When I again opened a 3D PDF, I found nothing had changed.

I checked for Windows Updates, everything up to date.

I was beginning to have doubts about my GPU, even though nothing was noticeably different. I decided to phone the company who built the PC and spoke with one of their Technicians. I explained the issue and was really looking for someone else with a high spec machine to see if they could see DirectX in Acrobat Reader settings. The guy I spoke with had a much newer card than mine (Nvidia GeForce 3070Ti) and he confirmed he could not see DirectX either, only Software Rendering.

The Solution:
I was essentially at a loss with no other options. The problem with 3D PDF's is, (to my knowledge) aside from Adobe Acrobat and Acrobat Reader, no other PDF software can open 3D PDF's and display them as intended. I decided to uninstall, and considered looking for an older version to install, from a time when I could view them without issue. However, I tried something different.

On the Adobe Reader download page (https://get.adobe.com/uk/reader/), there is link I noticed 'Do you have a different language or operating System' so I pressed that. On the next page I selected Windows 10 for the OS, English(UK) for language and for version, I found this:

Noticing the 32-bit version, I downloaded and ran the installer. When installed, opened up Acrobat Reader and found that my Preferred Render now contained Software Rendering AND DirectX 9! After choosing DirectX 9, I opened up the same 3D PDF and was relieved to see that everything was back to normal.

I do not know what is wrong with the 64-bit version but if you create or use 3D PDF's, use the 32-bit version of Acrobat Reader and do not install from Windows Store which installs the 64-bit version.

Here are a couple of Screenshots showing the difference between Software Rendering and DirectX 9

Software Rendering:


DirectX 9:

Hopefully this is of some use to others who may have also been suffering the same issue.

Parents Reply Children
No Data