JMDL

What is the highest version of java supported by Microstation? I am using Microstation V8 8.05.02.35, when I run code like this

System.out.println(System.getProperty("java.version"));

Reply is "1.3"

Also, where can I get the latest documentation for JMDL api?

Parents
  • Hi,

    if I remember correctly, JMDL was removed in MicroStation V8, so the last MicroStation that provides Java API was MicroStation/J (7.x).

    From API and application development perspective, MicroStation V8 brought MicroStation VBA and newer versions also have brought .NET and MicroStationAPI (native C++) also.

    Do you have any specific reason why you would like to use Java in MicroStation?

    With regards,

     Jan

Reply
  • Hi,

    if I remember correctly, JMDL was removed in MicroStation V8, so the last MicroStation that provides Java API was MicroStation/J (7.x).

    From API and application development perspective, MicroStation V8 brought MicroStation VBA and newer versions also have brought .NET and MicroStationAPI (native C++) also.

    Do you have any specific reason why you would like to use Java in MicroStation?

    With regards,

     Jan

Children
No Data