Dynamic views: PDF, measuring/dimensioning

I am creating a sheet (2D) which contains 6 dynamic views (plan/section of an object - concrete structure - in axonometric view).


(this is how it looks in MicroStation)

Looking at the upperleft image in more detail:

I have set up display styles so that the "cut" is in thicker red line, filled with grey (as shown above).

Question 1:
When printing this to PDF, the grey fill disappears. Is this normal behaviour, or do I have to have a special setting?

This is how the PDF looks like. As there is no grey filling, at some places it looks like you can see inside the wall (wall in the foreground).

Question 2:
When placing the dimensions (in the Sheet model), the results are not the actual size of the measured element, but some arbitrary figure. I am using Dynamic Views, so I would think it should read the sizes correctly.
As a result of this, I have to edit the dimensions manually - very annoying.
(I am using predefinded dimension styles in Sheet model - my workflow is that all text, dimensions, etc. on a drawing are done in the Sheet model)
Is this normal behaviour, or do I have to have a special setting?

TIA

  • Have you tried to dimension the edges with Dimension Element?

    I don't know if this would solve the dimensioning problem or not, just curious if it would work.

    Have you tried a Sheet (3D) instead of (2D)? Again, just curious as I haven't tried it.

    -Gary

  • Hi Jan,

    1. When you print to PDF does the grey fill show up in the print preview? Do you have Rasterized ticked, if not does ticking this make the grey print?

    2. Are the diemsions just random or are they the wrong sacle? If the wrong scale, are you using Annotation Scale in the sheet or when the dimensions are placed?

    Regards

    Marc

    Regards

    Marc

     

  • Gary & Marc, thanks for your input - it's good you guys see the forest, whereas I see the trees... :-) Meanwhile, I figured out a couple of things: - using Dimension Element makes no difference - haven't tried a 3D sheet - might do a test case - PDF: Rasterized does the trick - thanks Marc! (on a second note, wonder why that is...) - Annotation Scale: I am placing dimensions exclusively in the sheet - if I tick off Annotation Scale (in the Sheet), then the text of the dimension comes out too small (currently, I am doing another drawing with the same workflow - only difference now is that the "picture" is a Dynamic view of an object - furniture - with Display Style "Illustration") - the Sheet has Plans, Elevations, and Axonometric views and has a scale of 1:20. Don't want to use dimensions in the model for all sorts of reasons (references, some models displayed on the Sheet are cells, etc.) (not sure I understood your remark about Annotation Scale correctly - anyway, there is this difference in size when ticking Annotation Scale on and off) Will try a 3D sheet (I never understood the concept why you would have a 3D sheet - never saw a 3D sheet of paper... :-) ), so maybe this is the tool for my situation... Will report back. Thanks so far, Jan
  • Hi Jan,
                Regarding your second question about dimension, I guess "Reference Scale" toggle in the dimension style dialog (Dimension Style>Units>Reference Scale) is ON which sets to display the true size of the element in the reference. If it is OFF, dimension will display measured size of the element.

                    About Annotation Scale, it scales the size of the dimension to make it readable & not the dimension value.


    Thanks
    Mahendra